The information contained in this document is subject to change without notice. Ansoft makes no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. Ansoft shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

© 2005 Ansoft Corporation. All rights reserved.

Ansoft Corporation
225 West Station Square Drive
Suite 200
Pittsburgh, PA 15219
USA
Phone: 412-261-3200
Fax: 412-471-9427

HFSS and Optimetrics are registered trademarks or trademarks of Ansoft Corporation. All other trademarks are the property of their respective owners.

New editions of this manual will incorporate all material updated since the previous edition. The manual printing date, which indicates the manual’s current edition, changes when a new edition is printed. Minor corrections and updates which are incorporated at reprint do not cause the date to change. Update packages may be issued between editions and contain additional and/or replacement pages to be merged into the manual by the user. Note that pages which are rearranged due to changes on a previous page are not considered to be revised.

Edition: REV1.0
Date: 21 June 2005
Software Version: 10.0
This document discusses some basic concepts and terminology used throughout the Ansoft HFSS application. It provides an overview of the following topics:

0. Fundamentals
   - Ansoft HFSS Desktop
   - Opening a Design
   - Setting Model Type

1. Parametric Model Creation
   1.1 Boundary Conditions
   1.2 Excitations

2. Analysis Setup

3. Data Reporting

4. Solve Loop
   4.1 Mesh Operations

5. Examples - Antenna
6. Examples - Microwave
7. Examples - Filters
8. Examples - Signal Integrity
9. Examples - EMC/EMI
10. Examples - On Chip Components
What is HFSS?

HFSS is a high-performance full-wave electromagnetic (EM) field simulator for arbitrary 3D volumetric passive device modeling that takes advantage of the familiar Microsoft Windows graphical user interface. It integrates simulation, visualization, solid modeling, and automation in an easy-to-learn environment where solutions to your 3D EM problems are quickly and accurately obtained. Ansoft HFSS employs the Finite Element Method (FEM), adaptive meshing, and brilliant graphics to give you unparalleled performance and insight to all of your 3D EM problems. Ansoft HFSS can be used to calculate parameters such as S-Parameters, Resonant Frequency, and Fields. Typical uses include:

- **Package Modeling** - BGA, QFP, Flip-Chip
- **PCB Board Modeling** - Power/Ground planes, Mesh Grid Grounds, Backplanes
- **Silicon/GaAs** - Spiral Inductors, Transformers
- **EMC/EMI** - Shield Enclosures, Coupling, Near- or Far-Field Radiation
- **Antennas/Mobile Communications** - Patches, Dipoles, Horns, Conformal Cell Phone Antennas, Quadrafilar Helix, Specific Absorption Rate (SAR), Infinite Arrays, Radar Cross Section (RCS), Frequency Selective Surfaces (FSS)
- **Connectors** - Coax, SFP/XFP, Backplane, Transitions
- **Waveguide** - Filters, Resonators, Transitions, Couplers
- **Filters** - Cavity Filters, Microstrip, Dielectric

HFSS is an interactive simulation system whose basic mesh element is a tetrahedron. This allows you to solve any arbitrary 3D geometry, especially those with complex curves and shapes, in a fraction of the time it would take using other techniques.

The name HFSS stands for High Frequency Structure Simulator. Ansoft pioneered the use of the Finite Element Method (FEM) for EM simulation by developing/implementing technologies such as tangential vector finite elements, adaptive meshing, and Adaptive Lanczos-Pade Sweep (ALPS). Today, HFSS continues to lead the industry with innovations such as Modes-to-Nodes and Full-Wave Spice™.

Ansoft HFSS has evolved over a period of years with input from many users and industries. In industry, Ansoft HFSS is the tool of choice for high-productivity research, development, and virtual prototyping.
Installing the Ansoft HFSS Software

- **System Requirements**
  - Microsoft Windows XP (32/64), Windows 2000, or Windows 2003 Server. For up-to-date information, refer to the HFSS Release Notes.
  - Pentium-based computer
  - 128MB RAM minimum
  - 8MB Video Card minimum
  - Mouse or other pointing device
  - CD-ROM drive

**NOTE:** You should make backup copies of all HFSS projects created with a previous version of the software before opening them in HFSS v10

- **Installing the Ansoft HFSS Software**
  - For up-to-date information, refer to the HFSS Installation Guide

- **Starting Ansoft HFSS**
  1. Click the Microsoft [Start] button, select [Programs], and select the Ansoft, HFSS 10 program group. Click HFSS 10.
  2. Or Double click on the HFSS 10 icon on the Windows Desktop
Converting Older Files

Converting Older HFSS file to HFSS v10

Because of changes to the HFSS files with the development of HFSS v10, opening a HFSS document from an earlier release may take more time than you are used to experiencing. However, once the file has been opened and saved, subsequent opening time will return to normal.

Ansoft HFSS v10 provides a way for you to automatically convert your HFSS projects from an earlier version to the HFSS v10 format.

To access HFSS projects in an earlier version.

From HFSS v10,

1. Select the menu item **File > Open**
2. Open dialog
   
   1. Files of Type: **Ansoft Legacy EM Projects (.cls)**
   2. Browse to the existing project and select the .cls file
   3. Click the **Open** button

![Open Dialog](image)
Getting Help

If you have any questions while you are using Ansoft HFSS you can find answers in several ways:

- **Ansoft HFSS Online Help** provides assistance while you are working.
  - To get help about a specific, active dialog box, click the Help button in the dialog box or press the F1 key.
  - Select the menu item **Help > Contents** to access the online help system.
- **Tooltips** are available to provide information about tools on the toolbars or dialog boxes. When you hold the pointer over a tool for a brief time, a tooltip appears to display the name of the tool.
- As you move the pointer over a tool or click a menu item, the **Status Bar** at the bottom of the Ansoft HFSS window provides a brief description of the function of the tool or menu item.
- The Ansoft HFSS Getting Started guide provides detailed information about using HFSS to create and solve 3D EM projects.

**Ansoft Technical Support**

- To contact Ansoft technical support staff in your geographical area, please log on to the Ansoft corporate website, [www.ansoft.com](http://www.ansoft.com) and select **Contact**.
  - Your Ansoft sales engineer may also be contacted in order to obtain this information.

**Visiting the Ansoft Web Site**

- If your computer is connected to the Internet, you can visit the Ansoft Web site to learn more about the Ansoft company and products.
  - From the Ansoft Desktop
    - Select the menu item **Help > Ansoft Corporate Website** to access the Online Technical Support (OTS) system.
  - From your Internet browser
    - Visit [www.ansoft.com](http://www.ansoft.com)
Getting Help

For Technical Support

The following link will direct you to the Ansoft Support Page. The Ansoft Support Pages provide additional documentation, training, and application notes.

- Web Site: [http://www.ansoft.com/support.cfm](http://www.ansoft.com/support.cfm)
- Technical Support:
  - 9-4 EST:
    - **Pittsburgh, PA**
      - (412) 261-3200 x0 - Ask for Technical Support
    - **Burlington, MA**
      - (781) 229-8900 x0 - Ask for Technical Support
  - 9-4 PST:
    - **San Jose, CA**
      - (408) 261-9095 x0 - Ask for Technical Support
    - **Portland, OR**
      - (503) 906-7944 or (503) 906-7947
    - **El Segundo, CA**
      - (310) 426-2287 - Ask for Technical Support
WebUpdate

This new feature allows you to update any existing Ansoft software from the WebUpdate window. This feature automatically scans your system to find any Ansoft software, and then allows you to download any updates if they are available.
Ansoft Terms

The Ansoft HFSS window has several optional panels:

- A **Project Manager** which contains a design tree which lists the structure of the project.
- A **Message Manager** that allows you to view any errors or warnings that occur before you begin a simulation.
- A **Property Window** that displays and allows you to change model parameters or attributes.
- A **Progress Window** that displays solution progress.
- A **3D Modeler Window** which contains the model and model tree for the active design. For more information about the 3D Modeler Window, see chapter 1.
**Ansoft Terms**

**Project Manager**

- Project Manager Window
- Project
  - hfss_coax_training
  - HFSSModel1
    - Model
    - Boundaries
    - Excitations
  - Mesh Operations
  - Analysis
  - Optimetrics
  - Results
  - Port Field Display
  - Field Overlays
  - Radiation
  - Definitions
  - Materials

- Design
- Design Setup
- Design Results

- Design Automation
  - Parametric
  - Optimization
  - Sensitivity
  - Statistical
**Property Window**

The Property Window is a graphical user interface tool used to display and edit properties of objects. It consists of a table with columns for Name, Value, and Unit.

- **Property Table**: Contains properties such as Name, Material, Solve Inside, Orientation, Model, Display Wireframe, Color, and Transparent.
- **Property Tabs**: Allows for additional property management.
- **Property Buttons**: Provide options for further interaction and manipulation of properties.
Ansoft 3D Modeler

3D Modeler Window

3D Modeler design tree

Graphics area

Model

Context menu

Vertex

Edge

Plane

Coordinate System (CS)

Origin

Face

Model

Ansoft High Frequency Structure Simulator v10 User’s Guide
3D Modeler Design Tree

- Model
  - My_Ring
  - My_Teflon
  - Not Assigned
  - pec
  - Conductor1
    - CreateCylinder
    - SectionTo
    - Unite
    - CloneTo
    - CloneTo
    - CloneTo
  - vacuum
- Coordinate Systems
  - Global
    - RelativeCS1
    - RelativeCS2
    - RelativeCS3
- Planes
- Points
- Lists

Object View

Object Command History

Grouped by Material

Ansoft Terms
Design Windows

- In the Ansoft HFSS Desktop, each project can have multiple designs and each design is displayed in a separate window.
- You can have multiple projects and design windows open at the same time. Also, you can have multiple views of the same design visible at the same time.
- To arrange the windows, you can drag them by the title bar, and resize them by dragging a corner or border. Also, you can select one of the following menu options: Window > Cascade, Window > Tile Vertically, or Window > Tile Horizontally.
- To organize your Ansoft HFSS window, you can iconize open designs. Click the Iconize ** symbol in the upper right corner of the document border. An icon appears in the lower part of the Ansoft HFSS window. If the icon is not visible, it may be behind another open document. Resize any open documents as necessary. Select the menu item Window > Arrange Icons to arrange them at the bottom of the Ansoft HFSS window.
- Select the menu item Window > Close All to close all open design. You are prompted to Save unsaved designs.
Toolbars

The toolbar buttons are shortcuts for frequently used commands. Most of the available toolbars are displayed in this illustration of the Ansoft HFSS initial screen, but your Ansoft HFSS window probably will not be arranged this way. You can customize your toolbar display in a way that is convenient for you. Some toolbars are always displayed; other toolbars display automatically when you select a document of the related type. For example, when you select a 2D report from the project tree, the 2D report toolbar displays.

To display or hide individual toolbars:

- Right-click the Ansoft HFSS window frame.
  - A list of all the toolbars is displayed. The toolbars with a check mark beside them are visible; the toolbars without a check mark are hidden.
  - Click the toolbar name to turn its display on or off.
- To make changes to the toolbars, select the menu item Tools > Customize. See Customize and Arrange Toolbars on the next page.
**Customize and Arrange Toolbars**

To customize toolbars:

- Select the menu item **Tools > Customize**, or right-click the Ansoft HFSS window frame and click **Customize** at the bottom of the toolbar list.
- In the Customize dialog, you can do the following:
  
  **View a Description of the toolbar commands**
  
  1. Select an item from the Component pull-down list
  2. Select an item from the Category list
  3. Using the mouse click on the Buttons to display the Description
  4. Click the **Close** button when you are finished

  **Toggle the visibility of toolbars**
  
  1. From the Toolbar list, toggle the check boxes to control the visibility of the toolbars
  2. Click the **Close** button when you are finished
Ansoft HFSS Desktop

The Ansoft HFSS Desktop provides an intuitive, easy-to-use interface for developing passive RF device models. Creating designs involves the following:

1. **Parametric Model Generation** - creating the geometry, boundaries and excitations
2. **Analysis Setup** - defining solution setup and frequency sweeps
3. **Results** - creating 2D reports and field plots
4. **Solve Loop** - the solution process is fully automated

To understand how these processes co-exist, examine the illustration shown below.
Opening a Design

Opening a HFSS project

This section describes how to open a new or existing project.

Opening a New project

To open a new project:

1. In an Ansoft HFSS window, select the menu item *File > New*.
2. Select the menu *Project > Insert HFSS Design*.

Opening an Existing HFSS project

To open an existing project:

1. In an Ansoft HFSS window, select the menu *File > Open*. Use the Open dialog to select the project.
2. Click *Open* to open the project.

Opening an Existing Project from Explorer

You can open a project directly from the Microsoft Windows Explorer.

To open a project from Windows Explorer, do one of the following:

- Double-click on the name of the project in Windows Explorer.
- Right-click the name of the project in Windows Explorer and select *Open* from the shortcut menu.
Set Solution Type

This section describes how to set the Solution Type. The Solution Type defines the type of results, how the excitations are defined, and the convergence. The following Solution Types are available:

1. **Driven Modal** - calculates the modal-based S-parameters. The S-matrix solutions will be expressed in terms of the incident and reflected powers of waveguide modes.
2. **Driven Terminal** - calculates the terminal-based S-parameters of multi-conductor transmission line ports. The S-matrix solutions will be expressed in terms of terminal voltages and currents.
3. **Eigenmode** - calculate the eigenmodes, or resonances, of a structure. The Eigenmode solver finds the resonant frequencies of the structure and the fields at those resonant frequencies.

**Convergence**

- **Driven Modal** - Delta S for modal S-Parameters. This was the only convergence method available for Driven Solutions in previous versions.
- **Driven Terminal** - Delta S for the single-ended or differential nodal S-Parameters.
- **Eigenmode** - Delta F

**To set the solution type:**

1. Select the menu item **HFSS > Solution Type**
2. Solution Type Window:
   1. Choose one of the following:
      1. **Driven Modal**
      2. **Driven Terminal**
      3. **Eigenmode**
   2. Click the **OK** button
THIS PAGE INTENTIONALLY LEFT BLANK
Parametric Model Creation

The Ansoft HFSS 3D Modeler is designed for ease of use and flexibility. The power of the 3D Modeler is in its unique ability to create fully parametric designs without editing complex macros/model history.

The purpose of this chapter is to provide an overview of the 3D Modeling capabilities. By understanding the basic concepts outlined here you will be able to quickly take advantage of the full feature set offered by the 3D Parametric Modeler.

Overview of the 3D Modeler User Interface

The following picture shows the 3D Modeler window.

3D Modeler Design Tree - The 3D Modeler Design Tree is an essential part of the user interface. From here you may access the structural elements in addition to any object dependencies and attributes.

Context Menus - Context menus are a flexible way of accessing frequently used menu commands for the current context. The contents of these menus change dynamically and are available throughout the interface by clicking the right mouse button.

Graphics Area - The graphics area is used to interact with the structural elements.
Overview of the 3D Modeler User Interface (Continued)

When using the 3D Modeler interface you will also interact with two additional interfaces:

- **Property Window** - The Property Window is used to view or modify the attributes and dimensions of structural objects

![Property Window](image)

- **Status Bar/Coordinate Entry** - The Status Bar on the Ansoft HFSS Desktop Window displays the Coordinate Entry fields that can be used to define points or offsets during the creation of structural objects

```
X: 0  Y: 0  Z: -.35
```
Grid Plane

To simplify the creation of structural primitives, a grid or drawing plane is used. The drawing plane does not in any way limit the user to two dimensional coordinates but instead is used as a guide to simplify the creation of structural primitives. The drawing plane is represented by the active grid plane (The grid does not have to be visible). To demonstrate how drawing planes are used, review the following section: Creating and Viewing Simple Structures.

Active Cursor

The active cursor refers to the cursor that is available during object creation. The cursor allows you to graphically change the current position. The position is displayed on the status bar of the Ansoft HFSS Desktop Window.

```
X: 0  Y: 0  Z: -3.5
```

When objects are not being constructed, the cursor remains passive and is set for dynamic selection. See the Overview of Selecting Objects for more details.
Creating and Viewing a Simple Structure

Creating 3D structural objects is accomplished by performing the following steps:
1. Set the grid plane
2. Create the base shape of the object
3. Set the Height

Create a Box

We will investigate creating a box to demonstrate these steps. These steps assume that project and a HFSS design have already been created. Three points are required to create the box. The first two form the base rectangle and the third sets the height.

- Point 1: Defines the start point of the base rectangle
- Point 2: Defines the size of the base rectangle
- Point 3: Defines the height of the Box
Create a Box (Continued)

1. Select the menu item **3D Modeler > Grid Plane > XY**
2. Use the mouse to create the base shape
   1. Set the start point by positioning the active cursor and click the left mouse button.
   2. Position the active cursor and click the left mouse button to set the second point that forms the base rectangle.
   3. Set the Height by positioning the active cursor and clicking left mouse button.
Specifying Points

Grid

From the example, we saw that the simplest way to set a point is by clicking its position on the grid plane. To set the precision of the grid plane, select the menu item View > Grid Settings. From here you may specify the Grid Type, Style, Visibility, and Precision. By pressing the Save As Default button, you can set the default behavior for future HFSS Designs.

Coordinate Entry

Another way to specify a coordinate is to use the Coordinate Entry fields which are located on the status bar of the Ansoft HFSS Desktop. The position may be specified in Cartesian, Cylindrical, or Spherical coordinates. Once the first point is set, the Coordinate Entry will default to Relative coordinates. In Relative mode the coordinates are no longer absolute (measured from the origin of the working coordinate system), but relative to the last point entered.

Equations

The Coordinate Entry fields allow equations to be entered for position values. Examples: 2*5, 2+6+8, 2*cos(10*(pi/180)). Variables are not allowed in the Coordinate Entry Field

Note: Trig functions are in radians

<table>
<thead>
<tr>
<th>dX: 0.0000</th>
<th>dY: 0.0000</th>
<th>dZ: 0.0000</th>
<th>Relativ</th>
<th>Cartesian</th>
<th>mm</th>
</tr>
</thead>
</table>
| Relative mode
Specifying Points (Continued)

Object Properties

By default the Properties dialog will appear after you have finished sketching an object. The position and size of objects can be modified from the dialog. This method allows you to create objects by clicking the estimated values using the mouse and then correcting the values in the final dialog.

The Property dialog accepts equations, variables, and units. See the Overview of Entering Parameters for more detail.

Every object has two types of properties

1. Command - Defines the structural primitive
2. Attributes - Defines the material, display, and solve properties
Overview of Draw

Primitives

In solid modeling, the basic element or object is often called a primitive. Examples of primitives are boxes, cylinders, rectangles, circles, etc. There are two types of primitives: 3D primitives or solids, and 2D primitives or surfaces. By placing a collection of primitives in the correct location and of the correct size we can create a represent complex structural objects.

To create complex objects, primitives can be used as “tools” to cut holes, carve away, or join. The operations that are performed with these “tools” are often referred to as Boolean operations.

2D primitives can be swept to create arbitrarily shaped solid primitives

2D Draw Objects

The following 2D Draw objects are available:
- Rectangle, Circle, Line, Point, Spline, Ellipse, Regular Polygon (v8.5 circle)

3D Draw Objects

The following 3D Draw objects are available:
- Box, Cylinder, Sphere, Torus, Helix, Bond Wire, Cone, Regular Polyhedron (v8.5 cylinder)

True Surfaces

Circles, Cylinders, Spheres, etc are represented as true surfaces. In versions prior to release 9, these primitives would be represented as faceted objects. If you wish to use the faceted primitives (Cylinders or Circles), select the Regular Polyhedron or Regular Polygon.

To control the mesh generation of true surfaces objects, see the section on Mesh Control.
Overview of Draw (Continued)

Snap Mode

As an aid for graphical selection, the modeler provides Snap options. The default is to snaps are shown here. The shape of the active cursor will dynamically change as the cursor is moved over the snap positions.

Moving

By default all active cursor movement is in three dimensions. The modeler can also be set to allow the active cursor to only move in a plane or out of plane. These are set from the menu item 3D Modeler > Movement Mode.

In addition, the movement can be limited to a specific direction (x, y, or z) by holding down the x, y, or z key. This prevents movement in the other directions.

Pressing the CTRL+Enter key sets a local reference point. This can be useful for creating geometry graphically that is based on an existing objects. This is outlined on the next page:
Moving (Continued)

Step 1: Start Point

Step 2: Hold X key and select vertex point

Step 3: CTRL+Enter Keys set a local reference

Step 4: Hold Z key and set height
Overview of Draw

Import

In 3D modeler you can import a drawing file from outside. Choose option 3D Modeler -> Import. Here is the list of import files that we support. For some of these import option you will need an add-on translator feature in your license file.

- 3D Modeler File (*.sm3)
- Ansoft 3D Geometry Files (*.sm2)
- GDSII Files (*.gds)

Import Files:

- SAT File (*.sat)
- STEP File (*.step, *.stp)
- IGES File (*.igs, *.iges)
- AutoCAD Files (*.dxf, *.dwg)
- SLD File (*.sld)
- GEO File (*.geo)
- STL File (*.stl)

Healing

- Automated healing for imported solid models
- Post-translation user controlled healing

3D Model Analysis - 3D Modeler/Analyze

- Face, Object, Area analysis based on user inputs
- List of problems (faces, edges, vertices)
- Auto Zoom In into region where problem exists
- Remove Face
- Remove Edge
- Remove Sliver
- Remove Vertices
Selecting Previously Defined Shapes

You may select an object by moving the mouse over the object in the graphics area and clicking on it. The default mode is Dynamic selection which will display the object to be selected with a unique outline color. Please note that after selecting (Clicking on the object) the object it will be displayed solid pink while all other objects are drawn transparent.

Types of Selection

- The default is to select objects. Sometimes is necessary to select faces, edges, or vertices. To change the selection mode, select the menu item Edit > Select and choose the appropriate selection mode. The shortcut keys o (Object selection) and f (face selection) are useful for quickly switching between the most common selection modes.

Multiple Select or Toggle Selection

- Multiple objects can be selected graphically by holding down the CTRL key while selecting. In addition, with the CTRL key pressed, the selection of an object can be toggled between selected or unselected.

Blocked Objects

- If the object you wish to select is located behind another object, select the object that is blocking the desired object and press the b key or right-click and select Next Behind from the context menu. You may repeat this as many times as needed to select the correct object.

Select All Visible

- You can select all visible objects by pressing the CTRL+a key or by selecting the menu item Edit > Select All Visible.

Select by Name

- To select objects by Name you can use anyone of the following:
  - Select the menu item Edit > Select > By Name
  - Select the menu item HFSS > List
    - Select the Model tab
    - Select objects from the list
  - Use the Model Tree. See the next page.
Selecting Previously Defined Shapes (Continued)

Model Tree

After an object has been created, it is automatically added to the Model Tree. All objects can be found in the Model Tree. If you open the Model folder you will find the objects sorted by Object or by Material. You can toggle between the views by toggling the menu item 3D Modeler > Group Object by Material.

As stated previously, every object has two types of properties:

Attributes

You may select an object by clicking on the corresponding item in the Model Tree.

When the object is selected the attributes will be displayed in the Property Window. Double-clicking on the object will open a properties dialog. Use the Property Window or properties dialog to modify the attributes.

Commands

From the Model Tree, the Command Properties can be selected by expanding the object folder to display the command list. Using the mouse, select the corresponding command from the tree. The properties will be displayed in the Property Window. Double-clicking on the command will open a properties dialog. Use the Property Window or properties dialog to modify the command.

When the command is selected, the object will be outlined with bold lines in the 3D Model Window. Since an object can be a combination of several primitives, the command list may contain several objects. Anyone of these commands can be selected to visualize or modify the object.
Selecting Previously Defined Shapes (Continued)

Model Tree

Geometry in the 3D modeler is also grouped according to their model definition. Objects, Sheets, Lines, and Points are all separated so that they can be easily identified in the model tree.

If a boundary condition or an excitation is defined on a sheet object, then those 2D objects will be further separated according to their assignment.
Object Attributes

An object's attributes set the following user-defined properties:

- **Name** - User-defined name. Default names start with the primitive type followed by an increasing number: Box1, Box2, etc.
- **Material** - User-defined material property. The default property is vacuum. This can be changed by using the material toolbar.
- **Solve Inside** - By default HFSS only solves for fields inside dielectrics. To force HFSS to solve inside conductors, check solve inside.
- **Orientation**
- **Model Object** - Controls if the object is included in the solve.
- **Display Wireframe** - Forces the object to always be displayed as wireframe.
- **Color** - Set object color.
- **Transparency** - Set the transparency of an object. 0-Solid, 1-Wireframe.

**Note:** Visibility is not an object property.
Materials

By clicking on the property button for the material name, the material definition window will appear. You can select from the existing database or define a custom project material.
Materials (Continued)

User Defined Project Material

To define a custom material click the Add Material button from the material definition window. The following dialog will appear. Enter the material definitions and click the OK button.
Parametric Model Creation

Changing the View
You can change the view at any time (even during shape generation) by using the following commands:

**Toolbar**
- **Rotate** - The structure will be rotated around the coordinate system
- **Pan** - The structure will be translated in the graphical area
- **Dynamic Zoom** - Moving the mouse upwards will increase the zoom factor while moving the mouse downwards will decrease the zoom factor
- **Zoom In/Out** - In this mode a rubber band rectangle will be defined by dragging the mouse. After releasing the mouse button the zoom factor will be applied.

**Context Menu**
Right click in the graphics area and select the menu item **View** and choose from the options outlined in the Toolbar section. The context menu also offers the following:
- **Fit All** - This will zoom the defined structure to a point where it fits in the drawing area
- **Fit Selection** - This fits only the selected objects into the drawing area.
- **Spin** - Drag the mouse and release the mouse button to start the object spinning. The speed of the dragging prior to releasing the mouse controls the speed of the spin.
- **Animate** - Create or display the animation of parametric geometry

**Shortcuts**
Since changing the view is a frequently used operation, some useful shortcut keys exist. Press the appropriate keys and drag the mouse with the left button pressed:
- **ALT + Drag** - Rotate
  - In addition, there are 9 pre-defined view angles that can be selected by holding the ALT key and double clicking on the locations shown on the next page.
- **Shift + Drag** - Pan
- **ALT + Shift + Drag** - Dynamic Zoom
Shortcuts - Predefined Views

These 9 pre-defined views can be seen by holding the ALT key and double clicking the left mouse button on the locations shown below.
Changing the View (Continued)

Visibility
- The visibility of objects, Boundaries, Excitations, and Field Reports can be controlled from the menu item View > Visibility

Hide Selection
- The visibility of selected objects can be set hidden by selecting the object(s) and choosing the menu View > Hide Selection > All Views.

Rendering
- To change the rendering select the menu item View > Render > Wireframe or View > Render > Smooth Shaded

Coordinate System
- To control the view of the coordinate system, select the menu item:
  - Visibility:
    - Toggle the menu item View > Coordinate System > Hide (Show)
  - Size:
    - Toggle the menu item View > Coordinate System > Small (Large)

Background Color
- To set the background color, select the menu item View > Modify Attributes > Background Color

Addition View Settings
- Additional attributes of the view such as the projection, orientation, and lighting can be set from the menu item View > Modify Attributes
Enhancements and New Features

Selection

- Select Connected Vertices
- Select Connected Faces
- Select Connected Edges
- Select Edge Chain
- Select Face Chain
- Select Uncovered Loops

Healing

- Purge History - makes an object appear as an imported entity so that healing can be performed on it
- Remove Faces
- Remove Edges
- Remove Vertices
- Align Faces
Enhancements and New Features

Visibility
- Hide selected objects in Active View
- Hide selected objects in All Views
- Show selected objects in Active View
- Show selected objects in All Views

3D User Interface Options
- When there is a selection
  - Selection is always visible
  - Set transparency of selected objects
  - Set transparency of non-selected objects
- Default Rotation About
  - Screen Center
  - Current Axis
  - Model Center

3D Modeler Options
- Visualize history of objects
Applying Structural Transformations

So far we have investigated hot to model simple shapes and how to change the view of the model. To create more complicated models or reduce the number of objects that need to be created manually we can apply various transformations.

The following examples assume that you have already selected the object(s) that you wish to apply a transformation.

You can select the transformation options from the menu item Edit > Arrange > Move - Translates the structure along a vector

Rotate - Rotates the shape around a coordinate axis by an angle

Mirror - Mirrors the shape around a specified plane

Offset - Performs a uniform scale in x, y, and z.

Duplicate >

Along Lines - Create multiple copies of an object along a vector

Around Axis - Create multiple copies of an object rotated by a fixed angle around the x, y, or z axis

Mirror - Mirrors the shape around a specified plane and creates a duplicate

Scale - Allows non-uniform scaling in the x, y, or z direction

The faces of an object can also be moved to alter the shape of an existing object. To move the faces of an object select the menu item 3D Modeler > Surfaces > Move Faces and select Along Normal or Along Vector.
Combine Objects by Using Boolean Operations

Most complex structures can be reduced to combinations of simple primitives. Even the solid primitives can be reduced to simple 2D primitives that are swept along a vector or around an axis (Box is a square that is swept along a vector to give it thickness). The solid modeler supports the following Boolean operations:

- **Unite** - combine multiple primitives
  - Unite disjoint objects
  - Separate Bodies to separate
- **Subtract** - remove part of a primitive from another
- **Split** - break primitives into multiple parts
- **Intersect** - keep only the parts of primitives that overlap
- **Sweep** - turn a 2D primitive into a solid by sweeping: Along a Vector, Around an Axis, Along a Path
- **Connect** - connect 2D primitives. Use Cover Surfaces to turn the connected object into a solid
- **Section** - generate 2D cross-sections of a 3D object

Most Boolean operations require a base primitive in which the Boolean operation is performed. Only the base object will be preserved.

The Boolean functions provide the option to Clone objects.

**Split Crossing Objects** - When a group of objects are selected, a Boolean split is performed on ANY objects that overlap.
Local Coordinate Systems

The ability to create local coordinate systems adds a great deal of flexibility to the creations of structural objects. In previous sections we have only discussed objects that are aligned to the global coordinate system. The local coordinate system simplifies the definition of objects that do not align with the global coordinate system. In addition, the object history is defined relative to a coordinate system. If the coordinate system is moved, the geometry will automatically move with it. The definition of coordinate systems are maintained in the Model Tree.

Working Coordinate System

The working coordinate system is the currently selected CS. This can be a local or global CS.

Global CS

The default fixed coordinate system

Relative CS

User defined local coordinate system.
  Offset
  Rotated
  Both

Face CS

User defined local coordinate system. It is tied to the location of the object face it was created on. If the size of the base object changes, all objects created relative to the face CS will be updated automatically.

Continued on Next Page
Local Coordinate Systems (Continued)

Face CS (Continued)

To create a face CS, select the menu item **3D Modeler > Coordinate System > Face**

1. Graphically select Face (Highlighted in model)
2. Select Origin for Face CS
3. Set X-Axis

Step 1: Select Face

Step 2: Select Origin

Step 3: Set X-Axis

New Working CS
Local Coordinate Systems (Continued)

Example of Face CS

Cone is created with Face CS

Change the size of the box and the Cone is automatically moved with the Face CS
Parametric Geometry

The parametric modeler capability allows us to define variables in replace of a fixed position or size. Once this has been defined the variable can be changed by the user or by Optimetrics. Optimetrics can then be used to perform automatic Optimization, Parametric Sweeps, Statistical, or Sensitivity Analysis.

Defining Parameters

- Select the command to parameterized
- Choose the value to change
- Enter a variable in replace of the fixed value
- Define the variable using any combination of math functions or design variables.
- The model will automatically be updated

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command</td>
<td>CreateBox</td>
<td></td>
</tr>
<tr>
<td>Coordinate System</td>
<td>Global</td>
<td></td>
</tr>
<tr>
<td>Position</td>
<td>-1, -1.6, 0</td>
<td></td>
</tr>
<tr>
<td>XSize</td>
<td>2.6</td>
<td></td>
</tr>
<tr>
<td>YSize</td>
<td>2.8</td>
<td></td>
</tr>
<tr>
<td>ZSize</td>
<td>1</td>
<td></td>
</tr>
</tbody>
</table>

Add Variable to HFSSModel1

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>my_x</td>
<td>2.8<em>cos(0.5</em>[pi]/180)+global$var_1</td>
</tr>
</tbody>
</table>

Define variable value with units: "1 mm"

- Local Variable
- Project Variable
Parametric Model Creation

Parametric Geometry (Continued)

Variables
- There are two types of variables that can be defined in the HFSS Desktop
  - **Design Properties** - Local to model. To access the local variables select the menu item **HFSS > Design Properties**
  - **Project Variables** - Global to all models in project. Start with $. To access the global or project variables, select the menu item **Project > Project Variables**

Units
- When defining variables they must contain units. The default units for variables is meters.

Equations
- The variables can contain complex equations. See the Online Help for a complete list of math functions

Equation based Curves and Surfaces
- Any curve/surface that can be described by an equation in three dimensions can be drawn.

Animation
- Right-Click in the 3D Model Window & Choose Animate to preview the parameterization
- Note: depending on the quality of your graphics card you have the option of exporting ether AVI or GIF animation files.
THIS PAGE INTENTIONALLY LEFT BLANK
Boundary Conditions

This chapter describes the basics for applying boundary conditions. Boundary conditions enable you to control the characteristics of planes, faces, or interfaces between objects. Boundary conditions are important to understand and are fundamental to solution of Maxwell’s equations.

Why they are Important

The wave equation that is solved by Ansoft HFSS is derived from the differential form of Maxwell’s Equations. For these expressions to be valid, it is assumed that the field vectors are single-valued, bounded, and have continuous distribution along with their derivatives. Along boundaries or sources, the fields are discontinuous and the derivatives have no meaning. Therefore boundary conditions define the field behavior across discontinuous boundaries.

As a user of Ansoft HFSS you should be aware of the field assumptions made by boundary conditions. Since boundary conditions force a field behavior we want to be aware of the assumptions so we can determine if they are appropriate for the simulation. Improper use of boundary conditions may lead to inconsistent results.

When used properly, boundary conditions can be successfully utilized to reduce the model complexity. In fact, Ansoft HFSS automatically uses boundary conditions to reduce the complexity of the model. Ansoft HFSS can be thought of as a virtual prototyping world for passive RF devices. Unlike the real world which is bounded by infinite space, the virtual prototyping world needs to be made finite. In order to achieve this finite space, Ansoft HFSS applies a background or outer boundary condition which is applied to the region surrounding the geometric model.

The model complexity usually is directly tied to the solution time and computer resources so it is a competitive advantage to utilize them whenever possible.
Common Boundary Conditions

There are three types of boundary conditions. The first two are largely the users responsibility to define them or ensure that they are defined correctly. The material boundary conditions are transparent to the user.

1. **Excitations**
   - Wave Ports (External)
   - Lumped Ports (Internal)

2. **Surface Approximations**
   - Symmetry Planes
   - Perfect Electric or Magnetic Surfaces
   - Radiation Surfaces
   - Background or Outer Surface

3. **Material Properties**
   - Boundary between two dielectrics
   - Finite Conductivity of a conductor
How the Background Affects a Structure

The background is the region that surrounds the geometric model and fills any space that is not occupied by an object. Any object surface that touches the background is automatically defined to be a Perfect E boundary and given the boundary name *outer*. You can think of your structure as being encased with a thin, perfect conductor.

If it is necessary, you can change a surface that is exposed to the background to have properties that are different from *outer*.

- To model losses in a surface, you can redefine the surface to be either a Finite Conductivity or Impedance boundary. A Finite Conductivity boundary can be a lossy metal, with loss as a function of frequency and defined using conductivity and relative permeability parameters. An Impedance boundary has real or complex values that by default remain constant over frequency.

- To model a surface to allow waves to radiate infinitely far into space, redefine the surface to be radiation boundary.

The background can affect how you make material assignments. For example, if you are modeling a simple air-filled rectangular waveguide, you can create a single object in the shape of the waveguide and define it to have the characteristics of air. The surface of the waveguide is automatically assumed to be a perfect conductor and given the boundary condition *outer*, or you can change it to a lossy conductor.
Boundary Condition Precedence

The order in which boundaries are assigned is important in HFSS. Latter assigned boundaries take precedence over former assigned boundaries.

For example, if one face of an object is assigned to a Perfect E boundary, and a hole which lies in the same plane as this surface is assigned a Prefect H boundary, then the Perfect H will override the Perfect E in the area of the hole, and the E field will pass through the hole. If this operation were performed in the reverse order, then the Perfect E boundary would cover the Perfect H boundary, and no field would penetrate.

Once boundaries have been assigned, they can be re-prioritized by selecting HFSS > Boundaries > Re-prioritize. The order of the boundaries can be changed by clicking on a boundary and dragging it further up or down in the list. NOTE: Ports will always take the highest precedence.
1.1 Boundary Conditions

- **Technical Definition of Boundary Conditions**
  - **Excitation** - An excitation port is a type of boundary condition that permits energy to flow into and out of a structure. See the section on Excitations.
  - **Perfect E** - Perfect E is a perfect electrical conductor, also referred to as a perfect conductor. This type of boundary forces the electric field (E-Field) perpendicular to the surface. There are also two automatic Perfect E assignments:
    - Any object surface that touches the background is automatically defined to be a Perfect E boundary and given the boundary condition name *outer*.
    - Any object that is assigned the material pec (Perfect Electric Conductor) is automatically assigned the boundary condition Perfect E to its surface and given the boundary condition name *smetal*.
  - **Perfect H** - Perfect H is a perfect magnetic conductor. Forces E-Field tangential to the surface.
    - **Natural** - for a Perfect H boundary that overlaps with a perfect E boundary, this reverts the selected area to its original material, erasing the Perfect E boundary condition. It does not affect any material assignments. It can be used, for example, to model a cut-out in a ground plane for a coax feed.
  - **Finite Conductivity** - A Finite Conductivity boundary enables you to define the surface of an object as a lossy (imperfect) conductor. It is an imperfect E boundary condition, and is analogous to the lossy metal material definition. To model a lossy surface, you provide loss in Siemens/meter and permeability parameters. Loss is calculated as a function of frequency. It is only valid for good conductors. Forces the tangential E-Field equal to $Z_s(n \times H_{tan})_t$. The surface impedance ($Z_s$) is equal to, $(1+j)/(\delta \sigma)$, where:
    - $\delta$ is the skin depth, $(2/(\omega \sigma \mu))^{0.5}$ of the conductor being modeled
    - $\sigma$ is the frequency of the excitation wave.
    - $\sigma$ is the conductivity of the conductor
    - $\mu$ is the permeability of the conductor
Boundary Conditions

Technical Definition of Boundary Conditions (Continued)

- **Impedance** - a resistive surface that calculates the field behavior and losses using analytical formulas. Forces the tangential E-Field equal to $Z_s(n \times H_{\tan})$. The surface impedance is equal to $R_s + jX_s$, where:
  - $R_s$ is the resistance in ohms/square
  - $X_s$ is the reactance in ohms/square

- **Layered Impedance** - Multiple thin layers in a structure can be modeled as an impedance surface. See the Online Help for additional information on how to use the Layered Impedance boundary.

- **Lumped RLC** - a parallel combination of lumped resistor, inductor, and/or capacitor surface. The simulation is similar to the Impedance boundary, but the software calculate the ohms/square using the user supplied $R$, $L$, $C$ values.

- **Infinite Ground Plane** - Generally, the ground plane is treated as an infinite, Perfect E, Finite Conductivity, or Impedance boundary condition. If radiation boundaries are used in a structure, the ground plane acts as a shield for far-field energy, preventing waves from propagating past the ground plane. to simulate the effect of an infinite ground plane, check the Infinite ground plane box when defining a Perfect E, Finite Conductivity, or Impedance boundary condition. NOTE: Enabling the Infinite Ground Plane approximation ONLY affects post-processed far-field radiation patterns. It will not change the current flowing on the ground plane.

- **Radiation** - Radiation boundaries, also referred to as absorbing boundaries, enable you to model a surface as electrically open: waves can then radiate out of the structure and toward the radiation boundary. The system absorbs the wave at the radiation boundary, essentially ballooning the boundary infinitely far away from the structure and into space. Radiation boundaries may also be placed relatively close to a structure and can be arbitrarily shaped. This condition eliminates the need for a spherical boundary. For structures that include radiation boundaries, calculated S-parameters include the effects of radiation loss. When a radiation boundary is included in a structure, far-field calculations are performed as part of the simulation.
Technical Definition of Boundary Conditions (Continued)

- **Symmetry** - represent perfect E or perfect H planes of symmetry. Symmetry boundaries enable you to model only part of a structure, which reduces the size or complexity of your design, thereby shortening the solution time. Symmetry boundaries, as opposed to a simple Perfect E or H plane, should be used when the plane cuts across a port. In this instance, the port has a different amount of power, voltage, and current associated with it, and thus a different impedance. To make a port with a symmetry plane look like a full-sized port, you must use the Impedance Multiplier in the boundary wizard.
  - For a single Symmetry H boundary, the Impedance Multiplier is 0.5.
  - For a single Symmetry E boundary, the Impedance Multiplier is 2.
  - Other considerations for a Symmetry boundary condition:
    - A plane of symmetry must be exposed to the background.
    - A plane of symmetry must not cut through an object drawn in the 3D Modeler window.
    - A plane of symmetry must be defined on a planar surface.
    - Only three orthogonal symmetry planes can be defined in a problem.

- **Master / Slave** - Master and slave boundaries enable you to model planes of periodicity where the E-field on one surface matches the E-field on another to within a phase difference. They force the E-field at each point on the slave boundary match the E-field to within a phase difference at each corresponding point on the master boundary. They are useful for simulating devices such as infinite arrays. Some considerations for Master/Slave boundaries:
  - They can only be assigned to planar surfaces.
  - The geometry of the surface on one boundary must match the geometry on the surface of the other boundary.
Boundary Conditions

### Arbitrary Wave Sources
- Polarized plane waves (circular, elliptical)
- Evanescent plane waves
- Gaussian beams
- Hertzian Dipole and Line Source
- Linear antenna

**Incident Gaussian Beam**

**Total Fields**
1.1 Boundary Conditions

**Frequency Selective Surfaces**

- Automated Reflection & Transmission computation
- Interpolating sweep may be applied!

---

Frequency Selective Surfaces: Theory and Design, Ben A. Munk, Fig 2.15, pg 38
Technical Overview

- Ports are a unique type of boundary condition that allow energy to flow into and out of a structure. You can assign a port to any 2D object or 3D object face. Before the full three-dimensional electromagnetic field inside a structure can be calculated, it is necessary to determine the excitation field pattern at each port. Ansoft HFSS uses an arbitrary port solver to calculate the natural field patterns or modes that can exist inside a transmission structure with the same cross section as the port. The resulting 2D field patterns serve as boundary conditions for the full three-dimensional problem.

- By default Ansoft HFSS assumes that all structures are completely encased in a conductive shield with no energy propagating through it. You apply Wave Ports to the structure to indicate the area where the energy enters and exits the conductive shield.

- As an alternative to using Wave Ports, you can apply Lumped Ports to a structure instead. Lumped Ports are useful for modeling internal ports within a structure.
1.2 Excitations

**Wave Port**

The port solver assumes that the Wave Port you define is connected to a semi-ininitely long waveguide that has the same cross-section and material properties as the port. Each Wave Port is excited individually and each mode incident on a port contains one watt of time-averaged power. Wave Ports calculate characteristic impedance, complex propagation constant, and generalized S-Parameters.

**Wave Equation**

The field pattern of a traveling wave inside a waveguide can be determined by solving Maxwell’s equations. The following equation that is solved by the 2D solver is derived directly from Maxwell’s equation.

\[
\nabla \times \left( \frac{1}{\mu_r} \nabla \times E(x, y) \right) - k_0^2 \varepsilon_r E(x, y) = 0
\]

where:

- \( E(x, y) \) is a phasor representing an oscillating electric field.
- \( k_0 \) is the free space wave number,
- \( \mu_r \) is the complex relative permeability.
- \( \varepsilon_r \) is the complex relative permittivity.

To solve this equation, the 2D solver obtains an excitation field pattern in the form of a phasor solution, \( E(x, y) \). These phasor solutions are independent of \( z \) and \( t \), only after being multiplied by \( e^{-\gamma z} \), do they become traveling waves.

Also note that the excitation field pattern computed is valid only at a single frequency. A different excitation field pattern is computed for each frequency point of interest.
# Modes

For a waveguide or transmission line with a given cross section, there is a series of basic field patterns (modes) that satisfy Maxwell’s Equations at a specific frequency. Any linear combination of these modes can exist in the waveguide.

## Mode Conversion

In some cases it is necessary to include the effects of higher-order modes because the structure acts as a mode converter. For example, if the mode 1 (dominant) field at one port is converted (as it passes through a structure) to a mode 2 field pattern at another, then it is necessary to obtain the S-parameters for the mode 2 field.

## Modes, Reflections, and Propagation

It is also possible for a 3D field solution generated by an excitation signal of one specific mode to contain reflections of higher-order modes which arise due to discontinuities in a high frequency structure. If these higher-order modes are reflected back to the excitation port or transmitted onto another port, the S-parameters associated with these modes should be calculated. If the higher-order mode decays before reaching any port—either because of attenuation due to losses or because it is a non-propagating evanescent mode—there is no need to obtain the S-parameters for that mode.

## Modes and Frequency

The field patterns associated with each mode generally vary with frequency. However, the propagation constants and impedances always vary with frequency. Therefore, when a frequency sweep has been requested, a solution is calculated for each frequency point of interest. When performing frequency sweeps, be aware that as the frequency increases, the likelihood of higher-order modes propagating also increases.
1.2 Excitations

- **Modes and S-Parameters**
  - When the Wave Ports are defined correctly, for the modes that are included in the simulation, there is a perfect matched condition at the Wave Port. Because of this, the S-Parameters for each mode and Wave Port are normalized to a frequency dependent impedance. This type of S-Parameter is referred to as Generalized S-Parameter.

  - Laboratory measurements, such as those from a vector network analyzer, or circuit simulators use a constant reference impedance (i.e. the ports are not perfectly matched at every frequency).

  - To obtain results consistent with measurements or for use with circuit simulators, the generalized s-parameters calculated by Ansoft HFSS must be renormalized to a constant characteristic impedance. See the section on **Calibrating Wave Ports** for details on how to perform the renormalization.

  - **Note**: Failure to renormalize the generalized S-Parameters may result in inconsistent results. For example, since the Wave Ports are perfectly matched at every frequency, the S-Parameters do not exhibit the interaction that actually exists between ports with a constant characteristic impedance.
1.2 Excitations

Wave Port Boundary Condition

The edge of a Wave Port can have the following boundary conditions:

- **Perfect E or Finite Conductivity** - by default the outer edge of a Wave Port is defined to have a Perfect E boundary. With this assumption, the port is defined within a waveguide. For transmission line structures that are enclosed by metal, this is not a problem. For unbalanced or non-enclosed lines, the fields in the surrounding dielectric must be included. Improper sizing of the port definition will result in erroneous results.

- **Symmetry** - the port solver understands Perfect E and Perfect H symmetry planes. The proper Wave Port impedance multiplier needs to be applied when using symmetry planes.

- **Impedance** - the port solver will recognize an impedance boundary at the edges of the ports.

- **Radiation** - the default setting for the interface between a Wave Port and a Radiation boundary is to apply a Perfect E boundary to the edge of the ports.
1.2 Excitations

Calibrating Wave Ports

Wave Ports that are added to a structure must be calibrated to ensure consistent results. This calibration is required in order to determine direction and polarity of fields and to make voltage calculations.

Solution Type: Driven Modal

For Driven Modal simulations, the Wave Ports are calibrated using Integration Lines. Each Integration Line is used to calculate the following characteristics:

**Impedance** - As an impedance line, the line serves as the path over which Ansoft HFSS integrates the E-field to obtain the voltage at a Wave Port. Ansoft HFSS uses the voltage to compute the characteristic impedance of the Wave Ports, which is needed to renormalize generalized S-matrices to specific impedances such as 50 ohms.

**Note:** If you want to be able to renormalize S-parameters or view the values of Zpv or Zvi, you must apply Integration Lines to the Wave Ports of a structure.

**Calibration** - As a calibration line, the line explicitly defines the up or positive direction at each Wave Port. At any Wave Port, the direction of the field at $\omega t = 0$ can be in at least one of two directions. At some ports, such as circular ports, there can be more than two possible directions, and you will want to use Polarize E-Field. If you do not define an Integration Line, the resulting S-parameters can be out of phase with what you expect.

**Tip** You may need to run a ports-only solution first to help determine how the Integration Lines need to be applied to a Wave Port and their direction.
To calibrate a Wave Port, that has already been defined, with an Integration Line:

1. From the Project Tree, expand Excitations and double click on the Wave Port to be calibrated.
2. Select the Modes tab.
3. From the table, select the Integration Line column for the first mode and choose New Line.
4. Enter the position and length of the line using one of the following methods:
   - Type the start and stop points of the line directly into the x, y, or z axis fields, referenced to the working coordinates. For more information on coordinates, refer to “Getting Oriented in the Drawing Space” in Chapter **, Drawing Basics and Tips.
   - Graphically pick the points in the Design Window’s graphics area. The line is displayed as a vector; the vector indicates direction. From the Integration Line column, select Swap Endpoints to reverse the direction of the line, if necessary.
5. Repeat steps 3 and 4 to define and apply lines to other modes of the current Wave Port.
6. Click the OK button when you are finished defining Integration Lines.
7. Repeat steps 1-6 to apply lines to other Wave Ports.
### About Impedance Lines

The S-matrices initially calculated by Ansoft HFSS are generalized S-matrices normalized to the impedances of each port. However, it is often desirable to compute S-matrices that are normalized to specific impedances such as 50 ohms. To convert a generalized S-matrix to a renormalized S-matrix, Ansoft HFSS first computes the characteristic impedance at each port. There are several ways to compute the characteristic impedance ($Z_{pi}$, $Z_{pv}$, $Z_{vi}$).

Ansoft HFSS will always calculate $Z_{pi}$. The impedance calculation using power and current is well defined for a Wave Port. The other two methods - $Z_{pv}$ and $Z_{vi}$ - require a line of integration to determine voltage. By defining an Integration Line for each mode, the voltage can be computed.

In general, the impedance line should be defined between two points at which the voltage differential is expected to be a maximum. If you are analyzing multiple modes, define a separate Integration Lines for each mode since the orientation of the electric field will vary.

### About Calibration Lines

When the excitation field pattern at a Wave Port is computed, the direction of the field at $\omega t=0$ is arbitrary and can point in one of at least two ways. The Integration Lines calibrate the port by defining the preferred direction or the reference orientation. Be sure to define Integration Lines for each Wave Port so that the preferred direction is the same relative to other ports having identical or similar cross-sections. In this way, the results of laboratory measurements (in which the setup is calibrated by removing the structure and connecting two ports together) can be duplicated.

Because the calibration lines only determine the phase of the excitation signal and the traveling wave, the system ignores them during the Ports-Only solution.
1.2 Excitations

Solution Type: Driven Terminal

The Modal S-matrix solution computed by Ansoft HFSS is expressed in terms of the incident and reflected powers of the waveguide modes. This description does not lend itself to problems where several different quasi-transverse electromagnetic (TEM) modes can propagate simultaneously. For structures like coupled transmission lines or connectors, which support multiple, quasi-TEM modes of propagation, it is often desirable to compute the Terminal S-Parameters.

To calibrate a Wave Port, that has already been defined, with Terminal Lines:

1. From the Project Tree, expand Excitations and double click on the Wave Port to be calibrated
2. Select the Terminals tab.
3. From the table, select the Terminal Line column for the first terminal and choose New Line.
4. Enter the position and length of the line using one of the following methods
   - Type the start and stop points of the line directly into the x, y, or z axis fields, referenced to the working coordinates. For more information on coordinates, refer to “Getting Oriented in the Drawing Space” in Chapter **, Drawing Basics and Tips.
   - Graphically pick the points in the Design Window’s graphics area. The line is displayed as a vector; the vector indicates direction. From the Terminal Line column, select Swap Endpoints to reverse the direction of the line, if necessary.
5. Repeat steps 3 and 4 to define and apply lines to other terminals of the current Wave Port.
6. Click the OK button when you are finished defining Terminal Lines
7. Repeat steps 1-6 to apply lines to other Wave Ports.
About Terminal Lines

The Terminal S-Parameters represent the linear combination of nodal voltages and currents for the Wave Port. From the nodal voltages and currents, the admittance, impedance, and pseudo-S-matrices can be determined.

By defining a Terminal Line for each conductor across a port, Ansoft HFSS will automatically convert the Modal Solution to its equivalent Terminal Solution.

In general a single terminal line is created from the reference or “ground” conductor to each port-plane conductor.

The polarity reference for the voltage is established by the arrow head(+) and the base(-) of the terminal line. If you decide to create terminal lines, they must be defined for every port and every terminal on the port.
## Considerations for Defining Wave Ports

### Wave Port Locations

It is recommended that only surfaces that are exposed to the background be defined as Wave Ports. The background is given the boundary name `outer`. Therefore a surface is exposed to the background if it touches the boundary `outer`. You can locate all regions of `outer` by selecting the menu item **HFSS, Boundary Display (Solver View)**. From the **Solver View of Boundaries**, check the Visibility for `outer`.

![Solver View of Boundaries](image)

### Interior Wave Ports

If you want to apply Wave Ports to the interior of a structure, you must create an inner void or select the surface of an interior object that is assign a perfect conductor material property. Inner voids are automatically assigned the boundary `outer`. You can create an inner void by surrounding one object entirely with another object, then subtracting the interior object.

### Ports are Planar

A port must lie in a single plane. Ports that bend are not allowed. For example, if a geometric model has a curved surface exposed to the background, that curved surface cannot be defined as a port.
Wave Ports Require a Length of Uniform Cross Section

Ansoft HFSS assumes that each port you define is connected to a semi-infinitely long waveguide that has the same cross section as the Wave Port. When solving for S-parameters, the simulator assumes that the structure is excited by the natural field patterns (modes) associated with these cross sections. The following figures illustrate cross sections. The first figure shows regions that have been defined as Wave Ports on the outer conductive surface of a structure.

In the next figure, cross sections must be added to the structure. The waveguide on the left is not modeled correctly because it does not contain a length of uniform cross section at either Wave Port. To model it correctly, add a length of uniform cross section at each Wave Port, as shown on the waveguide to the right.
The length of the uniform cross section must be long enough to allow non-propagating modes to die out. This ensures accurate simulation results. For example, if a non-propagating mode takes approximately one-eighth of a wavelength to die out, either because of losses or because it is an evanescent mode, then you should make the uniform cross section one-eighth of a wavelength. Otherwise, you must include the effects of that higher-order mode in the simulation.

Discontinuities placed close to the port may also cause non-propagating modes to reach the port. Placing the port too close to discontinuities will cause erroneous results since the boundary condition at the port will prevent the simulated solution from matching the actual solution (i.e. The system forces the field at each port to be a linear combination of the modes you request). The energy from the non-propagating modes that reach the port will affect the apparent energy in the dominate mode and produce erroneous results.

The modes attenuate as a function of $e^{-\alpha z}$, assuming the wave propagates in the z-direction. Therefore, the required distance (uniform port length) depends on the value of the modes propagation constant.

When the Wave Ports lengths are correct, for modes that are included in the simulation there is a perfect matched condition at a Wave Port, as if the waveguide extended to infinity. For modes that are not included in a simulation, a Wave Port appears as a perfect conductor.

Wave Ports and Multiple Propagating Modes

Each higher-order mode represents a different field pattern that can propagate down a waveguide. In general, all propagating modes should be included in a simulation. In most cases, you can accept the default of 1 mode, but where propagating higher-order modes are present you need to change this to include higher-order modes. If there are more propagating modes than the number specified, erroneous results will be generated. The number of modes can vary among ports.
### Propagating Modes

Propagating modes are those that have a propagation constant, $\beta$ (rad/m), that is greater than their attenuation constant, $\alpha$ (Np/meter). One way to determine which modes need to be modeled is to set up the problem with multiple modes and generate a solution with no adaptive passes. Then, inspect the complex propagation constant, $\gamma = \alpha + \beta$, associated with each mode. To inspect the complex propagation constant (Gamma) after an analysis has been performed:

1. From the **HFSS, Analysis Setup** menu, select **Matrix Data**.
2. A dialog similar to the one shown below will appear, check **Gamma** and change the display type to **Real/Imaginary**.

   ![Solution Data](image)

   Each additional mode at a port results in an additional set of S-parameters. For example, if you are analyzing two modes at each port in a three-port structure, the final result is a 6x6 S-matrix. In general, an n-port solution is the total number of excitations of all ports, the number of modes, plus the number of sources.

If you choose not to include some higher-order modes in a simulation, make sure the cross sections on the Wave Ports are long enough so that the modes die out and are not reflected back.
Wave Ports and Symmetry Planes - The Impedance Multiplier

- When a ports size is reduced because of a symmetry plane, the impedance needs to be adjusted to account for the loss of voltage and power-flow.
  - A **Perfect E Symmetry** plane must be adjusted by a factor of 2.
    - Such models have half the voltage differential and half the power flow of the full structure, resulting in impedances that are half of those for the full structure.

- A **Perfect H Symmetry** plane must be adjusted by a factor of 0.5.
  - Such models have the same voltage differential but half the power flow of the full structure, resulting in impedances that are twice those for the full structure.

- If the structure has a combination of **Perfect E** and **Perfect H Symmetry** planes, adjust accordingly.
  - For instance, you do not have to enter an impedance multiplier for a structure with both a Perfect E and Perfect H boundary since you would be multiplying by 0.5 and 2.
THIS PAGE INTENTIONALLY LEFT BLANK
Analysis Setup

This chapter provides details on Analysis in the Ansoft HFSS v.10.0 software such as:

- Add Solution Setup
  - Adapt Frequency
  - Convergence Criteria
  - Initial Mesh Options
  - Adaptive Options
  - Low-Order Basis Functions

- Setup
  - Properties
  - Add Sweep
  - Sweep - Properties and Types of Sweeps
Adaptive Meshing

The adaptive meshing constructs a mesh that conforms to the electrical performance of the device. By employing adaptive meshing, the mesh is automatically tuned to give the most accurate and efficient mesh possible. Without adaptive meshing, the responsibility of generating the correct mesh would be left to the user. This is both error prone and tedious. With Adaptive Meshing you will know the answer is right the first time.

How it Works

The adaptive meshing algorithm searches for the largest gradients in the E-field or error and sub-divides the mesh in those regions. It also targets singularities, such as the edge of a conductor, as locations to add extra elements.

The mesh growth for each adaptive pass is controlled by the Tetrahedron Refinement in Setup Solution (Advanced Tab). You should notice, that the Tet. Refinement is a percentage. This ensures that between each pass the mesh is sufficiently perturbed and guarantees that you will not receive false convergences.

After the mesh has been refined, a full solution is performed and the process is repeated until convergence.

Convergence

After each adaptive pass, HFSS compares the S-Parameters from the current mesh to the results of the previous mesh. If the answers have not changed by the user defined value or Delta S, then the solution has converged and the current or previous mesh can be used to perform a frequency sweep. If the solution has converged, then technically, the previous mesh is as good as the current mesh. In this case, Ansoft HFSS will use the previous mesh to perform frequency sweeps if they have been requested.

Delta S

The Delta S is the default criteria used to determine mesh/solution convergence. The Delta S is defined as the maximum change in the magnitude of the S-parameters between two consecutive passes:

\[
\text{Max}_{ij}[\text{mag}(S_{ij}^N - S_{ij}^{(N-1)})], \text{ where i and j cover all matrix entries and N represents the pass number}
\]

Since this is the magnitude of a vector quantity, it can vary between 0 and 2.
Adaptive Meshing (Continued)

Since the adaptive meshing is based on the E-field, choosing the proper adaptive frequency can be critical. Like anything in engineering, there are exceptions to every rule, but in general, the following tips will help you select the correct adaptive frequency.

Broadband Structures

For broadband structures, the end frequency should be used since the finer mesh should be valid at all lower frequency points.

Filters

For filters or narrow-band devices, a frequency within the pass-band or operating region should be used since in the stop-band the E-field is only present at the ports.

Fast Frequency Sweeps

For Fast Frequency Sweeps, typically use the center of the frequency band. The Fast Frequency Sweep uses the mesh/solution at the adaptive frequency point. Since the error in the Fast Frequency Sweep typically increases as you move away from this point, the center of the frequency band is usually the preferred solution frequency to extrapolate the entire band from. It is also important to center the frequency sweep around a center point that will produce an adequate mesh. This is especially true for very high Q devices such as narrow-band filters. If the center frequency is not in the filters pass-band, the bandwidth and resonant frequency will not be accurate.

Full-Wave Spice Export

For Full-Wave Spice problems, use the Knee Frequency \( F_{\text{knee}} \approx 0.5/\text{rise time} \) to adapt to convergence. Then perform 2-5 more frequency points to adapt at. The additional points should be selected between the Knee Frequency and the maximum frequency (Only needs 2-3 passes per frequency point).

Frequencies below the Knee Frequency should have the largest impact on the time-domain, therefore the Knee Frequency is used for the primary adaptive meshing. Unfortunately, the mesh needed at the higher frequencies may not be resolved enough without performing the additional adaptive mesh passes.

Due to the large bandwidths, typically you will use an Interpolating Sweep. Using multiple frequency sweeps and combining the results may also be useful.
Adaptive Meshing (Continued)

High-Speed Digital/Signal Integrity

For high-speed digital simulations you are interested in the performance over a broad frequency range. To determine the frequency bandwidth that you need to simulate over, the following guide is recommended:

- \( \text{BW} \geq 5 \times F_{\text{knee}} \), where \( F_{\text{knee}} \approx 0.5 / \text{rise}\_\text{time} \)
- In general, all of the frequencies below the \( F_{\text{knee}} \) frequency have the largest impact on the digital signal. Therefore a good high-speed digital design will have a clean, well matched response up to at least \( F_{\text{knee}} \).

High-Speed Digital (SPICE Export)

- To export to SPICE, for transient simulations, a large bandwidth is required (\( \geq 5 \times F_{\text{knee}} \)). The reason for this is that the \( F_{\text{knee}} \) is an approximation, plus you want more then 1 sample point over the rise-time.
- When exporting to SPICE, the low frequency is also important. You want to get as close to DC as possible. Every port setup and every problem is a little different with regards to how low you can solve in Ansoft HFSS. 99% of the time you can simulate to at least 100MHz. Below that is trial and error. When you export to Full-Wave SPICE, the DC component will be extrapolated from the lowest frequency in the solve. Therefore, going from 1GHz to DC is not going to give a very accurate extrapolation.
- Frequency spacing. The setup for Full-Wave Spice recommends that the minimum frequency be used as the spacing. This usually results in 1000-3000 points depending on the bandwidth of the sweep.

High-Speed Digital (Adaptive Meshing)

- Since the simulation bandwidths can be so large, determining the proper adaptive mesh frequency can be very difficult. The following technique is recommended:
  1. Adapt at the \( F_{\text{knee}} \) until convergence (Delta S 0.02 to 0.01)
  2. Pick 2-3 frequency points above \( F_{\text{knee}} \) to adapt at
     - Don’t run these to convergence, just do 3-5 passes
  3. Solve the Frequency Sweep
     - For large bandwidths, either break up the frequency sweep and/or use Interpolating Sweeps
Adaptive Meshing (Continued)

High-Speed Digital (Why this technique?)

If the frequency points below Fknee have the biggest impact on the digital response, then meshing at that frequency should produce an accurate mesh for all frequency points below it.

If you simulate most passive devices over a large enough bandwidth, they start to exhibit a low pass filter response. So the higher frequency content contributes less to the time-domain simulation in addition to being filtered out by the devices frequency response. This is why we don't worry as much about the higher frequency adaptive passes converging. To appreciate the significance of this you also have to take into account how HFSS does its adaptive meshing. It is done by finding the highest gradient of the electric field. So if the device behaves as a filter and we are adapting outside the pass band of the filter, we are focusing most of the mesh only at the ports.

Now if your device performs well beyond Fknee, there is no harm in adapting at a higher frequency until convergence. Unfortunately, for real problems (10-40Gb/s) the design challenge is to get the device to work at least up to the knee frequency.

For these large Bandwidth sweeps, use the Interpolating Sweep. This sweep is based on the discrete sweep, but it adaptively picks discrete points and curve fits. So it takes less discrete points to represent a large bandwidth. The interpolating sweep can use either a polynomial fit or a rational function. So it can help to break up the sweep. Up to the knee frequency works good for a polynomial fit and above that the rational function will work better. The interpolation sweep will always pass through the start/end frequency points so if you don't change the mesh and make sure the start and end frequency points match up for your sweeps, they combine together without a problem.
Adaptive Meshing (Continued)

High-Speed Digital (Design Flow)

Up until this point, the entire discussion of High Speed Digital was based on the assumption that you are exporting every simulation to SPICE. There are many stages in the design cycle and going to SPICE is not required for every part of the design. If you have resonance's, mismatch, coupling, etc below the Fknee, these should be addressed in the field solver prior to running SPICE simulations. Therefore, the sweep only needs to be done to 1.5-2x Fknee to investigate the performance. In addition, for engineering design purposes, you may not need to go below 1GHz.

During these early stages of design, you may also want to use the Fast Frequency Sweep since you can get S-Parameters and fields for every frequency in the Sweep. This allows you to visualize any resonance or coupling you may be seeing in the S-Parameters.

Another useful tool for package/board analysis is the EigenMode solver. In many instances, resonances caused by the power and ground plane nets are the largest contributor to designs problems. By removing everything except the power/ground nets, the Eigenmode solver can be used to quickly identify resonances.
HFSS v10 Mesh Algorithm Improvements

Fault Tolerant Meshing

HFSS v10 introduces new feature when it comes to meshing 3D geometries. It is called Fault Tolerant Meshing. By default the Classical mesh maker is still default mesh maker since it has been improved over the years. If the classical mesh maker fails Fault Tolerant mesh maker will get invoked. You will notice that mesh3D_init_FT line in your profile file whenever Fault Tolerant mesher gets invoked. By default if the classical mesh maker was used the profile file will contain only mesh3D_init line.

Model Resolution length (MRL)

The model resolution length can be thought as a post initial mesh feature. It is a feature that could not be supported in the classical mesh maker. So if the user set the MRL, only the Fault Tolerant mesher will be used. Model resolution length enables model convergence. In the previous versions of HFSS the number of tetrahedrons as a basic mesh element could get too large so the solver would run out of memory. With the MRL we are able to reduce the number of tetrahedrons using a less memory resources while keeping the same accuracy as before.

MRL Default values

The model resolution length is the length to which mesh will resolve the model. The default values are 100 times the absolute resolution length (ResAbs) used by ACIS. ACIS uses 1.0 e-6 user units as the default ResAbs. Recommended values are of on the order of 0.1 to 0.05 of your wavelength. You can simply start with values from 0.1 and then try 0.01 and 0.001 and see if they improve the mesh sizes. If the user specifies the length that the mesh grossly misinterprets the model or changes the contacts between the objects HFSS will detect this and report this as an error ("MRL too large or object_name lost all surface triangles")
## Setting Convergence

It is very common to request too much accuracy when defining the Delta S. Remember! The manufacturing process, the laboratory equipment, and the measurement process all have inherent errors associated with them. Asking HFSS to provide a level of accuracy that is orders of magnitudes greater than what you can obtain in the real-world does not buy you anything other than extra simulation time. Instead, use the Convergence Monitoring and good engineering judgment to determine when to terminate the adaptive meshing process and how to set the Delta S. In general a Delta S of 0.02 (2%), which is the default, or as low as 0.01 (1%), is sufficient.

## Solution Convergence - S-Matrix vs. Fields

The convergence criteria is based on the S-Matrix. Typically, the S-Matrix converges prior to field quantities. That is to say if you are looking for the absolute field value within the problem region, chances are you will need to solve several more adaptive passes in order to see the same convergence that was obtained for the S-Matrix. This will also depend on the field quantity you are solving for. Ansoft HFSS solves for the E-field directly. From the E-field it calculates the H-field and from the H-field it calculates current. Therefore, the field quantities will also converge with varying mesh densities.
Adding a Solution Setup

To perform an Analysis in Ansoft HFSS, a Solution Setup must be added. To do this, right-click on Analysis in the Ansoft HFSS model tree. By default, the General Tab will be displayed. The Solution Frequency and the Convergence Criteria are set here.

Enabling/Disabling a Solution Setup

When adding a new solution setup, by default, it will be enabled. To disable any setups, right-click on the setup and remove the check mark next to Enable by left clicking once. Once a solution is disabled, it will be grayed out in the project tree. To enable a disabled project, right-click on the disabled setup and place a check mark next to Enable by left clicking once.
Adding a Solution Setup (Continued)

General Tab

Solution Frequency - This frequency point is used by the adaptive mesher to automatically refine the mesh to electrical performance of the device.

Solve Ports Only - The Port Solution uses an arbitrary, adaptive 2D eigenmode solver to determine the natural frequencies or modes that will be used to excite the structure. The ports only solution can be used to calculate only the modal field patterns for the 2D cross sections defined to be ports. This is useful for determining the number of modes, modal fields, the port length, and/or proper port setup prior to running a full solution.

Adaptive Solutions

Maximum Number of Passes - This number controls the maximum number of passes the adaptive mesh routine will perform as it attempts to satisfy the convergence criteria.

Maximum Delta S Per Pass - This number defines the convergence criteria for the adaptive meshing process.
Adding a Solution Setup (Continued)

Options Tab

Initial Mesh Options

Lambda Refinement - The Initial Mesh is based only on the 3D solid model, it has no bearing on the electrical performance of the device to be simulated. The Lambda Refinement process refines the Initial Mesh until most mesh element lengths are approximately one-quarter wavelength for air and one-third wavelength for dielectrics. A wavelength is based on the Single Frequency value entered in the Solution Frequency. In almost all cases Lambda Refinement should be used.

Use Free Space Lambda - This will force the lambda refinement to target a mesh size approximately one-quarter of a wavelength for air. The material properties of objects will be ignored. This may be useful in applications that have dielectrics with very high conductivities. Brain tissue or salt water are examples of materials that will produce very high mesh counts even though the RF penetration into the material will be limited to a region very close to the surface.
Adding a Solution Setup (Continued)

Options Tab

Adaptive Options

Refinement Per Pass - The mesh growth for each adaptive pass is controlled by the Refinement Per Pass. The Refinement Per Pass is a percentage. This ensures that between each pass the mesh is sufficiently perturbed and guarantees that you will not receive false convergences.

Minimum Number of Passes - An adaptive analysis will not stop unless the minimum number of passes you specify has been completed, even if convergence criteria have been met.

Minimum Converged Passes - An adaptive analysis will not stop unless the minimum number of converged passes you specify has been completed. The convergence criteria must be met for at least this number of passes before the adaptive analysis will stop.

Use Matrix Convergence - You can specify different stopping criteria for specific entries in the S-matrix. This is done by checking the Use Matrix Convergence box. The adaptive analysis will continue until the magnitude and phase of the entries change by an amount less than the specified criteria from one pass to the next, or until the number of requested passes is completed.
Adding a Solution Setup (Continued)

Options Tab (Continued)

Use Low-Order Solution Basis - The Low Order Basis Functions reduce the default second-order basis function to a linear basis function. It is intended for simulations in which the edge to edge spacing between tetrahedron is electrically small. In this situation, the basis function, and hence the number of unknowns, can be reduced. For this assumption to be valid, the edge lengths for all tetrahedron in the model should be on the order of 1/20th of a wavelength. In versions prior to v10.0, this was set with a system environment variable called ZERO_ORDER.

Common Applications:
- On-Chip Spiral Inductors, Capacitors, Transformers, etc.
- Package Analysis - Flip-Chip, BGA, etc.
Adding a Solution Setup (Continued)

Advanced Tab

Port Adapt Options

Port Field Accuracy - Usually, the default Port Field Accuracy value is adequate. You may want improved port accuracy under the following conditions:

- You are interested primarily in the port impedances. Port impedances are computed as part of the port solution.
- You need to lower the noise floor to catch S-parameters that are expected to be in the -70 dB range.

Refining the mesh at the ports causes HFSS to refine the mesh for the entire structure as well. This occurs because it uses the port field solutions as boundary conditions when computing the full 3D solution. Therefore, specifying too small a port field accuracy can result in an unnecessarily complex finite element mesh.
Adding a Solution Setup (Continued)

Solution Setp (Continued)

Set Min/Max Triangles

The mesh for each model port will be adaptively refined until it includes the minimum number of triangles. Refinement will then continue until the port field accuracy or the maximum number of triangles is reached.

To specify the minimum and maximum number of triangles in the port mesh, uncheck the Automatically Set Min/Max Triangles option.

Enter a value for the Minimum Number of Triangles. The default value is 25 for models with lumped gap ports and 90 for models with wave ports.

Enter a value for the Maximum Number of Triangles. The default value is 400.

If you leave Automatically Set Min/Max Triangles selected, HFSS will determine the reasonable values for the minimum and maximum number of triangles based on the port’s setup.

Defaults Tab

The Defaults tab allows you to save the current settings as the defaults for future solution setups or revert the current settings to the standard setting.


**Frequency Sweeps**

Using the converged mesh or initial mesh if no adaptive passes were requested, the swept frequency response of the device can be obtained. Ansoft HFSS provides several methods for calculating the frequency response:

- **Discrete** - performs a full solution at every frequency using the current mesh. The time required is the single frequency solve times the number of frequency points. Fields can be displayed at any frequency within the sweep range if the Save Fields Box is checked.

- **Fast** - uses an Adaptive Lanczos-Pade Sweep (ALPS) based solver to extrapolate an entire bandwidth of solution information from the center frequency. Very good for high-Q devices but it cannot be used to solve for devices that pass through cut-off. Once the band has been extrapolated, a high number of frequency points can be calculated without a penalty. In addition, the Fields can be displayed at any frequency within the sweep range. The time and memory required to solve a fast frequency sweep may be much larger than the single frequency solve.

- **Interpolating** - performs solves at discrete frequency points that are fit by interpolating. Ansoft HFSS determines the frequency points to solve at based on the error in the interpolation between consecutive passes. The interpolation error and maximum number of points is defined by the user in the **Edit Sweep**. As with the fast frequency sweep, the Interpolating Sweep can generate a larger number of frequency points. But you only have the field solution for the last solved frequency. The maximum solution time is the single frequency solve times the maximum number of points.

![Setup Interpolation Convergence](image)
Add Sweep

After a Solution Setup has been added you can also add a Frequency Sweep. To do this, right-click on Setup in the HFSS Model Tree. The Edit Sweep window will appear.

Sweep Type

[Diagram showing the Edit Sweep window with options for Sweep Type, Frequency Setup, and DC Extrapolation Options]
Add Sweep (Continued)

Frequency Setup

After the sweep type has been chosen, the frequencies of interest must be specified.

There are three Frequency Setup Options:
- Linear Step -- specify a linear range of values with a constant step size
- Linear Count -- specify a linear range of values and the number, or count, of points within the variable range
- Single Points -- specify a single values for the sweep definition

Saving Fields

It is possible to save the Field data for every point in the Fast Sweep and the Discrete Sweep. To save the Field information make sure that the Save Fields (All Frequencies) box is checked.

For the Interpolation Sweep, only the Field data for the last solved frequency will be available for post-processing.
Add Sweep (Continued)

DC Extrapolation Options

When exporting Spice subcircuits it is necessary to include the DC point. Since Ansoft HFSS does not solve down to DC we can use DC Extrapolation. The DC Extrapolation option is available in the Discrete and Interpolating Sweeps.

Time Domain Calculation

Ansoft HFSS can calculate the maximum frequency required to obtain an accurate time domain result. HFSS uses the following equation:

Max. Freq. = \((0.5/\text{Signal Rise Time}) \times \text{Time Steps Per Rise Time}\)
Frequency Sweeps (Continued)

Adding Points to a Fast or Interpolating Sweep

After the Fast or Interpolating sweeps have completed, additional frequency points can be added by changing the number of points in Edit Sweep. Clicking on Analyze will not resolve the entire frequency sweep, it will just calculate the additional frequency points.

Adding Solutions to Interpolating Sweeps

If the interpolating sweep does not converge with the requested passes or you wish to change the target convergence, the values can be changed and resolved. The interpolating sweep will recalculate the two end frequencies but after that it will use the previously calculated points and continue trying to reach the target convergence.

Ports Only and Frequency Sweeps

A discrete or interpolating frequency sweep can be used with the Ports Only solution.

Fast Frequency Sweep Ports Solve

The Fast Frequency sweep can not be used on ports that pass through cut-off. You may also experience problems if the sweep frequency approaches cut-off.

Combining Multiple Frequency Sweeps

For very large bandwidths, breaking the band into smaller frequency sweeps can improve the results. Since the Fast Frequency Sweep is extrapolated from the center frequency different error curves at the end frequencies will prevent the sweeps from aligning. The interpolating sweep will not have this problem since the solution always passes through the end frequencies (Assuming the same mesh is used).
Enhancements and New Features

Mesh Re-use

Copy geometric equivalent meshes - For optimetrics analysis setups you can request HFSS to copy a mesh that was calculated for one sweep variation for reuse on a geometrically-equivalent sweep variation.

Initial Mesh Options

Use mesh from current design - enables the use of a mesh from a previous setup.

Use mesh from other project - enables the use of a mesh from another model that has the same geometry.
Enhancements and New Features

- Matrix Convergence Options - allows the ability to define other convergence criteria
- Output Variable Convergence - Allows the creation of an output variable to be used for the convergence criteria. In order to use this, an output variable expression has to be created, then this field will become active
Overview
- Ansoft HFSS has very powerful and flexible data management and plotting capabilities. Once understood, it will make the whole solution process much easier, and will help craft the entire problem setup.

Topics of Discussion
- Data management
- 2D Plotting
- 3D Plotting
- Antenna characteristics
- Field Plotting
Data Management

With every model variation that is solved, a new data entry is stored within the project results directory. This capability has implications in that the user can perform a parametric sweep of a model without needing an Optimetrics license.

NOTE: Automatic parametric sweeps along with the other Optimetrics functions, Optimization, Sensitivity, and Statistical analyses, DO require an Optimetrics license.

The dataset validity can be checked by selecting **HFSS > Results > Browse Solutions**

By examining this dialog, the user can determine which parametric instances have been solved, and how many adaptive passes were necessary.
Data Management

Post-processing steps can also be performed in the new interface for HFSS. The common operations that were previously performed in the Matrix Data module of previous releases are:

- **Port Impedance Renormalization**
- **Port De-embedding**
- **Differential pair analyses**

Other post-processing operations that used to require the Matrix Data module that are now computed by default in HFSS version 9.0 are the **Y- and Z-matrices**. Also, given that the Solution Type defined early on in the process, negate the necessity of computing Terminal S-parameters from Modal S-parameters.

**Port Impedance Renormalization**

Within the new interface, many calculations are made automatically without user intervention. The wave port renormalization impedances are specified with the port wizard. By simply editing the properties of a port once a solution is completed, the port can be re-normalized.

**Port De-embedding**

This same dialog can be used to change the distance that a port will be de-embedded. The user can go back and edit this value as many times as necessary. Each time the OK button is pressed, the data, and also the plots if they exist, will be updated with the newly de-embedded data.

Positive values of de-embedding will move the reference plane into the model.
Data Management

**Differential pair analyses**

- For multiple terminals per port, differential pairs can be created to look at differential S-parameters instead of single-ended S-parameters. This can be useful for investigating the possible conversion between differential and common mode within a given structure.
- Within the wave port dialog, the Differential Pairs tab controls the creation of the pairs from the individual Terminals.
  1. To create a differential pair, select **New Pair**, and select the terminal lines that represent the positive and negative sides.
  2. From here, you can also change the **Differential** and **Common** mode impedance setting for each pair.
Data Management

Importing Data from other solutions

Often it is desirable to compare the results of one simulation to the results of another simulation, HFSS, circuit, or planar, or even measurements. This can be accomplished readily within the HFSS version 9.0 desktop environment.

To import solutions into HFSS Desktop:

NOTE: The minimum requirements for importing a solution are an existing model with at least one port.

1. Select **HFSS > Results > Import Solutions**, and the following dialog will appear:

   - The import options are **Import Solutions** and **Import Table**. Solutions represent S-parameter matrices in standard forms such as Touchstone and Ansoft legacy data in .szg file format. Tables are simply files containing rows and columns of data.

2. Selecting **Import Solution** will bring up the following dialog:
Data Management

3. From this window, select **Browse** to find the file to be imported. The acceptable file formats are: .sNp, .szg, .flp, .yNp, .zNp, and .tou.

4. Click **Open** to load the file.

5. Click **Import** to bring the data into the HFSS desktop.

6. Click **OK** when you are done importing solutions.

▲ All solutions will appear in the report editor under the **Sweep** category (more on this later)

▲ For Import Table, the following dialog will appear:

![Table Import Dialog](image)
Plotting Data

Data plotting can take a variety of forms. The most often used format is 2D Cartesian plotting, but we also have the capability to plot in 3D as well. Below is a list of all the quantities that can be plotted on various graphs. For definitions of each of these quantities, see the online help.

- **Eigenmode solution**
  - Eigenmode Parameters (modes)

- **Driven Modal Solution**
  - S-parameters
  - Y-parameters
  - Z-parameters
  - VSWR
  - Gamma (complex propagation constant)
  - Port Zo

- **Driven Terminal Solution**
  - S-parameters
  - Y-parameters
  - Z-parameters
  - VSWR
  - Power (at port)
  - Voltage Transform matrix (T)
  - Terminal Port Zo

- **Fields**
  - Mag_E
  - Mag_H
  - Mag_Jvol
  - Mag_Jsurf
  - ComplexMag_E
  - ComplexMag_H
  - ComplexMag_Jvol
  - ComplexMag_Jsurf
  - Local_SAR (Specific Absorption Rate)
  - Average_SAR

**NOTE**: For all Field plots, a polyline or surface must be selected before creating the Field plot.
Plotting Data

Types of Plots:
- Rectangular Plot
- Polar Plot
- 3D Rectangular Plot
- 3D Polar Plot
- Smith Chart
- Data Table
- Radiation Pattern

To Create a Plot:
1. Select HFSS > Results > Create Report
2. Select Report Type and Display Type from the selections above
3. Click OK and the Report Editor will be displayed - we will go over the options in this dialog on the next page.
Plotting Data

Creating a Plot (cont'd)

4. Context
   - **Design** - choose from available designs within a project
   - **Sweep** - choose from available sweeps including adaptive passes and imported data
   - **Domain** - defaults to Sweep, but can be switched to Time domain for plotting S-parameters with an impulse or step response.

5. **Sweep / X / Y Tabs**
   - **Sweep** - controls the source of the independent variable in the plot.
     - **NOTE:** By default, the Report editor selects **Use Current Design and Project variable values**. This will select the primary sweep of frequency usually, and the current simulated values of the project variables.
     - To display a plot with multiple traces for different variable values, change this setting to **Sweep Design and Project variable values**. You can then change the primary sweep from frequency to a variable if desired. This is useful for looking at S21 versus stub length, for example. Simply select the value in the **Name** column next to **primary sweep**, and change the value to whatever you desire.
     - You can also uncheck the **All Points** block to select which values of a variable are to be plotted.

   - **X** - controls any functional operator on the independent variable
   - **Y** - select the value to be plotted and any operator

6. Select **Add Trace** for as many values as you would like to plot

7. Select **Done** when finished

An example of a multi-trace plot of the sweep tab shown on the previous page is shown next.
Plotting Data

16 Jun 2003
Ansoft Corporation
XY Plot 5
HFSSModel1

0.00
-25.00
-50.00
-75.00
-100.00
-125.00

Y1
Y1
Y1
Y1
Y1

dB(Sl(p1,p2))
dB(Sl(p1,p2))
dB(Sl(p1,p2))
dB(Sl(p1,p2))
dB(Sl(p1,p2))

L=4.536637807e0
L=4.7774221101
L=4.8747158224
L=4.9627593257
L=5.030837807e0
L=5.0634950482

Freq [GHz]
Plotting Data

3D Plots - simply add a third dimension such that instead of plotting a family of curves, you can plot a 3D surface that represents your data changing with two independent variables. Below is a 3D plot of the previous family of curves.
Ansoft HFSS Data Plotting

**Plotting Data**

**Output Variables**

- In addition to being able to plot the built-in solved quantities, you can also create your own by using output variables.
- Clicking on the Output Variables button in the Traces dialog shown before, brings up the following dialog:

![Output Variables Dialog]

### To create an output variable:

- Type a name into the **Name** box
- Create an equation in the **Expression** box
- Click **Add**

In the example shown above, we have created an output variable that makes an approximation for Inductance of a spiral inductor. We could also have created an equation to calculate Q as well.

**NOTE:** These output variables can also be used for optimization.
Data Plotting - Special Case - Antenna Parameters

Since antenna parameters require a special computation setup to determine the region over which the fields are to be computed, displaying antenna parameters is a two step process.

Create an Infinite Sphere setup:
1. Select **HFSS > Radiation > Insert Far Field Setup > Infinite Sphere**

![Far Field Radiation Sphere Setup](image)

2. Enter the values and steps for **Theta** and **Phi**
3. You can also change the coordinate system to calculate based upon a shifted or rotated coordinate system. Select the **Coordinate System** tab, and switch to the new CS.
4. You can also change the Radiation Surface over which the far fields are computed by simply switching to the **Radiation Surface** tab, and select a new surface from any that were previously defined.
5. Click **OK**
Data Plotting - Antenna Parameters

Creating a 2D plot:
1. Select **HFSS > Results > Create Report**
2. Select **Far Field** from the **Report Type** pulldown
3. Select **Radiation Pattern** from the **Display Type** pulldown
4. Select the quantity to be plotted from the **Traces** dialog
   - **Note:** If multiple Infinite Sphere setups exist, make sure you select the appropriate one
5. Select **Add Trace** and **Done**
   - For a definition of the available antenna parameters, see the online help

Below is an example of the 2D slices of a patch antenna for LHCP and RHCP directivity.
Data Plotting - Antenna Parameters

Creating a 3D Plot:

Follow the procedures above for the 3D plot, except change the Phi and Theta quantities to match the far field calculation. Also choose an antenna quantity to plot.

Below is an example of a 3D plot for a patch antenna:
Data Plotting - Antenna Parameters

Special Case - Antenna Arrays

When using master and slave boundary condition pairs to emulate an antenna array, you might want to apply an array factor to the computation of the antenna patterns. This can easily be done in Ansoft HFSS.

To create an Antenna Array Factor calculation:

1. Select HFSS > Radiation > Antenna Array Setup
2. Select No, Regular, or Custom Array
3. Switch to the next tab, and enter the characteristics of the array, or enter the filename that contains the element locations
4. Once you click OK, any plots or calculations that are displayed will be updated with the array factor calculation. To go back to the single element calculations, select No Array Setup
Data Plotting - Antenna Parameters

Antenna array - Shown below are field patterns of a single element and an array setup scanned to 30 degree angle.
Data Manipulation

Sometimes, the built-in calculated quantities are not adequate even given the output variable capability. Because of this, Ansoft HFSS has the flexibility built in with an arbitrary fields calculator.

You can use the Fields Calculator to manipulate field quantities to obtain any number of values. One common use is to evaluate power flow within a structure. This can be accomplished by integrating the Poynting vector over a geometric surface. This can easily be accomplished within the field calculator.

To access the fields calculator:

- Select HFSS > Fields > Calculator

For a more detailed explanation of the functions within the field calculator, visit our online technical support at http://www.ansoft.com.ots
Field Overlay Plotting

Previously mentioned was the capability to plot field quantities over a geometry within a 2D plot, but this doesn’t give us a lot of insight. One of the main benefits of HFSS is that we can visualize what is going on with the electromagnetic fields within a structure, something that cannot be measured directly.

Field plots can be applied to geometry selection within the 3D modeler, and can be modified given different stimulus amplitude, frequency, and phase. We can also visualize how a field propagates throughout the volume by animating this plot versus phase, which essentially adds a time base.

To create a 2D / 3D Field Overlay Plot:

1. Select a face of an object, an entire object, or even multiple objects.
2. Select **HFSS > Fields > Plot Fields**
3. You can then change the frequency of the stimulus or phase with the resultant dialog box:
Field Overlay Plots

- Resultant modeler window for Magic “T” model with Mag_E plotted on Global:XY plane

- Selecting the object “arm”, and plotting within the volume yields:
Field Overlay Plots

The 3D plot shown on the previous page is called an Isoval surface plot. This is not the default.

To change the field plot type:
1. Selecting: HFSS > Fields > Modify Plot Attributes
2. Switch to the Plot tab
3. Select the applicable Plot from the pulldown
4. Select the IsoValSurface radio button

You can also leave the default of cloud plot and adjust the cloud density and point size until the plot looks acceptable.
Field Overlay plots - Source Stimulus

Sometimes it might be desirable to have multiple ports excited at the same time, perhaps out of phase. This is useful for evaluating power combiners. You might even want to calculate the incident or reflected power for a plane wave source.

To change the Field Plot stimulus:

Select HFSS > Fields > Edit Sources

The following field overlay plots show what happens to the Magic “T” when we have a 90 degree phase shift at the 2 E-plane end inputs. The component doesn’t isolate one port.
Field Overlay Plot - Phase animation

The final step in field overlay plots is creating animation. This essentially shows you how a wave propagates through the structure as you vary phase (time).

To create an animated 3D field plot:
1. Select HFSS > Field > Animate
2. Typically, you can accept the defaults, but you may want to change the number of steps to limit computation time.
Mesh Overlay Plot

Another plot that can be valuable in evaluating a simulation is the mesh overlay plot. Once created, you can tell which areas of the structure may need more tetrahedra for an improved quality of mesh.

To create a Mesh overlay plot:
1. Select the face, plane, or object to plot the mesh
2. Select HFSS > Fields > Plot Mesh
Viewing in the 3D modeler

With the ability to plot field quantities and mesh within the 3D modeler, it can sometimes get crowded, and model details can be obscured by the plots. You can reduce the clutter by turning off the visibility of objects and even field plots.

To turn off the visibility of field overlay plots:
1. Select View > Visibility
2. Select the Fields Reporter tab, and check, ✅, or uncheck, ❌, the fields plot you want displayed.
Solve Loop

Unlike pre-processing, the solution process is very automated. Once the problem has been defined properly, HFSS will take over and step through several stages of the solution process. To start the solution process, right click on Analysis in the HFSS Model Tree and select Analyze.

It is important to review this section since the solution setup has a direct impact on the automated solution process. A closer look at the solution process reveals it consists of three components:

- **Initial Solution** - includes the mesh generation, ports solution, and a full solution at a single frequency
- **Adaptive Refinement Loop** - refines the mesh and performs a full solution at the Initial solution frequency until convergence
- **Frequency Sweep** - calculates the swept frequency response using a mesh generated by the Adaptive Refinement Loop

**Mesh Re-use**

- Copy geometric equivalent meshes - For optimetrics analysis setups you can request HFSS to copy a mesh that was calculated for one sweep variation for reuse on a geometrically-equivalent sweep variation.
- **Initial Mesh Options**
  - Use mesh from current design - enables the use of a mesh from a previous setup.
  - Use mesh from other project - enables the use of a mesh from another model that has the same geometry

The illustration on the following page outlines the steps performed by the solution process.
Initial Solution

- Initial Mesh
- Seeding and Lambda Refinement (Single Frequency)
- Port Solution
- Full Volumetric Solution (S-Parameters/E-Fields)

Adaptive Mesh Loop

- Refine Mesh (Gradient of E-Field at Single Frequency)
- Check Convergence (Delta S)
- Frequency Sweep

Ports Only & Frequency Sweep

No Adaptive Meshing

No

YES
**Improved Analysis Configuration**

- Configurable default execution priority
  - To set this option, go to Tools > Options > HFSS Options > Solver

- Remote Analysis
  - heterogeneous platform support

- Queuing
  - Queue Projects, Designs, Parametric Sweeps, Frequency Sweeps
  - To enable this feature, go to Tools > Options > General Options > Analysis Options > Que all Simulations
  - To view queued projects, go to Tools > Show Queued Simulations
Distributed Analysis

10X Analysis Speed-Up

- An automated client-server implementation
- Little/no overhead
- Setup easily via remote analysis capability
- For Optimetrics instances and partitioned frequency sweeps
- An optional license to augment
- 10 “dependent analyses”
**Monitoring Convergence**

You can view the Convergence of the entire solution process. Right click on **Analysis/Setup** in the HFSS model tree. The **Convergence Tab** can be used to display a table or a plot.

**Matrix Convergence Options** - allows the ability to define other convergence criteria

- All - default
- Diagonal
- Off-Diagonal
- Selected Entries
Profile

At any time during or after the solution process, you can examine the computing resources - or profile data - that were used by HFSS during the analysis. The profile data is essentially a log of the tasks performed by HFSS during the solution. The log indicates the length of time each task took and how much RAM/disk memory was required.

<table>
<thead>
<tr>
<th>Task</th>
<th>Real Time</th>
<th>CPU Time</th>
<th>Memory</th>
<th>Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>solve_part2</td>
<td>00:00:01</td>
<td>00:00:00</td>
<td>33468 K</td>
<td>2660 tetrahedra</td>
</tr>
<tr>
<td>Frequency: 7.75 GHz</td>
<td></td>
<td></td>
<td></td>
<td>Interpolation Error: 0.0419509</td>
</tr>
<tr>
<td>WavePort1_solve</td>
<td>00:00:01</td>
<td>00:00:00</td>
<td>26288 K</td>
<td>94 triangles</td>
</tr>
<tr>
<td>WavePort2_solve</td>
<td>00:00:01</td>
<td>00:00:01</td>
<td>26288 K</td>
<td>94 triangles</td>
</tr>
<tr>
<td>adapt_part1</td>
<td>00:00:02</td>
<td>00:00:02</td>
<td>41664 K</td>
<td>2660 tetrahedra</td>
</tr>
<tr>
<td>Solver CSS</td>
<td>00:00:06</td>
<td>00:00:05</td>
<td>61816 K</td>
<td>14004 matrix</td>
</tr>
<tr>
<td>Disk I/O</td>
<td>00:00:00</td>
<td>00:00:00</td>
<td>0 K</td>
<td>8487 K</td>
</tr>
<tr>
<td>solve_part2</td>
<td>00:00:01</td>
<td>00:00:00</td>
<td>33468 K</td>
<td>2660 tetrahedra</td>
</tr>
<tr>
<td>Total</td>
<td>00:02:01</td>
<td>00:01:26</td>
<td></td>
<td>Interpolating sweep converged</td>
</tr>
</tbody>
</table>

- Task -- lists the software module that performed a task during the solution process, and the type of task that was performed. For example, for the task mesh3d_adapt, Mesh3d is the software module that adaptively refined the mesh.
- Real Time -- the amount of real time required to perform the task.
- CPU Time -- the amount of CPU time required to perform the task.
- Memory -- the peak amount of memory used by your machine while performing the task. This value includes all of the applications running at the time; it is not limited to HFSS.
- Information -- general information about the solution, including the number of tetrahedra used in the mesh.
Matrix Data

After the Solution is complete the Matrix Data can be viewed by clicking on Analysis/Setup. Right click on Setup and select Matrix Data. The Solution Data window will appear.

In the Simulation pull-down list, click the solution setup and solved pass - adaptive, single frequency solution, or frequency sweep - for which you want to view matrices.

Select the type of matrix to view.

- S-matrix
- Y-matrix
- Z-matrix
- Gamma
- Zo (characteristic impedance.)

The available types depend on the solution type.
Matrix Data (cont.)

- Data can be displayed in the following formats:
  - Magnitude/ Phase
  - Real/ Imaginary
  - dB/ Phase
  - Magnitude
  - Phase
  - Real
  - Imaginary
  - dB

- The available formats depend on the matrix type being displayed.

- You can also select solved frequencies that you would like to display
  - To display the matrix entries for all solved frequencies, choose All Freqs.
  - To show the matrix entries for one solved frequency, clear All Frequencies and then select the solved frequency that you want to view.
  - For adaptive passes, only the solution frequency specified in the Solution Setup dialog box is available. For frequency sweeps, the entire frequency range is available.

- To insert or delete one or more displayed frequencies, click Edit Freqs.
  - This command is only available if the sweep type is Fast or Interpolating. If you choose to export the matrix data for the Fast or Interpolating sweep after modifying the frequencies in the Edit Frequencies dialog box, only those frequencies displayed under the Matrix Data tab will be exported.

Exporting Matrix Data

- A number of export formats are available:
  - Touchstone (*.sNp)
  - Data Table (*.tab)
  - Planar EM/HFSS v6+ (*.szg)
  - Neutral Model Format (*.nmf)
  - MATLAB (*.m)
  - Citifile (*.cit)
**Equivalent Circuit Export**

It is possible to export Full-Wave Spice, Lumped Element and Partial Fraction Expansion models from Ansoft HFSS. To do this, click on Analysis/Setup/Matrix Data/Equivalent Circuit Export.

The Equivalent Circuit Export Options window will appear.
If you have a Driven Terminal solution you can export to PSpice, HSPICE, Spectre, or Maxwell Spice. You must have a frequency sweep solution and five or more frequency points to successfully export an equivalent circuit data file.

Select Lumped Element Export (Low Bandwidth) if you want to save the data as a low-frequency circuit model using simple lumped elements (resistors, capacitors, inductors, and dependent current sources).

Select Partial Fraction Expansion for Matlab to create a *.m file.

Click Combine Sweeps if you want to combine the data from two or more frequency sweeps into one file. The end points of the sweep ranges can touch, but may not overlap.

The S-matrices are written to the data file that you specified in the equivalent circuit data format.
List

To view Model Parameters, Boundaries, Excitations, Mesh Operations and Analysis Setup right click on **Analysis** in the Ansoft HFSS model tree and select **List**.
Mesh Operations

This chapter provides details on meshing in the Ansoft HFSS v.10.0 software. It discusses the default meshing of curvature, user control thereof, and the new volume correction capabilities used in matrix solution. The following topics are discussed:

- Curved Geometry Mesh Adaptation
- Faceting Default Settings
- Volume Perturbation in FEM Solutions
- User-Defining Surface Approximations
- Application Recommendations
- Model Resolution
- Applying Mesh Operations

Examples/Benchmarks

The following examples are provided to demonstrate the topics discussed in the chapter:

- Standard Pillbox Resonator
- Hemispherical Dielectric Resonator Antenna with Cavity
- Accelerator Spoke-Cavity Application
- Circular WG Quadrature Ortho-mode Junction (OMJ)
4.1 Curve Mesh Adaptation in HFSS v10.0

HFSS v10.0 meshes handles curved surfaces differently than prior versions of HFSS. Proper understanding of the differences in curved mesh handling and the advantages of new capabilities in the HFSS v10.0 solver are essential to obtaining accurate results.

- The new graphical drawing interface encourages the use of true-curved drawing, by removing the option to assign a facet count to the construction of primitives such as circles, cylinders, spheres, and ellipses.
  - Faceted primitives are available however as polyhedrons and polyhedral solids, if still desired.

- Initial meshing is constrained by faceting decisions made by the first pass of the meshing algorithms. In prior versions of HFSS however, adaptive mesh points could be placed ‘anywhere’ on the true-surface of the affected object(s), as shown in the before and after images below. (Initial mesh left, adapted at right. Note that regular faceting was not maintained after adaptive mesh alteration.)

For HFSS v10.0, however, in order to provide more robust meshing with respect to more complex geometries, the initial faceting selections made for curved objects are respected throughout the adaptation process, so that the adapted mesh is a subdivided variation of the same meshed volume as the initial mesh. An adapted mesh from HFSS v10.0 is shown below.
Faceter Default Settings

- In order to keep initial meshes at reasonable sizes, the initial faceting default setting is to constrain the mesh surface normals to fall within 30\(^\circ\) of the true-curved surface normals.
- This means that a cylindrical surface would be ‘faceted’ into 16 segments about its circumference, as illustrated below.
- The normal for each flat segment cannot be off by more than 30 degrees from the normal for the curved true surface which that segment’s face is approximating.

![Faceted Cylindrical Surface](image)

- Although aided by the Volume Perturbation technique now used in HFSS v10.0, it is not anticipated that this default faceting will be ‘enough’ for extremely high-accuracy analysis of resonant cavity volumes, spheroids, etc.
- The faceting default does not include a stringent aspect ratio default (note long triangles on top and bottom cylindrical faces).

The default however is sufficient for most applications in which the curved geometry is not itself highly critical to the simulation result, yet where more faceting would result in an extremely large initial mesh.

- E.g. Applicable for:
  - ...meshing of transmission line models with both signal and non-signal vias present to prevent parallel-plate modes in stripline or CPW configurations
  - ...Coaxial applications, where both the inner and outer radius faceting maintains an effectively congruent distance for characteristic impedance results.
  - ...cylinders or spheres used as radiation boundaries.

- Less Applicable for:
  - ....cylindrical cavity resonances to 0.001% frequency accuracy
  - ...elliptical waveguide coupling irises
  - ...circular waveguides
Introduction of Volume Perturbation to HFSS Solutions

Despite lower faceting ‘compliance’ to the true-curved geometry as the adaptation process adds mesh points, HFSS v10.0 introduces a new solution technology that should result in a more accurate solution from far smaller mesh counts than in prior versions. This technology is referred to as Volume Perturbation or Volume Correction.

- In a faceted mesh of a cylindrical solid, small arc-section volumes are ‘lost’ to the cylinder volume and become part of the volume of the cylinder’s surroundings.
- Since the true geometry definition is known before faceting, the delta-volumes represented by each of these sliver regions is computable.
- The meshing algorithm in HFSS v10.0 can provide ‘adjustment factors’ to both the tetrahedral center-edge node locations and to the appropriate volumes of the tetrahedra on either side of the curved boundary, so that the FEM solution proceeds with the right terms even for a loosely-discretized mesh.
- The end result is higher accuracy from the same mesh, even before the benefits of adaptive mesh refinement are taken into account.

Volume Perturbation solutions are always on. No user setting is required to activate them.
4.1 Mesh Operations

User Control of Curved Mesh Faceting

Since Volume Perturbation alone is not always enough, users can control the fidelity to which the initial mesh faceting conforms to geometric curvature by assigning Mesh Operation Surface Approximations to appropriate objects and/or object faces.

Mesh Operations can be assigned from the HFSS menu, from the Design Tree, or from the geometry interface’s context-sensitive menu.

The Surface Approximation options are shown below right. Definitions follow:

- **Surface Deviation** is the maximum spacing, in drawing units, that the tetrahedral surfaces may be from the true-curved geometry’s surface.
- **Normal Deviation** is the maximum angular difference, in degrees, that a tetrahedral face’s normal can have from the surface normal for the true geometry which it is meant to represent.
- **Aspect Ratio** refers to the maximum allowed aspect ratio of all faces of all tetrahedra of the selected object or face. This setting influences mesh quality rather than actual meshed volume or surface locations.
4.1 Mesh Operations

Each Setting can be forced, left at the default, or turned off entirely.

- **Ignore** means no evaluation of this constraint will be done in generation of the initial meshing, not even to the “built-in” settings HFSS follows without surface approximation instructions.
- **Use Defaults** leaves that constraint at the built-in settings, and is selected if you do not wish to tighten this constraint but also do not wish to deactivate it.
- **Set…** is of course used to apply a user constraint value which may be tighter or looser than the built-in constraint used in the absence of specific instructions.

Setting looser constraints than the default may require also setting adjoining objects to the same looser constraint so that the default does not take precedence at interfaces.

**Usage Suggestions**

- **Do not overspecify.**
  - It is always easier to ‘add’ than subtract mesh, by running more adaptive passes or by adding supplemental mesh instructions.
  - Too stringent a setting (e.g. Normal Deviation of 1 degree) can result in poor mesh qualities due to aspect ratios, poor mesh gradients to surrounding objects, etc.

- **Use Aspect Ratio settings along with Normal or Surface Deviation settings**
  - For cylindrical type objects where curved and planar faces meet, the normal and surface deviation settings apply to the curved faces only. Setting an aspect ratio limit as well (e.g. 4:1) will force a few additional triangles on the planar faces and help preserve a cleaner overall mesh.

- **Consider using Polyhedrons or Polygons instead if using to ‘reduce’ mesh**
  - If your design has many curved objects which you want only very coarsely meshed (e.g. a whole fence of ground vias, for which 30 degree default normal deviation is unnecessary), and the geometry is not imported, consider drawing the vias as hexagonal or even square solids instead, rather than having to ‘remember’ to reduce the meshing fidelity on them all.
4.1

Mesh Operations

Model Resolution

Model resolution enables model convergence and reduce solve times. If in previous versions the tetrahedron count got too large, the solver could run out of memory. It would be trying to add meshing elements to areas of the model that are not important. Now with model resolution, we are able to crank down the mesh size in order to actually get convergence before memory becomes an issue.

Model resolution is a length based value that modifies the initial mesh. This meshing operation allows the user to specify a minimum edge length of any tetrahedron used for the mesh. By specifying a minimum edge length for a tetrahedron, the mesher will have to coarsely mesh geometric detail that may not be electrically important. This saves the solver a tremendous amount of solution time since the initial mesh is smaller, and the mesher does not have to add mesh elements to areas that are not electrically important.

When dealing with models that have very high aspect ratios due to small geometric detail, use a model resolution of 1/10 to 1/20 of the thinnest conductor to start with. Then adjust the value accordingly.

A Complex Connector

Enabled Convergence (previously unsolvable)

- one half the mesh
- two thirds the memory
- one third the time
Model Resolution Con’t

Practical Example

This is part of a complex design that benefited from model resolution. The grey outline is the reduced model. The pink lines were the original model details that were removed due to the mesh operation. The original model had an initial mesh of 184,675 tets. After model resolution, the initial mesh was 24,691 tets.
Applying Mesh Operations

If you want to refine the mesh on a face or volume but don’t want to generate a solution, do the following after defining mesh operations:

- If a current mesh has been generated, HFSS will refine it using the defined mesh operations.
- If a current mesh has not been generated, HFSS will apply the mesh operations to the initial mesh.
- If an initial mesh has not been generated, HFSS will generate it and apply the mesh operations to the initial mesh.
- If the defined mesh operations have been applied to the selected face or object, the current mesh will not be altered.
- Define a new mesh operation rather than modify an existing mesh operation. HFSS will not re-apply a modified mesh operation. Applying mesh operations without solving enables you to experiment with mesh refinement in specific problem regions without losing design solutions. You cannot undo the applied mesh operations, but you can discard them by closing the project without saving them.
Mesh Operations

- **Source:** (Canonical)
- **Description**
  - A pillbox resonator is a simple cylindrical cavity, the exact resonance of which is solved analytically as:

  \[
  f_{r}^{TE_{nm}} = \frac{c\varepsilon}{2} \sqrt{\frac{q_{nm}^2}{(\pi b)^2} + \frac{p^2}{l^2}}
  \]

  \[
  f_{r}^{TM_{nm}} = \frac{c\varepsilon}{2} \sqrt{\frac{p_{nm}^2}{(\pi b)^2} + \frac{p^2}{l^2}}
  \]

- Equations for TE and TM modes of order (n, m, p) where p is the number of half-wave variations in the cavity axis direction
- \(p_{nm}\) and \(q_{nm}\) represent the zeros of the Bessel functions or their derivatives
- \(b\) is cavity radius, and \(l\) is cavity height
- \(c\varepsilon\) is the speed of light in the enclosed volume media

- **Benchmark**
  - A pillbox project with \(b = 10\) cm and \(l = 10\) cm was constructed.
  - Volume of cavity was vacuum; wall boundaries were perfect conductors
  - Solution was requested for 3 eigenmodes, with Surface Approximations set to vary the Normal Deviation
    - \(norm\) was varied from 5 to 45 degrees by 5 degree steps
    - \(Aspect\ ratio\) was set at 5:1; Surface Deviation setting was “Ignore”
    - Solution setup was 0.25 GHz starting frequency (to assure a starting frequency did not add mesh beyond those set by the surface approximation settings
    - Solutions were continued to 0.01% delta-f (real part) or 10 passes, whichever came first
  - Tabulated results vs. theoretical computations are shown on the page following
    - Bessel zeros were computed to about 5 digits (e.g. \(p_{11} = 1.84118\))
    - Speed of light used was 299792458 m/s
4.1 Mesh Operations

Results:

<table>
<thead>
<tr>
<th>Normal Deviation (deg)</th>
<th>HFSS TM010 Result (GHz)</th>
<th>Delta vs. Theory (%)</th>
<th>HFSS TE111 Result 1 (GHz)</th>
<th>HFSS TE111 Result 2 (GHz)</th>
<th>Avg. Delta vs. Theory (%)</th>
<th>Final Tetrahedra Count</th>
<th>Final Delta-f Convergence (%)</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>1.147406</td>
<td>0.001482</td>
<td>1.7361</td>
<td>1.736118</td>
<td>0.0756005</td>
<td>3347</td>
<td>0.0067755</td>
</tr>
<tr>
<td>10</td>
<td>1.147345</td>
<td>0.006798</td>
<td>1.73307</td>
<td>1.733154</td>
<td>0.2480399</td>
<td>2670</td>
<td>0.0077428</td>
</tr>
<tr>
<td>15</td>
<td>1.147124</td>
<td>0.026058</td>
<td>1.72758</td>
<td>1.727638</td>
<td>0.5647448</td>
<td>1882</td>
<td>0.022301</td>
</tr>
<tr>
<td>20</td>
<td>1.146748</td>
<td>0.058827</td>
<td>1.7192</td>
<td>1.719607</td>
<td>1.0370537</td>
<td>1060</td>
<td>0.042848</td>
</tr>
<tr>
<td>25</td>
<td>1.146623</td>
<td>0.069721</td>
<td>1.71165</td>
<td>1.712348</td>
<td>1.4632887</td>
<td>1087</td>
<td>0.040982</td>
</tr>
<tr>
<td>30</td>
<td>1.146196</td>
<td>0.106935</td>
<td>1.69707</td>
<td>1.697355</td>
<td>2.3142622</td>
<td>1008</td>
<td>0.052023</td>
</tr>
<tr>
<td>35</td>
<td>1.145602</td>
<td>0.158703</td>
<td>1.68868</td>
<td>1.688798</td>
<td>2.8019963</td>
<td>890</td>
<td>0.12154</td>
</tr>
<tr>
<td>40</td>
<td>1.144962</td>
<td>0.214481</td>
<td>1.67654</td>
<td>1.677916</td>
<td>3.4645009</td>
<td>887</td>
<td>0.033112</td>
</tr>
<tr>
<td>45</td>
<td>1.144962</td>
<td>0.214481</td>
<td>1.67654</td>
<td>1.677916</td>
<td>3.4645009</td>
<td>887</td>
<td>0.033112</td>
</tr>
</tbody>
</table>

Observations:

- With higher-order modes, absolute error is higher in order of ascending frequency regardless of normal deviation faceting applied.
  - This is expected due to some solution dependence on ‘starting’ frequency.
  - Added adaptive elements are ‘shared’ among modes. Yet higher order modes have more ‘focused’ field peaks as compared to more fundamental modes. Therefore more rapid improvement for lower order modes are an artifact of the adaptation technique and not one volume correction can strongly influence.
  - Note that for higher-accuracy analysis of the higher frequency modes, the solution can be executed with solution settings that will find that as the lowest frequency mode.
  - Even 22.5 degree setting will result in better than 0.05% error for the fundamental mode solution.
- 40 and 45 degree cases had identical meshes and results
  - When used to ‘reduce’ mesh, other quality checks may still constrain the result to more than just the surface approximation settings requested.

Conclusions:

- For simple canonical shapes and fundamental modes, increased faceting is unnecessary unless extremely tight accuracy deviations are required.
Source:

Description:
A hemispherical dielectric resonator antenna (DRA) is fed by a coaxial cable across an annular ring slot, which couples the DRA to a hemispherical cavity beneath it. This project has a combination of spherical and planar-circle curves which should give good evidence of the utility of the volume correction approach. The source provides both author-derived analytical results and measurement results.

Benchmark:
An image of the modeled geometry is shown (below, right).
- Symmetry was used (1 plane).
- Cavity (vacuum filled) is 25mm radius; DRA is 12.5 mm radius. DRA material has $\varepsilon_r = 9.5$
- Annular ring outer radius is 5.8 mm, 1 mm width
- Feed is generated using a lumped gap source port spanning the annular ring (see detail image)
- A 30mm radius by 35mm height polyhedron (16 sides) is used for the radiation boundary.
  - Bottom ground plane is treated as ‘infinite ground’ boundary condition
- Solution requested using only default surface approximations
  - 10 adaptive passes or to delta-S of 0.01 at adaptive frequency of 3.75 GHz
  - 2.5 – 5 GHz fast sweep requested
Results:
- Plots of S11 vs. frequency and real and imaginary Z11 vs. frequency are shown.
- Results conformed almost exactly to source’s reported measured results, and were closer to measurements than source analysis.
- HFSS v8.5 solved to effectively the same result, but required about 4 times the mesh: 3324 at pass 8 (v10) vs. 13,300 tetrahedra at pass 11 (v8.5).

Conclusions:
- This provides an example of a project for which the volume perturbation is extremely well-suited, by providing the proper dielectric resonance volume.
- Past experiments with as many as 24 facets per circumference without volume perturbation demonstrated a noticeable frequency error, therefore the role of the new solution capability in this success is clear.
- Solution accuracy was excellent in absolute terms even with default settings, and greatly exceeded HFSS v8.5’s capabilities.
- A second simulation with Normal Deviation set to 15 degrees solved to the same results and excellent convergence, still beating the HFSS v8.5 mesh required.
Source:
- [http://www.jlab.org/~piller/spoke/spoke.htm](http://www.jlab.org/~piller/spoke/spoke.htm)

Description:
A Spoke cavity is used in accelerators for ion beams. This variant is a ‘low Beta’ type. The cavity consists of a cylindrical volume with spherical sections subtracted from the flat ends. The ‘spoke’ is a smaller cylinder with its axis orthogonal to the main cavity’s axis that cuts through the cavity centerline on a diameter. There is an input/output beam pipe that runs coaxial with the main cavity and exits the two concave spheroid ends. Due to symmetry these cavities are usually analyzed in 1/8 sections with PHC boundary conditions.

Benchmark:
- An image of the modeled cavity geometry from the HFSS graphical interface is shown (below, right).
  - Main cavity 21.908 cm radius by 25.4 cm height
  - Spherical subtractions have radius 64.572 cm
  - Spoke is 3.81 cm radius; beam pipe 1.359 cm radius
  - Solved for Normal Deviations from 5 to 30 degrees (as parametric sweep)
    - Solution settings 10 passes or to delta-f of 0.01% (real)
    - The beam ports were left as PHC boundaries, so port loading is *not* included in these simulation results.

Results:
- A plot of solved resonant frequency vs. the Normal Deviation surface approximation setting used is shown above left. Tabulated results are on the page following, with mesh and error statistics.
- The reference website indicates that a different solution method for the cavity obtained a resonance frequency of 338.048 MHz, yet the measurement obtained 348.578 MHz. Deltas to both are shown in the table.
4.1 Mesh Operations

Results, cont.

<table>
<thead>
<tr>
<th>Normal Deviation (deg)</th>
<th>$f_r$ (MHz)</th>
<th>Delta vs. Ref. Analysis (%)</th>
<th>Delta vs. Ref. Measurement (%)</th>
<th>Final Tetrahedra Count</th>
<th>Final Delta-f Convergence (%)</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>339.332</td>
<td>0.379827717</td>
<td>2.652490978</td>
<td>21160</td>
<td>0.0021053</td>
</tr>
<tr>
<td>10</td>
<td>341.486</td>
<td>1.017015335</td>
<td>2.034551808</td>
<td>9425</td>
<td>0.011095</td>
</tr>
<tr>
<td>15</td>
<td>344.907</td>
<td>2.029001799</td>
<td>1.053135884</td>
<td>4246</td>
<td>0.10175</td>
</tr>
<tr>
<td>20</td>
<td>347.903</td>
<td>2.915266471</td>
<td>0.19364389</td>
<td>3356</td>
<td>0.1472</td>
</tr>
<tr>
<td>25</td>
<td>347.353</td>
<td>2.752567683</td>
<td>0.351427801</td>
<td>3757</td>
<td>0.016916</td>
</tr>
<tr>
<td>30</td>
<td>352.195</td>
<td>4.184908652</td>
<td>1.037644372</td>
<td>2601</td>
<td>0.3341</td>
</tr>
</tbody>
</table>

Observations:

- Since the reference analysis and measurement do not match, neither can be taken as an absolute accuracy validator for comparison to the HFSS results.
- The measurement was of a cavity with port loading at the beam pipe(s) and a probe loop which will themselves perturb results slightly.
- The trend of resonant frequency shift with tighter normal deviation restriction is quite nearly linear.
- Tighter initial faceting results in better reported convergence for the same pass count.
- V8.5 convergence was still not at low levels after the last solved pass. Therefore it was only coincidentally near the most-refined HFSS v10 solution. Carrying the HFSS v8.5 solution to good convergence rather than a limited number of tetrahedra took more mesh than reported for HFSS v10.

Conclusions:

- None of the meshes resulted in inadequate volume filling or clearly incorrect solutions. This is a geometry type for which increased faceting merely fine-tunes the resulting convergence and final solution outputs.
Source:


Description:

This quadrature orthomode junction (OMJ) uses a tapered septum to convert a circular, coaxial, quad-ridge waveguide into four contoured ridge waveguides which have modes analogous to rectangular single-ridge waveguide. The use of tapered septums intersecting with circular cross-sections necessitates drawing in true curvature.

Benchmark:

The geometry is shown above. Dimensions are as follows:

- Outer radius 160 mm, Ridge diameter 150mm, center diameter 60mm
- Ridges subtend 45 degrees, evenly spaced at 90 degree intervals
- Septums subtend 2 degrees and extend half the length of the modeled section (400mm)
- Two small ‘perturbers’ of $\varepsilon_r = 1.001$ (in red) are inserted at the single-waveguide end to provide stabilization of the degenerate mode order

The HFSS v10 project was generated by direct translation of the v8.5 project, and solved mesh surface approximation settings.

- 900 MHz adapt, swept from 400 - 950 MHz
- 10 passes or to a Delta-S of 0.009
- 10 and 15 degree normal deviation allowance
Results

Solution results are shown below, focusing on return loss.

- Results for 15 degree normal deviation are still unstable
  - Delta-S of 0.0342; final mesh of 16,177 tetrahedra
- Results for 10 degree normal deviation are excellent
  - Delta-S of 0.00752; final mesh of 15,897 tetrahedra (shown)

Conclusions:

- Due to very narrow annular gaps at the ridge peaks, this geometry type is poorly meshed without user-guidance in the form of tighter surface approximation settings, providing an example for which such guidance is required.
- However, with 10 degree faceting the solution convergence was better and to a smaller final mesh than with 15 degree faceting. Therefore in geometric cases where surface approximations are required for a good answer, they do not necessarily imply a longer solution time.
Examples - Contents

- **Chapter 5.0 - Antenna Examples**
  - 5.1 - UHF Probe
  - 5.2 - Circular Waveguide Horn
  - 5.3 - Probe Feed Patch
  - 5.4 - Slot Coupled Patch
  - 5.5 - Specific Absorption Rate
  - 5.6 - CPW Feed Bowtie Antenna
  - 5.7 - Endfire Array

- **Chapter 6.0 - Microwave Examples**
  - 6.1 - Magic T
  - 6.2 - Coax Bend
  - 6.3 - Ring Hybrid
  - 6.4 - Coax Stub
    - Includes Optimetrics Example
  - 6.5 - Microstrip - Wave Ports
    - Includes Optimetrics Example
  - 6.6 - Dielectric Resonator

- **Chapter 7.0 - Filter Examples**
  - 7.1 - Bandpass Filter
  - 7.2 - Bandstop Filter

- **Chapter 8.0 - Signal Integrity Examples**
  - 8.1 - LVDS Differential Pair
    - Includes Optimetrics Example
    - 8.1a - LVDS Differential Pair Transient Simulation (Ansoft Designer)
  - 8.2 - Segmented Return Path
    - 8.2a - Segmented Return Path TDR (Ansoft Designer)
  - 8.3 - Non-Ideal Planes
  - 8.4 - Return Path

- **Chapter 9.0 - EMC/EMI Examples**
  - 9.1 - Heat Sink
  - 9.2 - Enclosure

- **Chapter 10.0 - On Chip Component Examples**
  - 10.1 - Spiral Inductor
Chapter 5.0 - Antenna Examples

- 5.1 - UHF Probe
- 5.2 - Circular Waveguide Horn
- 5.3 - Probe Feed Patch
- 5.4 - Slot Coupled Patch
- 5.5 - Specific Absorption Rate
- 5.6 - CPW Feed Bowtie Antenna
- 5.7 - Endfire Array
The Ultra-High Frequency (UHF) Probe

This example is intended to show you how to create, simulate, and analyze a UHF probe, using the Ansoft HFSS Design Environment.
Ansoft HFSS Design Environment

- The following features of the Ansoft HFSS Design Environment are used to create this passive device model
  - 3D Solid Modeling
    - Primitives: Cylinders, Boxes
    - Boolean Operations: Unite, Subtract
  - Boundaries/Excitations
    - Ports: Wave Ports
  - Analysis
    - Sweep: Fast Frequency

Results

- Cartesian plotting

Field Overlays:

- 3D Far Field Plots
5.1 Example - UHF Probe

Getting Started

Launching Ansoft HFSS
1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft, HFSS 10 program group. Click HFSS 10.

Setting Tool Options

To set the tool options:

Note: In order to follow the steps outlined in this example, verify that the following tool options are set:

1. Select the menu item Tools > Options > HFSS Options
2. HFSS Options Window:
   1. Click the General tab
      - Use Wizards for data entry when creating new boundaries: ✔ Checked
      - Duplicate boundaries with geometry: ✔ Checked
   2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:
   1. Click the Operation tab
      - Automatically cover closed polylines: ✔ Checked
   2. Click the Drawing tab
      - Edit property of new primitives: ✔ Checked
   3. Click the OK button
## Opening a New Project

**To open a new project:**

1. In an Ansoft HFSS window, click the ☐ On the Standard toolbar, or select the menu item **File > New**.
2. From the **Project** menu, select **Insert HFSS Design**.

![Project Window](image)

## Set Solution Type

**To set the solution type:**

1. Select the menu item **HFSS > Solution Type**
2. Solution Type Window:
   1. Choose **Driven Terminal**
   2. Click the **OK** button

![Solution Type Window](image)
5.1 Example - UHF Probe

Creating the 3D Model

Set Model Units

To set the units:
1. Select the menu item **3D Modeler > Units**
2. Set Model Units:
   1. Select Units: **in (inches)**
   2. Click the OK button

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose **Select**
2. Select Definition Window:
   1. Type **copper** in the **Search by Name** field
   2. Click the OK button
Creating Annular Rings

Creating a ring is accomplished by creating a cylinder that represents the outer radius and a cylinder that represents the inner radius. By performing a Boolean subtraction, the resulting geometry is a ring.

For this model, two sets of rings are necessary. Instead of manually creating both rings, we will create one ring, copy it, and edit the dimensions of the copy.

Create Ring 1

1. Select the menu item **Draw > Cylinder**
2. Using the coordinate entry fields, enter the cylinder position
   
   X: 0.0, Y: 0.0, Z: 0.0, Press the **Enter** key
3. Using the coordinate entry fields, enter the radius:
   
   dX: 0.31, dY: 0.0, dZ: 0.0, Press the **Enter** key
4. Using the coordinate entry fields, enter the height:
   
   dX: 0.0, dY: 0.0, dZ: 5.0, Press the **Enter** key

To set the name:

1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: **ring_inner**
3. Click the **OK** button

To fit the view:

1. Select the menu item **View > Fit All > Active View**. Or press the **CTRL+D** key
Creating Annular Rings (Continued)

Create Ring 1 (Continued)
1. Select the menu item Draw > Cylinder
2. Using the coordinate entry fields, enter the cylinder position
   - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the radius:
   - dX: 0.37, dY: 0.0, dZ: 0.0, Press the Enter key
4. Using the coordinate entry fields, enter the height:
   - dX: 0.0, dY: 0.0, dZ: 5.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: ring_1
3. Click the OK button

To select objects to be subtracted:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: ring_1, ring_inner
   2. Click the OK button

To subtract:
1. Select the menu item 3D Modeler > Boolean > Subtract
2. Subtract Window
   - Blank Parts: ring_1
   - Tool Parts: ring_inner
   - Clone tool objects before subtract: □ Unchecked
   - Click the OK button
Creating Annular Rings (Continued)

Create Ring 2

1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: ring_1
   2. Click the OK button
3. Select the menu item Edit > Copy
4. Select the menu item Edit > Paste

Change the dimensions of Ring 2

1. To change the dimensions of ring_2, expand the model tree as shown below. It should be noted that order of the editing is important. If you make the inner radius > then the outer radius, a invalid object will result and it will be removed from the model.
2. Using the mouse, double click the left mouse button on the CreateCylinder command for ring_2
3. Properties dialog
   1. Change the radius to: 0.5 in
   2. Click the OK button
4. Using the mouse, double click the left mouse button on the CreateCylinder command for ring_inner1
5. Properties dialog
   1. Change the radius to: 0.435 in
   2. Click the OK button
Create Arm_1

To create Arm_1
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   X: -0.1, Y: -0.31, Z: 5.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   dX: 0.2, dY: -4.69, dZ: -0.065, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Arm_1
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Group Conductors

To group the conductors:
1. Select the menu item Edit > Select All Visible. Or press the CTRL+A key
2. Select the menu item, 3D Modeler > Boolean > Unite
Create the Center pin

To create the center pin
1. Select the menu item Draw > Cylinder
2. Using the coordinate entry fields, enter the cylinder position
   - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the radius:
   - dX: 0.1, dY: 0.0, dZ: 0.0, Press the Enter key
4. Using the coordinate entry fields, enter the height:
   - dX: 0.0, dY: 0.0, dZ: 5.1, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: center_pin
3. Click the OK button
Create Arm_2

To create Arm_2
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: -0.1, Y: 0.0, Z: 5.1, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: 0.2, dY: 5.0, dZ: -0.065, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Arm_2
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
Create the Grounding Pin

To create the grounding pin
1. Select the menu item Draw > Cylinder
2. Using the coordinate entry fields, enter the cylinder position
   - X: 0.0, Y: 1.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the radius:
   - dX: 0.0625, dY: 0.0, dZ: 0.0, Press the Enter key
4. Using the coordinate entry fields, enter the height:
   - dX: 0.0, dY: 0.0, dZ: 5.1, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: pin
3. Click the OK button

Group Conductors

To group the conductors:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Arm_2, center_pin, pin
      - Note: Use the Ctrl + Left mouse button to select multiple objects
   2. Click the OK button
3. Select the menu item, 3D Modeler > Boolean > Unite
5.1 Example - UHF Probe

Create the Wave port

To create a circle that represents the port:
1. Select the menu item **Draw > Circle**
2. Using the coordinate entry fields, enter the center position
   - X: **0.0**, Y: **0.0**, Z: **0.0**, Press the **Enter** key
3. Using the coordinate entry fields, enter the radius of the circle:
   - dX: **0.31**, dY: **0.0**, dZ: **0.0**, Press the **Enter** key

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: **p1**
3. Click the **OK** button
Example - UHF Probe

Set Default Material

To set the default material:
- Using the 3D Modeler Materials toolbar, choose vacuum

Create Air

To create Air
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: -5.0, Y: -10.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: 10.0, dY: 20.0, dZ: 12.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Air
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Create Radiation Boundary

To create a radiation boundary
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Air
   2. Click the OK button
3. Select the menu item HFSS > Boundaries > Assign > Radiation
4. Radiation Boundary window
   1. Name: Rad1
   2. Click the OK button
Create Wave Port Excitation 1 (Continued)

To select the object p1:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: p1
   2. Click the OK button

To assign wave port excitation
1. Select the menu item HFSS > Excitations > Assign > Wave Port
2. Wave Port: General
   1. Name: p1,
   2. Click the Next button
3. Wave Port: Terminals
   1. Number of Terminals: 1,
   2. For T1, click the Undefined column and select New Line
   3. Using the coordinate entry fields, enter the vector position
      \( X: 0.31, Y: 0.0, Z: 0.0, \) Press the Enter key
   4. Using the coordinate entry fields, enter the vertex
      \( dX: -0.21, dY: 0.0, dZ: 0.0, \) Press the Enter key
   5. Click the Next button
4. Wave Port: Differential Pairs
   1. Click the Next button
5. Wave Port: Post Processing
   1. Reference Impedance: 50
6. Click the Finish button
Create Infinite Ground Plane

To create an Infinite ground
1. Select the menu item Edit > Select > Faces
2. Graphically select the face of the Air object at Z=0
3. Select the menu item HFSS > Boundaries > Assign> Finite Conductivity
4. Finite Conductivity Boundary window
   1. Name: gnd_plane
   2. Use Material: ☑ Checked
   3. Click the vacuum button
   4. Select Definition Window:
      1. Type copper in the Search by Name field
      2. Click the OK button
   5. Infinite Ground Plane: ☑ Checked
   6. Click the OK button

Create a Radiation Setup

To define the radiation setup
1. Select the menu item HFSS > Radiation > Insert Far Field Setup > Infinite Sphere
2. Far Field Radiation Sphere Setup dialog
   1. Infinite Sphere Tab
      1. Name: ff_2d
      2. Phi: (Start: 0, Stop: 90, Step Size: 90)
      3. Theta: (Start: -180, Stop: 180, Step Size: 2)
   2. Click the OK button
Analysis Setup

Creating an Analysis Setup

To create an analysis setup:
1. Select the menu item **HFSS > Analysis Setup > Add Solution Setup**
2. Solution Setup Window:
   1. Click the General tab:
      - Solution Frequency: **0.55 GHz**
      - Maximum Number of Passes: **10**
      - Maximum Delta S per Pass: **0.02**
   2. Click the **OK** button

Adding a Frequency Sweep

To add a frequency sweep:
1. Select the menu item **HFSS > Analysis Setup > Add Sweep**
   1. Select Solution Setup: **Setup1**
   2. Click the **OK** button
2. Edit Sweep Window:
   1. Sweep Type: **Fast**
   2. Frequency Setup Type: **Linear Count**
      - Start: **0.35GHz**
      - Stop: **0.75GHz**
      - Count: **401**
      - Save Fields: **☑ Checked**
   3. Click the **OK** button
**Example - UHF Probe**

- **Save Project**
  - **To save the project:**
    1. In an Ansoft HFSS window, select the menu item *File > Save As*.
    2. From the *Save As* window, type the Filename: `hfss_uhf_probe`
    3. Click the *Save* button

- **Analyze**

- **Model Validation**
  - **To validate the model:**
    1. Select the menu item *HFSS > Validation Check*
    2. Click the *Close* button
  - **Note:** To view any errors or warning messages, use the Message Manager.

- **Analyze**
  - **To start the solution process:**
    1. Select the menu item *HFSS > Analyze All*
5.1 Example - UHF Probe

Solution Data

To view the Solution Data:
1. Select the menu item HFSS > Results > Solution Data
   - To view the Profile:
     1. Click the Profile Tab.
   - To view the Convergence:
     1. Click the Convergence Tab
     Note: The default view is for convergence is Table. Select the Plot radio button to view a graphical representation of the convergence data.
   - To view the Matrix Data:
     1. Click the Matrix Data Tab
     Note: To view a real-time update of the Matrix Data, set the Simulation to Setup1, Last Adaptive
2. Click the Close button

![Solution Data Interface](image)
Create Reports

Create Terminal S-Parameter Plot - Magnitude

To create a report:
1. Select the menu item HFSS > Results > Create Report
2. Create Report Window:
   1. Report Type: Terminal S Parameters
   2. Display Type: Rectangular
   3. Click the OK button
3. Traces Window:
   1. Solution: Setup1: Sweep1
   2. Domain: Sweep
   3. Click the Y tab
      1. Category: Terminal S Parameter
      2. Quantity: St(p1,p1),
      3. Function: dB
      4. Click the Add Trace button
   4. Click the Done button
Far Field Overlays

Create Far Field Overlay

To create a 2D polar far field plot:

1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Far Fields**
   2. Display Type: **Radiation Pattern**
   3. Click the **OK** button
3. Traces Window:
   1. Solution: **Setup1: LastAdaptive**
   2. Geometry: **ff_2d**
   3. In the **Sweeps** tab, select **Phi** under the **Name** column, and on the drop list, select **Theta**. This changes the primary sweep to **Theta**.
   4. In the **Mag** tab
      1. Category: **Gain**
      2. Quantity: **GainTotal**
      3. Function: **dB**
      4. Click the **Add Trace** button
   5. Click the **Done** button
Example - Conical Horn

Dual Mode Conical Horn

This example is intended to show you how to create, simulate, and analyze a waveguide horn antenna using the Ansoft HFSS Design Environment.
Example - Conical Horn

Ansoft HFSS Design Environment

- The following features of the Ansoft HFSS Design Environment are used to create this passive device model:
  - **3D Solid Modeling**
    - Primitives: Cylinders
    - Boolean: Union, Subtract, Connect
  - **Boundaries/Excitations**
    - Excitations: Wave Ports
    - Boundaries: Radiation
  - **Results**
    - Plotting: Radiation Pattern
5.2
Example - Conical Horn

### Design Review

#### Port Size/Type

Since the port is external to the model we could use a Wave Port. The size of the port is determined by the physical dimensions of the waveguide. Because the waveguide is circular, we must Polarize the E-Field for the port definition.

#### Free Space

Since we are evaluating a radiating structure, we need to create a free space environment for the device to operate in. This can be achieved by using the Radiation Boundary condition or a Perfectly Matched Layer (PML). We will use a Radiation Boundary since the surface will be cylindrical.

The Radiation Boundary needs to be placed at least $\lambda/4$ from radiating devices. For our example we will assume that $\sim\lambda/4$ (0.6in)
Example - Conical Horn

Getting Started

Launching Ansoft HFSS
1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft, HFSS 10 program group. Click HFSS 10.

Setting Tool Options
To set the tool options:

Note: In order to follow the steps outlined in this example, verify that the following tool options are set:
1. Select the menu item Tools > Options > HFSS Options
2. HFSS Options Window:
   1. Click the General tab
      Use Wizards for data entry when creating new boundaries: ☑ Checked
      Duplicate boundaries with geometry: ☑ Checked
   2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:
   1. Click the Operation tab
      Automatically cover closed polylines: ☑ Checked
   2. Click the Drawing tab
      Edit property of new primitives: ☑ Checked
   3. Click the OK button
### Opening a New Project

To open a new project:

1. In an Ansoft HFSS window, click the [File] On the Standard toolbar, or select the menu item **File > New**.
2. From the **Project** menu, select **Insert HFSS Design**.

### Set Solution Type

To set the solution type:

1. Select the menu item **HFSS > Solution Type**
2. Solution Type Window:
   1. Choose **Driven Modal**
   2. Click the **OK** button
Example - Conical Horn

Creating the 3D Model

Set Model Units

To set the units:
1. Select the menu item **3D Modeler > Units**
2. Set Model Units:
   1. Select Units: **in**
   2. Click the **OK** button

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose **vacuum**

Create Circular Waveguide

Create waveguide
1. Select the menu item **Draw > Cylinder**
2. Using the coordinate entry fields, enter the cylinder position
   1. X: **0.0**, Y: **0.0**, Z: **0.0**  Press the **Enter** key
3. Using the coordinate entry fields, enter the radius:
   1. dX: **0.838**, dY: **0.0**, dZ: **0.0**  Press the **Enter** key
4. Using the coordinate entry fields, enter the height:
   1. dX: **0.0**, dY: **0.0**, dZ: **3.0**  Press the **Enter** key

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: **Waveguide**
3. Click the **OK** button

To fit the view:
1. Select the menu item **View > Fit All > Active View**.
   Or press the **CTRL+D** key


### Create Offset Coordinate System

**Create CS**

1. Select the menu item **3D Modeler > Coordinate System > Create > Relative CS > Offset**

2. Using the coordinate entry fields, enter the origin
   - X: 0.0, Y: 0.0, Z: 3.0
   - Press the **Enter** key

![Coordinate System Diagram](image1)

### Create Transition Region

**Create waveguide transition**

1. Select the menu item **Draw > Cone**

2. Using the coordinate entry fields, enter the center position
   - X: 0.0, Y: 0.0, Z: 0.0
   - Press the **Enter** key

3. Using the coordinate entry fields, enter the lower radius:
   - dX: 0.838, dY: 0.0, dZ: 0.0
   - Press the **Enter** key

4. Using the coordinate entry fields, enter the upper radius:
   - dX: 0.709, dY: 0.0, dZ: 0.0
   - Press the **Enter** key

5. Using the coordinate entry fields, enter the height:
   - dX: 0.0, dY: 0.0, dZ: 1.227
   - Press the **Enter** key

**To set the name:**

1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: **Taper**
3. Click the **OK** button
5.2

Example - Conical Horn

Create Offset Coordinate System

Create CS

1. Select the menu item 3D Modeler > Coordinate System > Create > Relative CS > Offset
2. Using the coordinate entry fields, enter the origin
   X: 0.0, Y: 0.0, Z: 1.227 Press the Enter key

Create the Throat

Create Throat

1. Select the menu item Draw > Cylinder
2. Using the coordinate entry fields, enter the cylinder position
   X: 0.0, Y: 0.0, Z: 0.0 Press the Enter key
3. Using the coordinate entry fields, enter the radius:
   dX: 1.547, dY: 0.0, dZ: 0.0 Press the Enter key
4. Using the coordinate entry fields, enter the height:
   dX: 0.0, dY: 0.0, dZ: 3.236 Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Throat
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
Group Object
To group the objects:
1. Select the menu item **Edit > Select All Visible.** Or press the CTRL+A key
2. Select the menu item, **3D Modeler > Boolean > Unite**

Rename group
To rename the group of objects:
1. From the **Model** tree, select the only object shown
2. Click the **Properties** button
   1. For the **Value of Name** type: Horn_Air
   2. Click the **OK** button
3. Click the **Done** button

Set Working Coordinate System
To set the working coordinate system:
1. Select the menu item **3D Modeler > Coordinate System > Set Working CS**
2. Select Coordinate System Window,
   1. From the list, select the CS: Global
   2. Click the **Select** button

Set Default Material
To set the default material:
1. Using the 3D Modeler Materials toolbar, choose **Select**
2. Select Definition Window:
   1. Type **pec** in the **Search by Name** field
   2. Click the **OK** button
Create the Horn Wall

Create horn
1. Select the menu item **Draw > Cylinder**
2. Using the coordinate entry fields, enter the cylinder position
   ▶ X: 0.0, Y: 0.0, Z: 0.0 Press the Enter key
3. Using the coordinate entry fields, enter the radius:
   ▶ dX: 1.647, dY: 0.0, dZ: 0.0 Press the Enter key
4. Using the coordinate entry fields, enter the height:
   ▶ dX: 0.0, dY: 0.0, dZ: 7.463 Press the Enter key

To set the name:
1. Select the menu item **Attribute** tab from the **Properties** window.
2. For the **Value** of **Name** type: Horn
3. Click the OK button

To fit the view:
1. Select the menu item **View > Fit All > Active View**.

Complete the Horn

To select the object
1. Select the menu item **Edit > Select All Visible**. Or press the **CTRL+A** key

To complete the horn:
1. Select the menu item **3D Modeler > Boolean > Subtract**
2. Subtract Window
   ▶ Blank Parts: Horn
   ▶ Tool Parts: Horn_Air
   ▶ Clone tool objects before subtract: □ Unchecked
   ▶ Click the OK button
Example - Conical Horn

- **Set Default Material**
  - To set the default material:
    - Using the 3D Modeler Materials toolbar, choose *vacuum*.

- **Create Air**
  - Create Air
    1. Select the menu item *Draw > Cylinder*.
    2. Using the coordinate entry fields, enter the cylinder position:
       - X: 0.0, Y: 0.0, Z: 0.0 Press the Enter key.
    3. Using the coordinate entry fields, enter the radius:
       - dX: 2.2, dY: 0.0, dZ: 0.0 Press the Enter key.
    4. Using the coordinate entry fields, enter the height:
       - dX: 0.0, dY: 0.0, dZ: 8.2 Press the Enter key.
  - To set the name:
    1. Select the Attribute tab from the Properties window.
    2. For the Value of Name type: Air.
    3. Click the OK button.
  - To fit the view:
    1. Select the menu item *View > Fit All > Active View*.

- **Create Radiation Boundary**
  - To create a radiation boundary
    1. Select the menu item *Edit > Select > By Name*.
    2. Select Object Dialog,
       1. Select the objects named: Air.
       2. Click the OK button.
    3. Select the menu item *HFSS > Boundaries > Assign > Radiation*.
    4. Radiation Boundary window
       1. Name: Rad1
       2. Click the OK button.
Create the Wave port

To create a circle that represents the port:
1. Select the menu item *Draw > Circle*
2. Using the coordinate entry fields, enter the center position
   - X: 0.0, Y: 0.0, Z: 0.0 Press the *Enter* key
3. Using the coordinate entry fields, enter the radius of the circle:
   - dX: 0.838, dY: 0.0, dZ: 0.0 Press the *Enter* key

To set the name:
1. Select the *Attribute* tab from the *Properties* window.
2. For the *Value of Name* type: p1
3. Click the *OK* button

To select the object p1:
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: p1
   2. Click the *OK* button
Create Wave Port Excitation 1 (Continued)

To assign wave port excitation

1. Select the menu item \textit{HFSS > Excitations > Assign > Wave Port}
2. Wave Port: General
   1. Name: \textit{p1}
   2. Click the \textit{Next} button
3. Wave Port: Modes
   1. Number of Modes: 2
   2. For \textit{Mode 1}, click the \textit{None} column and select \textit{New Line}
   3. Using the coordinate entry fields, enter the vector position
      \begin{itemize}
      \item X: -0.838, Y: 0.0, Z: 0.0 Press the \textit{Enter} key
      \end{itemize}
   4. Using the coordinate entry fields, enter the vertex
      \begin{itemize}
      \item dX: 1.676, dY: 0.0, dZ: 0.0 Press the \textit{Enter} key
      \end{itemize}
   5. Polarize E Field: \checkmark \textit{Checked}
   6. Click the \textit{Next} button
4. Wave Port: Post Processing
5. Click the \textit{Finish} button
Create Offset Coordinate System

Create CS

1. Select the menu item 3D Modeler > Coordinate System > Create > Relative CS > Offset
2. Using the coordinate entry fields, enter the origin
   - X: 0.0, Y: 0.0, Z: 7.463
   - Press the Enter key

Create a Radiation Setup

To define the radiation setup

1. Select the menu item HFSS > Radiation > Insert Far Field Setup > Infinite Sphere
2. Far Field Radiation Sphere Setup dialog
   - Infinite Sphere Tab
     1. Name: ff_2d
     2. Phi: (Start: 0, Stop: 90, Step Size: 90)
     3. Theta: (Start: -180, Stop: 180, Step Size: 2)

1. Coordinate System Tab
   1. Select Use local coordinate system
   2. Choose RelativeCS3
   2. Click the OK button
Example - Conical Horn

Analysis Setup

Creating an Analysis Setup

To create an analysis setup:
1. Select the menu item **HFSS > Analysis Setup > Add Solution Setup**
2. Solution Setup Window:
   1. Click the General tab:
      - Solution Frequency: **5.0 GHz**
      - Maximum Number of Passes: **10**
      - Maximum Delta S per Pass: **0.02**
   2. Click the **OK** button

Save Project

To save the project:
1. In an Ansoft HFSS window, select the menu item **File > Save As**
2. From the **Save As** window, type the Filename: **hfss_chorn**
3. Click the **Save** button

Analyze

Model Validation

To validate the model:
1. Select the menu item **HFSS > Validation Check**
2. Click the **Close** button
   
   **Note:** To view any errors or warning messages, use the Message Manager.

Analyze

To start the solution process:
1. Select the menu item **HFSS > Analyze All**
Example - Conical Horn

Solution Data

To view the Solution Data:
1. Select the menu item HFSS > Results > Solution Data
   - To view the Profile:
     1. Click the Profile Tab.
   - To view the Convergence:
     1. Click the Convergence Tab
     - Note: The default view is for convergence is Table. Select the Plot radio button to view a graphical representations of the convergence data.
   - To view the Matrix Data:
     1. Click the Matrix Data Tab
     - Note: To view a real-time update of the Matrix Data, set the Simulation to Setup1, Last Adaptive
   2. Click the Close button

![Solutions: example 5-2 - HFSSModel1](image-url)
Far Field Overlays

Edit Sources

To Modify a Terminal excitation:
1. Select the menu item **HFSS > Fields > Edit Sources**
2. Edit Sources window
   1. Source: \textit{p1:m1}
      1. Scaling Factor: \textit{1}
      2. Offset: \textit{0}
   2. Source: \textit{p1:m2}
      1. Scaling Factor: \textit{1}
      2. OffsetPhase: \textit{90}
3. Click the OK button

Create Far Field Overlay

To create a 2D polar far field plot:
1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: \textit{Far Fields}
   2. Display Type: \textit{Radiation Pattern}
   3. Click the OK button
3. Traces Window:
   1. Solution: \textit{Setup1: LastAdaptive}
   2. Geometry: \textit{ff_2d}
   3. In the \textit{Sweeps} tab
      1. Primary Sweep: Click on the Name \textit{Phi} and toggle to \textit{Theta}
   4. In the \textit{Mag} tab
      1. Category: \textit{Gain}
      2. Quantity: \textit{GainLHCP, GainRHCP}
      3. Function: \textit{dB}
   5. Click the Done button
The Probe Feed Patch Antenna

This example is intended to show you how to create, simulate, and analyze a probe feed patch antenna using the Ansoft HFSS Design Environment.
5.3

Example - Probe Feed Patch Antenna

Getting Started

Launching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft > HFSS 10 program group. Click HFSS 10.

Setting Tool Options

To set the tool options:

Note: In order to follow the steps outlined in this example, verify that the following tool options are set:

1. Select the menu item Tools > Options > HFSS Options
2. HFSS Options Window:
   1. Click the General tab
      - Use Wizards for data entry when creating new boundaries: ✔ Checked
      - Duplicate boundaries with geometry: ✔ Checked
   2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:
   1. Click the Operation tab
      - Automatically cover closed polylines: ✔ Checked
   2. Click the Drawing tab
      - Edit property of new primitives: ✔ Checked
   3. Click the OK button
### Opening a New Project

To open a new project:

1. In an Ansoft HFSS window, click the On the Standard toolbar, or select the menu item **File > New**.
2. From the **Project** menu, select **Insert HFSS Design**.

### Set Solution Type

To set the solution type:

1. Select the menu item **HFSS > Solution Type**
2. Solution Type Window:
   1. Choose **Driven Terminal**
   2. Click the OK button
Creating the 3D Model

Set Model Units

To set the units:
1. Select the menu item 3D Modeler > Units
2. Set Model Units:
   1. Select Units: cm
   2. Click the OK button

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
   1. Type Rogers RT/duroid 5880 (tm) in the Search by Name field
   2. Click the OK button
Create Substrate

To create the substrate:
1. Select the menu item *Draw > Box*
2. Using the coordinate entry fields, enter the box position
   - X: **-5.0**, Y: **-4.5**, Z: **0.0**, Press the **Enter** key
2. Using the coordinate entry fields, enter the opposite corner of the box
   - dX: **10.0**, dY: **9.0**, dZ: **0.32**, Press the **Enter** key

To set the name:
1. Select the *Attribute* tab from the *Properties* window.
2. For the *Value of Name* type: **Sub1**
3. Click the **OK** button

To fit the view:
1. Select the menu item *View > Fit All > Active View*. Or press the **CTRL+D** key
**Create Infinite Ground**

*To create the infinite ground:*
1. Select the menu item *Draw > Rectangle*
2. Using the coordinate entry fields, enter the rectangle position
   - X: -5.0, Y: -4.5, Z: 0.0, Press the *Enter* key
3. Using the coordinate entry fields, enter the opposite corner of the rectangle:
   - dX: 10.0, dY: 9.0, dZ: 0.0, Press the *Enter* key

*To set the name:*
1. Select the *Attribute* tab from the *Properties* window.
2. For the *Value* of *Name* type: Inf_GND
3. Click the *OK* button

*To fit the view:*
1. Select the menu item *View > Fit All > Active View.*

**Assign a Perfect E boundary to the Infinite Ground**

*To select the trace:*
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: Inf_GND
   2. Click the *OK* button

*To assign the Perfect E boundary*
1. Select the menu item *HFSS > Boundaries > Assign > Perfect E*
2. Perfect E Boundary window
   1. Name: PerfE_Inf_GND
   2. Infinite Ground Plane: ☑ Checked
   3. Click the *OK* button
**Example – Probe Feed Patch Antenna**

### Create Infinite Ground Cut Out

**To create the cut out:**
1. Select the menu item **Draw > Circle**
2. Using the coordinate entry fields, enter the center position
   - X: -0.5, Y: 0.0, Z: 0.0, Press the **Enter** key
3. Using the coordinate entry fields, enter the radius:
   - dX: 0.16, dY: 0.0, dZ: 0.0, Press the **Enter** key

**To set the name:**
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: **Cut_Out**
3. Click the **OK** button

**To fit the view:**
1. Select the menu item **View > Fit All > Active View**

### Complete the Infinite Ground

**To select the objects Inf_GND & Cut_Out:**
1. Select the menu item **Edit > Select > By Name**
2. Select Object Dialog,
   1. Select the objects named: **Inf_GND**, **Cut_Out**
   2. Click the **OK** button

**To complete the ring:**
1. Select the menu item **3D Modeler > Boolean > Subtract**
2. Subtract Window
   - Blank Parts: **Inf_GN_D**
   - Tool Parts: **Cut_Out**
   - Clone tool objects before subtract: **Unchecked**
   - Click the **OK** button
Create Patch

To create the patch:
1. Select the menu item **Draw > Rectangle**
2. Using the coordinate entry fields, enter the rectangle position
   - X: -2.0, Y: -1.5, Z: 0.32, Press the *Enter* key
3. Using the coordinate entry fields, enter the opposite corner of the rectangle:
   - dX: 4.0, dY: 3.0, dZ: 0.0, Press the *Enter* key

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: Patch
3. Click the **OK** button

To fit the view:
1. Select the menu item **View > Fit All > Active View**.

Assign a Perfect E boundary to the Trace

To select the trace:
1. Select the menu item **Edit > Select > By Name**
2. Select Object Dialog,
   1. Select the objects named: Patch
   2. Click the **OK** button

To assign the Perfect E boundary:
1. Select the menu item **HFSS > Boundaries > Assign > Perfect E**
2. Perfect E Boundary window
   1. Name: PerfE_Patch
   2. Click the **OK** button
Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose vacuum

Create the Coax

To create the coax:
1. Select the menu item Draw > Cylinder
2. Using the coordinate entry fields, enter the cylinder position
   - X: -0.5, Y: 0.0, Z: 0.0 Press the Enter key
3. Using the coordinate entry fields, enter the radius:
   - dX: 0.16, dY: 0.0, dZ: 0.0 Press the Enter key
4. Using the coordinate entry fields, enter the height:
   - dX: 0.0, dY: 0.0, dZ: -0.5 Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Coax
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
**Set Default Material**

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
   1. Type pec in the Search by Name field
   2. Click the OK button

**Create the Coax Pin**

To create the coax pin:
1. Select the menu item Draw > Cylinder
2. Using the coordinate entry fields, enter the cylinder position
   - X: -0.5, Y: 0.0, Z: 0.0 Press the Enter key
3. Using the coordinate entry fields, enter the radius:
   - dX: 0.07, dY: 0.0, dZ: 0.0 Press the Enter key
4. Using the coordinate entry fields, enter the height:
   - dX: 0.0, dY: 0.0, dZ: -0.5 Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Coax_Pin
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
5.3

Example - Probe Feed Patch Antenna

Create the Wave port

To create a circle that represents the port:
1. Select the menu item Draw > Circle
2. Using the coordinate entry fields, enter the center position
   - X: -0.5, Y: 0.0, Z: -0.5 Press the Enter key
3. Using the coordinate entry fields, enter the radius of the circle:
   - dX: 0.16, dY: 0.0, dZ: 0.0 Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Port1
3. Click the OK button

To select the object Port1:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Port1
3. Click the OK button

To assign wave port excitation
1. Select the menu item HFSS > Excitations > Assign > Wave Port
2. Wave Port : General
   1. Name: p1
   2. Click the Next button
3. Wave Port : Terminals
   1. Number of Terminals: 1,
   2. For T1, click the Undefined column and select New Line
   3. Using the coordinate entry fields, enter the vertex position
      - X: -0.34, Y: 0.0, Z: -0.5, Press the Enter key
   4. Using the coordinate entry fields, enter the vertex
      - dX: -0.09, dY: 0.0, dZ: 0.0, Press the Enter key
5. Click the Next button
4. Wave Port : Differential Pairs
   1. Click the Next button
5. Wave Port : Post Processing
   1. Reference Impedance: 50
6. Click the Finish button
Create the Probe

To create the probe:
1. Select the menu item Draw > Cylinder
2. Using the coordinate entry fields, enter the cylinder position
   - X: -0.5, Y: 0.0, Z: 0.0 Press the Enter key
3. Using the coordinate entry fields, enter the radius:
   - dX: 0.07, dY: 0.0, dZ: 0.0 Press the Enter key
4. Using the coordinate entry fields, enter the height:
   - dX: 0.0, dY: 0.0, dZ: 0.32 Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Probe
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose vacuum

Create Air

To create the air:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: -5.0, Y: -4.5, Z: 0.0, Press the Enter key
2. Using the coordinate entry fields, enter the opposite corner of the box
   - dX: 10.0, dY: 9.0, dZ: 3.32, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Air
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
Example - Probe Feed Patch Antenna

Create Radiation Boundary

- **Picking the faces:**
  1. Select the menu item *Edit > Select > Faces*
  2. Graphically select all of the faces of the Air object except the face at Z=0.0cm

- **To create a radiation boundary**
  1. Select the menu item *HFSS > Boundaries > Assign > Radiation*
  2. Radiation Boundary window
     1. Name: Rad1
     2. Click the OK button

Create a Radiation Setup

- **To define the radiation setup**
  1. Select the menu item *HFSS > Radiation > Insert Far Field Setup > Infinite Sphere*
  2. Far Field Radiation Sphere Setup dialog
     1. Select the *Infinite Sphere* Tab
        1. Name: ff_2d
        2. Phi: (Start: 0, Stop: 90, Step Size: 90)
        3. Theta: (Start: -180, Stop: 180, Step Size: 2)
     2. Click the OK button
Analysis Setup

Creating an Analysis Setup

To create an analysis setup:
1. Select the menu item HFSS > Analysis Setup > Add Solution Setup
2. Solution Setup Window:
   1. Click the General tab:
      - Solution Frequency: 2.25 GHz
      - Maximum Number of Passes: 20
      - Maximum Delta S per Pass: 0.02
   2. Click the OK button

Adding a Frequency Sweep

To add a frequency sweep:
1. Select the menu item HFSS > Analysis Setup > Add Sweep
   1. Select Solution Setup: Setup1
   2. Click the OK button
2. Edit Sweep Window:
   1. Sweep Type: Fast
   2. Frequency Setup Type: Linear Count
      - Start: 1.0GHz
      - Stop: 3.5GHz
      - Count: 201
      - Save Fields: ☑ Checked
   3. Click the OK button
Save Project

To save the project:
1. In an Ansoft HFSS window, select the menu item File > Save As.
2. From the Save As window, type the Filename: hfss_probepatch
3. Click the Save button

Analyze

Model Validation

To validate the model:
1. Select the menu item HFSS > Validation Check
2. Click the Close button

Note: To view any errors or warning messages, use the Message Manager.

Analyze

To start the solution process:
1. Select the menu item HFSS > Analyze All

Setup1: Solving Parts on Local Machine -

Adapting p1, Pass 9

[Abort]
5.3 Example - Probe Feed Patch Antenna

Solution Data

To view the Solution Data:
1. Select the menu item **HFSS > Results > Solution Data**

   - To view the Profile:
     1. Click the **Profile** Tab.

   - To view the Convergence:
     1. Click the **Convergence** Tab
     
       **Note:** The default view is for convergence is **Table**. Select the **Plot** radio button to view a graphical representations of the convergence data.

   - To view the Matrix Data:
     1. Click the **Matrix Data** Tab
     
       **Note:** To view a real-time update of the Matrix Data, set the Simulation to **Setup1, Last Adaptive**

2. Click the **Close** button
Create Reports

Create Terminal S-Parameter Plot - Magnitude

To create a report:

1. Select the menu item HFSS > Results > Create Report
2. Create Report Window:
   1. Report Type: Terminal S Parameters
   2. Display Type: Rectangular
   3. Click the OK button
3. Traces Window:
   1. Solution: Setup1: Sweep1
   2. Domain: Sweep
   3. Click the Y tab
      1. Category: Terminal S Parameter
      2. Quantity: St(p1,p1),
      3. Function: dB
      4. Click the Add Trace button
   4. Click the Done button
4. Select the menu Report 2D > Mark All Traces
   1. Click the Min button

![Graph Image]
Far Field Overlays

Create Far Field Overlay

To create a 2D polar far field plot:

1. Select the menu item `HFSS > Results > Create Report`
2. Create Report Window:
   1. Report Type: `Far Fields`
   2. Display Type: `Radiation Pattern`
   3. Click the `OK` button
3. Traces Window:
   1. Solution: `Setup1: Sweep1`
   2. Geometry: `ff_2d`
   3. In the `Sweeps` tab, select `Phi` under the `Name` column, and on the drop list, select `Theta`. This changes the primary sweep to Theta.
   4. In the `Sweeps` tab, select the row labeled `Freq` and select the frequency `2.3625` from the list.
   5. In the `Mag` tab
      1. Category: `Gain`
      2. Quantity: `GainTotal`
      3. Function: `dB`
      4. Click the `Add Trace` button
6. Click the `Done` button
THIS PAGE INTENTIONALLY LEFT BLANK
Example - Slot Patch

The Slot Coupled Patch Antenna

This example is intended to show you how to create, simulate, and analyze a probe feed patch antenna using the Ansoft HFSS Design Environment.
Example - Slot Patch

Getting Started

Launching Ansoft HFSS
1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft > HFSS 10 program group. Click HFSS 10

Setting Tool Options
To set the tool options:

Note: In order to follow the steps outlined in this example, verify that the following tool options are set:
1. Select the menu item Tools > Options > HFSS Options
2. HFSS Options Window:
   1. Click the General tab
      - Use Wizards for data entry when creating new boundaries: ☑ Checked
      - Duplicate boundaries with geometry: ☑ Checked
   2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:
   1. Click the Operation tab
      - Automatically cover closed polylines: ☑ Checked
   2. Click the Drawing tab
      - Edit property of new primitives: ☑ Checked
   3. Click the OK button
### Opening a New Project

**To open a new project:**

1. In an Ansoft HFSS window, click the [ ] On the Standard toolbar, or select the menu item **File > New**.
2. From the **Project** menu, select **Insert HFSS Design**.

#### Set Solution Type

**To set the solution type:**

1. Select the menu item **HFSS > Solution Type**
2. Solution Type Window:
   1. Choose **Driven Terminal**
   2. Click the **OK** button
Creating the 3D Model

Set Model Units

To set the units:
1. Select the menu item 3D Modeler > Units
2. Set Model Units:
   1. Select Units: cm
   2. Click the OK button

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
   1. Type Rogers RT/duroid 5880 (tm) in the Search by Name field
   2. Click the OK button
5.4 Example - Slot Patch

▲ Create Substrate

▲ To create the substrate:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   ▲ X: -7.0, Y: -4.5, Z: 0.0, Press the Enter key
2. Using the coordinate entry fields, enter the opposite corner of the box
   ▲ dX: 12.0, dY: 9.0, dZ: 0.32, Press the Enter key

▲ To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Sub1
3. Click the OK button

▲ To fit the view:
1. Select the menu item View > Fit All > Active View. Or press the CTRL+D key
5.4 Example – Slot Patch

Create the Feed

To create the feed:
1. Select the menu item **Draw > Rectangle**
2. Using the coordinate entry fields, enter the rectangle position
   - X: **-5.0**, Y: **-0.2475**, Z: **0.0**, Press the **Enter** key
3. Using the coordinate entry fields, enter the opposite corner of the rectangle:
   - dX: **7.0**, dY: **0.495**, dZ: **0.0**, Press the **Enter** key

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value** of **Name** type: **Feed**
3. Click the **OK** button

To fit the view:
1. Select the menu item **View > Fit All > Active View**.

Assign a Perfect E boundary to the Feed

To select the feed:
1. Select the menu item **Edit > Select > By Name**
2. Select Object Dialog,
   1. Select the objects named: **Feed**
   2. Click the **OK** button

To assign the Perfect E boundary
1. Select the menu item **HFSS > Boundaries > Assign > Perfect E**
2. Perfect E Boundary window
   1. Name: **PerfE_Feed**
   2. Infinite Ground Plane: **Unchecked**
   3. Click the **OK** button
Example - Slot Patch

Create Ground

To create the ground:
1. Select the menu item Draw > Rectangle
2. Using the coordinate entry fields, enter the rectangle position
   X: -7.0, Y: -4.5, Z: 0.16, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the rectangle:
   dX: 12.0, dY: 9.0, dZ: 0.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Ground
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Assign a Perfect E boundary to the Ground

To select the ground:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Ground
   2. Click the OK button

To assign the Perfect E boundary
1. Select the menu item HFSS > Boundaries > Assign > Perfect E
2. Perfect E Boundary window
   1. Name: PerfE_Ground
   2. Infinite Ground Plane: Unchecked
   3. Click the OK button
Create Slot Cut Out

To create the cut out:
1. Select the menu item *Draw > Rectangle*
2. Using the coordinate entry fields, enter the rectangle position
   - X: -0.0775, Y: -0.7, Z: 0.16, Press the *Enter* key
3. Using the coordinate entry fields, enter the opposite corner of the rectangle:
   - dX: 0.155, dY: 1.4, dZ: 0.0, Press the *Enter* key

To set the name:
1. Select the *Attribute* tab from the *Properties* window.
2. For the *Value of Name* type: *Slot*
3. Click the *OK* button

To fit the view:
1. Select the menu item *View > Fit All > Active View*

Complete the Ground

To select the objects ground & slot
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   - 1. Select the objects named: *Ground, Slot*
   - 2. Click the *OK* button

To complete the ring:
1. Select the menu item *3D Modeler > Boolean > Subtract*
2. Subtract Window
   - Blank Parts: *Ground*
   - Tool Parts: *Slot*
   - Clone tool objects before subtract: ✅ *Unchecked*
   - Click the *OK* button
Example - Slot Patch

Create Patch

To create the patch:
1. Select the menu item *Draw > Rectangle*
2. Using the coordinate entry fields, enter the rectangle position
   - X: -2.0, Y: -1.5, Z: 0.32, Press the *Enter* key
3. Using the coordinate entry fields, enter the opposite corner of the rectangle:
   - dX: 4.0, dY: 3.0, dZ: 0.0, Press the *Enter* key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Patch
3. Click the OK button

To fit the view:
1. Select the menu item *View > Fit All > Active View.*

Assign a Perfect E boundary to the Trace

To select the trace:
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: Patch
   2. Click the OK button

To assign the Perfect E boundary
1. Select the menu item *HFSS > Boundaries > Assign > Perfect E*
2. Perfect E Boundary window
   1. Name: PerfE_Patch
   2. Click the OK button
Example - Slot Patch

Set Default Material
- To set the default material:
  1. Using the 3D Modeler Materials toolbar, choose vacuum

Create Air
- To create the air:
  1. Select the menu item Draw > Box
  2. Using the coordinate entry fields, enter the box position
     - X: -7.0, Y: -4.5, Z: -2.0, Press the Enter key
  2. Using the coordinate entry fields, enter the opposite corner of the box
     - dX: 12.0, dY: 9.0, dZ: 4.32, Press the Enter key

To set the name:
  1. Select the Attribute tab from the Properties window.
  2. For the Value of Name type: Air
  3. Click the OK button

To fit the view:
  1. Select the menu item View > Fit All > Active View
### Create Radiation Boundary

**Picking the faces:**
1. Select the menu item *Edit > Select > Faces*
2. Graphically select all of the faces of the *Air* object *except* the face at Z=0.0cm

**To create a radiation boundary**
1. Select the menu item *
   ![Image](image.png)

2. Radiation Boundary window
   1. Name: *Rad1*
   2. Click the OK button

### Create a Radiation Setup

**To define the radiation setup**
1. Select the menu item *
   ![Image](image.png)

2. Far Field Radiation Sphere Setup dialog
   1. Select the *Infinite Sphere* Tab
   2. Name: *ff_2d*
   3. Phi: (Start: 0, Stop: 90, Step Size: 90)
   4. Theta: (Start: -180, Stop: 180, Step Size: 2)
   2. Click the OK button
Set Grid Plane

To set the grid plane:
1. Select the menu item 3D Modeler > Grid Plane > YZ

Create Source

To create source:
1. Select the menu item Draw > Rectangle
2. Using the coordinate entry fields, enter the box position
   X: -5.0, Y: -0.2475, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   dX: 0.0, dY: 0.495, dZ: 0.16, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Source
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
5.4

Example - Slot Patch

Assign Excitation

To select the object Source:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Source
   2. Click the OK button

Note: You can also select the object from the Model Tree

To assign lumped port excitation
1. Select the menu item HFSS > Excitations > Assign > Lumped Port
2. Lumped Port : General
   1. Name: p1,
   2. Resistance: 50
   3. Reactance: 0
   4. Click the Next button
3. Lumped Port : Terminals
   1. Number of Terminals: 1,
   2. For T1, click the Undefined column and select New Line
   3. Using the coordinate entry fields, enter the vector position
      ▲ X: -5.0, Y: 0.0, Z: 0.16, Press the Enter key
   4. Using the coordinate entry fields, enter the vertex
      ▲ dX: 0.0, dY: 0.0, dZ: -0.16, Press the Enter key
   5. Click the Next button
   6. Click the Finish button
Analysis Setup

Creating an Analysis Setup

To create an analysis setup:
1. Select the menu item **HFSS > Analysis Setup > Add Solution Setup**
2. Solution Setup Window:
   1. Click the General tab:
      - Solution Frequency: **2.25 GHz**
      - Maximum Number of Passes: **20**
      - Maximum Delta S: **0.02**
   2. Click the **OK** button

Adding a Frequency Sweep

To add a frequency sweep:
1. Select the menu item **HFSS > Analysis Setup > Add Sweep**
   1. Select Solution Setup: **Setup1**
   2. Click the **OK** button
2. Edit Sweep Window:
   1. Sweep Type: **Fast**
   2. Frequency Setup Type: **Linear Count**
      - Start: **1.0GHz**
      - Stop: **3.5GHz**
      - Count: **201**
      - Save Fields: ☑ Checked
   3. Click the **OK** button
5.4 Example - Slot Patch

- **Save Project**
  - **To save the project:**
    1. In an Ansoft HFSS window, select the menu item *File > Save As*.
    2. From the *Save As* window, type the Filename: *hfss_slotpatch*
    3. Click the *Save* button

- **Model Validation**
  - **To validate the model:**
    1. Select the menu item *HFSS > Validation Check*
    2. Click the *Close* button
  - **Note:** To view any errors or warning messages, use the Message Manager.

- **Analyze**
  - **To start the solution process:**
    1. Select the menu item *HFSS > Analyze All*

![Setup: Solving Parts on Local Machine -](image)
Example - Slot Patch

**Solution Data**

To view the Solution Data:

1. Select the menu item **HFSS > Results > Solution Data**

To view the Profile:

1. Click the **Profile** Tab.

To view the Convergence:

1. Click the **Convergence** Tab

**Note:** The default view is for convergence is **Table**. Select the **Plot** radio button to view a graphical representations of the convergence data.

To view the Matrix Data:

1. Click the **Matrix Data** Tab

**Note:** To view a real-time update of the Matrix Data, set the Simulation to **Setup1, Last Adaptive**

2. Click the **Close** button
Create Reports

Create Terminal S-Parameter Plot - Magnitude

To create a report:

1. Select the menu item HFSS > Results > Create Report
2. Create Report Window:
   1. Report Type: Terminal S Parameters
   2. Display Type: Rectangular
   3. Click the OK button
3. Traces Window:
   1. Solution: Setup1: Sweep1
   2. Domain: Sweep
   3. Click the Y tab
      1. Category: Terminal S Parameter
      2. Quantity: St(p1,p1),
      3. Function: dB
      4. Click the Add Trace button
4. Click the Done button
4. Select the menu Report 2D > Mark All Traces
   1. Click the Min button
Far Field Overlays

Create Far Field Overlay

To create a 2D polar far field plot:
1. Select the menu item HFSS > Results > Create Report
2. Create Report Window:
   1. Report Type: Far Fields
   2. Display Type: Radiation Pattern
   3. Click the OK button
3. Traces Window:
   1. Solution: Setup1: Sweep1
   2. Geometry: ff_2d
   3. In the Sweeps tab, select Phi under the Name column, and on the drop list, select Theta. This changes the primary sweep to Theta.
   4. In the Sweeps tab, select the row labeled Freq and select the frequency 2.3 from the list.
   5. In the Mag tab
      1. Category: Gain
      2. Quantity: GainPhi, GainTheta
      3. Function: dB
      4. Click the Add Trace button
   6. Click the Done button
5.5 - Example - Specific Absorption Rate

**Specific Absorption Rate**

This example is intended to show you how to create, simulate, and analyze a simple phantom, which is commonly used to calibrate Specific Absorption Rate test equipment, using the Ansoft HFSS Design Environment.

With the explosion of consumer demand for wireless devices, consumers and the media have become aware of and are concerned with the biological effects of long-term exposure to radio frequency radiation (RFR). To ensure public safety, the Federal Communication Commission (FCC) has developed safety standards that wireless devices are required to meet in order to be sold in the US (Similar guidelines exist in other countries). The quantity used to quantify the amount of energy absorbed is the Specific Absorption Rate or SAR.

---

**Nominal Design:**

**Bowl:**
- Inner radius = \(106.5 \pm 5\text{mm}\)
- Thickness = \(5 \pm 0.5\text{mm}\).
- Opening = \(d_2 = 170\text{mm}\)
- \(\varepsilon_r = 4.6\)

**Antenna:**
- Overall Length = \(168\text{mm}\)
- Gap between dipoles = \(1\text{mm}\)
- Wire Diameter = \(3.6\text{mm}\)

**Fluid:**
- \(\varepsilon_r = 42.9 \pm 5\%\)
- \(\sigma = 0.9 \pm 10\%\)
- \(\rho = 1 \text{g/cm}^3\)
- Level = \(d_1 = 13.4\text{ cm}\)
**Example - Specific Absorption Rate**

- **Ansoft HFSS Analysis of Specific Absorption Rate for Flat Phantom Measurement Standard Outlined in IEEE P1528-2002**
  - **Reference: Draft** Recommended Standard for Determining the Spatial Peak Specific Absorption Rate (SAR) in the Human Head from Wireless Communication Devices: Measurement Technique

  The table below summarizes the data from an Ansoft HFSS analysis of flat phantom models as described in the IEEE draft standard for SAR measurements.

<table>
<thead>
<tr>
<th>Frequency (MHz)</th>
<th>1g SAR (W/kg)</th>
<th>10g SAR (W/kg)</th>
<th>Local SAR at surface (above feedpoint) (W/kg)</th>
<th>Local SAR at surface (y=2cm offset from feedpoint) (W/kg)</th>
</tr>
</thead>
<tbody>
<tr>
<td>300</td>
<td>3.06 (3.0)</td>
<td>2.07 (2.0)</td>
<td>4.63 (4.4)</td>
<td>2.20 (2.1)</td>
</tr>
<tr>
<td>450</td>
<td>4.98 (4.9)</td>
<td>3.31 (3.3)</td>
<td>7.59 (7.2)</td>
<td>3.28 (3.2)</td>
</tr>
<tr>
<td>835</td>
<td>9.62 (9.5)</td>
<td>6.26 (6.2)</td>
<td>14.71 (14.1)</td>
<td>4.93 (4.9)</td>
</tr>
<tr>
<td>900</td>
<td>10.98 (10.8)</td>
<td>7.02 (6.9)</td>
<td>17.01 (16.4)</td>
<td>5.47 (5.4)</td>
</tr>
<tr>
<td>1450</td>
<td>29.83 (29.0)</td>
<td>16.50 (16.0)</td>
<td>53.90 (50.2)</td>
<td>6.54 (6.5)</td>
</tr>
<tr>
<td>1800</td>
<td>39.36 (38.1)</td>
<td>20.45 (19.8)</td>
<td>74.39 (69.5)</td>
<td>6.85 (6.8)</td>
</tr>
<tr>
<td>1900</td>
<td>40.97 (39.7)</td>
<td>21.21 (20.5)</td>
<td>78.02 (72.1)</td>
<td>6.54 (6.6)</td>
</tr>
<tr>
<td>2450</td>
<td>55.42 (52.4)</td>
<td>25.42 (24.0)</td>
<td>115 (104.2)</td>
<td>8.09 (7.7)</td>
</tr>
<tr>
<td>3000</td>
<td>65.81 (63.8)</td>
<td>26.48 (25.7)</td>
<td>157.66 (140.2)</td>
<td>8.8 (9.5)</td>
</tr>
</tbody>
</table>

HFSS results: Measured data in parenthesis, from Table 8-1 of paper

- In general there is excellent agreement between the HFSS simulations and measurements. The possible exception would be the Local SAR above the feedpoint. This is likely due to the use of 50 Ω lumped gap sources as an approximation to the balun feed for the dipoles. Calculation of 1g and 10g SAR was done via the fields calculator on explicitly defined volumes in the flat phantom located immediately below the feed point.
Example - Specific Absorption Rate

Getting Started

Launching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft > HFSS 10 program group. Click HFSS 10.

Setting Tool Options

To set the tool options:

- **Note:** In order to follow the steps outlined in this example, verify that the following tool options are set:
  1. Select the menu item **Tools > Options > HFSS Options**.
  2. HFSS Options Window:
     1. Click the **General** tab.
        - Use Wizards for data entry when creating new boundaries: ☑ Checked
        - Duplicate boundaries with geometry: ☑ Checked
     2. Click the **OK** button.
  3. Select the menu item **Tools > Options > 3D Modeler Options**.
   4. 3D Modeler Options Window:
      1. Click the **Operation** tab.
         - Automatically cover closed polylines: ☑ Checked
      2. Click the **Drawing** tab.
         - Edit property of new primitives: ☑ Checked
      3. Click the **OK** button.
5.5 Example - Specific Absorption Rate

**Opening a New Project**

To open a new project:
1. In an Ansoft HFSS window, click the File tab on the Standard toolbar, or select the menu item *File > New.*
2. From the *Project* menu, select *Insert HFSS Design.*

![Project window](image)

**Set Solution Type**

To set the solution type:
1. Select the menu item *HFSS > Solution Type*
2. Solution Type Window:
   1. Choose *Driven Modal*
   2. Click the *OK* button

![Solution Type window](image)
5.5

Example - Specific Absorption Rate

Creating the 3D Model

Set Model Units

To set the units:
1. Select the menu item **3D Modeler > Units**
2. Set Model Units:
   1. Select Units: **mm**
   2. Click the **OK** button

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose **Select**
2. Select Definition Window:
   1. Type **pec** in the **Search by Name** field
   2. Click the **OK** button
Create Offset Coordinate System

To create an offset Coordinate System:
1. Select the menu item *3D Modeler > Coordinate System > Create > Relative CS > Offset*
2. Using the coordinate entry fields, enter the origin
   - X: 0.0, Y: 0.0, Z: -6.8, Press the Enter key

Create Dipole Antenna Arm 1

To set grid plane
1. Select the menu item *3D Modeler > Grid Plane > XZ*

To create the dipole antenna:
1. Select the menu item *Draw > Cylinder*
2. Using the coordinate entry fields, enter the cylinder position
   - X: 0.0, Y: -84.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the radius:
   - dX: 1.8, dY: 0.0, dZ: 0.0, Press the Enter key
4. Using the coordinate entry fields, enter the height:
   - dX: 0.0, dY: 83.5, dZ: 0.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Dipole
3. Click the OK button

To fit the view:
1. Select the menu item *View > Fit All > Active View.* Or press the CTRL+D key
Create Dipole Antenna Arm 2
- To create arm 2:
  1. Select the menu item **Edit > Select All Visible**. Or press the **CTRL+A** key.
  2. Select the menu item, **Edit > Duplicate > Mirror**.
     1. Input the anchor point of the mirror plane:
        - X: 0.0, Y: 0.0, Z: 0.0, Press the **Enter** key
     2. Input the target point of the vector normal to the mirror plane:
        - dX: 0.0, dY: 1.0, dZ: 0.0, Press the **Enter** key

Group the Dipole Antenna Arms
- To group the dipole arms:
  1. Select the menu item **Edit > Select All Visible**
  2. Select the menu item, **3D Modeler > Boolean > Unite**

Set Grid Plane
- To set the grid plane:
  1. Select the menu item **3D Modeler > Grid Plane > XY**

Create Source
- To create source:
  1. Select the menu item **Draw > Rectangle**
  2. Using the coordinate entry fields, enter the rectangle position
     - X: -1.8, Y: -0.5, Z: 0.0, Press the **Enter** key
  3. Using the coordinate entry fields, enter the opposite corner of the rectangle:
     - dX: 3.6, dY: 1.0, dZ: 0.0, Press the **Enter** key
- To set the name:
  1. Select the **Attribute** tab from the **Properties** window.
  2. For the **Value of Name** type: **Source**
  3. Click the **OK** button
- To fit the view:
  1. Select the menu item **View > Fit All > Active View**.
**Assign Excitation**

**To select the object Source:**
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: **Source**
   2. Click the OK button

**Note:** You can also select the object from the Model Tree

**To assign lumped port excitation**
1. Select the menu item *HFSS > Excitations > Assign > Lumped Port*
2. Lumped Port: General
   1. Name: **p1**
   2. Resistance: **50**
   3. Reactance: **0**
   4. Click the **Next** button
3. Lumped Port: Modes
   1. Number of Modes: **1**
   2. For **Mode 1**, click the **None** column and select **New Line**
   3. Using the coordinate entry fields, enter the vector position
      - X: **0.0**, Y: **-0.5**, Z: **0.0**, Press the **Enter** key
   4. Using the coordinate entry fields, enter the vertex
      - dX: **0.0**, dY: **1.0**, dZ: **0.0**, Press the **Enter** key
5. Click the **Next** button
6. Click the **Finish** button
### Add New Material

**To add a new material:**

1. Using the 3D Modeler Materials toolbar, choose **Select**
2. From the Select Definition window, click the **Add Material** button
3. View/Edit Material Window:
   1. For the **Material Name** type: **My_Bowl**
   2. For the **Value** of **Relative Permittivity** type: **4.6**
   3. Click the **OK** button
4. Click the **OK** button
Example - Specific Absorption Rate

**Set Working Coordinate System**

- **To set the working coordinate system:**
  1. Select the menu item `3D Modeler > Coordinate System > Set Working CS`
  2. Select Coordinate System Window,
     1. From the list, select the CS: **Global**
     2. Click the **Select** button

**Create Bowl**

- **To create the bowl:**
  1. Select the menu item `Draw > Sphere`
  2. Using the coordinate entry fields, enter the sphere position
     - X: 0.0, Y: 0.0, Z: 111.5, Press the **Enter** key
  3. Using the coordinate entry fields, enter the radius:
     - dX: 111.5, dY: 0.0, dZ: 0.0, Press the **Enter** key

- **To set the name:**
  1. Select the **Attribute** tab from the **Properties** window.
  2. For the **Value of Name** type: **Bowl**
  3. Click the **OK** button

- **To fit the view:**
  1. Select the menu item `View > Fit All > Active View`.

**Create Offset Coordinate System**

- **To create an offset Coordinate System:**
  1. Select the menu item `3D Modeler > Coordinate System > Create > Relative CS > Offset`
  2. Using the coordinate entry fields, enter the origin
     - X: 0.0, Y: 0.0, Z: 164.0, Press the **Enter** key
Create the Opening in the Bowl

To select the object Bowl:
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: **Bowl**
   2. Click the **OK** button

To select the split the bowl object:
1. Select the menu item *3D Modeler > Boolean > Split*
2. Split Window
   1. Split Plane: **XY**
   2. Keep Fragments: **Negative Side**
   3. Click the **OK** button

Add New Material

To add a new material:
1. Using the 3D Modeler Materials toolbar, choose **Select**
2. From the Select Definition window, click the **Add Material** button
3. View/Edit Material Window:
   1. For the **Material Name** type: **My_BrainFluid**
   2. For the **Value of Relative Permittivity** type: **42.9**
   3. For the **Value of Bulk Conductivity** type: **0.9**
   4. Click the **OK** button
4. Click the **OK** button

Set Working Coordinate System

To set the working coordinate system:
1. Select the menu item *3D Modeler > Coordinate System > Set Working CS*
2. Select Coordinate System Window,
   1. From the list, select the CS: **Global**
   2. Click the **Select** button
Example - Specific Absorption Rate

Create Brain Fluid

To create the brain fluid:
1. Select the menu item Draw > Sphere
2. Using the coordinate entry fields, enter the sphere position
   \( X: 0.0, Y: 0.0, Z: 111.5 \), Press the Enter key
3. Using the coordinate entry fields, enter the radius:
   \( dX: 106.5, dY: 0.0, dZ: 0.0 \), Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: BrainFluid
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Create the Shell of the Bowl

To select the objects Bowl and BrainFluid:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Bowl, BrainFluid
   2. Click the OK button

To complete the bowl:
1. Select the menu item 3D Modeler > Boolean > Subtract
2. Subtract Window
   \( \text{Blank Parts: Bowl} \)
   \( \text{Tool Parts: BrainFluid} \)
   \( \text{Clone tool objects before subtracting:} \checkmark \text{Checked} \)
   \( \text{Click the OK button} \)
Create Offset Coordinate System

To create an offset Coordinate System:
1. Select the menu item **3D Modeler > Coordinate System > Create > Relative CS > Offset**
2. Using the coordinate entry fields, enter the origin
   - X: 0.0, Y: 0.0, Z: 134.0, Press the **Enter** key

Set the Fluid Level

To select the object BrainFluid:
1. Select the menu item **Edit > Select > By Name**
2. Select Object Dialog,
   1. Select the objects named: **BrainFluid**
   2. Click the **OK** button

To select the split the bowl object:
1. Select the menu item **3D Modeler > Boolean > Split**
2. Split Window
   1. Split Plane: **XY**
   2. Keep Fragments: **Negative Side**
   3. Click the **OK** button

Create a SAR Calculation Line

To create a line:
1. Select the menu item **Draw > Line**
2. Using the coordinate entry fields, enter the vertex point:
   - X: 0.0, Y: 0.0, Z: -129.0, Press the **Enter** key
3. Using the coordinate entry fields, enter the vertex point:
   - X: 0.0, Y: 0.0, Z: 0.0, Press the **Enter** key
4. Click the **Enter** key for the same point to end line creation

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value** of **Name** type: **SAR_Line**
3. Click the **OK** button
Set Working Coordinate System

To set the working coordinate system:
1. Select the menu item 3D Modeler > Coordinate System > Set Working CS
2. Select Coordinate System Window,
   1. From the list, select the CS: RelativeCS1
   2. Click the Select button

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose vacuum

Create Air Box

To create the air box:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: -155.0, Y: -155.0, Z: -44.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: 310.0, dY: 310.0, dZ: 257.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Air
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
Create Radiation Boundary

To select the object Air:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Air
   2. Click the OK button

To create a radiation boundary
1. Select the menu item HFSS > Boundaries > Assign > Radiation
2. Radiation Boundary Window
   - Name: Rad1
   - Click the OK button

Create a Radiation Setup

To define the radiation setup
1. Select the menu item HFSS > Radiation > Insert Far Field Setup > Infinite Sphere
2. Far Field Radiation Sphere Setup dialog
   1. Select the Infinite Sphere Tab
      1. Name: ff_2d
      2. Phi: (Start: 0, Stop: 90, Step Size: 90)
      3. Theta: (Start: -180, Stop: 180, Step Size: 2)
   2. Click the OK button
Analysis Setup

Creating an Analysis Setup

To create an analysis setup:

1. Select the menu item *HFSS > Analysis Setup > Add Solution Setup*
2. Solution Setup Window:
   1. Click the *General* tab:
      - Solution Frequency: **0.835GHz**
      - Maximum Number of Passes: **20**
      - Maximum Delta S: **0.02**
   2. Click the *OK* button

Save Project

To save the project:

1. In an Ansoft HFSS window, select the menu item *File > Save As*.
2. From the *Save As* window, type the Filename: *hfss_sar*
3. Click the *Save* button

Analyze

Model Validation

To validate the model:

1. Select the menu item *HFSS > Validation Check*
2. Click the *Close* button

   Note: To view any errors or warning messages, use the Message Manager.

Analyze

To start the solution process:

1. Select the menu item *HFSS > Analyze All*
Solution Data

To view the Solution Data:
1. Select the menu item HFSS > Results > Solution Data
   - To view the Profile:
     1. Click the Profile Tab.
   - To view the Convergence:
     1. Click the Convergence Tab
     - Note: The default view is for convergence is Table. Select the Plot radio button to view a graphical representations of the convergence data.
   - To view the Matrix Data:
     1. Click the Matrix Data Tab
     - Note: To view a real-time update of the Matrix Data, set the Simulation to Setup1, Last Adaptive
2. Click the Close button
Create Reports

Create S-Parameter Plot vs. Adaptive Pass

Note: If this report is created prior or during the solution process, a real-time update of the results are displayed.

To create a report:
1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Modal S Parameters**
   2. Display Type: **Rectangular**
   3. Click the OK button
3. Traces Window:
   1. Solution: **Setup1: Adaptive1**
   2. Click the Y tab
      1. Category: **Terminal S Parameters**
      2. Quantity: **St(p1,p1)**,
      3. Function: **dB**
      4. Click the **Add Trace** button
   3. Click the **Done** button
Create SAR Plot

To create a report:

1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Fields**
   2. Display Type: **Rectangular**
   3. Click the OK button
3. Traces Window:
   1. Solution: **Setup1: LastAdaptive**
   2. Geometry: **SAR_Line**
   3. Click the Y tab
      1. Category: **Calculator Expressions**
      2. Quantity: **Local_SAR, Average_SAR**
      3. Function: **<none>**
      4. Click the **Add Trace** button
4. Click the **Done** button
Field Overlays

Create Field Overlay

Select the Global YZ Plane
1. Using the Model Tree, expand Planes
   1. Select Global:YZ
2. Select the menu item HFSS > Fields > Fields > E > Mag_E
3. Create Field Plot Window
   1. Solution: Setup1 : LastAdaptive
   2. Quantity: Mag_E
   3. In Volume: BrainFluid
   4. Click the Done button

To modify the attributes of a field plot:
1. Select the menu item HFSS > Fields > Modify Plot Attributes
2. Select Plot Folder Window:
   1. Select: E Field
   2. Click the OK button
3. E-Field1 Window:
   1. Click the Scale tab
      1. Select Use Limits
      2. Min: 2
      3. Max: 200
      4. Scale: Log
   2. Click the Close button
Example - Specific Absorption Rate

Far Field Overlays

Create Far Field Overlay

To create a 2D polar far field plot:
1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Far Fields**
   2. Display Type: **Radiation Pattern**
   3. Click the **OK** button
3. Traces Window:
   1. Solution: **Setup1: LastAdaptive**
   2. Geometry: **ff_2d**
   3. In the **Sweeps** tab, select **Phi** under the **Name** column, and on the drop list, select **Theta**. This changes the primary sweep to Theta.
   4. In the **Mag** tab
      1. Category: **Gain**
      2. Quantity: **GainL3Y**
      3. Function: **dB**
      4. Click the **Add Trace** button
   5. Click the **Done** button
Example - CPW Fed Bowtie Antenna

The CPW Fed Bowtie Antenna

- This example is intended to show you how to create, simulate, and analyze a Coplanar Waveguide (CPW) fed Bowtie antenna using the Ansoft HFSS Design Environment.
- A Lumped Port excitation will be used for the CPW feed.

Reference:

Example - CPW Fed Bowtie Antenna

## Design Review
1. The CPW slots and antenna shape will be openings in a metallized plane. Consider how the port will look
2. The antenna will be analyzed over a frequency range of 8 - 12 GHz. How large should the air volume be?

## Getting Started

### Launching Ansoft HFSS
1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft > HFSS 10 program group. Click HFSS 10

### Setting Tool Options
To set the tool options:
- **Note:** In order to follow the steps outlined in this example, verify that the following tool options are set:
  1. Select the menu item *Tools > Options > HFSS Options*
  2. HFSS Options Window:
     1. Click the General tab
        - Use Wizards for data entry when creating new boundaries: ☑ Checked
        - Duplicate boundaries with geometry: ☑ Checked
     2. Click the OK button
  3. Select the menu item *Tools > Options > 3D Modeler Options.*
  4. 3D Modeler Options Window:
     1. Click the Operation tab
        - Automatically cover closed polylines: ☑ Checked
     2. Click the Drawing tab
        - Edit property of new primitives: ☑ Checked
     3. Click the OK button
5.6

Example - CPW Fed Bowtie Antenna

Opening a New Project

To open a new project:

1. In an Ansoft HFSS window, click the On the Standard toolbar, or select the menu item File > New.
2. From the Project menu, select Insert HFSS Design.

Set Solution Type

To set the solution type:

1. Select the menu item HFSS > Solution Type
2. Solution Type Window:
   1. Choose Driven Modal
   2. Click the OK button
Creating the 3D Model

Set Model Units

To set the units:
1. Select the menu item 3D Modeler > Units
2. Set Model Units:
   1. Select Units: mm
   2. Click the OK button

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
   1. Type “Arlon C” in the Search by Name field and select Arlon CuClad 217 (tm) from the table below.
   2. Click the OK button
Create Substrate

To create the substrate:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   X: -17.0, Y: -32, Z: 0.0, Press the Enter key
2. Using the coordinate entry fields, enter the opposite corner of the box
   dX: 34.0, dY: 64.0, dZ: -2.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Sub1
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View or press the CTRL+D key

---

Ansoft High Frequency Structure Simulator v10 User's Guide
Create Copper Cladding

To create the ground:
1. Select the menu item Draw > Rectangle
2. Using the Drawing Plane dropdown, set the current plane to XY
3. Using graphical snapping, draw a rectangle to cover the top face of Sub1
   - First corner snap X: -17.0, Y: -32.0, Z: 0.0
   - Second corner snap dX: 34.0, dY: 64.0, dZ: 0.0

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: CuClad
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View
Assign a Finite Conductivity boundary to the Copper Cladding

To select the rectangle:
1. In the 3D Modeler Design Tree, right-click on Model and select Expand All
2. Find the entry name CuClad under the category Not Assigned and click it to select.

To assign the Finite Conductivity boundary
1. Right-Click on the 3D Modeler view, and select the menu item Assign Boundary > Finite Conductivity
2. Finite Conductivity Boundary window
   1. Name: Cu_bound
   2. Beneath Permeability, Check Use Material
   3. Click the block showing Arlon CuClad 217 (tm) to open the Material Listing
   4. Type “co” in the Name field and select copper from the table below, and click OK
   5. Leave Unchecked Infinite Ground Plane
   6. Click the OK button
Example - CPW Fed Bowtie Antenna

### Create Feed Cut Out

**To create the feed gap:**
1. Select the coordinate entry fields, enter the first corner position
   - X: **-0.5**, Y: **0.5**, Z: **0.0**, Press the **Enter** key
2. Using the coordinate entry fields, enter the diagonal corner:
   - dX: **13.0**, dY: **0.6**, dZ: **0.0**, Press the **Enter** key

**To set the name:**
1. Select the **Attribute** tab from the **Properties** window.
2. Leave the **Value** of **Name** as **Rect1**
3. Click the **OK** button

### Create Bowtie arm

**To create the bowtie polygon:**
1. Select the menu item **Draw > Line**
2. Snap to the first vertex position
   - Location X: **-0.5**, Y: **0.5**, Z: **0.0**
3. Using the coordinate entry fields, enter the second vertex
   - X: **-6.7**, Y: **21.0**, Z: **0.0**, Press the **Enter** key
4. Using the coordinate entry fields, enter the third vertex
   - X: **6.0**, Y: **21.0**, Z: **0.0**, Press the **Enter** key
5. Using the coordinate entry fields, enter the fourth vertex
   - X: **0.5**, Y: **1.1**, Z: **0.0**, Press the **Enter** key
6. Double-click on the starting vertex to finish and close the polyline.

**To set the name:**
1. Select the **Attribute** tab from the **Properties** window.
2. Set the **Value** of **Name** as **Bowtie**
3. Click the **OK** button

**To fit the view:**
1. Select the menu item **View > Fit All > Active View**
Example - CPW Fed Bowtie Antenna

Unite Feed and Bowtie

To select the objects Bowtie and Rect1
1. In the 3D Modeler Design Tree, right-click on Model and select Expand All
2. Under the category Unassigned select Bowtie and Rect1. (Use the CTRL key to select multiple objects)

To complete the bowtie arm:
1. Select the menu item 3D Modeler > Boolean > Unite. (The united object will take the name of the first item selected, Bowtie)

Mirror the Bowtie

To create the other side of the Bowtie:
1. Select the object Bowtie from the 3D Modeler Design Tree
2. Select the menu item Edit > Duplicate > Mirror
3. Set the starting vertex of the mirror normal using the coordinate entry box:
   Location X: 0, Y: 0, Z: 0
4. Set the ending vertex of the mirror normal using the coordinate entry box
   Location dX: 0, dY: 1.0, dZ: 0.0
Open the Bowtie Aperture in the Copper Cladding

To subtract the Bowtie from the Cladding

1. Select the objects Bowtie, Bowtie_1 and CuClad from the 3D Modeler Design Tree
2. Select the menu item **3D Modeler > Boolean > Subtract**
3. Subtract Window
   - Blank Parts: CuClad
   - Tool Parts: Bowtie, Bowtie_1
   - Clone tool objects before subtracting: **Checked**
   - Click the OK button

Assign a Mesh Operation on the Bowtie geometry

To assign the mesh operation:

1. Select the objects Bowtie and Bowtie_1 from the 3D Modeler Design Tree
2. Select the menu item **HFSS > Mesh Operation > Assign > On Selection > Length Based**
3. Element Length Based Refinement Window :
   - Name: Length1
   - Restrict Length of Elements: **Checked**
   - Maximum Length of Elements: 3 mm
   - Restrict the Number of Elements: **Unchecked**
4. Click the OK button
Create the Lumped Port

To draw the port rectangle:
1. Select the menu item **Draw > Rectangle**
2. Using the coordinate entry fields, enter the first corner position
   - X: 12.5, Y: -0.5, Z: 0.0, Press the **Enter** key
3. Using the coordinate entry fields, enter the diagonal corner:
   - dX: -1.0, dY: 1.0, dZ: 0.0, Press the **Enter** key

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. Enter the **Value of Name** as P1
3. Click the **OK** button

To select the object Port1:
1. Select the menu item **Edit > Select > By Name**
2. Select Object Dialog,
   1. Select the objects named: P1
   2. Click the **OK** button
Create the Lumped port, cont.

To assign lumped port excitation

1. Select the menu item HFSS > Excitations > Assign > Lumped Port
2. Lumped Port : General
   1. Name: Port1
   2. Resistance: 50 ohm
   3. Reactance: 0 ohm
   4. Click the Next button
3. Lumped Port : Modes
   1. Number of Modes: 1,
   2. In the row for Mode 1, click None in the Integration Line column and select New Line
   3. Using the coordinate entry fields, enter the vector position
      - X: 12.5, Y: 0.0, Z: 0.0
      - Press the Enter key
   4. Using the coordinate entry fields, enter the vertex
      - dX: -1.0, dY: 0.0, dZ: 0.0
      - Press the Enter key
4. Click the Finish button
Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose vacuum

Create the Air Volume

The analysis will be performed between 8 - 12 GHz. Therefore the minimum distance between the air volume wall and the radiating aperture should be one quarter wavelength at 8 GHz, or \[0.25 \times \left(\frac{3 \times 10^8}{8 \times 10^9}\right) = 9.375\text{mm} \]. The following dimensions round this up to 9.5mm spacing.

To create the air volume
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the starting position
   - X: -17.0, Y: -32.0, Z: -9.5 Press the Enter key
3. Using the coordinate entry fields, enter the diagonal corner:
   - dX: 34.0, dY: 64.0, dZ: 19.0 Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: AirBox
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
Assign the Radiation Boundary

To select the air volume
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: *AirBox*
   2. Click the *OK* button

To assign the boundary:
1. Right-click in the graphical view and select the Menu pick *Assign Boundary > Radiation*
2. For the Value of Name type: *Rad1*
3. Click the *OK* button

Create a Radiation Setup

To define the radiation setup
1. Select the menu item *HFSS > Radiation > Insert Far Field Setup > Infinite Sphere*
2. Far Field Radiation Sphere Setup dialog
   1. Select the *Infinite Sphere* Tab
      1. Name: *ff_all*
      2. Phi: (Start: -90, Stop: 90, Step Size: 10)
      3. Theta: (Start: 0, Stop: 360, Step Size: 10)
   2. Click the *OK* button
Analysis Setup

Creating an Analysis Setup

To create an analysis setup:
1. Select the menu item **HFSS > Analysis Setup > Add Solution Setup**
2. Solution Setup Window:
   1. Click the General tab:
      - Solution Frequency: **10 GHz**
      - Maximum Number of Passes: 6
      - Maximum Delta S: **0.01**
   2. Click the OK button

Adding a Frequency Sweep

To add a frequency sweep:
1. Select the menu item **HFSS > Analysis Setup > Add Sweep**
   1. Select Solution Setup: **Setup1**
   2. Click the OK button
2. Edit Sweep Window:
   1. Sweep Type: **Fast**
   2. Frequency Setup Type: **Linear Step**
      - Start: **8.0GHz**
      - Stop: **12.0GHz**
      - Step: **0.02**
      - Save Fields: ☑ **Checked**
   3. Click the OK button
Example - CPW Fed Bowtie Antenna

- **Save Project**
  - **To save the project:**
    1. In an Ansoft HFSS window, select the menu item *File > Save As*.
    2. From the *Save As* window, type the Filename: *hfss_cpwbowtie*
    3. Click the *Save* button

- **Analyze**

- **Model Validation**
  - **To validate the model:**
    1. Select the menu item *HFSS > Validation Check*
    2. Click the *Close* button
      - **Note:** To view any errors or warning messages, use the Message Manager.

- **Analyze**
  - **To start the solution process:**
    1. Select the menu item *HFSS > Analyze All*
Solution Data

To view the Solution Data:
1. Select the menu item \textit{HFSS > Results > Solution Data}
   - To view the Profile:
     1. Click the \textbf{Profile} Tab.
   - To view the Convergence:
     1. Click the \textbf{Convergence} Tab
     \textbf{Note}: The default view is for convergence is \textbf{Table}. Select the \textbf{Plot} radio button to view a graphical representations of the convergence data.
   - To view the Matrix Data:
     1. Click the \textbf{Matrix Data} Tab
     \textbf{Note}: To view a real-time update of the Matrix Data, set the Simulation to \textbf{Setup1, Last Adaptive} during solution.
2. Click the \textbf{Close} button when done viewing or simulation complete.
Example - CPW Fed Bowtie Antenna

- **Create Reports**
- **Create Modal S-Parameter Plot - Magnitude**

  To create a report:
  1. Select the menu item *HFSS > Results > Create Report*
  2. Create Report Window:
     1. Report Type: *Modal S Parameters*
     2. Display Type: *Rectangular*
     3. Click the **OK** button
  3. Traces Window:
     1. Solution: *Setup1: Sweep1*
     2. Domain: *Sweep*
     3. Click the **Y** tab
        1. Category: *S Parameter*
        2. Quantity: *S(Port1,Port1)*,
        3. Function: *dB*
        4. Click the **Add Trace** button
     4. Click the **Done** button
  4. Select the menu *Report 2D > Mark All Traces*
     1. Click the **Min** button to see the best match displayed
  5. Right-click on the graph and select **Exit Marker Mode**
Create Reports

Create Modal S-Parameter Plot - Impedance

To create a report:

1. Select the menu item HFSS > Results > Create Report
2. Create Report Window:
   1. Report Type: Modal S Parameters
   2. Display Type: Rectangular
   3. Click the OK button
3. Traces Window:
   1. Solution: Setup1: Sweep1
   2. Domain: Sweep
   3. Click the Y tab
      1. Category: Z Parameter
      2. Quantity: Z(Port1,Port1),
      3. Function: re
      4. Click the Add Trace button
      5. Function: im
      6. Click the Add Trace button
      7. In the tabular listing of assigned Traces, click the Y1 entry beside \(\text{im}(Z(Port1,Port1))\) and from the dropdown switch to Y2
4. Click the Done button
5. **Note:** Since a Lumped Port excitation was used, this plot is not deembedded up to the aperture itself.
Far Field Overlays

Create Far Field Overlay

To create a 2D polar far field plot:

1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Far Fields**
   2. Display Type: **Radiation Pattern**
   3. Click the OK button
3. Traces Window:
   1. Solution: **Setup1: Sweep1**
   2. Geometry: **ff_all**
   3. In the **Sweeps** tab:
      1. Select **Phi** under the **Name** column, and on the drop list, select **Theta**. This changes the primary sweep to Theta.
      2. Highlight the second row which now reads **Phi**. Uncheck **All Values** above the list to the right. Highlight only **-90deg** and **0deg** from this list.
      3. Select the row labeled **Freq** and select the frequency **10.44 GHz** from the list.
4. In the **Mag** tab
   1. Category: **Directivity**
   2. Quantity: **DirTotal**
   3. Function: **dB**
   4. Click the **Add Trace** button
5. Click the **Done** button
To create a 3D polar far field plot:

1. Select the menu item `HFSS > Results > Create Report`.
2. Create Report Window:
   1. Report Type: **Far Fields**
   2. Display Type: **3D Polar Plot**
   3. Click the OK button.
3. Traces Window:
   1. Solution: **Setup1: Sweep1**
   2. Geometry: **ff_all**
   3. In the **Sweeps** tab, select the row labeled **Freq** and select the frequency **10.44 GHz** from the list.
4. In the **Mag** tab:
   1. Category: **Gain**
   2. Quantity: **GainTotal**
   3. Function: **dB**
   4. Click the **Add Trace** button.
5. Click the **Done** button.
THIS PAGE INTENTIONALLY LEFT BLANK
5.7 Example - Endfire Antenna Array

The Endfire Waveguide Array

- This example is intended to show you how to create, simulate, and analyze a Waveguide array antenna using the Ansoft HFSS Design Environment.
- A WavePort excitation will be used for the feed.
- PMLs (Perfectly Matched Layers) will be used for the radiation load.
- Master/Slave boundary conditions will be used to create the array.

Reference:

Design Review

1. Instead of modeling the entire array, we will make use of the master/slave boundary conditions and only model a unit cell.
2. Since the Master/Slave boundary conditions also allow us to change the scan angle, we will need a better radiation load on the top of the antenna than a simple radiation boundary condition. We will need to use a PML.

Ansoft HFSS Design Environment

The following features of the Ansoft HFSS Design Environment are used to create this passive device model

- **3D Solid Modeling**
  - Primitives: Box
  - Other: Perfectly Matched Layer (PML)
- **Boundaries/Excitations**
  - Ports: Wave Ports
  - Boundaries: Master/Slave, Impedance
- **Analysis**
  - Sweep: None
- **Results**
  - Cartesian plotting
- **Field Overlays:**
  - Radiation Patterns
- **Optimetrics**
  - Parametric sweep

Getting Started

Launching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft > HFSS 10 program group. Click HFSS 10
Setting Tool Options

To set the tool options:

Note: In order to follow the steps outlined in this example, verify that the following tool options are set:

1. Select the menu item **Tools > Options > HFSS Options**
2. HFSS Options Window:
   1. Click the **General** tab
      - Use Wizards for data entry when creating new boundaries: **Checked**
      - Duplicate boundaries with geometry: **Checked**
   2. Click the **OK** button
3. Select the menu item **Tools > Options > 3D Modeler Options**.
4. 3D Modeler Options Window:
   1. Click the **Operation** tab
      - Automatically cover closed polylines: **Checked**
   2. Click the **Drawing** tab
      - Edit property of new primitives: **Checked**
   3. Click the **OK** button

Opening a New Project

To open a new project:

1. In an Ansoft HFSS window, click the **File > New** on the Standard toolbar, or select the menu item **File > New**.
2. From the **Project** menu, select **Insert HFSS Design**.
5.7

Example - Endfire Antenna Array

- **Set Solution Type**
  - **To set the solution type:**
    1. Select the menu item *HFSS > Solution Type*
    2. Solution Type Window:
       1. Choose *Driven Modal*
       2. Click the OK button

- **Creating the 3D Model**
- **Set Model Units**
  - **To set the units:**
    1. Select the menu item *3D Modeler > Units*
    2. Set Model Units:
       1. Select Units: in
       2. Click the OK button

- **Set Default Material**
  - **To set the default material:**
    1. Using the 3D Modeler Materials toolbar, make sure that vacuum is the default material
**Create Waveguide**

**To create the waveguide:**
1. Select the menu item *Draw > Box*
2. Using the coordinate entry fields, enter the box position
   - X: 0, Y: 0, Z: 0, Press the *Enter* key
3. Using the coordinate entry fields, enter the opposite corner of the box
   - dX: 0.4, dY: 0.9, dZ: 1.0, Press the *Enter* key

**To set the name:**
1. Select the *Attribute* tab from the *Properties* window.
2. For the *Value of Name* type: *waveguide*
3. Click the *OK* button

**To fit the view:**
1. Select the menu item *View > Fit All > Active View* or press the CTRL+D keys
Create Airbox

To create the airbox:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: -0.05, Y: -0.05, Z: 1.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box
   - dX: 0.5, dY: 1.0, dZ: 1.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: airbox
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View
Create PML load

To select the proper face of the airbox:
1. Select the menu item **Edit > Select > Faces**
2. Graphically pick the top face of the airbox that was just created.

To assign the PML boundary
1. Select the menu item **HFSS > Boundaries > PML Setup Wizard**
2. PML Setup Wizard: Cover Objects
   1. Select: **Create PML Cover Objects on Selected Faces**
   2. Uniform Layer Thickness: 0.2in
   3. Click the **Next** button
3. PML Setup Wizard: Material Parameters
   1. Select: **PML Objects accept Free Radiation**
      1. Min Frequency: 9 GHz
      2. Minimum Radiating Distance: 1in
      3. Click the **Next** button
   2. Review settings on the **PML Setup Wizard: Summary page**
   3. Click the **Finish** button

Top face selected  PML added
Example - Endfire Antenna Array

Make the PML object visible

- By default, the PML wizard will turn off visibility of the PML object once it is created. We want to turn it back on again.
  1. Select the menu item View > Active View Visibility
  2. Check the box next to PML_airbox1
  3. Click Done

Create the Master/Slave boundary objects

Set Grid Plane

- To set the grid plane:
  1. Select the menu item 3D Modeler > Grid Plane > YZ

Draw the Master / Slave objects

- To draw the first Master/Slave rectangle:
  1. Select the menu item Draw > Rectangle
  2. Using the coordinate entry fields, enter the box position
     - X: 0.45, Y: -0.05, Z: 1.0, Press the Enter key
  3. Using the coordinate entry fields, enter the opposite corner of the rectangle
     - dX: 0, dY: 1.0, dZ: 1.2, Press the Enter key

  - To set the name:
    1. Select the Attribute tab from the Properties window.
    2. For the Value of Name type: master1
    3. Click the OK button

- To set the grid plane:
  1. Select the menu item 3D Modeler > Grid Plane > XZ

- To draw the second Master/Slave rectangle:
  1. Select the menu item Draw > Rectangle
  2. Using the coordinate entry fields, enter the box position
     - X: -0.05, Y: -0.05, Z: 1.0, Press the Enter key
  2. Using the coordinate entry fields, enter the opposite corner of the rectangle
     - dX: 0.5, dY: 0, dZ: 1.2, Press the Enter key
Create the Master/Slave boundary objects (continued)

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: master2
3. Click the OK button

To duplicate the objects to create the slaves
1. Select the menu item Edit > Select > Objects
2. Select the menu item Edit > Select > By Name
3. Select the object, master1
4. Select the menu item Edit > Duplicate > Along Line
5. Using the coordinate entry fields, enter the start position of the duplicate vector
   - X: 0, Y: 0, Z: 0, Press the Enter key
6. Using the coordinate entry fields, enter the end point of the duplicate vector
   - dX: -0.5, dY: 0, dZ: 0, Press the Enter key
7. When the dialog box pops up requesting the total number of copies, change the value to 2, Press the OK button.
8. Repeat this process for the object master2 using a duplicate vector of <0,1,0>

Change Slave boundary names

To change the duplicated master boundary to slave boundary
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: master1_1
   2. Click the OK button
3. Select the menu Item: Edit > Properties
4. Change the name to: slave1
5. Repeat the process for master2_1 → slave2
### Assign Master/Slave Boundaries

#### To create a Master boundary
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: *master1*
   2. Click the **OK** button
3. Select the menu item *HFSS > Boundaries > Assign > Master*
4. Master Boundary window
   1. Name: *master1*
   2. Coordinate System: U Vector: click **Undefined** pulldown
   3. Using the coordinate entry fields, enter the start position
      - X:0.45, Y: -0.05, Z:1.0, Press the **Enter** key
   4. Using the coordinate entry fields, enter the stop position of the vector
      - dX: 0, dY: 1, dZ: 0, Press the **Enter** key
   5. For the V vector, check the **Reverse Direction** box

#### Repeat the process for master2 using the following points:
1. Using the coordinate entry fields, enter the start position
   - X:0.45, Y: -0.05, Z:1.0, Press the **Enter** key
2. Using the coordinate entry fields, enter the stop position of the vector
   - dX:-0.5, dY: 0, dZ: 0, Press the **Enter** key

#### To create a Slave boundary
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: *slave1*
   2. Click the **OK** button
3. Select the menu item *HFSS > Boundaries > Assign > Slave*
4. Slave Boundary window
   1. Name: *slave1*
   2. Master Boundary: click on **Undefined** pulldown and select **Master1**
   3. Coordinate System: U Vector: click **Undefined** pulldown
   4. Using the coordinate entry fields, enter the start position
      - X:-0.05, Y: -0.05, Z:1.0, Press the **Enter** key
Assign Master / Slave Boundaries (continued)

To create a Slave boundary (continued)

1. Using the coordinate entry fields, enter the stop position of the vector
   - $dX: 0$, $dY: 1$, $dZ: 0$, Press the Enter key
2. Click the Next button
3. Make sure that Use Scan Angles To Calculate Phase Delay is checked
   1. For $\phi$, enter 0 deg
   2. For $\theta$, enter a variable name $\theta_{\text{scan}}$, and hit Enter
   3. For the Add Variable dialog, enter 30deg for $\theta_{\text{scan}}$

Repeat the process for slave2:

1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: slave2
   2. Click the OK button
3. Select the menu item HFSS > Boundaries > Assign > Slave
4. Slave Boundary window
   1. Name: slave2
   2. Master Boundary: click on Undefined pulldown and select Master2
   3. Coordinate System: U Vector: click Undefined pulldown
   4. Using the coordinate entry fields, enter the start position
      - $X: 0.45$, $Y: 0.95$, $Z: 1.0$, Press the Enter key
   5. Using the coordinate entry fields, enter the stop position of the vector
      - $dX: -0.5$, $dY: 0$, $dZ: 0$, Press the Enter key
Assign Impedance Boundary

To create the impedance boundary on the PML object:
1. Select the menu item Edit > Select > Faces
2. Graphically pick the top face of the PML object
3. Select the menu item: HFSS > Boundaries > Assign > Impedance
4. Name: TopLoad
5. Resistance: $377 \times \cos(\theta_{\text{scan}})$
6. Reactance: 0

Create WavePort

To assign waveport to waveguide object:
1. Select the menu item Edit > Select > By Name
2. Select Face dialog: Select the object waveguide from the left column
3. Select different FaceIDs until the bottom face of the waveguide is highlighted.
4. Click OK
Create WavePort (continued)

To assign waveport to waveguide object (continued):
1. Select the menu item HFSS > Excitation > Assign > WavePort
2. Name: p1
3. Click Next
4. Wave Port: Modes
   1. Click Next
5. Wave Port: Post-Processing
   1. Click Finish

Create Facelist for Post-Processing

Far field calculations cannot be made on the impedance surface nor on the PML object. We need to create a facelist on which to calculate the radiation patterns.

To create the facelist:
1. Select the menu item Edit > Select > Faces
2. Select the menu item Edit > Select > By Name
3. Select Face dialog: Select the object airbox from the left column
4. Select different FacelIDs until the top face of the waveguide is highlighted.
5. Click OK
Analysis Setup

Creating an Analysis Setup

To create an analysis setup:
1. Select the menu item HFSS > Analysis Setup > Add Solution Setup
2. Solution Setup Window:
   1. Click the General tab:
      - Solution Frequency: 9.25 GHz
      - Maximum Number of Passes: 5
      - Maximum Delta S: 0.0001
   2. Click the OK button

Create a Radiation Setup

To define the radiation setup
1. Select the menu item HFSS > Radiation > Insert Far Field Setup > Infinite Sphere
2. Far Field Radiation Sphere Setup dialog
   1. Select the Infinite Sphere Tab
      1. Name: ff_all
      2. Phi: (Start: 0, Stop: 0, Step Size: 10)
      3. Theta: (Start: 0, Stop: 360, Step Size: 2)
   2. Switch to the Radiation Surface tab
   3. Make sure that Use Custom Radiation Surface is enabled and Facelist1 has been selected
   4. Click the OK button
Save Project

To save the project:
1. In an Ansoft HFSS window, select the menu item File > Save As.
2. From the Save As window, type the Filename: hfss_pmlarray
3. Click the Save button

Analyze

Model Validation

To validate the model:
1. Select the menu item HFSS > Validation Check
2. Click the Close button
   Note: To view any errors or warning messages, use the Message Manager.

Analyse

To start the solution process:
1. Select the menu item HFSS > Analyze All
Solution Data

To view the Solution Data:

1. Select the menu item **HFSS > Results > Solution Data**
   - **To view the Profile:**
     1. Click the Profile Tab.
   - **To view the Convergence:**
     1. Click the Convergence Tab
     - **Note:** The default view is for convergence is **Table**. Select the Plot radio button to view a graphical representation of the convergence data.
   - **To view the Matrix Data:**
     1. Click the Matrix Data Tab
     - **Note:** To view a real-time update of the Matrix Data, set the Simulation to **Setup1, Last Adaptive** during solution.

2. Click the Close button when done viewing or simulation complete.
Far Field Plots

Create Far Field Plot

To create a 2D polar far field plot:
1. Select the menu item \textit{HFSS > Results > Create Report}.
2. Create Report Window:
   1. Report Type: \textit{Far Fields}.
   2. Display Type: \textit{Radiation Pattern}.
   3. Click the OK button.
3. Traces Window:
   1. Solution: \textit{Setup1: LastAdaptive}.
   2. Geometry: \textit{ff_all}.
   3. In the Sweeps tab:
      1. Select \textit{Phi} under the \textit{Name} column, and on the drop list, select \textit{Theta}. This changes the primary sweep to Theta.
   4. In the Mag tab:
      1. Category: \textit{Directivity}.
      2. Quantity: \textit{DirTotal}.
      3. Function: \textit{dB}.
      4. Click the Add Trace button.
   5. Click the Done button.
### Add Array Factor to Plot

**To setup array factor:**

1. Select the menu item **HFSS > Radiation > Antenna Array Setup**
2. Select the radio button for **Regular Array Setup**
3. Switch to the **Regular Array** tab
4. First Cell Position:
   - X:0in, Y: 0 in, Z:0 in
5. Directions: U vector
   - X:1, Y: 0, Z:0
6. Directions: V Vector
   - X:0, Y: 1, Z:0
7. Distance Between Cells
   - U Direction: **0.5 in**
   - V Direction: **1 in**
8. Number of Cells
   - U Direction: **25**
   - V Direction: **25**
9. Scan Definition: Use Scan Angles
   - Theta: **theta_scan**
   - Phi: **0 deg**

![Antenna Array Setup](image.png)
Example - Endfire Antenna Array

Add Array Factor to Plot (continued)

![Graph of an endfire antenna array pattern](image)
Optimetrics Setup - Parametric Sweep

For this array design, we want to see the effect of scan angle on the input match of the antenna. To do this, we must sweep the scan angle with a parametric sweep.

Add a Parametric Sweep

1. Select the menu item **HFSS > Optimetrics Analysis > Add Parametric**
2. Setup **Sweep Analysis** Window:
   1. Click the **Sweep Definitions** tab:
      1. Click the **Add** button
      2. Add/Edit Sweep Dialog
         1. Select Variable: **theta_scan** (this is the only variable defined, so it is greyed out)
         2. Select **Linear Step**
         3. Start: **0deg**
         4. Stop: **60deg**
         5. Step: **10deg**
      6. Click the **Add** button
      7. Click the **OK** button

Analyze Parametric Sweep

To start the solution process:

1. Expand the Project Tree to display the items listed under **Optimetrics**
2. Right-click the mouse on **ParametricSetup1** and choose **Analyze**

Optimetrics Results

To view the Optimetrics Results:

1. Select the menu item **HFSS > Optimetrics Analysis > Optimetrics Results**
2. Select the **Profile** Tab to view the solution progress for each setup.
3. Click the **Close** button when you are finished viewing the results
Create S-Parameter Plot - S11 at each $\theta$

To create a report:
1. Select the menu item *HFSS > Results > Create Report*
2. Create Report Window:
   1. Report Type: *Modal S Parameters*
   2. Display Type: *Rectangular Plot*
   3. Click the OK button
3. Traces Window:
   1. Solution: *Setup1: LastAdaptive*
   2. Click the *Sweeps* tab
      1. Select *Sweep Design and Project variable values*
   3. In the *Sweeps* tab:
      1. Select *Freq* under the *Name* column, and on the drop list, select *theta_scan*. This changes the primary sweep to *theta_scan*.
   4. Click the Y tab
      1. Category: *S Parameter*
      2. Quantity: *S(p1,p1)*
      3. Function: *dB*
      4. Click the *Add Trace* button
4. Click the *Done* button
Chapter 6.0 - Microwave Examples

6.1 - Magic T
6.2 - Coax Bend
6.3 - Ring Hybrid
6.4 - Coax Stub
  - Includes Optimetrics Example
6.5 - Microstrip - Wave Ports
  - Includes Optimetrics Example
6.6 - Dielectric Resonator
THIS PAGE INTENTIONALLY LEFT BLANK
The Magic T

This example is intended to show you how to create, simulate, and analyze a Magic T, which is a commonly used microwave device, using the Ansoft HFSS Design Environment.

Nominal Design:

Waveguide:
- Width = 50.0 mm
- Height = 20.0 mm
- Length = 50.0 mm
### Ansoft HFSS Design Environment

- The following features of the Ansoft HFSS Design Environment are used to create this passive device model
  - **3D Solid Modeling**
    - Primitives: *Box*
    - Boolean Operations: *Unite, Duplicate*
  - **Excitations**
    - Ports: *Wave Ports*
  - **Analysis**
    - Sweep: *Fast Frequency*
  - **Results**
    - *Cartesian plotting*
  - **Fields**
    - *3D Field Plots, Animations*
Getting Started

Launching Ansoft HFSS
1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft, HFSS 10 program group. Click HFSS 10.

Setting Tool Options
1. To set the tool options:
   Note: In order to follow the steps outlined in this example, verify that the following tool options are set:
   1. Select the menu item Tools > Options > HFSS Options
   2. HFSS Options Window:
      1. Click the General tab
         Use Wizards for data entry when creating new boundaries: ✔ Checked
         Duplicate boundaries with geometry: ✔ Checked
      2. Click the OK button
   3. Select the menu item Tools > Options > 3D Modeler Options.
   4. 3D Modeler Options Window:
      1. Click the Operation tab
         Automatically cover closed polylines: ✔ Checked
      2. Click the Drawing tab
         Edit property of new primitives: ✔ Checked
      3. Click the OK button
6.1-4

Opening a New Project

To open a new project:
1. In an Ansoft HFSS window, click the \( \text{File} \) button on the Standard toolbar, or select the menu item \textit{File > New}.
2. From the \textit{Project} menu, select \textit{Insert HFSS Design}.

Set Solution Type

To set the solution type:
1. Select the menu item \textit{HFSS > Solution Type}
2. Solution Type Window:
   1. Choose \textbf{Driven Modal}
   2. Click the \textbf{OK} button
Creating the 3D Model

Set Model Units

To set the units:
1. Select the menu item 3D Modeler > Units
2. Set Model Units:
   1. Select Units: mm
   2. Click the OK button

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose vacuum

Create Top Arm

To create arm 1:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   X: -25.0, Y: -10.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   dX: 50.0, dY: 20.0, dZ: 75.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Arm
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
   Or press the CTRL+D key
Create Wave Port Excitation 1

Picking the port face:
1. Select the menu item Edit > Select > Faces
2. Graphically select the top face of the arm at Z=75mm

To assign wave port excitation
1. Select the menu item HFSS > Excitations > Assign > Wave Port
2. Wave Port : General
   1. Name: p1
   2. Click the Next button
3. Wave Port : Modes
   1. Click the Next button
4. Wave Port : Post Processing
   1. Click the Finish button
Set Object Selection

Set select to objects
1. Select the menu item Edit > Select > Objects

Create Arm 2

To create arm 2:
1. Select the menu item Edit > Select All Visible. Or press the CTRL+A key.
2. Select the menu item, Edit > Duplicate > Around Axis.
   1. Axis: X
   2. Angle: 90
   3. Total Number: 2
   4. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Create Arm 3 & 4

To select the object Arm_1:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Arm_1
   2. Click the OK button

To create arm 3 & 4:
1. Select the menu item, Edit > Duplicate > Around Axis.
   1. Axis: Z
   2. Angle: 90
   3. Total Number: 3
   4. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
6.1-8

Group the Arms

To group the arms:
1. Select the menu item Edit > Select All Visible. Or press the CTRL+A key.
2. Select the menu item, 3D Modeler > Boolean > Unite

To fit the view:
1. Select the menu item View > Fit All > Active View.

Boundary Display

To verify the boundary setup:
1. Select the menu item HFSS > Boundary Display (Solver View)
2. From the Solver View of Boundaries, toggle the Visibility check box for the boundaries you wish to display.
   - **Note:** The background (Perfect Conductor) is displayed as the outer boundary.
   - **Note:** The Perfect Conductors are displayed as the smetal boundary.
   - **Note:** Select the menu item, View > Visibility to hide all of the geometry objects. This makes it easier to see the boundary
3. Click the Close button when you are finished
Analysis Setup

Creating an Analysis Setup

To create an analysis setup:
1. Select the menu item HFSS > Analysis Setup > Add Solution Setup
2. Solution Setup Window:
   1. Click the General tab:
      ▲ Solution Frequency: 4.0GHz
      ▲ Maximum Number of Passes: 5
      ▲ Maximum Delta S per Pass: 0.02
   2. Click the OK button

Adding a Frequency Sweep

To add a frequency sweep:
1. Select the menu item HFSS > Analysis Setup > Add Sweep
   1. Select Solution Setup: Setup1
   2. Click the OK button
2. Edit Sweep Window:
   1. Sweep Type: Fast
   2. Frequency Setup Type: Linear Count
      ▲ Start: 3.4GHz
      ▲ Stop: 4.0GHz
      ▲ Count: 1001
      ▲ Save Fields: ☐ Checked
   3. Click the OK button
Save Project

To save the project:
1. In an Ansoft HFSS window, select the menu item File > Save As.
2. From the Save As window, type the Filename: hfss_magic_t
3. Click the Save button

Analyze

Model Validation

To validate the model:
1. Select the menu item HFSS > Validation Check
2. Click the Close button
   Note: To view any errors or warning messages, use the Message Manager.

Analyze

To start the solution process:
1. Select the menu item HFSS > Analyze
Solution Data

To view the Solution Data:

1. Select the menu item HFSS > Results > Solution Data

   To view the Profile:
   
   1. Click the Profile Tab.

   To view the Convergence:
   
   1. Click the Convergence Tab

   **Note:** The default view is for convergence is Table. Select the Plot radio button to view a graphical representations of the convergence data.

To view the Matrix Data:

1. Click the Matrix Data Tab

   **Note:** To view a real-time update of the Matrix Data, set the Simulation to Setup1, Last Adaptive

2. Click the Close button
Create Reports

Create S-Parameter Plot vs. Adaptive Pass

Note: If this report is created prior or during the solution process, a real-time update of the results are displayed.

To create a report:

1. Select the menu item HFSS > Results > Create Report
2. Create Report Window:
   1. Report Type: Modal S Parameters
   2. Display Type: Rectangular
   3. Click the OK button
3. Traces Window:
   1. Solution: Setup1: Adaptive1
   2. Click the X tab
      1. Use Primary Sweep: Unchecked
      2. Category: Variables
      3. Quantity: Pass
   3. Click the Y tab
      1. Category: S Parameter
      2. Quantity: S(p1,p1), S(p1,p2), S(p1,p3), S(p1,p4)
      3. Function: dB
      4. Click the Add Trace button
4. Click the Done button
Create S-Parameter Plot

To create a report:

1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Modal S Parameters**
   2. Display Type: **Rectangular**
   3. Click the **OK** button
3. Traces Window:
   1. Solution: **Setup1: Sweep1**
   2. Domain: **Sweep**
   3. Click the **Y** tab
      1. Category: **S Parameter**
      2. Quantity: \( S(p1,p1), S(p1,p2), S(p1,p3), S(p1,p4) \)
      3. Function: **dB**
      4. Click the **Add Trace** button
4. Click the **Done** button
Create Field Overlay

To select an object:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Arm
   2. Click the OK button
3. Select the menu item HFSS > Fields > Fields > E > Mag_E
4. Create Field Plot Window
   1. Solution: Setup1 : LastAdaptive
   2. Quantity: Mag_E
   3. In Volume: All
   4. Click the Done button

To modify the attributes of a field plot:
1. Select the menu item HFSS > Fields > Modify Plot Attributes
2. Select Plot Folder Window:
   1. Select: E Field
   2. Click the OK button
3. E-Field Window:
   1. Click the Plot tab
      1. IsoValType: IsoValSurface
      2. Click the Apply button.
   4. Click the Close button

Field Animations

To Animate a Magnitude field plot:
1. Select the menu item View > Animate
2. In the Swept Variable tab, accept the defaults settings:
   1. Swept variable: Phase
   2. Start: 0deg
   3. Stop: 180deg
   4. Steps: 9
3. Click OK
The Coaxial Connector

This example is intended to show you how to create, simulate, and analyze a coaxial connector, using the Ansoft HFSS Design Environment.
Example - Coaxial Connector

- **Ansoft HFSS Design Environment**
  - The following features of the Ansoft HFSS Design Environment are used to create this passive device model
    - **3D Solid Modeling**
      - Primitives: Cylinders, Polylines, Circles
      - Boolean Operations: Unite, Subtract, and Sweep
    - **Boundaries/Excitations**
      - Ports: Wave Ports and Terminal Lines
    - **Analysis**
      - Sweep: Fast Frequency
    - **Results**
      - Cartesian plotting
    - **Field Overlays:**
      - 3D Field Plots, Animations, Cut-Planes
6.2

Example - Coaxial Connector

△ Getting Started

△ Launching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft **Start** button, select **Programs**, and select the **Ansoft, HFSS 10** program group. Click **HFSS 10**.

△ Setting Tool Options

△ To set the tool options:

△ **Note:** In order to follow the steps outlined in this example, verify that the following tool options are set:

1. Select the menu item **Tools > Options > HFSS Options**
2. HFSS Options Window:
   1. Click the **General** tab
      △ Use Wizards for data entry when creating new boundaries: ✓ Checked
      △ Duplicate boundaries with geometry: ✓ Checked
   2. Click the **OK** button
3. Select the menu item **Tools > Options > 3D Modeler Options**.
4. 3D Modeler Options Window:
   1. Click the **Operation** tab
      △ Automatically cover closed polylines: ✓ Checked
   2. Click the **Drawing** tab
      △ Edit property of new primitives: ✓ Checked
   3. Click the **OK** button
6.2  
Example - Coaxial Connector

Opening a New Project

To open a new project:
1. In an Ansoft HFSS window, click the \( \text{File} > \text{New} \) on the Standard toolbar, or select the menu item \( \text{File} > \text{New} \).
2. From the \textit{Project} menu, select \textit{Insert HFSS Design}.

![Project Window](image)

Set Solution Type

To set the solution type:
1. Select the menu item \( \text{HFSS} > \text{Solution Type} \)
2. Solution Type Window:
   1. Choose \textit{Driven Terminal}
   2. Click the \textit{OK} button

![Solution Type Window](image)
Creating the 3D Model

Set Model Units

To set the units:
1. Select the menu item **3D Modeler > Units**
2. Set Model Units:
   1. Select Units: **cm**
   2. Click the **OK** button

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose **Select**
2. Select Definition Window:
   1. Type **pec** in the **Search by Name** field
   2. Click the **OK** button
**Create the Conductor 1**

**To create the conductor**

1. Select the menu item *Draw > Cylinder*.
2. Using the coordinate entry fields, enter the cylinder position
   - X: 0.0, Y: 0.0, Z: 0.0, Press the **Enter** key
   - ![Coordinate Entry Fields](coordinate_entry_fields.png)
3. Using the coordinate entry fields, enter the radius:
   - dX: 0.152, dY: 0.0, dZ: 0.0, Press the **Enter** key
   - ![Coordinate Entry Fields](coordinate_entry_fields.png)
4. Using the coordinate entry fields, enter the height:
   - dX: 0.0, dY: 0.0, dZ: 1.448, Press the **Enter** key
   - ![Coordinate Entry Fields](coordinate_entry_fields.png)

**To set the name:**

1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value** of **Name** type: **Conductor1**
3. Click the **OK** button

**To fit the view:**

1. Select the menu item *View > Fit All > Active View*.
   Or press the **CTRL+D** key

---

**Create Offset Coordinate System**

**To create an offset Coordinate System:**

1. Select the menu item *3D Modeler > Coordinate System > Create > Relative CS > Offset*
2. Using the coordinate entry fields, enter the origin
   - X: 0.0, Y: 0.0, Z: 1.448, Press the **Enter** key

---

**Create a Section**

**To section the conductor**

1. Select the menu item *Edit > Select All Visible*. Or press the **CTRL+A** key.
2. Select the menu item *3D Modeler > Surface > Section*
3. Section Window
   - Section Plane: XY
   - Click the **OK** button
**Example - Coaxial Connector**

### Rename the Section

**To set the name:**
1. Select the menu item **HFSS > List**
2. From the **Model** tab, select the object named **Section1**
3. Click the **Properties** button
   1. For the **Value of Name** type: **Bend**
   2. Click the **OK** button
4. Click the **Done** button

### Set Grid Plane

**To set the grid plane:**
1. Select the menu item **3D Modeler > Grid Plane > YZ**

### Create Conductor Bend

**To create the bend:**
1. Select the menu item **Draw > Arc > Center Point**
2. Using the coordinate entry fields, enter the vertex point:
   - **X:** 0.0, **Y:** 0.4, **Z:** 0.0, Press the **Enter** key
3. Using the coordinate entry fields, enter the radial point:
   - **X:** 0.0, **Y:** 0.0, **Z:** 0.0, Press the **Enter** key
4. Using the coordinate entry fields, enter the sweep arc length:
   - **X:** 0.0, **Y:** 0.4, **Z:** 0.4, Press the **Enter** key
5. Using the mouse, right-click and select **Done**
6. Click the **OK** button when the Properties dialog appears

**Sweep Bend:**
1. Select the menu item **Edit > Select > By Name**
2. Select Object Dialog,
   1. Select the objects named: **Bend, Polyline1**
   2. Click the **OK** button
3. Select the menu item **Draw > Sweep > Along Path**
4. Sweep along path Window
   - **Angle of twist:** 0
   - **Draft Angle:** 0
   - **Draft Type:** Round
   - Click the **OK** button
### Set Grid Plane

**To set the grid plane:**
1. Select the menu item *3D Modeler > Grid Plane > XZ*

### Create Offset Coordinate System

**To create an offset Coordinate System:**
1. Select the menu item *3D Modeler > Coordinate System > Create > Relative CS > Offset*
2. Using the coordinate entry fields, enter the origin
   - X: 0.0, Y: 0.4, Z: 0.4, Press the **Enter** key

### Create the Conductor 2

**To create the conductor**
1. Select the menu item *Draw > Cylinder*
2. Using the coordinate entry fields, enter the cylinder position
   - X: 0.0, Y: 0.0, Z: 0.0, Press the **Enter** key
3. Using the coordinate entry fields, enter the radius:
   - dX: 0.152, dY: 0.0, dZ: 0.0, Press the **Enter** key
4. Using the coordinate entry fields, enter the height:
   - dX: 0.0, dY: 0.436, dZ: 0.0, Press the **Enter** key
**To set the name:**
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value** of **Name** type: **Conductor2**
3. Click the **OK** button
**To fit the view:**
1. Select the menu item *View > Fit All > Active View.*

### Create Offset Coordinate System

**To create an offset Coordinate System:**
1. Select the menu item *3D Modeler > Coordinate System, Relative CS > Offset*
2. Using the coordinate entry fields, enter the origin
   - X: 0.0, Y: 0.436, Z: 0.0, Press the **Enter** key
Create the Conductor 3

To create the conductor

1. Select the menu item **Draw > Cylinder**
2. Using the coordinate entry fields, enter the cylinder position
   - X: 0.0, Y: 0.0, Z: 0.0, Press the **Enter** key
3. Using the coordinate entry fields, enter the radius:
   - dx: 0.225, dy: 0.0, dz: 0.0, Press the **Enter** key
4. Using the coordinate entry fields, enter the height:
   - dx: 0.0, dy: 1.3, dz: 0.0, Press the **Enter** key

To set the name:

1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: **Conductor3**
3. Click the **OK** button

To fit the view:

1. Select the menu item **View > Fit All > Active View.**

Group the Conductors

To group the conductors:

1. Select the menu item **Edit > Select All Visible.** Or press the CTRL+A key.
2. Select the menu item, **3D Modeler > Boolean > Unite**

To fit the view:

1. Select the menu item **View > Fit All > Active View.**

Set Default Material

To set the default material:

1. Using the 3D Modeler Materials toolbar, choose **vacuum**
Create the Female End

To create the female end:
1. Select the menu item **Draw > Cylinder**
2. Using the coordinate entry fields, enter the cylinder position
   - X: 0.0, Y: 0.0, Z: 0.0, Press the **Enter** key
3. Using the coordinate entry fields, enter the radius:
   - dX: 0.511, dY: 0.0, dZ: 0.0, Press the **Enter** key
4. Using the coordinate entry fields, enter the height:
   - dX: 0.0, dY: 1.3, dZ: 0.0, Press the **Enter** key

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the Value of Name type: Female
3. Click the **OK** button

To fit the view:
1. Select the menu item **View > Fit All > Active View**.

Create the Female Bend

To create the bend:
1. Select the menu item **Draw > Cylinder**
2. Using the coordinate entry fields, enter the cylinder position
   - X: 0.0, Y: 0.0, Z: 0.0, Press the **Enter** key
3. Using the coordinate entry fields, enter the radius:
   - dX: 0.351, dY: 0.0, dZ: 0.0, Press the **Enter** key
4. Using the coordinate entry fields, enter the height:
   - dX: 0.0, dY: -1.236, dZ: 0.0, Press the **Enter** key

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the Value of Name type: FemaleBend
3. Click the **OK** button

To fit the view:
1. Select the menu item **View > Fit All > Active View**.
Example - Coaxial Connector

### Set Working Coordinate System

To set the working coordinate system:
1. Select the menu item *3D Modeler > Coordinate System > Set Working CS*
2. Select Coordinate System Window,
   1. From the list, select the CS: *Global*
   2. Click the *Select* button

### Set Grid Plane

To set the grid plane:
1. Select the menu item *3D Modeler > Grid Plane > XY*

### Create the Male End

To create the male end:
1. Select the menu item *Draw > Cylinder*
2. Using the coordinate entry fields, enter the cylinder position
   - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the radius:
   - dX: 0.351, dY: 0.0, dZ: 0.0, Press the Enter key
4. Using the coordinate entry fields, enter the height:
   - dX: 0.0, dY: 0.0, dZ: 2.348, Press the Enter key

To set the name:
1. Select the *Attribute* tab from the *Properties* window.
2. For the *Value of Name* type: *Male*
3. Click the *OK* button

To fit the view:
1. Select the menu item *View > Fit All > Active View*.
6.2 Example - Coaxial Connector

Group the Vacuum Objects

To unite the objects Female, FemaleBend and Male:
1. Select the menu item **Edit > Select > By Name**
2. Select Object Dialog,
   1. Select the objects named: Female, FemaleBend, Male
   2. Click the OK button
3. Select the menu item, **3D Modeler > Boolean > Unite**

To fit the view:
1. Select the menu item **View > Fit All > Active View.**

Add New Material

To add a new material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. From the Select Definition window, click the Add Material button
3. View/Edit Material Window:
   1. For the **Material Name** type: My_Ring
   2. For the **Value of Relative Permittivity** type: 3
   3. Click the OK button
4. Click the OK button
Create the Ring

To create the ring:
1. Select the menu item Draw > Cylinder
2. Using the coordinate entry fields, enter the cylinder position
   - X: 0.0, Y: 0.0, Z: 0.736, Press the Enter key
3. Using the coordinate entry fields, enter the radius:
   - dX: 0.511, dY: 0.0, dZ: 0.0, Press the Enter key
4. Using the coordinate entry fields, enter the height:
   - dX: 0.0, dY: 0.0, dZ: 0.236, Press the Enter key

To set the name:
1. Select the menu item Draw > Cylinder
2. For the Value of Name type: Ring
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View

Complete the Ring

To select the objects Ring and Male:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Ring, Female
   2. Click the OK button

To complete the ring:
1. Select the menu item 3D Modeler > Boolean > Subtract
2. Subtract Window
   - Blank Parts: Ring
   - Tool Parts: Female
   - Clone tool objects before subtract: ✔ Checked
   - Click the OK button
### Add New Material

#### To add a new material:
1. Using the 3D Modeler Materials toolbar, choose **Select**
2. From the Select Definition window, click the **Add Material** button
3. View/Edit Material Window:
   1. For the **Material Name** type: **My_Teflon**
   2. For the **Value of Relative Permittivity** type: **2.1**
   3. Click the **OK** button
4. Click the **OK** button

### Create the Male Teflon

#### To create the teflon:
1. Select the menu item **Draw > Cylinder**
2. Using the coordinate entry fields, enter the cylinder position
   - X: **0.0**, Y: **0.0**, Z: **0.46**, Press the **Enter** key
3. Using the coordinate entry fields, enter the radius:
   - dX: **0.511**, dY: **0.0**, dZ: **0.0**, Press the **Enter** key
4. Using the coordinate entry fields, enter the height:
   - dX: **0.0**, dY: **0.0**, dZ: **0.788**, Press the **Enter** key

#### To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: **MaleTeflon**
3. Click the **OK** button

#### To fit the view:
1. Select the menu item **View > Fit All > Active View.**
Create Wave Port Excitation 1

Note: To simplify the instructions, a 2D object will be created to represent the port. This is not a requirement for defining ports. Graphical face selection can be used as an alternative.

To create a circle that represents the port:
1. Select the menu item Draw > Circle
2. Using the coordinate entry fields, enter the center position X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the radius of the circle: dX: 0.351, dY: 0.0, dZ: 0.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: p1
3. Click the OK button

To select the object p1:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: p1
   2. Click the OK button

Note: You can also select the object from the Model Tree

![Model Tree Diagram]
6.2 Example – Coaxial Connector

Create Wave Port Excitation 1 (Continued)

To assign wave port excitation
1. Select the menu item *HFSS > Excitations > Assign > Wave Port*
2. Wave Port: General
   1. Name: *p1*,
   2. Click the **Next** button
3. Wave Port: Terminals
   1. Number of Terminals: *1*,
   2. For T1, click the *Undefined* column and select *New Line*
   3. Using the coordinate entry fields, enter the vector position
      - X: *0.351*, Y: *0.0*, Z: *0.0*, Press the **Enter** key
   4. Using the coordinate entry fields, enter the vertex
      - dX: *-0.199*, dY: *0.0*, dZ: *0.0*, Press the **Enter** key
   5. Click the **Next** button
4. Wave Port: Differential Pairs
   1. Click the **Next** button
5. Wave Port: Post Processing
   1. Full Port Impedance: *50*
6. Click the **Finish** button

Set Working Coordinate System

To set the working coordinate system:
1. Select the menu item *3D Modeler > Coordinate System > Set Working CS*
2. Select Coordinate System Window,
   1. From the list, select the CS: *RelativeCS3*
   2. Click the **Select** button

Set Grid Plane

To set the grid plane:
1. Select the menu item *3D Modeler > Grid Plane > XZ*
Example - Coaxial Connector

Create Wave Port Excitation 2

**Note:** To simplify the instructions, a 2D object will be created to represent the port. This is not a requirement for defining ports. Graphical face selection can be used as an alternative.

**To create a circle that represents the port:**
1. Select the menu item *Draw > Circle*
2. Using the coordinate entry fields, enter the center position
   - X: **0.0**, Y: **1.3**, Z: **0.0**, Press the **Enter** key
3. Using the coordinate entry fields, enter the radius of the circle:
   - dX: **0.511**, dY: **0.0**, dZ: **0.0**, Press the **Enter** key

**To set the name:**
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value** of **Name** type: **p2**
3. Click the **OK** button

**To select the object p2:**
1. Select Object Dialog,
   1. Select the objects named: **p2**
   2. Click the **OK** button
6.2 Example - Coaxial Connector

△ Create Wave Port Excitation 2 (Continued)

△ To assign wave port excitation
1. Select the menu item *HFSS > Excitations > Assign > Wave Port*
2. Wave Port : General
   1. Name: *p2*,
   2. Click the Next button
3. Wave Port : Terminals
   1. Number of Terminals: 1,
   2. For T1, click the Undefined column and select New Line
   3. Using the coordinate entry fields, enter the vector position
      △ X: 0.511, Y: 1.3, Z: 0.0, Press the Enter key
   4. Using the coordinate entry fields, enter the vertex
      △ dX: -0.286, dY: 0.0, dZ: 0.0, Press the Enter key
   5. Click the Next button
4. Wave Port : Differential Pairs
   1. Click the Next button
5. Wave Port : Post Processing
   1. Full Port Impedance : 50
   2. Click the Finish button
Create the Female Teflon

To create the Teflon:
1. Select the menu item *Draw > Cylinder*
2. Using the coordinate entry fields, enter the cylinder position
   - **X:** 0.0, **Y:** 0.0, **Z:** 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the radius:
   - **dX:** 0.511, **dY:** 0.0, **dZ:** 0.0, Press the Enter key
4. Using the coordinate entry fields, enter the height:
   - **dX:** 0.0, **dY:** -0.236, **dZ:** 0.0, Press the Enter key

To set the name:
1. Select the menu item *Attribute* tab from the *Properties* window.
2. For the *Value of Name* type: *FemaleTeflon*
3. Click the *OK* button

To fit the view:
1. Select the menu item *View > Fit All > Active View*.

Complete the Vacuum Object

To select the objects Female, MaleTeflon, FemaleTeflon
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: *Female, MaleTeflon, FemaleTeflon*
   2. Click the *OK* button

To complete the vacuum objects:
1. Select the menu item *3D Modeler > Boolean > Subtract*
2. Subtract Window
   - Blank Parts: *Female*
   - Tool Parts: *MaleTeflon, FemaleTeflon*
   - Clone tool objects before subtract: ✔ *Checked*
   - Click the *OK* button
Example - Coaxial Connector

Complete the Model

To complete the model:
1. Select the menu item **Edit > Select > By Name**
2. Select Object Dialog,
   1. Select the objects named: Conductor1, Female, MaleTeflon, FemaleTeflon
   2. Click the OK button
3. Select the menu item **3D Modeler > Boolean > Subtract**
4. Subtract Window
   ▲ Blank Parts: Female, FemaleTeflon, MaleTeflon
   ▲ Tool Parts: Conductor1
   ▲ Clone tool objects before subtract: ☑ Checked
   ▲ Click the OK button

Boundary Display

To verify the boundary setup:
1. Select the menu item **HFSS > Boundary Display (Solver View)**
2. From the Solver View of Boundaries, toggle the Visibility check box for the boundaries you wish to display.
   ▲ **Note:** The background (Perfect Conductor) is displayed as the outer boundary.
   ▲ **Note:** The Perfect Conductors are displayed as the smetal boundary.
   ▲ **Note:** Select the menu item, **View > Visibility** to hide all of the geometry objects. This makes it easier to see the boundary
3. Click the Close button when you are finished

Solver View of Boundaries

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Solver Visibility</th>
<th>Visibility</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>User Defined</td>
<td>Visible to solver</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>User Defined</td>
<td>Visible to solver</td>
<td></td>
<td></td>
</tr>
<tr>
<td>outer</td>
<td>Default</td>
<td>Visible to solver</td>
<td></td>
<td></td>
</tr>
<tr>
<td>smetal</td>
<td>Default</td>
<td>Visible to solver</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Analysis Setup

Creating an Analysis Setup

To create an analysis setup:
1. Select the menu item **HFSS > Analysis Setup > Add Solution Setup**
2. Solution Setup Window:
   1. Click the General tab:
      - Solution Frequency: \textbf{8.1GHz}
      - Maximum Number of Passes: \textbf{10}
      - Maximum Delta S: \textbf{0.02}
   2. Click the **OK** button
3. Click the Options tab:
   - Minimum Converged Passes: \textbf{2}
4. Click the **OK** button

Adding a Frequency Sweep

To add a frequency sweep:
1. Select the menu item **HFSS > Analysis Setup > Add Sweep**
   1. Select Solution Setup: **Setup1**
   2. Click the **OK** button
2. Edit Sweep Window:
   1. Sweep Type: **Fast**
   2. Frequency Setup Type: **Linear Count**
      - Start: \textbf{0.1GHz}
      - Stop: \textbf{8.1GHz}
      - Count: \textbf{801}
      - Save Fields: \textbf{Checked}
   3. Click the **OK** button
Example - Coaxial Connector

Save Project

To save the project:
1. In an Ansoft HFSS window, select the menu item File > Save As.
2. From the Save As window, type the Filename: hfss_coax
3. Click the Save button

Analyze

Model Validation

To validate the model:
1. Select the menu item HFSS > Validation Check
2. Click the Close button
   
   Note: To view any errors or warning messages, use the Message Manager.

Analyze

To start the solution process:
1. Select the menu item HFSS > Analyze
Example - Coaxial Connector

Solution Data

To view the Solution Data:
1. Select the menu item \textit{HFSS > Results > Solution Data}

To view the Profile:
1. Click the \textbf{Profile} Tab.

To view the Convergence:
1. Click the \textbf{Convergence} Tab.
   - \textbf{Note}: The default view is for convergence is \textbf{Table}. Select the \textbf{Plot} radio button to view a graphical representation of the convergence data.

To view the Matrix Data:
1. Click the \textbf{Matrix Data} Tab.
   - \textbf{Note}: To view a real-time update of the Matrix Data, set the Simulation to \textbf{Setup1, Last Adaptive}

2. Click the \textbf{Close} button.
Create Reports

Create Terminal S-Parameter Plot vs. Adaptive Pass

Note: If this report is created prior to or during the solution process, a real-time update of the results are displayed

To create a report:
1. Select the menu item HFSS > Results > Create Report
2. Create Report Window:
   1. Report Type: Terminal S Parameters
   2. Display Type: Rectangular
   3. Click the OK button
3. Traces Window:
   1. Solution: Setup1: Adaptive1
   2. Click the X tab
      1. Use Primary Sweep: unchecked
      2. Category: Variables
      3. Quantity: Pass
   3. Click the Y tab
      1. Category: Terminal S Parameter
      2. Quantity: St(p1,p1), St(p1,p2),
      3. Function: dB
      4. Click the Add Trace button
   4. Click the Done button
6.2

Example - Coaxial Connector

Create Terminal S-Parameter Plot - Magnitude

To create a report:
1. Select the menu item HFSS > Results > Create Report
2. Create Report Window:
   1. Report Type: Terminal S Parameters
   2. Display Type: Rectangular
   3. Click the OK button
3. Traces Window:
   1. Solution: Setup1: Sweep1
   2. Domain: Sweep
   3. Click the Y tab
      1. Category: Terminal S Parameter
      2. Quantity: St(p1,p1), St(p1,p2),
      3. Function: dB
      4. Click the Add Trace button
4. Click the Done button
Example - Coaxial Connector

**Create Terminal S-Parameter Plot - Phase**

To create a report:
1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Terminal S Parameters**
   2. Display Type: **Rectangular**
   3. Click the **OK** button
3. Traces Window:
   1. Solution: **Setup1: Sweep1**
   2. Domain: **Sweep**
   3. Click the **Y** tab
   1. Category: **Terminal S Parameter**
   2. Quantity: **St(p1,p1), St(p1,p2)**
   3. Function: **ang_deg**
   4. Click the **Add Trace** button
4. Click the **Done** button
## Field Overlays

### Create Field Overlay

**To create a field plot:**
1. Select the Global YZ Plane
   1. Using the Model Tree, expand **Planes**
   2. Select **Global:YZ**
2. Select the menu item **HFSS > Fields > Fields > E > Mag_E**
3. Create Field Plot Window
   1. Solution: **Setup1 : LastAdaptive**
   2. Quantity: **Mag_E**
   3. In Volume: **All**
   4. Click the **Done** button

**To modify a Magnitude field plot:**
1. Select the menu item **HFSS > Fields > Modify Plot Attributes**
2. Select Plot Folder Window:
   1. Select: **E Field**
   2. Click the **OK** button
3. E-Field Window:
   1. Click the **Scale** tab
      1. Select **Use Limits**
      2. Min: **1.0**
      3. Max: **1000.0**
      4. Scale: **Log**
   2. Click the **Close** button
Example - Coaxial Connector

Edit Sources

To Modify a Terminal excitation:
1. Select the menu item HFSS > Fields > Edit Sources
2. Select p2:T1 from the Edit Sources window
   - Check the Terminated box
3. Click the OK button

To Select the Electric Field plot:
1. Expand the Project tree
2. Expand the Field Overlays
3. Click on the E Field or Mag_E1 to display the field plot

Field Animations

To Animate a Magnitude field plot:
1. Select the menu item View > Animate
2. In the Swept Variable tab, accept defaults settings:
   1. Swept variable: Phase
   2. Start: 0deg
   3. Stop: 180deg
   4. Steps: 9
3. Click the Close button
The 180° Ring Hybrid

This example is intended to show you how to create, simulate, and analyze a ring hybrid, using Ansoft HFSS.
Getting Started

Launching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft, HFSS 10 program group. Click HFSS 10.

Setting Tool Options

To set the tool options:

- **Note:** In order to follow the steps outlined in this example, verify that the following tool options are set:
  1. Select the menu item **Tools > Options > HFSS Options**
  2. HFSS Options Window:
     1. Click the General tab
        - Use Wizards for data entry when creating new boundaries: [✓ Checked]
        - Duplicate boundaries with geometry: [✓ Checked]
     2. Click the OK button
  3. Select the menu item **Tools > Options > 3D Modeler Options.**
  4. 3D Modeler Options Window:
     1. Click the Operation tab
        - Automatically cover closed polylines: [✓ Checked]
     2. Click the Drawing tab
        - Edit property of new primitives: [✓ Checked]
     3. Click the OK button
### Opening a New Project

**To open a new project:**

1. In an Ansoft HFSS window, click the on the Standard toolbar, or select the menu item **File > New**.
2. From the **Project** menu, select **Insert HFSS Design**.

![Project Menu](image.png)

### Set Solution Type

**To set the solution type:**

1. Select the menu item **HFSS > Solution Type**
2. Solution Type Window:
   1. Choose **Driven Terminal**
   2. Click the **OK** button

![Solution Type](image.png)
6.3

Example - 180° Ring Hybrid

Creating the 3D Model

Set Model Units
To set the units:
1. Select the menu item 3D Modeler > Units
2. Set Model Units:
   1. Select Units: mm
   2. Click the OK button

Set Default Material
To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
   1. Click the Add Material button
   2. View/Edit Material Window:
      1. For the Material Name type: My_Sub
      2. For the Value of Relative Permittivity type: 2.33
      3. For the Value of Dielectric Loss Tangent type: 4.29e-4
      4. Click the OK button
3. Click the OK button
Create Substrate

To create the substrate:
1. Select the menu item **Draw > Regular Polyhedron**
2. Using the coordinate entry fields, enter the center position
   - X: 0.0, Y: 0.0, Z: -1.143, Press the **Enter** key
3. Using the coordinate entry fields, enter the radius:
   - dX: 22.345mm/cos(30*π/180), dY: 0.0, dZ: 0.0, Press the **Enter** key
4. Using the coordinate entry fields, enter the height:
   - dX: 0.0, dY: 0.0, dZ: 2.286, Press the **Enter** key

Segment Number Window
- Number of Segments: 6
- Click the **OK** button

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value** of **Name** type: **Substrate**
3. Click the **OK** button

To fit the view:
1. Select the menu item **View > Fit All > Active View**.
   - Or press the **CTRL+D** key
Create Trace

To create the trace:
1. Select the menu item Draw > Rectangle
2. Using the coordinate entry fields, enter the rectangle position
   - X: -0.89154, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the rectangle:
   - dX: 1.78308, dY: 22.345, dZ: 0.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Trace
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Assign a Perfect E boundary to the Trace

To select the trace:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Trace
   2. Click the OK button

To assign the Perfect E boundary
1. Select the menu item HFSS > Boundaries > Assign > Perfect E
2. Perfect E Boundary window
   1. Name: PerfE_Trace
   2. Click the OK button
**Create Wave Port Excitation 1**

**Note:** This structure requires 4 ports with 1 terminal lines per port. We could use face selection to select the ends of the substrate that represent the port, define terminal lines, assign excitation, and repeat for port 2-4. Since we can duplicate port definitions, it is more efficient to define a rectangle with the appropriate port definition and copy it to the location of ports 2-4. The second method is described here:

**To set grid plane**
1. Select the menu item *3D Modeler > Grid Plane > XZ*

**To set the view**
1. Select the menu item *View > Modify Attributes > Orientation*
2. Select Viewing Direction from the List Window
   1. From the list select the view name: **Right**
   2. Click the **Apply** button
   3. Click the **Close** button

**To create the rectangle graphically:**
1. Select the menu item *Draw > Rectangle*
2. Using the mouse, position the active position indicator such that it snaps to the vertex of the lower left corner of the substrate face. The shape of the active position indicator will change to a square when it snaps to the vertex
3. Click the left mouse button to select this point as the start position.
4. Continued on next page...
Create Wave Port Excitation 1 (Continued)

4. Using the mouse, position the active position indicator such that it snaps to the vertex of the upper right corner of the substrate face. The shape of the active position indicator will change to a square when it snaps to the vertex.

5. Click the left mouse button to set the opposite corner of the rectangle.

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Port
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
Example - 180° Ring Hybrid

Create Wave Port Excitation 1 (Continued)

To assign wave port excitation

1. Select the menu item **HFSS > Excitations > Assign > Wave Port**
2. Wave Port : General
   1. Name: p1
   2. Click the Next button
3. Wave Port : Terminals
   1. Number of Terminals: 1, Click the Update button
   2. For T1, click the Undefined column and select New Line
   3. Using the coordinate entry fields, enter the vector position
      X: 0.0, Y: 22.345, Z: -1.143, Press the Enter key
   4. Using the coordinate entry fields, enter the vertex
      dX: 0.0, dY: 0.0, dZ: 1.143, Press the Enter key
   5. Click the Next button
4. Wave Port : Differential Pairs
   1. Click the Next button
5. Wave Port : Post Processing
6. Click the Finish button
6.3

Example - 180° Ring Hybrid

Create the remaining Traces and Wave Ports

To select objects:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Trace, Port
   2. Click the OK button

To duplicate the objects:
1. Select the menu item, Edit > Duplicate > Around Axis
2. Duplicate Around Axis Window
   1. Axis: Z
   2. Angle: 60deg
   3. Total Number: 4
   4. Click the OK button

Create Outer Ring

To set grid plane
1. Select the menu item 3D Modeler > Grid Plane > XY

To create the ring:
1. Select the menu item Draw > Circle
2. Using the coordinate entry fields, enter the position
   - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the radius:
   - dX: 11.795, dY: 0.0, dZ: 0.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Outer
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit Drawing.
6.3

Example - 180° Ring Hybrid

Group the Conductors

To group the conductors:
1. Select the menu item **Edit > Select > By Name**
2. Select Object Dialog,
   1. Select the objects named: Trace, Trace_1, Trace_2, Trace_3, Outer
   2. Click the OK button
3. Select the menu item, **3D Modeler > Boolean > Unite**

To fit the view:
1. Select the menu item **View > Fit Drawing**.

Create Inner Ring

To create the ring:
1. Select the menu item **Draw > Circle**
2. Using the coordinate entry fields, enter the position
   ▲ X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the radius:
   ▲ dX: 10.795, dY: 0.0, dZ: 0.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Inner
3. Click the OK button

Select objects:
1. Select the menu item **Edit > Select > By Name**
2. Select Object Dialog,
   1. Select the objects named: Trace, Inner
   2. Click the OK button
3. Select the menu item, **3D Modeler > Boolean > Subtract**
4. Subtract Window
   1. Blank Parts: Trace
   2. Tool Parts: Inner
   3. Clone tool objects before subtracting: □ Unchecked
   4. Click the OK button

To fit the view:
1. Select the menu item **View > Fit Drawing**. Or press the CTRL+D key
### Analysis Setup

#### Creating an Analysis Setup

To create an analysis setup:
1. Select the menu item *HFSS > Analysis Setup > Add Solution Setup*
2. Solution Setup Window:
   1. Click the General tab:
      - Solution Frequency: 4.0 GHz
      - Maximum Number of Passes: 20
      - Maximum Delta S: 0.02
   2. Click the **OK** button

#### Adding a Frequency Sweep

To add a frequency sweep:
1. Select the menu item *HFSS > Analysis Setup > Add Sweep*
   1. Select Solution Setup: Setup1
   2. Click the **OK** button
2. Edit Sweep Window:
   1. Sweep Type: **Fast**
   2. Frequency Setup Type: **Linear Step**
      - Start: 2.0 GHz
      - Stop: 7.0 GHz
      - Step: 0.05 GHz
      - Save Fields: **Checked**
   3. Click the **OK** button
Create Reports

Create Terminal S-Parameter Plot vs. Adaptive Pass

Note: If this report is created prior or during the solution process, a real-time update of the results are displayed

To create a report:
1. Select the menu item HFSS > Results > Create Report
2. Create Report Window:
   1. Report Type: Terminal S Parameters
   2. Display Type: Rectangular
   3. Click the OK button
3. Traces Window:
   1. Solution: Setup1: Adaptive1
   2. Click the X tab
      1. Use Primary Sweep: Unchecked
      2. Category: Variables
      3. Quantity: Pass
   3. Click the Y tab
      1. Category: Terminal S Parameter
      2. Quantity: St(p1,p1), St(p1,p2), St(p1,p3), St(p1,p4)
      3. Function: dB
      4. Click the Add Trace button
   4. Click the Done button
Example - 180° Ring Hybrid

 Creating Terminal S-Parameter Plot - Magnitude

To create a report:

1. Select the menu item `HFSS > Results > Create Report`
2. Create Report Window:
   1. Report Type: **Terminal S Parameters**
   2. Display Type: **Rectangular**
   3. Click the **OK** button
3. Traces Window:
   1. Solution: **Setup1: Sweep1**
   2. Domain: **Sweep**
   3. Click the **Y** tab
      1. Category: **Terminal S Parameter**
      2. Quantity: **St(p1,p1), St(p1,p2), St(p1,p3), St(p1,p4)**
      3. Function: **dB**
      4. Click the **Add Trace** button
   4. Click the **Done** button
6.3 Example - 180° Ring Hybrid

- **Save Project**
  - **To save the project:**
    1. In an Ansoft HFSS window, select the menu item *File > Save As*.
    2. From the *Save As* window, type the Filename: `hfss_ringhybrid`
    3. Click the *Save* button

- **Analyze**

- **Model Validation**
  - **To validate the model:**
    1. Select the menu item *HFSS > Validation Check*
    2. Click the *Close* button
    - **Note:** To view any errors or warning messages, use the Message Manager.

- **Analyze**
  - **To start the solution process:**
    1. Select the menu item *HFSS > Analyze*
Example - 180° Ring Hybrid

Solution Data

To view the Solution Data:
1. Select the menu item **HFSS > Results > Solution Data**

To view the Profile:
1. Click the **Profile** Tab.

To view the Convergence:
1. Click the **Convergence** Tab

**Note:** The default view is for convergence is **Table**. Select the **Plot** radio button to view a graphical representations of the convergence data.

To view the Matrix Data:
1. Click the **Matrix Data** Tab

**Note:** To view a real-time update of the Matrix Data, set the Simulation to **Setup1, Last Adaptive**

2. Click the **Close** button
### Example - 180° Ring Hybrid

#### Terminal S-Parameter Plot vs. Adaptive Pass

![Graph showing S-parameters vs. adaptive pass](image)

#### Terminal S-Parameter Plot - Magnitude

![Graph showing S-parameters magnitude](image)
THIS PAGE INTENTIONALLY LEFT BLANK
The Coaxial Stub Resonator

This example is intended to show you how to create, simulate, and optimize a coaxial stub resonator, using the Ansoft HFSS Design Environment.
Example - Coaxial Stub Resonator

Ansoft HFSS Design Environment

The following features of the Ansoft HFSS Design Environment are used to create this passive device model:

- **3D Solid Modeling**
  - Primitives: Cylinders
  - Boolean: Union
  - Duplicate: Around Axis

- **Boundaries/Excitations**
  - Excitations: Wave Ports

- **Analysis**
  - Sweep: Fast Frequency

- **Optimization**
  - Parametrics Setup
  - Optimetrics Setup

- **Results**
  - Data: Tabular
  - Plotting: Cartesian
Getting Started

Launching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft, HFSS 10 program group. Click HFSS 10.

Setting Tool Options

To set the tool options:

Note: In order to follow the steps outlined in this example, verify that the following tool options are set:

1. Select the menu item Tools > Options > HFSS Options
2. HFSS Options Window:
   1. Click the General tab
      - Use Wizards for data entry when creating new boundaries: ✔ Checked
      - Duplicate boundaries with geometry: ✔ Checked
   2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:
   1. Click the Operation tab
      - Automatically cover closed polylines: ✔ Checked
   2. Click the Drawing tab
      - Edit property of new primitives: ✔ Checked
   3. Click the OK button
6.4  

Example - Coaxial Stub Resonator

---

### Opening a New Project

- **To open a new project:**
  1. In an Ansoft HFSS window, click the **File > New** on the Standard toolbar, or select the menu item **File > New**.
  2. From the **Project** menu, select **Insert HFSS Design**.

---

### Set Solution Type

- **To set the solution type:**
  1. Select the menu item **HFSS > Solution Type**
  2. Solution Type Window:
     1. Choose **Driven Terminal**
     2. Click the **OK** button
Example - Coaxial Stub Resonator

Creating the 3D Model

Set Model Units

To set the units:
1. Select the menu item 3D Modeler > Units
2. Set Model Units:
   1. Select Units: mm
   2. Click the OK button

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
   1. Type pec in the Search by Name field
   2. Click the OK button
Example - Coaxial Stub Resonator

- **Set Grid Plane**
  - To set the grid plane:
    1. Select the menu item *3D Modeler > Grid Plane > XZ*

- **Create the Conductor 1**
  - To create the conductor
    1. Select the menu item *Draw > Cylinder*
    2. Using the coordinate entry fields, enter the cylinder position
       - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
    3. Using the coordinate entry fields, enter the radius:
       - dX: 0.86, dY: 0.0, dZ: 0.0, Press the Enter key
    4. Using the coordinate entry fields, enter the height:
       - dX: 0.0, dY: -6.0, dZ: 0.0, Press the Enter key
  - To set the name:
    1. Select the Attribute tab from the Properties window
    2. For the Value of Name type: Conductor
    3. Click the OK button
  - To fit the view:
    1. Select the menu item *View > Fit All > Active View*. Or press the CTRL+D key

![Diagram of a coaxial stub resonator with labels X, Y, and Z.](image)
6.4 Example - Coaxial Stub Resonator

Create the Stub

To create the stub:
1. Select the menu item Draw > Cylinder
2. Using the coordinate entry fields, enter the cylinder position:
   - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the radius:
   - dX: 0.86, dY: 0.0, dZ: 0.0, Press the Enter key
4. Using the coordinate entry fields, enter the height:
   - dX: 0.0, dY: 4.75, dZ: 0.0, Press the Enter key

To parameterize the object:
1. Select the Command tab from the Properties window
2. For Height, type: L, Click the Tab key to accept
   - Add Variable L: 4.75mm, Click the OK button

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Stub
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose vacuum
6.4

Example - Coaxial Stub Resonator

Create the Body

To create the body
1. Select the menu item Draw > Cylinder
2. Using the coordinate entry fields, enter the cylinder position
   - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the radius:
   - dX: 2.0, dY: 0.0, dZ: 0.0, Press the Enter key
4. Using the coordinate entry fields, enter the height:
   - dX: 0.0, dY: -6.0, dZ: 0.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Body
3. Click the OK button

Create Wave Port Excitation 1

Note: To simplify the instructions, a 2D object will be created to represent the port. This is not a requirement for defining ports. Graphical face selection can be used as an alternative.

To create a circle that represents the port:
1. Select the menu item Draw > Circle
2. Using the coordinate entry fields, enter the center position
   - X: 0.0, Y: -6.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the radius of the circle:
   - dX: 2.0, dY: 0.0, dZ: 0.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: p1
3. Click the OK button

To select the object p1:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: p1
   2. Click the OK button

Note: You can also select the object from the Model Tree
Create Wave Port Excitation 1 (Continued)

To assign wave port excitation

1. Select the menu item HFSS > Excitations > Assign > Wave Port
2. Wave Port : General
   1. Name: p1,
   2. Click the Next button
3. Wave Port : Terminals
   1. Number of Terminals: 1,
   2. For T1, click the Undefined column and select New Line
   3. Using the coordinate entry fields, enter the vector position
      X: 2.0, Y: -6.0, Z: 0.0, Press the Enter key
   4. Using the coordinate entry fields, enter the vertex
      dX: -1.14, dY: 0.0, dZ: 0.0, Press the Enter key
   5. Click the Next button
4. Wave Port : Differential Pairs
   1. Click the Next button
5. Wave Port : Post Processing
   1. Full Port Impedance: 50
6. Click the Finish button
Example – Coaxial Stub Resonator

Create Port 2 Arm

To select the objects Conductor, Body, & p1:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Body, Conductor, p1
   ▲ Note: Use the Ctrl + Left mouse button to select multiple objects
2. Click the OK button

To create the port 2 arm:
1. Select the menu item, Edit > Duplicate > Around Axis.
   1. Axis: X
   2. Angle: -90
   3. Total Number: 2
   4. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Create Stub Body

To select the objects Body:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Body
   2. Click the OK button

To create the stub body:
1. Select the menu Select the menu item, Edit > Duplicate > Around Axis.
   1. Axis: X
   2. Angle: 180
   3. Total Number: 2
   4. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
Group the Body Objects

To select the objects Body, Body_1, Body_2:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Body, Body_1, Body_2
   2. Click the OK button
3. Select the menu item, 3D Modeler > Boolean > Unite

To fit the view:
1. Select the menu item View > Fit All > Active View.

Group the Conductor & Stub Objects

To select the objects Conductor, Conductor_1, Stub:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Conductor, Conductor_1, Stub
   2. Click the OK button
3. Select the menu item, 3D Modeler > Boolean > Unite

To fit the view:
1. Select the menu item View > Fit All > Active View.
### Boundary Display

To verify the boundary setup:

1. Select the menu item **HFSS > Boundary Display (Solver View)**
2. From the Solver View of Boundaries, toggle the Visibility check box for the boundaries you wish to display.

**Note:** The background (Perfect Conductor) is displayed as the outer boundary.

**Note:** The Perfect Conductors are displayed as the smetal boundary.

**Note:** Select the menu item, **View > Visibility** to hide all of the geometry objects. This makes it easier to see the boundary.

3. Click the Close button when you are finished.

---

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Solver Visibility</th>
<th>Visibility</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>p1</td>
<td>User Defined Visible to solver</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
</tr>
<tr>
<td>p3</td>
<td>User Defined Visible to solver</td>
<td>n/a</td>
<td>n/a</td>
<td>n/a</td>
</tr>
<tr>
<td>outer</td>
<td>Default</td>
<td>Visible to solver</td>
<td>n/a</td>
<td>n/a</td>
</tr>
<tr>
<td>smetal</td>
<td>Default</td>
<td>Visible to solver</td>
<td>n/a</td>
<td>n/a</td>
</tr>
</tbody>
</table>

---

### Mesh Operations

To select the object Body

1. Select the menu item **Edit > Select > By Name**
2. Select Object Dialog,
   1. Select the objects named: **Body**
   2. Click the OK button

To create a mesh operation:

1. Select the menu item **HFSS > Mesh Operations > Assign > Inside Selection > Length based**
2. Element Length Based Refinement Window:
   1. Name: **Body_Mesh**
   2. Restrict Length of Elements: ☐ Unchecked
   3. Restrict the Number of Elements: ☑ Checked
     1. Maximum Number of Elements: **2000**
   4. Click the OK button
## Analysis Setup

### Creating an Analysis Setup

To create an analysis setup:

1. Select the menu item **HFSS > Analysis Setup > Add Solution Setup**
2. Solution Setup Window:
   1. Click the **General** tab:
      - Solution Frequency: **13.0 GHz**
      - Maximum Number of Passes: **10**
      - Maximum Delta S: **0.02**
   2. Click the **OK** button

### Adding a Frequency Sweep

To add a frequency sweep:

1. Select the menu item **HFSS > Analysis Setup > Add Sweep**
   1. Select Solution Setup: **Setup1**
   2. Click the **OK** button
2. Edit Sweep Window:
   1. Sweep Type: **Fast**
   2. Frequency Setup Type: **Linear Step**
      - Start: **5.0 GHz**
      - Stop: **20.0 GHz**
      - Step: **0.01 GHz**
      - Save Fields: **Checked**
   3. Click the **OK** button
Example - Coaxial Stub Resonator

Create Terminal S-Parameter Plot - Magnitude

To create a report:
1. Select the menu item HFSS > Results > Create Report
2. Create Report Window:
   1. Report Type: Terminal S Parameters
   2. Display Type: Rectangular Plot
   3. Click the OK button
3. Traces Window:
   1. Solution: Setup1: Sweep1
   2. Domain: Sweep
   3. Click the Y tab
      1. Category: Terminal S Parameter
      2. Quantity: St(p1,p1), St(p1,p2),
      3. Function: dB
      4. Click the Add Trace button
   4. Click the Done button
Example - Coaxial Stub Resonator

**Save Project**

- **To save the project:**
  1. In an Ansoft HFSS window, select the menu item *File > Save As*.
  2. From the *Save As* window, type the Filename: *hfss_stub_resonator*
  3. Click the *Save* button

**Analyze**

**Model Validation**

- **To validate the model:**
  1. Select the menu item *HFSS > Validation Check*
  2. Click the *Close* button
  - **Note:** To view any errors or warning messages, use the Message Manager.

**Analyze**

- **To start the solution process:**
  1. Select the menu item *HFSS > Analyze*
6.4 Example – Coaxial Stub Resonator

Solution Data

To view the Solution Data:
1. Select the menu item HFSS > Results > Solution Data

To view the Profile:
1. Click the Profile Tab.

To view the Convergence:
1. Click the Convergence Tab

Note: The default view is for convergence is Table. Select the Plot radio button to view a graphical representation of the convergence data.

To view the Matrix Data:
1. Click the Matrix Data Tab

Note: To view a real-time update of the Matrix Data, set the Simulation to Setup1, Last Adaptive

2. Click the Close button
Data Markers

The plot we created prior to the simulation will automatically be updated when the analysis completes. The xy plot should currently be displayed. If it is not, select the menu item *Window > XY Plot1* to switch to the plot display.

Mark All Traces

1. Select the menu item *Report 2D > Mark All Traces*.
2. Click the **Min** button.
3. When you are finished, select the menu item *Report 2D > Mark All Traces* to remove the marker.
Optimetrics Setup - Parametric Sweep

During the design of a microwave device, it is common practice to develop design trends based on swept parameters. Ansoft HFSS with Optimetrics Parametric Sweep can automatically create these design curves.

Add a Parametric Sweep

1. Select the menu item **HFSS > Optimetrics Analysis > Add Parametric**
2. Setup **Sweep Analysis** Window:
   1. Click the **Sweep Definitions** tab:
      1. Click the **Add** button
      2. Add/Edit Sweep Dialog
         1. Select Variable: L
         2. Select Linear Count
         3. Start: 4.0mm
         4. Stop: 5.5mm
         5. Count: 5
         6. Click the Add button
         7. Click the OK button
   2. Click the **Options** tab:
      1. Save Fields and Mesh: ✔ Checked
      2. Click the OK button

Analyze Parametric Sweep

To start the solution process:
1. Expand the Project Tree to display the items listed under **Optimetrics**
2. Right-click the mouse on **ParametricSetup1** and choose **Analyze**

Optimetrics Results

To view the Optimetrics Results:
1. Select the menu item **HFSS > Optimetrics Analysis > Optimetrics Results**
2. Select the **Profile** Tab to view the solution progress for each setup.
3. Click the **Close** button when you are finished viewing the results
Example - Coaxial Stub Resonator

Create Terminal S-Parameter Plot - S12 at each L

To create a report:
1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Terminal S Parameters**
   2. Display Type: **Rectangular Plot**
   3. Click the **OK** button
3. Traces Window:
   1. Solution: **Setup1: Sweep1**
   2. Domain: **Sweep**
   3. Click the **Sweeps** tab
      1. Select **Sweep Design and Project variable values**
   4. Click the **Y** tab
      1. Category: **Terminal S Parameter**
      2. Quantity: **St(p1,p2)**
      3. Function: **dB**
      4. Click the **Add Trace** button
   5. Click the **Done** button
Optimetrics Setup - Optimization

The Parametric Sweep was useful for generating design curves. For this simple design with only a single variable we could use the design curves to make educated guesses at performance targets that are not contained in the Parametric Sweep. Ansoft HFSS and Optimetrics with Optimization takes the guess work out of achieving performance targets. To demonstrate this we will target a minimum S12 at 13GHz. Since this device has a very high Q, we will consider anything <= -40dB at 13GHz to be a minimum. From the Parametric Sweep, we can see that the search range can be limited to the range 4.7-5.1mm. Since we are only interested in obtaining an optimum solution for 13GHz, we will add an additional Solution Setup that does not include the frequency sweep. This will reduce the amount of simulation time required to achieve the frequency goal.

Add an Analysis Setup

To create an analysis setup:
1. Select the menu item **HFSS > Analysis Setup > Add Solution Setup**
2. Solution Setup Window:
   1. Click the General tab:
      - Solution Frequency: **13.0 GHz**
      - Maximum Number of Passes: **10**
      - Maximum Delta S per Pass: **0.02**
   2. Click the OK button

Define Optimization Design Variables

To Define Optimization Design Variable
1. Select the menu item **HFSS > Design Properties**
2. Click the Optimization radio button:
   1. Name: **L**
   2. Include: ✅ Checked
   3. Min: **4.0 mm**
   4. Max: **5.5 mm**
3. Click the OK button
## Example – Coaxial Stub Resonator

### Add Optimization Setup

1. Select the menu item **HFSS > Optimetrics Analysis > Add Optimization**
2. Setup Optimization Window:
   1. Click the **Goals** tab:
      1. Optimizer: **Quasi-Newton**
      2. Max. No. of Iterations: **10**
      3. Click the **Add** button
      4. From the Solution Column, click on the **Setup1:Last Adaptive** and select **Setup2:LastAdaptive** from the list of solutions
      5. Click the **Edit Calculation** button
   6. Setup Output Variables dialog:
      1. Category: **Terminal S Parameter**
      2. Quantity: **St(p1,p2)**
      3. Function: **mag**
      4. Click the **Insert Quantity Into Expression** button
      5. Name: **s21_mag**
      6. Click the **Add** button
      7. Click the **Done** button
   7. Condition: <=
   8. Goal: **0.01**
   9. Weight: **1**
   10. Acceptable Cost: **0**
   11. Click the **Variables** tab:
      1. Min: **4.7 mm**
      2. Max: **5.1mm**
   12. Click the **OK** button
6.4 Example - Coaxial Stub Resonator

- **Analyze Optimization**
  - To start the solution process:
    1. Expand the Project Tree to display the items listed under Optimetrics
    2. Right-click the mouse on OptimizationSetup1 and choose Analyze

- **Optimetrics Results**
  - To view the Optimetrics Results:
    1. Select the menu item HFSS > Optimetrics Analysis > Optimetrics Results
    2. Click the Close button when you are finished viewing the results
Create Terminal S-Parameter Plot of Optimum Result

Once the Optimization completes, the design will automatically be updated with the Optimum value. To view the performance of the device versus frequency will require you to analyze the HFSS project with the optimum design value.

To analyze the optimum design
1. Select the menu item **HFSS > Analyze**

To view the plot
- The existing **XY Plot 1** will automatically be updated when the solution completes.
- To change to the XY Plot 1 window, select the menu item **Window > XY Plot 1**.
Example - Wave Ports

Microstrip Wave Port

This example is intended to show you how wave port size can influence the results of any simulation using the Ansoft HFSS Version 10 Design Environment.
Example - Wave Ports

Ansoft Design Environment

- The following features of the Ansoft HFSS Design Environment are used to create this passive device model
  - 3D Solid Modeling
    - Primitives: Boxes, Rectangle
    - Boolean Operations: Duplicate Along Line
  - Boundary/Excitation
    - Ports: Wave Ports and Integration Lines
  - Analysis
    - Solution: Ports Only
    - Sweep: Interpolating
  - Results
    - Cartesian plotting
  - Fields Overlays
    - Port Field Display
Example - Wave Ports

Getting Started

Launching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft, HFSS 10 program group. Click HFSS 10.

Setting Tool Options

To set the tool options:

- Note: In order to follow the steps outlined in this example, verify that the following tool options are set:
  1. Select the menu item Tools > Options > HFSS Options
  2. HFSS Options Window:
     1. Click the General tab
        - Use Wizards for data entry when creating new boundaries: ✔ Checked
        - Duplicate boundaries with geometry: ✔ Checked
     2. Click the OK button
  3. Select the menu item Tools > Options > 3D Modeler Options.
  4. 3D Modeler Options Window:
     1. Click the Operation tab
        - Automatically cover closed polylines: ✔ Checked
     2. Click the Drawing tab
        - Edit property of new primitives: ✔ Checked
     3. Click the OK button
## Design Review

Generally speaking when we assign a wave port to a microstrip line, or any quasi-TEM line, we need to include some area around the actual transmission line. The big question is, “how much area?”

Below you will see the cross section of a simple microstrip line with naming conventions shown.

As a rule of thumb, we typically create a 2D rectangle to represent the wave port stimulus for this type of structure. The dimensions of the rectangle are roughly five times the width of the transmission line by four times the height of the substrate.

REMEMBER: These are only guidelines !!!

The height of the port will be affected by the permittivity of the substrate. The higher the permittivity, the less the fields will propagate in the air, and the shorter the port can be made.

The width of the port will affect the port impedance and propagating modes. The narrower the width (image on right), the more the fields will couple to the side walls of the port. This effect may not be physical. The wider the port, the greater chance that a higher frequency waveguide mode can propagate.

This example will explore this last phenomenon.
### 6.5 Example - Wave Ports

#### Opening a New Project

- **To open a new project:**
  - In an Ansoft HFSS window, click the **File** button on the Standard toolbar, or select the menu item **File > New**.
  - From the **Project** menu, select **Insert HFSS Design**.

#### Set Solution Type

- **To set the solution type:**
  - Select the menu item **HFSS > Solution Type**
  - Solution Type Window:
    - Choose **Driven Modal**
    - Click the OK button

#### Set Model Units

- **To set the units:**
  - Select the menu item **3D Modeler > Units**
  - Set Model Units:
    - Select Units: **mil**
    - Click the OK button
6.5

Example - Wave Ports

Add New Material

To add a new material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. From the Select Definition window, click the Add Material button
3. View/Edit Material Window:
   1. Material Name: My_Rogers
   2. Relative Permittivity: 3.38
   3. Click the OK button
4. Click the OK button

![View / Edit Material Window Image]
Create Substrate

To create the substrate:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: 0.0, Y: -400.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   - dX: 200.0, dY: 800.0, dZ: 8.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Substrate
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
   1. Type pec in the Search by Name field
   2. Click the OK button
Create Trace

To create the trace:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: 0.0, Y: -9.25, Z: 8.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   - dX: 200.0, dY: 18.5, dZ: 1.4, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Trace
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Create Ground

To create the ground:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: 0.0, Y: -400.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   - dX: 200.0, dY: 800.0, dZ: -1.4, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Ground
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
6.5

Example - Wave Ports

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose vacuum

Create Air

To create the Air:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   X: 0.0, Y: -400.0, Z: -1.4, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   dX: 200.0, dY: 800.0, dZ: 200.0, Press the Enter key
4. To set the name:
   1. Select the Attribute tab from the Properties window.
   2. For the Value of Name type: Air
   3. Click the OK button
5. To fit the view:
   1. Select the menu item View > Fit All > Active View.

Create Radiation Boundary

To select the object Air:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Air
   2. Click the OK button
3. To create a radiation boundary
   1. Select the menu item HFSS > Boundaries > Assign > Radiation
   2. Radiation Boundary Window
      Name: Rad1
      Click the OK button
6.5 Example - Wave Ports

- **Set Grid Plane**
  - To set the grid plane:
    1. Select the menu item **3D Modeler > Grid Plane > YZ**

- **Create the Wave Port**
  - To create a rectangle that represents the port:
    1. Select the menu item **Draw > Rectangle**
    2. Using the coordinate entry fields, enter the center position:
      - X: 0.0, Y: -200.0, Z: 0.0, Press the Enter key
    3. Using the coordinate entry fields, enter the opposite corner of the rectangle:
      - dX: 0.0, dY: 400.0, dZ: 50.0, Press the Enter key
  - To parameterize the object:
    1. Select the **Command** tab from the **Properties** window
    2. For **Position**, type: 0mil, -Port_Width/2, 0mil, Click the Tab key to accept
    3. Add Variable **Port_Width**: 400mil, Click the OK button
  - For **YSize**, type: **Port_Width**, Click the Tab key to accept
  - To set the name:
    1. Select the **Attribute** tab from the **Properties** window.
    2. For the **Value of Name** type: **Port1**
    3. Click the **OK** button
### Assign the Excitation 1

#### To select the object p1:
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: **Port1**
   2. Click the **OK** button

#### To assign wave port excitation
1. Select the menu item *HFSS > Excitations > Assign > Wave Port*
2. Wave Port : General
   1. Name: **p1**
   2. Click the **Next** button
3. Wave Port : Modes
   1. Number of Modes: **5**
   2. For Mode **1**, click the **None** column and select **New Line**
   3. Using the coordinate entry fields, enter the vector position
      - **X: 0.0**, **Y: 0.0**, **Z: 0.0**, Press the **Enter** key
   4. Using the coordinate entry fields, enter the vertex
      - **dX: 0.0**, **dY: 0.0**, **dZ: 8.0**, Press the **Enter** key
   5. For Mode **1**, click the **Zpi** column and select **Zpv**
   1. Click the **Next** button
4. Wave Port : Post Processing
   1. Click the **Next** button
5. Click the **Finish** button
### Create Wave Port Excitation 2

**To select the object Port1:**
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: Port1
   2. Click the OK button

**To duplicate the port:**
1. Select the menu item, *Edit > Duplicate > Along Line*
2. Using the coordinate entry fields, enter the first point of the duplicate vector
   - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the second point of the duplicate vector
   - dX: 200.0, dY: 0.0, dZ: 0.0, Press the Enter key
4. Duplicate Along Line Windows
   1. Total Number: 2
   2. Click the OK button
5. Click the Done button
Boundary Display

To verify the boundary setup:

1. Select the menu item **HFSS > Boundary Display (Solver View)**

2. From the Solver View of Boundaries, toggle the Visibility check box for the boundaries you wish to display.

   - **Note:** The background (Perfect Conductor) is displayed as the outer boundary.

   - **Note:** The Perfect Conductors are displayed as the smetal boundary.

   - **Note:** Select the menu item, **View > Visibility** to hide all of the geometry objects. This makes it easier to see the boundary.

3. Click the **Close** button when you are finished.
Analysis Setup

Creating an Analysis Setup

To create an analysis setup:
1. Select the menu item HFSS > Analysis Setup > Add Solution Setup
2. Solution Setup Window:
   1. Click the General tab:
      - Solution Frequency: 20GHz
   2. Check Solve Ports Only
   3. Click the OK button

Adding a Frequency Sweep

To add a frequency sweep:
1. Select the menu item HFSS > Analysis Setup > Add Sweep
   1. Select Solution Setup: Setup1
   2. Click the OK button
2. Edit Sweep Window:
   1. Frequency Setup Type: Linear Count
      - Start: 0.1GHz
      - Stop: 50.1GHz
      - Count: 81
3. Edit Setup Interpolation Basis Window:
   1. Click the button for Setup Interpolation Basis
      - Sweep Type: Interpolating
      - Error Tolerance: 0.5%
      - Max Solutions: 20
   2. Click the OK button
4. Click the OK button
Example - Wave Ports

▲ Save Project
▲ To save the project:
1. In an Ansoft HFSS window, select the menu item File > Save As.
2. From the Save As window, type the Filename: hfss_waveports
3. Click the Save button

▲ Analyze

▲ Model Validation
▲ To validate the model:
1. Select the menu item HFSS > Validation Check
2. Click the Close button
▲ Note: To view any errors or warning messages, use the Message Manager.

▲ Analyze
▲ To start the solution process:
1. Select the menu item HFSS > Analyze
Example - Wave Ports

Solution Data

To view the Solution Data:
1. Select the menu item HFSS > Results > Solution Data

To view the Profile:
1. Click the Profile Tab.

To view the Matrix Data:
1. Click the Matrix Data Tab
2. Click the Close button

![Solution Data Screenshot](image)
Create Reports

Create Propagation Constant vs. Frequency

To Create a report:
1. Select the menu item HFSS > Results > Create Report
2. Create Report Window:
   1. Report Type: Modal S Parameters
   2. Display Type: Rectangular
   3. Click the OK button
3. Traces Window:
   1. Solution: Setup1: Sweep1
   2. Click the Y tab
      1. Domain: Sweep
      2. Category: Gamma
      3. Quantity: Gamma(p1:1), Gamma(p1:2), Gamma(p1:3), Gamma(p1:4), Gamma(p1:5)
      4. Function: \( \text{im} \)
      5. Click the Add Trace button
   3. Click the Done button
4. See next page for plot and discussion of results
### Discussion

- What does this plot tell us?
- Given the physical size of the wave port object that we created, the fundamental mode (p2:1) is a quasi-TEM mode that propagates from DC on up.
- This also shows that higher order modes can propagate (b>0) at a high enough frequency. The second modes starts propagating at ~14 GHz.
- Therefore, if we only needed to simulate up to 10 GHz, we wouldn't need to size our port any different, however, if we need to simulate up to 50 GHz, then we need to resize our port to eliminate the higher order propagating modes.
- The last part of the exercise will explore this.
Field Pattern Plots

- It might be illuminating to look at the field patterns at the port to discover which modes are excited.

To display the Mode field patterns in the modeler:
1. From within the project manager, expand the section Port Field Display
2. Expand p1, and select Mode 2

   1. The field pattern will be overlaid on the 3D model. From the plot below, Mode 2 is clearly not a microstrip mode, but a TE_{10}-like waveguide mode.
Optimetrics Setup - Parametric Sweep

Add a Parametric Sweep

1. Select the menu item **HFSS > Optimetrics Analysis > Add Parametric**
2. Setup **Sweep Analysis** Window:
   1. Click the **Sweep Definitions** tab:
      1. Click the **Add** button
      2. **Add/Edit Sweep Dialog**
         1. Variable: **Port_Width**
         2. Select **Linear Step**
         3. Start: **200mil**
         4. Stop: **600mil**
         5. Step: **100mil**
         6. Click the **Add >>** button
         7. Click the **OK** button
   2. Click the **OK** button
Example - Wave Ports

Save Project

To save the project:
1. In an Ansoft HFSS window, select the menu item File > Save.

Analyze

Model Validation

To validate the model:
1. Select the menu item HFSS > Validation Check
2. Click the Close button

Note: To view any errors or warning messages, use the Message Manager.

Analyze

To start the solution process:
1. Expand the Project Tree to display the items listed under Optimetrics
2. Right-click the mouse on ParametricSetup1 and choose Analyze
Create Reports

Create Propagation Constant vs. Frequency vs. Port_Width

To Create a report:

1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Modal S Parameters**
   2. Display Type: **Rectangular**
   3. Click the **OK** button
3. Traces Window:
   1. Solution: **Setup1: Sweep1**
   2. Click the Sweeps tab
      1. Select the **Sweep Design and Project Variable Values** button
   3. Click the **Y** tab
      1. Domain: **Sweep**
      2. Category: **Gamma**
      3. Quantity: **Gamma(p1:2)**
      4. Function: **im**
      5. Click the **Add Trace** button
   4. Click the **Done** button
5. See next page for plot and discussion of results
### Discussion

- **What does this plot tell us?**
- This shows that as we decrease the width of the port, the frequency at which the higher order mode starts to propagate increases.
- Therefore, by properly sizing the wave port, you can eliminate any higher order propagating modes if you believe that they do not exist.
- You need to use caution if you are simulating very high frequencies, i.e., millimeter wavelengths, as you may not be able to make the ports small enough to eliminate these modes. You probably shouldn’t even try as the higher order modes might represent real world effects.
Dielectric Resonator

This example is intended to show you how to create, simulate, and analyze a shielded cylindrical dielectric resonator using the Ansoft HFSS Design Environments eigen mode solver.

A dielectric resonator is intended to operate within a given frequency range and the electromagnetic field in the vicinity of the resonator is expected to exhibit behavior specific to the desired modes of operation. However, when employing resonant circuits, frequencies of undesired modes may interfere with the desired modes.

It is therefore of great practical importance to be able to determine the resonant frequencies, mode patterns, energy and dissipated power of the modes existing in a given structure, such that operation of and coupling to the resonator can be determined.
Ansoft HFSS Design Environment

The following features of the Ansoft HFSS Design Environment are used to create this passive device model:

- **3D Solid Modeling**
  - Primitives: Cylinders
  - Variables: Project and model variables

- **Materials/Boundaries/Excitations**
  - Materials: Defining custom materials
  - Boundaries: Perfect E

- **Solution Setup**
  - Parametric sweep

- **Results**
  - Eigenmode Data - convergence of the individual modes
  - Formatting plots
  - Fields: E- & H-Field
  - Fields: Plotting on custom cut-planes
Example - Dielectric Resonator

Design Review


The goal of this simulation is to determine how the resonant modes set up in the dielectric resonator changes as the geometry around the resonator changes. In particular a variation of the distance from the dielectric resonator top to the cavity top will be examined.

There are two methods we could use to analyze this problem:

- **Method 1**: Define e.g. a microstrip transfering in and out of the cavity and define excitation of the microstrip. The microstrip will have a loading effect on the cavity depending on location, termination etc. Therefore an investigation using this approach will be dependent on the feed structure and modes may be missed.

- **Method 2**: Use the Eigenmode solver to determine the natural resonances of the cylindrical dielectric resonator alone.

To follow the procedure in the reference, we will use the second method. As the eigenmode solver does not use ports we will only have to define the geometry and the boundary conditions. We will solve for the first 6 modes appearing in the structure.
Details of the model

The commonly used resonant modes in cylindrical dielectrics are denoted TE_{0,m,δ}, TM_{0,m,δ}, and HEM_{n,m,δ}, respectively, for transverse electric, transverse magnetic, and hybrid mode. The subscripts m, n, and δ are the azimuthal, radial and axial wavenumbers, respectively.

The dimensions in the model are as follows and a picture showing the dimensions given below as well.

<table>
<thead>
<tr>
<th></th>
<th>Hwall</th>
<th>6-15mm</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Cavity</strong></td>
<td>R</td>
<td>15mm</td>
</tr>
<tr>
<td></td>
<td>ε_0</td>
<td>1</td>
</tr>
<tr>
<td><strong>Dielectric resonator</strong></td>
<td>h</td>
<td>5mm</td>
</tr>
<tr>
<td></td>
<td>D</td>
<td>10mm</td>
</tr>
<tr>
<td></td>
<td>ε_r</td>
<td>36</td>
</tr>
<tr>
<td><strong>Substrate</strong></td>
<td>h_s</td>
<td>1mm</td>
</tr>
<tr>
<td></td>
<td>R</td>
<td>15mm</td>
</tr>
<tr>
<td></td>
<td>ε_s</td>
<td>9.6</td>
</tr>
</tbody>
</table>
Getting Started

Launching Ansoft HFSS
1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft, HFSS 10 program group. Click HFSS 10.

Setting Tool Options

To set the tool options:

Note: In order to follow the steps outlined in this example, verify that the following tool options are set:
1. Select the menu item Tools > Options > HFSS Options
2. HFSS Options Window:
   1. Click the General tab
      - Use Wizards for data entry when creating new boundaries: ☑ Checked
      - Duplicate boundaries with geometry: ☑ Checked
   2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:
   1. Click the Operation tab
      - Automatically cover closed polylines: ☑ Checked
   2. Click the Drawing tab
      - Edit property of new primitives: ☑ Checked
   3. Click the OK button
Opening a New Project

To open a new project:

1. In an Ansoft HFSS window, click the On the Standard toolbar, or select the menu item File > New.
2. From the Project menu, select Insert HFSS Design.

Set Solution Type

To set the solution type:

1. Select the menu item HFSS > Solution Type
2. Solution Type Window:
   1. Choose Eigenmode
   2. Click the OK button
Creating the 3D Model

Set Model Units
- **To set the units:**
  1. Select the menu item *3D Modeler > Units*
  2. Set Model Units:
     1. Select Units: **mm**
     2. Click the **OK** button

Set Default Material
- **To set the default material:**
  - Using the 3D Modeler Materials toolbar, choose **vacuum**

Create the cavity
- **Create a cylinder**
  1. Select the cylinder icon from the 3D modeler toolbar
  2. Using the coordinate entry fields, enter the base center
     - **X: 0.0, Y: 0.0, Z: 0.0**, Press the **Enter** key
  3. Using the 3D Modeler toolbar make sure that the base coordinate entry plane is set to **xy**. Then set the cavity radius in the x entry field and the height in the z-entry field. Note: It is not yet possible to use parameters directly in the coordinate entry field.
     - **dX: 15, dY: 0.0, dZ: 10**, Press the **Enter** key
  - **Parameterize the height of the cavity**
    1. In the 'Height' entry box write a parameter name called '**Hwall**'.
    2. Upon hitting the **Enter** key HFSS will ask you for the value of the parameter
    3. Write '10mm' - do not forget the units!
  - **To set the name:**
    1. Select the **Attribute** tab from the **Properties** window.
    2. For the **Value of Name** type: **Cavity**
Example - Dielectric Resonator

To set the Wireframe view:
1. Select the Attribute tab from the Properties window.
2. Display Wireframe: ☑ Checked
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
Or press the CTRL+D key

Create New Materials and Set Default Material
Create new materials:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Click ‘Add Material’-button.
3. Set Material Name to subs
4. Set the dielectric permittivity, \( \varepsilon_r \), to 9.6 and leave the rest with their defaults
5. Click ‘OK’
6. Add new material called DielRes with \( \varepsilon_r=36 \)

To set the default material:
1. You can now set default material by selecting subs in the list and clicking OK

Create the substrate
Create a cylinder
1. Select the cylinder icon from the 3D modeler toolbar
2. Using the coordinate entry fields, enter the base center
   \( X: 0.0, Y: 0.0, Z: 0.0 \), Press the Enter key
3. Set base coordinate entry plane to xy. Then set the radius in the x entry field and the height in the z-entry field.
   \( dX: 15, dY: 0.0, dZ: -1.0 \), Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Substrate

You can now set transparency and color to your liking.


## Example - Dielectric Resonator

### Set Default Material

Set the default material:

1. Using the 3D Modeler Materials toolbar select the material created previously called **DielRes**.

### Create the Dielectric Resonator

Create Cylinder representing resonator

1. Select the cylinder icon from the 3D modeler toolbar
2. Using the coordinate entry fields, enter the base center
   - \( X: 0.0, Y: 0.0, Z: 0.0 \), Press the Enter key
3. Set base coordinate entry plane to xy. Then set the radius in the x entry field and the height in the z-entry field.
   - \( dX: 5.0, dY: 0.0, dZ: 5.0 \), Press the Enter key

To set the name:

1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: **DielRes**

You can now set transparency and color to your likings

### Setting Boundary Conditions

We have know defined the complete model, the only thing missing before running the analysis is what boundary condition should be applied to the other part of the cavity and the substrate.

HFSS assigns per default ‘Perfect Electrical Conductor’ (PEC) to any boundary exposed to the background. This default assignment can be overridden if you wanted to enclose the resonator in e.g. a aluminum cavity. This would have an effect on the quality factor and the resonant modes. How much influence we could easily determine using the eigenmode solver.

However for this exercise we will just stick to the default behaviour of HFSS, and therefore we will effectively enclose the resonator in perfectly conducting cavity.
Analysis Setup

Creating an Analysis Setup

- To create an analysis setup:
  1. Select the menu item HFSS > Analysis Setup > Add Solution Setup
  2. Solution Setup Window:
     1. Click the General tab:
        △ Minimum Frequency: 3 GHz
        △ Number of Modes: 6
        △ Maximum Number of Passes: 14
        △ Maximum Delta Frequency per Pass: 2.5%
     2. Under the Options tab:
        △ Minimum Converged Passes: 3

Save Project

- To save the project:
  1. In an Ansoft HFSS window, select the menu item File > Save As.
  2. From the Save As window, type the Filename: hfss_diel_res
  3. Click the Save button

Analyze

Model Validation

- It is possible to check the validity of the model you have built before sending it off to be solved. This can e.g. be extremely useful before starting a large simulation.
  1. Select the menu item HFSS > Validation Check
  2. Click the Close button

  Note: To view any errors or warning messages, use the Message Manager.

Analyze

- To start the solution process:
  1. Select the menu item HFSS > Analyze
**Solution Data**

**To view the Solution Data:**

1. Select the menu item *HFSS > Results > Solution Data*

**To view the Profile (memory use, solution time and no. of tetrahedra):**

1. Click the *Profile* Tab.

**To view the Convergence:**

1. Click the *Convergence* Tab

**Note:** The default view is for convergence is *Table*. Select the *Plot* radio button to view a graphical representations of the convergence data.

**To view the Eigenmode Data:**

1. Click the *Eigenmode Data* Tab. You will notice that the following modes has been found:

<table>
<thead>
<tr>
<th>Eigenmode</th>
<th>Frequency (GHz)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mode 1</td>
<td>5.0078</td>
</tr>
<tr>
<td>Mode 2</td>
<td>5.0081</td>
</tr>
<tr>
<td>Mode 3</td>
<td>5.3321</td>
</tr>
<tr>
<td>Mode 4</td>
<td>5.5525</td>
</tr>
<tr>
<td>Mode 5</td>
<td>7.1435</td>
</tr>
<tr>
<td>Mode 6</td>
<td>7.1443</td>
</tr>
</tbody>
</table>
2. You will notice that some of the modes come in pairs - they are degenerate modes. You will also see this later in the exercise when we plot the fields inside the structure.

**Note:** To view a real-time update of the Eigenmode Data, set the Simulation to **Setup1, Last Adaptive**

2. Click the Close button

**We will now view the convergence of the individual modes rather than looking at the convergence through the HFSS convergence criteria, Δf in percent.**

1. Select the menu item HFSS > Results > Create Report
2. Create Report Window:
   1. Report Type: Eigenmode Parameters
   2. Display Type: Rectangular
   3. Click the OK button
3. Traces Window:
   1. Solution: Setup1: Adaptive_1
   2. Click the Y tab
   3. Category: Eigen Modes
   4. Quantity: Mode(1), Mode(2), ..., Mode(6). You can use CTRL for multiple select.
   5. Function: Re
   6. Click the Add Trace button
   7. Click the Done button
4. The plot you now see we need to format at bit to make it more easily readable.
   1. Double click on the y-axis numbers. This will get you the following dialogue:
Solution Data (continued)

2. Click the **Scaling**-tab.
3. Click the checkbox ‘**Scientific Notation**’
4. Write e.g. ‘**Resonant Frequency [Hz]**’ in the ‘Label’ text field

**Note:** To view a real-time update of the Eigenmode Data, set the Simulation to **Setup1, Last Adaptive**

2. Click the **Close** button

As you can see, the modes HFSS has found stays fairly constant in frequency versus iteration number after pass number 7. It is also easily identified that mode pair 5 & 6 as well as mode pair 1 & 2 are actually one and the same. The glitch in mode 5 between adaptive pass 4 and 6 is caused by the fact that mode 5 is not well represented by the mesh at pass no. 4. However, as mode 5 is degenerate we could most likely have plotted the fields at adaptive pass 4 by looking at the field distribution of mode 6 instead, and using our knowledge that the fields of the degenerate modes are orthogonal.
Field Overlays

We will now take the opportunity to look at the eigenmodes that HFSS has found. HFSS includes a number of different plotting techniques which will be explored in this section.

Create Field Overlay

To create a field plot:
1. Select the Global:YZ-plane in the model tree under the folder Planes.
2. Select the menu item HFSS > Fields > Fields > E > Mag_E
3. Create Field Plot Window
   1. Solution: Setup1 : LastAdaptive
   2. Quantity: Mag_E
   3. In Volume: All
   4. Click the Done button
4. You will now see the distribution of the Magnitude of the E-field on the XZ-cross plane for the complete model.

Mode 1: Magnitude of E-Field

Note: HFSS will be default display the first mode in the structure.

6. To change the mode excitation of the structure
   1. Select the menu item HFSS > Fields > Edit Sources
   2. Edit Sources window
      1. Set source: EigenMode_1 to magnitude: 0 and phase: 0
      2. Source: EigenMode_2 to magnitude: 1 and phase: 0
   3. Click the OK button
Magnitude of E plots in the XZ-plane

The following is a plot of the different mode field distribution in the XZ-plane, which has been created by modifying the source excitation.
Example - Dielectric Resonator

⚠️ **Magnitude of H plots in the XZ-plane**

⚠️ The following is a plot of the different mode field distributions in the XZ-plane for the H field.

⚠️ **Note**: The field distribution patterns for the H-field will at the default excitation (phase = 0) at times (depending on the setup) seemingly not provide any field - i.e. the...

Mode 1: Magnitude of H-Field

Mode 2: Magnitude of H-Field

Mode 3: Magnitude of H-Field

Mode 4: Magnitude of H-Field

Mode 5: Magnitude of H-Field

Mode 6: Magnitude of H-Field
Plotting Field Data on Custom Cut-plane

- It is possible to plot the field data on a custom defined cutplane. We will do this in the following:
  1. Create a new coordinate system which contains the cross plane of interest.
     1. Select 3D Modeler->Coordinate System->Create->Relative CS->Both
     2. Set origin to be at the center of the resonator by using the coordinate entry field:
        - X: 0.0, Y: 0.0, Z: 5.00 / 2, Press the Enter key
     3. Set the X-axis location
        - dX: 5.00, Y: 0.0, Z: -5.00 / 2, Press the Enter key
     4. Set the XY-plane (remember to select Absolute referencing on the coordinate toolbar)
        - X: 0.0, Y: 5.0, Z: 0.0 , Press the Enter key
  5. You will now see a new coordinate system called RelativeCS1. The cut-planes of this coordinate system can be selected in the Model Tree under the tab called Planes.
  6. Select RelativeCS1:XY
  7. Select HFSS > Fields > Fields > H > Mag_H and accept the defaults except setting Phase to 180deg. Do the same for Vector_H.
Example - Dielectric Resonator

Optimetrics Setup - Parametric Sweep

- We would now like to examine how the resonant frequencies changes as we change the the height of the cavity, \( H_{\text{Wall}} \). Ansoft HFSS with Optimetrics Parametric Sweep can automatically create these design curves.
- Since the structure already is parameterized with respect to \( H_{\text{Wall}} \), we will only need to create a parametric sweep. Afterwards we can then generate design trend curves to see how the modes shift.

**Note:** This exercise, will depending on the speed of your computer take quite some time. It took approximately 3.5 hours to solve on a 2.2GHz machine using at most 130Mb of RAM. Therefore if you want to follow this part of the exercise, you may want to reserve yourself more time than what is allotted during the standard Ansoft Training courses. Nevertheless, the exercise will give you some important insight into how the parametric analysis works together with the eigenmode solver in HFSS. Therefore, you may want to consider to

1. Reduce the Maximum number of adaptive passes used to 8
2. Reduce the number of \( H_{\text{Wall}} \) steps to 4 (using ‘Linear Count’ in the analysis setup)
3. Reduce the number of modes solved for to 4 (the TE_{0,m,\delta}, TM_{0,m,\delta}, and HEM modes + 1 degenerate).

Add a Parametric Sweep

1. Select the menu item **HFSS > Optimetrics Analysis > Add Parametric**
2. Setup **Sweep Analysis** Window:
   1. Click the **Sweep Definitions** tab:
      1. Click the **Add** button
      2. Add/Edit Sweep Dialog
         1. Variable: **HWall**
         2. Select **Linear Step**
         3. Start: **6mm**
         4. Stop: **15mm**
         5. Step: **1mm**
         6. Click the **Add >>** button
         7. Click the **OK** button
   2. Click on the **General** tab:
      1. Save Fields: **Checked**
      2. Click the **OK** button
**Save Project**

To save the project:
1. In an Ansoft HFSS window, select the menu item *File > Save*.

**Analyze**

To start the solution process:
1. Select the menu item *HFSS -> Analyze*
   - As previously mentioned this will take a couple of hours to solve depending on your solution settings.

**Create Reports**

**Create Mode plot vs. \( H_{Wall} \)**

To Create a report:
1. Select the menu item *HFSS > Results > Create Report*
2. Create Report Window:
   1. Report Type: *Eigenmode Parameters*
   2. Display Type: *Rectangular*
   3. Click the **OK** button
3. Traces Window:
   1. Solution: *Setup1: LastAdaptive*
   2. Click the Sweeps tab
      1. Select the **Sweep Design and Project Variable Values** button, to be able to look at the parametric sweeps and not only the nominal design
      2. In the table make sure \( H_{Wall} \) appears in the top of the Name column
   3. Click the **Y** tab
      1. Category: Eigen Modes
      2. Quantity: Mode(1), Mode(2), .... Mode(6).
      3. Function: Re
      4. Click the **Add Trace** button
   4. Click the **Done** button
4. Results can be seen on the following page, together with results from the reference stated on page 3.
Example - Dielectric Resonator

Mode dependence on $H_{wall}$

Modes found by HFSS

Modes found by Itoh et al.
Parametric investigation of mode dependence on $H_{\text{wall}}$

From the mode investigations on the previous page it is apparent that the results seems to qualitative the same. However ‘Mode 1’ which one would immediately think represents the $TM_{0\delta\delta}$-mode seems to flatten off towards $4.92\, \text{GHz}$ rather than rising to $5.72\, \text{GHz}$ at $H_{\text{wall}}=15\, \text{mm}$. This appears as a wrong result, but really is not. Rather this is due to the fact that:

- HFSS orders the modes such that the lowest resonant frequency always will be Mode 1, the second lowest resonant frequency will always be Mode 2 etc. That is

$$f_{\text{Mode}1} < f_{\text{Mode}2} < f_{\text{Mode}3} < \ldots < f_{\text{Mode}[n]}$$

Therefore to correlate the results we need to take this into consideration. We thus see that

- The TE$_{0\delta\delta}$-mode is represented by Mode 4 upto $H_{\text{Wall}}=12\, \text{mm}$ and thereafter by Mode 3
- The TM$_{0\delta\delta}$-mode is represented by Mode 1 upto $H_{\text{Wall}}=8\, \text{mm}$. Upto $12\, \text{mm}$ by Mode 3 and then finally by Mode 4 upto $16\, \text{mm}$.
- The hybrid mode, HEM, will be represented by Mode 3 upto $H_{\text{Wall}}=8\, \text{mm}$ and upwards by Mode 1 / Mode 2 (which again will be degenerate.

If we needed to determine the above without using a reference like Itoh, we would need to look at field plots to determine what the different modes found by HFSS represents. But as you have seen this is a fairly easy task simply but plotting the E and / or H fields in a cross section or within either the complete model volume or within specific parts of the model.

This concludes the exercise.
THIS PAGE INTENTIONALY LEFT BLANK
Chapter 7.0 - Filter Examples

- 7.1 - Bandpass Filter
- 7.2 - Bandstop Filter
Bandpass Filter

This example is intended to show you how to create, simulate, and analyze a bandpass filter using the Ansoft HFSS Design Environment.

Nominal Design:

- $F_{center} = 1.50\ \text{GHz}$
- $BW = 1\ \text{GHz}$
Example - Bandpass Filter

Ansoft Design Environment
- The following features of the Ansoft HFSS Design Environment are used to create this passive device model
  - 3D Solid Modeling
    - Primitives: Cylinders, Boxes
    - Boolean Operations: Duplicate Around Axis
  - Boundary/Excitation
    - Ports: Wave Ports and Terminal Lines
  - Analysis
    - Sweep: Fast Frequency
  - Results
    - Cartesian plotting
  - Fields Overlays
    - 2D & 3D Field Plots
Example - Bandpass Filter

Getting Started

Launching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft, HFSS 10 program group. Click HFSS 10.

Setting Tool Options

To set the tool options:

Note: In order to follow the steps outlined in this example, verify that the following tool options are set:

1. Select the menu item Tools > Options > HFSS Options
2. HFSS Options Window:
   1. Click the General tab
      ▲ Use Wizards for data entry when creating new boundaries: ☑ Checked
      ▲ Duplicate boundaries with geometry: ☑ Checked
   2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:
   1. Click the Operation tab
      ▲ Automatically cover closed polylines: ☑ Checked
   2. Click the Drawing tab
      ▲ Edit property of new primitives: ☑ Checked
   3. Click the OK button
7.1 Example - Bandpass Filter

## Opening a New Project

To open a new project:
- In an Ansoft HFSS window, click the \(\text{File} > \text{New}\).
- From the Project menu, select Insert HFSS Design.

## Set Solution Type

To set the solution type:
- Select the menu item HFSS \(\text{Solution Type}\).
- Solution Type Window:
  - Choose Driven Terminal
  - Click the OK button
Creating the 3D Model

Set Model Units
- To set the units:
  - Select the menu item **3D Modeler > Units**
  - Set Model Units:
    - Select Units: in
    - Click the OK button

Set Default Material
- To set the default material:
  - Using the 3D Modeler Materials toolbar, choose *vacuum*

Create Body
- To create body:
  1. Select the menu item **Draw > Box**
  2. Using the coordinate entry fields, enter the box position
     - X: -1.0, Y: -1.7, Z: -0.3125, Press the Enter key
  2. Using the coordinate entry fields, enter the opposite corner of the box
     - dX: 2.0, dY: 3.4, dZ: 0.0, Press the Enter key
  1. Using the coordinate entry fields, enter the box height
     - dX: 0.0, Y: 0.0, Z: 0.625, Press the Enter key

- To set the name:
  1. Select the Attribute tab from the Properties window.
  2. For the Value of Name type: air
  3. Click the OK button

- To fit the view:
  1. Select the menu item **View > Fit All > Active View.** Or press the CTRL+D key
Example - Bandpass Filter

Create coax outer diameter

To create the outer diameter:
1. From the Drawing Plane toolbar, change the active plane to YZ.
2. Select the menu item Draw > Cylinder
3. Using the coordinate entry fields, enter the center position
   X: 1.0, Y: -0.9, Z: 0.0, Press the Enter key
4. Using the coordinate entry fields, enter the radius of the cylinder
   dX: 0.0, dY: 0.14, dZ: 0.0, Press the Enter key
5. Using the coordinate entry fields, enter the height of the cylinder
   dX: 0.75, dY: 0.0, dZ: 0.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: feed1
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
   1. Type pec in the Search by Name field
   2. Click the OK button
### Create coax inner diameter

**To create the inner diameter:**
1. Select the menu item **Draw > Cylinder**
2. Using the coordinate entry fields, enter the center position
   - \( X: 1.0, Y: -0.9, Z: 0.0 \), Press the **Enter** key
3. Using the coordinate entry fields, enter the radius of the cylinder
   - \( dX: 0.0, dY: 0.06, dZ: 0.0 \), Press the **Enter** key
4. Using the coordinate entry fields, enter the height of the cylinder
   - \( dX: 0.75, dY: 0.0, dZ: 0.0 \), Press the **Enter** key

**To set the name:**
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: \textit{feedin1}
3. Click the **OK** button

**To fit the view:**
1. Select the menu item **View > Fit All > Active View**.

### Create the coax feed probe

**To create the coax feed probe:**
1. Select the menu item **Draw > Cylinder**
2. Using the coordinate entry fields, enter the center position
   - \( X: 1.0, Y: -0.9, Z: 0.0 \), Press the **Enter** key
3. Using the coordinate entry fields, enter the radius of the cylinder
   - \( dX: 0.0, dY: 0.06, dZ: 0.0 \), Press the **Enter** key
4. Using the coordinate entry fields, enter the height of the cylinder
   - \( dX: -0.15, dY: 0.0, dZ: 0.0 \), Press the **Enter** key

**To set the name:**
1. Select the **Attribute** tab from the **Properties** window
2. For the **Value of Name** type: \textit{feedprobe1}
3. Click the **OK** button

**To fit the view:**
1. Select the menu item **View > Fit All > Active View**.
Create the resonators

To create l1:
1. Select the menu item **Draw > Box**
2. Using the coordinate entry fields, enter the box position
   - X: 0.85, Y: -0.9625, Z: -0.03, Press the **Enter** key
3. Using the coordinate entry fields, enter the opposite corner of the box
   - dX: -1.7, dY: 0.125, dZ: 0.06, Press the **Enter** key

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: l1
3. Click the **OK** button

To create l2:
1. Select the menu item **Draw > Box**
2. Using the coordinate entry fields, enter the box position
   - X: -1.0, Y: -0.75, Z: -0.03, Press the **Enter** key
3. Using the coordinate entry fields, enter the opposite corner of the box
   - dX: 1.818, dY: 0.125, dZ: 0.06, Press the **Enter** key

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: l2
3. Click the **OK** button

To create l3:
1. Select the menu item **Draw > Box**
2. Using the coordinate entry fields, enter the box position
   - X: 1.0, Y: -0.48, Z: -0.03, Press the **Enter** key
3. Using the coordinate entry fields, enter the opposite corner of the box
   - dX: -1.818, dY: 0.125, dZ: 0.06, Press the **Enter** key

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: l3
3. Click the **OK** button
7.1-9

Example - Bandpass Filter

Create the resonators (Continued)

To create l4:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: -1.0, Y: -0.2, Z: -0.03, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box
   - dX: 1.818, dY: 0.125, dZ: 0.06, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: l4
3. Click the OK button

Create the Wave port

Picking the port face:
1. Select the menu item Edit > Select > Faces
2. Graphically select the outer face of the coax line at X=1.75in

To assign the wave port excitation:
1. Select the menu item HFSS > Excitations > Assign > Wave Port
2. Wave Port: General
   - Name: p1
   - Click the Next button
3. Wave Port: Terminals
   - Number of Terminals: 1,
   - For T1, click the Undefined column and select New Line
   - Using the coordinate entry fields, enter the vector position
     - X: 1.75, Y: -0.9, Z: -0.14, Press the Enter key
   - Using the coordinate entry fields, enter the vertex
     - dX: 0.0, dY: 0.0, dZ: 0.08, Press the Enter key
   - Click the Next button
4. Wave Port: Differential Pairs
   - Click the Next button
5. Wave Port: Post Processing
   - Full Port Impedance: 50
6. Click the Finish button
### Example - Bandpass Filter

**Set Object Selection**
- Set select to objects
  1. Select the menu item *Edit > Select > Objects*

**Create rest of model by duplication**
- **To select objects to be duplicated:**
  1. Select the menu item *Edit > Select > By Name*
  2. Select Object Dialog,
     1. Select the objects named: *feed1, feedpin1, feedprobe1, l1, l2, l3, l4*
        - **Note:** Use the Ctrl + Left mouse button to select multiple objects
     2. Click the OK button
- **To create rest of model:**
  1. Select the menu item *Edit > Duplicate > Around Axis*
     - Axis: Z
     - Angle: 180
     - Total Number: 2
     - Click the OK button
- **To fit the view:**
  1. Select the menu item *View > Fit All > Active View.*
Boundary Display

To verify the boundary setup:

1. Select the menu item HFSS > Boundary Display (Solver View)
2. From the Solver View of Boundaries, toggle the Visibility check box for the boundaries you wish to display.
   - Note: The background (Perfect Conductor) is displayed as the outer boundary.
   - Note: The Perfect Conductors are displayed as the smetal boundary.
   - Note: Select the menu item, View > Visibility, to hide all of the geometry objects. This makes it easier to see the boundary.
3. Click the Close button when you are finished.
7.1 Example - Bandpass Filter

Analysis Setup

Creating an Analysis Setup

To create an analysis setup:
1. Select the menu item HFSS > Analysis Setup > Add Solution Setup
2. Solution Setup Window:
   1. Click the General tab:
      ▶ Solution Frequency: 1.5GHz
      ▶ Maximum Number of Passes: 15
      ▶ Maximum Delta S per Pass: 0.02
   2. Click the OK button

Adding a Frequency Sweep

To add a frequency sweep:
1. Select the menu item HFSS > Analysis Setup > Add Sweep
   1. Select Solution Setup: Setup1
   2. Click the OK button
2. Edit Sweep Window:
   1. Sweep Type: Fast
   2. Frequency Setup Type: Linear Count
      ▶ Start: 0.6GHz
      ▶ Stop: 2.4GHz
      ▶ Count: 451
      ▶ Save Fields: ✔ Checked
   3. Click the OK button
7.1 Example - Bandpass Filter

**Save Project**

To save the project:
1. In an Ansoft HFSS window, select the menu item File > Save As.
2. From the Save As window, type the Filename: hfss_bpf
3. Click the Save button

**Analyze**

**Model Validation**

To validate the model:
1. Select the menu item HFSS > Validation Check
2. Click the Close button
   
   Note: To view any errors or warning messages, use the Message Manager.

**Analyze**

To start the solution process:
1. Select the menu item HFSS > Analyze
Example - Bandpass Filter

Solution Data

To view the Solution Data:
1. Select the menu item HFSS > Results > Solution Data
   - To view the Profile:
     1. Click the Profile Tab.
   - To view the Convergence:
     1. Click the Convergence Tab
     - Note: The default view is for convergence is Table. Select the Plot radio button to view a graphical representations of the convergence data.
   - To view the Matrix Data:
     1. Click the Matrix Data Tab
     - Note: To view a real-time update of the Matrix Data, set the Simulation to Setup1, Last Adaptive
2. Click the Close button

![Solution Data](image)
7.1 Example - Bandpass Filter

Create Reports

Create S-parameter vs. Frequency

To Create a report:
1. Select the menu item HFSS > Results > Create Report
2. Create Report Window:
   1. Report Type: Terminal S Parameters
   2. Display Type: Rectangular
   3. Click the OK button
3. Traces Window:
   1. Solution: Setup1: Sweep1
   2. Click the Y tab
      1. Domain: Sweep
      2. Category: Terminal S-Parameters
      3. Quantity: S(p1,p1), S(p2,p1)
      4. Function: dB
      5. Click the Add Trace button
   3. Click the Done button

![Graphic of S-parameter vs. Frequency plot]
Add a zoomed trace to the existing plot

To modify an existing plot:
- Right mouse click on the existing plot
- Select Modify Report… from the context menu

To add the trace:
1. Traces Window:
   1. Solution: Setup1: Sweep1
   2. Click the Y tab
      1. Domain: Sweep
      2. Category: Terminal S-Parameters
      3. Quantity: S(p2,p1)
      4. Function: dB
      5. Click the Add Trace button
   3. From the listing at the top of the Traces window, select the axis pulldown for the second instance of S(p2,p1), and select Y2
   4. Click the Done button

<table>
<thead>
<tr>
<th>X</th>
<th>Y</th>
<th>Y-axis</th>
</tr>
</thead>
<tbody>
<tr>
<td>Freq</td>
<td>dB[S1(p1,p1)]</td>
<td>Y1</td>
</tr>
<tr>
<td>Freq</td>
<td>dB[S1(p2,p1)]</td>
<td>Y1</td>
</tr>
<tr>
<td>Freq</td>
<td>dB[S1(p2,p1)]</td>
<td>Y2</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Add Blank Trace
Remove Trace
Remove All Traces

Print... Properties... Copy to Clipboard Export to File...
7.1 Example - Bandpass Filter

- **Change Plot Scale**
  - Plot window:
    1. Double click on the Y-axis on the right side of the plot,
    2. Y Axis Properties Dialog
      1. Click the **Scaling** tab
      2. Autoscale: **Unchecked**
      3. Min: -1.0
      4. Max: 0.0
      5. Click the OK button
Field Overlays

Set Sources: Terminate Port

To set the port termination:
1. Select the menu item **HFSS > Fields > Edit Sources**
2. Edit Sources Window:
   1. Select source: **p2:T1**
      - Terminated: **Checked**
      - Resistance: **50**
      - Reactance: **0**
   2. Click the **OK** button
Field Overlays (Continued)

Create Field Overlay

Select the Global XY Plane
1. Using the Model Tree, expand Planes
   1. Select Global:XY
2. Select the menu item HFSS > Fields > Fields > E > Mag_E
3. Create Field Plot Window
   1. Solution: Setup1 : LastAdaptive
   2. Quantity: Mag_E
   3. In Volume: All
   4. Click the Done button

To modify the attributes of a field plot:
1. Select the menu item HFSS > Fields > Modify Plot Attributes
2. Select Plot Folder Window:
   1. Select: E Field
   2. Click the OK button
3. E-Field1 Window:
   1. Click the Scale tab
      1. Select Use Limits
      2. Min: 5
      3. Max: 1500
      4. Scale: Log
   2. Click the Close button
THIS PAGE INTENTIONALY LEFT BLANK
The Microstrip Bandstop Filter

This example is intended to show you how to create, simulate, and analyze a microstrip filter using the Ansoft HFSS Design Environment.

Nominal Design:
- \( L_1 = 91.2 \text{ mil} \)
- \( L_2 = 86.4 \text{ mil} \)
- \( S = 4.8 \text{ mil} \)
Example - Microstrip Bandstop Filter

Getting Started

Launching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft > HFSS 10 program group. Click HFSS 10.

Setting Tool Options

To set the tool options:

Note: In order to follow the steps outlined in this example, verify that the following tool options are set:

1. Select the menu item Tools > Options > HFSS Options
2. HFSS Options Window:
   1. Click the General tab
      - Use Wizards for data entry when creating new boundaries: ✔ Checked
      - Duplicate boundaries with geometry: ✔ Checked
   2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:
   1. Click the Operation tab
      - Automatically cover closed polylines: ✔ Checked
   2. Click the Drawing tab
      - Edit property of new primitives: ✔ Checked
   3. Click the OK button
## Example - Microstrip Bandstop Filter

### Opening a New Project

**To open a new project:**

- In an Ansoft HFSS window, click the `File` on the Standard toolbar, or select the menu item `File > New`.
- From the `Project` menu, select `Insert HFSS Design`.

### Set Solution Type

**To set the solution type:**

- Select the menu item `HFSS > Solution Type`.
- Solution Type Window:
  - Choose `Driven Terminal`
  - Click the `OK` button.
Creating the 3D Model

Set Model Units

To set the units:
1. Select the menu item 3D Modeler > Units
2. Set Model Units:
   1. Select Units: mil
   2. Click the OK button

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
   1. Type pec in the Search by Name field
   2. Click the OK button
Create Input 1

To create the input:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   - dX: -4.8, dY: -14.4, dZ: 0.1, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Input1
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Create L1

To create L1:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   - dX: -4.8, dY: 91.2, dZ: 0.1, Press the Enter key

To parameterize the object:
1. Select the Command tab from the Properties window
2. For YSize, type: L1, Click the Tab key to accept
   - Add Variable L1: 91.2mil, Click the OK button

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: L1
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
### Example - Microstrip Bandstop Filter

#### Create S for Stub 1

**To create S:**

1. Select the menu item `Draw > Box`
2. Using the coordinate entry fields, enter the box position
   
   - X: 0.0, Y: 0.0, Z: 0.0, Press the **Enter** key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   
   - dX: 4.8, dY: 4.8, dZ: 0.1, Press the **Enter** key

**To parameterize the object:**

1. Select the **Command** tab from the **Properties** window
2. For **XSize**, type: **S**, Click the **Tab** key to accept
   
   - Add Variable **S**: 4.8mil, Click the **OK** button

**To set the name:**

1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: **S_Stub1**
3. Click the **OK** button

**To fit the view:**

1. Select the menu item `View > Fit All > Active View.`
Example - Microstrip Bandstop Filter

▲ Set Grid Plane

▲ To set the grid plane:
1. Select the menu item 3D Modeler > Grid Plane > XZ

▲ Create Source 1

▲ To create source:
1. Select the menu item Draw > Rectangle
2. Using the coordinate entry fields, enter the box position
   X: 0.0, Y: -14.4, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   dX: -4.8, dY: 0.0, dZ: -5.0, Press the Enter key

▲ To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Source1
3. Click the OK button

▲ To fit the view:
1. Select the menu item View > Fit All > Active View.
7.2 Example – Microstrip Bandstop Filter

Assign Excitation

To select the object Source:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Source1
   2. Click the OK button

Note: You can also select the object from the Model Tree

To assign lumped port excitation
1. Select the menu item HFSS > Excitations > Assign > Lumped Port
2. Lump Port: General
   1. Name: p1,
   2. Resistance: 50
   3. Reactance: 0
   4. Click the Next button
3. Lump Port: Terminals
   1. Number of Terminals: 1,
   2. For T1, click the Undefined column and select New Line
   3. Using the coordinate entry fields, enter the vector position
      X: -2.4, Y: -14.4, Z: -5.0, Press the Enter key
   4. Using the coordinate entry fields, enter the vertex
      dX: 0.0, dY: 0.0, dZ: 5.0, Press the Enter key
   4. Click the Next button
5. Wave Port: Post Processing
   1. Full Port Impedance: 50

Set Grid Plane

To set the grid plane:
1. Select the menu item 3D Modeler > Grid Plane > XY
7.2 Example – Microstrip Bandstop Filter

Create Offset Coordinate System

To create an offset Coordinate System:
1. Select the menu item 3D Modeler > Coordinate System > Create > Relative CS > Offset
2. Using the coordinate entry fields, enter the origin
   - X: 4.8, Y: 0.0, Z: 0.0, Press the Enter key

Set Working Coordinate System

To set the working coordinate system:
1. Select the menu item 3D Modeler > Coordinate System > Set Working CS
2. Select Coordinate System Window,
   - 1. From the list, select the CS: RelativeCS1
   - 2. Click the Select button

To set the name:
- Note: After selecting the coordinate system, its properties will be displayed in the property window. If you do not see the properties, repeat the steps to set the working coordinate system, or select the CS from the model tree.
1. For the Value of Name type: CS_SStub1

To parameterize the origin:
- Note: After selecting the coordinate system, its properties will be displayed in the property window. If you do not see the properties, repeat the steps to set the working coordinate system, or select the CS from the model tree
1. For the Value of Origin type: S, 0, 0, Click the Tab key to accept
Example - Microstrip Bandstop Filter

Create L2 for Stub 1

To create L2:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   dX: 4.8, dY: 86.4, dZ: 0.1, Press the Enter key

To parameterize the object:
1. Select the Command tab from the Properties window
2. For YSize, type: L2, Click the Tab key to accept
   1. Add Variable L2: 86.4mil, Click the OK button

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: L2_Stub1
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Set Working Coordinate System

To set the working coordinate system:
1. Select the menu item 3D Modeler > Coordinate System > Set Working CS
2. Select Coordinate System Window,
   1. From the list, select the CS: Global
   2. Click the Select button
Example - Microstrip Bandstop Filter

Create Offset Coordinate System

To create an offset Coordinate System:
1. Select the menu item 3D Modeler > Coordinate System > Create > Relative CS > Offset
2. Using the coordinate entry fields, enter the origin X: -4.8, Y: 91.2, Z: 0.0, Press the Enter key

Set Working Coordinate System

To set the working coordinate system:
1. Select the menu item 3D Modeler > Coordinate System > Set Working CS
2. Select Coordinate System Window,
   1. From the list, select the CS: RelativeCS1
   2. Click the Select button

To set the name:
Note: After selecting the coordinate system, its properties will be displayed in the property window. If you do not see the properties, repeat the steps to set the working coordinate system, or select the CS from the model tree.
1. For the Value of Name type: CS_L1

To parameterize the origin:
Note: After selecting the coordinate system, its properties will be displayed in the property window. If you do not see the properties, repeat the steps to set the working coordinate system, or select the CS from the model tree
1. For the Value of Origin type: -4.8, L1, 0, Click the Tab key to accept
Example – Microstrip Bandstop Filter

7.2 Create Input2

To create the input:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   dX: 4.8, dY: 4.8+14.4, dZ: 0.1, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Input2
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Create S for Stub 2

To create S:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   dX: -4.8, dY: 4.8, dZ: 0.1, Press the Enter key

To parameterize the object:
1. Select the Command tab from the Properties window
2. For XSize, type: -S, Click the Tab key to accept

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: S_Stub2
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
Example - Microstrip Bandstop Filter

Set Grid Plane

To set the grid plane:
1. Select the menu item **3D Modeler > Grid Plane > XZ**

Create Source 2

To create source:
1. Select the menu item **Draw > Rectangle**
2. Using the coordinate entry fields, enter the box position
   - X: 0.0, Y: 4.8+14.4, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: 4.8, dY: 0.0, dZ: -5.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: **Source2**
3. Click the OK button

To fit the view:
1. Select the menu item **View > Fit All > Active View**.
Assign Excitation

To select the object Source:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Source2
   2. Click the OK button

Note: You can also select the object from the Model Tree

To assign lumped port excitation
1. Select the menu item HFSS > Excitations > Assign > Lumped Port
2. Lumped Port : General
   1. Name: p2,
   2. Resistance: 50
   3. Reactance: 0
   4. Click the Next button
3. Lumped Port : Terminals
   1. Number of Terminals: 1,
   2. For T1, click the Undefined column and select New Line
   3. Using the coordinate entry fields, enter the vector position
      X: 2.4, Y: 19.2, Z: -5.0, Press the Enter key
   4. Using the coordinate entry fields, enter the vertex
      dX: 0.0, dY: 0.0, dZ: 5.0, Press the Enter key
4. Click the Next button
5. Wave Port : Post Processing
   1. Full Port Impedance : 50

Set Grid Plane

To set the grid plane:
1. Select the menu item 3D Modeler > Grid Plane > XY
Example – Microstrip Bandstop Filter

Create Offset Coordinate System

- **To create an offset Coordinate System:**
  1. Select the menu item *3D Modeler > Coordinate System > Create > Relative CS > Offset*
  2. Using the coordinate entry fields, enter the origin
     - X: -4.8, Y: 0.0, Z: 0.0, Press the *Enter* key

Set Working Coordinate System

- **To set the working coordinate system:**
  1. Select the menu item *3D Modeler > Coordinate System > Set Working CS*
  2. Select Coordinate System Window,
     1. From the list, select the CS: *RelativeCS1*
     2. Click the *Select* button

**To set the name:**

- **Note:** After selecting the coordinate system, its properties will be displayed in the property window. If you do not see the properties, repeat the steps to set the working coordinate system, or select the CS from the model tree.

  1. For the *Value of Name* type: *CS_Stub2*

**To parameterize the origin:**

- **Note:** After selecting the coordinate system, its properties will be displayed in the property window. If you do not see the properties, repeat the steps to set the working coordinate system, or select the CS from the model tree

  1. For the *Value of Origin* type: *-S, 0, 0*, Click the *Tab* key to accept
Create L2 for Stub 2

To create L2:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: 0.0, Y: 4.8, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   - dX: -4.8, dY: -86.4, dZ: 0.1, Press the Enter key

To parameterize the object:
1. Select the Command tab from the Properties window
2. For YSize, type: -L2, Click the Tab key to accept

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: L2_Stub2
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
Example - Microstrip Bandstop Filter

Set Working Coordinate System

To set the working coordinate system:
1. Select the menu item 3D Modeler > Coordinate System > Set Working CS
2. Select Coordinate System Window,
   1. From the list, select the CS: Global
   2. Click the Select button

Create Ground

To create the ground:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: -34.4, Y: -34.4, Z: -5.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   - dX: 64.0, dY: 164.8, dZ: -0.1, Press the Enter key

To parameterize the object:
1. Select the Command tab from the Properties window
2. For Position, type: -S-29.6mil, -34.4mil, -5mil, Click the Tab key to accept
3. For XSize, type: 54.4mil+2*S, Click the Tab key to accept
4. For YSize, type: 73.6mil+L1, Click the Tab key to accept

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Ground
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
Example - Microstrip Bandstop Filter

**Add New Material**

To add a new material:
1. Using the 3D Modeler Materials toolbar, choose **Select**
2. From the Select Definition window, click the **Add Material** button
3. **View/Edit Material Window**:
   1. Material Name: **My_Alumina**
   2. Relative Permittivity: **9.9**
   3. Click the **OK** button
4. Click the **OK** button
Create Substrate

To create the substrate:
1. Select the menu item **Draw > Box**
2. Using the coordinate entry fields, enter the box position:
   - X: -34.4, Y: -34.4, Z: 0.0, Press the **Enter** key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   - dX: 64.0, dY: 164.8, dZ: -5.0, Press the **Enter** key

To parameterize the object:
1. Select the **Command** tab from the **Properties** window
2. For **Position**, type: -S-29.6mil, -34.4mil, 0mil, Click the **Tab** key to accept
3. For **XSize**, type: 54.4mil+2*S, Click the **Tab** key to accept
4. For **YSize**, type: 73.6mil+L1, Click the **Tab** key to accept

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value** of **Name** type: **Substrate**
3. Click the **OK** button

To fit the view:
1. Select the menu item **View > Fit All > Active View**.

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose **vacuum**
Example - Microstrip Bandstop Filter

### Create Air

**To create the Air:**
1. Select the menu item **Draw > Box**
2. Using the coordinate entry fields, enter the box position
   - X: -34.4, Y: -34.4, Z: -5.1
   - Press the **Enter** key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   - dX: 64.0, dY: 164.8, dZ: 50.0
   - Press the **Enter** key

**To parameterize the object:**
1. Select the **Command** tab from the **Properties** window
2. For **Position**, type: -S-29.6mil, -34.4mil, -5.1mil
   - Click the **Tab** key to accept
3. For **XSize**, type: 54.4mil+2*S
   - Click the **Tab** key to accept
4. For **YSize**, type: 73.6mil+L1
   - Click the **Tab** key to accept

**To set the name:**
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: Air
3. Click the **OK** button

**To fit the view:**
1. Select the menu item **View > Fit > Active View**.

### Create Radiation Boundary

**To select the object Air:**
1. Select the menu item **Edit > Select > By Name**
2. Select Object Dialog,
   1. Select the objects named: Air
   2. Click the **OK** button

**To create a radiation boundary**
1. Select the menu item **HFSS > Boundaries > Assign > Radiation**
2. Radiation Boundary Window
   - Name: **Rad1**
   - Click the **OK** button
Boundary Display

To verify the boundary setup:

1. Select the menu item **HFSS > Boundary Display (Solver View)**
2. From the Solver View of Boundaries, toggle the Visibility check box for the boundaries you wish to display.
   - **Note:** The background (Perfect Conductor) is displayed as the outer boundary.
   - **Note:** The Perfect Conductors are displayed as the smetal boundary.
   - **Note:** Select the menu item, **View > Visibility** to hide all of the geometry objects. This makes it easier to see the boundary.
3. Click the **Close** button when you are finished.

![Solver View of Boundaries](image)
### Analysis Setup

#### Creating an Analysis Setup

To create an analysis setup:

1. Select the menu item **HFSS > Analysis Setup > Add Solution Setup**
2. Solution Setup Window:
   1. Click the **General** tab:
      - Solution Frequency: **20.0GHz**
      - Maximum Number of Passes: **20**
      - Maximum Delta S per Pass: **0.02**
   2. Click the **OK** button

#### Adding a Frequency Sweep

To add a frequency sweep:

1. Select the menu item **HFSS > Analysis Setup > Add Sweep**
   1. Select Solution Setup: **Setup1**
   2. Click the **OK** button
2. Edit Sweep Window:
   1. Sweep Type: **Fast**
   2. Frequency Setup Type: **Linear Step**
      - Start: **4.0GHz**
      - Stop: **20.0GHz**
      - Step: **0.05GHz**
      - Save Fields: **Checked**
   3. Click the **OK** button
Example - Microstrip Bandstop Filter

- **Save Project**
  - **To save the project:**
    1. In an Ansoft HFSS window, select the menu item *File > Save As*.
    2. From the *Save As* window, type the Filename: `hfss_msbsf`
    3. Click the *Save* button

- **Analyze**

- **Model Validation**
  - **To validate the model:**
    1. Select the menu item *HFSS > Validation Check*
    2. Click the *Close* button
  - **Note:** To view any errors or warning messages, use the Message Manager.

- **Analyze**
  - **To start the solution process:**
    1. Select the menu item *HFSS > Analyze*
Example - Microstrip Bandstop Filter

**Solution Data**

To view the Solution Data:

1. Select the menu item HFSS > Results > Solution Data

To view the Profile:

1. Click the Profile Tab.

To view the Convergence:

1. Click the Convergence Tab

**Note:** The default view is for convergence is Table. Select the Plot radio button to view a graphical representation of the convergence data.

To view the Matrix Data:

1. Click the Matrix Data Tab

**Note:** To view a real-time update of the Matrix Data, set the Simulation to Setup1, Last Adaptive

2. Click the Close button

---

**Solutions: hfs_mbsf · HFSSModel11**

- **Design Variation:**
  - L1=31.2mil, L2=88.4mil, S=4.8mil
- **Simulation:**
  - Setup1

**Profile**

- **Number of Passes**
  - Completed: 9
  - Maximum: 20
  - Minimum: 1

- **Max Mag. Delta S**
  - Target: 0.02
  - Current: 0.0180030

**View:**

- Table
- Plot

**X:**

- Pass Number
- Converged

**Y:**

- Max Mag. Delta S

**Consecutive Passes**

- Target: 1
- Current: 1

---

**Close**
## Create Reports

### Create S-parameter vs. Frequency

To Create a report:

1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   - 1. Report Type: **Terminal S Parameters**
   - 2. Display Type: **Rectangular**
   - 3. Click the **OK** button
3. Traces Window:
   - 1. Solution: **Setup1: Sweep1**
   - 2. Click the **Y** tab
     - 1. Domain: **Sweep**
     - 2. Category: **Terminal S-Parameters**
     - 3. Quantity: **St(p1,p1), St(p2,p1)**
     - 4. Function: **dB**
     - 5. Click the **Add Trace** button
   - 3. Click the **Done** button

![Graph of S-parameter vs. Frequency](image-url)
THIS PAGE INTENTIONALY LEFT BLANK
Chapter 8.0 - Signal Integrity Examples

8.1 - LVDS Differential Pair
   Includes Optimetrics Example
   8.1a - LVDS Differential Pair Transient Simulation (Ansoft Designer)

8.2 - Segmented Return Path
   8.2a - Segmented Return Path TDR (Ansoft Designer)

8.3 - Non-Ideal Planes

8.4 - Return Path
LVDS Differential Pair

This differential pair example is intended to show you how to create, simulate, and analyze a differential pair using the Ansoft HFSS Design Environment.

Low Voltage Differential Signaling (LVDS) technology is used for high-performance backplanes. The LVDS is used for multi-point communications and uses a bus similar to system show below. The following illustrations detail the passive device you will be creating.

Nominal Design:
- Traces:
  - Width = 6mil
  - Spacing = 18mil
  - Thickness = 0.7mil
  - Length = 1000mil
- Substrate:
  - Thickness = 26mil
  - \( \varepsilon_r = 4.4 \)
Ansoft HFSS Design Environment

The following features of the Ansoft HFSS Design Environment are used to create this passive device model.

- **3D Solid Modeling**
  - Primitives: **Box, Rectangles**
  - Boolean Operations: **Duplicate Along Line, Sweep Along Vector**

- **Boundaries/Excitations**
  - Ports: **Wave Ports, Terminal Lines**

- **Analysis**
  - Sweep: **Interpolating**

- **Results**
  - **Cartesian and Smith Chart plotting**

- **Field Overlays**
  - **3D Field Plots**
Example - LVDS Differential Pair

**Design Review**

Before we jump into setting up this device, let's review the design.

- Trace Width = 6mils
- Trace Length = 1000mils
- Dielectric Height = 13mils x 2
- 1/2oz copper Traces/Grounds = 0.7mils
- Port Size = ???

**Port Width**

From the Using Ports section, the port width should be at least 3-5 times the stackup (78-130mils). Since the traces are not centered, let's use 5x and add the pair spacing (18mils) for a total port/model width of 220mils.

**Trace Length**

Since we are modeling a uniform transmission line, we do not need to simulate the 1000mils length. Let's reduce the model to 100 mils and use de-embedding to add the extra length.

**Material Properties**

To start with, let's make an engineering assumption that the material properties are constant over frequency. In addition, we will assume that the modeling the traces as perfect conductors will not have an impact on the performance of the device. This will speed up the simulation. As an additional exercise, the model can be modified to include frequency dependent materials and lossy conductors.

**Ground Planes**

Since we are ignoring the metal conductivity, we do not need to create objects for the ground planes. Instead, we will utilize the background (Perfect Conductor) boundary. If we need to investigate the effects of copper, a finite conductivity boundary condition can be used to simulate the copper ground planes.
Solution Setup

Since we are going to use the model for SPICE simulation, the frequency range of interest is going to be determined by the rise-time(tr) of the input signal. The maximum frequency is calculated by taking 0.5/tr, or the knee frequency, and multiplying it by the number of samples per tr. The minimum frequency should be selected as close to DC as possible.

The following values will be used for the Solution Setup:

- Rise-Time(tr): 330ps
- Number of Samples: 5
  - Upper Frequency: (0.5/330ps)*5 ~ 7.58GHz or 8.0GHz
  - Lower Frequency: 0.01GHz
  - Frequency Spacing: 0.01GHz
  - Single(Adaptive) Frequency: 8.0GHz
  - Adaptive Passes: 10
  - Delta S: 0.02
  - Sweep Type: Interpolating
Getting Started

Launching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft, HFSS 10 program group. Click HFSS 10.

Setting Tool Options

To set the tool options:

Note: In order to follow the steps outlined in this example, verify that the following tool options are set:

1. Select the menu item Tools > Options > HFSS Options
2. HFSS Options Window:
   1. Click the General tab
      - Use Wizards for data entry when creating new boundaries: ☑ Checked
      - Duplicate boundaries with geometry: ☑ Checked
   2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:
   1. Click the Operation tab
      - Automatically cover closed polylines: ☑ Checked
   2. Click the Drawing tab
      - Edit property of new primitives: ☑ Checked
   3. Click the OK button
Example - LVDS Differential Pair

## Opening a New Project

To open a new project:

1. In an Ansoft HFSS window, click the File tab on the Standard toolbar, or select the menu item `File > New`.
2. From the Project menu, select `Insert HFSS Design`.

![Opening a New Project](image)

## Set Solution Type

To set the solution type:

1. Select the menu item `HFSS > Solution Type`.
2. Solution Type Window:
   1. Choose `Driven Terminal`
   2. Click the OK button

![Set Solution Type](image)
Creating the 3D Model

Set Model Units

To set the units:
1. Select the menu item **3D Modeler > Units**
2. Set Model Units:
   1. Select Units: mil
   2. Click the OK button

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
   1. Type **pec** in the **Search by Name** field
   2. Click the OK button
Create Trace 1

To create trace 1:

1. Select the menu item **Draw > Box**
2. Using the coordinate entry fields, enter the box position:
   - **X:** 0.0, **Y:** 9.0, **Z:** -0.35, Press the **Enter** key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - **dX:** 100.0, **dY:** 6.0, **dZ:** 0.7, Press the **Enter** key

To parameterize the object:

1. Select the **Command** tab from the **Properties** window.
2. For **Position**, type: **0.0mil, S/2, -0.35mil**, Click the **Tab** key to accept
   - Add Variable **S:** 18mil, Click the **OK** button
3. For **YSize**, type: **W**, Click the **Tab** key to accept
   - Add Variable **W:** 6mil, Click the **OK** button

To set the name:

1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: **trace1**
3. Click the **OK** button

To fit the view:

1. Select the menu item **View > Fit All > Active View**.
   Or press the **CTRL+D** key
Create Trace 2

To create trace 2:
1. Select the menu item **Edit > Select All Visible**. Or press the **CTRL+A** key.
2. Select the menu item, **Edit > Duplicate > Mirror**.
   1. Input the anchor point of the mirror plane:
      - X: 0.0, Y: 0.0, Z: 0.0, Press the **Enter** key
   2. Input the target point of the vector normal to the mirror plane:
      - dX: 0.0, dY: -1.0, dZ: 0.0, Press the **Enter** key

To set the name:
1. Select the menu item **HFSS > List**
2. From the **Model** tab, select the object named **trace1_1**
3. Click the **Properties** button
   1. For the **Value** of **Name** type: **trace2**
   2. Click the **OK** button
4. Click the **Done** button

To fit the view:
1. Select the menu item **View > Fit All > Active View**.
Add New Material

To add a new material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. From the Select Definition window, click the Add Material button
3. View/Edit Material Window:
   1. Material Name: My_FR4
   2. Relative Permittivity: 4.4
   3. Click the OK button
4. Click the OK button
Create Substrate

To create substrate:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: 0.0, Y: -100.0, Z: -13.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: 100.0, dY: 200.0, dZ: 26.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: substrate

To set the transparency:
1. Select the Attribute tab from the Properties window.
2. Click the button for Transparency
   1. Move the slide bar to 0.8 (Opaque=0, Transparency=1)
   2. Click the OK button
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
Create Wave Port Excitation 1

Note: This structure requires 2 ports with 2 terminal lines per port. We could use face selection to select the ends of the substrate that represent the port, define terminal lines, assign excitation, and repeat for port2. But since we can duplicate port definitions, it is more efficient to define a rectangle with the appropriate port definition and copy it to the location of the 2nd port. The second method is described here:

To set grid plane
- Select the menu item 3D Modeler > Grid Plane > YZ

To create a rectangle that represents the port:
1. Select the menu item Draw > Rectangle
2. Using the coordinate entry fields, enter the rectangle position
   - X: 0.0, Y: -100.0, Z: -13.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the rectangle:
   - dX: 0.0, dY: 200.0, dZ: 26.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Port1
3. Click the OK button

To select the object Port1:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Port1
   2. Click the OK button

Note: You can also select the object from the Model Tree
Create Wave Port Excitation 1 (Continued)

To assign wave port excitation
1. Select the menu item HFSS > Excitations > Assign > Wave Port
2. Wave Port : General
   1. Name: p1
   2. Click the Next button
3. Wave Port : Terminals
   1. Number of Terminals: 2, Click the Update button
   2. For T1, click the Undefined column and select New Line
   3. Using the coordinate entry fields, enter the vector position
      X: 0.0, Y: 0.0, Z: -13.0, Press the Enter key
   4. Using the coordinate entry fields, enter the vertex
      dX: 0.0, dY: 12.0, dZ: 12.65, Press the Enter key
   5. For T2, click the Undefined column and select New Line
   6. Using the coordinate entry fields, enter the vector position
      X: 0.0, Y: 0.0, Z: -13.0, Press the Enter key
   7. Using the coordinate entry fields, enter the vertex
      dX: 0.0, dY: -12.0, dZ: 12.65, Press the Enter key
   8. Click the Next button
4. Wave Port : Differential Pairs
   1. Click the New Pair button
   2. Click the Next button
5. Wave Port : Post Processing
6. Click the Finish button
Create Wave Port Excitation 2

To select the object Port1:
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: **Port1**
   2. Click the **OK** button

To duplicate the port:
1. Select the menu item, *Edit > Duplicate > Along Line*
2. Using the coordinate entry fields, enter the first point of the duplicate vector
   - X: **0.0**, Y: **0.0**, Z: **0.0**, Press the **Enter** key
3. Using the coordinate entry fields, enter the second point of the duplicate vector
   - dX: **100.0**, dY: **0.0**, dZ: **0.0**, Press the **Enter** key
4. Duplicate Along Line Windows
   1. Total Number: **2**
   2. Click the **OK** button

To set deembedding:
1. Select the menu item *HFSS > List*
2. From the **Excitations** tab, select the excitation named **p2**
3. Click the **Properties** button
   1. Deembed: ☑ **Checked**
   2. Deembed Distance: **-900mil** (Positive Values are into the Port)
   3. Click the **OK** button
4. Click the **Done** button
Boundary Display

To verify the boundary setup:
1. Select the menu item **HFSS > Boundary Display (Solver View)**
2. From the Solver View of Boundaries, toggle the Visibility check box for the boundaries you wish to display.
   - **Note:** The background (Perfect Conductor) is displayed as the outer boundary.
   - **Note:** The Perfect Conductors are displayed as the smetal boundary.
   - **Note:** Select the menu item, **View > Visibility** to hide all of the geometry objects. This makes it easier to see the boundary
3. Click the **Close** button when you are finished.

![Solver View of Boundaries](image)
Analysis Setup

Creating an Analysis Setup

To create an analysis setup:
1. Select the menu item HFSS > Analysis Setup > Add Solution Setup
2. Solution Setup Window:
   1. Click the General tab:
      ▶ Solution Frequency: 8.0GHz
      ▶ Maximum Number of Passes: 20
      ▶ Maximum Delta S: 0.02
   2. Click the Options tab:
      ▶ Do Lambda Refinement: ☑ Checked
      ▶ Target: 0.05
      ▶ Use Low-Order Solution Basis: ☑ Checked
   3. Click the OK button

Adding a Frequency Sweep

To add a frequency sweep:
1. Select the menu item HFSS > Analysis Setup > Add Sweep
   1. Select Solution Setup: Setup1
   2. Click the OK button
2. Edit Sweep Window:
   1. Sweep Type: Interpolating
   2. Click the Setup Interpolation Basis button
      ▶ Max Solutions: 20
      ▶ Error Tolerance: 0.5%
      ▶ User All Entries: Selected
      ▶ Click OK
   3. Extrapolate to DC: ☑ Checked
      ▶ Minimum Solve Frequency: 0.01 GHz
   4. Snap Magnitude to 0 or 1 at DC: ☐ Unchecked
   5. Frequency Setup Type: Linear Step
      ▶ Stop: 8.0GHz
      ▶ Step: 0.01GHz
   6. Click the OK button
## Save Project

To save the project:
1. In an Ansoft HFSS window, select the menu item **File > Save As**.
2. From the **Save As** window, type the Filename: `hfss_lvds_diffpair`
3. Click the **Save** button

## Analyze

## Model Validation

To validate the model:
1. Select the menu item **HFSS > Validation Check**
2. Click the **Close** button

**Note:** To view any errors or warning messages, see the Message Manager.

## Analyze

To start the solution process:
1. Select the menu item **HFSS > Analyze**
Solution Data

To view the Solution Data:
1. Select the menu item HFSS > Results > Solution Data
   - To view the Profile:
     1. Click the Profile Tab.
   - To view the Convergence:
     1. Click the Convergence Tab
     - Note: The default view is for convergence is Table. Select the Plot radio button to view a graphical representations of the convergence data.
   - To view the Matrix Data:
     1. Click the Matrix Data Tab
     - Note: To view a real-time update of the Matrix Data, set the Simulation to Setup1, Last Adaptive
2. Click the Close button

![Solution Data: hfss_lvds_opt - HFSSModel1](image)
Create Reports

Create Differential Pair S-Parameter Plot

To create a report:
1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Terminal S Parameters**
   2. Display Type: **Rectangular**
   3. Click the OK button
3. Traces Window:
   1. Solution: **Setup1: Sweep1**
   2. Domain: **Sweep**
   3. Click the Y tab
      1. Category: **Terminal S Parameters**
      2. Quantity: \( St(p1:Diff1,p1:Diff1), St(p1:Diff1,p1:Comm1), \)
         \( St(p1:Diff1,p2:Diff1) \)
      3. Function: **dB**
      4. Click the **Add Trace** button
   4. Click the **Done** button
Create Differential and Common Pair Impedances Data Table

To create a report:
1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Terminal S Parameters**
   2. Display Type: **Data Table**
   3. Click the **OK** button
3. Traces Window:
   1. Solution: **Setup1: LastAdaptive**
   2. Click the **Y** tab
      1. Category: **Terminal Port Zo**
      2. Quantity: **Zot(p1:Diff1,p1:Diff1), Zot(p1:Comm1,p1:Comm1)**
      3. Function: **mag**
      4. Click the **Add Trace** button
   3. Click the **Done** button

<table>
<thead>
<tr>
<th>Freq [GHz]</th>
<th>mag(Zot(p1:Diff1,p1:Diff1), Zot(p1:Comm1,p1:Comm1))</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>8.0000000</td>
</tr>
</tbody>
</table>
Matrix Data - Export S-parameters to a file

To view the Matrix Data:
1. Select the menu item HFSS > Results > Solution Data,
2. Solution Data dialog
   1. Click the Matrix Data Tab
   2. Simulation: Setup1, Sweep1
   3. Click the Export button.
      1. Filename: hfss_lvds_diffpair
      2. Save as Type: Touchstone
      3. Click the Save button
      4. Click the OK button to accept 50 ohm reference impedance
   4. Click the Close button
Field Overlays

Set Sources: Common

To set the field excitation:
1. Select the menu item HFSS > Fields > Edit Sources
2. Edit Sources Window:
   1. Select source: p1:T1
      - Magnitude: 1
      - Phase: 0
   2. Select source: p1:T2
      - Magnitude: 1
      - Phase: 0
   3. Select source: p2:T1
      - Terminated: ✓ Checked
      - Resistance: 50
      - Reactance: 0
   4. Select source: p2:T2
      - Terminated: ✓ Checked
      - Resistance: 50
      - Reactance: 0
   5. Click the OK button
Create Field Overlay

To create a field plot:
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: *Port1*
   2. Click the OK button
3. Select the menu item *HFSS > Fields > Fields > E > Mag_E*
4. Create Field Plot Window
   1. Solution: *Setup1 : LastAdaptive*
   2. Quantity: *Mag_E*
   3. In Volume: *All*
   4. Click the Done button

To modify the attributes of a field plot:
1. Select the menu item *HFSS > Fields > Modify Plot Attributes*
2. Select Plot Folder Window:
   1. Select: *E Field*
   2. Click the OK button
3. E-Field Window:
   1. Click the Scale tab
      1. Select *Use Limits*
      2. Min: *5*
      3. Max: *10000*
      4. Scale: *Log*
   2. Click the Plot tab
      1. IsoValType: *Fringe*
      2. If real time mode is not checked, click the Apply button.
4. Click the Close button
Create Field Overlay

To create a field plot:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Port1
   2. Click the OK button
3. Select the menu item HFSS > Fields > Fields > E > Vector_E
4. Create Field Plot Window
   1. Solution: Setup1: LastAdaptive
   2. Quantity: Vector_E
   3. In Volume: All
   4. Click the Done button

To modify the attributes of a field plot:
1. Select the menu item HFSS > Fields > Modify Plot Attributes
2. Select Plot Folder Window:
   1. Select: E Field
   2. Click the OK button
3. E-Field Window:
   1. Click the Marker/Arrow tab
      1. Type: Cylinder
      2. Map Size: □ Unchecked
      3. Arrow Tale: □ Unchecked
      4. If real time mode is not checked, click the Apply button.
   4. Click the Close button
Set Differential Mode Field Excitation

To set the field excitation:

1. Select the menu item HFSS > Fields > Edit Sources
2. Edit Sources Window:
   1. Select source: p1:T1
      - Magnitude: 1
      - Phase: 0
   2. Select source: p1:T2
      - Magnitude: 1
      - Phase: 180
   3. Select source: p2:T1
      - Terminated: Checked
      - Resistance: 50
      - Reactance: 0
   4. Select source: p2:T2
      - Terminated: Checked
      - Resistance: 50
      - Reactance: 0
   5. Click the OK button

The field plots will automatically be updated to reflect the changes.
Optimetrics Setup - Parametric Sweep

During the design of a device, it is common practice to develop design trends based on swept parameters. Ansoft HFSS with Optimetrics Parametric Sweep can automatically create these design curves.

We will parameterize this design using two variables:

1. Variable $W$ will vary the width of traces: $6 \leq W \leq 12$ mils
2. Variable $S$ will vary the spacing between traces: $15 \leq S \leq 21$ mils

In the post processor you will able to display results and see how Differential impedance changes with the respect to trace width and spacing between traces.
Optimetrics Setup - Parametric Sweep

Add a Parametric Sweep

1. Select the menu item **HFSS > Optimetrics Analysis > Add Parametric**
2. Setup **Sweep Analysis** Window:
   1. Click the **Sweep Definitions** tab:
      1. Click the **Add** button
      2. Add/Edit Sweep Dialog
         1. Variable: **W**
         2. Select **Linear Count**
         3. Start: **6mil**
         4. Stop: **12mil**
         5. Count: **3**
         6. Click the **Add >>** button
         7. Variable: **S**
         8. Select **Linear Count**
         9. Start: **15mil**
         10. Stop: **21mil**
         11. Count: **3**
         12. Click the **Add >>** button
         13. Click the **OK** button
   2. Click on the **Options** tab:
      1. Save Fields And Mesh: ☑ Checked
   3. Click the **OK** button
**Save Project**

To save the project:
1. In an Ansoft HFSS window, select the menu item **File > Save**.

**Analyze**

**Model Validation**

To validate the model:
1. Select the menu item **HFSS > Validation Check**
2. Click the **Close** button
   - **Note:** To view any errors or warning messages, use the Message Manager.

**Analyze**

To start the solution process:
1. Expand the Project Tree to display the items listed under **Optimetrics**
2. Right-click the mouse on **ParametricSetup1** and choose **Analyze**
Create Reports

Create Terminal Port Zo vs S

To Create a report:
1. Select the menu item *HFSS > Results > Create Report*
2. Create Report Window:
   1. Report Type: *Terminal S Parameters*
   2. Display Type: *Rectangular*
   3. Click the *OK* button
3. Traces Window:
   1. Solution: *Setup1: LastAdaptive*
   2. Click the Sweeps tab
      1. Select the *Sweep Design and Project Variable Values* button
      2. From the table, select *Freq* from the Name column and toggle the Primary Sweep to *S*
   3. Click the Y tab
      1. Category: *Terminal Port Zo*
      2. Quantity: *Zot(p1:Diff1,p1:Diff1), Zot(p1:Comm1,p1:Comm1)*
      3. Function: *mag*
      4. Click the *Add Trace* button
   4. Click the *Done* button
Example - LVDS Differential Pair

Field Overlays

Create Field Plot vs S

- Using the project tree, expand the Field Overlay, E Field.
- Double Click on Mag_E1 to make the field plot visible
- Right-Click on Mag_E1 and select Animate
- Setup Animation
  - Swept Variable: S
  - Click the OK button
  - The Animation dialog will appear.

Save Project

- To save the project:
  1. In an Ansoft HFSS window, select the menu item File > Save.

Exiting HFSS

- To Exit HFSS:
  1. Select the menu item File > Exit
  1. If prompted Save the changes
Ansoft Designer - Transient Simulation

Launching Ansoft Designer
1. To access Ansoft Designer, click the Microsoft Start button, select Programs, and select the Designer program group. Click Ansoft Designer.

Opening a New Project
1. In an Ansoft Designer window, click the On the Standard toolbar, or select the menu item File > New.
2. From the Project menu, select Insert Circuit Design.
3. Click None button when prompted for Choose Layout Technology.

Note: In this example we are not creating a layout or using components such as transmission lines that require substrate or stack up information. If we did, then it is recommended to choose a stack up from the list or create your own.
Creating the Circuit

Component Placement

Importing S-parameters

1. Select the menu item **Draw > N-Port** or click the toolbar button.
2. In the N-port data window,
   1. Select the **Link to file** radial button
   2. Click the browse button to locate and select your Touchstone file: *hfss_lvds_diffpair.s4p*
   3. Click the **Open** button
3. Click the **Ok** button
Component Placement - continued

1. To place the new component, single click with the left mouse button in the middle of the screen.

Placing Resistors, Voltage Sources, and Voltage Probes

1. Click the Components tab in the Project Manager window.
   - Resistors: Expand Lumped -> Resistors
   - Voltage Sources: Expand Sources -> Independent Sources
   - Voltage probes: Expand Probes
Component Placement - continued

Place 3 Resistors in the schematic

1. In the Components Tab, under Lumped -> Resistors, double click Resistors
2. Click the left mouse button 3 times to place 3 resistors in the schematic.
3. To end the placement, click the right mouse button and select Finish. (You can also end the placement by pressing the space bar)

Note: Before placing a component on the schematic use the R key to rotate. If a component is already placed, use the <ctrl> R key to rotate.

Change the value of the resistors

1. Right mouse click the component and then select Properties in the pull down menu
2. Change the value from 100 to 50, then hit Enter

Note: alternatively, you can left mouse button click on the resistor to bring up the Properties window (shown below) and change the value from 100 to 50, then hit Enter
Component Placement - continued

Place Piecewise Linear Source
1. In the Components Tab, under Sources -> Independent Sources, double click on Voltage Source.
2. Left mouse click to place the source in the schematic
3. Press the space bar to finish the placement

Source Selection dialog
1. In the Properties Window, click Edit
2. For Name type Vpos
3. For Type, choose Piecewise Linear
4. Click on the Waveform List Box (which is the unmarked column in between Unit and Description as shown below)
Component Placement - continued

- Piece-wise Waveform List dialog
  1. Click on the Radial button next to **Enter time/value points**.
  2. Enter two points:
     Time       Value
     0          0
     330ps      1V

Note: make sure you hit **Enter** after typing values

- Adding Second Source
  1. Repeat the same steps as adding the first source except change:
     1. For Name, type **Vneg**
     2. The data points to:
        Time       Value
        0          0
        330ps      -1V
Component Placement - continued

Adding Wiring to connect components
1. Select the menu item **Draw -> Wire**
2. Place the cursor (which is now an X) over a node and left mouse click once
3. Drag the mouse to the connection node and left mouse click once.
4. Repeat this procedure until the connections below are made

Adding Ground Connections
1. Select the menu item **Draw > Ground** (alternatively you can select the toolbar icon)
2. Place 2 ground connections on the ends of the voltage sources

Adding Voltage Probes
1. In the **Components** tab, expand the **Probes**.
2. Place 4 **Voltage Probes** and name them Vin1, Vin2, Vout1, Vout2.
3. Place a **Voltage Probe w/Ref. Node** across the 100 Ohm resistor and name it Vdiff
**Save Project**

To save the project:
1. In an Ansoft HFSS window, select the menu item *File > Save As*.
2. From the *Save As* window, type the Filename: *lvds_diffpair_transient*
3. Click the *Save* button

**Analysis Setup**

**Creating an Analysis Setup**

To create an analysis setup:
1. In the *Project Manager* window, click the *Project* tab
2. Select the menu item *Circuit -> Add Solution Setup*
3. Analysis Setup Window:
   1. For *Analysis Type*, choose *Transient Analysis*
   2. Click *Next*
   3. Analysis Control
      1. Length of Analysis: *2ns*
      2. Maximum Time Step Allowed: *1ps*
   4. Convolution Control
      1. Maximum Sampling Frequency: *8GHz*
      2. Delta Frequency: *0.01GHz*
   5. Click *Finish*
4. Select the menu item *Circuit -> Analyze*
Create Reports

Plot Input, Output and Difference waveforms

To create a report:
1. Select the menu item **Circuit -> Create Report**
2. Create Report Window:
   1. Report Type: **Standard**
   2. Display Type: **Rectangular Plot**
   3. Click the **OK** button
3. Traces Window:
   1. Category: **Voltage**
   3. Function: **<none>**
4. Click the **Add Trace** button
5. Click the **Done** button
Segmented Return Path

This example is intended to show you how to create, simulate, and analyze a trace over a slot in the ground plant using the Ansoft HFSS Design Environment.

Nominal Design:
- Board:
  - Thickness: 1.3mm
  - $\varepsilon_r = 4.5$
- Trace:
  - Length: 8.2cm
  - Termination: 47 Ohms
Ansoft HFSS Design Environment

- The following features of the Ansoft HFSS Design Environment are used to create this passive device model
  - 3D Solid Modeling
    - Primitives: Box, Rectangles
    - Boolean Operations: Subtract
  - Boundaries/Excitations
    - Ports: Lumped Port, Terminal Lines
    - Boundary Conditions: Lumped RLC, PML
  - Analysis
    - Sweep: Interpolating Sweep
  - Results
    - Cartesian and Smith Chart plotting
  - Field Overlays
    - Magnitude and Vector Field Plotting
    - Animation
Design Review

Before we jump into setting up this device let's review the design.
- Trace Width = 3mm
- Trace Length = 8.2cm
- Dielectric Height = 1.3mm
- Port Size/Type = ???
- Free Space = PML or Radiation Boundary

Port Size/Type
- Since the trace is internal to the model, let's use a lumped gap source port

Trace Thickness/Material Properties
- To start let's make an engineering assumption that the trace thickness and conductivity will not have an impact on the performance of the device. This will speed up the simulation.

Free Space
- We should expect some radiation to occur because of the slot in the ground, however, it should not be very strong. Because there is limited radiation the separation from the device and the free-space boundary can be kept to a minimum. The incidence angle of the radiation is unknown, therefore we should use a PML. The maximum spacing will be $\frac{\lambda}{20}$ @ 1GHz or about 1.5cm
Getting Started

Launching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft, HFSS 10 program group. Click HFSS 10.

Setting Tool Options

To set the tool options:

- **Note:** In order to follow the steps outlined in this example, verify that the following tool options are set:
  1. Select the menu item **Tools > Options > HFSS Options**
  2. HFSS Options Window:
     1. Click the **General** tab
        - Use Wizards for data entry when creating new boundaries: ✔ Checked
        - Duplicate boundaries with geometry: ✔ Checked
     2. Click the **OK** button
  3. Select the menu item **Tools > Options > 3D Modeler Options**
  4. 3D Modeler Options Window:
     1. Click the **Operation** tab
        - Automatically cover closed polylines: ✔ Checked
     2. Click the **Drawing** tab
        - Edit property of new primitives: ✔ Checked
     3. Click the **OK** button
### Opening a New Project

To open a new project:
1. In an Ansoft HFSS window, click the \( \text{File} \) On the Standard toolbar, or select the menu item \textit{File > New}.  
2. From the \textit{Project} menu, select \textit{Insert HFSS Design}.

### Set Solution Type

To set the solution type:
1. Select the menu item \textit{HFSS > Solution Type}  
2. Solution Type Window:
   1. Choose \textbf{Driven Terminal}  
   2. Click the OK button
Creating the 3D Model

Set Model Units

To set the units:
1. Select the menu item **3D Modeler > Units**
2. Set Model Units:
   1. Select Units: **cm**
   2. Click the **OK** button

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose **Select**
2. Select Definition Window:
   1. Click the **Add Material** button
   2. View/Edit Material Window:
      1. For the **Material Name** type: **My_FR4**
      2. For the **Value of Relative Permittivity** type: **4.5**
      3. Click the **OK** button
3. Click the **OK** button
Create Board

To create the board:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: 6.0, dY: 10.0, dZ: -1.3mm, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Board
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View or press the CTRL+D key

Create Ground

To create ground:
1. Select the menu item Draw > Rectangle
2. Using the coordinate entry fields, enter the box position
   - X: 0.0, Y: 0.0, Z: -1.3mm, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: 6.0, dY: 10.0, dZ: 0.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Ground
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
Create Offset Coordinate System

To create an offset Coordinate System:
1. Select the menu item 3D Modeler > Coordinate System > Create > Relative CS > Offset
2. Using the coordinate entry fields, enter the origin
   - X: 0.0, Y: 5.0, Z: -1.3mm, Press the Enter key

Create Ground Cut Out

To create cut out:
1. Select the menu item Draw > Rectangle
2. Using the coordinate entry fields, enter the box position
   - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: 4.0, dY: 6.0mm, dZ: 0.0, Press the Enter key

Select Ground & Rectangle1:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Ground, Rectangle1
   2. Click the OK button

To complete the ground object:
1. Select the menu item 3D Modeler > Boolean > Subtract
2. Subtract Window
   - Blank Parts: Ground
   - Tool Parts: Rectangle1
   - Clone tool objects before subtract: unchecked
   - Click the OK button
Assign a Perfect E boundary to the Ground

To select the ground:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Ground
   2. Click the OK button

To assign the Perfect E boundary
1. Select the menu item HFSS > Boundaries > Assign > Perfect E
2. Perfect E Boundary window
   1. Name: PerfE_Ground
   2. Click the OK button

Set Working Coordinate System

To set the working coordinate system:
1. Select the menu item 3D Modeler > Coordinate System > Set Working CS
2. Select Coordinate System Window,
   1. From the list, select the CS: Global
   2. Click the Select button

Create Offset Coordinate System

To create an offset Coordinate System:
1. Select the menu item 3D Modeler > Coordinate System > Create > Relative CS > Offset
2. Using the coordinate entry fields, enter the origin
   ▲ X: 1.0, Y: 8.0mm, Z: 0.0, Press the Enter key
Create Trace

To create trace:
1. Select the menu item Draw > Rectangle
2. Using the coordinate entry fields, enter the box position
   X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   dX: 3.0mm, dY: 8.2, dZ: 0.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Trace
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Assign a Perfect E boundary to the Trace

To select the trace:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Trace
   2. Click the OK button

To assign the Perfect E boundary
1. Select the menu item HFSS > Boundaries > Assign > Perfect E
2. Perfect E Boundary window
   1. Name: PerfE_Trace
   2. Click the OK button
Set Grid Plane

To set the grid plane:
1. Select the menu item 3D Modeler > Grid Plane > XZ

Create Source

To create source:
1. Select the menu item Draw > Rectangle
2. Using the coordinate entry fields, enter the box position
   X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   dX: 3.0mm, dY: 0.0, dZ: -1.3mm, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Source
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
Assign Excitation

To select the object Source:
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: **Source**
   2. Click the OK button

*Note:* You can also select the object from the Model Tree

To assign lumped port excitation
1. Select the menu item *HFSS > Excitations > Assign > Lumped Port*
2. Lumped Port: General
   1. Name: **p1**
   2. Resistance: **50**
   3. Reactance: **0**
   4. Click the **Next** button
3. Lumped Port: Terminals
   1. Number of Terminals: **1**
   2. For **T1**, click the **Undefined** column and select **New Line**
   3. Using the coordinate entry fields, enter the vector position
      - X: **1.5mm**, Y: **0.0**, Z: **-1.3mm**, Press the **Enter** key
   4. Using the coordinate entry fields, enter the vertex
      - dX: **0.0**, dY: **0.0**, dZ: **1.3mm**, Press the **Enter** key
   5. Click the **Finish** button
**Create Offset Coordinate System**

To create an offset Coordinate System:
1. Select the menu item **3D Modeler > Coordinate System > Create > Relative CS > Offset**
2. Using the coordinate entry fields, enter the origin
   - X: 0.0, Y: 8.2, Z: 0.0, Press the **Enter** key

**Create Resistor**

To create source:
1. Select the menu item **Draw > Rectangle**
2. Using the coordinate entry fields, enter the box position
   - X: 0.0, Y: 0.0, Z: 0.0, Press the **Enter** key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: 3.0mm, dY: 0.0, dZ: -1.3mm, Press the **Enter** key

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value** of **Name** type: **Resistor**
3. Click the **OK** button

To fit the view:
1. Select the menu item **View > Fit All > Active View.**
Assign Lumped RLC

To select the object Resistor:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Resistor
   2. Click the OK button

To assign lumped RLC boundary
1. Select the menu item HFSS > Boundaries > Assign > Lumped RLC
2. Lump RLC Boundary
   1. Name: R,
   2. Resistance: ☑ Checked
   3. Resistance: 47 Ohm
   4. For Current Flow Line, click Undefined and select New Line
   5. Using the coordinate entry fields, enter the vector position
      X: 1.5mm, Y: 0.0, Z: -1.3mm, Press the Enter key
   6. Using the coordinate entry fields, enter the vertex
      dX: 0.0, dY: 0.0, dZ: 1.3mm, Press the Enter key
   7. Click the OK button
Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose vacuum

Set Working Coordinate System

To set the working coordinate system:
1. Select the menu item 3D Modeler > Coordinate System > Set Working CS
2. Select Coordinate System Window,
   1. From the list, select the CS: Global
   2. Click the Select button

Create Air

To create the air:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   X: -1.5, Y: -1.5, Z: -1.5, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   dX: 9.0, dY: 13.0, dZ: 3.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Air
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
Assign a Perfectly Matched Layer (PML)

To select the air:
1. Select the menu item `Edit > Select > Faces`
2. Select the menu item `Edit > Select by name`
3. Object Name: `Air`
   1. FaceID: `<Select All>`
   2. Click the OK button

To assign the PML boundary
1. Select the menu item `HFSS > Boundaries > PML Setup Wizard`
2. PML Setup Wizard: Cover Objects
   1. Select: `Create PML Cover Objects on Selected Faces`
   2. Uniform Layer Thickness: 1cm
   3. Create joining corner and edge objects: ✓ Checked
   4. Click the Next button
3. PML Setup Wizard: Material Parameters
   1. Select: `PML Objects accept Free Radiation`
      1. Min Frequency: 0.01 GHz
      2. Click the Next button
   3. Click the Finish button
Create a Face List

Since we are using the PML, we need to create a face list that will be used for the radiation calculation.

To create a face list

1. Select the menu item Edit > Select > Faces
2. Select the menu item Edit > Select > By Name
3. Select Object Dialog,
   1. Select the objects named: Air
   2. FaceID: <Select All>
   3. Click the OK button
4. Select the menu item 3D Modeler > List > Create > Face List

Create a Radiation Setup

To define the radiation setup

1. Select the menu item HFSS > Radiation > Insert Far Field Setup > Infinite Sphere
2. Far Field Radiation Sphere Setup dialog
   ▲ Infinite Sphere Tab
      1. Name: Radiation
      2. Phi: (Start: 0, Stop: 90, Step Size: 90)
      3. Theta: (Start: -180, Stop: 180, Step Size: 2)
   1. Click the OK button
Boundary Display

To verify the boundary setup:

1. Select the menu item **HFSS > Boundary Display (Solver View)**
2. From the Solver View of Boundaries, toggle the Visibility check box for the boundaries you wish to display.
   - **Note:** The background (Perfect Conductor) is displayed as the outer boundary.
   - **Note:** The Perfect Conductors are displayed as the smetal boundary.
   - **Note:** Select the menu item, **View > Visibility** to hide all of the geometry objects. This makes it easier to see the boundary.
3. Click the Close button when you are finished.

### Solver View of Boundaries

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Solver Visibility</th>
<th>Visibility</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>PortE_Ground</td>
<td>User Defined</td>
<td>Visible to solver.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PortE_Trace</td>
<td>User Defined</td>
<td>Visible to solver.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lumped RLC</td>
<td>User Defined</td>
<td>Visible to solver.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PML_radiation1</td>
<td>User Defined</td>
<td>Visible to solver.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PML_radiation2</td>
<td>User Defined</td>
<td>Visible to solver.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PML_radiation3</td>
<td>User Defined</td>
<td>Visible to solver.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PML_radiation4</td>
<td>User Defined</td>
<td>Visible to solver.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PML_radiation5</td>
<td>User Defined</td>
<td>Visible to solver.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PML_radiation6</td>
<td>User Defined</td>
<td>Visible to solver.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>p1</td>
<td>User Defined</td>
<td>Visible to solver.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>outer</td>
<td>Default</td>
<td>Visible to solver.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Click Close
**Analysis Setup**

### Creating an Analysis Setup

To create an analysis setup:
1. Select the menu item **HFSS > Analysis Setup > Add Solution Setup**
2. Solution Setup Window:
   1. Click the **General** tab:
      - Solution Frequency: **2.5GHz**
      - Maximum Number of Passes: **20**
      - Maximum Delta S: **0.03**
   2. Click the **Options** tab:
      - Do Lambda Refinement: ✔ **Checked**
      - Target: **0.1**
      - User Low-Order Solution Basis: ✔ **Checked**
   3. Click the **OK** button

### Adding a Frequency Sweep

To add a frequency sweep:
1. Select the menu item **HFSS > Analysis Setup > Add Sweep**
   1. Select Solution Setup: **Setup1**
   2. Click the **OK** button
2. Edit Sweep Window:
   1. Sweep Type: **Interpolating**
   2. Click the **Setup Interpolation Basis** button
      - Max Solutions: **20**
      - Error Tolerance: **0.5%**
      - Click the **OK** button
   3. Extrapolate to DC: ✔ **Checked**
      - Minimum Solve Frequency: **0.01 GHz**
   4. Snap Magnitude to 0 or 1 at DC: □ **Unchecked**
   5. Frequency Setup Type: **Linear Step**
      - Stop: **2.5GHz**
      - Step: **0.01GHz**
   6. Click the **OK** button
Save Project

To save the project:
1. In an Ansoft HFSS window, select the menu item File > Save As.
2. From the Save As window, type the Filename: hfss_seg_gplane
3. Click the Save button

Analyze

Model Validation

To validate the model:
1. Select the menu item HFSS > Validation Check
2. Click the Close button
   
   Note: To view any errors or warning messages, use the Message Manager.

Analyze

To start the solution process:
1. Select the menu item HFSS > Analyze
Solution Data

To view the Solution Data:
1. Select the menu item HFSS > Results > Solution Data

To view the Profile:
1. Click the Profile Tab.

To view the Convergence:
1. Click the Convergence Tab

Note: The default view is for convergence is Table. Select the Plot radio button to view a graphical representation of the convergence data.

To view the Matrix Data:
1. Click the Matrix Data Tab

Note: To view a real-time update of the Matrix Data, set the Simulation to Setup1, Last Adaptive
2. Click the Close button
Create Reports

Create Terminal S-Parameter Plot vs. Adaptive Pass

- **Note:** If this report is created prior or during the solution process, a real-time update of the results are displayed.

- **To create a report:**
  1. Select the menu item **HFSS > Results > Create Report**
  2. Create Report Window:
     1. Report Type: **Terminal S Parameters**
     2. Display Type: **Rectangular**
     3. Click the **OK** button
  3. Traces Window:
     1. Solution: **Setup1: Adaptive1**
     2. Click the **Y** tab
        1. Category: **Terminal S Parameter**
        2. Quantity: **St(p1,p1)**
        3. Function: **dB**
        4. Click the **Add Trace** button
     3. Click the **Done** button

---

![Graph showing a plot of dB vs. Pass with labels on the axes.](image)
Create Terminal Z-Parameter Plot - Real/Imaginary

To create a report:
1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Terminal S Parameters**
   2. Display Type: **Rectangular**
   3. Click the **OK** button
3. Traces Window:
   1. Solution: **Setup1: Sweep1**
   2. Domain: **Sweep**
   3. Click the **Y** tab
   1. Category: **Terminal Z Parameter**
   2. Quantity: **Zt(p1,p1)**
   3. Function: **Re**
   4. Click the **Add Trace** button
   5. Category: **Terminal Z Parameter**
   6. Quantity: **Zt(p1,p1)**
   7. Function: **Im**
   8. Click the **Add Trace** button
4. To add an additional Y-Axis for **Im(Zt(p1,p1))**
   1. Select Y1 for Row 2 in Y-axis column and toggle it to **Y2**
5. Click the **Done** button
Create Terminal S-Parameter Plot - Smith Chart

To create a report:

1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Terminal S Parameters**
   2. Display Type: **Smith Chart**
   3. Click the **OK** button
3. Traces Window:
   1. Solution: **Setup1: Sweep1**
   2. Click the **Polar** tab
      1. Category: **Terminal S Parameter**
      2. Quantity: **St(p1,p1)**
      3. Function: **<none>**
      4. Click the **Add Trace** button
   3. Click the **Done** button
**Matrix Data - Export S-parameters to a file**

To view the Matrix Data:

1. Select the menu item *HFSS > Results > Solution Data*,
2. Solution Data dialog
   1. Click the **Matrix Data** Tab
   2. Simulation: **Setup1, Sweep1**
   3. Click the **Export** button.
      1. Filename: *hfss_seg_gplane*
      2. Save as Type: **Touchstone**
      3. Click the **Save** button
      4. Click the **OK** button to accept 50ohm reference impedance
   4. Click the **Close** button
Create 3D Polar Far Field Plot

To create a 3D Far Field Plot:

1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Far Fields**
   2. Display Type: **3D Polar Plot**
   3. Click the **OK** button
3. Traces Window:
   1. Solution: **Setup1: LastAdaptive**
   2. Domain: **Radiation**
   3. Click the **Mag** tab
      1. Category: **rE**
      2. Quantity: **rETotal**
      3. Function: **dB**
      4. Click the **Add Trace** button
4. Click the **Done** button
Field Overlays

Create Field Overlay

To create a field plot:
1. Confirm you are in Object Select mode by right-clicking in the geometry window, and selecting from context menu if necessary.
2. Select the menu item Edit > Select > By Name
3. Select Object Dialog,
   1. Select the objects named: Board
   2. Click the OK button
4. Select the menu item HFSS > Fields > Plot Fields > Mag_E
5. Create Field Plot Window
   1. Solution: Setup1 : LastAdaptive
   2. Quantity: Mag_E
   3. In Volume: All
   4. Click the Done button

To modify a Magnitude field plot:
1. Select the menu item HFSS > Fields > Modify Plot Attributes
2. Select Plot Folder Window:
   1. Select: E Field
   2. Click the OK button
3. E-Field Window:
   1. Click the Scale tab
      1. Select Use Limits
      2. Min: 1
      3. Max: 4500
      4. Scale: Log
   2. Click the Plots Tab
      1. Scalar Plot: IsoValSurface
      2. Click the Close button
Create Field Overlay

To create a field plot:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Ground
   2. Click the OK button
3. Select the menu item HFSS > Fields > Plot Fields > Vector_RealPoynting
4. Create Field Plot Window
   1. Solution: Setup1 : LastAdaptive
   2. Quantity: Vector_RealPoynting
   3. In Volume: All
   4. Click the Done button

To modify the attributes of a field plot:
1. Select the menu item HFSS > Fields > Modify Plot Attributes
2. Select Plot Folder Window:
   1. Select: Poynting
   2. Click the OK button
3. Poynting Window:
   1. Click the Scale tab
      1. Select Use Limits
      2. Min: 0.01
      3. Max: 2500
      4. Scale: Log
   2. Click the Marker/Arrow tab
      1. Type: Cylinder
      2. Map Size: Unchecked
      3. Arrow Tale: Unchecked
      4. If real time mode is not checked, click the Apply button.
   4. Click the Close button

Exiting HFSS

To Exit HFSS:
1. Select the menu item File > Exit
   1. If prompted Save the changes
THIS PAGE INTENTIONALLY LEFT BLANK
Ansoft Designer - Transient Simulation

Launching Ansoft Designer

1. To access Ansoft Designer, click the Microsoft Start button, select Programs, and select the Designer program group. Click Ansoft Designer.

Opening a New Project

To open a new project:

1. In an Ansoft Designer window, click the on the Standard toolbar, or select the menu item File > New.
2. From the Project menu, select Insert Circuit Design.
3. Click None button when prompted for Choose Layout Technology.

Note: In this example we are not creating a layout or using components such as transmission lines that require substrate or stack up information. If we did, then it is recommended to choose a stack up from the list or create your own.
Creating the Circuit

Component Placement

Importing S-parameters

1. Select the menu item Draw > N-Port or click the toolbar button.
2. In the N-port data window,
   1. Select the Link to file radial button
   2. Click the browse button to locate and select your Touchstone file: hfss_seg_gplane.s1p
   3. Click the Open button
3. Click the Ok button
## Component Placement - continued

1. To place the new component, single click with the left mouse button in the middle of the screen.

![Component Placement Diagram](image)

### Placing Resistors, Voltage Sources, and Voltage Probes

1. Click the **Components** tab in the **Project Manager** window.
   - **Resistors**: Expand **Lumped -> Resistors**
   - **Voltage Sources**: Expand **Sources -> Independent Sources**
   - **Voltage probes**: Expand **Probes**

![Component Manager Window](image)
Component Placement - continued

Place a Resistor in the schematic

1. In the Components Tab, under Lumped -> Resistors, double click Resistor
2. Click the left mouse button once to place a resistor in the schematic.
3. To end the placement, click the right mouse button and select Finish. (You can also end the placement by pressing the space bar)

![Resistor Icon](image)

Change the value of the resistor

1. Right mouse click the component and then select Properties in the pull down menu
2. Change the value from 100 to 50, then hit Enter

Note: alternatively, you can left mouse button click on the resistor to bring up the Properties window (shown below) and change the value from 100 to 50, then hit Enter

![Properties Window](image)
Component Placement - continued

Place a Coaxial Cable in the schematic

1. In the Components Tab, under Coaxial Cable, double click Coaxial Cable, K
2. Click the left mouse button once to place a coaxial cable in the schematic.
3. Press the space bar to finish the placement

![Coaxial Cable Diagram]

Z=50
P=10000mil

Change the physical length of the coaxial cable

1. Right mouse click the component and then select Properties in the pull down menu
2. Change the value of P to 10000mil, then hit Enter

![Component Properties Table]
Component Placement - continued

Place Piecewise Linear Source

1. In the Components Tab, under Sources -> Independent Sources, double click on Voltage Source.
2. Left mouse click to place the source in the schematic
3. Press the space bar to finish the placement

Source Selection dialog

1. In the Properties Window, click Edit
2. For Name type Vin
3. For Type, choose Piecewise Linear
4. Click on the Waveform List Box (which is the unmarked column in between Unit and Description as shown below)
Component Placement - continued

- Piece-wise Waveform List dialog
  1. Click on the Radial button next to Enter time/value points.
  2. Enter two points:
     Time | Value
     0    | 0
     1ns  | 1V

  - Note: make sure you hit Enter after typing values
  1. Click the OK button

1. Click the OK button
## Component Placement - continued

### Adding Wiring to connect components
1. Select the menu item **Draw -> Wire**
2. Place the cursor (which is now an X) over a node and left mouse click once
3. Drag the mouse to the connection node and left mouse click once.
4. Repeat this procedure until the connections below are made

### Adding Ground Connections
1. Select the menu item **Draw -> Ground** (alternatively you can select the toolbar icon)
2. Place a ground connection on the end of the voltage source

### Adding Voltage Probes
1. In the **Components** tab, expand the **Probes**.
2. Place 2 **Voltage Probes** and name them v1, v2.
Creating the Circuit

Save Project

To save the project:
1. In an Ansoft Designer window, select the menu item File > Save As.
2. From the Save As window, type the Filename: hfss_seg_gplane_tdr
3. Click the Save button

Analysis Setup

Creating an Analysis Setup

To create an analysis setup:
1. In the Project Manager window, click the Project tab
2. Select the menu item Circuit -> Add Solution Setup
3. Analysis Setup Window:
   1. For Analysis Type, choose Transient Analysis
   2. Click Next
   3. Analysis Control
      1. Length of Analysis: 8ns
      2. Maximum Time Step Allowed: 1ps
   4. Convolution Control
      1. Maximum Sampling Frequency: 2.5GHz
      2. Delta Frequency: 0.01GHz
   5. Click Finish
4. Select the menu item Circuit -> Analyze
Create Reports

Plot Input, Output waveforms

To create a report:
1. Select the menu item Circuit -> Create Report
2. Create Report Window:
   1. Report Type: Standard
   2. Display Type: Rectangular Plot
   3. Click the OK button
3. Traces Window:
   1. Category: Voltage
   2. Quantity: V(VPRB:V1), V(VPRB:V2)
   3. Function: <none>
   4. Click the Add Trace button
   5. Click the Done button
Create Reports

Plot TDR

To create a report:
1. Select the menu item Circuit -> Create Report
2. Create Report Window:
   1. Report Type: Standard
   2. Display Type: Rectangular Plot
   3. Click the OK button
3. Click on Output Variables button to create TDR equation
   1. Name: type TDR
   2. Expression: \( \frac{V(VPRB:v2)}{V(VPRB:v1)-V(VPRB:v2)}*50 \)
      
      Note: To create the above expression, follow these steps:
      1. Category: Voltage
      2. Quantity: V(VPRB:v2)
      3. Click Insert Quantity into Expression button
      4. Type / then type ( 
      5. Quantity: V(VPRB:v1)
      6. Click Insert Quantity into Expression button
      7. Type -
      8. Quantity: V(VPRB:v2)
      9. Click Insert Quantity into Expression button
      10. Type )
      11. Type * 50

3. Click the Add button
4. Click the Done button

- Traces Window:
  - Category: Output Variables
  - Quantity: TDR
  - Function: <none>
  - Click the Add Trace button
  - Click the Done button (see next page for TDR plot)
Non-Ideal Ground Plane

This example is intended to show you how to create, simulate, and analyze non-ideal ground planes using the Ansoft HFSS Design Environment.

Nominal Design:

- **Ground:**
  - Thickness = 0.1 mm

- **Board:**
  - Thickness = 0.9 mm
  - \( \varepsilon_r = 1 \)

- **Trace:**
  - Length = 10 mm
  - Width = 1 mm
  - Thickness = 0.1 mm

- **Via:**
  - Diameter = 1 mm
  - Height = 0.9 mm
Example - Non-Ideal Planes

Ansoft HFSS Design Environment

The following features of the Ansoft HFSS Design Environment are used to create this passive device model:

- **3D Solid Modeling**
  - Primitives: Box, Rectangles, Cylinders
  - Boolean Operations: Subtract, Unite, Duplicate

- **Boundary**
  - Boundary Conditions: Perfect H/Natural

- **Excitations**
  - Ports: Lumped Gap Source Port, Terminal Lines

- **Analysis**
  - Sweep: Fast Frequency

- **Results**
  - Cartesian plotting

- **Fields**
  - Fast Frequency Sweep/Field Plots
Design Review

Before we jump into setting up this device let's review the design.

- Port Size/Type = ???
- Free Space = ???

Port Size/Type

Since the trace is internal to the model, let's use a lumped gap source port.

Trace Thickness/Material Properties

To start with perfect conductor, let's make an engineering assumption that the trace conductivity will not have an impact on the performance of the device. This will speed up the simulation.

Free Space

Since we are only interested in the modes that occur between the ground planes, we can use a Perfect H or open boundary condition. We should expect to get the same answer using an Open(Perfect H) or matched(Radiation) boundary. The radiation boundary takes longer to solve since it requires a complex solve.

- You do need to use some caution when using Perfect H boundary conditions in place of radiation boundaries. The Perfect H and Symmetry Perfect H are mathematically equivalent. Therefore if you are simulating a subsection of a larger geometry, you have the potential to create modes that are the result of the boundary condition or non-physical. In our example, the Perfect H is applied to the outside of the model and not along any symmetry planes.
- It should be noted that the Perfect H boundary condition can be used with the Driven and Eigenmode solver. The Radiation boundary is only supported by the Driven Solution.
Getting Started

Launching Ansoft HFSS
1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft HFSS 10 program group. Click HFSS 10.

Setting Tool Options
To set the tool options:

Note: In order to follow the steps outlined in this example, verify that the following tool options are set:
1. Select the menu item Tools > Options > HFSS Options
2. HFSS Options Window:
   1. Click the General tab
      - Use Wizards for data entry when creating new boundaries: ✔ Checked
      - Duplicate boundaries with geometry: ✔ Checked
   2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:
   1. Click the Operation tab
      - Automatically cover closed polylines: ✔ Checked
   2. Click the Drawing tab
      - Edit property of new primitives: ✔ Checked
   3. Click the OK button
8.3 Opening a New Project

To open a new project:
1. In an Ansoft HFSS window, click the on the Standard toolbar, or select the menu item File > New.
2. From the Project menu, select Insert HFSS Design.

Set Solution Type

To set the solution type:
1. Select the menu item HFSS > Solution Type
2. Solution Type Window:
   1. Choose Driven Terminal
   2. Click the OK button
8.3-6

Creating the 3D Model

Set Model Units

To set the units:
1. Select the menu item **3D Modeler > Units**
2. Set Model Units:
   1. Select Units: **mm**
   2. Click the **OK** button

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
   1. Type **pec** in the Search by Name field
   2. Click the **OK** button
8.3 Example - Non-Ideal Planes

### Create Trace

**To create the trace:**
1. Select the menu item **Draw > Box**
2. Using the coordinate entry fields, enter the box position
   - X: \(-0.5\), Y: \(0.0\), Z: \(0.0\), Press the **Enter** key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: \(1.0\), dY: \(-10.0\), dZ: \(0.1\), Press the **Enter** key

**To set the name:**
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: **Trace**
3. Click the **OK** button

**To fit the view:**
1. Select the menu item **View > Fit All > Active View**. Or press the **CTRL+D** key

### Create Via Pad

**To create the via pad:**
1. Select the menu item **Draw > Cylinder**
2. Using the coordinate entry fields, enter the cylinder position
   - X: \(0.0\), Y: \(0.0\), Z: \(0.0\), Press the **Enter** key
3. Using the coordinate entry fields, enter the radius:
   - dX: \(0.75\), dY: \(0.0\), dZ: \(0.0\), Press the **Enter** key
4. Using the coordinate entry fields, enter the height:
   - dX: \(0.0\), dY: \(0.0\), dZ: \(0.1\), Press the **Enter** key

**To set the name:**
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: **Via_pad**
3. Click the **OK** button

**To fit the view:**
1. Select the menu item **View > Fit All > Active View**.
Example - Non-Ideal Planes

⚠️ Group the Trace & Via Pad

⚠️ To group the dipole arms:
1. Select the menu item **Edit > Select All Visible**. Or press the **CTRL+A** key.
2. Select the menu item, **3D Modeler > Boolean > Unite**

⚠️ Create Offset Coordinate System

⚠️ To create an offset Coordinate System:
1. Select the menu item **3D Modeler > Coordinate System > Create > Relative CS > Offset**
2. Using the coordinate entry fields, enter the origin
   - X: **0.0**, Y: **0.0**, Z: **-0.2**, Press the **Enter** key

⚠️ Create Ground 1

⚠️ To create ground:
1. Select the menu item **Draw > Box**
2. Using the coordinate entry fields, enter the box position
   - X: **-10.0**, Y: **-20.0**, Z: **0.0**, Press the **Enter** key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: **20.0**, dY: **40.0**, dZ: **0.1**, Press the **Enter** key

⚠️ To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: **Ground**
3. Click the **OK** button

⚠️ To fit the view:
1. Select the menu item **View > Fit All > Active View**.
Example - Non-Ideal Planes

Create Anti-Pad

To create the anti-pad:
1. Select the menu item Draw > Cylinder
2. Using the coordinate entry fields, enter the cylinder position
   - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the radius:
   - dX: 1.0, dY: 0.0, dZ: 0.0, Press the Enter key
4. Using the coordinate entry fields, enter the height:
   - dX: 0.0, dY: 0.0, dZ: 0.1, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Antipad
3. Click the OK button

Select Ground & Antipad:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Antipad, Ground
   2. Click the OK button

To complete the ground object:
1. Select the menu item 3D Modeler > Boolean > Subtract
2. Subtract Window
   - Blank Parts: Ground
   - Tool Parts: Antipad
   - Clone tool objects before subtract: □ Unchecked
   - Click the OK button
Set Working Coordinate System

To set the working coordinate system:
1. Select the menu item 3D Modeler > Coordinate System > Set Working CS
2. Select Coordinate System Window,
   1. From the list, select the CS: Global
   2. Click the Select button

Create Offset Coordinate System

To create an offset Coordinate System:
1. Select the menu item 3D Modeler > Coordinate System > Create > Relative CS > Offset
2. Using the coordinate entry fields, enter the origin
   - X: -0.5, Y: -10.0, Z: 0.0, Press the Enter key

Set Grid Plane

To set the grid plane:
1. Select the menu item 3D Modeler > Grid Plane > XZ
Create Source

To create source:
1. Select the menu item \textit{Draw > Rectangle}
2. Using the coordinate entry fields, enter the box position
   \begin{itemize}
   \item X: 0.0, Y: 0.0, Z: 0.0, Press the \textit{Enter} key
   \end{itemize}
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   \begin{itemize}
   \item dX: 1.0, dY: 0.0, dZ: -0.1, Press the \textit{Enter} key
   \end{itemize}

To set the name:
1. Select the \textit{Attribute} tab from the \textit{Properties} window.
2. For the \textit{Value} of \textit{Name} type: \textbf{Source}
3. Click the \textit{OK} button

To fit the view:
1. Select the menu item \textit{View > Fit All > Active View}. 
Example - Non-Ideal Planes

Assign Excitation

To select the object Source:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Source
   2. Click the OK button

Note: You can also select the object from the Model Tree

To assign lumped port excitation
1. Select the menu item HFSS > Excitations > Assign > Lumped Port
2. Lumped Port : General
   1. Name: p1,
   2. Resistance: 50
   3. Reactance: 0
   4. Click the Next button
3. Lumped Port : Terminals
   1. Number of Terminals: 1,
   2. For T1, click the Undefined column and select New Line
   3. Using the coordinate entry fields, enter the vector position
      X: 0.5, Y: 0.0, Z: -0.1, Press the Enter key
   4. Using the coordinate entry fields, enter the vertex
      dX: 0.0, dY: 0.0, dZ: 0.1, Press the Enter key
   5. Click the Finish button
Example - Non-Ideal Planes

Set Working Coordinate System

To set the working coordinate system:
1. Select the menu item 3D Modeler > Coordinate System > Set Working CS
2. Select Coordinate System Window,
   1. From the list, select the CS: Global
   2. Click the Select button

Create Offset Coordinate System

To create an offset Coordinate System:
1. Select the menu item 3D Modeler > Coordinate System > Create > Relative CS > Offset
2. Using the coordinate entry fields, enter the origin
   ▶ X: 0.0, Y: 0.0, Z: -0.45, Press the Enter key

Duplicate Objects

To duplicate the existing objects:
1. Select the menu item Edit > Select All Visible. Or press the CTRL+A key.
2. Select the menu item, Edit > Duplicate > Around Axis.
   1. Axis: X
   2. Angle: 180
   3. Total Number: 2
   4. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Set Grid Plane

To set the grid plane:
1. Select the menu item 3D Modeler > Grid Plane > XY
## Example - Non-Ideal Planes

### Set Working Coordinate System

To set the working coordinate system:
1. Select the menu item **3D Modeler > Coordinate System > Set Working CS**
2. Select Coordinate System Window,
   1. From the list, select the CS: **Global**
   2. Click the **Select** button

### Create Via

To create the via:
1. Select the menu item **Draw > Cylinder**
2. Using the coordinate entry fields, enter the cylinder position
   - X: **0.0**, Y: **0.0**, Z: **0.0**, Press the **Enter** key
3. Using the coordinate entry fields, enter the radius:
   - dX: **0.5**, dY: **0.0**, dZ: **0.0**, Press the **Enter** key
4. Using the coordinate entry fields, enter the height:
   - dX: **0.0**, dY: **0.0**, dZ: **-0.9**, Press the **Enter** key

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value** of **Name** type: **Via**
3. Click the **OK** button

To fit the view:
1. Select the menu item **View > Fit All > Active View**.

### Create Offset Coordinate System

To create an offset Coordinate System:
1. Select the menu item **3D Modeler > Coordinate System > Create > Relative CS > Offset**
2. Using the coordinate entry fields, enter the origin
   - X: **-5.0**, Y: **-10.0**, Z: **-0.2**, Press the **Enter** key
Create Ground Via

To create the Ground Via:
1. Select the menu item **Draw > Cylinder**
2. Using the coordinate entry fields, enter the cylinder position X: **0.0**, Y: **0.0**, Z: **0.0**, Press the **Enter** key
3. Using the coordinate entry fields, enter the radius:
   dX: **0.5**, dY: **0.0**, dZ: **0.0**, Press the **Enter** key
4. Using the coordinate entry fields, enter the height:
   dX: **0.0**, dY: **0.0**, dZ: **-0.5**, Press the **Enter** key

To set the name:
1. Select the **Attribute** tab from the Properties window.
2. For the **Value of Name** type: **Via_GND**
3. Click the **OK** button

To fit the view:
1. Select the menu item **View > Fit All > Active View**.

Set Working Coordinate System

To set the working coordinate system:
1. Select the menu item **3D Modeler > Coordinate System > Set Working CS**
2. Select Coordinate System Window,
   1. From the list, select the CS: **Global**
   2. Click the **Select** button

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose **vacuum**
Example - Non-Ideal Planes

**Create Board**
- **To create the board:**
  1. Select the menu item **Draw > Box**
  2. Using the coordinate entry fields, enter the box position
     - X: **-10.0**, Y: **-20.0**, Z: **0.0**, Press the **Enter** key
  3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
     - dX: **20.0**, dY: **40.0**, dZ: **-0.9**, Press the **Enter** key
- **To set the name:**
  1. Select the **Attribute** tab from the **Properties** window.
  2. For the **Value of Name** type: **Board**
  3. Click the **OK** button
- **To fit the view:**
  1. Select the menu item **View > Fit All > Active View.**

**Create Air**
- **To create the Air:**
  1. Select the menu item **Draw > Box**
  2. Using the coordinate entry fields, enter the box position
     - X: **-15.0**, Y: **-25.0**, Z: **-5.0**, Press the **Enter** key
  3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
     - dX: **30.0**, dY: **50.0**, dZ: **10.0**, Press the **Enter** key
- **To set the name:**
  1. Select the **Attribute** tab from the **Properties** window.
  2. For the **Value of Name** type: **Air**
  3. Click the **OK** button
- **To fit the view:**
  1. Select the menu item **View > Fit All > Active View.**

2.

2.
Assign Perfect H/Natural Boundaries

To select the object Air:
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: *Air*
   2. Click the OK button

To assign Perfect H Boundary
1. Select the menu item *HFSS > Boundaries > Assign > Perfect H...*
2. Click the OK button

Boundary Display

To verify the boundary setup:
1. Select the menu item *HFSS > Boundary Display (Solver View)*
2. From the Solver View of Boundaries, toggle the Visibility check box for the boundaries you wish to display.
   - **Note:** The Perfect Conductors are displayed as the *smetal* boundary.
   - **Note:** Select the menu item, *View > Visibility* to hide all of the geometry objects. This makes it easier to see the boundary
3. Click the Close button when you are finished.

---

**Solver View of Boundaries**

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Solver Visibility</th>
<th>Visibility</th>
<th>Color</th>
</tr>
</thead>
<tbody>
<tr>
<td>PerfH1</td>
<td>User Defined</td>
<td>Visible to solver.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>p1</td>
<td>User Defined</td>
<td>Visible to solver.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>p2</td>
<td>User Defined</td>
<td>Visible to solver.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>outer</td>
<td>Default</td>
<td>Overridden by other boundaries. Invis</td>
<td></td>
<td></td>
</tr>
<tr>
<td>smetal</td>
<td>Default</td>
<td>Visible to solver.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

---

**Close**
## Analysis Setup

### Creating an Analysis Setup

To create an analysis setup:

1. Select the menu item **HFSS > Analysis Setup > Add Solution Setup**
2. Solution Setup Window:
   
   1. Click the **General** tab:
      
      - Solution Frequency: **10.0GHz**
      - Maximum Number of Passes: **20**
      - Maximum Delta S: **0.02**

   2. Click the **Options** tab:
      
      - Do Lambda Refinement: ✓ **Checked**
      - Target: **0.05**
      - Use Low-Order Solution Basis: ✓ **Checked**

   3. Click the **OK** button

### Adding a Frequency Sweep

To add a frequency sweep:

1. Select the menu item **HFSS > Analysis Setup > Add Sweep**
   
   1. Select Solution Setup: **Setup1**
   2. Click the **OK** button

2. Edit Sweep Window:
   
   1. Sweep Type: **Fast**
   2. Frequency Setup Type: **Linear Count**
      
      - Start: **0.1GHz**
      - Stop: **10.0GHz**
      - Count: **991**
      - Save Fields: ✓ **Checked**

   3. Click the **OK** button
Example - Non-Ideal Planes

- **Save Project**
  - To save the project:
    1. In an Ansoft HFSS window, select the menu item *File > Save As.*
    2. From the *Save As* window, type the Filename: `hfss_nonidealgnd`
    3. Click the *Save* button

- **Analyze**

- **Model Validation**
  - To validate the model:
    1. Select the menu item *HFSS > Validation Check*
    2. Click the *Close* button
      - **Note:** To view any errors or warning messages, use the Message Manager.

- **Analyze**
  - To start the solution process:
    1. Select the menu item *HFSS > Analyze*
8.3 Example - Non-Ideal Planes

## Solution Data

To view the Solution Data:

1. Select the menu item **HFSS > Results > Solution Data**

   To view the Profile:
   1. Click the **Profile** Tab.

   To view the Convergence:
   1. Click the **Convergence** Tab

   **Note:** The default view is for convergence is **Table**. Select the **Plot** radio button to view a graphical representation of the convergence data.

   To view the Matrix Data:
   1. Click the **Matrix Data** Tab

   **Note:** To view a real-time update of the Matrix Data, set the Simulation to **Setup1, Last Adaptive**.

1. Click the **Close** button

---

### Solution Data: hfss_nonidealnd - HFSSModel1

<table>
<thead>
<tr>
<th>Design Variation:</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Simulation:</td>
<td>Setup1, Sweep1</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Convergence</th>
<th>Profile</th>
<th>Matrix Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Passes</td>
<td>Completed 12</td>
<td>Maximum 15</td>
</tr>
</tbody>
</table>

| Max Mag. Delta | Target 0.02 | Current 0.013508 |

View:  
- **Table**  
- **Plot**

**X:** Pass Number  
**Y:** Max Mag. Delta

CONVERGED
Create Reports

Create Terminal S-Parameter Plot vs. Adaptive Pass

Note: If this report is created prior or during the solution process, a real-time update of the results are displayed

To create a report:
1. Select the menu item HFSS > Results > Create Report
2. Create Report Window:
   1. Report Type: Terminal S Parameters
   2. Display Type: Rectangular
   3. Click the OK button
3. Traces Window:
   1. Solution: Setup1: Adaptive1
   2. Click the X tab
      1. Use Primary Sweep: unchecked
      2. Category: Variables
      3. Quantity: Pass
   3. Click the Y tab
      1. Category: Terminal S Parameter
      2. Quantity: St(p1,p1) and St(p1, p2)
      3. Function: dB
      4. Click the Add Trace button
   4. Click the Done button
**Create Terminal S21 Plot vs Frequency**

**To create a report:**

1. Select the menu item *HFSS > Results > Create Report*
2. Create Report Window:
   1. Report Type: **Terminal S Parameters**
   2. Display Type: **Rectangular**
   3. Click the **OK** button
3. Traces Window:
   1. Solution: **Setup1: Sweep1**
   2. Domain: **Sweep**
   3. Click the **Y** tab
      1. Category: **Terminal S Parameter**
      2. Quantity: **St(p1,p2)**
      3. Function: **dB**
      4. Click the **Add Trace** button
4. Click the **Done** button

**To add data marker to the Plots**

1. Select the menu item *Report2D > Data Marker*
2. Move cursor to the resonant points on the plotting curve and click the left mouse button
3. When you are finished placing markers at the resonances, right-click the mouse and select **Exit Marker Mode**.
Example - Non-Ideal Planes

Ansoft Corporation
XY Plot 2
HFSSModel1

18 Jun 2003

10:56:31

-50.00
-40.00
-30.00
-20.00
-10.00
0.00
10.00
20.00
30.00
40.00
50.00

0.00
2.00
4.00
6.00
8.00
10.00

Freq [GHz]

dB (S11(p21))
Field Overlays

Create Field Overlay

Select the Relative CS XY Plane
1. Using the Model Tree, expand Planes
   1. Select Relative CS3 XY
      - Note: Relative CS3 XY plane is the plane between the two Ground
        planes.
2. Select the menu item HFSS > Fields > Fields > E > Mag_E
3. Create Field Plot Window
   1. Solution: Setup1 : Sweep1
   2. Intrinsic Variables: Freq: 1.9GHz; Phase: 0deg
   3. Quantity: Mag_E
   4. In Volume: Board
   5. Click the Done button

To modify the attributes of a field plot:
1. Select the menu item HFSS > Fields > Modify Plot Attributes
2. Select Plot Folder Window:
   1. Select: E Field
   2. Click the OK button
3. E-Field Window:
   1. Click the Scale tab
      1. Select Use Limits
      2. Min: 5
      3. Max: 3500
      4. Scale: Log
   2. Click the Plots Tab
      1. Scalar Plot: Fringe
      2. Click the Close button
Create Field Overlay - Additional Frequency Points

To modify the Frequency of a field plot:
1. Select the menu item **HFSS > Fields > Modify Plot**
2. Select Plot Folder Window:
   1. Select: **E Field**
   2. Click the **OK** button
3. Create Field Plot Window
   1. Solution: **Setup1 : Sweep1**
   2. Freq: 6.84 GHz

Exiting HFSS

To Exit HFSS:
1. Select the menu item **File > Exit**
   1. If prompted Save the changes
THIS PAGE INTENTIONALY LEFT BLANK
Return Path

This example is intended to show you how to create, simulate, and analyze the return path examples used in the Boundary/Excitations Overview for the Ansoft HFSS Design Environment.
Getting Started

Launching Ansoft HFSS
1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft > HFSS 10 program group. Click HFSS 10.

Setting Tool Options
1. To set the tool options:
   - **Note:** In order to follow the steps outlined in this example, verify that the following tool options are set:
     1. Select the menu item Tools > Options > HFSS Options
     2. HFSS Options Window:
        1. Click the General tab
           - Use Wizards for data entry when creating new boundaries: ☑ Checked
           - Duplicate boundaries with geometry: ☑ Checked
        2. Click the OK button
     3. Select the menu item Tools > Options > 3D Modeler Options.
     4. 3D Modeler Options Window:
        1. Click the Operation tab
           - Automatically cover closed polylines: ☑ Checked
        2. Click the Drawing tab
           - Edit property of new primitives: ☑ Checked
        3. Click the OK button
## Opening a New Project

**To open a new project:**

1. In an Ansoft HFSS window, click the `File` on the Standard toolbar, or select the menu item `File > New`.
2. From the `Project` menu, select `Insert HFSS Design`.

## Set Solution Type

**To set the solution type:**

1. Select the menu item `HFSS > Solution Type`
2. Solution Type Window:
   1. Choose **Driven Terminal**
   2. Click the **OK** button
8.4

Creating the 3D Model

Set Model Units

To set the units:
1. Select the menu item 3D Modeler > Units
2. Set Model Units:
   1. Select Units: mm
   2. Click the OK button

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
   1. Type pec in the Search by Name field
   2. Click the OK button
Create Conductor

To create the conductor:
1. Select the menu item *Draw > Line*
2. Using the coordinate entry fields, enter the vertex point:
   - X: -5.0, Y: -0.24, Z: 0.1, Press the Enter key
3. Using the coordinate entry fields, enter the vertex point:
   - X: -1.0, Y: -0.24, Z: 0.1, Press the Enter key
4. Using the coordinate entry fields, enter the vertex point:
   - X: -1.0, Y: -0.24, Z: 1.1, Press the Enter key
5. Using the coordinate entry fields, enter the vertex point:
   - X: 0.0, Y: -0.24, Z: 1.1, Press the Enter key
6. Using the mouse, right-click and select Done
7. Click the OK button when the Properties dialog appears

To set the grid plane:
1. Select the menu item *3D Modeler > Grid Plane > YZ*

To create conductor profile:
1. Select the menu item *Draw > Rectangle*
2. Using the coordinate entry fields, enter the box position
   - X: -5.0, Y: -0.3, Z: 0.1, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: 0.0, dY: 0.12, dZ: 0.02, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Cond
3. Click the OK button

To Sweep the profile:
1. Select the menu item *Edit > Select All Visible.* Or press the CTRL+A key
2. Select the menu item *Draw > Sweep > Along Path*
3. Click the OK button when the Sweep along path dialog appears

To fit the view:
1. Select the menu item *View > Fit All > Active View.* Or press the CTRL+D key
**Example - Return Path**

- **Duplicate Conductor**
  - To select the object:
    1. Select the menu item *Edit > Select All Visible.*
  - To duplicate the conductor:
    1. Select the menu item, *Edit > Duplicate > Along Line.*
    - First Point: X: 0.0, Y: 0.0, Z: 0.0 Press the *Enter* key
    - Second Point: dX: 0.0, dY: 0.24, dZ: 0.0 Press the *Enter* key
    - Total Number: 3
    - Click the OK button

- **Mirror Conductor**
  - To duplicate the existing objects:
    1. Select the menu item *Edit > Select All Visible.* Or press the *CTRL+A* key.
    2. Select the menu item, *Edit > Duplicate > Mirror.*
    - Input the anchor point of the mirror plane:
      - X: 0.0, Y: 0.0, Z: 0.0, Press the *Enter* key
    - Input the target point of the vector normal to the mirror plane:
      - dX: 1.0, dY: 0.0, dZ: 0.0, Press the *Enter* key

- **Group Conductors**
  - To group the conductors:
    1. Select the menu item *Edit > Select All Visible.*
    2. Select the menu item, *3D Modeler > Boolean > Unite*
### Create Ground

**To create the ground:**
1. Select the menu item *Draw > Box*
2. Using the coordinate entry fields, enter the box position
   - X: -5.0, Y: -1.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: 4.0, dY: 2.0, dZ: -0.02, Press the Enter key

**To set the name:**
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: GND
3. Click the OK button

**To fit the view:**
1. Select the menu item *View > Fit All > Active View.*

### Mirror Ground

**To select the object GND:**
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   - 1. Select the objects named: GND
   - 2. Click the OK button

**To mirror the ground:**
1. Select the menu item, *Edit > Duplicate > Mirror.*
   1. Input the anchor point of the mirror plane:
      - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
   2. Input the target point of the vector normal to the mirror plane:
      - dX: 1.0, dY: 0.0, dZ: 0.0, Press the Enter key
Example - Return Path

- **Set Grid Plane**
  - To set the grid plane:
    1. Select the menu item *3D Modeler > Grid Plane > YZ*

- **Create Source**
  - To create source:
    1. Select the menu item *Draw > Rectangle*
    2. Using the coordinate entry fields, enter the box position
      - X: 5.0, Y: -0.06, Z: 0.1, Press the *Enter* key
    3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
      - dX: 0.0, dY: 0.12, dZ: -0.1, Press the *Enter* key
  - To set the name:
    1. Select the *Attribute* tab from the *Properties* window.
    2. For the *Value* of *Name* type: *Source*
    3. Click the *OK* button
  - To fit the view:
    1. Select the menu item *View > Fit All > Active View.*
Example - Return Path

⚠️ **Assign Excitation**

⚠️ **To select the object Source:**
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: **Source**
   2. Click the **OK** button
   ⚠️ **Note:** You can also select the object from the Model Tree

⚠️ **To assign lumped port excitation**
1. Select the menu item *HFSS > Excitations > Assign > Lumped Port*
2. Lumped Port: General
   1. Name: **p1**
   2. Resistance: **50**
   3. Reactance: **0**
   4. Click the **Next** button
3. Lumped Port: Terminals
   1. Number of Terminals: **1**
   2. For **T1**, click the **Undefined** column and select **New Line**
   3. Using the coordinate entry fields, enter the vector position
      ⚠️ X: **5.0**, Y: **0.0**, Z: **0.0**, Press the **Enter** key
   4. Using the coordinate entry fields, enter the vertex
      ⚠️ dX: **0.0**, dY: **0.0**, dZ: **0.1**, Press the **Enter** key
5. Click the **Next** button
6. Click the **Finish** button
Example - Return Path

Create Source2

To select Source:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Source
   2. Click the OK button

To mirror the source:
1. Select the menu item, Edit > Duplicate > Mirror:
   1. Input the anchor point of the mirror plane:
      ▲ X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
   2. Input the target point of the vector normal to the mirror plane:
      ▲ dX: 1.0, dY: 0.0, dZ: 0.0, Press the Enter key

Create Source3

To select Source:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Source_1
   2. Click the OK button

To mirror the source:
1. Select the menu item, Edit > Duplicate > Mirror:
   1. Input the anchor point of the mirror plane:
      ▲ X: 0.0, Y: 0.12, Z: 0.0, Press the Enter key
   2. Input the target point of the vector normal to the mirror plane:
      ▲ dX: 0.0, dY: 1.0, dZ: 0.0, Press the Enter key
**Add New Material**

**To add a new material:**

1. Using the 3D Modeler Materials toolbar, choose **Select**
2. From the Select Definition window, click the **Add Material** button
3. View/Edit Material Window:
   1. Material Name: **My_FR4**
   2. Relative Permittivity: **4.4**
   3. Click the **OK** button
4. Click the **OK** button
Example - Return Path

### Set Grid Plane

- **To set the grid plane:**
  1. Select the menu item 3D Modeler > Grid Plane > XY

### Create Substrate

- **To create substrate:**
  1. Select the menu item Draw > Box
  2. Using the coordinate entry fields, enter the box position
     - X: -5.0, Y: -1.0, Z: 0.0, Press the Enter key
  3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
     - dX: 4.0, dY: 2.0, dZ: 0.1, Press the Enter key

- **To set the name:**
  1. Select the Attribute tab from the Properties window.
  2. For the Value of Name type: Substrate

- **To set the transparency:**
  1. Select the Attribute tab from the Properties window.
  2. Click the button for Transparency
     1. Move the slide bar to 0.8 (Opaque=0, Transparency=1)
     2. Click the OK button
  3. Click the OK button

### Mirror Substrate

- **To select the object substrate:**
  1. Select the menu item Edit > Select > By Name
  2. Select Object Dialog,
     1. Select the objects named: Substrate
     2. Click the OK button

- **To mirror the ground:**
  1. Select the menu item Edit > Duplicate > Mirror.
     1. Input the anchor point of the mirror plane:
        - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
     2. Input the target point of the vector normal to the mirror plane:
        - dX: 1.0, dY: 0.0, dZ: 0.0, Press the Enter key
Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose vacuum

Create Air

To create the Air:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: -5.2, Y: -2.0, Z: -0.2, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: 10.4, dY: 4.0, dZ: 2.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Air
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Assign Radiation

To select the object Air:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Air
   2. Click the OK button

To assign Radiation Boundary
1. Select the menu item HFSS > Boundaries > Assign > Radiation
2. Click the OK button
Example - Return Path

**Boundary Display**

To verify the boundary setup:

1. Select the menu item *HFSS > Boundary Display (Solver View)*
2. From the Solver View of Boundaries, toggle the Visibility check box for the boundaries you wish to display.

   **Note:** The Perfect Conductors are displayed as the *smetal* boundary.

   **Note:** Select the menu item, *View > Visibility* to hide all of the geometry objects. This makes it easier to see the boundary.

3. Click the *Close* button when you are finished.
Analysis Setup

Creating an Analysis Setup

To create an analysis setup:
1. Select the menu item **HFSS > Analysis Setup > Add Solution Setup**
2. Solution Setup Window:
   1. Click the **General** tab:
      - Solution Frequency: **15.1GHz**
      - Maximum Number of Passes: **20**
      - Maximum Delta S: **0.03**
   2. Click the **Options** tab:
      - Do Lambda Refinement: ☑ Checked
      - Target: **0.05**
      - User Low-Order Solution Basis: ☑ Checked
3. Click the **OK** button

Adding a Frequency Sweep

To add a frequency sweep:
1. Select the menu item **HFSS > Analysis Setup > Add Sweep**
   1. Select Solution Setup: **Setup1**
   2. Click the **OK** button
2. Edit Sweep Window:
   1. Sweep Type: **Fast**
   2. Frequency Setup Type: **Linear Count**
      - Start: **0.1GHz**
      - Stop: **15.1GHz**
      - Count: **301**
      - Save Fields: ☑ Checked
3. Click the **OK** button
Example - Return Path

- **Save Project**
  - **To save the project:**
    1. In an Ansoft HFSS window, select the menu item *File > Save As.*
    2. From the *Save As* window, type the Filename: *hfss_returnpath*
    3. Click the *Save* button

- **Analyze**

- **Model Validation**
  - **To validate the model:**
    1. Select the menu item *HFSS > Validation Check*
    2. Click the *Close* button

  - **Note:** To view any errors or warning messages, use the Message Manager.

- **Analyze**
  - **To start the solution process:**
    1. Select the menu item *HFSS > Analyze All*
**Solution Data**

To view the Solution Data:

1. Select the menu item **HFSS > Results > Solution Data**

   To view the Profile:
   1. Click the **Profile** Tab.

   To view the Convergence:
   1. Click the **Convergence** Tab
   
   **Note:** The default view is for convergence is **Table**. Select the **Plot** radio button to view a graphical representations of the convergence data.

To view the Matrix Data:

1. Click the **Matrix Data** Tab

   **Note:** To view a real-time update of the Matrix Data, set the Simulation to **Setup1, Last Adaptive**

2. Click the **Close** button

![Solution Data: hfss_7_4 - new2_rad](image)
Create Reports

Create Terminal S-Parameter Plot vs. Adaptive Pass

Note: If this report is created prior or during the solution process, a real-time update of the results are displayed.

To create a report:

1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Terminal S Parameters**
   2. Display Type: **Rectangular**
   3. Click the **OK** button
3. Traces Window:
   1. Solution: **Setup1: Adaptive1**
   2. Click the **Y** tab
      1. Category: **Terminal S Parameter**
      2. Quantity: **St(p1,p1), St(p1, p2), St(p1, p3)**
      3. Function: **dB**
      4. Click the **Add Trace** button
3. Click the **Done** button
Example - Return Path

**Create Terminal S-Parameter Plot vs Frequency**

To create a report:

1. Select the menu item *HFSS > Results > Create Report*
2. Create Report Window:
   1. Report Type: **Terminal S Parameters**
   2. Display Type: **Rectangular**
   3. Click the **OK** button
3. Traces Window:
   1. Solution: **Setup1: Sweep1**
   2. Domain: **Sweep**
   3. Click the Y tab
     1. Category: **Terminal S Parameter**
     2. Quantity: $S_t(p1,p1), S_t(p1, p2), S_t(p1, p3)$
     3. Function: **dB**
     4. Click the **Add Trace** button
   4. Click the **Done** button.
Example - Return Path

Return Path - Add a DC Return Path

We will continue our investigation by adding a connection between the two ground planes. The DC return path will be the path of least resistance.
Example - Return Path

- **Copy the Design**
  - To copy the entire design:
    1. Using the project manager,
      1. Right-click on HFSSModel1, and choose *Copy*
    2. Using the project manager,
      1. Right-click on hfss_returmpath, and choose *Paste*

- **Open the 3D Model Editor**
  - To open the 3D Model Editor:
    1. Using the project manager,
      1. Right-click on HFSSModel2 and choose *3D Model Editor*

- **Set Default Material**
  - To set the default material:
    1. Using the 3D Modeler Materials toolbar, choose *pec*
Create DC Path

To create the DC path:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: -1.0, Y: 1.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: 2.0, dY: -0.12, dZ: 0.02, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: DCPAch
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
Example - Return Path

- **Save Project**
  - To save the project:
    1. In an Ansoft HFSS window, select the menu item **File > Save**

- **Analyze**

- **Model Validation**
  - To validate the model:
    1. Select the menu item **HFSS > Validation Check**
    2. Click the Close button

- **Analyze**
  - To start the solution process:
    1. Select the menu item **HFSS > Analyze All**

- **To Open All Existing Report**
  - To open all reports:
    1. Select the menu item **HFSS > Results > Open All Reports**

![Graph showing frequency response](image-url)
Return Path - Add a RF Return Path

We will continue our investigation by adding an RF return path between the two ground planes. The RF return path will be the path of least inductance.
Example - Return Path

Copy the Design

To copy the entire design:
1. Using the project manager, 
   1. Right-click on HFSSModel1, and choose Copy
2. Using the project manager, 
   1. Right-click on hfss_returnpath, and choose Paste

Open the 3D Model Editor

To open the 3D Model Editor:
1. Using the project manager, 
   1. Right-click on HFSSModel3 and choose 3D Model Editor

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose pec
Create RF Path

To create the RF path:
1. Select the coordinate item *Draw > Line*
2. Using the coordinate entry fields, enter the vertex point:
   - X: -1.0, Y: 0.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the radial point:
   - X: -0.972, Y: 0.0, Z: 0.0, Press the Enter key
4. Using the coordinate entry fields, enter the sweep arc length:
   - X: -0.972, Y: 0.0, Z: 1.072, Press the Enter key
5. Using the coordinate entry fields, enter the sweep arc length:
   - X: 0.0, Y: 0.0, Z: 1.072, Press the Enter key
6. Using the mouse, right-click and select Done
7. Click the OK button when the Properties dialog appears

To set the grid plane:
1. Select the menu item *3D Modeler > Grid Plane > YZ*

To create the profile:
1. Select the menu item *Draw > Rectangle*
2. Using the coordinate entry fields, enter the box position
   - X: -1.0, Y: -0.06, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: 0.0, dY: 0.12, dZ: -0.02, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: RFPath
3. Click the OK button

To Sweep the profile:
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: Polyline2, RFPath
   2. Click the OK button
3. Select the menu item *Draw > Sweep > Along Path*
4. Click the OK button when the Sweep along path dialog appears
Mirror Conductor

To duplicate the existing objects:
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: RFPath
   2. Click the OK button
3. Select the menu item, *Edit > Duplicate > Mirror*.
   1. Input the anchor point of the mirror plane:
      - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
   2. Input the target point of the vector normal to the mirror plane:
      - dX: 1.0, dY: 0.0, dZ: 0.0, Press the Enter key

Group Conductors

To group the conductors:
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: RFPath, RFPath_1
   2. Click the OK button
3. Select the menu item, *3D Modeler > Boolean > Unite*
## Example - Return Path

### Save Project

To save the project:
1. In an Ansoft HFSS window, select the menu item **File > Save**

### Analyze

### Model Validation

To validate the model:
1. Select the menu item **HFSS > Validation Check**
2. Click the Close button

### Analyze

To start the solution process:
1. Select the menu item **HFSS > Analyze**

### To Open All Existing Report

To open all reports:
1. Select the menu item **HFSS > Results > Open All Reports**

![Graph showing frequency response](image-url)
Exiting HFSS

To Exit HFSS:

1. Select the menu item **File > Exit**
   1. If prompted Save the changes
THIS PAGE INTENTIONALLY LEFT BLANK
Chapter 9.0 – EMC/EMI Examples

- 9.1 - Heat Sink
- 9.2 - Enclosure
THIS PAGE INTENTIONALLY LEFT BLANK
Heat Sink

This example is intended to show you how to create, simulate, and analyze a heat sink using the Ansoft HFSS Design Environment.

With higher power and microwave clock speed, containing emissions from heat sinks for microelectronics is rapidly becoming a necessity. We will investigate the performance of a single grounding configuration. The following illustrations detail the passive device you will be creating:

Heat Sink/Ground/Ground Pins = Perfect Conductor
Example - Heat Sink

Ansoft HFSS Design Environment

- The following features of the Ansoft HFSS Design Environment are used to create this passive device model:
  - 3D Solid Modeling
    - Primitives: Box, Rectangle
  - Boundaries/Excitations
    - Boundaries: Perfect H, Perfect E
  - Results
    - Eigenmode Data
    - Fields: E- & H-Field
9.1 Example - Heat Sink

### Design Review

Before we jump into setting up this device let's review the design.
- **Port Size/Type**
  - ???
- **Free Space**
  - ??

### Port Size/Type

The goal of this simulation is to determine the effectiveness of various grounding conditions at reducing the radiated emissions from a heat sink. There are two methods we could use to analyze this problem:

- **Method 1:** Define a port which will excite the structure and measure the radiated emissions some distance from the model to determine the resonant frequencies. From the radiated emissions, the low frequency performance can be determined. This can be very computer intensive and depending on the location of the excitation, modes can be missed.

- **Method 2:** Use the Eigenmode solver to determine the natural resonances of the heat sink. This will not give us the radiated emissions, but it will quickly tell us which configuration reduces the low frequency emissions.

Let's try Case 2. The Eigenmode solver does not use ports so we only have to define the geometry and the boundary conditions.

### Free Space

The Eigenmode Solver does not support radiation boundaries. Therefore, we will apply a perfect H boundary to the outside of the model to simulate free space.
Example - Heat Sink

Getting Started

Launching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft HFSS 10 program group. Click HFSS 10.

Setting Tool Options

To set the tool options:

Note: In order to follow the steps outlined in this example, verify that the following tool options are set:

1. Select the menu item Tools > Options > HFSS Options
2. HFSS Options Window:
   1. Click the General tab
      - Use Wizards for data entry when creating new boundaries: ☑ Checked
      - Duplicate boundaries with geometry: ☑ Checked
   2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options
4. 3D Modeler Options Window:
   1. Click the Operation tab
      - Automatically cover closed polylines: ☑ Checked
   2. Click the Drawing tab
      - Edit property of new primitives: ☑ Checked
   3. Click the OK button
Example - Heat Sink

### Opening a New Project

To open a new project:

1. In an Ansoft HFSS window, click the on the Standard toolbar, or select the menu item **File > New**.
2. From the **Project** menu, select **Insert HFSS Design**.

![Image of project tree](image)

### Set Solution Type

To set the solution type:

1. Select the menu item **HFSS > Solution Type**
2. Solution Type Window:
   1. Choose **Eigenmode**
   2. Click the **OK** button

![Image of solution type dialog](image)
Creating the 3D Model

Set Model Units

To set the units:
1. Select the menu item **3D Modeler > Units**
2. Set Model Units:
   1. Select Units: **mm**
   2. Click the **OK** button

Set Default Material

To set the default material:
Using the 3D Modeler Materials toolbar, choose **vacuum**

Create an Air box

Create Air box
1. Select the menu item **Draw > Box**
2. Using the coordinate entry fields, enter the box position
   - $X: -80.0$, $Y: -60.0$, $Z: 0.0$, Press the **Enter** key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - $dX: 160.0$, $dY: 120.0$, $dZ: 44.1$, Press the **Enter** key

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: **Air**

To set the Wireframe view:
1. Select the **Attribute** tab from the **Properties** window.
2. Display Wireframe: **Checked**
3. Click the **OK** button

To fit the view:
1. Select the menu item **View > Fit All > Active View** or press the **CTRL+D** key
### Example - Heat Sink

#### Assign a Perfect H boundary to Air

**To select the Air:**
1. Select the menu item *Edit > Select All*

**To assign the Perfect H boundary**
1. Select the menu item *HFSS > Boundaries > Assign > Perfect H*
2. Perfect H Boundary window
   - Name: *Open*
   - Click the OK button

#### Set Default Material

**To set the default material:**
1. Using the 3D Modeler Materials toolbar, choose *Select*
2. Select Definition Window:
   1. Type *pec* in the Search by Name field
   2. Click the OK button

#### Create the Heat Sink

**Create Heat Sink**
1. Select the menu item *Draw > Box*
2. Using the coordinate entry fields, enter the box position
   - X: *-44.45*, Y: *-31.75*, Z: *6.0* Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: *88.9*, dY: *63.5*, dZ: *38.1* Press the Enter key

**To set the name:**
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: *Sink*
3. Click the OK button

**To fit the view:**
1. Select the menu item *View > Fit All > Active View.*


### Example - Heat Sink

#### Create Offset Coordinate System

- **Create CS**
  1. Select the menu item *3D Modeler > Coordinate System > Create > Relative CS > Offset*
  2. Using the coordinate entry fields, enter the origin
     - X: -44.45, Y: 0.0, Z: 6.0 Press the Enter key

#### Create a Ground Pin 1

- **Create Ground Pin 1**
  1. Select the menu item *Draw > Box*
  2. Using the coordinate entry fields, enter the box position
     - X: 0.0, Y: -3.0, Z: 0.0 Press the Enter key
  3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
     - dX: 6.0, dY: 6.0, dZ: -6.0 Press the Enter key

- **To set the name:**
  1. Select the *Attribute* tab from the *Properties* window.
  2. For the *Value of Name* type: *Ground_Pin*
  3. Click the *OK* button

- **To fit the view:**
  1. Select the menu item *View > Fit All > Active View.*
Example - Heat Sink

Create Ground Pin 2

To select the object Ground_Pin:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Ground_Pin
   2. Click the OK button

To create Ground Pin 2:
1. Select the menu item, Edit > Duplicate > Along Line.
   1. First Point: X: 6.0, Y: 0.0, Z: 0.0 Press the Enter key
   2. Second Point: dX: 82.9, dY: 0.0, dZ: 0.0 Press the Enter key
   3. Total Number: 2
   4. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Set Working Coordinate System

To set the working coordinate system:
1. Select the menu item 3D Modeler > Coordinate System > Set Working CS
2. Select Coordinate System Window,
   1. From the list, select the CS: Global
   2. Click the Select button
**Example - Heat Sink**

### Create Ground

**To create ground:**
1. Select the menu item *Draw > Rectangle*
2. Using the coordinate entry fields, enter the box position:
   - **X:** -80.0, **Y:** -60.0, **Z:** 0.0, Press the *Enter* key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - **dX:** 160.0, **dY:** 120.0, **dZ:** 0.0, Press the *Enter* key

**To set the name:**
1. Select the *Attribute* tab from the *Properties* window.
2. For the *Value of Name* type: **Ground**
3. Click the *OK* button

**To fit the view:**
1. Select the menu item *View > Fit All > Active View.*

### Assign a Perfect E boundary to the Ground

**To select the ground:**
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: **Ground**
   2. Click the *OK* button

**To assign the Perfect E boundary**
1. Select the menu item *HFSS > Boundaries > Assign > Perfect E*
2. Perfect E Boundary window
   1. Name: **PerfE_Ground**
   2. Click the *OK* button
Mesh Operations

To select an object:
1. Select the menu item \textit{Edit > Select > By Name}
2. Select Object Dialog,
   1. Select the objects named: \textit{Ground}
   2. Click the OK button

To assign a mesh operation:
1. Select the menu item, \textit{HFSS > Mesh Operations > Assign > On Selection > Length Based}
2. Element Length Based Refinement Dialog.
   1. Name: \textit{Ground}
   2. Restrict Length of Elements: \textit{Unchecked}
   3. Restrict Number of Elements: \textit{Checked}
   4. Maximum Number of Elements: 1000
   5. Click the OK button
Example - Heat Sink

Analysis Setup

Creating an Analysis Setup

To create an analysis setup:
1. Select the menu item **HFSS > Analysis Setup > Add Solution Setup**
2. Solution Setup Window:
   1. Click the **General** tab:
      - Minimum Frequency: 0.1 GHz
      - Number of Modes: 2
      - Maximum Number of Passes: 10
      - Maximum Delta Frequency per Pass: 1%
   2. Click the **OK** button

Save Project

To save the project:
1. In an Ansoft HFSS window, select the menu item **File > Save As**
2. From the **Save As** window, type the Filename: *hfss_heat_sink*
3. Click the **Save** button

Analyze

Model Validation

To validate the model:
1. Select the menu item **HFSS > Validation Check**
2. Click the **Close** button

   Note: To view any errors or warning messages, use the Message Manager.

Analyze

To start the solution process:
1. Select the menu item **HFSS > Analyze All**
### Example - Heat Sink

#### Solution Data

To view the Solution Data:

1. Select the menu item `HFSS > Results > Solution Data`

To view the Profile:

1. Click the **Profile** Tab.

To view the Convergence:

1. Click the **Convergence** Tab

**Note:** The default view is for convergence is **Table**. Select the **Plot** radio button to view a graphical representations of the convergence data.

To view the Eigenmode Data:

1. Click the **Eigenmode Data** Tab

**Note:** To view a real-time update of the Eigenmode Data, set the Simulation to **Setup1, Last Adaptive**

2. Click the **Close** button

![Solution Data: hfss_heat_sink - HFSSModel1](image)
Field Overlays

Create Field Overlay

To create a field plot:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Ground
   2. Click the OK button
3. Select the menu item HFSS > Fields > Fields > E > Mag_E
4. Create Field Plot Window
   1. Solution: Setup1 : LastAdaptive
   2. Quantity: Mag_E
   3. In Volume: All
   4. Click the Done button
### Example – Heat Sink

**Edit Sources**

**To Excite Mode 2:**

1. Select the menu item *HFSS > Fields > Edit Sources*
2. Edit Sources window
   1. Source: *EigenMode_1*
      1. Scaling Factor: 0
      2. Offset Phase: 0
   2. Source: *EigenMode_2*
      1. Scaling Factor: 1
      2. Offset Phase: 0
3. Click the OK button

![Mode 2: E-Field](image)
Create Field Overlay

To create a field plot:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Ground
   2. Click the OK button
3. Select the menu item HFSS > Fields > Fields > H > Mag_H
4. Create Field Plot Window
   1. Solution: Setup1 : LastAdaptive
   2. Quantity: Mag_H
   3. In Volume: All
   4. Click the Done button

Edit Sources

To Excite Mode 1:
1. Select the menu item HFSS > Fields > Edit Sources
2. Edit Sources window
   1. Source: EigenMode_1
      1. Scaling Factor: 1
      2. Offset Phase: 90
   2. Source: EigenMode_2
      1. Scaling Factor: 0
      2. Offset Phase: 0
   3. Click the OK button

Mode 1: H-Field
Example - Heat Sink

Edit Sources

To Excite Mode 2:
1. Select the menu item *HFSS > Fields > Edit Sources*
2. Edit Sources window
   1. Source: *EigenMode_1*
      1. Scaling Factor: 0
      2. Offset Phase: 0
   2. Source: *EigenMode_2*
      1. Scaling Factor: 1
      2. Offset Phase: 90
3. Click the OK button

Exiting HFSS

To Exit HFSS:
1. Select the menu item *File > Exit*
   1. If prompted Save the changes
Shielded Enclosure

This example is intended to show you how to create, simulate, and analyze a shielded enclosure using the Ansoft HFSS Design Environment.

Shielding enclosures for high-speed digital designs can be compromised by slots and apertures. Therefore an understanding of the energy coupling mechanisms is essential.
Ansoft HFSS Design Environment

The following features of the Ansoft HFSS Design Environment are used to create this passive device model:

- **3D Solid Modeling**
  - Primitives: Box, Rectangle, Cylinder
  - Boolean: Unite, Subtract

- **Boundaries/Excitations**
  - Boundaries: Lumped RLC, Radiation

- **Results**
  - Reports: S-Parameters
  - Fields: E-Field
References

1. EMI from Shielding Enclosures—FDTD Modeling and Measurements, Min Li, Electromagnetic Compatibility Laboratory, University of Missouri-Rolla March 1999
Getting Started

Launching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft HFSS 10 program group. Click HFSS 10.

Setting Tool Options

To set the tool options:

Note: In order to follow the steps outlined in this example, verify that the following tool options are set:

1. Select the menu item Tools > Options > HFSS Options
2. HFSS Options Window:
   1. Click the General tab
      - Use Wizards for data entry when creating new boundaries: ☑ Checked
      - Duplicate boundaries with geometry: ☑ Checked
   2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:
   1. Click the Operation tab
      - Automatically cover closed polylines: ☑ Checked
   2. Click the Drawing tab
      - Edit property of new primitives: ☑ Checked
   3. Click the OK button
### Opening a New Project

**To open a new project:**

1. In an Ansoft HFSS window, click the button On the Standard toolbar, or select the menu item `File > New`.
2. From the `Project` menu, select `Insert HFSS Design`.

![Project window](image)

### Set Solution Type

**To set the solution type:**

1. Select the menu item `HFSS > Solution Type`.
2. Solution Type Window:
   1. Choose `Driven Terminal`.
   2. Click the OK button.

![Solution Type window](image)
Creating the 3D Model

Set Model Units

To set the units:
1. Select the menu item **3D Modeler > Units**
2. Set Model Units:
   1. Select Units: **cm**
   2. Click the **OK** button

Set Default Material

To set the default material:
- Using the 3D Modeler Materials toolbar, choose **vacuum**

Create the Air Inside case

Create Air Inside Case
1. Select the menu item **Draw > Box**
2. Using the coordinate entry fields, enter the box position
   - X: **0.0**, Y: **0.0**, Z: **0.0**, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: **22.0**, dY: **14.0**, dZ: **30.0**, Press the Enter key

To set the name:
1. Select the **Attribute** tab from the Properties window.
2. For the **Value of Name** type: **Air_Inside**
3. Click the **OK** button

To fit the view:
1. Select the menu item **View > Fit All > Active View**.
   Or press the **CTRL+D** key
Create the Slot

Create Slot

1. Select the menu item **Draw > Box**
2. Using the coordinate entry fields, enter the box position
   - X: 0.0, Y: 0.2, Z: 9.0 Press the **Enter** key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: -0.05, dY: 0.1, dZ: 12.0 Press the **Enter** key

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: Slot
3. Click the **OK** button

To fit the view:
1. Select the menu item **View > Fit All > Active View**.

Create an Air box

Create an Air box

1. Select the menu item **Draw > Box**
2. Using the coordinate entry fields, enter the box position
   - X: -4.05, Y: -4.05, Z: -4.05, Press the **Enter** key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: 28.1, dY: 20.1, dZ: 38.1, Press the **Enter** key

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: Air
3. Display Wireframe: **Checked**
4. Click the **OK** button

To fit the view:
1. Select the menu item **View > Fit All > Active View**.

Create Offset Coordinate System

Create CS

1. Select the menu item **3D Modeler > Coordinate System > Create > Relative CS > Offset**
2. Using the coordinate entry fields, enter the origin
   - X: 17.0, Y: 14.0, Z: 15.0 Press the **Enter** key
Create Coax Dielectric

To create the coax dielectric:
1. From the Drawing Plane toolbar, change the active plane to XZ.
2. Select the menu item Draw > Cylinder
3. Using the coordinate entry fields, enter the center position
   X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
4. Using the coordinate entry fields, enter the radius of the cylinder
   dX: 0.16, dY: 0.0, dZ: 0.0, Press the Enter key
5. Using the coordinate entry fields, enter the height of the cylinder
   dX: 0.0, dY: 2.05, dZ: 0.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Coax_Diel
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View

Group Objects

To group the objects:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Air_Inside, Coax_Diel, Slot
   2. Click the OK button.
3. Select the menu item, 3D Modeler > Boolean > Unite

To fit the view:
1. Select the menu item View > Fit All > Active View.

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
   1. Type pec in the Search by Name field
   2. Click the OK button
Create Coax Shield

To create the coax shield:
1. From the Drawing Plane toolbar, change the active plane to XZ.
2. Select the menu item Draw > Cylinder
3. Using the coordinate entry fields, enter the center position:
   - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
4. Using the coordinate entry fields, enter the radius of the cylinder:
   - dX: 0.21, dY: 0.0, dZ: 0.0, Press the Enter key
5. Using the coordinate entry fields, enter the height of the cylinder:
   - dX: 0.0, dY: 2.05, dZ: 0.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Coax_Shield
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View

Create Coax Pin

To create the coax pin:
1. From the Drawing Plane toolbar, change the active plane to XZ.
2. Select the menu item Draw > Cylinder
3. Using the coordinate entry fields, enter the center position:
   - X: 0.0, Y: 2.05, Z: 0.0, Press the Enter key
4. Using the coordinate entry fields, enter the radius of the cylinder:
   - dX: 0.08, dY: 0.0, dZ: 0.0, Press the Enter key
5. Using the coordinate entry fields, enter the height of the cylinder:
   - dX: 0.0, dY: -15.89, dZ: 0.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Coax_Pin
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View
Create the Wave port

To create a circle that represents the port:
1. From the Drawing Plane toolbar, change the active plane to XZ.
2. Select the menu item **Draw > Circle**
3. Using the coordinate entry fields, enter the center position
   - X: 0.0, Y: 2.05, Z: 0.0, Press the Enter key
4. Using the coordinate entry fields, enter the radius of the circle:
   - dX: 0.16, dY: 0.0, dZ: 0.0, Press the Enter key

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value** of **Name** type: p1
3. Click the OK button

To select the object p1:
1. Select the menu item **Edit > Select > By Name**
2. Select Object Dialog,
   1. Select the objects named: p1
3. Click the OK button

To assign wave port excitation
1. Select the menu item **HFSS > Excitations > Assign > Wave Port**
2. Wave Port : General
   1. Name: p1,
   2. Click the Next button
3. Wave Port : Terminals
   1. Number of Terminals: 1,
   2. For T1, click the **Undefined** column and select **New Line**
   3. Using the coordinate entry fields, enter the vector position
      - X: 0.16, Y: 2.05, Z: 0.0, Press the Enter key
   4. Using the coordinate entry fields, enter the vertex
      - dX: -0.08, dY: 0.0, dZ: 0.0, Press the Enter key
3. Click the Next button
4. Wave Port : Differential Pairs
   1. Click the Next button
5. Wave Port : Post Processing
   1. Reference Impedance: 50
6. Click the Finish button
Create Offset Coordinate System

- **Create CS**
  1. Select the menu item *3D Modeler > Coordinate System > Create > Relative CS > Offset*
  2. Using the coordinate entry fields, enter the origin
     - X: 0.0, Y: -13.84, Z: 0.0 Press the Enter key

Create Resistor

- **To create the Resistor:**
  1. From the Drawing Plane toolbar, change the active plane to XY.
  2. Select the menu item *Draw > Rectangle*
  3. Using the coordinate entry fields, enter the box position
     - X: -0.08, Y: 0.0, Z: 0.0, Press the Enter key
  4. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
     - dX: 0.16, dY: -0.16, dZ: 0.0, Press the Enter key

- **To set the name:**
  1. Select the Attribute tab from the Properties window.
  2. For the Value of Name type: Resistor
  3. Click the OK button

- **To fit the view:**
  1. Select the menu item *View > Fit All > Active View*.
**Assign a Lumped RLC boundary to the Resistor**

**To select the ground:**
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: **Resistor**
   2. Click the OK button

**To assign the Perfect E boundary**
1. Select the menu item *HFSS > Boundaries > Assign > Lumped RLC*
2. Lumped RLC Boundary window
   1. Name: **Resistor**
   2. ☑️ Resistance: 47 ohm
   3. Current Flow Line: **New Line**
      1. Point 1: X: **0.0**, Y: **0.0**, Z: **0.0**, Press the Enter Key
      2. Point 2: dX: **0.0**, dY: **-0.16**, dZ: **0.0**, Press the Enter Key
   4. Click the OK button

**Set Working Coordinate System**

**To set the working coordinate system:**
1. Select the menu item *3D Modeler > Coordinate System > Set Working CS*
2. Select Coordinate System Window,
   1. From the list, select the CS: **Global**
   2. Click the Select button
Create the Case

Create Case
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: -0.05, Y: -0.05, Z: -0.05, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: 22.1, dY: 14.1, dZ: 30.1, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Case
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Group Objects

To group the objects:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   - 1. Select the objects named: Case, Coax_Shield
   - 2. Click the OK button
3. Select the menu item, 3D Modeler > Boolean > Unite

To fit the view:
1. Select the menu item View > Fit All > Active View.


Complete the Case

To select the objects:
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: **Case, Air_Inside**
   2. Click the **OK** button

To complete the case:
1. Select the menu item *3D Modeler > Boolean > Subtract*
2. Subtract Window
   - Blank Parts: **Case**
   - Tool Parts: **Air_Inside**
   - Clone tool objects before subtract: **Unchecked**
   - Click the **OK** button

Create Radiation Boundary

To create a radiation boundary
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: **Air**
   2. Click the **OK** button
3. Select the menu item *HFSS > Boundaries > Assign > Radiation*
4. Radiation Boundary window
   1. Name: **Rad1**
   2. Click the **OK** button
Analysis Setup

Creating an Analysis Setup

To create an analysis setup:
1. Select the menu item **HFSS > Analysis Setup > Add Solution Setup**
2. Solution Setup Window:
   1. Click the General tab:
      - Solution Frequency: **1.1 GHz**
      - Maximum Number of Passes: **10**
      - Maximum Delta S: **0.02**
   2. Click the OK button

Adding a Frequency Sweep

To add a frequency sweep:
1. Select the menu item **HFSS > Analysis Setup > Add Sweep**
   1. Select Solution Setup: **Setup1**
   2. Click the OK button
2. Edit Sweep Window:
   1. Sweep Type: **Fast**
   2. Frequency Setup Type: **Linear Count**
      - Start: **0.6 GHz**
      - Stop: **1.6 GHz**
      - Count: **201**
      - Save Fields: **Checked**
   3. Click the OK button
### Save Project
- **To save the project:**
  1. In an Ansoft HFSS window, select the menu item *File > Save As.*
  2. From the *Save As* window, type the Filename: *hfss_enclosure*
  3. Click the *Save* button

### Analyze

### Model Validation
- **To validate the model:**
  1. Select the menu item *HFSS > Validation Check*
  2. Click the *Close* button

  **Note:** To view any errors or warning messages, use the Message Manager.

### Analyze
- **To start the solution process:**
  1. Select the menu item *HFSS > Analyze All*
Solution Data

To view the Solution Data:

1. Select the menu item **HFSS > Results > Solution Data**

   To view the Profile:
   1. Click the **Profile** Tab.

   To view the Convergence:
   1. Click the **Convergence** Tab

   **Note:** The default view is for convergence is **Table**. Select the **Plot** radio button to view a graphical representation of the convergence data.

   To view the Matrix Data:
   1. Click the **Matrix Data** Tab

   **Note:** To view a real-time update of the Matrix Data, set the Simulation to **Setup1, Last Adaptive**

2. Click the **Close** button
Create Reports

Create Terminal S-Parameter Plot - Magnitude

To create a report:

1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Terminal S Parameters**
   2. Display Type: **Rectangular**
   3. Click the **OK** button
3. Traces Window:
   1. Solution: **Setup1: Sweep1**
   2. Domain: **Sweep**
   3. Click the **Y** tab
      1. Category: **Terminal S Parameter**
      2. Quantity: **St(p1,p1)**
      3. Function: **dB**
      4. Click the **Add Trace** button
   4. Click the **Done** button
Create Reports (Continued)

Custom Equations - Output Variables

1. Select the menu item HFSS > Results > Create Report
2. Create Report Window:
   1. Report Type: Terminal S Parameters
   2. Display Type: Rectangular
   3. Click the OK button
3. Traces Window:
   1. Click the Output Variables button
   2. Output Variables dialog:
      1. Name: Pdelivered_nW
      2. Expression:
         - Type: 2.5*(1-
         - Category: Terminal S Parameters
         - Quantity: St(p1,p1)
         - Function: mag
         - Click the Insert Quantity into Expression button
         - Type: ^2)
      3. Click the Add button
      4. Click the Done button
3. Solution: Setup1: Sweep1
4. Domain: Sweep
5. Click the Y tab
   1. Category: Output Variables
   2. Quantity: Pdelivered_nW
   3. Function: <none>
   4. Click the Add Trace button
6. Click the Done button
Field Overlays

To create a field plot:
1. Select an object to overlay fields
   1. Select the menu item `Edit > Select > By Name`
   2. Select Object Dialog,
      1. Select the objects named: Air
      2. Click the OK button
   ▲ Note: You can also select the object from the Model Tree
2. Select the menu item `HFSS > Fields > Fields > E > Mag_E`
3. Create Field Plot Window
   1. Solution: Setup1 : Sweep1
   2. Freq: 0.89 GHz
   3. Quantity: Mag_E
   4. In Volume: All
   5. Click the Done button

To modify the attributes of a field plot:
1. Select the menu item `HFSS > Fields > Modify Plot Attributes`
2. Select Plot Folder Window:
   1. Select: E Field
   2. Click the OK button
3. E-Field Window:
   1. Click the Scale tab
      1. Select Use Limits
      2. Min: 5
      3. Max: 600
      4. Scale: Log
   2. Click the Plot tab
      1. IsoValType: IsoValSurface
      2. Click the Apply button.
   4. Click the Close button
Field Overlays

To modify the Frequency of a field plot:
1. Select the menu item **HFSS > Fields > Modify Plot**
2. Select Plot Folder Window:
   1. Select: **E Field**
   2. Click the **OK** button
3. Create Field Plot Window
   1. Solution: **Setup1 : Sweep1**
   2. Freq: **1.08 GHz**

1.08 GHz

1.51 GHz
Chapter 10.0 - On-Chip Passives Examples

10.1 - Spiral Inductor
THIS PAGE INTENTIONALLY LEFT BLANK
The Silicon Spiral Inductor

This example is intended to show you how to create, simulate, and analyze a 2.5 turn spiral inductor using the Ansoft HFSS Design Environment.

Nominal Design:

- **Spiral**: 2.5T, W=15um, S=1.5um, Rad=60um
  - M6, 2um, σ= 2.8e7 S/m
- **Underpass**: M5, 0.5um, σ= 2.8e7 S/m
- **Stackup**:
  - **Passivation**: 0.7um, εr = 7.9
  - **Oxide**: 9.8um, εr = 4.0
  - **Substrate**: 300um, εr = 11.9, σ= 10 S/m
Getting Started

Launching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft Start button, select Programs, and select the Ansoft > HFSS 10 program group. Click HFSS 10.

Setting Tool Options

To set the tool options:

- **Note:** In order to follow the steps outlined in this example, verify that the following tool options are set:
  
  1. Select the menu item Tools > Options > HFSS Options
  2. HFSS Options Window:
     
        1. Click the General tab
        
           - Use Wizards for data entry when creating new boundaries: ☑ Checked
        
           - Duplicate boundaries with geometry: ☑ Checked
     
  2. Click the OK button
  3. Select the menu item Tools > Options > 3D Modeler Options.
  4. 3D Modeler Options Window:
     
        1. Click the Operation tab
        
           - Automatically cover closed polylines: ☑ Checked
     
        2. Click the Drawing tab
        
           - Edit property of new primitives: ☑ Checked
     
        3. Click the OK button


### Opening a New Project

To open a new project:

- In an Ansoft HFSS window, click the File > New. On the Standard toolbar, or select the menu item File > New.
- From the Project menu, select Insert HFSS Design.

### Set Solution Type

To set the solution type:

- Select the menu item HFSS > Solution Type
- Solution Type Window:
  - Choose Driven Terminal
  - Click the OK button
Creating the 3D Model

Set Model Units

To set the units:
1. Select the menu item 3D Modeler > Units
2. Set Model Units:
   1. Select Units: um
   2. Click the OK button

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
   1. Click the Add Material button
   2. View/Edit Material Window:
      1. For the Material Name type: My_Sub
      2. For the Value of Relative Permittivity type: 11.9
      3. For the Value of Bulk Conductivity type: 10
      4. Click the OK button
3. Click the OK button
Create Substrate

To create the substrate:
1. Select the menu item **Draw > Box**
2. Using the coordinate entry fields, enter the box position
   - X: **-270.0**, Y: **-270.0**, Z: **0.0**, Press the **Enter** key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   - dX: **540.0**, dY: **540.0**, dZ: **300.0**, Press the **Enter** key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: **Sub**
3. Click the OK button

To fit the view:
1. Select the menu item **View > Fit All > Active View**.

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
   1. Click the **Add Material** button
   2. View/Edit Material Window:
      1. For the **Material Name** type: **My_Oxide**
      2. For the **Value of Relative Permittivity** type: **4.0**
      3. Click the OK button
   3. Click the OK button
**Create Oxide**

- **To create substrate:**
  1. Select the menu item *Draw > Box*
  2. Using the coordinate entry fields, enter the box position
     - X: -270.0, Y: -270.0, Z: 300.0, Press the **Enter** key
  3. Using the coordinate entry fields, enter the opposite corner of the box:
     - dX: 540.0, dY: 540.0, dZ: 9.8, Press the **Enter** key

- **To set the name:**
  1. Select the **Attribute** tab from the **Properties** window.
  2. For the **Value of Name** type: Oxide
  3. Click the **OK** button

- **To fit the view:**
  1. Select the menu item *View > Fit All > Active View*

**Set Default Material**

- **To set the default material:**
  1. Using the 3D Modeler Materials toolbar, choose **Select**
  2. Select Definition Window:
     1. Click the **Add Material** button
     2. View/Edit Material Window:
        1. For the **Material Name** type: My_Pass
        2. For the **Value of Relative Permittivity** type: 7.9
        3. Click the **OK** button
  3. Click the **OK** button
**Example - Silicon Spiral Inductor**

### Create Passivation

- **To create substrate:**
  1. Select the menu item *Draw > Box*
  2. Using the coordinate entry fields, enter the box position
     - X: -270.0, Y: -270.0, Z: 309.8, Press the *Enter* key
  3. Using the coordinate entry fields, enter the opposite corner of the box:
     - dX: 540.0, dY: 540.0, dZ: 0.7, Press the *Enter* key
- **To set the name:**
  1. Select the *Attribute* tab from the *Properties* window.
  2. For the *Value of Name* type: *Pass*
  3. Click the *OK* button
- **To fit the view:**
  1. Select the menu item *View > Fit All > Active View*

### Set Default Material

- **To set the default material:**
  1. Using the 3D Modeler Materials toolbar, choose vacuum

### Create Air

- **To create air:**
  1. Select the menu item *Draw > Box*
  2. Using the coordinate entry fields, enter the box position
     - X: -270.0, Y: -270.0, Z: 0.0, Press the *Enter* key
  3. Using the coordinate entry fields, enter the opposite corner of the box:
     - dX: 540.0, dY: 540.0, dZ: 600.0, Press the *Enter* key
- **To set the name:**
  1. Select the *Attribute* tab from the *Properties* window.
  2. For the *Value of Name* type: *Air*
  3. Click the *OK* button
- **To fit the view:**
  1. Select the menu item *View > Fit All > Active View*
Example - Silicon Spiral Inductor

Create Radiation Boundary

To select the object Air:
- Select the menu item Edit > Select > By Name
- Select Object Dialog,
  - Select the objects named: Air
  - Click the OK button

To create a radiation boundary
- Select the menu item HFSS > Boundaries > Assign > Radiation
- Radiation Boundary Window
  - Name: Rad1
  - Click the OK button

Create Ground

To create ground:
- Select the menu item Draw > Rectangle
- Using the coordinate entry fields, enter the box position
  - X: -270.0, Y: -270.0, Z: 0.0, Press the Enter key
- Using the coordinate entry fields, enter the opposite corner of the base rectangle:
  - dX: 540.0, dY: 540.0, dZ: 0.0, Press the Enter key

To set the name:
- Select the Attribute tab from the Properties window.
- For the Value of Name type: Ground
- Click the OK button

To fit the view:
- Select the menu item View > Fit All > Active View.
Assign a Perfect E boundary to the Ground

To select the ground:
1. Select the menu item **Edit > Select > By Name**
2. Select Object Dialog,
   1. Select the objects named: **Ground**
   2. Click the **OK** button

To assign the Perfect E boundary
1. Select the menu item **HFSS > Boundaries > Assign > Perfect E**
2. Perfect E Boundary window
   1. Name: **PerfE_Ground**
   2. Click the **OK** button

Hide Dielectrics

To hide the dielectrics:
1. Select the menu item **Edit > Select All Visible**
2. Select the menu item **View > Hide Selection > All Views**

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose **Select**
2. Select Definition Window:
   1. Click the **Add Material** button
   2. View/Edit Material Window:
      1. For the **Material Name** type: **My_Met**
      2. For the **Value of Bulk Conductivity** type: **2.8e7**
      3. Click the **OK** button
   3. Click the **OK** button

Create Offset Coordinate System

To create an offset Coordinate System:
1. Select the menu item **3D Modeler > Coordinate System > Create > Relative CS > Offset**
2. Using the coordinate entry fields, enter the origin
   1. **X**: 0.0, **Y**: 0.0, **Z**: 304.8, Press the **Enter** key
Example - Silicon Spiral Inductor

Create Spiral Path

To create the path:

1. Select the menu item *Draw > Line*
2. Using the coordinate entry fields, enter the vertex point:
   - X: **-60.0**, Y: **7.5**, Z: **0.0**, Press the **Enter** key
3. Using the coordinate entry fields, enter the vertex point:
   - X: **-60.0**, Y: **-60.0**, Z: **0.0**, Press the **Enter** key
4. Using the coordinate entry fields, enter the vertex point:
   - X: **76.5**, Y: **-60.0**, Z: **0.0**, Press the **Enter** key
5. Using the coordinate entry fields, enter the vertex point:
   - X: **76.5**, Y: **76.5**, Z: **0.0**, Press the **Enter** key
6. Using the coordinate entry fields, enter the vertex point:
   - X: **-76.5**, Y: **76.5**, Z: **0.0**, Press the **Enter** key
7. Using the coordinate entry fields, enter the vertex point:
   - X: **-76.5**, Y: **-76.5**, Z: **0.0**, Press the **Enter** key
8. Using the coordinate entry fields, enter the vertex point:
   - X: **93.0**, Y: **-76.5**, Z: **0.0**, Press the **Enter** key
9. Using the coordinate entry fields, enter the vertex point:
   - X: **93.0**, Y: **93.0**, Z: **0.0**, Press the **Enter** key
10. Using the coordinate entry fields, enter the vertex point:
    - X: **-93.0**, Y: **93.0**, Z: **0.0**, Press the **Enter** key
11. Using the coordinate entry fields, enter the vertex point:
    - X: **-93.0**, Y: **-93.0**, Z: **0.0**, Press the **Enter** key
12. Using the coordinate entry fields, enter the vertex point:
    - X: **109.5**, Y: **-93.0**, Z: **0.0**, Press the **Enter** key
13. Using the coordinate entry fields, enter the vertex point:
    - X: **109.5**, Y: **7.5**, Z: **0.0**, Press the **Enter** key
14. Using the coordinate entry fields, enter the vertex point:
    - X: **131.0**, Y: **7.5**, Z: **0.0**, Press the **Enter** key
15. Using the mouse, right-click and select **Done**
16. Click the **OK** button when the Properties dialog appears
**Create the Spiral**

- **To set the grid plane:**
  1. Select the menu item `3D Modeler > Grid Plane > XZ`

- **To create conductor profile:**
  1. Select the menu item `Draw > Rectangle`
  2. Using the coordinate entry fields, enter the box position
     - X: -60.0, Y: 7.5, Z: 0.0, Press the Enter key
  3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
     - dX: -15.0, dY: 0.0, dZ: 2.0, Press the Enter key

- **To set the name:**
  1. Select the Attribute tab from the Properties window.
  2. For the Value of Name type: Spiral
  3. Click the OK button

- **To Sweep the profile:**
  1. Select the menu item `Edit > Select > By Name`
  2. Select Object Dialog,
     1. Select the objects named: Polyline1, Spiral
     2. Click the OK button

  **Note:** You can also select the object from the Model Tree
  1. Select the menu item `Draw > Sweep > Along Path`
  2. Click the OK button when the Sweep along path dialog appears

- **To fit the view:**
  1. Select the menu item `View > Fit All > Active View`
Example - Silicon Spiral Inductor

### Set Grid Plane

**To set the grid plane:**
1. Select the menu item *3D Modeler > Grid Plane > XY*

### Create Underpass

**To create underpass:**
1. Select the menu item *Draw > Box*
2. Using the coordinate entry fields, enter the box position
   - X: \(-60.0\), Y: \(7.5\), Z: \(-0.8\), Press the *Enter* key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   - dX: \(-75.0\), dY: \(-15.0\), dZ: \(-0.5\), Press the *Enter* key

**To set the name:**
1. Select the *Attribute* tab from the *Properties* window.
2. For the *Value of Name* type: *Underpass*
3. Click the *OK* button

**To fit the view:**
1. Select the menu item *View > Fit All > Active View.*
Create Via1

To create via:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: -60.0, Y: 7.5, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   - dX: -15.0, dY: -15.0, dZ: -0.8, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Via1
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Create Via2

To create via:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: -120.0, Y: 7.5, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   - dX: -15.0, dY: -15.0, dZ: -0.8, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Via2
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.
**Create Feed**

To create feed:
1. Select the menu item **Draw > Box**
2. Using the coordinate entry fields, enter the box position
   - X: **-120.0**, Y: **7.5**, Z: **0.0**, Press the **Enter** key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   - dX: **-22.0**, dY: **-15.0**, dZ: **2.0**, Press the **Enter** key

To set the name:
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: Feed
3. Click the **OK** button

To fit the view:
1. Select the menu item **View > Fit All > Active View**

**Solve Inside Conductors**

To solve inside:
1. Select the menu item **Edit > Select All Visible**
2. Select the menu item **Edit > Properties**
3. Properties Dialog Attribute Tab
   1. Solve Inside: ☑ Checked
   2. Click the **OK** button

Click the **OK** button for all warning messages (Solving inside a solid with high conductivity may require a large mesh)

**Seed Mesh Conductors set for Solve Inside**

To solve inside:
1. Select the menu item **Edit > Select All Visible**
2. Select the menu item **HFSS > Mesh Operations > Assign > Inside**
3. **Selection > Length Based**
   1. Element Length Based Refinement Dialog
      1. Restrict Length of Elements: ☐ Unchecked
      2. Restrict Number of Elements: ☑ Checked
      3. Maximum Number of Elements: **5000**
      4. Click the **OK** button
Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
   1. Type pec in the Search by Name field
   2. Click the OK button

Create Ground Ring

To create outer ring:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: -225.0, Y: -225.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   - dX: 450.0, dY: 450.0, dZ: 2.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Ring
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View

Create Inner Ring

To create inner ring:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   - X: -210.0, Y: -210.0, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   - dX: 420.0, dY: 420.0, dZ: 2.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Inner
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View


**Complete the Ring**

**To select the objects Ring and Inner:**
1. Select the menu item *Edit > Select > By Name*
2. Select Object Dialog,
   1. Select the objects named: **Ring, Inner**
   2. Click the **OK** button

**To complete the ring:**
1. Select the menu item *3D Modeler > Boolean > Subtract*
2. Subtract Window
   - Blank Parts: **Ring**
   - Tool Parts: **Inner**
   - Click the **OK** button

**Create Extension 1**

**To create extension:**
1. Select the menu item *Draw > Box*
2. Using the coordinate entry fields, enter the box position
   - X: **-157.0**, Y: **7.5**, Z: **0.0**, Press the **Enter** key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   - dX: **-53.0**, dY: **-15.0**, dZ: **2.0**, Press the **Enter** key

**To set the name:**
1. Select the **Attribute** tab from the **Properties** window.
2. For the **Value of Name** type: **Ring_Ext1**
3. Click the **OK** button

**To fit the view:**
1. Select the menu item *View > Fit All > Active View*
10.1

Example - Silicon Spiral Inductor

Create Extension 2

To create extension:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
   a. X: 146.0, Y: 7.5, Z: 0.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
   a. dX: 64.0, dY: -15.0, dZ: 2.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Ring_Ext2
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View

Group the Conductors

To group the conductors:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Ring, Ring_Ext1, Ring_Ext2
   2. Click the OK button
3. Select the menu item, 3D Modeler > Boolean > Unite

To fit the view:
1. Select the menu item View > Fit All > Active View.
Example - Silicon Spiral Inductor

Create Source 1

To create source:
1. Select the menu item Draw > Rectangle
2. Using the coordinate entry fields, enter the box position
   - X: -142.0, Y: 7.5, Z: 1.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: -15.0, dY: -15.0, dZ: 0.0, Press the Enter key

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Source1
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Assign Excitation

To select the object Source:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   - Select the objects named: Source1
3. Click the OK button

Note: You can also select the object from the Model Tree

To assign lumped port excitation
1. Select the menu item HFSS > Excitations > Assign > Lumped Port
2. Lumped Port: General
   1. Name: p1,
   2. Resistance: 50
   3. Reactance: 0
4. Click the Next button
3. Lumped Port: Terminals
   1. Number of Terminals: 1,
   2. For T1, click the Undefined column and select New Line
   3. Using the coordinate entry fields, enter the vector position
      - X: -157.0, Y: 0.0, Z: 1.0, Press the Enter key
   4. Using the coordinate entry fields, enter the vertex
      - dX: 15.0, dY: 0.0, dZ: 0.0, Press the Enter key
5. Click the Finish button
Create Source 2

To create source:
1. Select the menu item Draw > Rectangle
2. Using the coordinate entry fields, enter the box position
   - X: 131.0, Y: 7.5, Z: 1.0, Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:
   - dX: 15.0, dY: -15.0, dZ: 0.0, Press the Enter key

To set the name:
1. Select the object Source:
2. For the Value of Name type: Source2
3. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View.

Assign Excitation

To select the object Source:
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
   1. Select the objects named: Source2
   2. Click the OK button

Note: You can also select the object from the Model Tree

To assign lumped port excitation
1. Select the menu item HFSS > Excitations > Assign > Lumped Port
2. Lumped Port: General
   1. Name: p2,
   2. Resistance: 50
   3. Reactance: 0
3. Click the Next button

Lumped Port: Terminals
1. Number of Terminals: 1,
2. For T1, click the Undefined column and select New Line
3. Using the coordinate entry fields, enter the vector position
   - X: 146.0, Y: 0.0, Z: 1.0, Press the Enter key
4. Using the coordinate entry fields, enter the vertex
   - dX: -15.0, dY: 0.0, dZ: 0.0, Press the Enter key
5. Click the Finish button
1. Select the menu item **View > Show All > All Views**

### Boundary Display

**To verify the boundary setup:**

1. Select the menu item **HFSS > Boundary Display (Solver View)**
2. From the Solver View of Boundaries, toggle the Visibility check box for the boundaries you wish to display.
   - **Note:** The background (Perfect Conductor) is displayed as the outer boundary.
   - **Note:** The Perfect Conductors are displayed as the smetal boundary.
   - **Note:** Select the menu item, **View > Visibility** to hide all of the geometry objects. This makes it easier to see the boundary.
3. Click the **Close** button when you are finished
Example - Silicon Spiral Inductor

## Analysis Setup

### Creating an Analysis Setup

To create an analysis setup:

1. Select the menu item **HFSS > Analysis Setup > Add Solution Setup**
2. Solution Setup Window:
   
   1. Click the **General** tab:
      - Solution Frequency: **12.0GHz**
      - Maximum Number of Passes: **20**
      - Maximum Delta S: **0.02**
   
   2. Click the **Options** tab:
      - Do Lambda Refinement: ✔ **Checked**
      - Target: **0.05**
      - User Low-Order Solution Basis: ✔ **Checked**
   
3. Click the **OK** button

### Adding a Frequency Sweep

To add a frequency sweep:

1. Select the menu item **HFSS > Analysis Setup > Add Sweep**
   
   1. Select Solution Setup: **Setup1**
      
      2. Click the **OK** button
   
2. Edit Sweep Window:
   
   1. Sweep Type: **Interpolating**
   
      2. Click the **Setup Interpolation Basis** button
         
         - Max Solutions: **20**
         - Error Tolerance: **0.5%**
         - Click the **OK** button
   
   3. Frequency Setup Type: **Linear Step**
      
      1. Start: **0.1GHz**
      2. Stop: **20.0GHz**
      3. Step: **0.1GHz**
   
   4. Click the **OK** button
Example - Silicon Spiral Inductor

### Save Project

To save the project:
1. In an Ansoft HFSS window, select the menu item *File > Save As*.
2. From the *Save As* window, type the Filename: `hfss_spiral_inductor`
3. Click the *Save* button

### Analyze

### Model Validation

To validate the model:
1. Select the menu item *HFSS > Validation Check*
2. Click the *Close* button
   - **Note:** To view any errors or warning messages, use the Message Manager.

### Analyze

To start the solution process:
1. Select the menu item *HFSS > Analyze All*
Example - Silicon Spiral Inductor

Solution Data

To view the Solution Data:
1. Select the menu item HFSS > Results > Solution Data
   - To view the Profile:
     1. Click the Profile Tab.
   - To view the Convergence:
     1. Click the Convergence Tab
     Note: The default view is for convergence is Table. Select the Plot radio button to view a graphical representations of the convergence data.
   - To view the Matrix Data:
     1. Click the Matrix Data Tab
     Note: To view a real-time update of the Matrix Data, set the Simulation to Setup1, Last Adaptive

2. Click the Close button
Create Reports

Create S-parameter vs. Frequency

To Create a report:
1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Terminal S Parameters**
   2. Display Type: **Rectangular**
   3. Click the **OK** button
3. Traces Window:
   1. Solution: **Setup1: Sweep1**
   2. Click the Y tab
      1. Domain: **Sweep**
      2. Category: **Terminal S-Parameters**
      3. Quantity: **St(p1,p1), St(p2,p1)**
      4. Function: **dB**
      5. Click the **Add Trace** button
   3. Click the **Done** button
Create Reports (Continued)

Custom Equations - Output Variables
1. Select the menu item HFSS > Results > Create Report
2. Create Report Window:
   1. Report Type: Terminal S Parameters
   2. Display Type: Rectangular
   3. Click the OK button
3. Traces Window:
   1. Click the Output Variables button
   2. Output Variables dialog:
      1. Name: Q11
      2. Expression:
         ▲ Category: Terminal Y Parameters
         ▲ Quantity: Yt(p1,p1)
         ▲ Function: \(\text{im}\)
         ▲ Click the Insert Quantity into Expression button
         ▲ Type: /
         ▲ Quantity: Yt(p1,p1)
         ▲ Function: \(\text{re}\)
         ▲ Click the Insert Quantity into Expression button
      3. Click the Add button
      4. Repeat for Q22, by replacing Yt(p1,p1) with Yt(p2,p2)
      5. Click the Done button
3. Solution: Setup1: Sweep
4. Domain: Sweep
5. Click the \(Y\) tab
   1. Category: Output Variables
   2. Quantity: Q11, Q22
   3. Function: \(\text{abs}\)
   4. Click the Add Trace button
   5. Click the Done button

\[
Q_{nn} = \frac{\text{Im}(Y_{nn})}{\text{Re}(Y_{nn})}
\]
Create Reports (Continued)

Custom Equations - Output Variables

1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Terminal S Parameters**
   2. Display Type: **Rectangular**
   3. Click the OK button
3. Traces Window:
   1. Click the **Output Variables** button
   2. Output Variables dialog:
      1. Name: **L11**
      2. Expression:
         - Type: `-1/(2*pi*freq)`
         - Category: **Terminal Y Parameters**
         - Quantity: `Yt(p1,p1)`
         - Function: `im`
         - Click the **Insert Quantity into Expression** button
   3. Click the Add button
   4. Click the Done button
3. Solution: **Setup1: Sweep1**
4. Domain: **Sweep**
5. Click the Y tab
   1. Category: **Output Variables**
   2. Quantity: **Y11**
   3. Function: **none**
   4. Click the **Add Trace** button
6. Click the Done button

\[
L_{nn} = \frac{-1}{2\pi \cdot f \cdot \text{im}(Y_{nn})}
\]
Example - Silicon Spiral Inductor

Appendix - Alternative Lumped Ports

PEC Bridge
Example - Silicon Spiral Inductor

Appendix - Alternative Lumped Ports

[Diagram of silicon spiral inductor with labeled ports and gaps]

Lumped Port

Port

G

S

G

G

S

G

Lumped Port

gap

gap
Example - Silicon Spiral Inductor

Appendix - Alternative Lumped Ports

Port

G
S
G

G
Via

Lumped Port

G
Via

Ground Bridge
Quick Example - Coax Tee

HFSS - High Frequency Structure Simulator

- Full-Wave 3D field solver
- Solves for the fields in an arbitrary volume
Starting HFSS

- Click the Microsoft Start button, select Programs, and select the Ansoft > HFSS 10 > HFSS 10
- Or Double click on the HFSS 10 icon on the Windows Desktop

Adding a Design

- When you first start HFSS a new project with a new design will be automatically added to the Project Tree.

To include additional designs into an existing project, select the menu item Project > Insert HFSS Design

Alternatively to open a new project with a new design manually, select the menu item File > New.
Ansoft Desktop

- Menu bar
- Toolbars
- 3D Modeler Window
- Project Manager with project tree
- Message Manager
- Status bar
- Property Window
- Progress Window
- Coordinate Entry Fields

Enter the box position: X: 350.00 Y: -100.00 Z: 0.0000
Ansoft Desktop - Project Manager

- Multiple Designs per Project
- Multiple Projects per Desktop
- Integrated Optimetrics Setup
- Requires License for Analysis

![Project Manager Window]

- Project Manager Window
- Project
- Design
- Design Setup
- Design Results

Design Automation
- Parametric
- Optimization
- Sensitivity
- Statistical

- Project Manager Window
- hfss_coax_training
  - HFSSModel1
    - Model
    - Boundaries
    - Excitations
    - Mesh Operations
  - Analysis
    - Optimetrics
    - Results
    - Port Field Display
    - Field Overlays
    - Radiation
  - Definitions
  - Materials
Ansoft Desktop - 3D Modeler

3D Modeler Window

Graphics area

Model

3D Modeler design tree

Context menu

Select Objects O

Select Faces F

Next Behind B
All Object Faces
Faces On Plane
Measure Measure
View View
Edit Edit

Assign Material...
Assign Boundary
Assign Excitation
Assign Mesh Operation
Fields
Plot Mesh
Copy To Clipboard

Coordinate System (CS)
Origin
Face
Model
Plane
Vertex
Edge
Set Solution Type

To set the solution type:
1. Select the menu item **HFSS > Solution Type**
2. Solution Type Window:
   1. Choose **Driven Modal**
   2. Click the **OK** button

HFSS - Solution Types

- **Driven Modal** - calculates the modal-based S-parameters. The S-matrix solutions will be expressed in terms of the incident and reflected powers of waveguide modes.
  - Generalized S-parameters
- **Driven Terminal** - calculates the terminal-based S-parameters of multi-conductor transmission line ports. The S-matrix solutions will be expressed in terms of terminal voltages and currents.
- **Eigenmode** - calculate the eigenmodes, or resonances, of a structure. The Eigenmode solver finds the resonant frequencies of the structure and the fields at those resonant frequencies.

Convergence

- **Driven Modal** - Delta S for modal S-Parameters.
- **Driven Terminal** - Delta S for the single-ended or differential nodal S-Parameters.
- **Eigenmode** - Delta F
Set Model Units

To set the units:
1. Select the menu item **3D Modeler > Units**
2. Set Model Units:
   1. Select Units: **mm**
   2. Click the **OK** button

Set Default Material

To set the default material:
1. Using the 3D Modeler Materials toolbar, choose **Select**
2. Select Definition Window:
   1. Type **pec** in the **Search by Name** field
   2. Click the **OK** button
3D Modeler - Create a Primitive

The Coordinate Entry fields allow equations to be entered for position values. Examples: 2*5, 2+6+8, 2*cos(10*(pi/180)).

Variables are not allowed in the Coordinate Entry Field

Note: Trig functions are in radians.
3D Modeler - Object Properties

**Commands**

<table>
<thead>
<tr>
<th>Command</th>
<th>Attribute</th>
<th>Value</th>
<th>Unit</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command</td>
<td>CreateBox</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Coordinate System</td>
<td>Global</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Position</td>
<td>x, y, z</td>
<td>-1, 2, 0</td>
<td>mm</td>
<td>mm</td>
</tr>
<tr>
<td>XSize</td>
<td>2</td>
<td>mm</td>
<td></td>
<td></td>
</tr>
<tr>
<td>YSize</td>
<td>2.4</td>
<td>mm</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ZSize</td>
<td>0.6</td>
<td>mm</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Attributes**

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Value</th>
<th>Unit</th>
<th>Description</th>
<th>Read-only</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Box1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Material</td>
<td>vacuum</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Solve Inside</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Orientation</td>
<td>Global</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mode</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Display Wireframe</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Color</td>
<td></td>
<td></td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td>Transparent</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### 3D Modeler - Attributes

#### Select Definition

<table>
<thead>
<tr>
<th>Name</th>
<th>Location</th>
<th>Origin</th>
<th>Relative Permittivity</th>
<th>Relative Permeability</th>
<th>Bulk Conductivity</th>
<th>Dielectric Loss Tan</th>
</tr>
</thead>
<tbody>
<tr>
<td>copper</td>
<td>Project</td>
<td>Materials 1</td>
<td>8.933931</td>
<td>500000000 Siemens/m</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>copper</td>
<td>SysLibrary</td>
<td>Materials</td>
<td>8.933931</td>
<td>500000000 Siemens/m</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>corning_glass</td>
<td>SysLibrary</td>
<td>Materials</td>
<td>5.75</td>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>grate_mat</td>
<td>SysLibrary</td>
<td>Materials</td>
<td>3.8</td>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>diamond</td>
<td>SysLibrary</td>
<td>Materials</td>
<td>16.5</td>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>diamond_hips</td>
<td>SysLibrary</td>
<td>Materials</td>
<td>3.7</td>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>diamond_pl_vd</td>
<td>SysLibrary</td>
<td>Materials</td>
<td>3.5</td>
<td>1</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

#### View/Edit Material

<table>
<thead>
<tr>
<th>Property of the Material</th>
<th>Name</th>
<th>Value</th>
<th>Type</th>
<th>Value</th>
<th>Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>Relative Permittivity</td>
<td>Simple</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Relative Permeability</td>
<td>Simple</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bulk Conductivity</td>
<td>Simple</td>
<td>0</td>
<td></td>
<td>Siemens/m</td>
<td></td>
</tr>
<tr>
<td>Dielectric Loss Tangent</td>
<td>Simple</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Magnetic Loss Tangent</td>
<td>Simple</td>
<td>0</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Magnetic Saturation</td>
<td>Simple</td>
<td>0</td>
<td></td>
<td>Tesla</td>
<td></td>
</tr>
<tr>
<td>Lossy G Factor</td>
<td>Simple</td>
<td>2</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Delta H</td>
<td>Simple</td>
<td>0</td>
<td></td>
<td>A_per_meter</td>
<td></td>
</tr>
</tbody>
</table>

**Attribute**

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Box1</td>
<td></td>
</tr>
<tr>
<td>Material</td>
<td>vacuum</td>
<td></td>
</tr>
<tr>
<td>Solve Inside</td>
<td>✔</td>
<td></td>
</tr>
<tr>
<td>Orientation</td>
<td>Global</td>
<td></td>
</tr>
<tr>
<td>Model</td>
<td>✔</td>
<td></td>
</tr>
<tr>
<td>Display Wireframe</td>
<td>✔</td>
<td></td>
</tr>
<tr>
<td>Color</td>
<td>Edit</td>
<td></td>
</tr>
<tr>
<td>Transparent</td>
<td>0</td>
<td></td>
</tr>
</tbody>
</table>
Set Grid Plane

To set the Grid Plane:
- Select the menu item 3D Modeler > Grid Plane > YZ

Create Coax Pin

To create the coax pin:
1. Select the menu item Draw > Cylinder
2. Using the coordinate entry fields, enter the center position
   - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
     X: 0 0 0 Absolute Cartesian mm
3. Using the coordinate entry fields, enter the radius of the cylinder
   - dX: 0.0, dY: 0.86, dZ: 0.0, Press the Enter key
     dX: 0 dY: 0.86 dZ: 0 Relative Cartesian mm
4. Using the coordinate entry fields, enter the height of the cylinder
   - dX: 6.0, dY: 0.0 dZ: 0.0, Press the Enter key
     dX: 6 dY: 0 dZ: 0 Relative Cartesian mm

Continued on Next Page
Create Coax Pin (Continued)

To Parameterize the Height
1. Select the Command tab from the Properties window
2. Height: H
3. Press the Tab key
4. Add Variable Window
   1. Value: 6mm
   2. Click the OK button

To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Coax_Pin

To set the color:
1. Select the Attribute tab from the Properties window.
2. Click the Edit button

To set the transparency:
1. Select the Attribute tab from the Properties window.
2. Click the OK button

To finish editing the object properties
1. Click the OK button

To fit the view:
1. Select the menu item View > Fit All > Active View
3D Modeler - Views

- **View > Modify Attributes >**
  - **Orientation** - Predefined/Custom View Angles
  - **Lighting** - Control angle, intensity, and color of light
  - **Projection** - Control camera and perspective
  - **Background Color** - Control color of 3D Modeler background

- **View > Active View Visibility** - Controls the display of: 3D Modeler Objects, Color Keys, Boundaries, Excitations, Field Plots

- **View > Options** - Stereo Mode, Drag Optimization, Color Key Defaults, Default Rotation

- **View > Render > Wire Frame** or **Smooth Shaded** (Default)

- **View > Coordinate System > Hide** or **Small (Large)**

- **View > Grid Setting** - Controls the grid display

  ![Grid Setting](image)
Changing the View

**Toolbar**
- Rotate Around Current Axis
- Rotate Around Model Center
- Pan
- Zoom In/Out
- Fit Selected
- Dynamic Zoom
- Fit All

**Context Menu**
- Rotate Model Center
- Pan
- Zoom
- Zoom In
- Zoom Out
- Fit All
- Fit Selection
- Hide Selection
- Show Selection
- Spin
- Animate...

**Shortcuts**

- Since changing the view is a frequently used operation, some useful shortcut keys exist. Press the appropriate keys and drag the mouse with the left button pressed:
  - **ALT + Drag** - Rotate
  - In addition, there are 9 pre-defined view angles that can be selected by holding the ALT key and double clicking on the locations shown on the next page.

- **Shift + Drag** - Pan
- **ALT + Shift + Drag** - Dynamic Zoom

**Predefined View Angles**
- Top
- Left
- Right
- Bottom
Set Default Material

- To set the default material:
  - Using the 3D Modeler Materials toolbar, choose vacuum

Create Coax

- To create the coax:
  1. Select the menu item Draw > Cylinder
  2. Using the coordinate entry fields, enter the center position
     - X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key
  4. Using the coordinate entry fields, enter the radius of the cylinder
     - dX: 0.0, dY: 2.0, dZ: 0.0, Press the Enter key
  5. Using the coordinate entry fields, enter the height of the cylinder
     - dX: 6.0, dY: 0.0, dZ: 0.0, Press the Enter key

- To Parameterize the Height:
  1. Select the Command tab from the Properties window
  2. Height: H
  3. Click the OK button

- To set the name:
  1. Select the Attribute tab from the Properties window.
  2. For the Value of Name type: Coax
  3. Click the OK button

- To fit the view:
  1. Select the menu item View > Fit All > Active View
Create Excitation

Face Selection

Select the menu item **Edit > Select > Faces**
- By moving the mouse, graphically highlight the top face of the Coax object
- Click the left mouse button to select the face

Assign Excitation

Select the menu item **HFSS > Excitations > Assign > Wave Port**

1. Wave Port: General
   1. Name: p1
   2. Click the Next button
2. Wave Port: Modes
   1. Click the Next button
3. Wave Port: Post Processing
   1. Renormalize All Modes: ☑ Checked
   2. Full Port Impedance: 50 Ohm
4. Click the Finish button
**Duplicate boundaries with geometry**

- Works with all boundaries and excitations
  1. Select the menu item **Tools > Options > HFSS Options**
  2. HFSS Options Window:
     1. Click the **General** tab
        - Use Wizards for data entry when creating new boundaries: **Checked**
        - Duplicate boundaries with geometry: **Checked**
     2. Click the **OK** button

**Example:**
- Assign an Excitation to the face of an object
- Duplicate the object around an axis three times
- The Excitation is automatically duplicated
Set Object Selection

- Set select to objects
  1. Select the menu item *Edit > Select > Objects*

Create Tee

- To create Tee:
  1. Select the menu item *Edit > Select All Visible*. Or press the CTRL+A key.
  2. Select the menu item, *Edit > Duplicate > Around Axis*.
     1. Axis: Z
     2. Angle: **90**
     3. Total Number: **3**
     4. Click the OK button

- To fit the view:
  1. Select the menu item *View > Fit All > Active View*. 

---

Ansoft High Frequency Structure Simulator v10 - Training Seminar
**Overview**

**Unite Conductors**

- **Select Conductors**
  1. Select the menu item *Edit > Select > By Name*
  2. Select Object Dialog,
     1. Select the objects named: Coax_Pin, Coax_Pin_1, Coax_Pin_2
     2. Click the **OK** button

- **Unite**
  1. Select the menu item *3D Modeler > Boolean > Unite*

**Unite Coax**

- **Select Coax**
  1. Select the menu item *Edit > Select > By Name*
  2. Select Object Dialog,
     1. Select the objects named: Coax, Coax_1, Coax_2
     2. Click the **OK** button

- **Unite**
  1. Select the menu item *3D Modeler > Boolean > Unite*
HFSS - Solution Setup

Creating an Analysis Setup

To create an analysis setup:

1. Select the menu item **HFSS > Analysis Setup > Add Solution Setup**
2. Solution Setup Window:
   1. Click the **General** tab:
      - Solution Frequency: **10.0 GHz**
   2. Click the **OK** button

Picking the Adapt Frequency

See **User Guide Chapter 2**
Adding a Frequency Sweep

To add a frequency sweep:

1. Select the menu item **HFSS > Analysis Setup > Add Sweep**
   1. Select Solution Setup: **Setup1**
   2. Click the **OK** button

2. Edit Sweep Window:
   1. Sweep Type: **Fast**
   2. Frequency Setup Type: **Linear Step**
      1. Start: 1.0 GHz
      2. Stop: 10.0 GHz
      3. Step: 0.1 GHz
      4. Save Fields: **Checked**
   3. Click the **OK** button

HFSS - Frequency Sweep

- **Discrete** - Solves using adaptive mesh at every frequency
  - Matrix Data and Fields at every frequency in sweep
- **Fast** - ALPS
  - Matrix Data and Fields at every frequency in sweep
- **Interpolating** - Adaptively determines discrete solve points using the adaptive mesh
  - Matrix Data at every frequency in sweeps
  - Fields at last adaptive solution
Save Project

To save the project:
1. In an Ansoft HFSS window, select the menu item **File > Save As**.
2. From the **Save As** window, type the Filename: **hfss_coax_tee**.
3. Click the **Save** button.

Analyze

Model Validation

To validate the model:
1. Select the menu item **HFSS > Validation Check**.
2. Click the **Close** button.
   - **Note:** To view any errors or warning messages, use the Message Manager.

Analyze

To start the solution process:
1. Select the menu item **HFSS > Analyze All**.
Create Reports

To create a report:

1. Select the menu item **HFSS > Results > Create Report**
2. Create Report Window:
   1. Report Type: **Modal S Parameters**
   2. Display Type: **Rectangular**
   3. Click the **OK** button
3. Traces Window:
   1. Solution: **Setup1: Sweep1**
   2. Domain: **Sweep**
   3. Click the **Y** tab
      1. Category: **Terminal S Parameter**
      2. Quantity: **S(p1,p1), S(p1,p2), S(p2,p3)**
      3. Function: **dB**
      4. Click the **Add Trace** button
   4. Click the **Done** button
Field Overlays

To create a field plot:
1. Select an object to overlay fields
   1. Select the menu item Edit > Select > By Name
   2. Select Object Dialog,
      1. Select the objects named: Coax
      2. Click the OK button
2. Select the menu item HFSS > Fields > Fields > E > Mag_E
3. Create Field Plot Window
   1. Solution: Setup1 : LastAdaptive
   2. Quantity: Mag_E
   3. In Volume: All
   4. Click the Done button

To modify the attributes of a field plot:
1. Select the menu item HFSS > Fields > Modify Plot Attributes
2. Select Plot Folder Window:
   1. Select: E Field
   2. Click the OK button
3. E-Field Window:
   1. Click the Scale tab
      1. Select Use Limits
      2. Min: 5
      3. Max: 25000
      4. Scale: Log
   2. Click the Plot tab
      1. IsoValType: IsoValSurface
      2. Click the Apply button.
4. Click the Close button
What is HFSS?

**HFSS - High Frequency Structure Simulator**
- Arbitrary 3D Volumetric Full-Wave Field Solver

**Ansoft Desktop**
- Advanced ACIS based Modeling
- True Parametric Technology - Dynamic Editing
- Powerful Report Generation
- Dynamic Field Visualization
- Design Flow Automation
  - Optimetrics/Ansoft Designer/AnsoftLinks

**Advanced Material Types**
- Frequency Dependent Materials
- Non-linear Materials
- Anisotropic Materials

**Advanced Boundary Conditions**
- Radiation and Perfectly Matched Layers
- Symmetry, Finite Conductivity, Infinite Planes, RLC, and Layered Impedance
- Master/Slave - Unit Cells

**Advanced Solver Technology**
- Automatic Conformal Mesh Generation
- Adaptive Mesh Generation
- Internal/External Excitations - Includes Loss
- ALPS Fast Frequency Sweep
- Eigenmode
Common HFSS Applications

**Antenna**
- **Planar Antennas** - Patches, Dipoles, Horns, Conformal Cell Phone Antennas, Spirals
- **Waveguide** - Circular/Square Horns
- **Wire** - Dipole, Helix
- **Arrays** - Infinite Arrays, Frequency Selective Surfaces (FSS) & Photonic Band Gaps (PBG)
- **Radar Cross Section (RCS)**

**Microwave**
- **Filters** - Cavity Filters, Microstrip, Dielectric
- **EMC/EMI** - Shield Enclosures, Coupling, Near- or Far-Field Radiation
- **Connectors** - Coax, SFP/XFP, Backplane, Transitions
- **Waveguide** - Filters, Resonators, Transitions, Couplers
- **Silicon/GaAs** - Spiral Inductors, Transformers

**Signal Integrity/High-Speed Digital**
- **Package Modeling** - BGA, QFP, Flip-Chip
- **PCB Board Modeling** - Power/Ground planes, Mesh Grid Grounds, Backplanes
- **Connectors** - SFP/XFP, VHDM, GBX, NexLev, Coax
- **Transitions** - Differential/Single-ended Vias
What Information does HFSS Compute?

- **Matrix Data**
  - Modal/Terminal/Differential
    - S-, Y-, and Z-Parameters
    - VSWR
  - Excitations
    - Complex Propagation Constant (Gamma)
    - Zo
  - Full-Wave Spice
    - Full-Wave Spice - Broadband Model
    - Lumped RLC - Low Frequency Model
    - Partial Fraction - Matlab
    - Export Formats - HSPICE, PSPICE, Cadence Spectre, and Maxwell SPICE

- **Common Display Formats:**
  - Rectangular, Polar
  - Smith Chart
  - Data Tables

- **Common Output Formats:**
  - Neutral Models Files (NMF) (Optimetrics only)
  - Parametric Results
  - Touchstone, Data Tables, Matlab, Citifile
  - Graphics - Windows Clipboard
What Information does HFSS Compute? (Continued)

Fields
- Modal/Terminal/Differential
  - Electric Field
  - Magnetic Field
  - Current (Volume/Surface)
  - Power
  - Specific Absorption Rate
- Radiation
  - 2D/3D Far-/Near-Fields
  - Arrays - Regular and Custom Setups
  - RCS
- Field Calculator
  - User Defined Field Calculations
- Common Display Formats
  - Volume
  - Surface
  - Vector
  - 2D Reports - Rectangular, Polar, Radiation Patterns
- Common Output Formats:
  - Animations - AVI, GIF
  - Data Tables
  - Graphics - Windows Clipboard, BMP, GIF, JPG, TIFF, VRML
What is the Technology Behind the HFSS Field Solver?

**Volumetric Field Solver**
- **Type:** Full-Wave
- **Solution Method:** 3D Finite Element Method (FEM)
  - **Accuracy:** If there were no limits on the size of the matrix and on the number of digits for computation, there would be no limit to the accuracy of the Finite Element Method!
- **Mesh Type:** Conformal
- **Mesh Element:** Tetrahedron
- **Mesh Process:** Adaptive
  - **Convergence:** Complex Magnitude Change in S-Parameters (Delta S)

**Excitations - Port Solver**
- **Solution Method:** 2D Finite Element Method
- **Mesh Process:** Adaptive

**Frequency Sweeps**
- **Fast Frequency Sweep:** ALPS
  - Matrix Data and Fields at every frequency in sweep
    - Supports sweeps as large as 10000 data points from a single solution.
- **Interpolating Sweep**
  - Adaptive Discrete Sweep with curve fitting
    - Supports sweeps as large as 10000 data points. Number of discrete solution points varies with response.
Adaptive Mesh Refinement automatically tunes the mesh to the electrical performance of the device. This ensures simulations are correct the first time.

Mesh Convergence: Real-Time update of performance per adaptive solution.
- Matrix Data
- Fields
The Process

1. Parametric Model
   - Geometry/Materials

2. Analysis
   - Solution Setup
   - Frequency Sweep

3. Results
   - 2D Reports
   - Fields

4. Solve Loop
   - Mesh Refinement
   - Converged
   - Solve
   - Finished

   - NO
   - YES

- Design
- Solution Type
- 1.1. Boundaries
- 1.2. Excitations
- 4.1 Mesh Operations
- Analyze
- Update

- NO
- YES
Overview

Initial Solution

- Initial Mesh
- Seeding and Lambda Refinement (Single Frequency)
  - Full Volumetric Solution (S-Parameters/E-Fields)
- Port Solution (Adaptive)
  - Frequency Sweep
- Ports Only & Frequency Sweep
  - No Adaptive Meshing

Adaptive Mesh Loop

- Refine Mesh (Gradient of E-Field at Single Frequency)
  - Full Volumetric Solution (S-Parameters/E-Fields)
- Check Convergence (Delta S)
  - Frequency Sweep
    - Yes
    - No
  - Full Volumetric Solution (S-Parameters/E-Fields)
    - Refine Mesh (Gradient of E-Field at Single Frequency)
3D Modeler - Model Tree

- Select menu item **3D Modeler > Group by Material**
3D Modeler - Commands

- Parametric Technology
- Dynamic Edits - Change Dimensions
- Add Variables
  - Project Variables (Global) or Design Variables (Local)
  - Animate Geometry
  - Include Units - Default Unit is meters
- Supports mixed Units

Add Variable to HFSSModel1

- Name: my_x
- Value: $2.8 \times \cos(10^{\pi/180}) + $global_var_1

Include units – Default Unit is meters
- Supports mixed Units

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command</td>
<td>CreateBox</td>
<td></td>
</tr>
<tr>
<td>Coordinate System</td>
<td>Global</td>
<td></td>
</tr>
<tr>
<td>Position</td>
<td>-1, -1.6, 0</td>
<td>mm</td>
</tr>
<tr>
<td>XSize</td>
<td>2.6</td>
<td>mm</td>
</tr>
<tr>
<td>YSize</td>
<td>2.8</td>
<td>mm</td>
</tr>
<tr>
<td>ZSize</td>
<td>1</td>
<td>mm</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command</td>
<td>CreateBox</td>
<td></td>
</tr>
<tr>
<td>Coordinate System</td>
<td>Global</td>
<td></td>
</tr>
<tr>
<td>Position</td>
<td>-1, -1.6, 0</td>
<td>mm</td>
</tr>
<tr>
<td>XSize</td>
<td>my_x</td>
<td></td>
</tr>
<tr>
<td>YSize</td>
<td>2.8</td>
<td>mm</td>
</tr>
<tr>
<td>ZSize</td>
<td>1</td>
<td>mm</td>
</tr>
</tbody>
</table>
3D Modeler - Primitives

2D Draw Objects
- The following 2D Draw objects are available:
  - Line, Spline, Arc, Equation Based Curve, Rectangle, Ellipse, Circle, Regular Polygon, Equation Based Surface

3D Draw Objects
- The following 3D Draw objects are available:
  - Box, Cylinder, Regular Polyhedron, Cone, Sphere, Torus, Helix, Spiral, Bond Wire

Toolbar:
- 2D Objects
- 3D Objects
Splitting versus Subtracting objects

- Two or more true surface objects overlapping
- Perform Split of objects for Meshing purposes
  1. Move coordinate system to a desired position
  2. Select multiple objects to split
  3. Select 3D Modeler > Boolean > Split
  4. Select desired split plane and Both sets of objects to keep.

No need to Copy->Subtract->Paste

Recommended approach

Original Model (overlaps between two cylinders)
3D Modeler - Boolean Operations/Transformations

- **3D Modeler > Boolean**
  - **Unite** - combine multiple primitives
  - Unite disjoint objects (Separate Bodies to separate)
  - **Subtract** - remove part of a primitive from another
  - **Intersect** - keep only the parts of primitives that overlap
  - **Split** - break primitives into multiple parts along a plane (XY, YZ, XZ)
  - **Split Crossing Objects** - splits objects along a plane (XY, YZ, XZ) only where they intersect
  - **Separate Bodies** - separates objects which are united but not physically connected into individual objects

- **3D Modeler > Surfaces > Move Faces** - Resize or Reposition an objects face along a normal or vector.

- **Edit > Arrange**
  - **Move** - Translates the structure along a vector
  - **Rotate** - Rotates the shape around a coordinate axis by an angle
  - **Mirror** - Mirrors the shape around a specified plane
  - **Offset** - Performs a uniform scale in x, y, and z.

- **Edit > Duplicate**
  - **Along Line** - Create multiple copies of an object along a vector
  - **Around Axis** - Create multiple copies of an object rotated by a fixed angle around the x, y, or z axis
  - **Mirror** - Mirrors the shape around a specified plane and creates a duplicate

- **Edit > Scale** - Allows non-uniform scaling in the x, y, or z direction
3D Modeler - Selection

- **Selection Types**
  - Object (Default)
  - Face
  - Edge
  - Vertex

- **Selection Modes**
  - All Objects
  - All Visible Object
  - By Name

- **Highlight Selection Dynamically** - By default, moving the mouse pointer over an object will dynamically highlight the object for selection. To select the object simply click the left mouse button.

  - **Multiple Object Selection** - Hold the CTRL key down to graphically select multiple objects

  - **Next Behind** - To select an object located behind another object, select the front object, press the b key to get the next behind. Note: The mouse pointer must be located such that the next behind object is under the mouse pointer.

  - **To Disable:** Select the menu item Tools > Options > 3D Modeler Options

    From the Display Tab, uncheck Highlight selection dynamically
3D Modeler - Moving Around

**Step 1:** Start Point

**Step 2:** Hold X key and select vertex point

**Step 3:** CTRL+Enter Keys set a local reference

**Step 4:** Hold Z key and set height

**Toolbar:** Snap Mode

**Snap Mode**

- Snap To:
  - Grid
  - Vertex
  - Edge Center
  - Face Center
  - Quadrant
  - Arc Center

- OK
- Cancel
Overview

3D Modeler - Coordinate System
- Can be Parameterized
- Working Coordinate System
  - Currently selected CS. This can be a local or global CS
- Global CS
  - The default fixed coordinate system
- Relative CS
  - User defined local coordinate system.
    - Offset
    - Rotated
    - Both
- Face CS (setting available to automatically switch to face coordinate system in the 3D Modeler Options)

Step 1: Select Face
Step 2: Select Origin
Step 3: Set X-Axis
New Working CS

Cone created with Face CS
Change Box Size and Cone is automatically positioned with the top face of the box
HFSS - Matrix Data

- **HFSS > Results > Solution Data**
- Export
  - NMF, Touchstone, Data Tables, Citifile, MATLAB (*.m)
  - **NOTE**: Make sure the Simulation is set to a Sweep before exporting. The Adaptive Passes will only export a single frequency point.
- Equivalent Circuit Export
  - HSPICE, PSPICE, Spectre, Maxwell SPICE
Results - Data Management

- HFSS > Results > Browse Solutions
  - Solved model variations are retained. Unless otherwise notified by HFSS.

- HFSS > Results > Clean Up Solutions

- HFSS > Results > Import Solutions
Results - Create Reports

- HFSS > Results > Create Report
- Output Variables
- User Defined Equations
Fields

- Select Object Volume, Surface, or Line to display fields
- **HFSS > Fields > Plot Fields**
- Modify Plot - Solution/Frequency/Qty
- Plot Attributes
- Edit Sources - Change Excitation

![Modify Field Plot Window](image)

**Modify Field Plot**

- **Name**: Mag_E1
- **Category**: Standard
- **Solution**: Setup1: Sweep1
- **Plot Folder**: E Field
- **Intrinsic Variables**
  - **Freq**: 2GHz
  - **Phase**: 0deg

![Plot Attributes Window](image)

**Plot Attributes**

- **Scalar plot**
  - **Cloud**
  - **Point size**

![Edit Sources Window](image)

**Edit Sources**

- **Source**: X1
- **Type**: Port
- **Solved Magnitude**: 1V
- **Solved Phase**: 0 deg
- **Scaling Factor**: 1.0
- **Offset Phase**: 0 deg
- **Unit**: N/A
- **Terminated**: N/A
- **Resistance**: N/A
- **Unit**: N/A
**Mesh Display**

- **Field Overlay**
  1. Select an object
  2. Select the menu item **HFSS > Fields > Plot Mesh**
**Menu Structure**

- **Draw** - Primitives
- **3D Modeler** - Settings and Boolean Operations
- **Edit** - Arrange, Duplicate
- **HFSS** - Boundaries, Excitations, Mesh Operations, Analysis Setup, Results

![Menu Structure Diagram]
Measure

3D Modeler > Measure >

- **Position** - Points and Distance
- **Length** - Edge Length
- **Area** - Surface Area
- **Volume** - Object Volume
Options - General

- **Tools > Options > General Options**
  - **Temp Directory** - Location used during solution process
    - Make sure it is at least 512MB free disk.

Options - HFSS

- **Tools > Options > HFSS Options > Solver**
  - Number of Processors - Requires additional license
  - Desired RAM Limit - leave it unchecked for auto-detect
  - Maximum RAM Limit - leave it unchecked for auto-detect
  - Process Priority - set the simulation priority from Critical (highest) to Idle (lowest)
Converting Older HFSS Projects (pre-HFSS v9) to HFSS v10

From HFSS v10.0,
1. Select the menu item **File > Open**
2. Open dialog
   1. Files of Type: **Ansoft Legacy EM Projects (.cls)**
   2. Browse to the existing project and select the .cls file
   3. Click the **Open** button

What is Converted?
- Converts Entire Model: Geometry, Materials, Boundaries, Sources and Setup
- **Solutions, Optimetrics projects and Macros are not converted**

Legacy License
- Existing customers using HFSS v9.2.1 should have received legacy licenses with the new v10.0 licenses.
  - These licenses allow you to run either v10.0 or v9.2.1
  - Contact your Account Manager if this feature is not available
  - **NOTE:** Once a project is saved in v10 it can no longer be opened in v9
HFSS v10 Enhancements

From import of complex solid models to HFSS analysis is a multi-stage process, each step of which plays an important role.

\[\text{import} \rightarrow \text{healing} \rightarrow \text{meshing} \rightarrow \text{model resolution} \rightarrow \text{analysis}\]

Applications Include:

- Complex Connectors
- High-Speed PCBs
- Microwave Devices
**HFSS v10 Enhancements**

- **Healing Geometry**
  - Key Edit Features
    - *Auto/Manual Import Healing*
  - 3D Model Analysis - 3D Modeler/Analyze
    - Face, Object, Area analysis based on user inputs
    - List of problems (faces, edges, vertices)
    - Auto Zoom In into region where problem exists
    - Remove Face
    - Remove Edge
    - Remove Sliver
    - Remove Vertices
**HFSS v10 Enhancements**

- Improved Mesh Generation
  - Significantly improved mesh generation algorithms
HFSS v10 Enhancements

Model Resolution

Mesh before:
184,675 tets

Mesh after:
24,691 tets

Length = 0.1 mm
**Overview**

**HFSS v10 Enhancements**

- New dynamic links with HFSS and between Designer/Nexxim and SIWave

- New incident wave: Spherical, cylindrical, line dipole, Gaussian beam, etc
HFSS v10 Enhancements

Distributed Analysis

1) The graphical user interface enables users to select computer addresses for analysis distribution
2) Automated parser management and reassembly of data
3) Parametric tables and studies
4) Frequency sweeps for discrete, fast, and interpolating
5) Per license, distributed analysis allows up to 10 parallel simulations on remote machines, providing near-linear reduction of simulation run times
Recommended Service Packs (SP) - PC only
- Microsoft Windows XP - SP2 or higher
- Microsoft Windows 2000 - SP4 or higher

Updating Drivers
- Update your DirectX drivers to ver9.0c
  http://www.microsoft.com/directx
- Update your video drivers to the latest available from the card manufacturer

Memory allocation HFSS v9.2
- With the release of HFSS v9.2 you can access up to 3GB of Ram on PC
- All about 3GB switch, supported OS
  http://support.microsoft.com/default.aspx?scid=kb;en-us;291988
- How to use /3GB switch
- Possible problems
  http://support.microsoft.com/default.aspx?scid=kb;en-us;328269

Increasing Memory allocation HFSS v10
- With the release of HFSS v10 on a 64bit operating system theoretically there is no RAM limitation
- Practically you can access up to 32GB of RAM due to hardware limitations
Unix Operating Systems
- HPUX 11.0
- Solaris 2.8 and 2.9
- Note: Requires OpenGL
- Note: Please perform required OS updates outlined in readme file on the CD

Common Desktop (CDE)
- There is an issue with HFSS dialog boxes moving behind the main window. The following instructions describe how to prevent this:
  - Select **Tools > Desktop Controls**
  - Select **Window Style Manager**
  - From the Style Manager - Window
  - Uncheck **Allow Primary Windows on Top**
Project Files
- Everything regarding the project is stored in an ascii file
  - File: `<project_name>.hfss`
  - Double click from Windows Explorer will open and launch HFSS v10
- Results and Mesh are stored in a folder named `<project_name>.hfssresults`
- Lock file: `<project_name>.lock.hfss`
  - Created when a project is opened
- Auto Save File: `<project_name>.hfss.auto`
  - When recovering, software only checks date
    - If an error occurred when saving the auto file, the date will be newer than the original
    - Look at file size (provided in recover dialog)

Scripts
- Default Script recorded in v10
  - Visual Basic Script

Remote Solve (Windows Only)
- Tools > Options > General Options > Analysis Options
- Uses DCOM
Ansoft Designer SV

- Ansoft Designer™ SV is a full-featured subset of Ansoft's commercially distributed Ansoft Designer.
- Ansoft Designer SV contains a complete high-frequency linear circuit simulator, schematic and layout design entry, powerful design utilities, and post-processing, all integrated in an easy-to-use environment. The software also includes a complete set of linear distributed transmission line models, discontinuities, vendor component parts, and ideal circuit elements.
- Ansoft Designer SV allows the simulation of S-, Y-, and Z-parameters, group delay, noise figure, and stability circles of RF and microwave circuits. Utilities include real-time tuning, filter and TRL synthesis, and Smith Tool matching. Post-processing includes rectangular plots, Smith Charts, polar plots, and data tables. Additionally, Ansoft Designer SV comes with a set of real-world examples.
- **Free Download**: www.ansoft.com/ansoftdesignersv
For Technical Support

The following link will direct you to the Ansoft Support Page. The Ansoft Support Pages provide additional documentation, training, and application notes. Web Site: http://www.ansoft.com/support.cfm

Application Engineers for North America

The names and numbers in this list may change without notice

9-4 EST:

- Pittsburgh, PA
  - (412) 261-3200 x0 - Ask for Technical Support

- Burlington, MA
  - (781) 229-8900 x0 - Ask for Technical Support

9-4 PST:

- San Jose, CA
  - (408) 261-9095 x0 - Ask for Technical Support

- Portland, OR
  - (503) 906-7944 or (503) 906-7947

- El Segundo, CA
  - (310) 426-2287 - Ask for Technical Support
THIS PAGE INTENTIONALLY LEFT BLANK
Why are They Critical?

For most practical problems, the solution to Maxwell’s equations requires a rigorous matrix approach such as the Finite Element Method (FEM) which is used by Ansoft HFSS.

The wave equation solved by Ansoft HFSS is derived from the differential form of Maxwell’s equations.

For these expressions to be valid, it is assumed that the field vectors are:
- single-valued,
- bounded, and have a
- continuous distribution (along with their derivatives)

Along boundaries of media or at sources,
- Field vectors are discontinuous
- Derivatives of the field vectors have no meaning

Boundary Conditions define the field behavior across discontinuous boundaries

\[
\nabla \times E = -\frac{\partial B}{\partial t} \\
\nabla \times H = J + \frac{\partial D}{\partial t} \\
\n\nabla \cdot D = \rho \\
\n\nabla \cdot B = 0
\]
Why do I Care?

They *Force* the fields to align with the definition of the boundary condition

As a user I should be asking

What assumptions, about the fields, do the boundary conditions make?
Are these assumptions appropriate for the structure being simulated?

*Model Scope*

To reduce the infinite space of the real world to a finite volume, Ansoft HFSS automatically applies a boundary to the surface surrounding the geometric model

- Outer boundary
- Default Boundary: Perfect E

*Model Complexity*

To reduce the complexity of a model, the boundary conditions can be used to improve the:

- Solution Time
- Computer Resources

Failure to understand boundary conditions may lead to inconsistent results
What are Common Ansoft HFSS Boundary Conditions?

**Excitations**
- Wave Ports (External)
- Lumped Ports (Internal)

**Surface Approximations**
- Perfect E or Perfect H Surface
- Finite Conductivity Surface
- Impedance Surface
- Symmetry Planes
- Radiation Surface

**Material Properties**
- Boundary between two dielectrics
- Finite Conductivity of a conductor

Largely the users responsibility

Transparent to the user
**Surface Approximations**

- **Perfect E** - Forces the electric field perpendicular to the surface
  - Outer Surface - Default Boundary
  - PEC/Perfect Conductor Material Property
  - Model complexity: Reduced by eliminating conductor loss

- **Perfect H** - Forces the electric field tangent to the surface

- **Finite Conductivity** - Lossy electric conductor.
  - Forces the tangential electric field at the surface to: \( Z_s(n \times H_{\text{tan}}) \).
  - The surface impedance \( Z_s \) is equal to, \( (1+j)/(\delta \sigma) \),
  - Model complexity: Reduced by eliminating conductor thickness

- **Impedance Surface** - Represent surfaces of a known impedance
  - Forces the tangential electric field at the surface to: \( Z_s(n \times H_{\text{tan}}) \).
  - The surface impedance \( Z_s \) is equal to, \( R_s + jX_s \) (Ohms/Square)
  - **Layered Impedance** - Models multiple thin layers in a structure as an Impedance Surface
  - **Lumped RLC** - Parallel combination

---

**Perfect E Surface**

**Perfect H Surface**
Surface Approximations (Continued)

- **Symmetry Planes** - Enable you to model only part of a structure
  - Perfect E or Perfect H Symmetry Planes
    - Must be exposed to the outer surface
    - Must be on a planar surface
    - **Remember! Mechanical Symmetry does not Equal Electrical Symmetry**

- **Model complexity**: Reduced by eliminating part of the solution volume

---

Full Model

Perfect E Symmetry

Perfect H Symmetry
Surface Approximations (Continued)

**Radiation Surface** - Allows waves to radiate infinitely far into space.
- The boundary absorbs wave at the radiation surface
- Can be placed on arbitrary surfaces
- Accuracy depends on
  - The distance between the boundary and the radiating object
    - The radiation boundary should be located at least one-quarter of a wavelength from a radiating structure. If you are simulating a structure that does not radiate, the boundary can be located less than one-quarter of a wavelength (The validity of this assumption will require your engineering judgment).
  - The incident angle
    - The radiation boundary will reflect varying amounts of energy depending on the incidence angle. The best performance is achieved at normal incidence. Avoid angles greater than ~30 degrees. In addition, the radiation boundary must remain convex relative to the wave.

**Perfectly Matched Layer (PML)** - Allows waves to radiate infinitely far into space.
- Not a Boundary Condition. Fictitious materials that fully absorb the electromagnetic fields impinging upon them. These materials are complex anisotropic.
- Types
  - Free Space Termination or Reflection Free Termination
- Can only be placed on planar surface
- Model complexity: They do not suffer from the distance or incident angle problems of Radiation boundaries but should be placed at least one-tenth of a wave length from strong radiators.
Surface Approximations (Continued)

- Infinite Ground Planes - Simulate the effects of an infinite ground plane
  - Only affects the calculation of near- or far-field radiation during post processing
  - Types: Perfect E, Finite Conductivity, or Impedance Surface

- Frequency Dependent Boundary Conditions
  - The following boundary parameters can be assigned an expression that includes \( Freq \):
    - Finite Conductivity
    - Impedance
    - Lumped RLC
    - Layered Impedance
  - Supported Frequency Sweeps
    - Single Frequency
    - Discrete Sweep
    - Interpolating Sweep
Excitations

- Ports are a unique type of boundary condition
  - Allow energy to flow into and out of a structure.
  - Defined on 2D planar surface
  - Arbitrary port solver calculates the natural field patterns or modes
    - Assumes semi-infinitely long waveguide
    - Same cross-section and material properties as port surface
  - 2D field patterns serve as boundary conditions for the full 3D problem

Excitation Types

- Wave Port (Waveguide) - *External*
  - Recommended only for surfaces exposed to the background
  - Supports multiple modes (Example: Coupled Lines) and deembedding
  - Compute Generalized S-Parameters
    - Frequency dependent Characteristic Impedance (Zo)
    - Perfectly matched at every frequency

- Lumped Port - *Internal*
  - Recommended only for surfaces internal to geometric model
  - Single mode (TEM) and *no* deembedding
  - Normalized to a constant user defined Zo
Excitations (Continued)

Wave Equation

The field pattern of a traveling wave inside a waveguide can be determined by solving Maxwell’s equations. The following equation that is solved by the 2D solver is derived directly from Maxwell’s equation.

\[ \nabla \times \left( \frac{1}{\mu_r} \nabla \times E(x, y) \right) - k_0^2 \varepsilon_r E(x, y) = 0 \]

where:
- \( E(x,y) \) is a phasor representing an oscillating electric field.
- \( k_0 \) is the free space wave number,
- \( \mu_r \) is the complex relative permeability.
- \( \varepsilon_r \) is the complex relative permittivity.

To solve this equation, the 2D solver obtains an excitation field pattern in the form of a phasor solution, \( E(x,y) \). These phasor solutions are independent of \( z \) and \( t \) only after being multiplied by \( e^{-jz} \) do they become traveling waves.

Also note that the excitation field pattern computed is valid only at a single frequency. A different excitation field pattern is computed for each frequency point of interest.
Excitations (Continued)

- **Modes, Reflections, and Propagation**
  - It is also possible for a 3D field solution generated by an excitation signal of one specific mode to contain reflections of higher-order modes which arise due to discontinuities in a high frequency structure.
  - If these higher-order modes are reflected back to the excitation port or transmitted onto another port, the S-parameters associated with these modes should be calculated.
  - If the higher-order mode decays before reaching any port—either because of attenuation due to losses or because it is a non-propagating evanescent mode—there is no need to obtain the S-parameters for that mode.

- **Wave Ports Require a Length of Uniform Cross Section**
  - Ansoft HFSS assumes that each port you define is connected to a semi-infinitely long waveguide that has the same cross section as the Wave Port.

![Diagram of wave ports with and without uniform cross section](image)
Excitations (Continued)

- **Wave Port Boundary Conditions**
  - *Perfect E or Finite Conductivity*
    - Default: All outer edges are *Perfect E* boundary.
    - Port is defined within a waveguide.
    - Easy for enclosed transmission lines: Coax or Waveguide
    - Challenging for unbalanced or non-enclosed lines: Microstrip, CPW, Slotline, etc.
  - *Symmetry or Impedance*
    - Recognized at the port edges
  - *Radiation*
    - Default interface is a *Perfect E* boundary
Excitations (Continued)

- **Lumped Port Boundary Conditions**
  - *Perfect E or Finite Conductivity*
    - Any port edge that interfaces with a conductor or another port edge
  - *Perfect H*
    - All remaining port edges
Excitations (Continued)

**Excitation - Calibration**
- Ports must be *calibrated* to ensure consistent results. Determines:
  - Direction and polarity of fields
  - Voltage calculations.

**Solution Type: Driven Modal**
- Expressed in terms of the incident and reflected powers of the waveguide modes.
  - Definition not desirable for problems having several propagating quasi-TEM modes
    - Coupled/Multi-Coupled Transmission Lines
- Always used by the solver
- Calibration: Integration Line
  - Phase between Ports
  - Modal voltage integration path: Zpi, Zpv, Zvi

**Solution Type: Driven Terminal**
- Linear combination of nodal voltages and currents for the Wave Port.
  - Equivalent transformation performed from Modal Solution
- Calibration: Terminal Line
  - Polarity
  - Nodal voltage integration path
Example Solution Types:

Mode 1 (Even Mode)

Mode 2 (Odd Mode)

Modes to Nodes Transformation

SPICE Differential Pairs

Boundary/Excitations - Overview
**Application of Boundary Conditions - Case 1**

- Emulate laboratory measurements
- Verification/Validation before production
Application of Boundary Conditions - Case 2

- Isolate part of a structure (i.e. Exciting arbitrary transmission lines)
  - Not physically possible to measure in the laboratory
  - Full-Wave analysis not required for total system
    - Or total system too complex
  - Design work/Component level optimization
  - Post production problem solving

Total System

Isolated Component - Via Transition
Boundary/Excitations - Overview

Example Structure
- Coax to Stripline
Material Properties

- All 3D (Solid) objects have material definitions
  - To complete the model shown previously we must include the air that surrounds the structure.

Note: Substrate/Air boundary included in structure
**Remember!** Material Boundary conditions are transparent to the user
- They are not visible in the Project Tree

**Example Material Boundary:** Conductors ⇒ Surface Approximations
- **Perfect Conductors** ⇒ **Perfect E Boundary (Boundary Name: smetal)**
  - Forces E-Field perpendicular to surface
- **Lossy Conductors** ⇒ **Finite Conductivity Boundary**
  - Forces tangential E-Field to \((1+j)/(\delta\sigma)(n \times H_{tan})\).
  - Assumes one skin depth - User must manually force Ansoft HFSS to solve inside lossy conductors that are ≤ a skin depth
Surface Approximations

- Background or Outer Boundary
  - Not visible in the Project Tree
  - Any object surface that touches it ⇒ Perfect E Boundary
  - Default boundary applied to the region surrounding the geometric model
    - Model is encased in a thin metal layer that no fields propagate through

Override with Radiation Boundary
What Port Type Should I Use?

- Example is easy decision
- Port touches background (External)
- Cross Section is Coax (Enclosed Transmission Line)

**Wave Port**

- Solution Type: Driven Terminal
- SPICE Output

Identify Port Type & Cross Section

Assign Excitation & Calibrate Port

Define Default Post Processing
Is it Really that Simple?

Yes, but the geometric model was setup with several considerations

1. Only the face of the coax dielectric was selected for the port face
   - Port Boundary conditions define outer conductor
   - Material Definitions define inner conductor

2. Uniform port cross-section
   - Only supports a single mode
   - Higher-order modes caused by reflections would attenuate before port
     - Modes attenuate as a function of $e^{-\alpha z}$, assuming propagation in the z-direction.
     - Required distance (uniform port length) depends on modes propagation constant.
How often is the Setup that Simple?

- If you are emulating laboratory measurements? [Case 1]
  - Most of the time!
    - Laboratory equipment does not directly connect to arbitrary transmission lines
  - Exceptions
    - Emulating Complex Probes with a Port ⇒ Understanding of Probe

- If you are isolating part of a structure? [Case 2]
  - For “real” designs - usually only by dumb luck!
    - User Must Understand and/or Implement Correctly:
      1. Port Boundary conditions and impact of boundary condition
      2. Fields within the structure
      3. Assumptions made by port solver
      4. Return path
Side Note: Problems Associated with Correlating Results [Case 2]

- Can be broken into two categories of problems

1. Complex Structure
   - BGA, Backplane, Antenna Feed, Waveguide “Plumbing”, etc
   - Most common problems result from
     - Measurement setup - Test fixtures, deembedding, etc.
     - Failing to understand the fields in the structure ⇒ Boundary Problem
     - Return path problems - Model truncation

2. Simple Structures
   - Uniform transmission lines
     - Equations or Circuit Elements
   - Most common problems result from
     - Improper use of default or excitation boundary conditions
     - Failure to understand the assumptions used by “correct” results
       (Equations or Circuit Elements)
Why are they critical?

- Any current injected into a system must return to the source
  - DC
    - Chooses path of least resistance
  - AC
    - Chooses path of least inductance
    - A signal propagates between the signal trace and its reference plane
    - *Reference plane is just as important as signal trace!*

Why do I care?

- Many real designs have nonideal return paths
  - These effects are only captured by full-wave simulators
- Isolating parts of a structure
  - Failure to maintain the correct return path will
    - Limit correlation to measurements
    - Mask or create design problems
  - Port and Boundary setup is the most common source of error in model setup
Boundary/Excitations - Overview
Boundary/Excitations - Overview

DC & RF Return Path

- S21
- S11
- S31

Freq [GHz]

0.00 2.50 5.00 7.50 10.00 12.50 15.00

-80.00 -60.00 -40.00 -20.00 0.00

S21
S31
S11
Isolate part of structure - Case 2

- Isolate Transition
  - Deembed
  - Recombine using Ansoft Designer - Circuit
Boundary/Excitations - Overview

Ansoft Designer - Circuit

![Diagram of a circuit with ports 1 and 2 with S-Parameters graph showing resonant frequencies.](image)
Boundary/Excitations - Overview
What went wrong?

- **Isolate Port from Discontinuity?**
  - Yes

- **Uniform Cross-Section?**
  - NO - The cross section of the port (including its boundaries) is not maintained

- **Maintain Return Path?**
  - NO - Boundary on port shorts the planes together at edges
    - Identical to placing vias at port edge!

- **All Modes Accounted for?**
  - NO - Did not consider Parallel Plate mode
    - Even if we did, the via (port edge) cuts off mode ⇒ Reason vias are used!
Boundary/Excitations - Overview

2 Terminals

Mode Matching

Wave Port

Parallel Plate

Ansoft Designer - Circuit

Stripline

WavedPort WavedPort WavedPort WavedPort

2d Terminals 2d Terminals 2d Terminals 2d Terminals
Boundary/Excitations - Overview

- Lumped Port
- Return Path
- Port Influences
- No DC Return Path

Results

Port Parameters
Boundary/Excitations - Overview
Boundary/Excitations - Overview

- **GND**
- **Signal**
- **Power**

- **Lumped Gap Port**
- **Terminal Line**
Boundary/Excitations - Overview

Lumped Gap Port
Boundary/Excitations - Overview

Differential Lumped Gap Ports
Boundary/Excitations - Overview

Port

Port

Port
Microstrip Port Sizing Guidelines
- Assume width of microstrip trace is $w$
- Assume height of substrate dielectric is $h$

Port Height Guidelines
- Between $6h$ and $10h$
  - Tend towards upper limit as dielectric constant drops and more fields exist in air rather than substrate
  - Bottom edge of port coplanar with the upper face of ground plane
  - (If real structure is enclosed lower than this guideline, model the real structure!)

Port Width Guidelines
- $10w$, for microstrip profiles with $w \geq h$
- $5w$, or on the order of $3h$ to $4h$, for microstrip profiles with $w < h$
Stripline Port Sizing Guidelines
- Assume width of stripline trace is $w$
- Assume height of substrate dielectric is $h$

Port Height Guidelines
- Extend from upper to lower groundplane, $h$

Port Width Guidelines
- $8w$, for microstrip profiles with $w \geq h$
- $5w$, or on the order of $3h$ to $4h$, for microstrip profiles with $w < h$

Boundary Note: Can also make side walls of port Perfect $H$ boundaries

$8w$, $w \geq h$

or

$5w$ ($3h$ to $4h$), $w < h$