User’s Guide

Agilent Technologies
PSG Signal Generators

This guide applies to the following signal generator models:

E8267C PSG Vector Signal Generator
E8257C PSG Analog Signal Generator
E8247C PSG CW Signal Generator

Due to our continuing efforts to improve our products through firmware and hardware revisions, signal generator design and operation may vary from descriptions in this guide. We recommend that you use the latest revision of this guide to ensure you have up-to-date product information. Compare the print date of this guide (see bottom of page) with the latest revision, which can be downloaded from the following website:

www.agilent.com/find/psg
Notice

The material contained in this document is provided “as is”, and is subject to being changed, without notice, in future editions.

Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either express or implied with regard to this manual and to any of the Agilent products to which it pertains, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or any of the Agilent products to which it pertains. Should Agilent have a written contract with the User and should any of the contract terms conflict with these terms, the contract terms shall control.

Questions or Comments about our Documentation?

We welcome any questions or comments you may have about our documentation. Please send us an E-mail at sources_manuals@am.exch.agilent.com.
1. Signal Generator Overview ...................................................... 1
   Signal Generator Models and Features ..................................... 2
     E8247C PSG CW Signal Generator Features .............................. 2
     E8257C PSG Analog Signal Generator Features ......................... 3
     E8267C PSG Vector Signal Generator Features ......................... 4
   Options ........................................................................... 4
   Firmware Upgrades .......................................................... 4
   Modes of Operation ......................................................... 5
   Front Panel ...................................................................... 6
     1. Display ...................................................................... 7
     2. Softkeys ..................................................................... 7
     3. Knob ......................................................................... 7
     4. Amplitude .................................................................... 7
     5. Frequency ..................................................................... 7
     6. Save .......................................................................... 7
     7. Recall ......................................................................... 7
     8. Trigger ....................................................................... 8
     9. MENUS ...................................................................... 8
    10. Help .......................................................................... 8
    11. EXT 1 INPUT ............................................................... 8
    12. EXT 2 INPUT ............................................................... 9
    13. LF OUTPUT ................................................................... 9
    14. Mod On/Off .................................................................. 9
    15. ALC INPUT .................................................................. 9
    16. RF On/Off .................................................................... 9
    17. Numeric Keypad ............................................................ 9
    18. RF OUTPUT ................................................................... 10
    19. SYNC OUT ................................................................... 10
    20. VIDEO OUT ............................................................... 10
    21. Line Power LED ........................................................... 10
    22. Power Switch ............................................................. 10
    23. Standby LED .............................................................. 10
    24. Iner Set ....................................................................... 10
    25. GATE/PULSE/TRIGGER INPUT ..................................... 10
    26. Arrows ....................................................................... 11
    27. Hold .......................................................................... 11
    28. Return ....................................................................... 11
    29. Display Contrast Decrease .............................................. 11
# Contents

30. Display Contrast Increase .......................................................... 11  
31. Local ................................................................................. 11  
32. Preset ................................................................................ 11  
33. I/Q INPUTS ........................................................................ 12  
34. DATA INPUT ........................................................................ 12  
35. DATA CLOCK INPUT .............................................................. 12  
36. SYMBOL SYNC INPUT .............................................................. 12

Front Panel Display ................................................................. 13  
1. Active Entry Area ................................................................. 13  
2. Frequency Area .................................................................. 13  
3. Annunciators ....................................................................... 14  
4. Digital Modulation Annunciators .......................................... 16  
5. Amplitude Area .................................................................... 16  
6. Error Message Area .............................................................. 16  
7. Text Area ............................................................................. 16  
8. Softkey Label Area .............................................................. 16

Rear Panel .................................................................................. 17  
1. AC Power Receptacle ............................................................. 18  
2. GPIB .................................................................................. 18  
3. AUXILIARY INTERFACE ...................................................... 18  
4. LAN .................................................................................. 18  
5. STOP SWEEP IN/OUT ........................................................... 19  
6. Z-AXIS BLANK/MKRS .............................................................. 19  
7. SWEEP OUT ....................................................................... 19  
8. TRIGGER OUT .................................................................... 19  
9. TRIGGER IN ....................................................................... 19  
10. SOURCE SETTLED ............................................................... 19  
11. EVENT 1 ............................................................................ 20  
12. EVENT 2 ............................................................................ 20  
13. PATTERN TRIG IN ................................................................. 20  
14. BURST GATE IN ................................................................. 20  
15. AUXILIARY I/O ................................................................. 21  
16. Digital Bus .......................................................................... 22  
17. WIDEBAND I INPUT .............................................................. 22  
18. WIDEBAND Q INPUT .............................................................. 22  
19. COH (COHERENT CARRIER OUTPUT) ................................. 22  
20. I OUT ............................................................................... 22  
21. I-bar OUT .......................................................................... 23
2. Basic Operation ................................................................. 25
   Using Table Editors .......................................................... 26
   Table Editor Softkeys .......................................................... 27
   Modifying Table Items in the Data Fields .................................. 27
   Configuring the RF Output ..................................................... 28
   Configuring a Continuous Wave RF Output .................................. 28
   Configuring a Swept RF Output ............................................... 31
   Extending the Frequency Range with a mm-Wave Source Module ........... 47
   Modulating a Signal .............................................................. 50
   Turning On a Modulation Format .............................................. 50
   Applying a Modulation Format to the RF Output ......................... 51
   Using Data Storage Functions ............................................... 52
   Using the Memory Catalog .................................................... 52
   Using the Instrument State Register ....................................... 54
   Enabling Options ............................................................... 57
   Enabling a Software Option .................................................. 57

3. Optimizing Performance ...................................................... 59
   Selecting ALC Bandwidth ...................................................... 59
   To Select an ALC Bandwidth ................................................... 59
   Using External Leveling ....................................................... 60
   To Level with Detectors and Couplers/Splitters ............................ 60
   To Level with a mm-Wave Source Module .................................. 63
   Creating and Applying User Flatness Correction .......................... 64
   Creating a User Flatness Correction Array .................................. 64
   Creating a User Flatness Correction Array with a mm-Wave Source Module ............................................. 69
   Adjusting Reference Oscillator Bandwidth (Option UNR) ................. 76
   To Select the Reference Oscillator Bandwidth .............................. 76
   To Restore Factory Default Settings: ....................................... 76
Contents

4. Analog Modulation ................................................................. 77
   Analog Modulation Waveforms ........................................... 78
   Configuring AM ................................................................... 79
      To Set the Carrier Frequency .......................................... 79
      To Set the RF Output Amplitude ...................................... 79
      To Set the AM Depth and Rate ........................................ 79
      To Turn on Amplitude Modulation .................................... 79
   Configuring FM ..................................................................... 80
      To Set the RF Output Frequency ....................................... 80
      To Set the RF Output Amplitude ...................................... 80
      To Set the FM Deviation and Rate .................................... 80
      To Activate FM ................................................................ 80
   Configuring ΦM .................................................................... 81
      To Set the RF Output Frequency ....................................... 81
      To Set the RF Output Amplitude ...................................... 81
      To Set the FM Deviation and Rate .................................... 81
      To Activate FM ................................................................ 81
   Configuring Pulse Modulation .............................................. 82
      To Set the RF Output Frequency ....................................... 82
      To Set the RF Output Amplitude ...................................... 82
      To Set the Pulse Period and Width ................................... 82
      To Activate Pulse Modulation .......................................... 82
   Configuring the LF Output .................................................... 83
      To Configure the LF Output with an Internal Modulation Source .................................................... 84
      To Configure the LF Output with a Function Generator Source .................................................... 85

5. Dual Arbitrary Waveform Generator ........................................ 87
   Arbitrary (ARB) Waveform File Headers ................................ 88
   Creating a File Header for a Modulation Format Waveform ........ 89
   Modifying Header Information in a Modulation Format ............ 90
   Storing Header Information for a Dual ARB Player Waveform Sequence .................................................... 95
   Modifying and Viewing Header Information in the Dual ARB Player .................................................... 95
   Playing a Waveform File that Contains a Header ....................... 98
   Using the Dual ARB Waveform Player .................................... 99
      Accessing the Dual ARB Player ......................................... 99
      Creating Waveform Segments ......................................... 100
      Building and Storing a Waveform Sequence ......................... 101
      Playing a Waveform ......................................................... 102
### Contents

- **Editing a Waveform Sequence** ................................................................. 102
- **Storing and Loading Waveform Segments** .............................................. 103
- **Renaming a Waveform Segment** ............................................................ 103
- **Using Waveform Markers** ....................................................................... 104
  - To Place a Marker at the First Point within a Waveform Segment .............. 104
  - To Place a Marker Across a Range of Points within a Waveform Segment .... 104
  - To Place Repetitively Spaced Markers within a Waveform Segment .......... 105
  - To Use Marker 2 to Blank the RF Output .............................................. 105
  - To Toggle Markers in an Existing Waveform Sequence ........................... 106
  - To Toggle Markers As You Create a Waveform Sequence ...................... 107
- **Waveform Marker Concepts** ................................................................. 108
- **Using Waveform Triggers** ...................................................................... 111
  - To Use Segment Advance Triggering .................................................. 111
- **Using Waveform Clipping** ..................................................................... 112
  - To Configure Circular Clipping ......................................................... 112
  - To Configure Rectangular Clipping .................................................... 112
- **Waveform Clipping Concepts** .............................................................. 113

6. **Custom Arb Waveform Generator** ..................................................... 119

- **Overview** ............................................................................................ 120
- **Working with Predefined Setups (Modes)** ............................................. 121
  - Selecting a Custom ARB Setup or a Custom Digital Modulation State ......... 121
  - Working with User-Defined Setups (Modes)-Custom Arb Only ................... 122
    - Modifying a Single-Carrier NADC Setup ........................................ 122
    - Customizing a Multicarrier Setup ................................................... 123
    - Recalling a User-Defined Custom Digital Modulation State .................. 124
  - Working with Filters ............................................................................. 125
    - Using a Predefined FIR Filter .......................................................... 126
    - Using a User-Defined FIR Filter ....................................................... 127
  - Working with Symbol Rates ................................................................. 133
    - To Set a Symbol Rate ....................................................................... 133
    - To Restore the Default Symbol Rate (Custom Real Time I/Q Only) ......... 133
  - Working with Modulation Types ........................................................... 136
    - To Select a Predefined Modulation Type .......................................... 136
    - To Use a User-Defined Modulation Type (Real Time I/Q Only) ............. 137
  - Configuring Hardware ........................................................................... 143
    - To Set a Delayed, Positive Polarity, External Single Trigger .................. 143
## Contents

To View a Two-Tone Waveform ................................................................. 182
To Minimize Carrier Feedthrough ........................................................... 184
To Change the Alignment of a Two-Tone Waveform .................................. 186

### 10. Troubleshooting ................................................................. 187

**RF Output Power Problems** ................................................................. 189
**RF Output Power too Low** ................................................................. 189
**The Power Supply has Shut Down** ......................................................... 189
**Signal Loss While Working with a Mixer** ............................................... 190
**Signal Loss While Working with a Spectrum Analyzer** ................................ 192
**No Modulation at the RF Output** .......................................................... 193
**Sweep Problems** .................................................................................. 194
**Sweep Appears to be Stalled** ................................................................. 194
**Cannot Turn Off Sweep Mode** ............................................................... 194
**Incorrect List Sweep Dwell Time** ......................................................... 195
**List Sweep Information is Missing from a Recalled Register** ...................... 195
**Data Storage Problems** ....................................................................... 196
**Registers With Previously Stored Instrument States are Empty** ..................... 196
**Saved Instrument State, but Register is Empty or Contains Wrong State** .......... 196
**Cannot Turn Off Help Mode** ................................................................. 197
**Signal Generator Locks Up** ................................................................. 198
**Fail-Safe Recovery Sequence** ............................................................... 198
**Error Messages** ................................................................................. 200
**Error Message File** ............................................................................ 200
**Error Message Format** ........................................................................ 201
**Error Message Types** ........................................................................... 202
**Returning a Signal Generator to Agilent Technologies** ............................... 203
1 Signal Generator Overview

In the following sections, this chapter describes the models, options, and features available for Agilent PSG signal generators. The modes of operation, front panel user interface, as well as front and rear panel connectors are also described.

- “Signal Generator Models and Features” on page 2
- “Options” on page 4
- “Firmware Upgrades” on page 4
- “Modes of Operation” on page 5
- “Front Panel” on page 6
- “Front Panel Display” on page 13
- “Rear Panel” on page 17
Signal Generator Overview

Signal Generator Models and Features

Table 1-1 lists the available PSG signal generator models along with their output signal types and frequency range.

<table>
<thead>
<tr>
<th>Model</th>
<th>Type</th>
<th>Frequency Range</th>
</tr>
</thead>
<tbody>
<tr>
<td>E8247C PSG CW signal generator</td>
<td>CW</td>
<td>250 kHz to 20 GHz, or 250 kHz to 40 GHz</td>
</tr>
<tr>
<td>E8257C PSG analog signal generator</td>
<td>Analog</td>
<td>250 kHz to 20 GHz, or 250 kHz to 40 GHz</td>
</tr>
<tr>
<td>E8267C PSG vector signal generator</td>
<td>Vector</td>
<td>250 kHz to 20 GHz</td>
</tr>
</tbody>
</table>

**E8247C PSG CW Signal Generator Features**

An E8247C PSG CW signal generator includes the following features:

- CW output from 250 kHz to 20 GHz or 40 GHz
- Frequency resolution to 0.001 Hz
- List and step sweep of frequency and amplitude, with multiple trigger sources
- User flatness correction
- External diode detector leveling
- Automatic leveling control (ALC) on and off modes; power calibration in ALC-off mode is available, even without power search
- 10 MHz reference oscillator with external output
- RS-232, GPIB, and 10Base-T LAN I/O interfaces
- A millimeter head interface that is compatible with Agilent 83550 Series millimeter heads (for frequency extension up to 110 GHz)
E8257C PSG Analog Signal Generator Features

An E8257C PSG analog signal generator provides all the functionality of an E8247C PSG CW signal generator and adds the following features:

- open-loop or closed-loop AM
- dc-synthesized FM to 10 MHz rates; maximum deviation depends on the carrier frequency
- phase modulation ($\Phi_M$)
- pulse modulation
- external modulation inputs for AM, FM, $\Phi_M$, and pulse
- simultaneous modulation configurations (except: FM with $\Phi_M$ or Linear AM with Exponential AM)
- an internal pulse generator that includes the following:
  - selectable pulse modes: internal square, internal free-run, internal triggered, internal doublet, internal gated, and external pulse; internal triggered, internal doublet, and internal gated require an external trigger source
  - adjustable pulse rate
  - adjustable pulse period
  - adjustable pulse width
  - adjustable pulse delay
  - selectable external pulse triggering: positive or negative
- dual function generators that includes the following:
  - 50Ω low frequency output, 0 to 3Vp, available through LF OUTPUT
  - selectable waveforms: sine, dual-sine, swept-sine, triangle, positive ramp, negative ramp, square, uniform noise, Gaussian noise, and dc
  - adjustable frequency modulation rates
  - selectable triggering in list and step sweep modes: free run (auto), trigger key (single), bus (remote), and external
**Signal Generator Overview**

**Options**

**E8267C PSG Vector Signal Generator Features**

An E8267C PSG vector signal generator provides all the functionality of an E8257C PSG analog signal generator, and adds the following features:

- internal I/Q modulator
- external analog I/Q inputs
- single-ended and differential analog I/Q outputs

**Options**

PSG signal generators have hardware, firmware, software, and documentation options. The data sheet shipped with your signal generator provides an overview of available options. For details, refer to the Agilent Technologies website.

2. Select the desired model.
3. Click View complete price list.

**Firmware Upgrades**

The firmware in your signal generator may be upgraded when new firmware is released. New firmware releases may contain signal generator features and functionality not available in previous firmware releases.

To inquire about the availability of new signal generator firmware, contact Agilent at [http://www.agilent.com/find/upgradeassistant](http://www.agilent.com/find/upgradeassistant), or call the appropriate number listed in Table 10-1 on page 203.
Signal Generator Overview

Modes of Operation

All PSG signal generator models can be used in CW mode:

- **CW mode** produces a single carrier signal.
  - If you have an E8247C PSG CW signal generator, you can produce a CW single carrier signal without modulation.
  - If you have an E8257C PSG analog signal generator, you can produce a CW single carrier signal without modulation, or you can add AM, FM, ΦM, or Pulse modulation to produce a single carrier modulated signal; some of these modulations can be used together.
  - If you have an E8267C PSG vector signal generator, you can produce a CW single carrier signal without modulation, or you can add AM, FM, ΦM, Pulse, or I/Q modulation to produce a single carrier modulated signal; some of these modulations can be used together.

In addition to CW and analog mode, all of the following modes are also available to the E8267C PSG vector signal generator:

- **Custom Arb Waveform Generator** mode can produce a single modulated carrier or multiple modulated carriers. Each modulated carrier waveform must be calculated and generated before it can be output; this signal generation occurs on the internal baseband generator (Option 002/602). Once a waveform has been created, it can be stored and recalled which enables repeatable playback of test signals. To learn more, refer to “Custom Arb Waveform Generator” on page 119.

- **Custom Real Time I/Q Baseband** mode produces a single carrier, but it can be modulated with real time data that allows real time control over all of the parameters that affect the signal. The single carrier signal that is produced can be modified by applying various data patterns, filters, symbol rates, modulation types, and burst shapes. To learn more, refer to “Custom Real Time I/Q Baseband” on page 145.

- **Two Tone** mode produces two separate carrier signals without any kind of modulation; the frequency spacing between the two carrier signals is adjustable as well as the amplitude of both carriers. To learn more, refer to “Two-Tone Waveform Generator” on page 179.

- **Multitone** mode produces any number of carrier signals without any kind of modulation; like Two Tone mode, the frequency spacing between all carrier signals is adjustable as well as the amplitude of all carriers. To learn more, refer to “Multitone Waveform Generator” on page 169.

- **Dual ARB** mode is used to control the playback sequence of waveform segments that have been written into the ARB memory located on the internal baseband generator (Option 002/602). These waveforms can be generated using the internal baseband generator, in Custom Arb Waveform Generator mode, or downloaded through a remote interface into the ARB memory. To learn more, refer to “Dual Arbitrary Waveform Generator” on page 87.
Signal Generator Overview

Front Panel

Figure 1-1 shows the E8267C PSG vector signal generator front panel with a list of items called out that enable you to define, monitor, and manage input and output characteristics.

The description of each item also applies to both the E8257C PSG analog signal generator and the E8247C PSG CW signal generator front panels. Not all items being described are available on every signal generator; the list of items that your particular signal generator has is dependent on its model and options.

Figure 1-1  Front Panel Diagram (E8267C PSG Vector Signal Generator)
1. Display

The LCD screen provides information on the current function. Information can include status indicators, frequency and amplitude settings, and error messages. Softkeys labels are located on the right-hand side of the display. For more detail on the front panel display, see “Front Panel Display” on page 13.

2. Softkeys

Softkeys activate the displayed function to the left of each key.

3. Knob

Use the knob to increase or decrease a numeric value, changes a highlighted digit or character, or step through lists or select items in a row.

4. Amplitude

Pressing this hardkey makes amplitude the active function. You can change the output amplitude or use the menus to configure amplitude attributes such as power search, user flatness, and leveling mode.

5. Frequency

Pressing this hardkey makes frequency the active function. You can change the output frequency or use the menus to configure frequency attributes such as frequency multiplier, offset, and reference.

6. Save

Pressing this hardkey accesses a menu of choices enabling you to save data in the instrument state register. The instrument state register is a section of memory divided into 10 sequences (numbered 0 through 9) each containing 100 registers (numbered 00 through 99). It is used to store and recall:

- frequency and amplitude settings on an E8247C PSG CW signal generator
- frequency, amplitude, and modulation settings on an E8257C PSG analog signal generator or E8267C PSG vector signal generator

The Save hardkey provides a quick alternative to reconfiguring the signal generator through the front panel or SCPI commands when switching between different signal configurations. Once an instrument state has been saved, all of the frequency, amplitude, and modulation settings can be recalled with the Recall hardkey.

7. Recall

Restores an instrument state saved in a memory register. Refer to the Save hardkey for further information.
8. Trigger

Initiates an immediate trigger event for a function such as a list, step, or ramp sweep (Option 007 only). Before this hardkey can be used to initiate a trigger event, the trigger mode must be set to Trigger Key. For example: press the Sweep/List hardkey, then one of the following sequences of softkeys:

- More (1 of 2) > Sweep Trigger > Trigger Key
- More (1 of 2) > Point Trigger > Trigger Key

9. MENUS

These keys open softkey menus for configuring various functions. For descriptions, see the Key Reference.

Table 1-2  Hardkeys in Front Panel MENUS Group

<table>
<thead>
<tr>
<th>E8247C PSG CW</th>
<th>E8257C PSG Analog</th>
<th>E8267C PSG Vector</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sweep/ List</td>
<td>AM</td>
<td>Mode</td>
</tr>
<tr>
<td>Utility</td>
<td>Sweep/ List</td>
<td>Mux</td>
</tr>
<tr>
<td></td>
<td>FM/ΦM</td>
<td>AM</td>
</tr>
<tr>
<td></td>
<td>Utility</td>
<td>Sweep/ List</td>
</tr>
<tr>
<td></td>
<td>Pulse</td>
<td>Mode Setup</td>
</tr>
<tr>
<td></td>
<td>LF Out</td>
<td>Aux Fcn</td>
</tr>
<tr>
<td></td>
<td></td>
<td>FM/ΦM</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Utility</td>
</tr>
<tr>
<td></td>
<td></td>
<td>I/ Q</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Pulse</td>
</tr>
<tr>
<td></td>
<td></td>
<td>LF Out</td>
</tr>
</tbody>
</table>

10. Help

Pressing this hardkey accesses a short description of any hardkey or softkey. There are two help modes available on the signal generator: single and continuous. The single mode is the factory preset condition. Toggle between single and continuous mode by pressing Utility > Instrument Info/ Help Mode > Help Mode Single Cont.

- In single mode, help text is provided for the next key you press without activating the key’s function. Any key pressed afterward exits the help mode and its function is activated.
- In continuous mode, help text is provided for each subsequent key press until you press the Help hardkey again or change to single mode. In addition, each key is active, meaning that the key function is executed (except for the Preset key).

11. EXT 1 INPUT

This female BNC input connector (E8257C and E8267C only) accepts a ±1 V_p signal for AM, FM, and ΦM. For these modulations, ±1 V_p produces the indicated deviation or depth. When ac-coupled inputs are selected for AM, FM, or ΦM and the peak input voltage differs from 1V_p by more than 3%, the HI/LO display annunciators light. The input impedance is selectable as either 50 or 600Ω; the damage levels are 5 V_rms and 10 V_p. On signal generators with Option 1EM, this connector is relocated to the a rear panel.
12. **EXT 2 INPUT**

This female BNC input connector (E8257C and E8267C only) accepts a ±1V_p signal for AM, FM, and \(\Phi\)M. With AM, FM, or \(\Phi\)M, ±1 V_p produces the indicated deviation or depth. When ac-coupled inputs are selected for AM, FM, or \(\Phi\)M and the peak input voltage differs from 1V_p by more than 3%, the HI/LO annunciators light on the display. The input impedance is selectable as either 50Ω or 600Ω and damage levels are 5 V rms and 10 V_p. On signal generators with Option 1EM, this input is relocated to the rear panel.

13. **LF OUTPUT**

This female BNC output connector (E8257C and E8267C only) outputs modulation signals generated by the low frequency (LF) source function generator. This output is capable of driving 3V_p (nominal) into a 50Ω load. On signal generators with Option 1EM, this output is relocated to the rear panel.

14. **Mod On/Off**

This hardkey (E8257C and E8267C only) enables or disables all active modulation formats (AM, FM, \(\Phi\)M, Pulse, or I/Q) applied to the output carrier signal available through the RF Output connector. This hardkey does not set up or activate an AM, FM, \(\Phi\)M, Pulse, or I/Q format; each modulation format must still be set up and activated (for example, AM > AM On) or nothing is applied to the output carrier signal when the Mod On/Off hardkey is enabled. The MOD ON/OFF annunciator, which is always present on the display, indicates whether active modulation formats have been enabled or disabled with the Mod On/Off hardkey.

15. **ALC INPUT**

This female BNC input connector is used for negative external detector leveling. This connector accepts an input of −0.2 mV to −0.5V. The nominal input impedance is 120 kΩ and the damage level is ±15V. On signal generators with Option 1EM, this input is relocated to the rear panel.

16. **RF On/Off**

Pressing this hardkey toggles the operating state of the RF signal present at the RF OUTPUT connector. Although you can set up and enable various frequency, power, and modulation states, the RF and microwave output signal is not present at the RF OUTPUT until RF On/Off is set to On. An annunciator is always visible in the display to indicate whether the RF is turned on or off.

17. **Numeric Keypad**

The numeric keypad consists of the 0 through 9 hardkeys, a decimal point hardkey, and a backspace hardkey (\(\pm/\leftrightarrow\)). The backspace hardkey enables you to backspace or alternate between a positive and a negative value. When specifying a negative numeric value, the negative sign must be entered prior to entering the numeric value.
18. RF OUTPUT

This connector is the output for RF and microwave signals. The nominal output impedance is 50\(\Omega\). The reverse-power damage levels are 0 Vdc, 0.5 watts nominal. On signal generators with Option 1EM, this output is relocated to a rear panel female BNC connector.

19. SYNC OUT

This female BNC output connector (E8257C and E8267C only) outputs a synchronizing TTL-compatible pulse signal that is nominally 50 ns wide during internal and triggered pulse modulation. The nominal source impedance is 50\(\Omega\). On signal generators with Option 1EM, this output is relocated to the rear panel.

20. VIDEO OUT

This female BNC output connector (E8257C and E8267C only) outputs a TTL-level compatible pulse signal that follows the output envelope in all pulse modes. The nominal source impedance is 50\(\Omega\). On signal generators with Option 1EM, this output is relocated to the rear panel.

21. Line Power LED

This green LED indicates when the signal generator power switch is set to the on position.

22. Power Switch

In the on position, this switch activates full power to the signal generator; in standby, it deactivates all signal generator functions. In standby, the signal generator remains connected to the line power and power is supplied to some internal circuits.

23. Standby LED

This yellow LED indicates when the signal generator power switch is set to the standby condition.

24. Incr Set

This hardkey enables you to set the increment value of the current active function. This the increment value of the current active function appears in the active entry area of the display. Use the numeric keypad, arrow hardkeys, or the knob to adjust the increment value.

25. GATE/ PULSE/ TRIGGER INPUT

This female BNC input connector (E8257C and E8267C only) accepts an externally supplied pulse signal for use as a pulse or trigger input. With pulse modulation, +1V is on and 0V is off (trigger threshold of 0.5V with a hysteresis of 10%; so 0.6V would be on and 0.4V would be off). The damage levels are ±5V_{rms} and
10Vp. The nominal input impedance is 50Ω. On signal generators with Option 1EM, this input is relocated to the rear panel.

26. Arrows

These up and down arrow hardkeys are used to increase or decrease a numeric value, step through displayed lists, or to select items in a row of a displayed list. Individual digits or characters may be highlighted using the left and right arrow hardkeys. Once an individual digit or character is highlighted, its value can be changed using the up and down arrow hardkeys.

27. Hold

Pressing this hardkey blanks the softkey label area and text areas on the display. Softkeys, arrow hardkeys, the knob, the numeric keypad, and the Incr Set hardkey have no effect once this hardkey is pressed.

28. Return

Pressing this hardkey will return the signal generator one level back from its current softkey menu level to the previous softkey menu level. It enables you to step back through the menus until you reach the first menu you selected.

29. Display Contrast Decrease

Pressing this hardkey causes the display background to darken.

30. Display Contrast Increase

Pressing this hardkey causes the display background to lighten.

31. Local

Pressing this hardkey deactivates remote operation and returns the signal generator to front panel control.

32. Preset

Pressing this hardkey sets the signal generator to a known state (factory or user-defined).
Signal Generator Overview

Front Panel

33. I/Q INPUTS

These female BNC input connectors (E8267C only) accept an externally supplied, analog, I/Q modulation; the in-phase component is supplied through the I INPUT; the quadrature-phase component is supplied through the Q INPUT. The signal level is $\sqrt{I^2 + Q^2} = 0.5 \text{ V}\text{rms}$ for a calibrated output level. The nominal input impedance is 50Ω or 600Ω. The damage level is 1 V rms and 10 V peak. To activate signals applied to these connectors, press Mux > I/Q Source 1 or I/Q Source 2 and then select either Ext 50 Ohm or Ext 600 Ohm. On signal generators with Option 1EM, these inputs are relocated to the rear panel.

34. DATA INPUT

This female BNC input connector (E8267C with Option 002/602 only) is CMOS compatible and accepts an externally supplied serial data input for digital modulation applications. The expected input is a 3.3 V CMOS signal (which is also TTL compatible) where a CMOS high = a data 1 and a CMOS low = a data 0. The maximum input data rate is 50 Mb/s. The data must be valid on the falling edges of the data clock (normal mode) or the on the falling edges of the symbol sync (symbol mode). The damage levels are $> +5.5$ and $< -0.5$V. On signal generators with Option 1EM, this input is relocated to the rear panel.

35. DATA CLOCK INPUT

This female BNC input connector (E8267C only) is CMOS compatible and accepts an externally supplied data-clock input signal to synchronize serial data for use with the internal baseband generator (Option 002/602). The expected input is a 3.3 V CMOS bit clock signal (which is also TTL compatible) where the rising edge is aligned with the beginning data bit. The falling edge is used to clock the DATA and SYMBOL SYNC signals. The maximum clock rate is 50 MHz. The damage levels are $> +5.5$ and $< -0.5$V. On signal generators with Option 1EM, this input is relocated to the rear panel.

36. SYMBOL SYNC INPUT

This female BNC input connector (E8267C only) is CMOS compatible and accepts an externally supplied symbol sync signal for use with the internal baseband generator (Option 002/602). The expected input is a 3.3 V CMOS bit clock signal (which is also TTL compatible). SYMBOL SYNC might occur once per symbol or be a single one-bit-wide pulse that is used to synchronize the first bit of the first symbol. The maximum clock rate is 50 MHz. The damage levels are $> +5.5$ and $< -0.5$V. SYMBOL SYNC can be used in two modes:

- When used as a symbol sync in conjunction with a data clock, the signal must be high during the first data bit of the symbol. The signal must be valid during the falling edge of the data clock signal and may be a single pulse or continuous.
- When the SYMBOL SYNC itself is used as the (symbol) clock, the CMOS falling edge is used to clock the DATA signal.

On signal generators with Option 1EM, this input is relocated to the rear panel.
Front Panel Display

Figure 1-2 shows the front panel display. The LCD screen displays data fields, annotations, key press results, softkey labels, error messages, and annunciators that represent various active signal generator functions.

1. Active Entry Area
The current active function is shown in this area. For example, if frequency is the active function, the current frequency setting will be displayed here. If the current active function has an increment value associated with it, that value is also displayed.

2. Frequency Area
The current frequency setting is shown in this portion of the display. Indicators are also displayed in this area when the frequency offset or multiplier is used, the frequency reference mode is turned on, or a source module is enabled.
3. Annunciators

The display annunciators show the status of some of the signal generator functions and indicate any error conditions. An annunciator position may be used by more than one function. This does not create a problem, because only one function that shares an annunciator position can be active at a time.

ΦM
This annunciator (E8257C and E8267C only) appears when phase modulation is on. If frequency modulation is on, the FM annunciator replaces ΦM.

ALC OFF
This annunciator appears when the ALC circuit is disabled. A second annunciator, UNLEVEL, appears in the same position if the ALC is enabled and cannot maintain the output level.

AM
This annunciator (E8257C and E8267C only) appears when amplitude modulation is on.

ARMED
This annunciator appears when a sweep has been initiated and the signal generator is waiting for the sweep trigger event.

ATTEN HOLD
This annunciator (Option 1E1 or E8267C only) appears when the attenuator hold function is on. When this function is on, the attenuator is held at its current setting.

DIG BUS
This annunciator appears when the Digital Bus is active, and the internal oven reference oscillator is not cold (they appear in the same location).

ENVLP
This annunciator appears if a burst condition exists, such as when marker 2 is set to enable RF blanking in the Dual ARB format.

ERR
This annunciator appears when an error message is in the error queue. This annunciator does not turn off until you either view all the error messages or cleared the error queue. To access error messages, press Utility > Error Info.

EXT
This annunciator appears when external leveling is on.

EXT1 LO/HI
This annunciator (E8257C and E8267C only) appears as either EXT1 LO or EXT1 HI, when the ac-coupled signal to the EXT 1 INPUT is <0.97 Vp or >1.03 Vp.

EXT2 LO/HI
This annunciator (E8257C and E8267C only) is displayed as either EXT2 LO or EXT2 HI. This annunciator appears when the ac-coupled signal to the EXT 2 INPUT is <0.97 Vp or >1.03 Vp.

EXT REF
This annunciator appears when an external frequency reference is applied.

FM
This annunciator (E8257C and E8267C only) appears when frequency modulation is turned on. If phase modulation is turned on, the ΦM annunciator will replace FM.

I/Q
This annunciator (E8267C with Option 002/602 only) appears when I/Q modulation is turned on.

L
This annunciator appears when the signal generator is in listener mode and is receiving information or commands over the RS-232, GPIB, or VXI-11 LAN interface.
MOD ON/OFF
This annunciator (E8257C and E8267C only) which is always present on the display, indicates whether active modulation formats have been enabled or disabled with the Mod On/Off hardkey. Pressing the Mod On/Off hardkey enables or disables all active modulation formats (AM, FM, ΦM, Pulse, or I/Q) that are applied to the output carrier signal available through the RF Output connector. The Mod On/Off hardkey does not set up or activate an AM, FM, ΦM, Pulse, or I/Q format; each individual modulation format must still be set up and activated (for example, AM > AM On) or nothing will be applied to the output carrier signal when the Mod On/Off hardkey is enabled.

OVEN COLD
This annunciator (Option UNR only) appears when the temperature of the internal oven reference oscillator has dropped below an acceptable level. When this annunciator is on, frequency accuracy is degraded. This condition should occur only if the signal generator is disconnected from line power.

PULSE
This annunciator (E8257C and E8267C only) appears when pulse modulation is on.

R
This annunciator appears when the signal generator is remotely controlled over the GPIB, RS-232, or VXI-11/Sockets LAN interface (TELNET operation does not activate the R annunciator). When the R annunciator is on, the front panel keys are disabled, except for the Local key and the line power switch. For information on remote operation, refer to the Programming Guide.

RF ON/OFF
This annunciator indicates when the RF and microwave signal is present (RF ON) at the RF OUTPUT, or if the RF and microwave signal is not present (RF OFF) at the RF OUTPUT. Either condition of this annunciator is always visible in the display.

S
This annunciator appears when the signal generator has generated a service request (SRQ) over the RS-232, GPIB, or VXI-11 LAN interface.

SWEEP
This annunciator appears when the signal generator is in list, step, or ramp sweep mode; ramp sweep is available with Option 007 only. List mode is when the signal generator can jump from point to point in a list (hop list); the list is traversed in ascending or descending order. The list can be a frequency list, a power level list, or both. Step mode is when a start, stop, and step value (frequency or power level) are defined and the signal generator produces signals that start at the start value and increment by the step value until it reaches the stop value. Ramp sweep mode (Option 007 only) is when a start and stop value (frequency or power level) are defined and the signal generator produces signals that start at the start value and produce a continuous output until it reaches the stop value.

T
This annunciator appears when the signal generator is in talker mode and is transmitting information over the GPIB, RS-232, or VXI-11 LAN interface.

UNLEVEL
This annunciator appears when the signal generator is unable to maintain the correct output level. The UNLEVEL annunciator is not necessarily an indication of instrument failure. Unleveled conditions can occur during normal operation. A second annunciator, ALC OFF, will appear in the same position when the ALC circuit is disabled.
Signal Generator Overview

Front Panel Display

4. Digital Modulation Annunciators

All digital modulation annunciators (E8267C PSG with Option 002/602 only) appear in this location. These annunciators appear only when the modulation is active, and only one digital modulation can be active at any given time.

<table>
<thead>
<tr>
<th>ARB</th>
<th>Dual Arbitrary Waveform Generator</th>
<th>M-TONE</th>
<th>Multitone Waveform Generator</th>
</tr>
</thead>
<tbody>
<tr>
<td>CUSTOM</td>
<td>Custom Real Time I/Q Baseband</td>
<td>T-TONE</td>
<td>Two-Tone Waveform Generator</td>
</tr>
<tr>
<td>DIGMOD</td>
<td>Custom Arb Waveform Generator</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

5. Amplitude Area

The current output power level setting is shown in this portion of the display. Indicators are also displayed in this area when amplitude offset is used, amplitude reference mode is turned on, external leveling mode is enabled, a source module is enabled, and when user flatness is enabled.

6. Error Message Area

Abbreviated error messages are reported in this space. When multiple error messages occur, only the most recent message remains displayed. Reported error messages with details can be viewed by pressing Utility > Error Info.

7. Text Area

This text area of the display:

- show signal generator status information, such as the modulation status, sweep lists, and file catalogs
- displays the tables
- enables you to perform functions such as managing information, entering information, and displaying or deleting files

8. Softkey Label Area

The labels in this area define the function of the softkeys located immediately to the right of the label. The softkey label may change depending upon the function selected.
Rear Panel

The signal generator rear panel (Figure 1-3) provides input, output, and remote interface connections. Descriptions are provided for each rear panel connector. When Option 1EM is added, all front panel connectors are moved to the real panel; for a description of these connectors, see “Front Panel” on page 6.

![Rear Panel Diagram](image)

**Figure 1-3 Rear Panel Diagram**
Signal Generator Overview

Rear Panel

1. AC Power Receptacle

The ac line voltage is connected here. The power cord receptacle accepts a three-pronged power cable that is shipped with the signal generator.

2. GPIB

This GPIB interface allows listen and talk capability with compatible IEEE 488.2 devices.

3. AUXILIARY INTERFACE

This 9-pin D-subminiature female connector is an RS-232 serial port that can be used for serial communication and Master/Slave source synchronization.

<table>
<thead>
<tr>
<th>Pin Number</th>
<th>Signal Description</th>
<th>Signal Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>No Connection</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Receive Data</td>
<td>RECV</td>
</tr>
<tr>
<td>3</td>
<td>Transmit Data</td>
<td>XMIT</td>
</tr>
<tr>
<td>4</td>
<td>+5V</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Ground, 0V</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>No Connection</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Request to Send</td>
<td>RTS</td>
</tr>
<tr>
<td>8</td>
<td>Clear to Send</td>
<td>CTS</td>
</tr>
<tr>
<td>9</td>
<td>No Connection</td>
<td></td>
</tr>
</tbody>
</table>

4. LAN

This LAN interface allows ethernet local area network communication through a 10Base-T LAN cable. The yellow LED on the interface illuminates when data transmission (transfer/receive) is present. The green LED illuminates when there is a delay in data transmission or no data transmission is present.
5. STOP SWEEP IN/OUT

This female BNC connector (Option 007 only) provides an open-collector, TTL-compatible input/output signal that is used during ramp sweep operation. It provides low level (nominally 0V) output during sweep retrace and band-cross intervals. It provides high level (nominally +5V) output during the forward portion of sweep. Sweep stops when this input/output connector is grounded externally.

6. Z-AXIS BLANK/MKRS

This female BNC connector (Option 007 only) supplies a +5V (nominal) level during retrace and band-switch intervals of a step, list, or ramp sweep. During ramp sweep, this female BNC connector supplies a –5V (nominal) level when the RF frequency is at a marker frequency and intensity marker mode is on. This connection is most commonly used to interface with an Agilent 8757D scalar network analyzer.

7. SWEEP OUT

This female BNC connector outputs a voltage proportional to the RF power or frequency sweep ranging from 0 V at the start of sweep and goes to +10 V (nominal) at the end of sweep, regardless of sweep width. The output impedance is less than 1Ω and can drive a 2 kΩ load.

When connected to an Agilent Technologies 8757D network analyzer, it generates a selectable number of equally spaced 1 ms 10 V pulses (nominal) across a ramp (analog) sweep. The number of pulses can be set from 101 to 1601 by remote control through the 8757D.

8. TRIGGER OUT

This female BNC connector, in step/list sweep mode, outputs a TTL signal that is high at the start of a dwell sequence or when waiting for a point trigger in manual sweep mode. The signal is low when the dwell is over or when a point trigger is received. In ramp sweep mode, the output provides 1601 equally-spaced 1 µs pulses (nominal) across a ramp sweep. When using LF Out, the output provides a 2 µs pulse at the start of LF sweep.

9. TRIGGER IN

This female BNC connector accepts a 3.3V CMOS signal that is used for point-to-point triggering in manual sweep mode or a low-frequency (LF) sweep in external sweep mode. Triggering can occur on either the positive or negative edge of the signal start. The damage level is \( \leq -4 \text{ V} \) or \( \geq +10 \text{ V} \).

10. SOURCE SETTLED

This female BNC connector provides an indication when the signal generator has settled to a new frequency or power level. A low indicates that the source has settled.
11. EVENT 1

This female BNC connector (E8267C only) is used with an internal baseband generator (Option 002/602); on signal generators without Option 002/602, this female BNC connector is non-functional.

In real-time mode, the EVENT 1 connector outputs a pattern or frame synchronization pulse for triggering or gating external equipment. It may be set to start at the beginning of a pattern, frame, or timeslot and is adjustable to within ± one timeslot with one bit resolution.

In arbitrary waveform mode, the EVENT 1 connector outputs a timing signal generated by Marker 1. A marker (3.3V CMOS high when positive polarity is selected; 3.3V CMOS low when negative polarity is selected) is output on the EVENT 1 connector whenever a Marker 1 is turned on in the waveform. The damage levels for this connector are > +8V and < −4V.

12. EVENT 2

This female BNC connector (E8267C only) is used with an internal baseband generator (Option 002/602); on signal generators without Option 002/602, this female BNC connector is non-functional. In real-time mode, the EVENT 2 connector outputs a data enable signal for gating external equipment. This is applicable when external data is clocked into internally generated timeslots.

Data is enabled when the signal is low. In arbitrary waveform mode, the EVENT 2 connector outputs a timing signal generated by Marker 2. A marker (3.3V CMOS high when positive polarity is selected; 3.3V CMOS low when negative polarity is selected) is output on the EVENT 2 connector whenever a Marker 2 is turned on in the waveform. The damage levels for this connector are > +8V and < −4V.

13. PATTERN TRIG IN

This female BNC connector (E8267C only) is used with an internal baseband generator (Option 002/602); on signal generators without Option 002/602, this female BNC connector is non-functional. This connector accepts a signal that triggers an internal pattern or frame generator to start single pattern output. Minimum pulse width is 100 ns. Damage levels are > +5.5 and < −0.5V.

14. BURST GATE IN

This female BNC connector (E8267C only) is used with an internal baseband generator (Option 002/602); on signal generators without Option 002/602, this female BNC connector is non-functional. This connector accepts a signal for gating burst power. Burst gating is used when you are externally supplying data and clock information.

The input signal must be synchronized with the external data input that will be output during the burst. The burst power envelope and modulated data are internally delayed and re-synchronized. The input signal must be CMOS high for normal burst RF power or CW RF output power and CMOS low for RF off. Damage levels are > +5.5 and < −0.5V.
15. AUXILIARY I/ O

This female 37-pin connector (E8267C only) is active only on instruments with an internal baseband generator (Option 002/602); on signal generators without Option 002/602, this connector is non-functional. This connector provides access to the inputs and outputs described in the following figure.

**Figure 1-5 Auxiliary I/ O Connector (Female 37-Pin)**

<table>
<thead>
<tr>
<th>Pin</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>19</td>
<td>EVENT 3</td>
</tr>
<tr>
<td>18</td>
<td>EVENT 4</td>
</tr>
<tr>
<td>17</td>
<td>PATT TRIG IN 2</td>
</tr>
<tr>
<td>16</td>
<td>ALT PWR IN</td>
</tr>
<tr>
<td>15</td>
<td>GND</td>
</tr>
<tr>
<td>14</td>
<td>GND</td>
</tr>
<tr>
<td>13</td>
<td>GND</td>
</tr>
<tr>
<td>12</td>
<td>GND</td>
</tr>
<tr>
<td>11</td>
<td>GND</td>
</tr>
<tr>
<td>10</td>
<td>DATA OUT</td>
</tr>
<tr>
<td>9</td>
<td>DATA CLK OUT</td>
</tr>
<tr>
<td>8</td>
<td>SYM SYNC OUT</td>
</tr>
<tr>
<td>20</td>
<td>A</td>
</tr>
<tr>
<td>1</td>
<td>B</td>
</tr>
</tbody>
</table>

- **View looking into rear panel connector**
- **Used with an internal baseband generator.** In arbitrary waveform mode, this pin outputs a timing signal generated by Marker 3. A marker (3.3V CMOS high when positive polarity is selected; 3.3V CMOS low when negative polarity is selected) is output on this pin when a Marker 3 is turned on in the waveform. Reverse damage levels: > +8V and < −4V.
- **Accepts a signal that triggers an internal pattern or frame generator to start single pattern output.** Minimum pulse width: 100 ns. Damage levels: > +5.5 and < −0.5V
- **Used with an internal baseband generator.** This pin accepts a CMOS signal for synchronization of external data and alternate power signal timing. Damage levels are > +8V and < −4V.
- **Used with an internal baseband generator.** This pin outputs data (CMOS) from the internal data generator or the externally supplied signal at data input.
- **Used with an internal baseband generator.** This pin relays a CMOS bit clock signal for synchronizing serial data.
- **Used with an internal baseband generator.** This pin outputs the CMOS symbol clock for symbol synchronization, one data clock period wide.
16. Digital Bus

This is a proprietary bus used for Agilent Baseband Studio products, which require an E8267C with Option 602. This connector is not operational for general purpose customer use. Signals are present only when a Baseband Studio option is installed (for details, refer to www.agilent.com/find/basebandstudio). The Dig Bus annunciator appears on the display when the Digital Bus is active (and the internal oven reference oscillator is not cold—they appear in the same location).

17. WIDEBAND I INPUT

This female BNC connector (E8267C only) is used with wideband external I/Q inputs (Option 015). It accepts wide-band AM and allows direct high-bandwidth analog inputs to the I/Q modulator in the 3.2–20 GHz range. This input is not calibrated and accepts a 0 dBm maximum power. On signal generators without Option 015, this connector is non-functional.

18. WIDEBAND Q INPUT

This female BNC connector (E8267C only) is used with wideband external I/Q inputs (Option 015); on signal generators without Option 015, this female BNC connector is non-functional. This female BNC connector allows direct high-bandwidth analog inputs to the I/Q modulator in the 3.2 to 20 GHz frequency range. This input is not calibrated and accepts a 0 dBm maximum power.

19. COH (COHERENT CARRIER OUTPUT)

This female SMA connector (E8267C only) outputs an RF signal that is phase coherent with the signal generator carrier. The coherent carrier connector outputs RF that is not modulated with AM, pulse, or I/Q modulation, but is modulated with FM or \( \Phi M \) (when FM or \( \Phi M \) are on).

The output power is nominally 0 dBm. The output frequency range is from 249.99900001 MHz to 3.2 GHz; this output is not useful for output frequencies > 3.2 GHz. If the RF output frequency is below 249.99900001 MHz, the coherent carrier output signal will have the following frequency:

- Frequency of coherent carrier = (1E9 – Frequency of RF output) in Hz.
- Damage levels are 20 Vdc and 13 dBm reverse RF power.

20. I OUT

This female BNC connector (E8267C only) can be used with an internal baseband generator (Option 002/602) to output the analog, in-phase component of I/Q modulation; on signal generators without Option 002/602, this female BNC connector can be used to output the in-phase component of an external I/Q modulation that has been fed into the I input connector. The nominal output impedance of the I OUT connector is 50\( \Omega \), dc-coupled.
21. I-bar OUT

This female BNC connector (E8267C only) can be used with an internal baseband generator (Option 002/602) to output the complement of the analog, in-phase component of I/Q modulation; on signal generators without Option 002/602, this female BNC connector can be used to output the complement of the in-phase component of an external I/Q modulation that has been fed into the I input connector.

I-bar OUT is used in conjunction with I OUT to provide a balanced baseband stimulus. Balanced signals are signals present in two separate conductors that are symmetrical relative to ground and are opposite in polarity (180 degrees out of phase). The nominal output impedance of the I-bar OUT connector is 50Ω, dc-coupled.

22. Q OUT

This female BNC connector (E8267C only) can be used with an internal baseband generator (Option 002/602) to output the analog, quadrature-phase component of I/Q modulation; on signal generators without Option 002/602, this female BNC connector can be used to output the quadrature-phase component of an external I/Q modulation that has been fed into the Q input connector. The nominal output impedance of the Q OUT connector is 50Ω, dc-coupled.

23. Q-bar OUT

This female BNC connector (E8267C only) can be used with an internal baseband generator (Option 002/602) to output the complement of the analog, quadrature-phase component of I/Q modulation; on signal generators without Option 002/602, this female BNC connector can be used to output the complement of the quadrature-phase component of an external I/Q modulation that has been fed into the Q input connector.

Q-bar OUT is used in conjunction with Q OUT to provide a balanced baseband stimulus. Balanced signals are signals present in two separate conductors that are symmetrical relative to ground and are opposite in polarity (180 degrees out of phase). The nominal output impedance of the Q-bar OUT connector is 50Ω, dc-coupled.

24. BASEBAND GEN REF IN

This female BNC connector (E8267C only) is used with an internal baseband generator (Option 002/602); on signal generators without Option 002/602, this female BNC connector is non-functional. This connector accepts a 0 to +20 dBm sine wave or TTL square wave signal from an external timebase reference. This external timebase reference clock is used by the internal baseband generator for both component and receiver test applications (only the internal baseband generator can be locked to this external reference; the RF frequency remains locked to the 10 MHz reference).

This connector accepts rates from 250 kHz through 100 MHz; the nominal input impedance is 50Ω at 13 MHz, ac-coupled. The internal clock for the arbitrary waveform generator is locked to this signal when external reference is selected in the ARB setup. The minimum pulse width must be > 10 ns. The damage levels are > +8V and < −8V.
Signal Generator Overview

Rear Panel

25. SMI (SOURCE MODULE INTERFACE)
This interface is used to connect to compatible Agilent Technologies 83550 Series mm-wave source modules.

26. 10 MHz OUT
This female BNC connector outputs a nominal signal level of > +4 dBm and has an output impedance of \(50\Omega\). The accuracy is determined by the timebase used.

27. 10 MHz IN
This female BNC connector accepts an external timebase reference input signal level of >−3 dBm. The reference must be 1, 2, 2.5, 5, or 10 MHz, within ±1 ppm. The signal generator detects when a valid reference signal is present at this connector and automatically switches from internal to external reference operation. The nominal input impedance is \(50\Omega\). For Option UNR, this BNC connector accepts a signal with a nominal input level of 5 ±5 dBm. The external frequency reference must be 10 MHz, within ±1 ppm. The nominal input impedance is \(50\Omega\) with a damage level of ≥ 10 dBm.

28. 10 MHz EFC (Option UNR)
This female BNC input connector accepts an external dc voltage, ranging from −5 to +5V, for electronic frequency control (EFC) of the internal 10 MHz reference oscillator. This voltage inversely tunes the oscillator about its center frequency approximately −0.0025 ppm/V. The input resistance is greater than 1 M\(\Omega\). When not in use, this connector should be shorted using the supplied shorting cap to assure a stable operating frequency.
2 Basic Operation

In the following sections, this chapter describes operations common to all Agilent PSG signal generators:

- “Using Table Editors” on page 26
- “Configuring a Continuous Wave RF Output” on page 28
- “Configuring a Swept RF Output” on page 31
- “Using Ramp Sweep (Option 007)” on page 37
- “Extending the Frequency Range with a mm-Wave Source Module” on page 47
- “Turning On a Modulation Format” on page 50
- “Applying a Modulation Format to the RF Output” on page 51
- “Using Data Storage Functions” on page 52
- “Enabling Options” on page 57
Using Table Editors

Table editors simplify configuration tasks, such as creating a list sweep. This section provides information to familiarize you with basic table editor functionality using the List Mode Values table editor as an example.

Press **Preset > Sweep/List > Configure List Sweep**.

The signal generator displays the List Mode Values table editor, as shown below.

**Figure 2-1**

- **Active Function Area** displays the active table item while its value is edited
- **Cursor** an inverse video identifier used to highlight specific table items for selection and editing
- **Table Softkeys** select table items, preset table values, and modify table structures
- **Table Items** values arranged in numbered rows and titled columns (The columns are also known as data fields. For example, the column below the Frequency title is known as the Frequency data field).
Table Editor Softkeys

The following table editor softkeys are used to load, navigate, modify, and store table item values.

- **Edit Item**
  - displays the selected item in the active function area of the display where the item’s value can be modified
- **Insert Row**
  - inserts an identical row of table items above the currently selected row
- **Delete Row**
  - deletes the currently selected row
- **Goto Row**
  - opens a menu of softkeys (Enter, Goto Top Row, Goto Middle Row, Goto Bottom Row, Page Up, and Page Down) used to quickly navigate through the table items
- **Insert Item**
  - inserts an identical item in a new row below the currently selected item
- **Delete Item**
  - deletes the item from the bottom row of the currently selected column
- **Page Up** and **Page Down**
  - displays table items that occupy rows outside the limits of the ten-row table display area
- **More (1 of 2)**
  - accesses Load/Store and its associated softkeys
- **Load/Store**
  - opens a menu of softkeys (Load From Selected File, Store To File, Delete File, Goto Row, Page Up, and Page Down) used to load table items from a file in the memory catalog, or to store the current table items as a file in the memory catalog

Modifying Table Items in the Data Fields

1. If not already displayed, open the List Mode Values table editor (shown in Figure 2-1 on page 26):
   - Press Preset > Sweep/ List > Configure List Sweep
2. Use the arrow keys or the knob to move the table cursor over the desired item.
   - In Figure 2-1, the first item in the Frequency data field is selected.
3. Press **Edit Item**.
   - The selected item is displayed in the active function area of the display.
4. Use the knob, arrow keys, or the numeric keypad to modify the value.
5. Press **Enter**.
   - The modified item is now displayed in the table.
Basic Operation
Configuring the RF Output

Configuring the RF Output

This section provides information on how to create continuous wave and swept RF (on page 31) outputs. It also has information on using a mm-Wave source module to extend the signal generator’s frequency range (see page 47).

Configuring a Continuous Wave RF Output

These procedures demonstrate how to set the following parameters:

- RF output frequency
- frequency reference and frequency offset (on page 29)
- RF output amplitude (on page 30)
- amplitude reference and amplitude offset (page 30)

Setting the RF Output Frequency

Set the RF output frequency to 700 MHz, and increment or decrement the output frequency in 1 MHz steps.

1. Return the signal generator to the factory-defined state: Press Preset.

   NOTE You can change the preset condition of the signal generator to a user-defined state. For these examples, however, use the factory-defined preset state (set the Preset Normal User softkey in the Utility menu to Normal).

2. Observe the FREQUENCY area of the display (in the upper left-hand corner).
   The value displayed is the maximum specified frequency of the signal generator.

   The RF On/Off hardkey must be pressed before the RF signal is available at the RF OUTPUT connector. The display annunciator changes from RF OFF to RF ON. The maximum specified frequency should be output at the RF OUTPUT connector (at the signal generator’s minimum power level).

4. Press Frequency > 700 > MHz.
   The 700 MHz RF frequency should be displayed in the FREQUENCY area of the display and also in the active entry area.

5. Press Frequency > Incr Set > 1 > MHz.
   This changes the frequency increment value to 1 MHz.
Basic Operation
Configuring the RF Output

6. Press the up arrow key.

   Each press of the up arrow key increases the frequency by the increment value last set with the **Incr Set** hardkey. The increment value is displayed in the active entry area.

7. The down arrow decreases the frequency by the increment value set in the previous step. Practice stepping the frequency up and down in 1 MHz increments.

   You can also adjust the RF output frequency using the knob. As long as frequency is the active function (the frequency is displayed in the active entry area), the knob will increase and decrease the RF output frequency.

8. Use the knob to adjust the frequency back to 700 MHz.

Setting the Frequency Reference and Frequency Offset

The following procedure sets the RF output frequency as a reference frequency to which all other frequency parameters are relative. The frequency initially shown on the display is 0.00 Hz (the frequency output by the hardware minus the reference frequency). Although the display changes, the frequency output does not change. Any subsequent frequency changes are shown as incremental or decremental to 0 Hz.

1. Preset the signal generator: Press: **Preset**

2. Set the frequency reference to 700 MHz:

   Press: **Frequency > 700 > MHz > More (1 of 3) > Freq Ref Set**.

   This activates the frequency reference mode and sets the current output frequency (700 MHz) as the reference value. The FREQUENCY area displays 0.000 Hz, which is the frequency output by the hardware (700 MHz) minus the reference value (700 MHz). The **REF** indicator activates and the **Freq Ref Off On** softkey toggles to On.

3. Turn on the RF output: Press **RF On/ Off**.

   The display annunciator changes from **RF OFF** to **RF ON**. The RF frequency at the RF OUTPUT connector is 700 MHz.

4. Set the frequency increment value to 1 MHz: Press **Frequency > Incr Set > 1 > MHz**.

5. Increment the output frequency by 1 MHz: Press the up arrow key.

   The FREQUENCY area display changes to show 1.000 000 000 MHz, which is the frequency output by the hardware (700 MHz + 1 MHz) minus the reference frequency (700 MHz). The frequency at the RF OUTPUT changes to 701 MHz.

6. Enter a 1 MHz offset: Press **More (1 of 3) > Freq Offset > 1 > MHz**.

   The FREQUENCY area displays 2.000 000 00 MHz, which is the frequency output by the hardware (701 MHz) minus the reference frequency (700 MHz) plus the offset (1 MHz). The **OFFS** indicator activates. The frequency at the RF OUTPUT connector is still 701 MHz.
Basic Operation

Configuring the RF Output

Setting the RF Output Amplitude

1. Preset the signal generator: Press Preset.
   The AMPLITUDE area of the display shows the minimum power level of the signal generator. This is the normal preset RF output amplitude.

2. Turn on the RF output: Press RF On/Off.
   The display annunciator changes to RF ON. At the RF OUTPUT connector, the RF signal is output at the minimum power level.

3. Change the amplitude to −20 dBm: Press Amplitude > −20 > dBm.
   The new output power displays in the AMPLITUDE area of the display and in the active entry area. Until you press a different front panel function key, amplitude remains the active function. You can also change the amplitude using the up and down arrow keys or the knob.

Setting the Amplitude Reference and Amplitude Offset

The following procedure sets the RF output power as an amplitude reference to which all other amplitude parameters are relative. The amplitude initially shown on the display is 0 dB (the power output by the hardware minus the reference power). Although the display changes, the output power does not change. Any subsequent power changes are shown as incremental or decremental to 0 dB.

1. Press Preset.

2. Set the amplitude to −20 dBm: Press Amplitude > −20 > dBm.

3. Activate the amplitude reference mode and set the current output power (−20 dBm) as the reference value: Press More (1 of 2) > Ampl Ref Set.
   The AMPLITUDE area displays 0.00 dB, which is the power output by the hardware (−20 dBm) minus the reference value (−20 dBm). The REF indicator activates and the Ampl Ref Off On softkey toggles On.

4. Turn the RF output on: Press RF On/Off.
   The display annunciator changes to RF ON. The power at the RF OUTPUT connector is −20 dBm.

5. Change the amplitude increment value to 10 dB: Press Incr Set > 10 > dB.

6. Use the up arrow key to increase the output power by 10 dB.
   The AMPLITUDE area displays 10.00 dB, which is the power output by the hardware (−20 dBm plus 10 dBm) minus the reference power (−20 dBm). The power at the RF OUTPUT connector changes to −10 dBm.

7. Enter a 10 dB offset: Press Ampl Offset > 10 > dB.
   The AMPLITUDE area displays 20.00 dB, which is the power output by the hardware (−10 dBm) minus the reference power (−20 dBm) plus the offset (10 dB). The OFFS indicator activates. The power at the RF OUTPUT connector is still −10 dBm.
Configuring a Swept RF Output

A PSG signal generator has up to three sweep types: step sweep, list sweep, and ramp sweep (Option 007).

NOTE	List sweep data cannot be saved within an instrument state, but *can* be saved to the memory catalog. For instructions on saving list sweep data, see “Storing Files to the Memory Catalog” on page 53.

During swept RF output, the FREQUENCY and AMPLITUDE areas of the signal generator's display are deactivated, depending on what is being swept.

Step sweep (see page 32) and ramp sweep (see page 34) provide a linear progression through the start-to-stop frequency and/or amplitude values, while list sweep enables you to create a list of arbitrary frequency, amplitude, and dwell time values and sweep the RF output based on that list.

The list sweep example uses the points created in the step sweep example as the basis for a new list sweep.

Ramp sweep (see page 37) is faster than step or list sweep, and is designed to work with an 8757D scalar network analyzer.
Basic Operation

Configuring the RF Output

Using Step Sweep

Step sweep provides a linear progression through the start-to-stop frequency and/or amplitude values. You can toggle the direction of the sweep, up or down. When the **Sweep Direction Down Up** softkey is set to Up, values are swept from the start amplitude/frequency to the stop amplitude/frequency. When set to Down, values are swept from the stop amplitude/frequency to the start amplitude/frequency.

When a step sweep is activated, the signal generator sweeps the RF output based on the values entered for RF output start and stop frequencies and amplitudes, a number of equally spaced points (steps) to dwell upon, and the amount of dwell time at each point; dwell time is the minimum period of time after the settling time that the signal generator will remain at its current state. The frequency, amplitude, or frequency and amplitude of the RF output will sweep from the start amplitude/frequency to the stop amplitude/frequency, dwelling at equally spaced intervals defined by the **# Points** softkey value.

To Configure a Single Step Sweep

In this procedure, you create a step sweep with nine, equally-spaced points, and the following parameters:

- frequency range from 500 MHz to 600 MHz
- amplitude from $-20\text{ dBm}$ to $0\text{ dBm}$
- dwell time 500 ms at each point

1. Press **Preset**.
2. Press **Sweep/ List**.
   This opens a menu of sweep softkeys.
3. Press **Sweep Repeat Single Cont**.
   This toggles the sweep repeat from continuous to single.
4. Press **Configure Step Sweep**.
5. Press **Freq Start > 500 > MHz**.
   This changes the start frequency of the step sweep to 500 MHz.
6. Press **Freq Stop > 600 > MHz**.
   This changes the stop frequency of the step sweep to 600 MHz.
7. Press **Ampl Start > -20 > dBm**.
   This changes the amplitude level for the start of the step sweep.
8. Press **Ampl Stop > 0 > dBm**.
   This changes the amplitude level for the end of the step sweep.
9. Press **# Points > 9 > Enter**.
   This sets the number of sweep points to nine.
10. Press **Step Dwell > 500 > msec**.
    This sets the dwell time at each point to 500 milliseconds.
   This sets the step sweep to sweep both frequency and amplitude data. Selecting this softkey returns you
to the previous menu and turns on the sweep function.

   The display annunciator changes from RF OFF to RF ON.

   A single sweep of the frequencies and amplitudes configured in the step sweep is executed and available
at the RF OUTPUT connector. On the display, the SWEEP annunciator appears for the duration of the
sweep and a progress bar shows the progression of the sweep. The Single Sweep softkey can also be used
to abort a sweep in progress. To see the frequencies sweep again, press Single Sweep to trigger the
sweep.

To Configure a Continuous Step Sweep

Press Sweep Repeat Single Cont.

This toggles the sweep from single to continuous. A continuous repetition of the frequencies and amplitudes
configured in the step sweep are now available at the RF OUTPUT connector. The SWEEP annunciator
appears on the display, indicating that the signal generator is sweeping and progression of the sweep is
shown by a progress bar.
Basic Operation

Configuring the RF Output

Using List Sweep

List sweep enables you to create a list of arbitrary frequency, amplitude, and dwell time values and sweep the RF output based on the entries in the List Mode Values table.

Unlike a step sweep that contains linear ascending/descending frequency and amplitude values, spaced at equal intervals throughout the sweep, list sweep frequencies and amplitudes can be entered at unequal intervals, nonlinear ascending/descending, or random order.

For convenience, the List Mode Values table can be copied from a previously configured step sweep. Each step sweep point’s associated frequency, amplitude and dwell time values are entered into a row in the List Mode Values table, as the following example illustrates.

To Configure a Single List Sweep Using Step Sweep Data

In this procedure, you will leverage the step sweep points and change the sweep information by editing several points in the List Mode Values table. For information on using tables, see “Using Table Editors” on page 26.

1. Press **Sweep Repeat Single Cont**.
   This toggles the sweep repeat from continuous to single. The **SWEEP** annunciator is turned off. The sweep will not occur until it is triggered.

2. Press **Sweep Type List Step**.
   This toggles the sweep type from step to list.

3. Press **Configure List Sweep**.
   This opens another menu displaying softkeys that you will use to create the sweep points. The display shows the current list data. (When no list has been previously created, the default list contains one point set to the signal generator’s maximum frequency, minimum amplitude, and a dwell time of 2 ms.)

4. Press **More (1 of 2) > Load List From Step Sweep > Confirm Load From Step Data**.
   The points you defined in the step sweep are automatically loaded into the list.
To Edit List Sweep Points

1. Press Return > Sweep > Off.

   Turning the sweep off allows you to edit the list sweep points without generating errors. If sweep remains on during editing, errors occur whenever one or two point parameters (frequency, power, and dwell) are undefined.

2. Press Configure List Sweep.

   This returns you to the sweep list table.

3. Use the arrow keys to highlight the dwell time in row 1.

4. Press Edit Item.

   The dwell time for point 1 becomes the active function.

5. Press 100 > msec.

   This enters 100 ms as the new dwell time value for row 1. Note that the next item in the table (in this case, the frequency value for point 2) becomes highlighted after you press the terminator softkey.

6. Using the arrow keys, highlight the frequency value in row 4.

7. Press Edit Item > 545 > MHz.

   This changes the frequency value in row 4 to 545 MHz.

8. Highlight any column in the point 7 row and press Insert Row.

   This adds a new point between points 7 and 8. A copy of the point 7 row is placed between points 7 and 8, creating a new point 8, and renumbering the successive points.

9. Highlight the frequency item for point 8, then press Insert Item.

   Pressing Insert Item shifts frequency values down one row, beginning at point 8. Note that the original frequency values for both points 8 and 9 shift down one row, creating an entry for point 10 that contains only a frequency value (the power and dwell time items do not shift down).

   The frequency for point 8 is still active.

10. Press 590 > MHz.

11. Press Insert Item > -2.5 > dBm.

    This inserts a new power value at point 8 and shifts down the original power values for points 8 and 9 by one row.

12. Highlight the dwell time for point 9, then press Insert Item.

    A duplicate of the highlighted dwell time is inserted for point 9, shifting the existing value down to complete the entry for point 10.
Basic Operation

Configuring the RF Output

To Configure a Single List Sweep

1. Press **Return > Sweep > Freq & Ampl**
   - This turns the sweep on again. No errors should occur if all parameters for every point have been defined in the previous editing process.

2. Press **Single Sweep**.
   - The signal generator will single sweep the points in your list. The SWEEP annunciator activates during the sweep.

3. Press **More (1 of 2) > Sweep Trigger > Trigger Key**.
   - This sets the sweep trigger to occur when you press the Trigger hardkey.

4. Press **More (2 of 2) > Single Sweep**.
   - This arms the sweep. The ARMED annunciator is activated.

5. Press the **Trigger** hardkey.
   - The signal generator will single sweep the points in your list and the SWEEP annunciator will be activated during the sweep.

To Configure a Continuous List Sweep

Press **Sweep Repeat Single Cont**.

This toggles the sweep from single to continuous. A continuous repetition of the frequencies and amplitudes configured in the list sweep are now available at the RF OUTPUT connector. The SWEEP annunciator appears on the display, indicating that the signal generator is sweeping and progression of the sweep is shown by a progress bar.
Using Ramp Sweep (Option 007)

Ramp sweep provides a linear progression through the start-to-stop frequency and/or amplitude values. Ramp sweep is much faster than step or list sweep, and is designed to work with an 8757D scalar network analyzer. This section describes the ramp sweep capabilities available in PSG signal generators with Option 007. You will learn how to use basic ramp sweep, and how to configure a ramp sweep for a master/slave setup (see page 45).

Refer to the Programming Guide for an example program that uses pass-thru commands in a ramp sweep system (pass-thru commands enable you to temporarily interrupt ramp sweep system interaction so that you can send operating instructions to the PSG).

Using Basic Ramp Sweep Functions

This procedure demonstrates the following tasks (each task builds on the previous task):

- “Configuring a Frequency Sweep” on page 38
- “Using Markers” on page 40
- “Adjusting Sweep Time” on page 42
- “Using Alternate Sweep” on page 43
- “Configuring an Amplitude Sweep” on page 44
Basic Operation

Configuring the RF Output

Configuring a Frequency Sweep

1. Set up the equipment as shown in Figure 2-2.

NOTE
The PSG signal generator is not compatible with the GPIB system interface of an 8757A, 8757C, or 8757E. For these older scalar network analyzers, do not connect the GPIB cable in Figure 2-2. This method provides only a subset of 8757D functionality. See the PSG Data Sheet for details. Use the 8757A/C/E documentation instead of this procedure.

Figure 2-2 Equipment Setup

2. Turn on both the 8757D and the PSG.
3. On the 8757D, press SYSTEM > MORE > SWEEP MODE and verify that the SYSINTF softkey is set to ON.
   This ensures that the system interface mode is activated on the 8757D. The system interface mode enables the instruments to work as a system.
4. Press Utility > GPIB/RS-232 LAN to view the PSG’s GPIB address under the GPIB Address softkey. If you want to change it, press GPIB Address and change the value.
5. On the 8757D, press LOCAL > SWEEPER and check the GPIB address. If it does not match that of the PSG, change the value.
6. Preset either instrument.

Presetting one of the instruments should automatically preset the other as well. If both instruments do not preset, check the GPIB connection, GPIB addresses, and ensure the 8757D is set to system interface mode (`SYSINTF` set to ON).

The PSG automatically activates a 2 GHz to maximum frequency ramp sweep with a constant amplitude of 0 dBm. Notice that the `RF ON`, `Sweep`, and `Pulse` annunciators appear on the PSG display. The `Pulse` annunciator appears because the 8757D is operating in AC mode.

The PSG also switches its remote language setting to `8757D System`, allowing the PSG to talk to the 8757D during ramp sweep operations. You can confirm this by pressing `Utility > GPIB/RS-232 LAN` and observing the selection under the `Remote Language` softkey.

**NOTE**

During swept RF output, the `FREQUENCY` and/or `AMPLITUDE` areas of the signal generator’s display are deactivated, depending on what is being swept. In this case, since frequency is being swept, nothing appears in the `FREQUENCY` area of the display.

7. Press `Frequency > Freq CW`.

The current continuous wave frequency setting now controls the RF output and ramp sweep is turned off.

8. Press `Freq Start`.

The ramp sweep settings once again control the RF output and the CW mode is turned off. Pressing any one of the softkeys `Freq Start`, `Freq Stop`, `Freq Center`, or `Freq Span` activates a ramp sweep with the current settings.

**NOTE**

In a frequency ramp sweep, the start frequency must be lower than the stop frequency.

9. Adjust the settings for `Freq Center` and `Freq Span` so that the frequency response of the device under test (DUT) is clearly seen on the 8757D display.

Notice how adjusting these settings also changes the settings for the `Freq Start` and `Freq Stop` softkeys. You may need to rescale the response on the 8757D for a more accurate evaluation of the amplitude. Figure 2-3 on page 40 shows an example of a bandpass filter response.
Using Markers

1. Press **Markers**.

   This opens a table editor and associated marker control softkeys. You can use up to 10 different markers, labeled 0 through 9.

2. Press **Marker Freq** and select a frequency value within the range of your sweep.

   In the table editor, notice how the state for marker 0 automatically turns on. The marker also appears on the 8757D display.

3. Use the arrow keys to move the cursor in the table editor to marker 1 and select a frequency value within the range of your sweep, but different from marker 0.

   Notice that marker 1 is activated and is the currently selected marker, indicated by the marker arrow pointing down. As you switch between markers, using the arrow keys, you will notice that the selected marker’s arrow points down, while all others point up.

   Notice also that the frequency and amplitude data for the currently selected marker is displayed on the 8757D.

![Figure 2-3 Bandpass Filter Response on 8757D](image)
4. Move the cursor back to marker 0 and press **Delta Ref Set > Marker Delta Off** to On.

In the table editor, notice that the frequency values for each marker are now relative to marker 0. **Ref** appears in the far right column (also labeled **Ref**) to indicate which marker is the reference. Refer to **Figure 2-4**.

**Figure 2-4  Marker Table Editor**

5. Move the cursor back to marker 1 and press **Marker Freq**. Turn the front panel knob while observing marker 1 on the 8757D.

On the 8757D, notice that the displayed amplitude and frequency values for marker 1 are relative to marker 0 as the marker moves along the trace. Refer to **Figure 2-5**.
6. Press **Turn Off Markers**.

All active markers turn off. Refer to the *Key Reference* for information on other marker softkey functions.

**Adjusting Sweep Time**

1. Press **Sweep/List**.

This opens a menu of sweep control softkeys and displays a status screen summarizing all the current sweep settings.

2. Press **Configure Ramp/Step Sweep**.

Since ramp is the current sweep type, softkeys in this menu specifically control ramp sweep settings. When step is the selected sweep type, the softkeys control step sweep settings. Notice that the **Freq Start** and **Freq Stop** softkeys appear in this menu in addition to the **Frequency** hardkey menu.

   In auto mode, the sweep time automatically sets to the fastest allowable value. In manual mode, you can select any sweep time slower than the fastest allowable. The fastest allowable sweep time is dependent on the number of trace points and channels being used on the 8757D and the frequency span.

4. Press **Sweep Time** to Auto.

   The sweep time returns to its fastest allowable setting.

**Using Alternate Sweep**

1. Press the **Save** hardkey.

   This opens the table editor and softkey menu for saving instrument states. Notice that the **Select Reg** softkey is active. (For more information on saving instrument states refer to “Using the Instrument State Register” on page 54.)

2. Turn the front panel knob until you find an available register and press **SAVE**. Remember this saved register number. If no registers are available, you can write over an in-use register, by pressing **Re-SAVE**.

**NOTE**

When you are using the PSG in a system with an 8757 network analyzer, you are limited to using registers 1 through 9 in sequence 0 for saving and recalling states.

3. Press **Sweep/List > Configure Ramp/ Step Sweep** and enter new start and stop frequency values for the ramp sweep.

4. Press **Alternate Sweep Register** and turn the front panel knob to select the register number of the previously saved sweep state.

5. Press **Alternate Sweep Off On** to On.

   The signal generator alternates between the original saved sweep and the current sweep. You may need to adjust 8757D settings to effectively view both sweeps, such as setting channel 2 to measure sensor A. Refer to Figure 2-6.
Configuring the RF Output

Configuring an Amplitude Sweep

1. Press Return > Sweep > Off.
   
   This turns off both the current sweep and the alternate sweep from the previous task. The current CW settings now control the RF output.

2. Press Configure Ramp/Step Sweep.

3. Using the Ampl Start and Ampl Stop softkeys, set an amplitude range to be swept.

   
   The new amplitude ramp sweep settings control the RF output and the CW mode is turned off.
Configuring a Ramp Sweep for a Master/Slave Setup

This procedure shows you how to configure two PSGs and an 8757D to work in a master/slave setup.

1. Set up the equipment as shown in Figure 2-7. Use a 9-pin, D-subminiature, male RS-232 cable with the pin configuration shown in Figure 2-8 on page 46 to connect the auxiliary interfaces of the two PSGs. You can also order the cable (part number 8120-8806) from Agilent Technologies.

   By connecting the master PSG’s 10 MHz reference standard to the slave PSG’s 10 MHz reference input, the master’s timebase supplies the frequency reference for both PSGs.

![Figure 2-7 Master/Slave Equipment Setup](image-url)
2. Set up the slave PSG’s frequency and power settings.
   By setting up the slave first, you avoid synchronization problems.
3. Set up the master PSG’s frequency, power, and sweep time settings.
   The two PSGs can have different frequency and power settings for ramp sweep.
4. Set the slave PSG’s sweep time to match that of the master.
   Sweep times must be the same for both PSGs.
5. Set the slave PSG to continuous triggering.
   The slave must be set to continuous triggering, but the master can be set to any triggering mode.
6. On the slave PSG, press **Sweep/ List > Sweep Type > Sweep Control > Slave.**
   This sets the PSG to operate in slave mode.
7. On the master PSG, press **Sweep/ List > Sweep Type > Sweep Control > Master.**
   This sets the PSG to operate in master mode.
Extending the Frequency Range with a mm-Wave Source Module

The RF output frequency of the signal generator can be multiplied using an Agilent 83550 Series millimeter-wave source module. The signal generator/mm-wave source module’s output is automatically leveled when the instruments are connected. The output frequency range depends on the specific mm-wave source module.

NOTE
To ensure adequate RF amplitude at the mm-wave source module RF input, when using an E8267C PSG, E8247C PSG with Option 1EA, or E8257C PSG with Option 1EA, maximum amplitude loss through the adapters and cables connected between the signal generator’s RF output and the mm-wave source module’s RF input should be less than 1.5 dB.

Required Equipment

- Agilent 83550 Series millimeter-wave source module
- Agilent 8349B microwave amplifier

Signal generators without Option 1EA (E8247C PSG and E8257C PSG) require an Agilent 8349B microwave amplifier. Signal generators with Option 1EA can drive the output of millimeter-wave source modules to maximum specified power without a microwave amplifier.

- cables and adapters as required

Connect the Equipment

CAUTION
To prevent damage to the signal generator, turn off the line power to the signal generator before connecting the source module interface cable to the rear panel SOURCE MODULE interface connector.

1. Turn off the signal generator’s line power.
2. Connect the equipment as shown.
   - E8247C PSG and E8257C PSG without Option 1EA, use the setup in Figure 2-9.
   - E8267C PSG or E8247C PSG and E8257C PSG with Option 1EA, use the setup in Figure 2-10.
Setting the Signal Generator

1. Turn on the signal generator’s line power.

Upon power-up, the signal generator automatically:

- senses the mm-wave source module,
- switches the signal generator’s leveling mode to external/source module (power is leveled at the mm-wave source module output),
- sets the mm-wave source module frequency and amplitude to the source module’s preset values, and
- in the FREQUENCY and AMPLITUDE areas of the signal generator, displays the RF output frequency and amplitude values available at the mm-wave source module output.
Chapter 2 49

Basic Operation

Configuring the RF Output

Figure 2-10 Setup for E8267C PSG or E8247C PSG and E8257C PSG with Option 1EA

The MOD indicator in the FREQUENCY area and the M indicator in the AMPLITUDE area of the signal generator’s display indicate that the mm-wave source module is active.

NOTE Refer to the mm-wave source module specifications for the specific frequency and amplitude ranges.

2. If the RF OFF annunciator is displayed, press RF On/Off.

Leveled power should be available at the output of the millimeter-wave source module.

To obtain flatness-corrected power, refer to “Creating and Applying User Flatness Correction” on page 64.
**Modulating a Signal**

This section describes how to turn on a modulation format, and how to apply it to the RF output.

**Turning On a Modulation Format**

A modulation format can be turned on prior to or after setting the signal parameters.

1. Access the first menu within the modulation format.
   This menu displays a softkey that associates the format’s name with off and on. For example, **AM Off On**. For some formats, the off/on key may appear in additional menus other than the first one.

2. Press the modulation format off/on key until On highlights.

Figure 2-11 shows the portion of the AM modulation format’s first menu that displays the state of the modulation format, as well as the active modulation format annunciator.

The modulation format generates, but the carrier signal is not modulated until you apply it to the RF output (see page 51).

Depending on the modulation format, the signal generator may require a few seconds to build the signal. Within the digital formats (E8267C PSG with Option 002/602 only), you may see a BaseBand Reconfiguring status bar appear on the display. Once the signal is generated, an annunciator showing the name of the format appears on the display, indicating that the modulation format is active. For digital formats (E8267C PSG with Option 002/602 only), the I/Q annunciator appears in addition to the name of the modulation format.

---

**Figure 2-11** Example of AM Modulation Format Off and On

![Example of AM Modulation Format Off and On](image)

- **First AM Menu**
  - Modulation format is off

- **Active Modulation Format Annunciator**
  - Modulation format is on
Applying a Modulation Format to the RF Output

The carrier signal is modulated when the Mod On/Off key is set to On, and an individual modulation format is active.

When the Mod On/Off key is set to Off, the MOD OFF annunciator appears on the display. When the key is set to On, the MOD ON annunciator shows in the display, whether or not there is an active modulation format. The annunciators simply indicate whether the carrier signal will be modulated when a modulation format is turned on.

To Turn RF Output Modulation On

Press the Mod On/Off key until the MOD ON annunciator appears in the display.

The carrier signal should be modulated with all active modulation formats. This is the factory default.

To Turn RF Output Modulation Off

Press the Mod On/Off key until the MOD OFF annunciator appears in the display.

The carrier signal is no longer modulated or capable of being modulated when a modulation format is active.

Figure 2-12 Carrier Signal Modulation Status

- Mod Set to On—Carrier is Modulated
- AM Modulation Format is Active
- Mod Set to Off—Carrier is not Modulated
- AM Modulation Format is Active
- Mod Set to On—Carrier is not Modulated
- No Active Modulation Format
Basic Operation
Using Data Storage Functions

Using Data Storage Functions

This section explains how to use the two forms of signal generator data storage: the memory catalog and the instrument state register.

Using the Memory Catalog

The Memory Catalog is the signal generator’s interface for viewing, storing, and saving files; it can be accessed through the signal generator’s front panel or a remote controller. (For information on performing these tasks remotely, see the Programming Guide.)

Table 2-1 Memory Catalog File Types and Associated Data

<table>
<thead>
<tr>
<th>File Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Binary</td>
<td>binary data</td>
</tr>
<tr>
<td>State</td>
<td>instrument state data (controlling instrument operating parameters, such as frequency, amplitude, and mode)</td>
</tr>
<tr>
<td>LIST</td>
<td>sweep data from the List Mode Values table including frequency, amplitude, and dwell time</td>
</tr>
<tr>
<td>User Flatness</td>
<td>user flatness calibration correction pair data (user-defined frequency and corresponding amplitude correction values)</td>
</tr>
<tr>
<td>FIR</td>
<td>Finite Impulse Response (FIR) filter coefficients</td>
</tr>
<tr>
<td>ARB Catalog Types</td>
<td>(E8267C PSG with Option 002/602 only) user created files - Waveform Catalog Types: WFM1 (waveform file), NVARB Catalog Types: NVWFM (non-volatile, ARB waveform file), NVMKR (non-volatile, ARB waveform marker file), Seq (ARB sequence file), MTONE (ARB multitone file), DMOD (ARB digital modulation file), MDMOD (ARB multicarrier digital modulation file)</td>
</tr>
<tr>
<td>Modulation Catalog Types</td>
<td>(E8267C PSG with Option 002/602 only) associated data for I/Q and FSK (frequency shift keying) modulation files</td>
</tr>
<tr>
<td>Shape</td>
<td>burst shape of a pulse</td>
</tr>
<tr>
<td>Bit</td>
<td>Bit</td>
</tr>
</tbody>
</table>
Storing Files to the Memory Catalog

To store a file to the memory catalog, first create a file. For this example, use the default list sweep table.

1. Press Preset.
2. Press Sweep/List > Configure List Sweep > More (1 of 2) > Load/Store.
   This opens the “Catalog of List Files”.
3. Press Store to File.
   This displays a menu of alphabetical softkeys for naming the file. Store to: is displayed in the active function area.
4. Enter the file name LIST1 using the alphabetical softkeys and the numeric keypad (for the numbers 0 to 9).
5. Press Enter.
   The file should be displayed in the “Catalog of List Files”, showing the file name, file type, file size, and the date and time the file was modified.

Viewing Stored Files in the Memory Catalog

1. Press Utility > Memory Catalog > Catalog Type.
   All files in the memory catalog are listed in alphabetical order, regardless of which catalog type you select. File information appears on the display and includes the file name, file type, file size, and the date and time the file was modified.
2. Press List.
   The “Catalog of List Files” is displayed.
3. Press Catalog Type > State.
   The “Catalog of State Files” is displayed.
4. Press Catalog Type > All.
   The “Catalog of All Files” is displayed. For a complete list of file types, refer to Table 2-1 on page 52.
Basic Operation

Using Data Storage Functions

Using the Instrument State Register

The instrument state register is a section of memory divided into 10 sequences (numbered 0 through 9) each containing 100 registers (numbered 00 through 99). It is used to store and recall instrument settings. It provides a quick way to reconfigure the signal generator when switching between different signal configurations. Once an instrument state has been saved, you can recall the instrument settings for that state with minimum effort.

NOTE
List sweep data is not saved within an instrument state. For instructions on saving list sweep data, see “Storing Files to the Memory Catalog” on page 53.

Saving an Instrument State

1. Preset the signal generator, then enables amplitude modulation (the \textit{AM} annunciator will turn on):
   a. Press \textit{Frequency} \textgreater{} 800 \textgreater{} MHz.
   b. Press \textit{Amplitude} \textgreater{} 0 \textgreater{} dBm.
   c. Press \textit{AM} \textgreater{} AM Off On.
2. Press \textit{Save} \textgreater{} \textit{Select Seq}.
   The sequence number becomes the active function. The signal generator displays the last sequence used. Using the arrow keys, set the sequence to 1.
3. Press \textit{Select Reg}.
   The register number in sequence 1 becomes the active function. The signal generator displays either the last register used accompanied by the text: (\textit{in use}), or (if no registers are in use) register 00 accompanied by the text: (\textit{available}). Use the arrow keys to select register 01.
   This saves this instrument state in sequence 1, register 01 of the instrument state register.
5. Press \textit{Add Comment to Seq[1] Reg[01]}.
   This enables you to add a descriptive comment to sequence 1 register 01.
6. Using the alphanumeric softkeys or the knob, enter a comment and press \textit{Enter}.
7. Press \textit{Edit Comment In Seq[1] Reg[01]}.
   If you wish, you can now change the descriptive comment for sequence 1 register 01.

After making changes to an instrument state, you can save it back to a specific register by highlighting that register and pressing \textit{Re-SAVE Seq[n] Reg[nn]}. 
Recalling an Instrument State

Using this procedure, you will learn how to recall instrument settings saved to an instrument state register.

1. Press **Preset**.
2. Press the **Recall** hardkey.
   
   Notice that the **Select Seq** softkey shows sequence 1. (This is the last sequence that you used.)
3. Press **RECALL Reg**.
   
   The register to be recalled in sequence 1 becomes the active function. Press the up arrow key once to select register 1. Your stored instrument state settings should have been recalled.

Deleting Registers and Sequences

These procedures describe how to delete registers and sequences saved to an instrument state register.

Deleting a Specific Register within a Sequence

1. Press **Preset**.
2. Press the **Recall** or **Save** hardkey.
   
   Notice that the **Select Seq** softkey shows the last sequence that you used.
3. Press **Select Seq** and enter the sequence number containing the register you want to delete.
4. Press **Select Reg** and enter the register number you want to delete.
   
   Notice that the **Delete Seq[n] Reg[nn]** should be loaded with the sequence and register you want to delete.
5. Press **Delete Seq[n] Reg[nn]**.
   
   This deletes the chosen register.
Basic Operation

Using Data Storage Functions

Deleting All Registers within a Sequence

1. Press **Preset**.
2. Press the **Recall** or **Save** hardkey.
   Notice that the **Select Seq** softkey shows the last sequence that you used.
3. Press **Select Seq** and enter the sequence number containing the registers you want to delete.
4. Press **Delete all Regs in Seq[n]**.
   This deletes all registers in the selected sequence.

Deleting All Sequences

**CAUTION** Be sure you want to delete the contents of *all* registers and *all* sequences in the instrument state register.

1. Press **Preset**.
2. Press the **Recall** or **Save** hardkey.
   Notice that the **Select Seq** softkey shows the last sequence that you used.
3. Press **Delete All Sequences**.
   This deletes all of the sequences saved in the instrument state register.
Enabling Options

You can retrofit your signal generator after purchase to add new capabilities. Some new optional features are implemented in hardware that you must install. Some options are implemented in software, but require the presence of optional hardware in the instrument. This example shows you how to enable software options.

Enabling a Software Option

A license key (provided on the license key certificate) is required to enable each software option.

1. Access the Software Options menu:
   Utility > Instrument Adjustments > Instrument Options > Software Options.
   The following is an example of the signal generator display, which lists any enabled software options, and any software options that can be enabled:

   ![Software Options Menu Example]

   2. Verify that the host ID shown on the display matches the host ID on the license key certificate. The host ID is a unique number for every instrument. If the host ID on the license key certificate does not match your instrument, the license key cannot enable the software option.

   3. Verify that any required hardware is installed. Because some software options are linked to specific hardware options, before the software option can be enabled, the appropriate hardware option must be installed. For example, Option 420 (radar simulation modulation format) requires that Option 002/602 (internal baseband generator) be installed. If the software option that you intend to install is listed in a grey font, the required hardware may not be installed (look for an X in the “Selected” column of the appropriate hardware option in the Hardware Options menu).
Basic Operation

Enabling Options

4. Enable the software option:
   a. Highlight the desired option.
   b. Press **Modify License Key**, and enter the 12-character license key (from the license key certificate).
   c. Verify that you want to reconfigure the signal generator with the new option:
      *Proceed With Reconfiguration > Confirm Change*
      
The instrument enables the option and reboots.
3 Optimizing Performance

In the following sections, this chapter describes procedures that improve the performance of the Agilent PSG signal generator.

- Selecting ALC Bandwidth (below)
- “Using External Leveling” on page 60
- “Creating and Applying User Flatness Correction” on page 64
- “Adjusting Reference Oscillator Bandwidth (Option UNR)” on page 76

Selecting ALC Bandwidth

For internal leveling, the signal generator uses automatic leveling control (ALC) circuitry prior to the RF output. ALC bandwidth has five selections: automatic, 100 Hz, 1 kHz, 10 kHz, and 100 kHz. In automatic mode (the preset selection), the signal generator automatically adjusts the ALC bandwidth among three of the four possible settings, depending on the active functions (see Figure 3-1).

Figure 3-1: Decision Tree for Automatic ALC Bandwidth Selection

To Select an ALC Bandwidth

Press Amplitude > ALC BW > 100 Hz, 1 kHz, 10 kHz, or 100 kHz.

This overrides the automatic ALC bandwidth selection with your specific selection.
Using External Leveling

The PSG signal generator can be externally leveled by connecting an external sensor at the point where leveled RF output power is desired. This sensor detects changes in RF output power and returns a compensating voltage to the signal generator’s ALC input. The ALC circuitry raises or lowers (levels) the RF output power based on the voltage received from the external sensor, ensuring constant power at the point of detection.

There are two types of external leveling available on the PSG. You can use external leveling with a detector and coupler/power splitter setup, or a millimeter-wave source module.

To Level with Detectors and Couplers/Splitters

Figure 3-2 illustrates a typical external leveling setup. The power level feedback to the ALC circuitry is taken from the external negative detector, rather than the internal signal generator detector. This feedback voltage controls the ALC system, leveling the RF output power at the point of detection.

To use detectors and couplers/splitters for external leveling at an RF output frequency of 10 GHz and an amplitude of 0 dBm, follow the instructions in this section.

Required Equipment

- Agilent 8474E negative detector
- Agilent 87301D directional coupler
- cables and adapters, as required

Connect the Equipment

Set up the equipment as shown in Figure 3-2.
Configure the Signal Generator

1. Press Preset.
2. Press Frequency > 10 > GHz.
3. Press Amplitude > 0 > dBm.
5. Press Leveling Mode > Ext Detector.

This deactivates the internal ALC detector and switches the ALC input path to the front panel ALC INPUT connector. The EXT indicator is activated in the AMPLITUDE area of the display.

**NOTE**

For signal generators with Option 1E1, notice that the ATTN HOLD (attenuator hold) annunciator is displayed. During external leveling, the signal generator automatically uncouples the attenuator from the ALC system for all external leveling points. While in this mode, the RF output amplitude adjustment is limited to −20 to +25 dBm, the adjustment range of the ALC circuitry. For more information, see “External Leveling with Option 1E1 Signal Generators” on page 63.

6. Observe the coupling factor printed on the directional coupler at the detector port. Typically, this value is −10 to −20 dB.

Enter the positive dB value of this coupling factor into the signal generator.

7. Press More (1 of 2) > Ext Detector Coupling Factor > 16 (or the positive representation of the value listed at the detector port of the directional coupler) > dB.

Leveled output power is now available at the output of the directional coupler.

**NOTE**

While operating in external leveling mode, the signal generator’s displayed RF output amplitude is affected by the coupling factor value, resulting in a calculated approximation of the actual RF output amplitude. To determine the actual RF output amplitude at the point of detection, measure the voltage at the external detector output and refer to Figure 3-3 or measure the power directly with a power meter.
Optimizing Performance

Using External Leveling

Determining the Leveled Output Power

Figure 3-3 shows the input power versus output voltage characteristics for typical Agilent Technologies diode detectors. Using this chart, you can determine the leveled power at the diode detector input by measuring the external detector output voltage. You must then add the coupling factor to determine the leveled output power. The range of power adjustment is approximately -20 to +25 dBm.

Figure 3-3  Typical Diode Detector Response at 25° C
External Leveling with Option 1E1 Signal Generators

Signal generators with Option 1E1 contain a step attenuator prior to the RF output connector. During external leveling, the signal generator automatically holds the present attenuator setting (to avoid power transients that may occur during attenuator switching) as the RF amplitude is changed. A balance must be maintained between the amount of attenuation and the optimum ALC level to achieve the required RF output amplitude. For optimum accuracy and minimum noise, the ALC level should be greater than $-10$ dBm.

For example, leveling the CW output of a 30 dB gain amplifier to a level of $-10$ dBm requires the output of the signal generator to be approximately $-40$ dBm when leveled. This is beyond the amplitude limits of the ALC modulator alone, resulting in an unleveled RF output. Inserting 45 dB of attenuation results in an ALC level of $+5$ dBm, well within the range of the ALC modulator.

NOTE

In the example above, 55 dB is the preferred attenuation choice, resulting in an ALC level of $+15$ dBm. This provides adequate dynamic range for AM or other functions that vary the RF output amplitude.

To achieve the optimum ALC level at the signal generator RF output of $-40$ dBm for an unmodulated carrier, follow these steps:

1. Press **Amplitude > Set Atten > 45 > dB**.
2. Press **Set ALC Level > 5 > dBm**.

This sets the attenuator to 45 dB and the ALC level to $+5$ dBm, resulting in an RF output amplitude of $-40$ dBm, as shown in the AMPLITUDE area of the display.

To obtain flatness-corrected power, refer to “Creating and Applying User Flatness Correction” on page 64.

To Level with a mm-Wave Source Module

Millimeter-wave source module leveling is similar to external detector leveling. The power level feedback signal to the ALC circuitry is taken from the millimeter-wave source module, rather than the internal signal generator detector. This feedback signal levels the RF output power at the mm-wave source module output through the signal generator’s rear panel SOURCE MODULE interface connector.

For instructions and setups, see “Extending the Frequency Range with a mm-Wave Source Module” on page 47.
Creating and Applying User Flatness Correction

User flatness correction allows the digital adjustment of RF output amplitude for up to 1601 frequency points in any frequency or sweep mode. Using an Agilent E4416A/17A or E4418B/19B power meter (controlled by the signal generator through GPIB) to calibrate the measurement system, a table of power level corrections is created for frequencies where power level variations or losses occur. These frequencies may be defined in sequential linear steps or arbitrarily spaced.

To allow different correction arrays for different test setups or different frequency ranges, you may save individual user flatness correction tables to the signal generator’s memory catalog and recall them on demand.

Use the steps in the next sections to create and apply user flatness correction to the signal generator’s RF output.

Afterward, use the steps in “Recalling and Applying a User Flatness Correction Array” on page 68 to recall a user flatness file from the memory catalog and apply it to the signal generator’s RF output.

Creating a User Flatness Correction Array

In this example, you create a user flatness correction array. The flatness correction array contains ten frequency correction pairs (amplitude correction values for specified frequencies), from 1 to 10 GHz in 1 GHz intervals.

An Agilent E4416A/17A/18B/19B power meter (controlled by the signal generator via GPIB) and E4413A power sensor are used to measure the RF output amplitude at the specified correction frequencies and transfer the results to the signal generator. The signal generator reads the power level data from the power meter, calculates the correction values, and stores the correction pairs in the user flatness correction array.

If you do not have the required Agilent power meter, or if your power meter does not have a GPIB interface, you can enter correction values manually.

Required Equipment

- Agilent E4416A/17A/18B/19B power meter
- Agilent E4413A E Series CW power sensor
- GPIB interface cable
- adapters and cables, as required

NOTE

If the setup has an external leveling configuration, the equipment setup in Figure 3-4 assumes that the steps necessary to correctly level the RF output have been followed. If you have questions about external leveling, refer to “Using External Leveling” on page 60.
Configure the Power Meter

1. Select SCPI as the remote language for the power meter.
2. Zero and calibrate the power sensor to the power meter.
3. Enter the appropriate power sensor calibration factors into the power meter as appropriate.
4. Enable the power meter’s cal factor array.

NOTE
For operating information on a particular power meter/sensor, refer to its operating guide.

Connect the Equipment

Connect the equipment as shown in Figure 3-4.

NOTE
During the process of creating the user flatness correction array, the power meter is slaved to the signal generator via GPIB. No other controllers are allowed on the GPIB interface.

Figure 3-4  User Flatness Correction Equipment Setup
Optimizing Performance

Creating and Applying User Flatness Correction

Configure the Signal Generator

1. Press **Preset**.

2. Configure the signal generator to interface with the power meter.
   
a. Press **Amplitude** > More (1 of 2) > User Flatness > More (1 of 2) > Power Meter > E4416A, E4417A, E4418B, or E4419B.
   
b. Press **Meter Address** > enter the power meter’s GPIB address > **Enter**.
   
c. For E4417A and E4419B models, press **Meter Channel A B** to select the power meter’s active channel.
   
d. Press **Meter Timeout** to adjust the length of time before the instrument generates a timeout error if unsuccessfully attempting to communicate with the power meter.

3. Press **More (2 of 2) > Configure Cal Array > More (1 of 2) > Preset List > Confirm Preset**.
   
   This opens the User Flatness table editor and presets the cal array frequency/correction list.

4. Press **Configure Step Array**.
   
   This opens a menu for entering the user flatness step array data.

5. Press **Freq Start > 1 > GHz**.

6. Press **Freq Stop > 10 > GHz**.

7. Press **# of Points > 10 > Enter**.
   
   Steps 4, 5, and 6 enter the desired flatness-corrected frequencies into the step array.

8. Press **Return > Load Cal Array From Step Array > Confirm Load From Step Data**.
   
   This populates the user flatness correction array with the frequency settings defined in the step array.

9. Press **Amplitude > 0 > dBm**.

10. Press **RF On/ Off**.
    
    This activates the RF output and the RF ON annunciator is displayed on the signal generator.
Perform the User Flatness Correction

NOTE If you are not using an Agilent E4416A/17A/18B/19B power meter, or if your power meter does not have a GPIB interface, you can perform the user flatness correction manually. For instructions, see “Performing the User Flatness Correction Manually” on page 67.

1. Press More (1 of 2) > User Flatness > Do Cal.

   This creates the user flatness amplitude correction value table entries. The signal generator enters the user flatness correction routine and a progress bar is shown on the display.

2. Press Done.

   This loads the amplitude correction values into the user flatness correction array.

   If desired, press Configure Cal Array.

   This opens the user flatness correction array, where you can view the stored amplitude correction values. The user flatness correction array title displays User Flatness: (UNSTORED) indicating that the current user flatness correction array data has not been saved to the memory catalog.

Performing the User Flatness Correction Manually

If you are not using an Agilent E4416A/17A/18B/19B power meter, or if your power meter does not have a GPIB interface, complete the steps in this section and then continue with the user flatness correction tutorial.

1. Press More (1 of 2) > User Flatness > Configure Cal Array.

   This opens the User Flatness table editor and places the cursor over the frequency value (1 GHz) for row 1. The RF output changes to the frequency value of the table row containing the cursor and 1.000 000 000 00 is displayed in the AMPLITUDE area of the display.

2. Observe and record the measured value from the power meter.

3. Subtract the measured value from 0 dBm.

4. Move the table cursor over the correction value in row 1.

5. Press Edit Item > enter the difference value from step 3 > dB.

   The signal generator adjusts the RF output amplitude based on the correction value entered.

6. Repeat steps 2 through 5 until the power meter reads 0 dBm.

7. Use the down arrow key to place the cursor over the frequency value for the next row. The RF output changes to the frequency value of the table row containing the cursor, as shown in the AMPLITUDE area of the display.

8. Repeat steps 2 through 7 for every entry in the User Flatness table.
Optimizing Performance

Creating and Applying User Flatness Correction

Save the User Flatness Correction Data to the Memory Catalog

This process allows you to save the user flatness correction data as in the signal generator’s memory catalog. With several user flatness correction files saved to the memory catalog, any file can be recalled, loaded into the correction array, and applied to the RF output to satisfy specific RF output flatness requirements.

1. Press Load/Store.
2. Press Store to File.
3. Enter the file name FLATCAL1 using the alphanumeric softkeys, numeric keypad, or the knob.
4. Press Enter.
The user flatness correction array file FLATCAL1 is now stored in the memory catalog as a UFLT file.

Applying a User Flatness Correction Array

Press Return > Return > Flatness Off On.

This applies the user flatness correction array to the RF output. The UF indicator is activated in the AMPLITUDE section of the signal generator’s display and the frequency correction data contained in the correction array is applied to the RF output amplitude.

Recalling and Applying a User Flatness Correction Array

Before performing the steps in this section, complete “Creating a User Flatness Correction Array” on page 64.

1. Press Preset.
4. Ensure that the file FLATCAL1 is highlighted.
5. Press Load From Selected File > Confirm Load From File.
   This populates the user flatness correction array with the data contained in the file FLATCAL1. The user flatness correction array title displays User Flatness: FLATCAL1.
   This applies the user flatness correction data contained in FLATCAL1.
Returning the Signal Generator to GPIB Listener Mode

During the user flatness correction process, the power meter is slaved to the signal generator via GPIB, and no other controllers are allowed on the GPIB interface. The signal generator operates in GPIB talker mode, as a device controller for the power meter. In this operating mode, it cannot receive SCPI commands via GPIB.

If the signal generator is to be interfaced to a remote controller after performing the user flatness correction, its GPIB controller mode must be changed from GPIB talker to GPIB listener.

If an RF carrier has been previously configured, you must save the present instrument state before returning the signal generator to GPIB listener mode.

1. Save your instrument state to the instrument state register.
   For instructions, see “Saving an Instrument State” on page 54.
2. Press **GPIB Listener Mode**.
   This presets the signal generator and returns it to GPIB listener mode. The signal generator can now receive remote commands executed by a remote controller connected to the GPIB interface.
3. Recall your instrument state from the instrument state register.
   For instructions, see “Saving an Instrument State” on page 54.

Creating a User Flatness Correction Array with a mm-Wave Source Module

In this example, a user flatness correction array is created to provide flatness-corrected power at the output of an Agilent 83554A millimeter-wave source module driven by an E8247C signal generator.

The flatness correction array contains 28 frequency correction pairs (amplitude correction values for specified frequencies), from 26.5 to 40 GHz in 500 MHz intervals. This will result in 28 evenly spaced flatness corrected frequencies between 26.5 GHz and 40 GHz at the output of the 83554A millimeter-wave source module.

An Agilent E4416A/17A/18B/19B power meter (controlled by the signal generator via GPIB) and R8486A power sensor are used to measure the RF output amplitude of the millimeter-wave source module at the specified correction frequencies and transfer the results to the signal generator. The signal generator reads the power level data from the power meter, calculates the correction values, and stores the correction pairs in the user flatness correction array.

If you do not have the required Agilent power meter, or if your power meter does not have a GPIB interface, you can enter correction values manually.
Optimizing Performance

Creating and Applying User Flatness Correction

Required Equipment

- Agilent 83554A millimeter-wave source module
- Agilent E4416A/17A/18B/19B power meter
- Agilent R8486A power sensor
- Agilent 8349B microwave amplifier (required for signal generators without Option 1EA)
- GPIB interface cable
- adapters and cables as required

NOTE

The equipment setups in Figure 3-5 and Figure 3-6 assume that the steps necessary to correctly level the RF output have been followed. If you have questions about leveling with a millimeter-wave source module, refer to “To Level with a mm-Wave Source Module” on page 63.

Configure the Power Meter

1. Select SCPI as the remote language for the power meter.
2. Zero and calibrate the power sensor to the power meter.
3. Enter the appropriate power sensor calibration factors into the power meter as appropriate.
4. Enable the power meter’s cal factor array.

NOTE

For operating information on your particular power meter/sensor, refer to their operating guides.
Connect the Equipment

**CAUTION** To prevent damage to the signal generator, turn off the line power to the signal generator before connecting the source module interface cable to the rear panel SOURCE MODULE interface connector.

1. Turn off the line power to the signal generator.
2. Connect the equipment. For standard signal generators, use the setup in Figure 3-5. For Option 1EA signal generators, use the setup in Figure 3-6.

**NOTE** During the process of creating the user flatness correction array, the power meter is slaved to the signal generator via GPIB. No other controllers are allowed on the GPIB interface.

**Figure 3-5** User Flatness with mm-Wave Source Module for a Signal Generator without Option 1EA
Optimizing Performance

Creating and Applying User Flatness Correction

NOTE

To ensure adequate RF amplitude at the mm-wave source module RF input when using Option 1EA signal generators, maximum amplitude loss through the adapters and cables connected between the signal generator’s RF output and the mm-wave source module’s RF input should be less than 1.5 dB.

Configure the Signal Generator

1. Turn on the signal generator’s line power. At power-up, the signal generator automatically does the following:
   - senses the mm-wave source module
   - switches the signal generator’s leveling mode to external/source module
   - sets the mm-wave source module frequency and amplitude to the source module’s preset values
   - displays the RF output frequency and amplitude available at the mm-wave source module output

The MMOD indicator in the FREQUENCY area and the MM indicator in the AMPLITUDE area of the signal generator’s display indicate that the mm-wave source module is active

NOTE

For specific frequency/amplitude ranges, see the mm-wave source module specifications.
2. Configure the signal generator to interface with the power meter.
   b. Press **Meter Address > enter the power meter’s GPIB address > Enter**.
   c. For E4417A and E4419B models, press **Meter Channel A B** to select the power meter’s active channel.
   d. Press **Meter Timeout** to adjust the length of time before the instrument generates a timeout error if unsuccessfully attempting to communicate with the power meter.
3. Press **More (2 of 2) > Configure Cal Array > More (1 of 2) > Preset List > Confirm Preset**.
   This opens the User Flatness table editor and resets the cal array frequency/correction list.
4. Press **Configure Step Array**.
   This opens a menu for entering the user flatness step array data.
5. Press **Freq Start > 26.5 > GHz**.
6. Press **Freq Stop > 40 > GHz**.
7. Press **# of Points > 28 > Enter**.
   This enters the desired flatness-corrected frequencies (26.5 GHz to 40 GHz in 500 MHz intervals) into the step array.
8. Press **Return > Load Cal Array From Step Array > Confirm Load From Step Data**.
   This populates the user flatness correction array with the frequency settings defined in the step array.
9. Press **Amplitude > 0 > dBm**.
10. Press **RF On/Off**.
    This activates the RF output and the **RF ON** annunciator is displayed on the signal generator.

**Perform the User Flatness Correction**

---

**NOTE**
If you are not using an Agilent E4416A/17A/18B/19B power meter, or if your power meter does not have a GPIB interface, you can perform the user flatness correction manually. For instructions, see **Performing the User Flatness Correction Manually** below.

1. Press **More (1 of 2) > User Flatness > Do Cal**.
   This creates the user flatness amplitude correction value table entries. The signal generator begins the user flatness correction routine and a progress bar is shown on the display.
Optimizing Performance

Creating and Applying User Flatness Correction

2. When prompted, press Done.

This loads the amplitude correction values into the user flatness correction array.

If desired, press Configure Cal Array.

This opens the user flatness correction array, where you can view the list of defined frequencies and their calculated amplitude correction values. The user flatness correction array title displays User Flatness: (UNSTORED) indicating that the current user flatness correction array data has not been saved to the memory catalog.

Performing the User Flatness Correction Manually

If you are not using an Agilent E4416A/17A/18B/19B power meter, or if your power meter does not have a GPIB interface, complete the steps in this section and then continue with the user flatness correction tutorial.

1. Press More (1 of 2) > User Flatness > Configure Cal Array.

This opens the User Flatness table editor and places the cursor over the frequency value (26.5 GHz) for row 1. The RF output changes to the frequency value of the table row containing the cursor and 26.500 000 000 00 is displayed in the AMPLITUDE area of the display.

2. Observe and record the measured value from the power meter.

3. Subtract the measured value from 0 dBm.

4. Move the table cursor over the correction value in row 1.

5. Press Edit Item > enter the difference value from step 3 > dB.

The signal generator adjusts the RF output amplitude based on the correction value entered.

6. Repeat steps 2 through 5 until the power meter reads 0 dBm.

7. Use the down arrow key to place the cursor over the frequency value for the next row. The RF output changes to the frequency value highlighted by the cursor, as shown in the AMPLITUDE area of the display.

8. Repeat steps 2 through 7 for each entry in the User Flatness table.
Save the User Flatness Correction Data to the Memory Catalog

This process allows you to save the user flatness correction data as a file in the signal generator’s memory catalog. With several user flatness correction files saved to the memory catalog, specific files can be recalled, loaded into the correction array, and applied to the RF output to satisfy various RF output flatness requirements.

1. Press **Load/Store**.
2. Press **Store to File**.
3. Enter the file name **FLATCAL2** using the alphanumeric softkeys and the numeric keypad.
4. Press **Enter**.

The user flatness correction array file FLATCAL2 is now stored in the memory catalog as a UFLT file.

Applying the User Flatness Correction Array

1. Press **Return > Return > Flatness Off On**.

   This applies the user flatness correction array to the RF output. The UF indicator is activated in the AMPLITUDE section of the signal generator’s display and the frequency correction data contained in the correction array is applied to the RF output amplitude of the mm-wave source module.

Recalling and Applying a User Flatness Correction Array

Before performing the steps in this section, complete the section “Creating a User Flatness Correction Array with a mm-Wave Source Module” on page 69.

1. Press **Preset**.
2. Press **Amplitude > More (1 of 2) > User Flatness > Configure Cal Array > More (1 of 2) > Preset List > Confirm Preset**.
3. Press **More (2 of 2) > Load/Store**.
4. Ensure that the file FLATCAL2 is highlighted.
5. Press **Load From Selected File > Confirm Load From File**.

   This populates the user flatness correction array with the data contained in the file FLATCAL2. The user flatness correction array title displays User Flatness: FLATCAL2.
6. Press **Return > Flatness Off On**.

   This activates flatness correction using the data contained in the file FLATCAL2.
Optimizing Performance

Adjusting Reference Oscillator Bandwidth (Option UNR)

The reference oscillator bandwidth (sometimes referred to as loop bandwidth) in signal generators with Option UNR (improved close-in phase noise) is adjustable in fixed steps for either an internal or external 10 MHz frequency reference. The reference bandwidth can be set to 25, 55, 125, 300, or 650 Hz; models without option UNR have a fixed reference oscillator bandwidth of about 15 Hz.

The reference oscillator bandwidth is the frequency below which the PSG derives its reference directly from the internal or external frequency reference. Above this frequency, stability and phase noise are governed by the synthesizer hardware within the PSG.

To optimize the overall phase noise performance of the signal generator for your particular application, make this adjustment depending on your confidence in the stability and phase noise of the external or internal reference versus the synthesizer hardware for various frequency offsets from the carrier.

**To Select the Reference Oscillator Bandwidth**

**When using the internal timebase reference:**
2. Select the desired bandwidth.

**When using an external timebase reference:**
2. Select the desired bandwidth.

**To Restore Factory Default Settings:**

Internal Timebase: 125 Hz
External Timebase: 25 Hz

4 Analog Modulation

In the following sections, this chapter describes the analog modulation capability in Agilent E8257C PSG Analog and E8267C PSG Vector Signal Generators.

- “Analog Modulation Waveforms” on page 78
- “Configuring AM” on page 79
- “Configuring FM” on page 80
- “Configuring ΦM” on page 81
- “Configuring Pulse Modulation” on page 82
- “Configuring the LF Output” on page 83
Analog Modulation Waveforms

The signal generator can modulate the RF carrier with four types of analog modulation:

- amplitude,
- frequency,
- phase, and
- pulse.

Available internal waveforms include:

- **Sine**: sine wave with adjustable amplitude and frequency
- **Dual-Sine**: dual-sine waves with individually adjustable frequencies and a percent-of-peak-amplitude setting for the second tone (available from function generator only)
- **Swept-Sine**: swept-sine wave with adjustable start and stop frequencies, sweep rate, and sweep trigger settings (available from function generator only)
- **Triangle**: triangle wave with adjustable amplitude and frequency
- **Ramp**: ramp with adjustable amplitude and frequency
- **Square**: square wave with adjustable amplitude and frequency
- **Noise**: noise with adjustable amplitude generated as a peak-to-peak value (RMS value is approximately 80% of the displayed value)
Configuring AM

In this example, you will learn how to generate an amplitude-modulated RF carrier.

**To Set the Carrier Frequency**

1. Press *Preset*.
2. Press *Frequency > 1340 > kHz*.

**To Set the RF Output Amplitude**

Press *Amplitude > 0 > dBm*.

**To Set the AM Depth and Rate**

1. Press the *AM* hardkey.
2. Press *AM Depth > 90 > %*.
3. Press *AM Rate > 10 > kHz*.

The signal generator is now configured to output a 0 dBm, amplitude-modulated carrier at 1340 kHz with the AM depth set to 90% and the AM rate set to 10 kHz. The shape of the waveform is a sine wave. Notice that sine is the default selection for the *AM Waveform* softkey, which can be viewed by pressing *(More 1 of 2)*.

**To Turn on Amplitude Modulation**

Follow these remaining steps to output the amplitude-modulated signal.

1. Press the *AM Off On* softkey to On.
2. Press the front panel *RF On Off* key.

The *AM* and *RF ON* annunciators are now displayed. This indicates that you have enabled amplitude modulation and the signal is now being transmitted from the RF OUTPUT connector.
Analog Modulation
Configuring FM

Configuring FM

In this example, you will learn how to create a frequency-modulated RF carrier.

To Set the RF Output Frequency

1. Press **Preset**.
2. Press **Frequency > 1 > GHz**.

To Set the RF Output Amplitude

Press **Amplitude > 0 > dBm**.

To Set the FM Deviation and Rate

1. Press the **FM/ΦM** hardkey.
2. Press **FM Dev > 75 > kHz**.
3. Press **FM Rate > 10 > kHz**.

The signal generator is now configured to output a 0 dBm, frequency-modulated carrier at 1 GHz with a 75 kHz deviation and a 10 kHz rate. The shape of the waveform is a sine wave. (Notice that sine is the default for the **FM Waveform** softkey. Press **More (1 of 2)** to see the softkey.)

To Activate FM

1. Press **FM Off On** to On.
2. Press **RF On/Off**.

The **FM** and **RF ON** annunciators are now displayed. This indicates that you have enabled frequency modulation and the signal is now being transmitted from the RF OUTPUT connector.
**Configuring ΦM**

In this example, you will learn how to create a phase-modulated RF carrier.

**To Set the RF Output Frequency**

1. Press **Preset**.
2. Press **Frequency > 3 GHz**.

**To Set the RF Output Amplitude**

Press **Amplitude > 0 dBm**.

**To Set the FM Deviation and Rate**

1. Press the **FM/ΦM** hardkey.
2. Press the **FM ΦM** softkey.
3. Press **FM Dev > .25 > π rad**.
4. Press **FM Rate > 10 > kHz**.

The signal generator is now configured to output a 0 dBm, phase-modulated carrier at 3 GHz with a 0.25 π radian deviation and 10 kHz rate. The shape of the waveform is a sine wave. (Notice that sine is the default for the **FM Waveform** softkey. Press **More (1 of 2)** to see the softkey.)

**To Activate FM**

1. Press **FM Off On**.
2. Press **RF On/Off**.

The FM and RF **ON** annunciators are now displayed. This indicates that you have enabled phase modulation and the signal is now being transmitted from the RF OUTPUT connector.
Analog Modulation

Configuring Pulse Modulation

In this example, you will learn how to create a pulse-modulated RF carrier.

To Set the RF Output Frequency

1. Press **Preset**.
2. Press **Frequency > 2 > GHz**.

To Set the RF Output Amplitude

Press **Amplitude > 0 > dBm**.

To Set the Pulse Period and Width

1. Press **Pulse > Pulse Period > 100 > usec**.
2. Press **Pulse > Pulse Width > 24 > usec**.

The signal generator is now configured to output a 0 dBm, pulse-modulated carrier at 2 GHz with a 100-microsecond pulse period and 24-microsecond pulse width. The pulse source is set to Internal Free Run. (Notice that Internal Free Run is the default for the **Pulse Source** softkey.)

To Activate Pulse Modulation

Follow these remaining steps to output the pulse-modulated signal.

1. Press **Pulse Off On** to On.
2. Press **RF On/ Off**.

The Pulse and RF On annunciators are now displayed. This indicates that you have enabled pulse modulation and the signal is now being transmitted from the RF OUTPUT connector.
Configuring the LF Output

The signal generator has a low frequency (LF) output (described on page 9). The LF output's source can be switched between Internal 1 Monitor, Internal 2 Monitor, Function Generator 1, or Function Generator 2.

Using Internal 1 Monitor or Internal 2 Monitor as the LF output source, the LF output provides a replica of the signal from the internal source that is being used to modulate the RF output. The specific modulation parameters for this signal are configured through the AM, FM, or FM menus.

Using Function Generator 1 or Function Generator 2 as the LF output source, the function generator section of the internal modulation source drives the LF output directly. Frequency and waveform are configured from the LF output menu, not through the AM, FM, or FM menus. You can select the waveform shape from the following choices:

- **Sine**  
  sine wave with adjustable amplitude and frequency

- **Dual-Sine**  
  dual-sine waves with individually adjustable frequencies and a percent-of-peak-amplitude setting for the second tone (available from function generator 1 only)

- **Swept-Sine**  
  a swept-sine wave with adjustable start and stop frequencies, sweep rate, and sweep trigger settings (available from function generator 1 only)

- **Triangle**  
  triangle wave with adjustable amplitude and frequency

- **Ramp**  
  ramp with adjustable amplitude and frequency

- **Square**  
  square wave with adjustable amplitude and frequency

- **Noise**  
  noise with adjustable amplitude generated as a peak-to-peak value (RMS value is approximately 80% of the displayed value)

- **DC**  
  direct current with adjustable amplitude

**NOTE**  
The LF Out Off On softkey controls the operating state of the LF output. However when the LF output source selection is Internal Monitor, you have three ways of controlling the output. You can use the modulation source (AM, FM, or FM) on/off key, the LF output on/off key, or the Mod On/ Off softkey.

The RF On/ Off hardkey does not apply to the LF OUTPUT connector.
Analog Modulation

Configuring the LF Output

To Configure the LF Output with an Internal Modulation Source

In this example, the internal FM modulation is the LF output source.

**NOTE**

Internal modulation (Internal Monitor) is the default LF output source.

Configuring the Internal Modulation as the LF Output Source

1. Press **Preset**.
2. Press the **FM/ΦM** hardkey.
3. Press **FM Dev > 75 > kHz**.
4. Press **FM Rate > 10 > kHz**.
5. Press **FM Off On**.

You have set up the FM signal with a rate of 10 kHz and 75 kHz of deviation. The FM annunciator is activated indicating that you have enabled frequency modulation.

Configuring the Low Frequency Output

1. Press the **LF Out** hardkey.
2. Press **LF Out Amplitude > 3 > Vp**.
3. Press **LF Out Off On**.

You have configured the LF output signal for a 3 volt sine wave (default wave form) output which is frequency modulated using the Internal 1 Monitor source selection (default source).
To Configure the LF Output with a Function Generator Source

In this example, the function generator is the LF output source.

Configuring the Function Generator as the LF Output Source

1. Press Preset.
2. Press the LF Out hardkey.

Configuring the Waveform

1. Press LF Out Waveform > Swept-Sine.
2. Press LF Out Start Freq > 100 > Hz.
3. Press LF Out Stop Freq > 1 > kHz.
   This returns you to the top LF Output menu.

Configuring the Low Frequency Output

   This sets the LF output amplitude to 3 Vp.

The LF output is now transmitting a signal using Function Generator 1 that is providing a
3 Vp swept-sine waveform. The waveform is sweeping from 100 Hz to 1 kHz.
Analog Modulation

Configuring the LF Output
5 Dual Arbitrary Waveform Generator

In the following sections, this chapter describes the Dual Arb mode, which is available only in E8267C PSG vector signal generators with Option 002/602:

- “Arbitrary (ARB) Waveform File Headers” on page 88
- “Using the Dual ARB Waveform Player” on page 99
- “Using Waveform Clipping” on page 112
- “Waveform Clipping Concepts” on page 113
- “Using Waveform Markers” on page 104
- “Waveform Marker Concepts” on page 108
- “Using Waveform Triggers” on page 111
Arbitrary (ARB) Waveform File Headers

An ARB waveform file header enables you to save instrument setup information (key format settings) along with a waveform. When you retrieve a stored waveform, the header information is applied so that when the waveform starts playing, the dual ARB player is set up the same way each time.

Headers can also store a user-specified 32-character description of the waveform or sequence file.

A default header is automatically created whenever a waveform is generated, a waveform sequence is created, or a waveform file is downloaded to the PSG (for details on downloading files, see the PSG Programming Guide).

The following signal generator settings are saved in a file header:

- ARB sample clock rate
- Runtime scaling (only in the dual ARB player)
- Marker polarity (markers 1 through 4)
- Marker routing functions (markers 1 through 4)
  - ALC hold
  - Alternate amplitude
  - RF blanking
- High crest mode (only in the dual ARB player)
- Modulator attenuation
- Modulator filter
- I/Q output filter (used when routing signals to the rear panel I/Q outputs)
- Other instrument optimization settings (for files generated by the PSG) that cannot be set by the user.
Creating a File Header for a Modulation Format Waveform

When you turn on a modulation format, the PSG generates a temporary waveform file (AUTOGEN_WAVEFORM), with a default file header. The default header has no signal generator settings saved to it.

This procedure, which is the same for all ARB formats, demonstrates how to create a file header for a Custom digital modulation format.

1. Preset the signal generator.
2. Turn on the Custom modulation format:
   Press Mode > Custom > ARB Waveform Generator > Digital Modulation Off On to On

   A default file header is created, and the temporary waveform file (AUTOGEN_WAVEFORM) plays. Figure 5-1 shows the PSG’s display.

At this point, a default file header has been created, with default (unspecified) settings that do not reflect the current signal generator settings for the active modulation. To save the settings for the active modulation, you must modify the default settings before you save the header information with the waveform file (see “Modifying Header Information in a Modulation Format” on page 90).

NOTE Each time an ARB modulation format is turned on, a new temporary waveform file (AUTOGEN_WAVEFORM) and file header are generated, overwriting the previous temporary file and file header. Because all ARB formats use the same file name, this happens even if the previous AUTOGEN_WAVEFORM file was created by a different ARB modulation format.
Modifying Header Information in a Modulation Format

This procedure builds on the previous procedure, explaining the different areas of a file header, and showing how to access, modify, and save changes to the information.

In a modulation format, you can access a file header only while the modulation format is active (on). In this procedure, we work within the Custom digital modulation format. All ARB modulation formats and the dual ARB player access the file header using the same key presses, except that for some modulation formats, you may have to go to page two of the first-level softkey menu.

1. From the first-level softkey menu (shown in Figure 5-1 on page 89), open the Header Utilities menu:
   Press ARB Setup > Header Utilities

   The default header for the Custom digital modulation waveform is displayed (see Figure 5-2). In the Saved Header Settings column, the signal generator settings for the active format are shown as Unspecified, which means that no settings have been saved to the file header. If a setting is unspecified in the file header, the current value for that setting does not change when the waveform is selected for later use.

   The Current Inst. Settings column shows the current signal generator settings for the active modulation. These settings become the saved header settings when they are saved to the file header (as demonstrated in step two).

---

**Figure 5-2 Custom Digital Modulation Default Header Display**

![Diagram of custom digital modulation default header display with annotations for description field, clear header, save setup to header, page up, page down, and default header settings.]

---

*Note:* Parameters that are inactive (such as Runtime Scaling) can be set only in the dual ARB player.
2. Save the information in the **Current Inst. Settings** column to the file header: Press **Save Setup To Header**.

The same settings are now displayed in both the **Saved Header Settings** column and the **Current Inst. Settings** column. The settings in the **Saved Header Settings** column are the ones that have been saved in the file header.

The following signal generator settings are saved to the file header:

- **32-Character Description:** A description entered for the header, such as a the waveform’s function (saved/edited with the **Edit Description** key, see Figure 5-2 on page 90).
- **Sample Rate:** The ARB sample clock rate.
- **Runtime Scaling:** The Runtime scaling value. Runtime scaling is applied in real-time while the waveform is playing. This setting can be changed only for files in the dual ARB player.
- **Marker 1...4 Polarity:** The marker polarity, positive or negative.
- **ALC Hold Routing:** Which marker, if any, implements the PSG’s ALC hold function. The ALC hold function holds the ALC modulator at its current level when the marker signal is low. When the marker signal goes high, the ALC hold function is discontinued. If the RF Blank Routing function is selected, it automatically activates the ALC hold for the same marker.
- **Alt Ampl. Routing:** Which marker, if any, triggers the PSG’s alternate amplitude feature when the marker signal is low. When the marker signal goes high, the trigger is terminated disengaging alternate amplitude. You must configure the alternate amplitude parameters, accessed in the **Amplitude** hardkey menu.
- **RF Blank Routing:** Which marker, if any, implements the PSG’s RF blanking function when the marker signal is low. Selecting RF blanking also implements ALC hold. When the marker signal goes high, RF blanking is discontinued.

**NOTE**

All waveforms generated in the PSG have a marker on the first sample point. To see the desired results from the three routing selections, you may need to select a range of sample (marker) points. To set the marker points, use the **Set Marker on Range of Points** softkey in the **Marker Utilities** menu. Refer to “To Place a Marker Across a Range of Points within a Waveform Segment” on page 104 for more information.

- **I/Q Mod Filter:** The I/Q modulator filter setting. The modulator filter affects the I/Q signal modulated onto the RF carrier.
- **I/Q Output Filter:** The I/Q output filter setting. The I/Q output filter is used for I/Q signals routed to the rear panel I and Q outputs.
- **Mod Attenuation:** The I/Q modulator attenuation setting.
Dual Arbitrary Waveform Generator

Arbitrary (ARB) Waveform File Headers

   This menu lets you change the current instrument settings. Figure 5-3 shows the ARB Setup softkey menu and the softkey paths used in steps four through nine.

4. Set the ARB sample clock to 5 MHz: Press ARB Sample Clock > 5 MHz.

5. Set the modulator attenuation to 15 dB:

6. Set the I/Q modulation filter to a through:

7. Set marker one to blank the RF output at the set marker point(s):
   For information on setting markers, see “Using Waveform Markers” on page 104.

8. Set the polarity of Marker 1 negative: Press Return > Marker Polarity > Marker 1 Polarity Neg Pos to Neg.

   Notice that the Current Inst. Settings column now reflects the changes made to the current signal generator setup in steps 4 through 8, but that the saved header values have not changed (as shown in Figure 5-4 on page 94).

10. Save the current settings to the file header: Press Save Setup To Header softkey.
   The settings from the Current Inst. Settings column now appear in the Saved Header Settings column. The file header has been modified and the current instrument settings saved. This is shown in Figure 5-5 on page 94.

While a modulation format is active, the waveform file (AUTOGEN_WAVEFORM) is playing and you can modify the header information within the active modulation format. Once you turn the modulation format off, the header information is available only in the dual ARB player. If you turn the modulation format off and then on, you overwrite the previous AUTOGEN_WAVEFORM file and its file header. To avoid this, rename the file before you turn the modulation format back on (see page 103).

When you store the waveform file (see page 103), the header information is stored with the waveform.
Figure 5-3  ARB Setup Softkey Menu and Marker Utilities

Dual ARB Player softkey
(it does not appear in the ARB formats)
Dual Arbitrary Waveform Generator

Arbitrary (ARB) Waveform File Headers

Figure 5-4  Differing Values between Header and Current Setting Columns

<table>
<thead>
<tr>
<th>Description</th>
<th>Saved Header Settings</th>
<th>Current Inst. Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sample Rate</td>
<td>Unspecified</td>
<td>5,000,000 Hz</td>
</tr>
<tr>
<td>Marker 1 Polarity</td>
<td>Unspecified</td>
<td>New</td>
</tr>
<tr>
<td>Marker 2 Polarity</td>
<td>Unspecified</td>
<td>Pos</td>
</tr>
<tr>
<td>Marker 3 Polarity</td>
<td>Unspecified</td>
<td>Pos</td>
</tr>
<tr>
<td>Marker 4 Polarity</td>
<td>Unspecified</td>
<td>Pos</td>
</tr>
<tr>
<td>ALC Hold Routing</td>
<td>Unspecified</td>
<td>None</td>
</tr>
<tr>
<td>ALC Hold Routing</td>
<td>None</td>
<td>None</td>
</tr>
</tbody>
</table>

Figure 5-5  Saved File Header Changes

<table>
<thead>
<tr>
<th>Description</th>
<th>Saved Header Settings</th>
<th>Current Inst. Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sample Rate</td>
<td>5,000,000 Hz</td>
<td>5,000,000 Hz</td>
</tr>
<tr>
<td>Marker 1 Polarity</td>
<td>New</td>
<td>New</td>
</tr>
<tr>
<td>Marker 2 Polarity</td>
<td>Positive</td>
<td>Pos</td>
</tr>
<tr>
<td>Marker 3 Polarity</td>
<td>Positive</td>
<td>Pos</td>
</tr>
<tr>
<td>Marker 4 Polarity</td>
<td>Positive</td>
<td>Pos</td>
</tr>
<tr>
<td>ALC Hold Routing</td>
<td>None</td>
<td>None</td>
</tr>
<tr>
<td>ALC Hold Routing</td>
<td>None</td>
<td>None</td>
</tr>
</tbody>
</table>

Values differ between the two columns.
Storing Header Information for a Dual ARB Player Waveform Sequence

When you create a waveform sequence (described on page 101), the PSG automatically creates a default file header, which takes priority over the headers for the waveform segments that compose the waveform sequence. During a waveform sequence playback, the waveform segment headers are ignored (except to verify that all required options are installed). When you store the waveform sequence, its file header is stored with it.

Modifying and Viewing Header Information in the Dual ARB Player

Once a modulation format is turned off, the waveform file is available only to the dual ARB player. This is also true for downloaded waveform files. Because of this, future edits to a waveform’s header information must be performed using the dual ARB player.

To modify header information in the dual ARB player, the waveform file must be playing in the dual ARB player (although you can view the header information in the dual ARB player without playing the file)

You can reapply saved header settings by reselecting the waveform file for playback. When you do this, the values from the Saved Header Settings column are applied to the PSG.

Modifying Header Information

All of the same header characteristics shown in “Modifying Header Information in a Modulation Format” on page 90 are valid in the dual ARB player. This task guides you through selecting a waveform file and accessing the header for the selected file, then refers you back to the aforementioned procedure to perform the modifications.

1. Select a waveform:
   a. Press Mode > Dual ARB > Select Waveform.
   b. Using the arrow keys, highlight the desired waveform file.
   c. Press the Select Waveform softkey.
4. Refer to “Modifying Header Information in a Modulation Format” to edit the header information:
   • For a default header, read the information in step one on page 90, then perform the remaining steps in the procedure.
   • To modify an existing file header, start with step three on page 92.

The rest of this section focuses on the additional file header operations found in the dual ARB player.
Viewing Header Information with the Dual ARB Player Off

One of the differences between a modulation format and the dual ARB player is that even when the dual ARB player is off, you can view a file header. You cannot, however, modify the displayed file header unless the dual ARB player is on, and the displayed header is selected for playback. With the dual ARB player off, perform the following steps.

1. Select a waveform:
   a. Press **Mode > Dual ARB > Select Waveform**.
   b. Highlight the desired waveform file.
   c. Press the **Select Waveform** softkey.

2. Access the file header: Press **ARB Setup > Header Utilities**.
   The header information is now visible in the PSG display. As shown in Figure 5-6, the header editing softkeys are grayed-out, meaning they are inactive.

![Figure 5-6 Viewing Header Information](image)

**Header Field**
- **Description**: DSC_JM
- **Sample Rate**: 5.0000 MHz
- **RUNTIME Setting**: 50.000 %
- **Marker 1 Polarity**: Negative
- **Marker 2 Polarity**: Positive
- **Marker 3 Polarity**: Positive
- **Marker 4 Polarity**: Positive
- **RF Hold Duration**: None
- **RF Hold Poling**: None
- **High Level Node**: DFF
- **Low Level Node**: OFF
- **I/O Pad Filter**: Through
- **I/O Output Filter**: Auto

**Sample Rate**: 20.00000000000 MHz
**AMplitude**: -135.00 dB
Viewing Header Information for a Different Waveform File

While a waveform is playing in the dual ARB player, you can view the header information of a different waveform file, but you can modify the header information only for the waveform that is currently playing. When you select another waveform file, the header editing softkeys are grayed-out (see Figure 5-6). This task guides you through the available viewing choices.

1. View the waveform file list: Press Mode > Dual ARB > ARB Setup > Header Utilities > View Different Header.

   As shown in Figure 5-7, there is an alphabetical list of waveform files in the table.

   **Figure 5-7 Waveform File List for Viewing a Different Header**

   ![Waveform File List](image)

   Current waveform file type
   Waveform File Types
   Table

2. View all waveform segments in non-volatile memory:
   a. Press the Catalog Type softkey. As shown in Figure 5-7, you have a choice of three waveform file types that can be displayed in the table accessed in step one.

      NVWFM displays all waveform segments stored in non-volatile memory
      Seq displays all waveform sequence files
      WFM1 displays all waveform segments stored in volatile memory
   b. Press the NVWFM softkey. The table displays the waveform files in non-volatile memory

3. View a waveform file's header information: Highlight a file and press the View Header softkey.

   The header information for the selected waveform file appears in the PSG display. If there is a waveform playing, its header information is replaced by this information, but the waveform settings used by the signal generator do not change. To return to the header information for the playing waveform, either press View Different Header, select the current playing waveform file, and press View Header, or press Return > Header Utilities.
Playing a Waveform File that Contains a Header

After a waveform file (AUTOGEN_WAVEFORM) is generated in a modulation format and the format is turned off, the file becomes accessible to and can be played back in only the dual ARB player. This is also true for downloaded waveform files (downloading files is described in the Programming Guide). When the waveform is selected for playback, the saved header information is used by the signal generator. Some of these settings appear as part of the labels of the softkeys used to set the parameters, and also appear on the dual ARB summary display (see Figure 5-8).

**NOTE**
The signal generator used to play back a stored waveform file must have the same options as are required to generate the file.

For details on applying file header settings and playing back a waveform, see “Playing a Waveform” on page 102.

To properly set up the instrument:

1. Select the waveform.
2. Modify the signal generator settings as desired.
3. Turn on the dual ARB.

**Figure 5-8** File Header Settings
Using the Dual ARB Waveform Player

The dual arbitrary (ARB) waveform player is used to edit and play waveform files. There are two types of waveform files: segments (WFM1) and sequences (SEQ). A segment is an individual waveform that is defined using an installed ARB format, such as Two Tone, and created using the internal arbitrary waveform generator. A sequence is several individual segments strung together in one file. Waveform files can also be created remotely and downloaded to the PSG for playback as a segment. For information on downloading waveforms, refer to the Programming Guide.

A waveform is generated when an ARB modulation format is turned on, and is named AUTOGEN_WAVEFORM. Because this default file name is shared among all ARB formats, if the file is not renamed in the dual ARB player after turning the modulation format off, it is overwritten when the same or another ARB format is turned on.

Waveform player features include waveform clipping, markers, and triggering. Clipping allows you to reduce high power peaks, which can cause adjacent channel noise. Markers and triggering are useful for synchronizing the output of the signal generator with other devices.

Before you can work with a waveform file, it must reside in volatile memory. A newly generated segment file (AUTOGEN_WAVEFORM) initially resides in volatile memory until you store it to non-volatile memory. Whenever you cycle the power on the PSG or download new firmware, you must reload your waveform file from non-volatile memory.

Accessing the Dual ARB Player

Press Mode > Dual ARB.

You are now at the first-level softkey menu as shown in the following figure. Most procedures after the procedure “Creating the First Waveform Segment” on page 100 start from this first-level softkey menu.
Creating Waveform Segments

There are two ways to provide waveform segments for use by the waveform sequencer. You can either download a waveform via remote interface or generate a waveform using one of the ARB modulation formats. For information on downloading waveforms via remote interface, see the Programming Guide.

The following procedure describes how to create waveform segments using internally generated two tone and multitone waveforms. In this example, you generate two waveform segments, then name and store them in ARB memory. After the two waveform segments are named and stored in ARB memory, they are used to build a waveform sequence in the procedure, “Building and Storing a Waveform Sequence” on page 101.

Generating the First Waveform

1. Press Preset.
2. Press Mode > Two Tone.
3. Press Alignment Left Cent Right to Right.
4. Press Two Tone Off On to On.
5. Press Two Tone Off On to Off.

This generates a two tone waveform with the tone on the right placed at the carrier frequency. During waveform generation, the T-TONE and I/Q annunciators activate. The waveform is stored in volatile memory with the default file name AUTOGEN_WAVEFORM, as you will see in the next section. The Two Tone mode was turned off after generation because a waveform cannot be renamed as a segment while it is in use.

NOTE
Because there can be only one AUTOGEN_WAVEFORM waveform in memory at any given time, you must rename this file to clear the way for a second waveform.

Creating the First Waveform Segment

1. Press Mode > Dual ARB.
2. Press Waveform Segments.
3. Press Load Store to Store.
4. Highlight the default segment AUTOGEN_WAVEFORM.
5. Press More (1 of 2) > Rename Segment > Editing Keys > Clear Text.
6. Enter a file name (for example, TTONE) using the alpha keys and the numeric keypad, and press Enter.

The waveform segment is renamed and remains in volatile memory as a WFM1 file.
Generating the Second Waveform

Use the following steps to generate a new multitone waveform with nine tones. During waveform generation, the M-TONE and I/Q annunciators activate. The waveform is stored in volatile memory with the default file name AUTOGEN_WAVEFORM.

1. Press Mode > Multitone > Initialize Table > Number Of Tones > 9 > Enter > Done.
2. Generate the waveform: press Multitone Off On to On.
3. Because a waveform cannot be renamed as a segment while it is in use, turn off Multitone mode now that the waveform has been generated: press Multitone Off On to Off.

Creating the Second Waveform Segment

In the following steps, the second waveform segment is renamed and remains in volatile memory as a WFM1 file.

1. Press Mode > Dual ARB > Waveform Segments > Load Store to Store.
2. Highlight the default segment AUTOGEN_WAVEFORM.
4. Enter a file name (for example, MTONE) using the alpha keys and the numeric keypad.
5. Press Enter.

Building and Storing a Waveform Sequence

This example shows how to build and edit a waveform sequence using two waveform segments. If you have not created the waveform segments, complete the steps in “Creating Waveform Segments” on page 100. If you need to save or load waveform segments, see “Storing and Loading Waveform Segments” on page 103.

Selecting the Waveform Segments

Use the following steps to define a sequence as one repetition of the two-tone waveform segment followed by one repetition of the nine-tone multitone waveform segment.

1. Press Mode > Dual ARB > Waveform Sequences > Build New Waveform Sequence > Insert Waveform.
2. Highlight the first waveform segment (for example, TTONE) and press Insert Selected Waveform.
3. Highlight the second waveform segment (for example, MTONE) and press Insert Selected Waveform.
4. Press Done Inserting.

Storing the Waveform Sequence

Store the sequence under a new name to the Catalog of Seq Files in the memory catalog.

1. Press Name and Store.
2. Enter a file name (for example, TTONE+MTONE) using the alpha keys and the numeric keypad.
3. Press Enter.
Dual Arbitrary Waveform Generator

Using the Dual ARB Waveform Player

Playing a Waveform

You can play a waveform sequence or a waveform segment using this procedure. Both waveform types follow the same process.

This example plays a waveform sequence. If you have not created waveform segments and used them to build and store a waveform sequence, complete the steps in the previous procedures, “Creating Waveform Segments” on page 100, “Building and Storing a Waveform Sequence” on page 101.

Selecting a Waveform Sequence

1. Press Select Waveform.
2. Highlight a waveform (for example, TTONE+MTONE) from the Sequence column of the Select Waveform catalog, and press Select Waveform.

The display shows the currently selected waveform (for example, Selected Waveform: SEQ:TTONE+MTONE).

Generating the Waveform

Press ARB Off On until On is highlighted.

This plays the waveform sequence created in the previous sections. During the waveform sequence generation, the ARB and I/Q annunciators activate.

Editing a Waveform Sequence

This procedure demonstrates how to edit waveform segments within a waveform sequence, and then save the edited sequence under a new name. Within the editing display, you can change the number of times each segment plays (the repetitions), delete segments, add segments, toggle markers on or off (for more on markers, see “To Toggle Markers As You Create a Waveform Sequence” on page 107), and save changes.

NOTE

If you do not store changes to the waveform sequence prior to exiting the waveform sequence editing display, the changes are removed.

1. Press Waveform Sequences > Edit Selected Waveform Sequence, and highlight the first entry.
2. Press Edit Repetitions > 100 > Enter. The second segment is automatically selected.
3. Press Edit Repetitions > 200 > Enter.
4. Save the edited file as a new waveform sequence:
   a. Press Name And Store.
   b. Press Editing Keys > Clear Text, then enter a new file name (for example, TTONE100+MTONE200).
   c. Press Enter.
You have now changed the number of repetitions for each waveform segment entry from 1 to 100 and 200, respectively. The sequence has been stored under a new name to the Catalog of Seq Files in the signal generator’s memory catalog.

To play the waveform sequence, refer to “Playing a Waveform” on page 102.

Storing and Loading Waveform Segments

Waveform segments can reside in volatile memory as WFM1 files, or they can be stored to non-volatile memory as NVWFM files, or both. To play or edit a waveform file, it must reside in volatile memory. Because files stored in volatile memory do not survive a power cycle, it is a good practice to store important files to non-volatile memory and load them to volatile memory whenever you want to use them.

Storing Waveform Segments to Non-volatile Memory

1. Press Mode > Dual ARB > Waveform Segments.
2. If necessary, press Load Store to Store.
3. Press Store All To NVWFM Memory.

Copies of all WFM1 waveform segment files have been stored in non-volatile memory as NVWFM files. You can also store files individually by highlighting the file and pressing Store Segment To NVWFM Memory.

Loading Waveform Segments from Non-volatile Memory

1. Clear out the volatile memory and delete all WFM1 files: Power cycle the instrument.
2. Press Mode > Dual ARB > Waveform Segments.
3. If necessary, press Load Store to Load.
4. Press Load All From NVWFM Memory.

Copies of all NVWFM waveform segment files have been loaded into volatile memory as WFM1 files. You can also load files individually by highlighting the file and pressing Load Segment From NVWFM Memory.

Renaming a Waveform Segment

1. Press Mode > Dual ARB > Waveform Segments.
2. Highlight the desired file and press Rename Segment > Editing Keys > Clear Text.
3. Enter the desired file name, then press Enter.
Using Waveform Markers

Waveform markers provide auxiliary output signals that are synchronized with a waveform segment. You can place up to four markers on a waveform segment. However, only Marker 1 and Marker 2 can be placed using the waveform player’s user interface (for more information, refer to “Waveform Marker Concepts” on page 108).

Using markers, you can construct an output signal as a trigger to synchronize another instrument to a given portion of a waveform. You can also place markers into a waveform sequence, either as the sequence is being built or within an existing waveform sequence.

For instructions on verifying marker operation, see “To Verify Marker Operation” on page 107.

To Place a Marker at the First Point within a Waveform Segment

If you have not created a waveform segment, complete the steps in the previous sections, “Generating the First Waveform” on page 100 and “Creating the First Waveform Segment” on page 100.

1. Press Mode > Dual ARB > Waveform Segments.
2. Press Load Store.
3. Highlight a waveform segment (for example, TTONE).

This sets Marker 1 (selected by default) on the first point in the selected waveform segment.

To Place a Marker Across a Range of Points within a Waveform Segment

If you have not created a waveform segment, complete the steps in the previous sections, “Generating the First Waveform” on page 100 and “Creating the First Waveform Segment” on page 100.

1. Press Mode > Dual ARB > Waveform Segments.
2. Press Load Store.
3. Highlight a waveform segment (for example, TTONE).
5. Press First Mkr Point > 10 > Enter.
6. Press Last Mkr Point > 163830 > Enter.
7. Press Apply To Waveform.

NOTE  The last marker point must be greater than or equal to the first marker point.

This activates Marker 1 (selected by default) from point 10 to point 163830 in the selected waveform segment.
Dual Arbitrary Waveform Generator
Using Waveform Markers

To Place Repetitively Spaced Markers within a Waveform Segment

If you have not created a waveform segment, complete the steps in the previous sections, “Generating the First Waveform” on page 100 and “Creating the First Waveform Segment” on page 100.

1. Press Mode > Dual ARB > Waveform Segments.
2. Press Load Store.
3. Highlight a waveform segment (for example, TTONE).
5. Press First Mkr Point > Enter.
6. Press Last Mkr Point > Enter.
7. Press # Skipped Points > Enter.
8. Press Apply To Waveform.

NOTE The last marker point must be greater than or equal to the first marker point.

This activates Marker 1 (selected by default) every three points from point 10 to point 163830 in the selected waveform segment.

To Use Marker 2 to Blank the RF Output

If you have not created a waveform segment, complete the steps in the previous sections, “Generating the First Waveform” on page 100 and “Creating the First Waveform Segment” on page 100.

NOTE RF blanking applies to Marker 2 only. Marker 1 does not blank the RF output. For more information, see “Waveform Marker Concepts” on page 108.

1. Press Preset.
2. Press Mode > Dual ARB > Select Waveform.
3. Highlight a waveform segment (for example, TTONE).
4. Press Select Waveform.
5. Press Mode > Dual ARB > ARB Setup > Mkr 2 To RF Blank Off On.
8. Press First Mkr Point > Enter.
9. Press Last Mkr Point > Enter.
10. Press Apply To Waveform.
To Toggle Markers in an Existing Waveform Sequence

In a waveform sequence, you can independently toggle the operating state of the markers on each waveform segment. When you build a waveform sequence, the markers on each segment are toggled to the last marker operating state that was used.

In this example, you learn how to toggle markers within an existing waveform sequence. If you have not created waveform segments, used them to build and store a waveform sequence, and configured markers for the waveform sequence, complete the steps in the previous sections, “Creating Waveform Segments” on page 100, “Building and Storing a Waveform Sequence” on page 101, and “To Place a Marker at the First Point within a Waveform Segment” on page 104.

1. Press Mode > Dual ARB > Waveform Sequences.
2. Highlight the desired waveform sequence (for example, TTONE+MTONE).
3. Press Edit Selected Waveform Sequence.
4. Highlight the desired waveform segment (for example, WFM1:TTONE).
5. Press Toggle Markers > Toggle Marker 1 or Toggle Marker 2.
6. Highlight the next desired waveform segment.
7. Press Toggle Marker 1 or Toggle Marker 2.
8. Repeat steps 6 and 7 until you have finished modifying the desired waveform segments.
10. Press Name And Store.
11. Press Enter.

The markers are toggled per your selections, and the changes have been saved to the selected sequence file.

An entry (1, 2, or 12) in the Marker column indicates that a marker is active. No entry in that column means that both markers are off, as shown in Figure 5-9.

Figure 5-9
To Toggle Markers As You Create a Waveform Sequence

You can combine waveform segments to create a waveform sequence while independently toggling the markers of each waveform segment.

In this example, you learn how to toggle markers while building a waveform sequence. If you have not created waveform segments, complete the steps in the previous section, “Creating Waveform Segments” on page 100.

1. Press Mode > Dual ARB > Waveform Sequences > Build New Waveform Sequence.
2. Press Insert Waveform.
3. Highlight the desired waveform segment (for example, TTONE).
4. Press Insert Selected Waveform > Insert Selected Waveform > Done Inserting.
5. Highlight the first waveform segment.
   An entry (1, 2 or 12) in the Mk column indicates that a marker is active. No entry in that column means that both markers are off.
6. Press Toggle Markers.
7. Press Toggle Marker 1 and Toggle Marker 2 until only 2 is showing in the Mk column.
8. Press Return.

You now have a waveform sequence that contains two TTONE waveform segments. Marker 2 is on for the first waveform segment and markers 1 and 2 are on for the second waveform segment.

To Verify Marker Operation

In this example, you learn how to verify marker operation. If you have not created waveform segments and applied makers, complete the steps in the previous sections, “Creating Waveform Segments” on page 100 and “To Place a Marker at the First Point within a Waveform Segment” on page 104.

Once you set a marker on a waveform segment, you can detect the marker pulse at the EVENT 1 or EVENT 2 connectors (EVENT 1 for this example). For more information, see “Waveform Marker Concepts” on page 108

1. Press Mode > Dual ARB > Select Waveform.
2. Highlight the desired waveform segment or sequence.
4. Connect an oscilloscope input to the EVENT 1 connector, and trigger on the Event 1 signal.

When a marker is present, a marker pulse is displayed on the oscilloscope.
Waveform Marker Concepts

The Dual Arb mode of the signal generator has four markers that you can place on a waveform segment. Marker 1 and Marker 2 provide auxiliary output signals to the rear-panel EVENT 1 and EVENT 2 connectors, respectively. Markers 3 and 4 are available only for custom-programmed waveforms, and they provide auxiliary output signals to pins 19 and 18 of the rear-panel AUXILIARY I/O connector, respectively. You can construct these output signals as a trigger signal to synchronize another instrument to a given portion of a waveform. The following timing diagrams describe the effects of Markers 1 and 2 on the state of the signal at the EVENT 1 and EVENT 2 rear panel connectors.

NOTE
If marker polarity selection is not be available in your version of the firmware, marker polarity is always positive.

### Table 5-1

table

<table>
<thead>
<tr>
<th>Marker File Bit 1</th>
<th>Waveform point n</th>
<th>point n+1</th>
<th>point n+2</th>
<th>point n+3</th>
<th>...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Signal At EVENT 1 Connector</td>
<td>For Marker Polarity = Positive</td>
<td>For Marker Polarity = Negative</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

![Figure 5-10](image)

**Figure 5-10**

Positive

Marker Polarity

Negative

EVENT 1
### Table 5-2

**Marker 2 and EVENT 2**

<table>
<thead>
<tr>
<th>Marker File Bit 2</th>
<th>Waveform point $n$</th>
<th>point $n+1$</th>
<th>point $n+2$</th>
<th>point $n+3$</th>
<th>...</th>
</tr>
</thead>
</table>

**Signal At EVENT 2 Connector**

- For Marker Polarity = Positive
- For Marker Polarity = Negative

**RF Output**

- RF Unblanked (low)
  - Mkr 2 to RF Blank = Off
- RF Unblanked
  - RF Blanked
    - Mkr 2 to RF Blank = On
      - Marker Polarity = Positive
  - RF Blanked
    - Mkr 2 to RF blank = On
      - Marker Polarity = Negative
      - RF Blanked

---

**Dual Arbitrary Waveform Generator**

**Using Waveform Markers**
Dual Arbitrary Waveform Generator

Using Waveform Markers

A waveform sequence comprises waveform segments. When you combine segments to form a sequence, you can enable or disable Marker 1 and/or Marker 2 on a segment-by-segment basis.

When you select a sequence to output, the markers embedded in any one segment of that sequence are output only if the sequence marker for that segment is enabled (toggled on). This makes it possible to output markers for some segments in a sequence, but not for others.
Using Waveform Triggers

The dual arbitrary waveform generator includes several different triggering options: single, gated, segment advance, and continuous. The trigger source can be the Trigger hardkey, a command sent through the remote interface, or an external signal applied to the TRIGGER IN rear panel connector.

To Use Segment Advance Triggering

Using this procedure, you learn how to control sequence playback of two waveform segments using segment advance triggering.

If you have not created and stored a waveform sequence, complete the steps in the previous sections, “Creating Waveform Segments” on page 100, and “Building and Storing a Waveform Sequence” on page 101.

Configuring the Waveform Sequence Trigger

1. Press Preset.
2. Press Mode > Dual ARB > Select Waveform.
3. Highlight a waveform sequence file (for example, TTONE100+MTONE200).
4. Press Select Waveform.
5. Press Trigger > Segment Advance.
6. Press Trigger > Trigger Setup > Trigger Source > Trigger Key.

The first waveform segment in the sequence (TTONE) plays and modulates the RF carrier. The waveform player has been programmed to stop the playback of the current waveform segment and start the playback of the next waveform segment in the sequence when a trigger is received from the front panel Trigger hardkey.

You can now enable the RF output and use the signal.

Triggering the Second Waveform

1. Press the Trigger hardkey.
2. Observe the second waveform segment in the sequence (MTONE) is now playing.

Pressing the Trigger hardkey stops the playback of the first waveform segment and starts the playback of the second waveform segment. Pressing the Trigger hardkey again will return the waveform player to the first waveform segment.
Using Waveform Clipping

Clipping limits power peaks in waveform segments by clipping the I and Q data to a selected percentage of its highest peak. *Circular* clipping is defined as clipping the composite I/Q data (I and Q data are equally clipped). *Rectangular* clipping is defined as independently clipping the I and Q data. For more information, see “Waveform Clipping Concepts” on page 113.

In this section, you learn how to clip waveform segments. If you have not created waveform segments, complete the steps in the previous section, “Creating Waveform Segments” on page 100.

**To Configure Circular Clipping**

1. Press Mode > Dual ARB > Waveform Segments.
2. Press Load Store to Store.
3. Highlight the first waveform segment (for example, TTONE).
5. Press Clip |I+jQ| To > 80 > % > Apply to Waveform.

   The I and Q data are both clipped by 80%. You will see 80.0% displayed below the Clip |I+jQ| To softkey.

**To Configure Rectangular Clipping**

1. Press Mode > Dual ARB > Waveform Segments.
2. Press Load Store to Store.
3. Highlight the second waveform segment (for example, MTONE).
5. Press Clipping Type |I+JQ| |I|,|Q|.
   
   This activates the Clip |I| To and Clip |Q| To softkeys that allow you to configure rectangular (independent) I and Q data clipping.
6. Press Clip |I| To > 80 > %.
7. Press Clip |Q| To > 40 > % > Apply to Waveform.

   The I and Q data are individually clipped by 80% and 40%, respectively. You will see 80.0% displayed below the Clip |I| To softkey and 40.0% below the Clip |Q| To softkey.
Waveform Clipping Concepts

Waveforms with high power peaks can cause intermodulation distortion, which generates spectral regrowth (a condition that interferes with signals in adjacent frequency bands). The clipping function allows you to reduce high power peaks.

The clipping feature is available only with the Dual Arb mode.

How Power Peaks Develop

To understand how clipping reduces high power peaks, it is important to know how the peaks develop as the signal is constructed. I/Q waveforms can be the summation of multiple channels (see Figure 5-11).

Whenever most or all of the individual channel waveforms simultaneously contain a bit in the same state (high or low), an unusually high power peak (negative or positive) occurs in the summed waveform. This does not happen frequently because the high and low states of the bits on these channel waveforms are random, which causes a cancelling effect.

The I and Q waveforms combine in the I/Q modulator to create an RF waveform. The magnitude of the RF envelope is determined by the equation $\sqrt{I^2 + Q^2}$, where the squaring of I and Q always results in a positive value.
Dual Arbitrary Waveform Generator
Using Waveform Clipping

As shown in Figure 5-12, simultaneous positive and negative peaks in the I and Q waveforms do not cancel each other, but combine to create an even greater peak.

Figure 5-12  Combining the I and Q Waveforms

Resultant Baseband
Waveform Determined
by $\sqrt{I^2 + Q^2}$

Vector Representation
of High Peak
How Peaks Cause Spectral Regrowth

Because of the relative infrequency of high power peaks, a waveform will have a high peak-to-average power ratio (see Figure 5-13). Because a transmitter’s power amplifier gain is set to provide a specific average power, high peaks can cause the power amplifier to move toward saturation. This causes intermodulation distortion, which generates spectral regrowth.

Spectral regrowth is a range of frequencies that develops on each side of the carrier (similar to sidebands) and extends into the adjacent frequency bands (see Figure 5-14). Consequently, spectral regrowth interferes with communication in the adjacent bands. Clipping can provide a solution to this problem.
How Clipping Reduces Peak-to-Average Power

You can reduce peak-to-average power, and consequently spectral regrowth, by clipping the waveform to a selected percentage of its peak power. The PSG vector signal generator provides two different methods of clipping: circular and rectangular.

During circular clipping, clipping is applied to the combined I and Q waveform (|I + jQ|). Notice in Figure 5-15 that the clipping level is constant for all phases of the vector representation and appears as a circle.

During rectangular clipping, clipping is applied to the I and Q waveforms separately (|I|, |Q|). Notice in Figure 5-16 on page 117 that the clipping level is different for I and Q; therefore, it appears as a rectangle in the vector representation. With either method, the objective is to clip the waveform to a level that effectively reduces spectral regrowth, but does not compromise the integrity of the signal. Figure 5-17 on page 118 uses two complementary cumulative distribution plots to show the reduction in peak-to-average power that occurs after applying circular clipping to a waveform.

The lower you set the clipping value, the lower the peak power that is passed (or the more the signal is clipped). Often, the peaks can be clipped successfully without substantially interfering with the rest of the waveform. Data that might be lost in the clipping process is salvaged because of the error correction inherent in the coded systems. If you clip too much of the waveform, however, lost data is irrecoverable. You may have to try several clipping settings to find a percentage that works well.

Figure 5-15 Circular Clipping
Figure 5-16  Rectangular Clipping

Clipped I Waveform

Clipped Q Waveform

Vector Representation of Clipped I & Q Peak

a) || Clipping Set to 100% (No Clipping)
b) || Clipping Set to 75% of Greatest Peak
c) |Q| Clipping Set to 100% (No Clipping)
d) |Q| Clipping Set to 50% of Greatest Peak
Dual Arbitrary Waveform Generator
Using Waveform Clipping

Figure 5-17 Reduction of Peak-to-Average Power

Complementary Cumulative Distribution

- CCDF with Clipping = 100% (No Clipping)
- CCDF with Clipping = 80%

Reduction of Peak-to-Average Power Ratio

≈12 dB
≈11 dB
6 Custom Arb Waveform Generator

This chapter describes the Custom Arb Waveform Generator mode which is available only in E8267C PSG vector signal generators.

This chapter includes the following major sections:

- “Overview” on page 120
- “Working with Predefined Setups (Modes)” on page 121
- “Working with Filters” on page 125
- “Working with Symbol Rates” on page 133
- “Working with Modulation Types” on page 136
- “Configuring Hardware” on page 143

See also:

- “Using Waveform Markers” on page 104
- “Arbitrary (ARB) Waveform File Headers” on page 88
Custom Arb Waveform Generator

Overview

Custom Arb Waveform Generator mode can produce a single modulated carrier or multiple modulated carriers. Each modulated carrier waveform must be calculated and generated before it can be output; this signal generation occurs on the internal baseband generator (Option 002/602). Once a waveform has been created, it can be stored and recalled which enables repeatable playback of test signals.

To begin using the Custom Arb Waveform Generator mode, select whether to create a single modulated carrier or a multiple modulated carrier waveform:

- If you want to create a single modulated carrier waveform, start by selecting a Digital Modulation Setup from a set of predefined modes (setups). Once a predefined mode is selected, you can modify the Modulation Type, the Filter being used, the Symbol Rate, and the type of Triggering; the Data Pattern is random by default. This modified setup can then be stored and reused.

- If you want to create a multiple modulated carrier waveform, start by selecting a Multicarrier Setup from a set of predefined modes (setups). Once a predefined mode is selected, you can modify the number of carriers to be created, the frequency spacing between each carrier, whether the phase offset between each carrier is to be fixed or random, and the type of Triggering; the Data Pattern is random by default, the Filter is set to 40 MHz by default, and the Symbol Rate is automatically specified by the selected Modulation Type being used.
Working with Predefined Setups (Modes)

When you select a predefined mode, default values for components of the setup (including the filter, symbol rate, and modulation type) are automatically specified.

Selecting a Custom ARB Setup or a Custom Digital Modulation State

1. Preset the signal generator: press Preset.
2. Press Mode > Custom > Arb Waveform Generator > Setup Select.
3. Select either:
   - one of the predefined modulation setups: NADC, PDC, PHS, GSM, DECT, EDGE, APCO 25 w/ C4FM, APCO 25 w/ CQPSK, CDPD, PWT, or TETRA
     This selects a predefined setup where filtering, symbol rate, and modulation type are defined by the predefined modulation setup (mode) that you selected and returns you to the top-level custom modulation menu; it does not include bursting or channel coding.
   or
   - Custom Digital Mod State
     This selects a custom setup stored in the Catalog of DMOD Files (see page 122 for information on creating a custom digital modulation setup).
Custom Arb Waveform Generator

Working with User-Defined Setups (Modes)—Custom Arb Only

Modifying a Single-Carrier NADC Setup

In this procedure, you learn how to start with a single-carrier NADC digital modulation and modify it to a custom waveform with customized modulation type, symbol rate, and filtering.

1. Press **Preset**.
2. Press **Mode > Custom > ARB Waveform Generator > Setup Select > NADC**.
3. Press **Digital Mod Define > Modulation Type > PSK > QPSK and OQPSK > QPSK**.
4. Press **Symbol Rate > 56 > ksps**.
5. Press **Filter > Select > Nyquist**.

   This generates a waveform with the custom single-carrier NADC digital modulation state. The display changes to **Dig Mod Setup: NADC (Modified)**. During waveform generation, the **DIGMOD** and **I/Q** annunciators appear and the custom single-carrier digital modulation state is stored in volatile memory.

7. Set the RF output frequency to 835 MHz.
8. Set the output amplitude to 0 dBm.
9. Press **RF On/Off**.

   The user-defined NADC signal is now available at the RF OUTPUT connector.

10. Press **Return > Return**.

    This returns to the top-level Digital Modulation menu, where **Digital Modulation Off On** is the first softkey.

11. Press **Digital Mod Define > Store Custom Dig Mod State > Store To File**.

    If there is already a file name from the Catalog of DMOD Files occupying the active entry area, press: **Edit Keys > Clear Text**

12. Enter a file name (for example, **NADCQPSK**) using the alpha keys and the numeric keypad.

13. Press **Enter**.

   The user-defined single-carrier digital modulation state should now be stored in non-volatile memory. The RF output amplitude, frequency, and operating state settings are not stored as part of a user-defined digital modulation state file.
Customizing a Multicarrier Setup

In this procedure, you learn how to customize a predefined multicarrier digital modulation setup by creating a custom 3-carrier EDGE digital modulation state.

1. Press `Preset`.
3. Press `Multicarrier Define > Initialize Table > Carrier Setup > EDGE > Done`.
4. Highlight the `Freq Offset` value (500.000 kHz) for the carrier in row 2, and press `Edit Item > −625 > kHz`.
5. Highlight the `Power` value (0.00 dB) for the carrier in row 2, and press `Edit Item > −10 > dB`.

   You have a custom 2-carrier EDGE waveform with a carrier at a frequency offset of −625 kHz and a power level of −10.00 dBm.


   This generates a waveform with the custom multicarrier EDGE state. The display changes to `Dig Mod Setup: Multicarrier (Modified)`. During waveform generation, the DIGMOD and I/Q annunciators appear and the new custom multicarrier EDGE state is stored in volatile memory.

7. Set the RF output frequency to 890.01 MHz.
8. Set the output amplitude to −10 dBm.

   The custom multicarrier EDGE waveform is available at the RF OUTPUT connector; it does not include bursting or channel coding.

10. Press `Mode > Custom > Arb Waveform Generator`, where `Digital Modulation Off On` is the first softkey.


   If there is already a file name from the Catalog of MDMOD Files occupying the active entry area, press `Edit Keys > Clear Text`.

12. Enter a file name (for example, `EDGEM1`) using the alpha keys and the numeric keypad, and press `Enter`.

   The user-defined multicarrier digital modulation state is now stored in non-volatile memory.

---

**NOTE**

The RF output amplitude, frequency, and operating state settings (such as RF On/Off) are not stored as part of a user-defined digital modulation state file. For more information, refer to “Using Data Storage Functions” on page 52.
Recalling a User-Defined Custom Digital Modulation State

In this procedure, you learn how to select (recall) a previously stored custom digital modulation state from the Memory Catalog (the Catalog of DMOD Files).

1. Press **Preset**.
2. Press **Mode > Custom > ARB Waveform Generator > Setup Select**.
3. Press **More (1 of 2) > Custom Digital Mod State**.
4. Press **Select File** to select a custom modulation state from the Catalog of DMOD Files.

The user-defined custom digital modulation state should now be recalled from non-volatile memory. Because the RF output amplitude, frequency, and operating state settings are not stored as part of a user-defined digital modulation state file, they must still be set or recalled separately. For more information, refer to “Using Data Storage Functions” on page 52.
Working with Filters

This section provides information on using predefined (page 126) and user-defined (page 127) FIR filters.

NOTE

The procedures in this section apply only to filters created in either the Custom Arb Waveform Generator or Custom Real Time I/Q Baseband mode; they do not work with downloaded files, such as those created in Matlab.

The Filter menu selections enable you to apply a filter to the generated signal, define a finite impulse response (FIR) filter, change a Root Nyquist or Nyquist filter alpha, change a Gaussian filter BbT, or restore all filter parameters to their default state. In Custom Real Time I/Q mode, you can also optimize a FIR filter for Error Vector Magnitude (EVM) or Adjacent Channel Power (ACP).

Predefined Filters (Filter > Select)

- **Root Nyquist** is a root-raised cosine pre-modulation FIR filter. Use a Root Nyquist filter when you want to place half of the filtering in the transmitter and the other half in the receiver. The ideal root-raised cosine filter frequency response has unity gain at low frequencies, the square root of raised cosine function in the middle, and total attenuation at high frequencies. The width of the middle frequencies is defined by the roll off factor or Filter Alpha (0 < Filter Alpha < 1).

- **Nyquist** is a raised cosine pre-modulation FIR filter. You can use a Nyquist filter to reduce the bandwidth required by a signal without losing information. The ideal raised cosine filter frequency response comprises unity gain at low frequencies, a raised cosine function in the middle, and total attenuation at high frequencies. The width of the middle frequencies is defined by the roll off factor or Filter Alpha (0 < Filter Alpha < 1).

- **Gaussian** is a Gaussian pre-modulation FIR filter.

- **User FIR** enables you to select from a Catalog of FIR filters; use this selection if the other predefined FIR filters do not meet your needs. For more information, see Define User FIR, below.

- **Rectangle** is a rectangular pre-modulation FIR filter.

- **APCO 25 C4FM** is an APCO 25-specified C4FM filter; this is a Nyquist filter with an alpha of 0.200 that is combined with a shaping filter.

Filter Parameters

- **Define User FIR** is available for when the predefined FIR filters do not meet your needs. You can define FIR coefficients and set the oversample ratio (number of filter coefficients per symbol) to be applied to a custom FIR filter.
Custom Arb Waveform Generator

Working with Filters

- **Filter Alpha** enables you to adjust the filter alpha for a Nyquist or root Nyquist filter. If a Gaussian filter is used, you will see Filter BbT; this softkey is grayed out when any other filter is selected.

- *(Custom Realtime I/Q Baseband Only)* Optimize FIR for EVM ACP enables you to optimize a Nyquist or root Nyquist filter for minimized error vector magnitude (EVM) or for minimized adjacent channel power (ACP); the softkey is grayed out when any other filter is selected.

- **Restore Default Filters** replaces the current FIR filter with the default FIR filter for the selected format.

Using a Predefined FIR Filter

Selecting a Predefined FIR Filter

1. Preset the instrument: Press **Preset**.
2. Press **Mode > Custom > ARB Waveform Generator > Digital Mod Define > Filter > Select**
   or
   **Mode > Custom > Real Time I/ Q Baseband > Filter > Select**
3. Select the desired filter. If the filter you want is not in the first list, press **More (1 of 2)**.

Adjusting the Filter Alpha of a Predefined Root Nyquist or Nyquist Filter

1. Preset the instrument: Press **Preset**.
2. Press **Mode > Custom > ARB Waveform Generator > Digital Mod Define > Filter > Filter Alpha**
   or
   **Mode > Custom > Real Time I/ Q Baseband > Filter > Filter Alpha**
3. Enter a new Filter Alpha value and press **Enter**.

Adjusting the Bandwidth-Bit-Time (BbT) Product of a Predefined Gaussian Filter

1. Press **Mode > Custom > ARB Waveform Generator > Digital Mod Define > Filter > Select > Gaussian**
   or
   **Mode > Custom > Real Time I/ Q Baseband > Filter > Select > Gaussian**
2. Press **Filter BbT**.
3. Enter a new Bandwidth-Bit-Time (BbT) product filter parameter and press **Enter**.

Optimizing a Nyquist or Root Nyquist FIR Filter for EVM or ACP (Custom Realtime I/ Q Baseband only)

1. Preset the instrument: Press **Preset**.
2. Press **Mode > Custom > Real Time I/ Q Baseband > Filter > Optimize FIR For EVM or ACP**.
   The FIR filter is now optimized for minimum error vector magnitude (EVM) or for minimum adjacent channel power (ACP). This feature applies only to Nyquist and root Nyquist filters; the softkey is grayed out when any other filter is selected.
Restoring Default FIR Filter Parameters

1. Preset the instrument: Press Preset.
2. Press Mode > Custom > ARB Waveform Generator > Digital Mod Define > Filter > Restore Default Filter.

This replaces the current FIR filter with the default filter for the selected modulation format.

Using a User-Defined FIR Filter

FIR filters can be created and modified by defining the FIR coefficients or by defining the oversample ratio (number of filter coefficients per symbol) to be applied to your own custom FIR filter.

To Modify Predefined FIR Coefficients for a Gaussian Filter Using the FIR Values Editor

You can define from 1 to 32 FIR coefficients, where the maximum combination of symbols and oversample ratio is 1024 coefficients. While the FIR Values editor allows a maximum filter length of 1024 coefficients, the PSG hardware is limited to 64 symbols for real-time and 512 symbols for arbitrary waveform generation (the number of symbols equals the number of coefficients divided by the oversample ratio).

If you enter more than 64 symbols for real-time or 512 symbols for arbitrary waveform generation, the PSG cannot use the filter; it will decimate the filter (throw away coefficients) until the required condition is met and then use the filter, but fine resolution may be lost from the impulse response.

FIR filters stored in signal generator memory can easily be modified using the FIR Values editor. In this example, you will load the FIR Values editor with coefficient values from a default FIR filter (or, if one has been defined, a user-defined FIR file that has been stored in the Memory Catalog), modify the coefficient values, and store the new file to the Memory Catalog.

1. Press Preset.
2. Press Mode > Custom > Arb Waveform Generator > Digital Mod Define > Filter
   or
   Mode > Custom > Real Time I/ Q Baseband > Filter
4. Press Filter BbT > 0.300 > Enter.
5. Press Filter Symbols > 8 > Enter.
6. Press Generate.

NOTE

The actual oversample ratio during modulation is automatically selected by the instrument. A value between 4 and 16 is chosen dependent on the symbol rate, the number of bits per symbol of the modulation type, and the number of symbols.
Custom Arb Waveform Generator

Working with Filters

7. Press **Display Impulse Response**. A graph displays the impulse response of the current FIR coefficients.

![Impulse Response Graph]

8. Press **Return**.


10. Press 0 > **Enter**.

11. Press **Display Impulse Response**.

![Impulse Response Graph]

The graphic display can provide a useful troubleshooting tool (in this case, it indicates that a coefficient value is set incorrectly, resulting in an improper Gaussian response).

12. Press **Return**.

13. Highlight coefficient 15.

14. Press 1 > **Enter**.

15. Press **Load/Store > Store To File**.

16. Name the file NEWFIR2, and press **Enter**.

The contents of the current FIR Values editor are stored to a file in the Memory Catalog and the Catalog of FIR Files is updated to show the new file.
To Create a User-Defined FIR Filter with the FIR Values Editor

In this procedure, you use the FIR Values editor to create and store an 8-symbol, windowed, sinc function filter with an oversample ratio of 4. The Oversample Ratio (OSR) is the number of filter coefficients per symbol.

You can define from 1 to 32 FIR coefficients, where the maximum combination of symbols and oversample ratio is 1024 coefficients.

The FIR Values editor allows a maximum filter length of 1024 coefficients, but the PSG hardware is limited to 512 symbols for arbitrary waveform generation, and 64 symbols for real-time waveform generation. The number of symbols equals the number of coefficients divided by the oversample ratio. If you enter more than the maximum number of symbols, the PSG cannot use the filter; it decimates the filter (throws away coefficients) until the required condition is met and then uses the filter, but fine resolution may be lost from the impulse response.

1. Press **Preset**.
2. Press **Mode > Custom > Arb Waveform Generator > Digital Mod Define > Filter**
   or
   **Mode > Custom > Real Time I/Q Baseband > Filter**
3. Press **Define User FIR > More (1 of 2)**.
4. Press **Delete All Rows > Confirm Delete Of All Rows > More (2 of 2)**.
   This brings up the FIR Values editor and clears the table of existing values.

5. Press **Edit Item**. The Value field for coefficient 0 should be highlighted.
6. Use the numeric keypad to type the first value (−0.000076) from the following table and press Enter. As you press the numeric keys, the numbers are displayed in the active entry area. (If you make a mistake, you can correct it using the backspace key.) Continue entering the coefficient values from the table until all 16 values have been entered.

<table>
<thead>
<tr>
<th>Coefficient</th>
<th>Value</th>
<th>Coefficient</th>
<th>Value</th>
<th>Coefficient</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>−0.000076</td>
<td>6</td>
<td>0.043940</td>
<td>12</td>
<td>0.123414</td>
</tr>
<tr>
<td>1</td>
<td>−0.001747</td>
<td>7</td>
<td>0.025852</td>
<td>13</td>
<td>0.442748</td>
</tr>
<tr>
<td>2</td>
<td>−0.005144</td>
<td>8</td>
<td>−0.035667</td>
<td>14</td>
<td>0.767329</td>
</tr>
<tr>
<td>3</td>
<td>−0.004424</td>
<td>9</td>
<td>−0.116753</td>
<td>15</td>
<td>0.972149</td>
</tr>
<tr>
<td>4</td>
<td>0.007745</td>
<td>10</td>
<td>−0.157348</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>0.029610</td>
<td>11</td>
<td>−0.088484</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

7. Press Mirror Table.

In a windowed sinc function filter, the second half of the coefficients are identical to the first half, but in reverse order. The signal generator provides a mirror table function that automatically duplicates the existing coefficient values in the reverse order; coefficients 16 through 31 are automatically generated and the first of these coefficients (number 16) highlights, as shown in the following figure.

8. For this example, the desired OSR is 4, which is the default, so no action is necessary.

The Oversample Ratio (OSR) is the number of filter coefficients per symbol. Acceptable values range from 1 through 32; the maximum combination of symbols and oversampling ratio allowed by the FIR Values editor is 1024. Remember, however, that the instrument hardware is limited to 64 symbols for
real-time waveform generation, and 512 symbols for arbitrary waveform generation. The number of symbols equals the number of coefficients divided by the oversample ratio.


A graph displays the fast Fourier transform of the current set of FIR coefficients. The signal generator has the capability of graphically displaying the filter in both time and frequency dimensions.

![FFT Graph](image.png)

10. Press **Return > Display Impulse Response**.

A graph shows the impulse response of the current set of FIR coefficients.

![Impulse Response Graph](image.png)

11. Press **Return > Load/ Store > Store To File**.

The Catalog of FIR Files appears along with the amount of memory available.

12. If there is already a file name occupying the active entry area, press: **Edit Keys > Clear Text**

13. Using the alphabetic menu and the numeric keypad, enter **NEWFIR1** as the file name.

14. Press **Enter**.

The NEWFIR1 file is the first file name listed. (If you have previously stored other FIR files, additional file names are listed below NEWFIR1.) The file type is FIR and the size of the file is 260 bytes. The amount of memory used is also displayed. The number of files that can be saved depends on the size of the files and the amount of memory used.
Custom Arb Waveform Generator

**Working with Filters**

<table>
<thead>
<tr>
<th>FREQUENCY</th>
<th>AMPLITUDE</th>
</tr>
</thead>
<tbody>
<tr>
<td>20.000 000 000 000 GHz</td>
<td>-135.00 dBn</td>
</tr>
</tbody>
</table>

**Catalog of FIR Files**

<table>
<thead>
<tr>
<th>File Name</th>
<th>Type</th>
<th>Size</th>
<th>Modified</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>File</td>
<td>100 bytes</td>
<td>2001-02-01 08:12:15</td>
</tr>
</tbody>
</table>

**Load From**

Selected File

**Store To**

File

**Delete File**

**Goto Row**

**Page Up**

**Page Down**
Working with Symbol Rates

The Symbol Rate menu enables you to set the rate at which I/Q symbols are fed to the I/Q modulator. The default transmission symbol rate can also be restored in this menu.

- Symbol Rate (displayed as Sym Rate) is the number of symbols per second that are transmitted using the modulation (displayed as Mod Type) along with the filter and filter alpha (displayed as Filter). Symbol rate directly influences the occupied signal bandwidth.
  
  Symbol Rate is the Bit Rate divided by the number of bits that can be transmitted with each symbol; this is also known as the Baud Rate.

- Bit Rate is the frequency of the system bit stream. The internal baseband generator (Option 002/602) automatically streams the selected Data Pattern at the appropriate rate to accommodate the symbol rate setting (Bit Rate = Symbols/s x Number of Bits/Symbol).

- Occupied Signal Bandwidth = Symbol Rate x (1 + Filter Alpha); therefore, the occupied signal bandwidth is dependent on the filter alpha of the Nyquist or Root Nyquist filter being used. (To change the filter alpha, refer to the procedure, “Adjusting the Filter Alpha of a Predefined Root Nyquist or Nyquist Filter” on page 126.)

To Set a Symbol Rate

1. Press Preset.
2. Press Mode > Custom > ARB Waveform Generator > Digital Mod Define > Symbol Rate
   or
   Mode > Custom > Real Time I/Q Baseband > Symbol Rate
3. Enter a new symbol rate and press Msps, kps, or sps.

To Restore the Default Symbol Rate (Custom Real Time I/Q Only)

- Press Mode > Custom > Real Time I/Q Baseband > Symbol Rate > Restore Default Symbol Rate.
  
  This replaces the current symbol rate with the default symbol rate for the selected modulation format.
<table>
<thead>
<tr>
<th>Modulation Type</th>
<th>Bits Per Symbol</th>
<th>Bit Rate = Symbols/s x Number of Bits/ Symbol</th>
<th>Internal Symbol Rate (Minimum/Maximum)</th>
<th>Custom/Real Time Only External Symbol Rate (Minimum/Maximum)</th>
</tr>
</thead>
<tbody>
<tr>
<td>PSK Phase Shift Keying</td>
<td>QPSK and OQPSK (quadrature phase shift keying and offset quadrature phase shift keying) Includes: QPSK, IS95 QPSK, Gray Coded QPSK, OQPSK, IS95 OQPSK</td>
<td>2</td>
<td>90 bps – 100 Mbps</td>
<td>45 sps – 50 Msps</td>
</tr>
<tr>
<td>BPSK (binary phase shift keying)</td>
<td>1</td>
<td>45 bps – 50 Mbps</td>
<td>45 sps – 50 Msps</td>
<td>45 sps – 50 Msps</td>
</tr>
<tr>
<td>π/4 DQPSK</td>
<td>2</td>
<td>90 bps – 100 Mbps</td>
<td>45 sps – 50 Msps</td>
<td>45 sps – 25 Msps</td>
</tr>
<tr>
<td>8PSK (eight phase state shift keying)</td>
<td>3</td>
<td>135 bps – 150 Mbps</td>
<td>45 sps – 50 Msps</td>
<td>45 sps – 16.67 Msps</td>
</tr>
<tr>
<td>16PSK (sixteen phase state shift keying)</td>
<td>4</td>
<td>180 bps – 200 Mbps</td>
<td>45 sps – 50 Msps</td>
<td>45 sps – 12.5 Msps</td>
</tr>
<tr>
<td>D8PSK (eight phase state shift keying)</td>
<td>3</td>
<td>135 bps – 150 Mbps</td>
<td>45 sps – 50 Msps</td>
<td>45 sps – 16.67 Msps</td>
</tr>
<tr>
<td>MSK Minimum Shift Keying</td>
<td>MSK (GSM - Global System for Mobile Communications)</td>
<td>1</td>
<td>45 bps – 50 Mbps</td>
<td>45 sps – 50 Msps</td>
</tr>
<tr>
<td>FSK Frequency Shift Keying</td>
<td>2-Lvl FSK</td>
<td>1</td>
<td>45 bps – 50 Mbps</td>
<td>45 sps – 50 Msps</td>
</tr>
<tr>
<td>4-Lvl FSK</td>
<td>2</td>
<td>90 bps – 100 Mbps</td>
<td>45 sps – 50 Msps</td>
<td>45 sps – 25 Msps</td>
</tr>
<tr>
<td>8-Lvl FSK</td>
<td>3</td>
<td>135 bps – 150 Mbps</td>
<td>45 sps – 50 Msps</td>
<td>45 sps – 16.67 Msps</td>
</tr>
<tr>
<td>16-Lvl FSK</td>
<td>4</td>
<td>180 bps – 200 Mbps</td>
<td>45 sps – 50 Msps</td>
<td>45 sps – 12.5 Msps</td>
</tr>
<tr>
<td>C4FM</td>
<td>2</td>
<td>90 bps – 100 Mbps</td>
<td>45 sps – 50 Msps</td>
<td>45 sps – 25 Msps</td>
</tr>
<tr>
<td>Modulation Type</td>
<td>Bits Per Symbol</td>
<td>Bit Rate = Symbols/s x Number of Bits/ Symbol</td>
<td>Internal Symbol Rate (Minimum:Maximum)</td>
<td>Custom Real Time Only External Symbol Rate (Minimum:Maximum)</td>
</tr>
<tr>
<td>-----------------</td>
<td>-----------------</td>
<td>-----------------------------------------------</td>
<td>----------------------------------------</td>
<td>--------------------------------------------------------</td>
</tr>
<tr>
<td>QAM</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4QAM</td>
<td>2</td>
<td>90 bps – 100 Mbps</td>
<td>45 sps – 50 Msps</td>
<td>45 sps – 25 Msps</td>
</tr>
<tr>
<td>16QAM</td>
<td>4</td>
<td>180 bps – 200 Mbps</td>
<td>45 sps – 50 Msps</td>
<td>45 sps – 12.5 Msps</td>
</tr>
<tr>
<td>32QAM</td>
<td>5</td>
<td>225 bps – 250 Mbps</td>
<td>45 sps – 50 Msps</td>
<td>45 sps – 10 Msps</td>
</tr>
<tr>
<td>64QAM</td>
<td>6</td>
<td>270 bps – 300 Mbps</td>
<td>45 sps – 50 Msps</td>
<td>45 sps – 8.33 Msps</td>
</tr>
<tr>
<td>128QAM</td>
<td>7</td>
<td>315 bps – 350 Mbps</td>
<td>45 sps – 50 Msps</td>
<td>45 sps – 7.14 Msps</td>
</tr>
<tr>
<td>256QAM</td>
<td>8</td>
<td>360 bps – 400 Mbps</td>
<td>45 sps – 50 Msps</td>
<td>45 sps – 6.25 Msps</td>
</tr>
</tbody>
</table>

*128QAM There is no preset value for this modulation, it must be user defined.*
Working with Modulation Types

The Modulation Type menu enables you to specify the type of modulation applied to the carrier signal when the Mod On Off hardkey is on.

When the Custom Off On softkey is on:

- For Custom Arb, the BBG creates a sampled version of the I/Q waveform based on a random data pattern and the modulation type that has been selected.

- For Custom Real Time I/Q, the real-time custom I/Q symbol builder creates I/Q symbols based on the data pattern and modulation type that has been selected (see “Working with Data Patterns” on page 147 for information on selecting a data pattern).

In Custom Real Time I/Q, you can also:

- Create user-defined modulation type (see page 137) that can be used immediately or saved to the Memory Catalog.

- Restore all modulation parameters to their default state.

To Select a Predefined Modulation Type

1. Press Preset.
2. Press Mode > Custom > ARB Waveform Generator > Digital Mod Define > Modulation Type > Select
   or
   Mode > Custom > Real Time I/Q Baseband > Modulation Type > Select
3. Select one of the available modulation types.

NOTE If you select QPSK and OQPSK, you must make a specific selection from the menu that displays.
To Use a User-Defined Modulation Type (Real Time I/Q Only)

Creating a 128QAM I/Q Modulation Type User File with the I/Q Values Editor

In I/Q modulation schemes, symbols appear in default positions in the I/Q plane. Using the I/Q Values editor, you can define your own symbol map by changing the position of one or more symbols. Use the following procedure to create and store a 128-symbol QAM modulation.

**NOTE** Although this procedure provides a quick way to implement a 128QAM modulation format, it does not take full advantage of the I/Q modulator’s dynamic range. This is because you begin with a 256QAM constellation, and delete unwanted points. The remaining points that make up the 128QAM constellation are closer together than if you had mapped each point specifically. Additionally, this approach does not enable you to define the bit pattern associated with each symbol point, as you could if the 128QAM constellation had been defined one point at a time.

1. Press **Preset**.
2. Press **Mode > Custom > Real Time I/Q Baseband > Modulation Type > Define User I/Q > More (1 of 2) > Load Default I/Q Map > QAM > 256QAM**.
   
   This loads a default 256QAM I/Q modulation into the I/Q Values editor.
3. Press **More (2 of 2) > Display I/Q Map**.

   ![I/Q State Map](image)

   In the next steps, you will delete specific portions of this I/Q constellation and change it into a 128QAM with 128 I/Q states.
Custom Arb Waveform Generator

Working with Modulation Types

4. Press **Return** > **Goto Row** > **0011 0000** > **Enter**; this is row 48.

5. Press the **Delete Row** softkey 16 times.

Repeat this pattern of steps using the following table:

<table>
<thead>
<tr>
<th>Goto Row...</th>
<th>Press the Delete Row softkey...</th>
</tr>
</thead>
<tbody>
<tr>
<td>0110 0000 (96)</td>
<td>16 times</td>
</tr>
<tr>
<td>1001 0000 (144)</td>
<td>16 times</td>
</tr>
<tr>
<td>1100 0000 (192)</td>
<td>16 times</td>
</tr>
<tr>
<td>0001 0000 (16)</td>
<td>4 times</td>
</tr>
<tr>
<td>0001 0100 (20)</td>
<td>4 times</td>
</tr>
<tr>
<td>0001 1000 (24)</td>
<td>8 times</td>
</tr>
<tr>
<td>0011 0000 (48)</td>
<td>4 times</td>
</tr>
<tr>
<td>0011 0100 (52)</td>
<td>4 times</td>
</tr>
<tr>
<td>0011 1000 (56)</td>
<td>4 times</td>
</tr>
<tr>
<td>0101 1000 (88)</td>
<td>8 times</td>
</tr>
<tr>
<td>0111 0000 (112)</td>
<td>4 times</td>
</tr>
<tr>
<td>0111 0100 (116)</td>
<td>4 times</td>
</tr>
<tr>
<td>0111 1000 (120)</td>
<td>8 times</td>
</tr>
</tbody>
</table>

6. Press **Display I/Q Map** to view the new constellation that has been created. The I/Q State Map in this example has 128 symbols.

7. Press **Return**. When the contents of an **I/Q Values** table have not been stored, **I/Q Values (UNSTORED)** appears on the display.

8. Press **More (1 of 2) > Load/Store > Store To File**.

   If there is already a file name from the **Catalog of IQ Files** occupying the active entry area, press the following keys:

   **Editing Keys > Clear Text**

9. Enter a file name (for example, 128QAM) using the alpha keys and the numeric keypad.

10. Press **Enter**.

    The user-defined I/Q State Map should now be stored in the **Catalog of IQ Files**.
Creating a QPSK I/ Q Modulation Type User File with the I/ Q Values Editor

In I/Q modulation schemes, symbols appear in default positions in the I/Q plane. Using the I/Q Values editor, you can define your own symbol map by changing the position of one or more symbols. Use the following procedure to create and store a 4-symbol unbalanced QPSK modulation.

1. Press Preset.
2. Press Mode > Custom > Real Time I/ Q Baseband > Modulation Type > Define User I/ Q > More (1 of 2) > Delete All Rows > Confirm Delete All Rows.

This loads a default 4QAM I/Q modulation and clears the I/Q Values editor.

3. Enter the I and Q values listed in the following table:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Data</th>
<th>I Value</th>
<th>Q Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0000</td>
<td>0.500000</td>
<td>1.000000</td>
</tr>
<tr>
<td>1</td>
<td>0001</td>
<td>−0.500000</td>
<td>1.000000</td>
</tr>
<tr>
<td>2</td>
<td>0010</td>
<td>0.500000</td>
<td>−1.000000</td>
</tr>
<tr>
<td>3</td>
<td>0011</td>
<td>−0.500000</td>
<td>−1.000000</td>
</tr>
</tbody>
</table>

a. Press 0.5 > Enter.
b. Press 1 > Enter.
c. Enter the remaining I and Q values.

As the I value updates, the highlight moves to the first Q entry (and provides a default value of 0) and an empty row of data appears below the first row. As the Q value updates, the highlight moves to the next I value. As you press the numeric keys, the numbers display in the active entry area. If you make a mistake, use the backspace key and retype.

Also note that 0.000000 appears as the first entry in the list of Distinct Values, and that 0.500000 and 1.000000 are listed as the distinct values.


An I/Q State Map is displayed from the current values in the I/Q Values table.

The I/Q State Map in this example has four symbols. The I/Q State Map uses the following four unique values: 0.5, 1.0, −0.5, and −1.0 to create the four symbols. It is not the number of values that defines how many symbols a map has, but how those values are combined.

5. Press Return.

When the contents of an I/Q Values table have not been stored, I/Q Values (UNSTORED) appears on the display.
Custom Arb Waveform Generator

Working with Modulation Types


   If there is already a file name from the Catalog of IQ Files occupying the active entry area, press the following keys: Editing Keys > Clear Text.

7. Enter a file name (for example, NEW4QAM) using the alpha keys and the numeric keypad.

8. Press Enter. The user-defined I/Q State Map should now be stored in the Catalog of IQ Files and can be recalled even after the E8267C PSG signal generator has been turned off.

Modifying a Predefined I/ Q Modulation Type (I/ Q Symbols) & Simulating Magnitude Errors & Phase Errors

Use the following procedure to manipulate symbol locations which simulate magnitude and phase errors. In this example, you edit a 4QAM constellation to move one symbol closer to the origin.

1. Press Preset.

2. Press Mode > Custom > Real Time I/ Q Baseband > Modulation Type > Define User I/ Q > More (1 of 2) > Load Default I/ Q Map > QAM > 4QAM.

   This loads a default 4QAM I/Q modulation into the I/Q Values editor.


4. In the I/Q Values editor, navigate to Data 00000000 and press Edit Item.

5. Press .235702 > Enter, then .235702 > Enter.

   When you press Enter the first time, the I value updates and the highlight moves to the first Q entry. The second time, the Q value updates and the highlight moves to the following I entry.

6. Press Display I/ Q Map. Note that one symbol has moved, as shown.
Creating an FSK Modulation Type User File with the Frequency Values Editor

Use this procedure to set the frequency deviation for data 00, 01, 10, and 11 to configure a user-defined FSK modulation.

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband > Modulation Type > Define User FSK > More (1 of 2) > Delete All Rows > Confirm Delete All Rows.
   
   This accesses the Frequency Values editor and clears the previous values.

3. Press 600 Hz.

4. Press 1.8 kHz.

5. Press -600 Hz.

6. Press -1.8 kHz.
   
   Each time you enter a value, the Data column increments to the next binary number, up to a total of 16 data values (from 0000 to 1111). An unstored file of frequency deviation values is created for the custom 4-level FSK file.

7. Press Load/Store > Store To File.
   
   If there is already a file name from the Catalog of FSK Files occupying the active entry area, press the following keys:

   Edit Keys > Clear Text

8. Enter a file name (for example, NEWFSK) using the alpha keys and the numeric keypad.

   
   The user-defined FSK modulation should now be stored in the Catalog of FSK Files.
Modifying a Predefined FSK Modulation Type User File with the Frequency Values Editor

Using the Frequency Values editor, you can define, modify, and store user-defined frequency shift keying modulation. The Frequency Values editor is available for custom Real-Time I/Q Baseband mode, but is not available for waveforms generated in custom Arb Waveform Generator mode. Use this example to learn how to add errors to a default FSK modulation.

1. Press **Preset**.
2. Press **Mode > Custom > Real Time I/Q Baseband > Modulation Type > Define User FSK > More (1 of 2) > Load Default FSK**.
3. Press **Freq Dev > 1.8 > kHz**.
4. Press **4-Lvl FSK**.
   
   This sets the frequency deviation and opens the Frequency Values editor with the 4-level FSK default values displayed. The frequency value for data 0000 is highlighted.

5. Press **-1.81 > kHz**.
6. Press **-590 > Hz**.
7. Press **1.805 > kHz**.
8. Press **610 > Hz**.
   
   As you modify the frequency deviation values, the cursor moves to the next data row. An unstored file of frequency deviation values is created for your custom 4-level FSK file.

9. Press **Load/Store > Store To File**.
   
   If there is already a file name from the Catalog of FSK Files occupying the active entry area, press the following keys:

   **Edit Keys > Clear Text**

10. Enter a file name (for example, NEWFSK) using the alpha keys and the numeric keypad.
11. Press **Enter**.
   
   The user-defined FSK modulation should now be stored in the Catalog of FSK Files.
Configuring Hardware

- “To Set the ARB Reference” see page 144

**To Set a Delayed, Positive Polarity, External Single Trigger**

Using this procedure, you learn how to utilize an external function generator to apply a delayed single-trigger to a custom multicarrier waveform.

1. Connect an Agilent 33120A function generator or equivalent to the signal generator PATT TRIGGER IN port, as shown in Figure 6-1.

   **Figure 6-1**

2. On the signal generator, press **Preset**.
3. Press **Mode > Custom > Arb Waveform Generator**.
4. Press **Multicarrier Off On** until On is highlighted.
5. Press **Trigger > Single**.
6. Press **Trigger > Trigger Setup > Trigger Source > Ext**.
7. Press **Ext Polarity Neg Pos** until Pos is highlighted.
8. Press **Ext Delay Off On** until On is highlighted.
9. Press **Ext Delay Time > 100 > msec**.

   The Custom Arb Waveform Generator has been configured to play a single multicarrier waveform 100 milliseconds after it detects a change in TTL state from low to high at the PATT TRIG IN rear panel connector.

10. Set the function generator waveform to a 0.1 Hz square wave at an output level of 0 to 5V.
Custom Arb Waveform Generator
Configuring Hardware

11. On the signal generator, press **Mode** > **Custom** > **Arb Waveform Generator** > **Digital Modulation Off On** until On is highlighted.

   This generates a waveform with the custom multicarrier state and the display changes to **Dig Mod Setup: Multicarrier**.

   During waveform generation, the **DIGMOD** and **I/Q** annunciators activate and the new custom multicarrier state is stored in volatile ARB memory. The waveform should be modulating the RF carrier.

12. Press **RF On/Off**.

   The externally single-triggered custom multicarrier waveform should be available at the signal generator’s RF OUTPUT connector 100 ms after receiving a change in TTL state from low to high at the PATT TRIG IN.

To Set the ARB Reference

Setting for an External or Internal Reference

1. Press **Custom** > **Arb Waveform Generator** > **More (1 of 2)**.

2. Press **ARB Reference Ext Int** to select either external or internal as the waveform sample clock reference.

   - If you select Ext, you must enter the reference frequency (250 kHz to 100 MHz) and apply the reference signal to the rear-panel BASEBAND GEN REF IN.
   
   - If you select Int, the internal clock is used for the arbitrary waveform (ARB) frequency reference.

Setting the External Frequency

The external Arb reference frequency is only used when the **ARB Reference Ext Int** softkey has been set to Ext (external).

1. Press **Custom** > **Arb Waveform Generator** > **More (1 of 2)**.

2. Press **Reference Freq**, enter a desired frequency (250 kHz to 100 MHz), and press **MHz**, **kHz**, or **Hz**.
7 Custom Real Time I/Q Baseband

This chapter describes the Custom Real Time I/Q Baseband mode which is available only in E8267C PSG vector signal generators.

This chapter includes the following major sections:

- “Overview” on page 146
- “Working with Predefined Setups (Modes)” on page 146
- “Working with Data Patterns” on page 147
- “Working with Burst Shapes” on page 153
- “Configuring Hardware” on page 158
- “Working with Phase Polarity” on page 160
- “Working with Differential Data Encoding” on page 160

See also:

- “Working with Filters” on page 125
- “Working with Symbol Rates” on page 133
- “Working with Modulation Types” on page 136
Custom Real Time I/Q Baseband

Overview

Overview

Custom Real Time I/Q Baseband mode can produce a single carrier, but it can be modulated with real time data that allows real time control over all of the parameters that affect the signal. The single carrier signal that is produced can be modified by applying various data patterns, filters, symbol rates, modulation types, and burst shapes.

To begin using the Custom Real Time I/Q Baseband mode, start by selecting from a set of predefined modes (setups) or specify a setup by selecting a Data Pattern, Filter, Symbol Rate, Modulation Type, Burst Shape, Configure Hardware, Phase Polarity, and whether Diff Data Encode is off or on.

Working with Predefined Setups (Modes)

When you select a predefined mode, default values for components of the setup (including the filter, symbol rate, and modulation type) are automatically specified.

Selecting a Predefined Real Time Modulation Setup

The following steps select a predefined mode where filtering, symbol rate, and modulation type are defined by the APCO 25 w/C4FM digital modulation standard, and return to the top-level custom modulation menu.

1. Press **Preset**.
2. Press **Mode > Custom > Real Time I/Q Baseband**.
4. Press **More (3 of 3)**.

Deselecting a Predefined Real Time Modulation Setup

To deselect any predefined mode that has been previously selected, and return to the top-level custom modulation menu:

1. Press **Preset**.
2. Press **Mode > Custom > Real Time I/Q Baseband**.
3. Press **More (1 of 3) > More (2 of 3) > Predefined Mode > None**.
4. Press **More (3 of 3)**.
Working with Data Patterns

This section provides information on the following:

- “Using a Predefined Data Pattern” on page 148
- “Using a User-Defined Data Pattern” on page 149
- “Using an Externally Supplied Data Pattern” on page 152

The Data menu enables you to select from predefined and user defined data patterns. Data Patterns are used for transmitting continuous streams of unframed data. When the Custom Off On softkey is on, the real-time custom I/Q symbol builder creates I/Q symbols based on the data pattern and modulation type that has been selected. Refer to “Working with Modulation Types” on page 136 for information on selecting a modulation type.

The following data patterns are available:

- PN sequence allows you to access a menu (PN9, PN11, PN15, PN20, PN23) for internal data generation of pseudorandom sequences (pseudorandom noise sequences); a pseudorandom noise sequence is a periodic binary sequence approximating, in some sense, a Bernoulli “coin tossing” process with equiprobable outcomes.

- FIX4 0000 allows you to define a 4-bit repeating sequence data pattern and make it the active function. The selected 4-bit pattern will be repeated as necessary to provide a continuous stream of data.

- Other Patterns allows you to access a menu of choices (4 1’s & 4 0’s, 8 1’s & 8 0’s, 16 1’s & 16 0’s, 32 1’s & 32 0’s, or 64 1’s & 64 0’s) from which you can select a data pattern. Each pattern contains an equal number of ones and zeroes. The selected pattern will be repeated as necessary to provide a continuous stream of data.

- User File allows you to access a menu of choices from which you can create a file and store it to the Catalog of Bit Files, select from a Catalog of Bit Files and use it, or select from a Catalog of Bit Files, edit the file, and resave the file.

- Ext allows data patterns to be fed into the I/Q symbol builder, through the DATA port, in real-time.
### Using a Predefined Data Pattern

**Selecting a Predefined PN Sequence Data Pattern**

1. Press Preset.
2. Press Mode > Custom > Real Time I/Q Baseband > Data > PN Sequence.
3. Press one of the following: PN9, PN11, PN15, PN20, PN23.

**Selecting a Predefined Fixed 4-bit Data Pattern**

1. Press Preset.
2. Press Mode > Custom > Real Time I/Q Baseband > Data > FIX4.
3. Press 1010 > Enter > Return.

**Selecting a Predefined Data Pattern Containing an Equal Number of 1s & 0s**

1. Press Preset.
2. Press Mode > Custom > Real Time I/Q Baseband > Data > Other Patterns.
3. Press one of the following:

   - 4 1's & 4 0's, 8 1's & 8 0's, 16 1's & 16 0's, 32 1's & 32 0's, or 64 1's & 64 0's.
Using a User-Defined Data Pattern

User Files (user-defined data pattern files) can be created and modified using the signal generator’s Bit File Editor or they can be created on a remote computer and moved to the signal generator for direct use; these remotely created data pattern files can also be modified with the Bit File Editor. For information on creating user-defined data files on a remote computer, see the programming guide.

These procedures demonstrate how to use the Bit File Editor to create, edit, and store user-defined data pattern files for use within the custom real-time I/Q baseband generator modulation. For this example, a user file is defined within a custom digital communication.

Creating a Data Pattern User File with the Bit File Editor

This procedure uses the Bit File Editor to create a Data Pattern User File and stores the resulting file in the Memory Catalog (described on page 52).

1. Press Preset.
2. Press Mode > Custom > Real Time I/Q Baseband > Data > User File > Create File.

   This opens the Bit File Editor, which contains three columns, as shown in the following figure.

   ![Bit File Editor Figure]

   **NOTE**
   When you create a new file, the default name is UNTITLED, or UNTITLED1, and so forth. This prevents overwriting previous files.
Custom Real Time I/Q Baseband

Working with Data Patterns

3. Enter the 32 bit values shown using the numeric keypad.

   Bit data is entered into the Bit File Editor in 1-bit format. The current hexadecimal value of the binary data is shown in the Hex Data column and the cursor position (in hexadecimal) is shown in the Position indicator.


5. Enter a file name (for example, USER1) using the alpha keys and the numeric keypad.

6. Press Enter.

   The user file should be renamed and stored to the Memory Catalog with the name USER1.

Selecting a Data Pattern User File from the Catalog of Bit Files

In this procedure, you learn how to select a data pattern user file from the Catalog of Bit Files. If you have not created and stored a user-defined data file, complete the steps in the previous section, “Creating a Data Pattern User File with the Bit File Editor” on page 149.

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband > Data > User File.

3. Highlight the file to be selected (for example, USER1).


   The Bit File Editor should open the selected file (for example, USER1).
Modifying an Existing Data Pattern User File

In this example, you learn how to modify an existing data pattern user file by navigating to a particular bit position and changing its value. Next, you will learn how to invert the bit values of an existing data pattern user file.

If you have not already created, stored, and recalled a data pattern user file, complete the steps in the previous sections, “Creating a Data Pattern User File with the Bit File Editor” on page 149 and “Selecting a Data Pattern User File from the Catalog of Bit Files” on page 150.

Navigating the Bit Values of an Existing Data Pattern User File

1. Press **Goto > 4 > C > Enter**.

   This moves the cursor to bit position 4C, of the table, as shown in the following figure.
Custom Real Time I/Q Baseband

Working with Data Patterns

Inverting the Bit Values of an Existing Data Pattern User File

1. Press 1011.

   This inverts the bit values that are positioned 4C through 4F. Notice that hex data in this row has now changed to 76DB6DB6, as shown in the following figure.

   ![](bits_inversion.png)

   **Bits 4C through 4F inverted**

   **Hex Data changed**

   

To Apply Bit Errors to an Existing Data Pattern User File

This example demonstrates how to apply bit errors to an existing data pattern user file. If you have not created and stored a data pattern user file, first complete the steps in the previous section, “Creating a Data Pattern User File with the Bit File Editor” on page 149.

1. Press **Apply Bit Errors**.
2. Press **Bit Errors > 5 > Enter**.
3. Press **Apply Bit Errors**.
   Notice both **Bit Errors** softkeys change value as they are linked.

Using an Externally Supplied Data Pattern

In this procedure, an external real time data pattern is supplied through DATA, DATA CLOCK, and SYMBOL SYNC connectors.

1. Press **Preset**.
2. Press **Mode > Custom > Real Time I/Q Baseband > Data > Ext**.
3. Connect the real-time data to the DATA input.
4. Connect the data clock trigger signal to DATA CLOCK input.
5. Connect the symbol sync trigger to the SYMBOL SYNC input.
Working with Burst Shapes

- “Configuring the Burst Rise and Fall Parameters” on page 154
- “Using User-Defined Burst Shape Curves” on page 155

The Burst Shape menu enables you to modify the rise and fall time, rise and fall delay, and the burst shape (either sine or user file defined). In addition, you can define the shape of the burst and preview the burst shape through a Rise Shape Editor, or restore all of the burst shape parameters back to their original default state.

Rise time  the period of time, specified in bits, where the burst increases from a minimum of $-70 \text{ dB} (0)$ to full power (1).

Fall time  the period of time, specified in bits, where the burst decreases from full power (1) to a minimum of $-70 \text{ dB} (0)$.

Rise delay  the period of time, specified in bits, that the start of the burst rise is delayed. Rise delay can be either negative or positive. Entering a delay other than zero shifts the full power point earlier or later than the beginning of the first useful symbol.

Fall delay  the period of time, specified in bits, that the start of the burst fall is delayed. Fall delay can be either negative or positive. Entering a delay other than zero shifts the full power point earlier or later than the end of the last useful symbol.

User-defined burst shape  up to 256 user-entered values, which define the shape of the curve in the specified rise or fall time. The values can vary between 0 (no power) and 1 (full power) and are scaled linearly. Once specified, the values are resampled as necessary to create the cubic spline that passes through all of the sample points.

The default burst shape of each format is implemented according to the standards of the format selected. You can, however, modify the following aspects of the burst shape:

![Diagram of burst shape parameters](image)
Custom Real Time I/Q Baseband

Working with Burst Shapes

Burst shape maximum rise and fall time values are affected by the following factors:

- the symbol rate
- the modulation type

When the rise and fall delays equal 0, the burst shape attempts to synchronize the maximum burst shape power to the beginning of the first valid symbol and the ending of the last valid symbol.

If you find that the error vector magnitude (EVM) or adjacent channel power (ACP) increases when you turn bursting on, you can adjust the burst shape to assist with troubleshooting.

Configuring the Burst Rise and Fall Parameters

1. Press **Preset**.
2. Press **Mode > Custom > Real Time I/Q Baseband > Burst Shape**.
3. Press **Rise Time > 5 > bits**.
4. Press **Rise Delay > 1 > bits**.
5. Press **Fall Time > 5 > bits**.
6. Press **Fall Delay > 1 > bits**.

This configures the burst shape for the custom real-time I/Q baseband digital modulation format. For instructions on creating and applying user-defined burst shape curves, see “To Create and Store User-Defined Burst Shape Curves” on page 155.
Using User-Defined Burst Shape Curves

You can adjust the shape of the rise time curve and the fall time curve using the Rise Shape and Fall Shape editors. Each editor enables you to enter up to 256 values, equidistant in time, to define the shape of the curve. The values are then resampled to create the cubic spline that passes through all of the sample points.

The Rise Shape and Fall Shape editors are available for custom real-time I/Q baseband generator waveforms. They are not available for waveforms generated by the dual arbitrary waveform generator.

You can also design burst shape files externally and download the data to the signal generator. For more information, see the programming guide.

To Create and Store User-Defined Burst Shape Curves

Using this procedure, you learn how to enter rise shape sample values and mirror them as fall shape values to create a symmetrical burst curve.

1. Press Preset.
2. Press Mode > Custom > Real Time I/Q Baseband > Burst Shape.
3. Press Define User Burst Shape > More (1 of 2) > Delete All Rows > Confirm Delete Of All Rows.
4. Enter values similar to the sample values in the following table:

<table>
<thead>
<tr>
<th>Sample</th>
<th>Value</th>
<th>Sample</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0.000000</td>
<td>5</td>
<td>0.900000</td>
</tr>
<tr>
<td>1</td>
<td>0.400000</td>
<td>6</td>
<td>0.950000</td>
</tr>
<tr>
<td>2</td>
<td>0.600000</td>
<td>7</td>
<td>0.980000</td>
</tr>
<tr>
<td>3</td>
<td>0.750000</td>
<td>8</td>
<td>0.990000</td>
</tr>
<tr>
<td>4</td>
<td>0.830000</td>
<td>9</td>
<td>1.000000</td>
</tr>
</tbody>
</table>

a. Highlight the value (1.000000) for sample 1.
b. Press .4 > Enter.
c. Press .6 > Enter.
d. Enter the remaining values for samples 3 through 9 from the table above.
e. Press More (2 of 2) > Edit Fall Shape > Load Mirror Image of Rise Shape > Confirm Load Mirror Image of Rise Shape.

This changes the fall shape values to a mirror image of the rise shape values.
Custom Real Time I/Q Baseband

Working with Burst Shapes

5. Press **More (1 of 2)** > **Display Burst Shape**.

   This displays a graphical representation of the waveform’s rise and fall characteristics.

6. Press **Return** > **Load/Store** > **Store To File**.

   If there is already a file name from the Catalog of SHAPE Files occupying the active entry area, press the following keys: **Editing Keys** > **Clear Text**
7. Enter a file name (for example, NEWBURST) using the alpha keys and the numeric keypad.

8. Press Enter.

The contents of the current Rise Shape and Fall Shape editors are stored to the Catalog of SHAPE Files. This burst shape can now be used to customize a modulation or as a basis for a new burst shape design.

**To Select and Recall a User-Defined Burst Shape Curve from the Memory Catalog**

Once a user-defined burst shape file is stored in the Memory Catalog, it can be recalled for use with real-time I/Q baseband generated digital modulation.

This example requires a user-defined burst shape file stored in memory. If you have not created and stored a user-defined burst shape file, complete the steps in the previous sections.

1. Press Preset.

2. Press Mode > Custom > Real Time I/Q Baseband > Burst Shape > Burst Shape Type > User File.

3. Highlight the desired burst shape file (for example, NEWBURST).

4. Press Select File.

The selected burst shape file is now applied to the current real-time I/Q baseband digital modulation state.

5. Press Return > Custom Off On.

This generates the custom modulation with user-defined burst shape created in the previous steps. During waveform generation, the CUSTOM and I/Q annunciators activate. The waveform is now modulating the RF carrier.


The current real-time I/Q baseband digital modulation format with user-defined burst shape should be available at the signal generator’s RF OUTPUT connector.
Configuring Hardware

To Set the BBG Reference

Setting for an External or Internal Reference

1. Press **Mode > Custom > Real Time I/Q Baseband > More (1 of 3) > Configure Hardware**.

   Configure Hardware displays a menu where you can set the BBG Reference to External or Internal.

2. Press **BBG Ref Ext Int** to select either external or internal as the bit-clock reference for the data generator.

   If external is selected, apply the reference frequency to the rear-panel BASEBAND GEN REF IN connector.

Setting the External Frequency

The BBG reference external frequency is used only when the **BBG Ref Ext Int** softkey has been set to Ext (external).

1. Press **Mode > Custom > Real Time I/Q Baseband > More (1 of 3) > Configure Hardware**.

   Configure Hardware displays a menu where you can set the external BBG reference frequency.

2. Press **Ext BBG Ref Freq**.

3. Use the numeric keypad to a desired frequency, then press **MHz, kHz, or Hz**.

To Set the BBG Reference

To Set the External DA TA CLOCK to Receive Input as Either Normal or Symbol” on page 159

To Set the BBG DATA CLOCK to External or Internal” on page 159

“To Adjust the I/Q Scaling” on page 159

“*To Set the BBG Reference*” on page 158
To Set the External DATA CLOCK to Receive Input as Either Normal or Symbol

1. Press **Mode > Custom > Real Time I/Q Baseband > More (1 of 3) > Configure Hardware.**

   Configure Hardware allows you to access a menu from which you can set the external DATA CLOCK to receive input as either Normal or Symbol.

2. Press **Ext Data Clock** to select either Normal or Symbol; this setting has no effect in internal clock mode.
   - When set to Normal, the DATA CLOCK input connector requires a bit clock.
   - When set to Symbol, a one-shot or continuous symbol sync signal must be provided to the SYMBOL SYNC input connector.

To Set the BBG DATA CLOCK to External or Internal

1. Press **Mode > Custom > Real Time I/Q Baseband > More (1 of 3) > Configure Hardware.**

   Configure Hardware allows you to access a menu from which you can set the BBG DATA CLOCK to receive input from External or Internal.

2. Press **BBG Data Clock Ext Int** to select either external or internal.
   - When set to Ext (external), the DATA CLOCK connector is used to supply the BBG Data Clock.
   - When set to Int (internal), the internal data clock is used.

To Adjust the I/Q Scaling

Adjusting the I/Q Scaling (amplitude of the I/Q outputs) multiplies the I and Q data by the I/Q scaling factor that is selected and can be used to improve the Adjacent Channel Power (ACP). Lower scaling values equate to better ACP. This setting has no effect with MSK or FSK modulation.

1. Press **Mode > Custom > Real Time I/Q Baseband > More (1 of 3) > Configure Hardware.**

   Configure Hardware allows you to access a menu from which you can adjust the I/Q Scaling.

2. Press **I/Q Scaling**, enter a desired I/Q scaling level, and press %.
Working with Phase Polarity

To Set Phase Polarity to Normal or Inverted

1. Press **Mode** > **Custom** > **Real Time I/Q Baseband** > **More (1 of 3)** > **Phase Polarity Normal Invert**.

   Phase Polarity Normal Invert enables you to either leave the selection as Normal (so that the phase relationship between the I and Q signals is not altered by the phase polarity function), or set to Invert and invert the internal Q signal, reversing the rotation direction of the phase modulation vector.

   When you choose Invert, the in-phase component lags the quadrature-phase component by 90° in the resulting modulation. Inverted phase polarity is required by some radio standards and it is useful for lower sideband mixing applications. The inverted selection also applies to the I, I-bar, Q, and Q-bar output signals.

Working with Differential Data Encoding

The Diff Data Encode Off On menu enables you to toggle the operational state of the signal generator’s differential data encoding.

- When set to Off, data bits are not encoded prior to modulation.
- When set to On, data bits are encoded prior to modulation. Differential encoding uses an exclusive-OR function to generate a modulated bit. Modulated bits will have a value of 1 if a data bit is different from the previous bit or they will have a value of 0 if a data bit is the same as the previous bit.

This section provides information about the following:

- “Understanding Differential Encoding”
- “Using Differential Encoding” on page 165

Understanding Differential Encoding

Differential encoding is a digital-encoding technique whereby a binary value is denoted by a signal *change* rather than a particular signal state. Using differential encoding, binary data in any user-defined I/Q or FSK modulation can be encoded during the modulation process via symbol table offsets defined in the Differential State Map.

For example, consider the signal generator’s default 4QAM I/Q modulation. With a user-defined modulation based on the default 4QAM template, the I/Q Values editor contains data that represent four symbols (00, 01, 10, and 11) mapped into the I/Q plane using two distinct values, 1.000000 and -1.000000. These four
symbols can be differentially encoded during the modulation process by assigning symbol table offset values associated with each data value. Figure 7-3 shows the 4QAM modulation in the I/Q Values editor.

Figure 7-3

The number of bits per symbol can be expressed using the following formula. Because the equation is a ceiling function, if the value of \( x \) contains a fraction, \( x \) is rounded up to the next whole number.

\[
x = \lceil \log_2 (y) \rceil
\]

Where \( x \) = bits per symbol, and \( y \) = the number of differential states.

The following illustration shows a 4QAM modulation I/Q State Map.
Differential Data Encoding

In real-time I/Q baseband digital modulation waveforms, data (1’s and 0’s) are encoded, modulated onto a carrier frequency and subsequently transmitted to a receiver. In contrast to differential encoding, differential data encoding modifies the data stream prior to I/Q mapping. Where differential encoding encodes the raw data by using symbol table offset values to manipulate I/Q mapping at the point of modulation, differential data encoding uses the transition from one bit value to another to encode the raw data.

Differential data encoding modifies the raw digitized data by creating a secondary, encoded data stream that is defined by changes in the digital state, from 1 to 0 or from 0 to 1, of the raw data stream. This differentially encoded data stream is then modulated and transmitted.

In differential data encoding, a change in a raw data bit’s digital state, from 1 to 0 or from 0 to 1, produces a 1 in the encoded data stream. No change in digital state from one bit to the next, in other words a bit with a value of 1 followed by another bit with a value of 1 or a bit with a value of 0 followed by the same, produces a 0 in the encoded data. For instance, differentially encoding the data stream containing 01010011001010 renders 1111010101111.

Differential data encoding can be described by the following equation:

\[
\text{transmittedbit}(i) = \text{databit}(i - 1) \oplus \text{databit}(i)
\]

For a bit-by-bit illustration of the encoding process, see the following illustration:
How Differential Encoding Works

Differential encoding employs offsets in the symbol table to encode user-defined modulation schemes. The Differential State Map editor is used to introduce symbol table offset values, which in turn cause transitions through the I/Q State Map based on their associated data value. Whenever a data value is modulated, the offset value stored in the Differential State Map is used to encode the data by transitioning through the I/Q State Map in a direction and distance defined by the symbol table offset value.

Entering a value of +1 causes a 1-state forward transition through the I/Q State Map. As an example, consider the following data/symbol table offset values. These symbol table offsets result in one of the transitions shown.

<table>
<thead>
<tr>
<th>Example</th>
<th>Data</th>
<th>Offset Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>00000000</td>
<td>+1</td>
</tr>
<tr>
<td>2</td>
<td>00000001</td>
<td>−1</td>
</tr>
<tr>
<td>3</td>
<td>00000010</td>
<td>+2</td>
</tr>
<tr>
<td>4</td>
<td>00000011</td>
<td>0</td>
</tr>
</tbody>
</table>

NOTE: The following I/Q State Map illustrations show all possible state transitions using a particular symbol table offset value. The actual state-to-state transition depends on the state in which the modulation starts.

Example 1: transition 1 state forward

Example 2: transition 1 state backward

Example 3: transition 2 states forward

Example 4: no transition
When applied to the user-defined default 4QAM I/Q map, starting from the 1st symbol (data 00), the differential encoding transitions for the data stream (in 2-bit symbols) 0011100001 appear in the previous illustration.

As you can see, the 1st and 4th symbols, having the same data value (00), produce the same state transition (forward 1 state). In differential encoding, symbol values do not define location; they define the direction and distance of a transition through the I/Q State Map.

For instructions on configuring differential encoding, see “Understanding Differential Encoding” on page 160.
Using Differential Encoding

Differential encoding is a digital-encoding technique that denotes a binary value by a signal change rather than a particular signal state. It is available for Custom Real Time I/Q Baseband mode. It is not available for waveforms generated by Arb Waveform Generator mode.

The signal generator’s Differential State Map editor enables you to modify the differential state map associated with user-defined I/Q and user-defined FSK modulations. In this procedure, you create a user-defined I/Q modulation and then configure, activate, and apply differential encoding to the user-defined modulation. For more information, see “Understanding Differential Encoding” on page 160.

This section includes information on following:

• “Configuring User-Defined I/Q Modulation”
• “Accessing the Differential State Map Editor” on page 166
• “Editing the Differential State Map” on page 166

Configuring User-Defined I/Q Modulation

1. Press Preset.
2. Press Mode > Custom > Real Time I/Q Baseband > Modulation Type > Define User I/Q > More (1 of 2) > Load Default I/Q Map > QAM > 4QAM.

This loads a default 4QAM I/Q modulation and displays it in the I/Q Values editor. The default 4QAM I/Q modulation contains data that represent 4 symbols (00, 01, 10, and 11) mapped into the I/Q plane using 2 distinct values (1.000000 and −1.000000). These 4 symbols will be traversed during the modulation process by the symbol table offset values associated with each symbol of data.
Accessing the Differential State Map Editor

- Press **Configure Differential Encoding**.

This opens the Differential State Map editor. At this point, you see the data for the 1st symbol (00000000) and the cursor prepared to accept an offset value. You are now prepared to create a custom differential encoding for the user-defined default 4QAM I/Q modulation.

1. Press **1 > Enter**.

This encodes the first symbol by adding a symbol table offset of 1. The symbol rotates forward through the state map by 1 value when a data value of 0 is modulated.

2. Press **+/->1>Enter**.

This encodes the second symbol by adding a symbol table offset of -1. The symbol rotates backward through the state map by 1 value when a data value of 1 is modulated.

**NOTE**
At this point, the modulation has one bit per symbol. For the first two data values (00000000 and 00000001) only the last bits (the 0 and the 1, respectively) are significant.

3. Press **2>Enter**.

This encodes the third symbol by adding a symbol table offset of 2. The symbol rotates forward through the state map by 2 values when a data value of 10 is modulated.
4. Press 0 > Enter.

This encodes the fourth symbol by adding a symbol table offset of 0. The symbol does not rotate through the state map when a data value of 11 is modulated.

NOTE
At this point, the modulation has two bits per symbol. For the data values 00000000, 00000001, 00000010, 00000011, the symbol values are 00, 01, 10, and 11 respectively.


This applies the custom differential encoding to a user-defined modulation.

NOTE
Notice that (UNSTORED) appears next to Differential State Map on the signal generator’s display. Differential state maps are associated with the user-defined modulation for which they were created.

To save a custom differential state map, you must store the user-defined modulation for which it was designed. Otherwise the symbol table offset data is purged when you press the Confirm Exit From Table Without Saving softkey when exiting from the I/Q or FSK editor.
Custom Real Time I/ Q Baseband

Working with Differential Data Encoding
8 Multitone Waveform Generator

This chapter describes the Multitone mode, which is available only in E8267C PSG vector signal generators. This chapter includes the following major sections:

- “Overview” on page 170
- “Creating, Viewing, and Optimizing Multitone Waveforms” on page 171
Multitone Waveform Generator

Overview

Multitone Waveform Generator

Overview

The multitone mode builds a waveform that has up to 64 CW signals, or tones. Using the Multitone Setup table editor, you can define, modify, and store waveforms for playback. Multitone waveforms are generated by the internal I/Q baseband generator.

The multitone waveform generator is typically used for testing the intermodulation distortion characteristics of multi-channel devices, such as mixers or amplifiers. Intermodulation distortion (IMD) occurs when non-linear devices with multiple input frequencies cause unwanted outputs at other frequencies or interfere with adjacent channels. The multitone waveform generator supplies a waveform with a user-specified number of tones whose IMD products can be measured using a spectrum analyzer and used as a reference when measuring the IMD generated by a device-under-test.

Multitone waveforms are created using the internal I/Q baseband generator and stored in ARB memory for playback. Although the multitone mode generates a high-quality waveform, a small amount of IMD, carrier feedthrough, and feedthrough-related IMD occurs. Carrier feedthrough may be observed when an even number of tones are generated, since there are no tones at the center carrier frequency to mask the feedthrough. To minimize carrier feedthrough for an even-numbered multitone signal, it is necessary to manually adjust the I and Q offsets while observing the center carrier frequency with a spectrum analyzer.

For measurements that require more than 64 tones or the absence of IMD and carrier feedthrough, you can create up to 1024 distortion-free multitone signals using Agilent Technologies Signal Studio software Option 408.

NOTE For more information about multitone waveform characteristics and the PSG vector signal generator multitone format, download Application Note 1410 from our website by going to www.agilent.com and searching for “AN 1410” in Test & Measurement.
Creating, Viewing, and Optimizing Multitone Waveforms

This section describes how to set up, generate, and optimize a multitone waveform while viewing it with a spectrum analyzer. Although you can view a generated multitone signal using any spectrum analyzer that has sufficient frequency range, an Agilent Technologies PSA high-performance spectrum analyzer was used for this demonstration. Before generating your signal, connect the spectrum analyzer to the signal generator as shown in Figure 8-1.

**Figure 8-1** Spectrum Analyzer Setup

To Create a Custom Multitone Waveform

Using the Multitone Setup table editor, you can define, modify and store user-defined multitone waveforms. Multitone waveforms are generated by the dual arbitrary waveform generator.

1. Preset the signal generator.
2. Set the signal generator RF output frequency to 20 GHz.
3. Set the signal generator RF output amplitude to 0 dBm.
4. Press **Mode > Multitone > Initialize Table > Number of Tones > 9 > Enter.**
5. Press **Freq Spacing > 1 > MHz.**
7. Press **Done.**
8. Press **Multitone Off On** to On.
9. Turn on the RF output.
Multitone Waveform Generator

Creating, Viewing, and Optimizing Multitone Waveforms

The multitone signal should be available at the signal generator RF OUTPUT connector. Figure 8-2 on page 172 shows what the signal generator display should look like after all steps have been completed. Notice that the M-TONE, I/Q, RF ON, and MOD ON annunciators are displayed and the parameter settings for the signal are shown in the status area of the signal generator display. The multitone waveform is stored in volatile ARB memory.

The waveform has nine tones spaced 1 MHz apart with random initial phase values. The center tone is placed at the carrier frequency, while the other eight tones are spaced in 1 MHz increments from the center tone. If you create an even number of tones, the carrier frequency will be centered between the two middle tones.

To View a Multitone Waveform

This procedure describes how to configure the spectrum analyzer to view a multitone waveform and its IMD products. Actual key presses will vary, depending on the model of spectrum analyzer you are using.

1. Preset the spectrum analyzer.
2. Set the carrier frequency to 20 GHz.
3. Set the frequency span to 20 MHz.
4. Set the amplitude for a 10 dB scale with a 4 dBm reference.
5. Adjust the resolution bandwidth to sufficiently reduce the noise floor to expose the IMD products. A 9.1 kHz setting was used in our example.
6. Turn on the peak detector.
7. Set the attenuation to 14 dB, so you’re not overdriving the input mixer on the spectrum analyzer.

You should now see a waveform with nine tones and a 20 GHz center carrier frequency that is similar to the one shown in Figure 8-3 on page 173. You will also see IMD products at 1 MHz intervals above and below the highest and lowest tones.

**Figure 8-3**

![Waveform Diagram](image)

**To Edit the Multitone Setup Table**

This procedure builds upon the previous procedure.

1. Press **Initialize Table > Number of Tones > 10 > Enter.**
2. Press **Done.**
3. Highlight the value (On) in the **State** column for the tone in row 2.
4. Press **Toggle State.**
5. Highlight the value (0 dB) in the **Power** column for the tone in row 4.
Multitone Waveform Generator
Creating, Viewing, and Optimizing Multitone Waveforms

6. Press **Edit Item > -10 > dB**.
7. Highlight the value (0) in the **Phase** column for the tone in row 4.
8. Press **Edit Item > 123 > deg**.
9. Press **Apply Multitone**.

**NOTE**  Whenever a change is made to a setting while the multitone generator is operating (*Multitone Off On* set to On), you must apply the change by pressing the Apply Multitone softkey before the updated waveform will be generated. When you apply a change, the baseband generator creates a multitone waveform using the new settings and replaces the existing waveform in ARB memory.

You have now changed the number of tones to 10, disabled tone 2, and changed the power and phase of tone 4. **Figure 8-4 on page 174** shows what the multitone setup table display on the signal generator should look like after all steps have been completed. The spectrum analyzer should display a waveform similar to the one shown in **Figure 8-5 on page 175**. Notice that even-numbered multitone waveforms have a small amount of carrier feedthrough at the center carrier frequency.

**Figure 8-4**

![Multitone Setup Table Display](image-url)
Figure 8-5

To Minimize Carrier Feedthrough

This procedure describes how to minimize carrier feedthrough and measure the difference in power between the tones and their intermodulation distortion products. Carrier feedthrough can only be observed with even-numbered multitone waveforms.

This procedure builds upon the previous procedure.

1. On the spectrum analyzer, set the resolution bandwidth for a sweep rate of about 100-200 ms. This will allow you to dynamically view the carrier feedthrough spike as you make adjustments.

2. On the signal generator, press I/Q > I/Q Adjustments > I/Q Adjustments Off On to On.

3. Press I Offset and turn the rotary knob while observing the carrier feedthrough with the spectrum analyzer. Changing the I offset in the proper direction will reduce the feedthrough level. Adjust the level as low as possible.
4. Press Q Offset and turn the rotary knob to further reduce the carrier feedthrough level.
5. Repeat steps 3 and 4 until you have reached the lowest possible carrier feedthrough level.
6. On the spectrum analyzer, return the resolution bandwidth to its previous setting.
7. Turn on waveform averaging.
8. Create a marker and place it on the peak of one of the end tones.
9. Create a delta marker and place it on the peak of the adjacent intermodulation product, which should be spaced 10 MHz from the marked tone.
10. Measure the power difference between the tone and its distortion product.

You should now see a display that is similar to the one shown in Figure 8-6 on page 176. Your optimized multitone signal can now be used to measure the IMD products generated by a device-under-test.

Note that carrier feedthrough changes with time and temperature. Therefore, you will need to periodically readjust your I and Q offsets to keep the signal optimized.

**Figure 8-6**
**Creating, Viewing, and Optimizing Multitone Waveforms**

To Determine Peak to Average Characteristics

This procedure describes how to set the phases of the tones in a multitone waveform and determine the peak to average characteristics by plotting the complementary cumulative distribution function (CCDF).

1. Press **Mode > Multitone > Initialize Table** > **Number of Tones > 64 > Enter**.
2. Press **Freq Spacing > 20 > kHz**.
3. Press **Initialize Phase Fixed Random** to Fixed.
4. Press **Done**.
5. Press **Apply Multitone**.
6. Press **More (1 of 2) > Waveform Statistics > Plot CCDF**.

You should now see a display that is similar to the one shown in Figure 8-7. The CCDF plot displays the peak to average characteristics of the waveform with all phases set to zero.

**Figure 8-7**  CCDF Plot with Fixed Phase Set

7. Press **Mode Setup > Initialize Table**.
Multitone Waveform Generator
Creating, Viewing, and Optimizing Multitone Waveforms

10. Press **Done**.
11. Press **Apply Multitone**.

You should now see a display that is similar to the one shown in **Figure 8-8**. The CCDF plot displays the peak to average characteristics of the waveform with randomly generated phases and a random seed.

The random phase setup simulates the typically random nature of multitone waveforms. Notice that randomly distributed phases result in a much lower peak to average ratio than fixed phases. An increase in the number of tones with random phases will decrease the probability of a maximum peak power occurrence.

**Figure 8-8**  CCDF Plot with Random Phase Set
9 Two-Tone Waveform Generator

In the following sections, this chapter describes the Two Tone mode, which is available only in E8267C PSG vector signal generators.

- “Overview” on page 180
- “Creating, Viewing, and Modifying Two-Tone Waveforms” on page 181
Two-Tone Waveform Generator

Overview

The two-tone mode builds a waveform that has two equal-powered CW signals, or tones. The default waveform has two tones that are symmetrically spaced from the center carrier frequency, and have user-defined amplitude, carrier frequency, and frequency separation settings. The user can also align the tones left or right, relative to the carrier frequency.

The two-tone waveform generator is designed for testing the intermodulation distortion characteristics of non-linear devices, such as mixers or amplifiers. Intermodulation distortion (IMD) occurs when non-linear devices with multiple input frequencies interfere with adjacent channels or cause unwanted outputs at other frequencies. The two-tone waveform generator supplies a signal whose IMD products can be measured using a spectrum analyzer and used as a reference when measuring the IMD generated by a device-under-test.

Two-tone waveforms are created using the internal I/Q baseband generator and stored in ARB memory for playback. Although the two-tone mode generates a high-quality waveform, a small amount of IMD occurs. In addition to IMD, a small amount of carrier feedthrough and feedthrough-related IMD may be present when the spacing between the tones is centered on the carrier frequency. To minimize carrier feedthrough for a two-tone signal, you must manually adjust the I and Q offsets while observing the center carrier frequency with a spectrum analyzer. For measurements that require the absence of IMD and carrier feedthrough, you can create distortion-free multitone signals using Agilent Technologies’ Signal Studio software Option 408.

NOTE For more information about two-tone waveform characteristics and the PSG vector signal generator two-tone format, download *Application Note 1410* from our website by going to www.agilent.com and searching for “AN 1410” in Test & Measurement.
Creating, Viewing, and Modifying Two-Tone Waveforms

This section describes how to set up, generate, and modify a two-tone waveform while viewing it with a spectrum analyzer. Although you can view a generated two-tone signal using any spectrum analyzer that has sufficient frequency range, an Agilent Technologies PSA Series High-Performance Spectrum Analyzer was used for this demonstration. Before generating your signal, connect the spectrum analyzer to the signal generator as shown in Figure 9-1.

Figure 9-1  Spectrum Analyzer Setup

To Create a Two-Tone Waveform

This procedure describes how to create and a basic, center-aligned, two-tone waveform.

1. Preset the signal generator.
2. Set the signal generator RF output frequency to 20 GHz.
3. Set the signal generator RF output amplitude to 0 dBm.
4. Press Mode > Two Tone > Freq Separation > 10 > MHz.
5. Press Two Tone Off On to On.
6. Turn on the RF output.

The two-tone signal is now available at the signal generator RF OUTPUT connector. Figure 9-2 shows what the signal generator display should look like after all steps have been completed. Notice that the T-TONE, I/Q, RF ON, and MOD ON annunciators are displayed and the parameter settings for the signal are shown in the status area of the signal generator display.
Two-Tone Waveform Generator

Creating, Viewing, and Modifying Two-Tone Waveforms

Figure 9-2

To View a Two-Tone Waveform

This procedure describes how to configure the spectrum analyzer to view a two-tone waveform and its IMD products. Actual key presses will vary, depending on the model of spectrum analyzer you are using.

1. Preset the spectrum analyzer.
2. Set the carrier frequency to 20 GHz.
3. Set the frequency span to 60 MHz.
4. Set the amplitude for a 10 dB scale with a 4 dBm reference.
5. Adjust the resolution bandwidth to sufficiently reduce the noise floor to expose the IMD products. A 9.1 kHz setting was used in our example.
6. Turn on the peak detector.
7. Set the attenuation to 14 dB, so you’re not overdriving the input mixer on the spectrum analyzer.

You should now see a two-tone waveform with a 20 GHz center carrier frequency that is similar to the one shown in Figure 9-3 on page 183. You will also see IMD products at 10 MHz intervals above and below the generated tones, and a carrier feedthrough spike at the center frequency with carrier feedthrough distortion products at 10 MHz intervals above and below the center carrier frequency.
Figure 9-3

Two-Tone Waveform Generator
Creating, Viewing, and Modifying Two-Tone Waveforms
Two-Tone Waveform Generator

Creating, Viewing, and Modifying Two-Tone Waveforms

To Minimize Carrier Feedthrough

This procedure describes how to minimize carrier feedthrough and measure the difference in power between the tones and their intermodulation distortion products. Carrier feedthrough only occurs with center-aligned two-tone waveforms.

This procedure builds upon the previous procedure.

1. On the spectrum analyzer, set the resolution bandwidth for a sweep rate of about 100-200 ms. This will allow you to dynamically view the carrier feedthrough spike as you make adjustments.

2. On the signal generator, press I Q > I Q Adjustments > I/Q Adjustments Off On to On.

3. Press I Offset and turn the rotary knob while observing the carrier feedthrough with the spectrum analyzer. Changing the I offset in the proper direction will reduce the feedthrough level. Adjust the level as low as possible.

4. Press Q Offset and turn the rotary knob to further reduce the carrier feedthrough level.

5. Repeat steps 3 and 4 until you have reached the lowest possible carrier feedthrough level.

6. On the spectrum analyzer, return the resolution bandwidth to its previous setting.

7. Turn on waveform averaging.

8. Create a marker and place it on the peak of one of the two tones.

9. Create a delta marker and place it on the peak of the adjacent intermodulation product, which should be spaced 10 MHz from the marked tone.

10. Measure the power difference between the tone and its distortion product.

You should now see a display that is similar to the one shown in Figure 9-4 on page 185. Your optimized two-tone signal can now be used to measure the IMD products generated by a device-under-test.

Note that carrier feedthrough changes with time and temperature. Therefore, you will need to periodically readjust your I and Q offsets to keep your signal optimized.
Two-Tone Waveform Generator
Creating, Viewing, and Modifying Two-Tone Waveforms

Figure 9-4

[Diagram showing a graph with markers labeled as 'Main Marker', 'Minimized Carrier Feedthrough', and 'Delta Marker'.]
To Change the Alignment of a Two-Tone Waveform

This procedure describes how to align a two-tone waveform left or right, relative to the center carrier frequency. Because the frequency of one of the tones is the same as the carrier frequency, this alignment eliminates carrier feedthrough. However, image frequency interference caused by left or right alignment may cause minor distortion of the two-tone signal. This procedure builds upon the previous procedure.

2. Press Apply Settings to regenerate the waveform.

NOTE Whenever a change is made to a setting while the two-tone generator is operating (Two Tone Off On set to On), you must apply the change by pressing the Apply Settings softkey before the updated waveform will be generated. When you apply a change, the baseband generator creates a two-tone waveform using the new settings and replaces the existing waveform in ARB memory.

3. On the spectrum analyzer, temporarily turn off waveform averaging to refresh your view more quickly. You should now see a left-aligned two-tone waveform that is similar to the one shown in Figure 9-5.

Figure 9-5

Agilent 12:01:27 Jun 7, 2002

![Two-Tone Waveform Diagram](image-url)

Ref 0 dBm  10 dB
Upper Tone
Two-Tone Channels
Intermodulation
Distortion
Carrier Frequency

Center 20.0000 GHz  Span 80 MHz

Agilent 12:01:27 Jun 7, 2002

Agilent 12:01:27 Jun 7, 2002

Agilent 12:01:27 Jun 7, 2002
10 Troubleshooting

This chapter provides basic troubleshooting information for Agilent PSG signal generators. If you do not find a solution here, refer to the *Service Guide*.

**NOTE** If the signal generator displays an error, always read the error message text by pressing **Utility > Error Info**.

- “RF Output Power Problems” on page 189
- “No Modulation at the RF Output” on page 193
- “Sweep Problems” on page 194
- “Data Storage Problems” on page 196
- “Cannot Turn Off Help Mode” on page 197
- “Signal Generator Locks Up” on page 198
- “Error Messages” on page 200
- “Returning a Signal Generator to Agilent Technologies” on page 203
Troubleshooting
Troubleshooting
RF Output Power Problems

RF Output Power Problems

Check the RF ON/OFF annunciator on the display. If it reads RF OFF, press RF On/Off to toggle the RF output on.

RF Output Power too Low

1. Look for an OFFS or REF indicator in the AMPLITUDE area of the display.

   OFFS tells you that an amplitude offset has been set. An amplitude offset changes the value shown in the AMPLITUDE area of the display but does not affect the output power. The amplitude displayed is equal to the current power output by the signal generator hardware plus the value for the offset.

   To eliminate the offset, press the following keys:
   Amplitude > More (1 of 2) > Ampl Offset > 0 > dB.

   REF tells you that the amplitude reference mode is activated. When this mode is on, the displayed amplitude value is not the output power level. It is the current power output by the signal generator hardware minus the reference value set by the Ampl Ref Set softkey.

   To exit the reference mode, follow these steps:
   a. Press Amplitude > More (1 of 2).
   b. Press Ampl Ref Off On until Off is highlighted.

   You can then reset the output power to the desired level.

2. If you are using the signal generator with an external mixer, see “Signal Loss While Working with a Mixer” on page 190.

3. If you are using the signal generator with a spectrum analyzer, see “Signal Loss While Working with a Spectrum Analyzer” on page 192.

The Power Supply has Shut Down

If the power supply is not working, it requires repair or replacement. There is no user-replaceable power supply fuse. Refer to the Service Guide for instructions.
Troubleshooting
RF Output Power Problems

Signal Loss While Working with a Mixer

If you experience signal loss at the signal generator’s RF output during low-amplitude coupled operation with a mixer, you can solve the problem by adding attenuation and increasing the RF output amplitude of the signal generator.

Figure 10-1 on page 190 shows a hypothetical configuration in which the signal generator provides a low amplitude signal to a mixer.

Figure 10-1 Effects of Reverse Power on ALC

The internally leveled signal generator RF output (and ALC level) is -8 dBm. The mixer is driven with an LO of +10 dBm and has an LO-to-RF isolation of 15 dB. The resulting LO feedthrough of -5 dBm enters the signal generator’s RF output connector and arrives at the internal detector.

Depending on frequency, it is possible for most of this LO feedthrough energy to enter the detector. Since the detector responds to its total input power regardless of frequency, this excess energy causes the ALC to reduce the RF output of the signal generator. In this example, the reverse power across the detector is actually greater than the ALC level, which may result in loss of signal at the RF output.

Figure 10-2 on page 191 shows a similar configuration with the addition of a 10 dB attenuator connected between the RF output of the signal generator and the input of the mixer. The signal generator’s ALC level is increased to +2 dBm and transmitted through a 10 dB attenuator to achieve the required -8 dBm amplitude at the mixer input.
Compared to the original configuration, the ALC level is 10 dB higher while the attenuator reduces the LO feedthrough (and the RF output of the signal generator) by 10 dB. Using the attenuated configuration, the detector is exposed to a +2 dBm desired signal versus the -15 dBm undesired LO feedthrough. This 17 dB difference between desired and undesired energy results in a maximum 0.1 dB shift in the signal generator’s RF output level.
Troubleshooting

RF Output Power Problems

Signal Loss While Working with a Spectrum Analyzer

The effects of reverse power can cause problems with the signal generator’s RF output when the signal generator is used with a spectrum analyzer that does not have preselection capability.

Some spectrum analyzers have as much as +5 dBm LO feedthrough at their RF input port at some frequencies. If the frequency difference between the LO feedthrough and the RF carrier is less than the ALC bandwidth, the LO’s reverse power can cause amplitude modulation of the signal generator’s RF output. The rate of the undesired AM equals the difference in frequency between the spectrum analyzer’s LO feedthrough and the RF carrier of the signal generator.

Reverse power problems can be solved by using one of two unleveled operating modes: ALC off or power search.

Setting ALC Off Mode

ALC off mode deactivates the automatic leveling circuitry prior to the signal generator’s RF output. In this mode, a power meter is required to measure the output of the signal generator and assist in achieving the required output power at the point of detection.

Use the following steps to set the signal generator to the ALC off mode:

1. Preset the signal generator: press Preset.
2. Set the desired frequency: press Frequency and enter the desired frequency.
3. Set the desired amplitude: press Amplitude and enter the desired amplitude.
4. Turn the RF off: set RF On/Off to Off
5. Turn the signal generator’s automatic leveling control (ALC) off: press Amplitude > ALC Off On to Off.
6. Monitor the RF output amplitude as measured by the power meter.
7. Press Amplitude and adjust the signal generator’s RF output amplitude until the desired power is measured by the power meter.

Setting Power Search Mode

Power search mode executes a power search routine that temporarily activates the ALC, calibrates the power of the current RF output, and then disconnects the ALC circuitry.

Use the following steps to set the signal generator to manual fixed power search mode:

1. Preset the signal generator: press Preset.
2. Set the desired frequency: press Frequency and enter the desired frequency.
3. Set the desired amplitude: press Amplitude and enter the desired amplitude.
4. Turn the signal generator’s automatic leveling control (ALC) off: press Amplitude > ALC Off On to Off.
5. Turn the RF on: set RF On/Off to On.
   This executes the manual fixed power search routine, which is the default mode.
Troubleshooting

No Modulation at the RF Output

There are three power search modes: manual, automatic, and span.

When Power Search is set to Manual, pressing Do Power Search executes the power search calibration routine for the current RF frequency and amplitude. In this mode, if there is a change in RF frequency or amplitude, you will need to press Do Power Search again.

When Power Search is set to Auto, the calibration routine is executed whenever the frequency or amplitude of the RF output is changed.

When Power Search is set to Span, pressing Do Power Search executes the power search calibration routine over a selected range of frequencies at one time. The power search corrections are then stored and used whenever the signal generator is tuned within the selected range of frequencies.

No Modulation at the RF Output

Check the MOD ON/OFF annunciator on the display. If it reads MOD OFF, press Mod On/Off to toggle the modulation on.

Although you can set up and enable various modulations, the RF carrier is modulated only when you have also set Mod On/Off to On.

For digital modulation, make sure that I/ Q Off On is set to On.
Troubleshooting

Sweep Problems

Sweep Appears to be Stalled

The current status of the sweep is indicated as a shaded rectangle in the progress bar. You can observe the progress bar to determine if the sweep is progressing. If the sweep appears to have stalled, check the following:

- Have you turned on the sweep by pressing any of the following key sequences?
  - Sweep/List > Sweep > Freq
  - Sweep/List > Sweep > Ampl
  - Sweep/List > Sweep > Freq & Ampl

- Is the sweep in continuous mode? If the sweep is in single mode, be sure that you have pressed the Single Sweep softkey at least once since completion of the prior sweep. Try setting the mode to continuous to determine if the missing single sweep is blocking the sweep.

- Is the signal generator receiving the appropriate sweep trigger? Try setting the Sweep Trigger softkey to Free Run to determine if a missing sweep trigger is blocking the sweep.

- Is the signal generator receiving the appropriate point trigger? Try setting the Point Trigger softkey to Free Run to determine if a missing point trigger is blocking the sweep.

- Is the dwell time appropriate? Try setting the dwell time to one second to determine if the dwell time was set to a value which was too slow or too fast for you to see.

- Do you have at least two points in your step sweep or list sweep?

Cannot Turn Off Sweep Mode

Press Sweep/List > Sweep > Off.

In the sweep mode menu you can choose to set the sweep to various sweep types or to turn sweep off.
**Incorrect List Sweep Dwell Time**

If the signal generator does not dwell for the correct period of time at each sweep list point, follow these steps:

1. Press **Sweep/List > Configure List Sweep**.
   
   This displays the sweep list values.

2. Check the sweep list dwell values for accuracy.

3. Edit the dwell values if they are incorrect.

---

**NOTE**

The effective dwell time at the RF OUTPUT connector is the sum of the value set for the dwell plus processing time, switching time, and settling time. This additional time added to the dwell is generally a few milliseconds. The TTL/CMOS output available at the TRIG OUT connector, however, is asserted high only during the actual dwell time.

---

If the list dwell values are correct, continue to the next step.

4. Observe if the **Dwell Type List Step** softkey is set to Step.

   When Step is selected, the signal generator will sweep the list points using the dwell time set for step sweep rather than the sweep list dwell values.

   To view the step sweep dwell time, follow these steps:

   a. Press **Configure Step Sweep**.
   
   b. Observe the value set for the **Step Dwell** softkey.

---

**List Sweep Information is Missing from a Recalled Register**

List sweep information is not stored as part of the instrument state in an instrument state register. Only the current list sweep is available to the signal generator. List sweep data can be stored in the instrument catalog. For instructions, see “Storing Files to the Memory Catalog” on page 53.
Data Storage Problems

Registers With Previously Stored Instrument States are Empty

The save/recall registers are backed-up by a battery when line power to the signal generator is not connected. The battery may need to be replaced.

To verify that the battery has failed:

1. Turn off line power to the signal generator.
2. Unplug the signal generator from line power.
3. Plug in the signal generator.
4. Turn on the signal generator.
5. Observe the display for error messages.
   
   If either error message −311 or −700 is stored in the error message queue, the signal generator’s battery has failed.

6. Refer to the Service Guide for battery replacement instructions.

Saved Instrument State, but Register is Empty or Contains Wrong State

If you select a register number greater than 99, the signal generator automatically selects register 99 to save the instrument state.

If the register number you intended to use is empty or contains the wrong instrument state, recall register 99:

Press Recall > 99 > Enter.

The lost instrument state may be saved there.
Cannot Turn Off Help Mode

1. Press **Utility > Instrument Info/ Help Mode**

2. Press **Help Mode Single Cont** until Single is highlighted.

The signal generator has two help modes; single and continuous.

When you press **Help** in single mode (the factory preset condition), help text is provided for the next key you press. Pressing another key will exit the help mode and activate the key’s function.

When you press **Help** in continuous mode, help text is provided for the next key you press and that key’s function is also activated (except for **Preset**). You will stay in help mode until you press **Help** again or change to single mode.
Troubleshooting

Signal Generator Locks Up

If the signal generator is locked up, check the following:

- Make sure that the signal generator is not in remote mode (in remote mode, the \textit{R} annunciator appears on the display). To exit remote mode and unlock the front panel keypad, press \textit{Local}.
- Make sure that the signal generator is not in local lockout condition. Local lockout prevents front panel operation. For more information on local lockout, refer to the \textit{Programming Guide}.
- Check for a progress bar on the signal generator display, which indicates that an operation is in progress.
- Press \textit{Preset}.
- Cycle power on the signal generator.

Fail-Safe Recovery Sequence

Use the fail-safe recovery sequence only if the previous suggestions do not resolve the problem.

\textbf{CAUTION} This process does reset the signal generator, but it also destroys the following types of data:

- all user files (instrument state and data files)
- DCFM/DCΦM calibration data
- persistent states

\textbf{NOTE} Do not attempt to perform any other front panel or remote operations during the fail-safe sequence.

To run the fail-safe sequence, follow these steps:

1. Hold down the \textit{Preset} key while cycling power.
2. Continue to hold down the \textit{Preset} key until the following message is displayed:

\textbf{WARNING} You are entering the diagnostics menu which can cause unpredictable instrument behavior. Are you sure you want to continue?

\textbf{CAUTION} Carefully read the entire message! It may list additional risks with this procedure.
3. Release the Preset key.

4. To continue with the sequence, press Continue (to abort with no lost files, press Abort).

5. When the sequence concludes:
   a. Cycle power.
      Cycling power restores all previously installed options. Because calibration files are restored from EEPROM, you should see several error messages.
   b. Perform the DCFM/DCΦM calibration.
      Refer to the DCFM/DCΦM Cal softkey description in the Key Reference.
   c. Agilent Technologies is interested in the circumstances that made it necessary for you to initiate this procedure. Please contact us at the appropriate telephone number listed in Table 10-1 on page 203. We would like to help you eliminate any repeat occurrences.
Error Messages

If an error condition occurs in the signal generator, it is reported to both the front panel display error queue and the SCPI (remote interface) error queue. These two queues are viewed and managed separately; for information on the SCPI error queue, refer to the Programming Guide.

NOTE When there is an unviewed message in the front panel error queue, the ERR annunciator appears on the signal generator’s display.

<table>
<thead>
<tr>
<th>Characteristic</th>
<th>Front Panel Display Error Queue</th>
</tr>
</thead>
<tbody>
<tr>
<td>Capacity (#errors)</td>
<td>30</td>
</tr>
<tr>
<td>Overflow Handling</td>
<td>Circular (rotating).</td>
</tr>
<tr>
<td></td>
<td>Drops oldest error as new error comes in.</td>
</tr>
<tr>
<td>Viewing Entries</td>
<td>Press: Utility &gt; Error Info &gt; View Next (or Previous) Error Message</td>
</tr>
<tr>
<td>Clearing the Queue</td>
<td>Press: Utility &gt; Error Info &gt; Clear Error Queue(s)</td>
</tr>
<tr>
<td>Unresolved Errors(^a)</td>
<td>Re-reported after queue is cleared.</td>
</tr>
<tr>
<td>No Errors</td>
<td>When the queue is empty (every error in the queue has been read, or the queue is cleared), the following message appears in the queue: 0 No Error Message(s) in Queue</td>
</tr>
</tbody>
</table>

\(^a\) Errors that must be resolved. For example, unlock.

Error Message File

A complete list of error messages is provided in the file errormessages.pdf, on the CDROM supplied with your instrument.

In the error message list, an explanation is generally included with each error to further clarify its meaning. The error messages are listed numerically. In cases where there are multiple listings for the same error number, the messages are in alphabetical order.
**Error Message Format**

When accessing error messages through the front panel display error queue, the error numbers, messages and descriptions are displayed on an enumerated (“1 of N”) basis.

Error messages appear in the lower-left corner of the display as they occur.

<table>
<thead>
<tr>
<th>Error Number</th>
<th>Error Message</th>
<th>Error Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-222</td>
<td>Data out of range; value clipped to lower limit.</td>
<td>Indicates that the user has entered a deviation, depth or internal source frequency that is beyond the specified limits.</td>
</tr>
</tbody>
</table>

Explanation provided in the Error Message List
(This is not displayed on the instrument)
Troubleshooting

Error Messages

Error Message Types

Events do not generate more than one type of error. For example, an event that generates a query error will not generate a device-specific, execution, or command error.

Query Errors (−499 to −400) indicate that the instrument’s output queue control has detected a problem with the message exchange protocol described in IEEE 488.2, Chapter 6. Errors in this class set the query error bit (bit 2) in the event status register (IEEE 488.2, section 11.5.1). These errors correspond to message exchange protocol errors described in IEEE 488.2, 6.5. In this case:

• Either an attempt is being made to read data from the output queue when no output is either present or pending, or
• data in the output queue has been lost.

Device Specific Errors (−399 to −300, 201 to 703, and 800 to 810) indicate that a device operation did not properly complete, possibly due to an abnormal hardware or firmware condition. These codes are also used for self-test response errors. Errors in this class set the device-specific error bit (bit 3) in the event status register (IEEE 488.2, section 11.5.1).

The <error_message> string for a positive error is not defined by SCPI. A positive error indicates that the instrument detected an error within the GPIB system, within the instrument’s firmware or hardware, during the transfer of block data, or during calibration.

Execution Errors (−299 to −200) indicate that an error has been detected by the instrument’s execution control block. Errors in this class set the execution error bit (bit 4) in the event status register (IEEE 488.2, section 11.5.1). In this case:

• Either a <PROGRAM DATA> element following a header was evaluated by the device as outside of its legal input range or is otherwise inconsistent with the device’s capabilities, or
• a valid program message could not be properly executed due to some device condition.

Execution errors are reported after rounding and expression evaluation operations are completed. Rounding a numeric data element, for example, is not reported as an execution error.

Command Errors (−199 to −100) indicate that the instrument’s parser detected an IEEE 488.2 syntax error. Errors in this class set the command error bit (bit 5) in the event status register (IEEE 488.2, section 11.5.1). In this case:

• Either an IEEE 488.2 syntax error has been detected by the parser (a control-to-device message was received that is in violation of the IEEE 488.2 standard. Possible violations include a data element that violates device listening formats or whose type is unacceptable to the device.), or
• an unrecognized header was received. These include incorrect device-specific headers and incorrect or unimplemented IEEE 488.2 common commands.
Returning a Signal Generator to Agilent Technologies

To return your signal generator to Agilent Technologies, follow these steps:

1. Be prepared to give your service representative as much information as possible regarding the signal generator’s problem.

2. Call the phone number listed in Table 10-1 appropriate to the signal generator’s location. After sharing information regarding the signal generator and its condition, you will receive information regarding where to ship your instrument for repair.

3. Ship the signal generator in the original factory packaging materials, if they are available. If not, use similar packaging to properly protect the instrument.

Table 10-1  Contacting Agilent

<table>
<thead>
<tr>
<th>United States</th>
<th>Latin America</th>
<th>Canada</th>
<th>Europe</th>
</tr>
</thead>
<tbody>
<tr>
<td>(tel) 1 800 452 4844</td>
<td>(tel) (305) 269 7500 (fax) (305) 269 7599</td>
<td>(tel) 1 877 894 4414 (fax) (905) 282-6495</td>
<td>(tel) (+31) 20 547 2323 (fax) (+31) 20 547 2390</td>
</tr>
<tr>
<td>New Zealand</td>
<td>Japan</td>
<td>Australia</td>
<td></td>
</tr>
<tr>
<td>(tel) 0 800 738 378 (fax) (+64) 4 495 8950</td>
<td>(tel) (+81) 426 56 7832 (fax) (+81) 426 56 7840</td>
<td>(tel) 1 800 629 485 (fax) (+61) 3 9210 5947</td>
<td></td>
</tr>
</tbody>
</table>

Asia Call Center Numbers

<table>
<thead>
<tr>
<th>Country</th>
<th>Phone Number</th>
<th>Fax Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>Singapore</td>
<td>1-800-375-8100</td>
<td>(65) 836-0252</td>
</tr>
<tr>
<td>Malaysia</td>
<td>1-800-828-848</td>
<td>1-800-801664</td>
</tr>
<tr>
<td>Philippines</td>
<td>(632) 8426802 1-800-16510170 (PLDT Subscriber Only)</td>
<td>(632) 8426809 1-800-16510288 (PLDT Subscriber Only)</td>
</tr>
<tr>
<td>Thailand</td>
<td>(088) 226-008 (outside Bangkok) (662) 661-3999 (within Bangkok)</td>
<td>(66) 1-661-3714</td>
</tr>
<tr>
<td>Hong Kong</td>
<td>800-930-871</td>
<td>(852) 2506 9233</td>
</tr>
<tr>
<td>Taiwan</td>
<td>0800-047-866</td>
<td>(886) 2 25456723</td>
</tr>
<tr>
<td>People’s Republic of China</td>
<td>800-810-0189 (preferred) 10800-650-0021</td>
<td>10800-650-0121</td>
</tr>
<tr>
<td>India</td>
<td>1-600-11-2929</td>
<td>000-800-650-1101</td>
</tr>
</tbody>
</table>
Troubleshooting

Returning a Signal Generator to Agilent Technologies
Symbols
ΦM, 81

Numerics
10 MHz connectors, 24
128QAM I/Q modulation, creating, 137
1410, application note, 170, 180

A
AC power receptacle, 18
ACP, 126, 154
active entry area (display), 13
adjustments, display, 11
Agilent Technologies, 203
ALC
annunciator, 14
bandwidth selection, 59
input connector, 9
limitations, amplitude, 61
off mode, setting, 192
with attenuator option, 63
Alpha adjustment (filter), 126
alternate ramp sweep, 43
AM, 14, 79
amplifier, microwave, 47
amplitude
display area, 16
hardkey, 7
LF output, 84
modulation. See AM
ramp sweep, 44
reference & offset, 30
analog modulation, 77–85
analog PSG features, 3
annunciators, 14
application note 1410, 170, 180
ARB
file catalogs, 52
reference, setting, 144
waveform header files, 88–98
See also Custom Arb waveform generator
See also Dual Arbitrary waveform generator
ARMED annunciator, 14
arrow hardkeys, 11
ATTEN HOLD annunciator, 14
attenuator, external leveling, 63
automatic leveling control. See ALC
AUXILIARY I/O connector, 21
AUXILIARY INTERFACE connector, 18

B
bandwidth
ALC, selecting, 59
reference oscillator, adjusting, 76
baseband generator
custom Arb mode, 119
custom real time I/Q mode, 145
Dual Arb mode, 87
Multitone mode, 169
REF IN connector, 23
settings, 158, 159
Two-Tone mode, 179
BbT, adjusting, 126
binary files, 52
bit files, 52
bits per symbol, equation, 161
BURST GATE IN connector, 20
burst shapes, 153–157

C
carrier feedthrough, minimizing, 175, 184
carrier signal, modulating, 51
CCDF, 177
ceiling function, bits per symbol, 161
certificate, license key, 57
clipping, 112–118
COH connector, 22
comments, adding & editing (instrument state), 54
concepts
differential data encoding, 160
FIR filters, 125
waveform clipping, 113
waveform markers, 108
Configuring the Burst Rise and Fall Parameters, 154
connectors, 6, 17
Index

continuous
  list sweep, 36
  step sweep, 33
  wave RF output, 28
contrast adjustments (display), 11
correction array (user flatness configuration, 66
load from step array, 66
viewing, 67
  See also user flatness correction
couplers/splitters, using, 60
Custom Arb waveform generator, 119–144
Custom Real Time I/Q baseband, 145–167
CW PSG features, 2

D
data, 196
clock, 12, 159
fields, editing, 27
files, 52
input, 12
patterns, 147
  See also instrument state register
  See also memory catalog
default FIR filter, restoring, 127
Delete Item softkey, 27
Delete Row softkey, 27
description, adding & editing (instrument state), 54
detector, diode response, 62
detector, using, 60
differential data encoding, 160–167
DIG BUS annunciator, 14
Digital Bus connector, 22
digital modulation
  annunciators, 16
custom, 119–144, 145–167
dual arb, 87–118
  multitone, 169–178
two-tone, 179–186
diode detector response, 62
display, 11, 13
DMOD files, 52
dual ARB player, 99
Dual Arbitrary waveform generator, 87–118
dwell time, 32

E
Edit Item softkey, 27
ERR annunciator, 14, 200
error messages, 16, 200
EVENT connectors, 20
EVM, 126, 154
EXT
  annunciators, 14
  INPUT connectors, 8, 9
external
data clock, setting, 159
detector, diode response, 62
trigger, setting, 143

F
fail-safe recovery sequence, 198
failures. See troubleshooting
fall delay, burst shape, 154
fall time, burst shape, 154
features, signal generator, 2
feedthrough, carrier, minimizing, 184
files
  catalogs, 52
  using, 53–56
  waveform segment, 103
  waveform sequence, 101, 102
  See also instrument state register
  See also memory catalog
filters, 125–132
FIR, 52, 125
firmware, upgrades, 4
flatness correction. See user flatness correction
FM, 14, 80
ΦM, 14, 81
FM/Φ hardkey, 8
FM/ΦM hardkey, 8
frequency
display area, 13
hardkey, 7
modulation. See FM offset, 29
ramp sweep, 38
reference, 29
RF output, setting, 28
front panel description, 6–16
FSK
  files, 52
  modulation, 136, 141, 142

G
GATE/PULSE/TRIGGER INPUT connector, 10
Gaussian filter, selecting, 126
Goto Row softkey, 27
GPIOB, 18, 69

H
hardkeys, 6–11
hardware, configuring, 143, 158
header files (ARB waveform), 88–98
Help hardkey, 8
help mode troubleshooting, 197
Hold hardkey, 11

I
I OUT connector, 22
I/O connector, auxiliary, 21
I/Q
  4QAM state map, 161
  annunciator, 14
  files, 52
  input connectors, 12
  modulation, 140, 165
  scaling, adjusting, 159
I-bar OUT connector, 23
IMD. See intermodulation distortion
Incr Set hardkey, 10
Insert Item softkey, 27
Insert Row softkey, 27
instrument state register
  comments, adding and editing, 54
  troubleshooting, 196
  using, 54
  See also memory catalog
interface connectors
  AUXILIARY INTERFACE, 18
  GPIOB, 18
  LAN, 18
  RS-232, 18
  interface, remote, 69
intermodulation distortion
  from power peaks, 115
  testing non-linear devices, 170, 180

K
key, license, 57
keypad, numeric, 9
keys, 6–11
knob, front panel, 7

L
L (listener mode) annunciator, 14
LAN connector, 18
LEDs, 10
leveling
  ALC, 9, 192
  external, 60–63
  internal, 59
  mm-wave source module, using, 47
LF output, 9, 83–85
license key, 57
line power LED, 10
list
  error messages, 200
  files, 52
  mode values table editor, 26
  sweep, 34, 195
listener mode annunciator, 14
Load/Store softkey, 27
Local hardkey, 11
low frequency output. See LF output

M
magnitude error simulation, 140
markers
  blanking in sequence, 110
  output, 19
  ramp sweep, 40
  toggling in waveform sequence, 106, 107
  waveform, 104
master/slave setup, 45
MDMOD files, 52
memory catalog, 52, 196
  See also instrument state register
MENUS hardkeys, 8
<table>
<thead>
<tr>
<th>Index</th>
</tr>
</thead>
<tbody>
<tr>
<td>microwave amplifier, 47</td>
</tr>
<tr>
<td>mixer, signal loss while using, 190</td>
</tr>
<tr>
<td>mm-wave source module</td>
</tr>
<tr>
<td>extending frequency range with, 47</td>
</tr>
<tr>
<td>leveling with, 63</td>
</tr>
<tr>
<td>user flatness correction array, creating, 69–75</td>
</tr>
<tr>
<td>mod on/off, 9, 15</td>
</tr>
<tr>
<td>models, signal generator, 2</td>
</tr>
<tr>
<td>modes of operation, 5</td>
</tr>
<tr>
<td>modulation</td>
</tr>
<tr>
<td>amplitude. See AM</td>
</tr>
<tr>
<td>analog, 78</td>
</tr>
<tr>
<td>annunciators, 14–16</td>
</tr>
<tr>
<td>applying, 50</td>
</tr>
<tr>
<td>file catalogs, 52</td>
</tr>
<tr>
<td>frequency. See FM</td>
</tr>
<tr>
<td>on/off hardkey, 9</td>
</tr>
<tr>
<td>phase. See ΦM</td>
</tr>
<tr>
<td>predefined setups, 121, 146</td>
</tr>
<tr>
<td>pulse, 82</td>
</tr>
<tr>
<td>types, 136</td>
</tr>
<tr>
<td>user-defined, 122, 165</td>
</tr>
<tr>
<td>See also digital modulation</td>
</tr>
<tr>
<td>MSK modulation, 136</td>
</tr>
<tr>
<td>MTONE files, 52</td>
</tr>
<tr>
<td>multitone waveform generator, 169–178</td>
</tr>
<tr>
<td>N</td>
</tr>
<tr>
<td>non-linear devices, testing, 170, 180</td>
</tr>
<tr>
<td>numeric keypad, 9</td>
</tr>
<tr>
<td>NVMKR files, 52</td>
</tr>
<tr>
<td>NVWFM files, 52</td>
</tr>
<tr>
<td>Nyquist filters, 125</td>
</tr>
<tr>
<td>O</td>
</tr>
<tr>
<td>offset, 29, 30</td>
</tr>
<tr>
<td>on/off switch, 10</td>
</tr>
<tr>
<td>options, 4, 57</td>
</tr>
<tr>
<td>oscillator, reference, adjusting BW, 76</td>
</tr>
<tr>
<td>output. See LF output and RF output</td>
</tr>
<tr>
<td>OVEN COLD annunciator, 15</td>
</tr>
<tr>
<td>P</td>
</tr>
<tr>
<td>Page Down softkey, 27</td>
</tr>
<tr>
<td>Page Up softkey, 27</td>
</tr>
<tr>
<td>PATTERN TRIG IN connector, 20</td>
</tr>
<tr>
<td>peak to average characteristics, 177</td>
</tr>
<tr>
<td>peak-to-average power, reducing, 116</td>
</tr>
<tr>
<td>performance, optimizing, 59–76</td>
</tr>
<tr>
<td>phase</td>
</tr>
<tr>
<td>error simulation, 140</td>
</tr>
<tr>
<td>modulation. See ΦM</td>
</tr>
<tr>
<td>polarity, 160</td>
</tr>
<tr>
<td>player, dual ARB, 9</td>
</tr>
<tr>
<td>power</td>
</tr>
<tr>
<td>meter, 64, 192</td>
</tr>
<tr>
<td>peaks, 113–115</td>
</tr>
<tr>
<td>receptacle, AC, 18</td>
</tr>
<tr>
<td>search mode, 192</td>
</tr>
<tr>
<td>supply troubleshooting, 189</td>
</tr>
<tr>
<td>switch, 10</td>
</tr>
<tr>
<td>predefined filters, 125</td>
</tr>
<tr>
<td>predefined modulation setups, 121, 146</td>
</tr>
<tr>
<td>Preset hardkey, 11</td>
</tr>
<tr>
<td>problems. See troubleshooting</td>
</tr>
<tr>
<td>PSK modulation, 136</td>
</tr>
<tr>
<td>pulse</td>
</tr>
<tr>
<td>annunciator, 15</td>
</tr>
<tr>
<td>input, 10</td>
</tr>
<tr>
<td>modulation, 82</td>
</tr>
<tr>
<td>Q</td>
</tr>
<tr>
<td>Q OUT connector, 23</td>
</tr>
<tr>
<td>QAM modulation, 136, 161</td>
</tr>
<tr>
<td>Q-bar OUT connector, 23</td>
</tr>
<tr>
<td>QPSK I/Q modulation, creating, 139</td>
</tr>
<tr>
<td>queue, error, 200</td>
</tr>
<tr>
<td>R</td>
</tr>
<tr>
<td>R (remote) annunciator, 15</td>
</tr>
<tr>
<td>ramp sweep, 37–46</td>
</tr>
<tr>
<td>Real Time I/Q, 145–167</td>
</tr>
<tr>
<td>rear panel description, 17</td>
</tr>
<tr>
<td>Recall hardkey, 7</td>
</tr>
<tr>
<td>recovery sequence, fail-safe, 198</td>
</tr>
<tr>
<td>Index</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>rectangular clipping, 112</td>
</tr>
<tr>
<td>reference</td>
</tr>
<tr>
<td>amplitude, setting, 30</td>
</tr>
<tr>
<td>frequency, setting, 29</td>
</tr>
<tr>
<td>oscillator bandwidth, adjusting, 76</td>
</tr>
<tr>
<td>registers, 54, 55</td>
</tr>
<tr>
<td>remote control, 69</td>
</tr>
<tr>
<td>remote operation annunciator, 15</td>
</tr>
<tr>
<td>repair, return instructions, 203</td>
</tr>
<tr>
<td>Return hardkey, 11</td>
</tr>
<tr>
<td>RF output</td>
</tr>
<tr>
<td>annunciator, 15</td>
</tr>
<tr>
<td>configuring, 28–49</td>
</tr>
<tr>
<td>connector, 10</td>
</tr>
<tr>
<td>leveling, external, 60–63</td>
</tr>
<tr>
<td>mm-wave source module, using, 47</td>
</tr>
<tr>
<td>On/Off hardkey, 9</td>
</tr>
<tr>
<td>sweeping, 31</td>
</tr>
<tr>
<td>troubleshooting, 189</td>
</tr>
<tr>
<td>user flatness correction, 64–75</td>
</tr>
<tr>
<td>rise delay, burst shape, 154</td>
</tr>
<tr>
<td>rise time, burst shape, 154</td>
</tr>
<tr>
<td>root Nyquist filters, 126</td>
</tr>
<tr>
<td>RS-232 connector, 18</td>
</tr>
<tr>
<td>S</td>
</tr>
<tr>
<td>S (service request) annunciator, 15</td>
</tr>
<tr>
<td>Save hardkey, 7</td>
</tr>
<tr>
<td>Seq files, 52</td>
</tr>
<tr>
<td>sequences</td>
</tr>
<tr>
<td>deleting, 55</td>
</tr>
<tr>
<td>instrument state register, 54</td>
</tr>
<tr>
<td>renaming, 102</td>
</tr>
<tr>
<td>toggling markers in, 106, 107</td>
</tr>
<tr>
<td>service request annunciator, 15</td>
</tr>
<tr>
<td>service. See troubleshooting</td>
</tr>
<tr>
<td>shape files, 52</td>
</tr>
<tr>
<td>signal loss, troubleshooting, 189</td>
</tr>
<tr>
<td>Signal Studio software, 170, 180</td>
</tr>
<tr>
<td>single step sweep, 32</td>
</tr>
<tr>
<td>SMI connector, 24</td>
</tr>
<tr>
<td>softkeys, 7, 16, 27</td>
</tr>
<tr>
<td>SOURCE SETTLED OUTPUT connector, 19</td>
</tr>
<tr>
<td>spectral regrowth, 115</td>
</tr>
<tr>
<td>spectrum analyzer, troubleshooting signal loss, 192</td>
</tr>
<tr>
<td>standby LED, 10</td>
</tr>
<tr>
<td>state files, 52</td>
</tr>
<tr>
<td>step array (user flatness), 64</td>
</tr>
<tr>
<td>See also user flatness correction</td>
</tr>
<tr>
<td>step attenuator, external leveling, 63</td>
</tr>
<tr>
<td>step sweep, 32–33</td>
</tr>
<tr>
<td>STOP SWEEP connector, 19</td>
</tr>
<tr>
<td>storage, troubleshooting, 196</td>
</tr>
<tr>
<td>sweep</td>
</tr>
<tr>
<td>annunciator, 15</td>
</tr>
<tr>
<td>list, 34</td>
</tr>
<tr>
<td>output, 19</td>
</tr>
<tr>
<td>ramp, 37–46</td>
</tr>
<tr>
<td>RF output, 31</td>
</tr>
<tr>
<td>step, 32</td>
</tr>
<tr>
<td>trigger, 36</td>
</tr>
<tr>
<td>troubleshooting, 194</td>
</tr>
<tr>
<td>Sweep/List hardkey, 8</td>
</tr>
<tr>
<td>switch, power, 10</td>
</tr>
<tr>
<td>symbol rates, 133</td>
</tr>
<tr>
<td>SYMBOL SYNC INPUT connector, 12</td>
</tr>
<tr>
<td>SYNC OUT connector, 10</td>
</tr>
<tr>
<td>T</td>
</tr>
<tr>
<td>T (talker mode) annunciator, 15</td>
</tr>
<tr>
<td>table editor, using, 26–27</td>
</tr>
<tr>
<td>talker mode annunciator, 15</td>
</tr>
<tr>
<td>text display area, 16</td>
</tr>
<tr>
<td>trigger</td>
</tr>
<tr>
<td>hardkey, 8</td>
</tr>
<tr>
<td>inputs</td>
</tr>
<tr>
<td>GATE/PULSE/TRIGGER, 10</td>
</tr>
<tr>
<td>PATTERN TRIG IN, 20</td>
</tr>
<tr>
<td>TRIGGER IN, 19</td>
</tr>
<tr>
<td>output, 19</td>
</tr>
<tr>
<td>setting, 36, 143</td>
</tr>
<tr>
<td>waveform, 111</td>
</tr>
<tr>
<td>troubleshooting, 187–203</td>
</tr>
<tr>
<td>two-tone, 179–186</td>
</tr>
<tr>
<td>U</td>
</tr>
<tr>
<td>UNLEVEL annunciator, 15</td>
</tr>
<tr>
<td>UNLOCK annunciator, 16</td>
</tr>
<tr>
<td>user flatness, 52, 64–75</td>
</tr>
</tbody>
</table>
Index

user-defined
  burst shape curves, 155
  data patterns, 149
  files, 52
  filters, 127, 129
  modulation type
    custom arb, 122
    real time I/Q, 137, 165

V
  vector PSG features, 4
  VIDEO OUT connector, 10

W
  waveforms
    analog modulation, 78
    ARB header files, 88–98
    clipping, 112–118
    custom, 119–144
    Custom Real Time I/Q baseband, 145–167
    dual arb, 87–118
    file catalogs, 52
    file, renaming, 103
    markers, 104
    multitone, 169–178
    player, dual ARB, 99
    segments, 100–103
    sequence
      blanking markers, 110
      building and storing, 101–103
      renaming, 102
      toggling markers, 106, 107
    triggers, 111
    two-tone, 179–186
    WFM1 files, 52
    WIDEBAND I INPUT connector, 22
    WIDEBAND Q INPUT connector, 22

Z
  Z-AXIS BLANK/MKRS connector, 19