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Ansoft HFSS Fundamentals

What is HFSS?
HFSS is a high-performance full-wave electromagnetic(EM) field simulator for 

arbitrary 3D volumetric passive device modeling that takes advantage of the 

familiar Microsoft Windows graphical user interface.  It integrates simulation, 

visualization, solid modeling, and automation in an easy-to-learn environment 

where solutions to your 3D EM problems are quickly and accurately obtained.  
Ansoft HFSS employs the Finite Element Method(FEM), adaptive meshing, and 

brilliant graphics to give you unparalleled performance and insight to all of your 

3D EM problems.  Ansoft HFSS can be used to calculate parameters such as S-

Parameters, Resonant Frequency, and Fields. Typical uses include:

Package Modeling – BGA, QFP, Flip-Chip

PCB Board Modeling – Power/Ground planes, Mesh Grid Grounds, 

Backplanes

Silicon/GaAs - Spiral Inductors, Transformers

EMC/EMI – Shield Enclosures, Coupling, Near- or Far-Field Radiation

Antennas/Mobile Communications – Patches, Dipoles, Horns, Conformal 

Cell Phone Antennas, Quadrafilar Helix, Specific Absorption Rate(SAR), 

Infinite Arrays, Radar Cross Section(RCS), Frequency Selective 

Surfaces(FSS)

Connectors – Coax, SFP/XFP, Backplane, Transitions

Waveguide – Filters, Resonators, Transitions, Couplers

Filters – Cavity Filters, Microstrip, Dielectric

HFSS is an interactive simulation system whose basic mesh element is a 
tetrahedron.  This allows you to solve any arbitrary 3D geometry, especially those 

with complex curves and shapes, in a fraction of the time it would take using 

other techniques.  

The name HFSS stands for High Frequency Structure Simulator.  Ansoft 

pioneered the use of the Finite Element Method(FEM) for EM simulation by 
developing/implementing technologies such as tangential vector finite elements, 

adaptive meshing, and  Adaptive Lanczos-Pade Sweep(ALPS).  Today, HFSS 

continues to lead the industry with innovations such as Modes-to-Nodes and Full-

Wave Spice™.

Ansoft HFSS has evolved over a period of years with input from many users and 

industries.  In industry, Ansoft HFSS is the tool of choice for high-productivity 

research, development, and virtual prototyping.
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Installing the Ansoft HFSS Software

System Requirements
Microsoft Windows XP(32/64), Windows 2000, or Windows 2003 Server. For up-

to-date information, refer to the HFSS Release Notes.

Pentium –based computer

128MB RAM minimum

8MB Video Card minimum

Mouse or other pointing device

CD-ROM drive

Installing the Ansoft HFSS Software
For up-to-date information, refer to the HFSS Installation Guide

Starting Ansoft HFSS
1. Click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select the Ansoft, HFSS 10 Ansoft, HFSS 10 Ansoft, HFSS 10 Ansoft, HFSS 10 

program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

2.2.2.2. Or Or Or Or Double click on the HFSS 10 icon  on the Windows Desktop

NOTENOTENOTENOTE:  You should make backup copies of all HFSS projects created with a 

previous version of the software before opening them in HFSS v10
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Converting Older Files

Converting Older HFSS file to HFSS v10
Because of changes to the HFSS files with the development of HFSS v10, 

opening a HFSS document from an earlier release may take more time than you 

are used to experiencing.  However, once the file has been opened and saved, 

subsequent opening time will return to normal

Ansoft HFSS v10 provides a way for you to automatically convert your HFSS 
projects from an earlier version to the HFSS v10 format.  

To access HFSS projects in an earlier version.

From HFSS v10From HFSS v10From HFSS v10From HFSS v10, 

1. Select the menu item File > OpenFile > OpenFile > OpenFile > Open

2. Open dialog

1. Files of Type:  Ansoft Legacy EM Projects (.Ansoft Legacy EM Projects (.Ansoft Legacy EM Projects (.Ansoft Legacy EM Projects (.clsclsclscls))))

2. Browse to the existing project and select the .cls file

3. Click the OpenOpenOpenOpen button
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Getting Help

Getting Help
If you have any questions while you are using Ansoft HFSS you can find answers 

in several ways:

Ansoft HFSS Online HelpAnsoft HFSS Online HelpAnsoft HFSS Online HelpAnsoft HFSS Online Help provides assistance while you are working.

To get help about a specific, active dialog box, click the HelpHelpHelpHelp button 
in the dialog box or press the F1F1F1F1 key.

Select the menu item Help > ContentsHelp > ContentsHelp > ContentsHelp > Contents to access the online help 

system.

TooltipTooltipTooltipTooltips are available to provide information about tools on the 

toolbars or dialog boxes.  When you hold the pointer over a tool for a 
brief time, a tooltip appears to display the name of the tool.

As you move the pointer over a tool or click a menu item, the Status Status Status Status 

BarBarBarBar at the bottom of the Ansoft HFSS window provides a brief 

description of the function of the tool or menu item.

The Ansoft HFSS Getting Started guide provides detailed 

information about using HFSS to create and solve 3D EM projects.

Ansoft Technical SupportAnsoft Technical SupportAnsoft Technical SupportAnsoft Technical Support

To contact Ansoft technical support staff in your geographical area, 

please log on to the Ansoft corporate website, www.ansoft.com and 
select ContactContactContactContact. 

Your Ansoft sales engineer may also be contacted in order to 

obtain this information.

Visiting the Ansoft Web Site
If your computer is connected to the Internet, you can visit the Ansoft Web site to 

learn more about the Ansoft company and products. 

From the Ansoft Desktop

Select the menu item Help > Ansoft Corporate WebsiteHelp > Ansoft Corporate WebsiteHelp > Ansoft Corporate WebsiteHelp > Ansoft Corporate Website to access 

the Online Technical Support (OTS) system.

From your Internet browser

Visit www.ansoft.com
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Getting Help

For Technical Support
The following link will direct you to the Ansoft Support Page.  The Ansoft Support 

Pages provide additional documentation, training, and application notes. 

Web Site: http://www.ansoft.com/support.cfm

Technical Support: 

9-4 EST: 

Pittsburgh, PAPittsburgh, PAPittsburgh, PAPittsburgh, PA

(412) 261-3200 x0 – Ask for Technical Support

Burlington, MABurlington, MABurlington, MABurlington, MA

(781) 229-8900 x0 – Ask for Technical Support 

9-4 PST: 

San Jose, CA San Jose, CA San Jose, CA San Jose, CA 

(408) 261-9095 x0 – Ask for Technical Support

Portland, ORPortland, ORPortland, ORPortland, OR

(503) 906-7944 or (503) 906-7947 

El Segundo, CAEl Segundo, CAEl Segundo, CAEl Segundo, CA

(310) 426-2287 – Ask for Technical Support
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WebUpdate

WebUpdate
This new feature allows you to update any existing Ansoft software from the 

WebUpdate window. This feature automatically scans your system to find any 

Ansoft software, and then allows you to download any updates if they are 

available. 
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Ansoft Terms

Ansoft Terms
The Ansoft HFSS window has several optional panels:

A Project ManagerProject ManagerProject ManagerProject Manager which contains a design tree which lists the structure of 

the project.  

A Message ManagerMessage ManagerMessage ManagerMessage Manager that allows you to view any errors or warnings that 
occur before you begin a simulation.

A Property WindowProperty WindowProperty WindowProperty Window that displays and allows you to change model 

parameters or attributes. 

A Progress WindowProgress WindowProgress WindowProgress Window that displays solution progress.

A 3D Modeler Window3D Modeler Window3D Modeler Window3D Modeler Window which contains the model and model tree for the 
active design.  For more information about the3D Modeler Window, see 

chapter 1.

Menu 

bar

Progress 

Window

Property Window

Message 

Manager

Project

Manager

with project

tree

Status 

bar

3D Modeler

Window

Toolbars

Coordinate Entry Fields
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Ansoft Terms

Project Manager 

Project

Design

Design Results

Design Setup

Design Automation
•Parametric
•Optimization

•Sensitivity

•Statistical

Project Manager Window
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Ansoft Terms

Property Window 

Property Window

Property tabs

Property 

buttons
Property 

table
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Ansoft Terms

Ansoft 3D Modeler 

Edge
Vertex

Plane

Coordinate System (CS)

Origin

Face

Model

3D Modeler Window

Graphics

area

Model

3D Modeler 

design tree

Context menu
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Ansoft Terms

3D Modeler Design Tree

Grouped by MaterialGrouped by MaterialGrouped by MaterialGrouped by Material

Object ViewObject ViewObject ViewObject View

Material

Object

Object Command History
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Design Windows

Design Windows
In the Ansoft HFSS Desktop, each project can have multiple designs and each 

design is displayed in a separate window.

You can have multiple projects and design windows open at the same time.  

Also, you can have multiple views of the same design visible at the same time.

To arrange the windows, you can drag them by the title bar, and resize them by 

dragging a corner or border.  Also, you can select one of the following menu 

options: Window >CascadeWindow >CascadeWindow >CascadeWindow >Cascade, Window >Tile VerticallyWindow >Tile VerticallyWindow >Tile VerticallyWindow >Tile Vertically, or Window > Tile Window > Tile Window > Tile Window > Tile 
Horizontally.Horizontally.Horizontally.Horizontally.

To organize your Ansoft HFSS window, you can iconize open designs.  Click the 
Iconize ** symbol in the upper right corner of the document border.  An icon 

appears in the lower part of the Ansoft HFSS window.  If the icon is not visible, it 

may be behind another open document.  Resize any open documents as 

necessary.  Select the menu item Window > Arrange IconsWindow > Arrange IconsWindow > Arrange IconsWindow > Arrange Icons to arrange them at 

the bottom of the Ansoft HFSS window. 

Select the menu item Window > Close AllWindow > Close AllWindow > Close AllWindow > Close All to close all open design.  You are 

prompted to SaveSaveSaveSave unsaved designs.

Design icons

Iconize

Symbol
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Toolbars

Toolbars
The toolbar buttons are shortcuts for frequently used commands. Most of the 

available toolbars are displayed in this illustration of the Ansoft HFSS initial 

screen, but your Ansoft HFSS window probably will not be arranged this way.  

You can customize your toolbar display in a way that is convenient for you.

Some toolbars are always displayed; other toolbars display automatically when 
you select a document of the related type.  For example, when you select a 2D 

report from the project tree, the 2D report toolbar displays.

To display or hide individual toolbars:
Right-click the Ansoft HFSS window frame.

A list of all the toolbars is displayed.  The toolbars with a check mark 

beside them are visible; the toolbars without a check mark are hidden.  
Click the toolbar name to turn its display on or off

To make changes to the toolbars, select the menu item Tools > CustomizeTools > CustomizeTools > CustomizeTools > Customize.  See 

Customize and Arrange ToolbarsCustomize and Arrange ToolbarsCustomize and Arrange ToolbarsCustomize and Arrange Toolbars on the 

next page.

Toolbars

Ansoft HFSS

panels
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Toolbars

Customize and Arrange Toolbars
To customize toolbars:

Select the menu item Tools > Customize,Tools > Customize,Tools > Customize,Tools > Customize, or right-click the Ansoft HFSS 

window frame and click CustomizeCustomizeCustomizeCustomize at the bottom of the toolbar list.

In the Customize dialog, you can do the following:

View a Description of the toolbar commandsView a Description of the toolbar commandsView a Description of the toolbar commandsView a Description of the toolbar commands

1. Select an item from the Component pull-down list

2. Select an item from the Category list

3. Using the mouse click on the Buttons to display the 
Description

4. Click the CloseCloseCloseClose button when you are finished

Toggle the visibility of toolbarsToggle the visibility of toolbarsToggle the visibility of toolbarsToggle the visibility of toolbars

1. From the Toolbar list, toggle the check boxes to control the 

visibility of the toolbars

2. Click the CloseCloseCloseClose button when you are finished
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Overview

Ansoft HFSS Desktop
The Ansoft HFSS Desktop provides an intuitive, easy-to-use interface for 

developing passive RF device models.  Creating designs, involves the following:

1.1.1.1. Parametric Model GenerationParametric Model GenerationParametric Model GenerationParametric Model Generation – creating the geometry, boundaries and 

excitations

2.2.2.2. Analysis Setup Analysis Setup Analysis Setup Analysis Setup – defining solution setup and frequency sweeps

3.3.3.3. ResultsResultsResultsResults – creating 2D reports and field plots

4.4.4.4. Solve LoopSolve LoopSolve LoopSolve Loop - the solution process is fully automated

To understand how these processes co-exist, examine the illustration shown 

below.

DesignDesignDesignDesign

Solution TypeSolution TypeSolution TypeSolution Type

1.1. Boundaries1.1. Boundaries1.1. Boundaries1.1. Boundaries

1.2. Excitations1.2. Excitations1.2. Excitations1.2. Excitations

4.1 Mesh 4.1 Mesh 4.1 Mesh 4.1 Mesh 

OperationsOperationsOperationsOperations
2. Analysis2. Analysis2. Analysis2. Analysis

Solution Setup

Frequency Sweep

1. Parametric Model1. Parametric Model1. Parametric Model1. Parametric Model
Geometry/Materials

3. Results3. Results3. Results3. Results
2D Reports

Fields

MeshMeshMeshMesh

RefinementRefinementRefinementRefinement
SolveSolveSolveSolve

UpdateUpdateUpdateUpdate

ConvergedConvergedConvergedConverged

AnalyzeAnalyzeAnalyzeAnalyze

FinishedFinishedFinishedFinished

4. Solve Loop4. Solve Loop4. Solve Loop4. Solve Loop

NONONONO

YESYESYESYES
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Opening a Design

Opening a HFSS project
This section describes how to open a new or existing project.

Opening a New projectOpening a New projectOpening a New projectOpening a New project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, select the menu item File > NewFile > NewFile > NewFile > New.

2. Select the menu Project >Project >Project >Project > Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Opening an Existing HFSS projectOpening an Existing HFSS projectOpening an Existing HFSS projectOpening an Existing HFSS project

To open an existing project:To open an existing project:To open an existing project:To open an existing project:

1. In an Ansoft HFSS window, 

select the menu File > OpenFile > OpenFile > OpenFile > Open.  

Use the Open dialog to select 

the project.

2. Click OpenOpenOpenOpen to open the project

Opening an Existing Project from ExplorerOpening an Existing Project from ExplorerOpening an Existing Project from ExplorerOpening an Existing Project from Explorer

You can open a project directly from the Microsoft Windows Explorer.

To open a project from Windows Explorer, do one of the followingTo open a project from Windows Explorer, do one of the followingTo open a project from Windows Explorer, do one of the followingTo open a project from Windows Explorer, do one of the following::::

Double-click on the name of the project in Windows Explorer.

Right-click the name of the project in Windows Explorer and select 

OpenOpenOpenOpen from the shortcut menu.
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Set Solution Type

Set Solution Type
This section describes how to set the Solution Type.  The Solution Type defines 

the type of results, how the excitations are defined, and the convergence.  The 

following Solution Types are available:

1.1.1.1. Driven ModalDriven ModalDriven ModalDriven Modal - calculates the modal-based S-parameters. The S-matrix 

solutions will be expressed in terms of the incident and reflected powers of 
waveguide modes.

2.2.2.2. Driven TerminalDriven TerminalDriven TerminalDriven Terminal - calculates the terminal-based S-parameters of multi-

conductor transmission line ports. The S-matrix solutions will be expressed 

in terms of terminal voltages and currents.

3.3.3.3. EignemodeEignemodeEignemodeEignemode – calculate the eigenmodes, or resonances, of a structure. The 

Eigenmode solver finds the resonant frequencies of the structure and the 

fields at those resonant frequencies. 

Convergence

Driven ModalDriven ModalDriven ModalDriven Modal – Delta S for modal S-Parameters.   This was the only 

convergence method available for Driven Solutions in previous versions.

Driven Terminal Driven Terminal Driven Terminal Driven Terminal – Delta S for the single-ended or differential nodal S-

Parameters.  

EigenmodeEigenmodeEigenmodeEigenmode - Delta F

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose one of the following:

1.1.1.1. Driven ModalDriven ModalDriven ModalDriven Modal

2.2.2.2. Driven TerminalDriven TerminalDriven TerminalDriven Terminal

3.3.3.3. EigenmodeEigenmodeEigenmodeEigenmode

2. Click the OKOKOKOK button
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Parametric Model Creation
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Parametric Model Creation
The Ansoft HFSS 3D Modeler is designed for ease of use and flexibility.  The 
power of the 3D Modeler is in its unique ability to create fully parametric designs 
without editing complex macros/model history.

The purpose of this chapter is to provide an overview of the 3D Modeling 
capabilities.  By understanding the basic concepts outlined here you will be able 
to quickly take advantage of the full feature set offered by the 3D Parametric 
Modeler.

Overview of the 3D Modeler User Interface
The following picture shows the 3D Modeler window.

3D Modeler Design Tree3D Modeler Design Tree3D Modeler Design Tree3D Modeler Design Tree – The 3D Modeler Design Tree is an essential part 
of the user interface.  From here you may access the structural elements in 
addition to any object dependencies and attributes.

Context MenusContext MenusContext MenusContext Menus – Context menus are a flexible way of accessing frequently 
used menu commands for the current context.  The contents of these 
menus change dynamically and are available throughout the interface by 
clicking the right mouse button. 

Graphics AreaGraphics AreaGraphics AreaGraphics Area – The graphics area is used to interact with the structural 
elements.

Graphics
area

Model

3D Modeler 
design tree

Context menu
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Overview of the 3D Modeler User Interface (Continued)
When using the 3D Modeler interface you will also interact with two additional 
interfaces:

Property WindowProperty WindowProperty WindowProperty Window – The Property Window is used to view or modify the 
attributes and dimensions of structural objects

Status Bar/Coordinate EntryStatus Bar/Coordinate EntryStatus Bar/Coordinate EntryStatus Bar/Coordinate Entry – The Status Bar on the Ansoft HFSS Desktop 
Window displays the Coordinate Entry fields that can be used to define 
points or offsets during the creation of structural objects

Property tabs

Property 
buttons

Property 
table
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Grid Plane
To simplify the creation of structural primitives, a grid or drawing plane is used.  
The drawing plane does not in any way limit the user to two dimensional 
coordinates but instead is used as a guide to simplify the creation of structural 
primitives.  The drawing plane is represented by the active grid plane (The grid 
does not have to be visible).   To demonstrate how drawing planes are used, 
review the following section: Creating and Viewing Simple StructuresCreating and Viewing Simple StructuresCreating and Viewing Simple StructuresCreating and Viewing Simple Structures.

Active Cursor
The active cursor refers to the cursor that is available during object creation.  The 
cursor allows you to graphically change the current position.  The position is 
displayed on the status bar of the Ansoft HFSS Desktop Window.  

When objects are not being constructed, the cursor remains passive and is set 
for dynamic selection.  See the Overview of Selecting Objects for more details.
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Creating and Viewing a Simple Structure
Creating 3D structural objects is accomplished by performing the following steps:

1. Set the grid plane

2. Create the base shape of the object

3. Set the Height

Create a BoxCreate a BoxCreate a BoxCreate a Box

We will investigate creating a box to demonstrate these steps.  These steps 
assume that project and a HFSS design have already been created. Three 
points are required to create the box.  The first two form the base rectangle 
and the third sets the height.

Point 1: Defines the start point of the base rectangle

Point 2: Defines the size of the base rectangle

Point 3: Defines the height of the Box

Point 2

Point 3

Point 1

Grid Plane

Base Rectangle
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Create a Box (Continued)Create a Box (Continued)Create a Box (Continued)Create a Box (Continued)

1. Select the menu item 3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY

2. Use the mouse to create the base shape

1. Set the start point by positioning the active cursor and click the left 
mouse button.

2. Position the active cursor and click the left mouse button to set the 
second point that forms the base rectangle

3. Set the Height by positioning the active cursor and clicking left mouse 
button.
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Specifying Points
GridGridGridGrid

From the example, we saw that the simplest way to set a point is by 
clicking its position on the grid plane.  To set the precision of the grid plane, 
select the menu item View > Grid Settings.View > Grid Settings.View > Grid Settings.View > Grid Settings. From here you may specify the 
Grid Type, Style, Visibility, and Precision.  By pressing the Save As DefaultSave As DefaultSave As DefaultSave As Default
button, you can set the default behavior for future HFSS Designs. 

Coordinate EntryCoordinate EntryCoordinate EntryCoordinate Entry

Another way to specify a coordinate is to use the Coordinate Entry fields 
which are located on the status bar of the Ansoft HFSS Desktop. The 
position may be specified in Cartesian, CylindricalCartesian, CylindricalCartesian, CylindricalCartesian, Cylindrical, or SphericalSphericalSphericalSpherical
coordinates.  Once the first point is set, the Coordinate Entry will default to 
Relative coordinates.  In Relative mode the coordinates are no longer 
absolute (measured from the origin of the working coordinate system), but 
relative to the last point entered.  

Equations Equations Equations Equations 

The Coordinate Entry fields allow equations to be entered for 
position values.  Examples: 2*5, 2+6+8, 2*cos(10*(pi/180)).

Variables are not allowed in the Coordinate Entry Field

NoteNoteNoteNote: Trig functions are in radians

Relative mode
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Specifying Points (Continued)
Object PropertiesObject PropertiesObject PropertiesObject Properties

By default the Properties dialog will appear after you have finished 
sketching an object.  The position and size of objects can be modified from 
the dialog.  This method allows you to create objects by clicking the 
estimated values using the mouse and then correcting the values in the 
final dialog.  

The Property dialog accepts equations, variables, and units.  See the 
Overview of Entering ParametersOverview of Entering ParametersOverview of Entering ParametersOverview of Entering Parameters for more detail.

Every object has two types of properties

1.1.1.1. CommandCommandCommandCommand – Defines the structural primitive

2.2.2.2. AttributesAttributesAttributesAttributes – Defines the material, display, and solve properties

Attributes

Commands
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Overview of Draw
PrimitivesPrimitivesPrimitivesPrimitives

In solid modeling, the basic element or object is often called a primitive.  
Examples of primitives are boxes, cylinders, rectangles, circles, etc.  There 
are two types of primitives: 3D primitives or solids, and 2D primitives or 
surfaces.  By placing a collection of primitives in the correct location and of 
the correct size we can create a represent complex structural objects.  

To create complex objects, primitives can be used as “tools” to cut holes, 
carve away, or join.  The operations that are performed with these “tools” 
are often referred to as Boolean operations.

2D primitives can be swept to create arbitrarily shaped solid primitives

2D Draw Objects2D Draw Objects2D Draw Objects2D Draw Objects

The following 2D Draw objects are available:

Rectangle, Circle, Line, Point, Spline, Ellipse, Regular Polygon (v8.5 
circle)

3D Draw Objects3D Draw Objects3D Draw Objects3D Draw Objects

The following 3D Draw objects are available:

Box, Cylinder, Sphere, Torus, Helix, Bond Wire, Cone, Regular 
Polyhedron (v8.5 cylinder)

True SurfacesTrue SurfacesTrue SurfacesTrue Surfaces

Circles, Cylinders, Spheres, etc are represented as true surfaces.  In 
versions prior to release 9, these primitives would be represented as 
faceted objects.  If you wish to use the faceted primitives (Cylinders or 
Circles), select the Regular Polyhedron or Regular Polygon.

To control the mesh generation of true surfaces objects, see the section on 
Mesh Control.
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Overview of Draw (Continued)

Snap ModeSnap ModeSnap ModeSnap Mode

As an aid for graphical selection, the 
modeler provides Snap options.  The 
default is to snaps are shown here.  The 
shape of the active cursor will dynamically 
change as the cursor is moved over the 
snap positions.

MovingMovingMovingMoving

By default all active cursor movement is in three dimensions.  The modeler 
can also be set to allow the active cursor to only move in a plane or out of 
plane.  These are set from the menu item 3D Modeler > Movement Mode.3D Modeler > Movement Mode.3D Modeler > Movement Mode.3D Modeler > Movement Mode.

In addition, the movement can be limited to a specific direction (x, y, or z) 
by holding down the x, y, or z key.  This prevents movement in the other 
directions.

Pressing the CTRL+EnterCTRL+EnterCTRL+EnterCTRL+Enter key sets a local reference point.  This can be 
useful for creating geometry graphically that is based on an existing 
objects.  This is outlined on the next page:



Ansoft High Frequency Structure Simulator v10 User’s Guide 

1
Parametric Model Creation

1-10

Moving (Continued)Moving (Continued)Moving (Continued)Moving (Continued)

Step 1: Start Point Step 2: Hold X key and select vertex point

Step 3: CTRL+Enter Keys set a local reference Step 4: Hold Z key and set height
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Overview of Draw
ImportImportImportImport

In 3D modeler you can import a drawing file from outside.

Choose option 3D Modeler 3D Modeler 3D Modeler 3D Modeler ----> Import> Import> Import> Import . Here is the list of import files that we 
support. For some of these import option you will need an add-on translator 
feature in your license file.

HealingHealingHealingHealing

Automated healing for imported solid models

Post-translation user controlled healing

3D Model Analysis – 3D Modeler/Analyze

Face, Object , Area analysis based on user inputs

List of problems (faces, edges, vertices)

Auto Zoom In into region where problem exists

Remove Face

Remove Edge

Remove Sliver

Remove Vertices
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Selecting Previously Defined Shapes 
You may select an object by moving the mouse over the object in the graphics 
area and clicking on it.  The default mode is Dynamic selection which will display 
the object to be selected with a unique outline color.  Please note that after 
selecting (Clicking on the object) the object it will be displayed solid pink while all 
other objects are drawn transparent.  

Types of SelectionTypes of SelectionTypes of SelectionTypes of Selection

The default is to select objects.  Sometimes is necessary to select faces, 
edges, or vertices.  To change the selection mode, select the menu item 
Edit > SelectEdit > SelectEdit > SelectEdit > Select and choose the appropriate selection mode.  The shortcut 
keys oooo (Object selection) and f f f f (face selection) are useful for quickly 
switching between the most common selection modes

Multiple Select or Toggle SelectionMultiple Select or Toggle SelectionMultiple Select or Toggle SelectionMultiple Select or Toggle Selection

Multiple objects can be selected graphically by holding down the CTRL key 
while selecting.  In addition, with the CTRL key pressed, the selection of an 
object can be toggled between selected or unselected.

Blocked ObjectsBlocked ObjectsBlocked ObjectsBlocked Objects

If the object you wish to select is located behind another object, select the 
object that is blocking the desired object and press the bbbb key or right-click 
and select Next BehindNext BehindNext BehindNext Behind from the context menu.  You may repeat this as 
many times as needed to select the correct object.

Select All VisibleSelect All VisibleSelect All VisibleSelect All Visible

You can select all visible objects by pressing the CTRL+aCTRL+aCTRL+aCTRL+a key or by 
selecting the menu item Edit > Select All Visible.Edit > Select All Visible.Edit > Select All Visible.Edit > Select All Visible.

Select by NameSelect by NameSelect by NameSelect by Name

To select objects by Name you can use anyone of the following:

Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

Select the menu item HFSS > ListHFSS > ListHFSS > ListHFSS > List

Select the ModelModelModelModel tab

Select objects from the list

Use the Model TreeModel TreeModel TreeModel Tree.  See the next page  
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Selecting Previously Defined Shapes (Continued)
Model TreeModel TreeModel TreeModel Tree

After an object has been created, it is automatically added to the Model 
Tree.  All objects can be found in the Model Tree.  If you open the Model 
folder you will find the objects sorted by Object or by Material.  You can 
toggle between the views by toggling the menu item 3D Modeler > Group 3D Modeler > Group 3D Modeler > Group 3D Modeler > Group 
Object by MaterialObject by MaterialObject by MaterialObject by Material.  

As stated previously, every object has two types of properties: 

AttributesAttributesAttributesAttributes

You may select an object by clicking on the corresponding 
item in the Model Tree.  

When the object is selected the attributes will be displayed in 
the Property Window.  Double-clicking on the object will open 
a properties dialog.  Use the Property Window or properties 
dialog to modify the attributes.

Commands Commands Commands Commands 

From the Model Tree, the Command Properties can be 
selected by expanding the object folder to display the 
command list.  Using the mouse, select the corresponding 
command from the tree.  The properties will be displayed in 
the Property Window.  Double-clicking on the command will 
open a properties dialog.  Use the Property Window or 
properties dialog to modify the command.

When the command is selected, the object will be outlined 
with bold lines in the 3D Model Window.  Since an object can 
be a combination of several primitives, the command list may 
contain several objects.  Anyone of these commands can be 
selected to visualize or modify the object.

Attributes

Commands

Sorted by Object Sorted by Material
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Selecting Previously Defined Shapes (Continued)
Model TreeModel TreeModel TreeModel Tree

Geometry in the 3D modeler is also grouped according to their model 
definition. Objects, Sheets, Lines, and Points are all separated so that they 
can be easily identified in the model tree

If a boundary condition or an excitation is defined on a sheet object, then 
those 2D objects will be further separated according to their assignment.
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Object Attributes
An objects attributes set the following user defined properties:

NameNameNameName – User defined name.  Default names start with the primitive type
followed by an increasing number: Box1, Box2, etc.

MaterialMaterialMaterialMaterial – User defined material property.  The default property is vacuum.  
This can be changed by using the material toolbar

Solve InsideSolve InsideSolve InsideSolve Inside – By default HFSS only solves for fields inside 
dielectrics.  To force HFSS to solve inside conductors, check
solve inside.

Orientation

Model Object Model Object Model Object Model Object – Controls if the object is included in the solve

Display Display Display Display WireframeWireframeWireframeWireframe – Forces the object to always be displayed as wireframe

Color Color Color Color –––– Set object color

Transparency Transparency Transparency Transparency –––– Set the transparency of an object.  0–Solid, 1- Wireframe

Note:Note:Note:Note: Visibility is not an object property.
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Materials
By clicking on the property button for the material name, the material definition 
window will appear.  You can select from the existing database or define a 
custom project material.
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Materials (Continued)
User Defined Project MaterialUser Defined Project MaterialUser Defined Project MaterialUser Defined Project Material

To define a custom material click the Add MaterialAdd MaterialAdd MaterialAdd Material button from the material 
definition window.  The following dialog will appear.  Enter the material 
definitions and click the OK button.
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Changing the View
You can change the view at any time (even during shape generation) by using 
the following commands:

ToolbarToolbarToolbarToolbar

RotateRotateRotateRotate – The structure will be rotated around the coordinate system

PanPanPanPan – The structure will be translated in the graphical area

Dynamic ZoomDynamic ZoomDynamic ZoomDynamic Zoom – Moving the mouse upwards will increase the zoom factor 
while moving the mouse downwards will decrease the zoom factor

Zoom In/OutZoom In/OutZoom In/OutZoom In/Out – In this mode a rubber band rectangle will be defined by 
dragging the mouse.  After releasing the mouse button the zoom factor will 
be applied.

Context MenuContext MenuContext MenuContext Menu

Right click in the graphics area and select the menu item View View View View and choose 
from the options outlined in the Toolbar section.  The context menu also 
offers the following:

Fit AllFit AllFit AllFit All – This will zoom the defined structure to a point where it fits in 
the drawing area

Fit SelectionFit SelectionFit SelectionFit Selection – This fits only the selected objects into the drawing 
area.

SpinSpinSpinSpin – Drag the mouse and release the mouse button to start the 
object spinning.  The speed of the dragging prior to releasing the 
mouse controls the speed of the spin.

AnimateAnimateAnimateAnimate – Create or display the animation of parametric geometry

ShortcutsShortcutsShortcutsShortcuts

Since changing the view is a frequently used operation, some useful 
shortcut keys exist.  Press the appropriate keys and drag the mouse with 
the left button pressed:

ALT + DragALT + DragALT + DragALT + Drag – Rotate

In addition, there are 9 pre-defined view angles that can be 
selected by holding the ALT key and double clicking on the 
locations shown on the next page.

Shift + DragShift + DragShift + DragShift + Drag - Pan

ALT + Shift + DragALT + Shift + DragALT + Shift + DragALT + Shift + Drag – Dynamic Zoom

Pan

Rotate Dynamic Zoom

Zoom In/Out



Ansoft High Frequency Structure Simulator v10 User’s Guide 

1
Parametric Model Creation

1-19

Shortcuts - Predefined Views
These 9 pre-defined views can be seen by holding the ALT key and double 
clicking the left mouse button on the locations shown below.

TopTopTopTop

BottomBottomBottomBottom

RightRightRightRight

Predefined View Angles

LeftLeftLeftLeft
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Changing the View (Continued)
VisibilityVisibilityVisibilityVisibility

The visibility of objects, Boundaries, Excitations, and Field Reports can be 
controlled from the menu item View > VisibilityView > VisibilityView > VisibilityView > Visibility

Hide SelectionHide SelectionHide SelectionHide Selection

The visibility of selected objects can be set hidden by selecting the 
object(s) and choosing the menu View > Hide Selection > All ViewsView > Hide Selection > All ViewsView > Hide Selection > All ViewsView > Hide Selection > All Views.

RenderingRenderingRenderingRendering

To change the rendering select the menu item View > Render > Wireframe
or View > Render > Smooth Shaded

Coordinate SystemCoordinate SystemCoordinate SystemCoordinate System

To control the view of the coordinate system, select the menu item:

Visibility:Visibility:Visibility:Visibility:

Toggle the menu item  View > Coordinate System > Hide View > Coordinate System > Hide View > Coordinate System > Hide View > Coordinate System > Hide 
(Show)(Show)(Show)(Show)

SizeSizeSizeSize:

Toggle the menu item  View > Coordinate System > Small View > Coordinate System > Small View > Coordinate System > Small View > Coordinate System > Small 
(Large)(Large)(Large)(Large)

Background ColorBackground ColorBackground ColorBackground Color

To set the background color, select the menu item View > Modify Attributes View > Modify Attributes View > Modify Attributes View > Modify Attributes 
> Background Color> Background Color> Background Color> Background Color

Addition View Addition View Addition View Addition View SeetingsSeetingsSeetingsSeetings

Additional attributes of the view such as the projection, orientation, and 
lighting can be set from the menu item View > Modify AttributesView > Modify AttributesView > Modify AttributesView > Modify Attributes
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Enhancements and New Features

SelectionSelectionSelectionSelection

Select Connected VerticesConnected VerticesConnected VerticesConnected Vertices

Select Connected FacesConnected FacesConnected FacesConnected Faces

Select Connected EdgesConnected EdgesConnected EdgesConnected Edges

Select Edge Chain Edge Chain Edge Chain Edge Chain 

Select Face ChainFace ChainFace ChainFace Chain

Select Uncovered LoopsUncovered LoopsUncovered LoopsUncovered Loops

HealingHealingHealingHealing

Purge HistoryPurge HistoryPurge HistoryPurge History – makes an object appear as an 

imported entity so that healing can be 

performed on it

Remove Faces 

Remove Edges 

Remove Vertices

Align Faces
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Enhancements and New Features

VisibilityVisibilityVisibilityVisibility

Hide selected objects in Active View

Hide selected objects in All Views

Show selected objects in Active View

Show selected objects in All Views

3D User Interface Options3D User Interface Options3D User Interface Options3D User Interface Options

When there is a selection

Selection is always visible

Set transparency of selected objects

Set transparency of non-selected objects

Default Rotation About

Screen Center

Current Axis

Model Center

3D Modeler Options3D Modeler Options3D Modeler Options3D Modeler Options

Visualize history of objects
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Applying Structural Transformations
So far we have investigated hot to model simple shapes and how to change the 
view of the model.  To create more complicated models or reduce the number of 
objects that need to be created manually we can apply various transformations.

The following examples assume that you have already selected the object(s) that 
you wish to apply a transformation.

You can select the transformation options from the menu item Edit >Edit >Edit >Edit >

Arrange >Arrange >Arrange >Arrange >

Move Move Move Move –––– Translates the structure along a vector

Rotate Rotate Rotate Rotate –––– Rotates the shape around a coordinate axis by an angle

Mirror Mirror Mirror Mirror –––– Mirrors the shape around a specified plane

Offset Offset Offset Offset –––– Performs a uniform scale in x, y, and z.

Duplicate >Duplicate >Duplicate >Duplicate >

Along Lines Along Lines Along Lines Along Lines –––– Create multiple copies of an object along a vector

Around Axis Around Axis Around Axis Around Axis –––– Create multiple copies of an object rotated by a fixed 
angle around the x, y, or z axis

Mirror Mirror Mirror Mirror ---- Mirrors the shape around a specified plane and creates a 
duplicate

Scale Scale Scale Scale –––– Allows non-uniform scaling in the x, y, or z direction

The faces of an object can also be moved to alter the shape of an existing object.  
To move the faces of an object select the menu item 3D Modeler > Surfaces > 3D Modeler > Surfaces > 3D Modeler > Surfaces > 3D Modeler > Surfaces > 
Move FacesMove FacesMove FacesMove Faces and select Along NormalAlong NormalAlong NormalAlong Normal or Along VectorAlong VectorAlong VectorAlong Vector.
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Combine Objects by Using Boolean Operations
Most complex structures can be reduced to combinations of simple primitives.  
Even the solid primitives can be reduced to simple 2D primitives that are swept 
along a vector or around an axis(Box is a square that is swept along a vector to 
give it thickness).  The solid modeler supports the following Boolean operations:

UniteUniteUniteUnite – combine multiple primitives

Unite disjoint objects 

Separate Bodies to separate

SubtractSubtractSubtractSubtract – remove part of a primitive from another

SplitSplitSplitSplit – break primitives into multiple parts

IntersectIntersectIntersectIntersect– keep only the parts of primitives that overlap

SweepSweepSweepSweep – turn a 2D primitive into a solid by sweeping: Along a Vector, 
Around an Axis, Along a Path

ConnectConnectConnectConnect – connect 2D primitives.  Use Cover Surfaces to turn the 
connected object into a solid

SectionSectionSectionSection – generate 2D cross-sections of a 3D object

Most Boolean operations require a base primitive in which the Boolean operation 
is performed.  Only the base object will be preserved.

The Boolean functions provide the option to Clone objects.

Split Crossing ObjectsSplit Crossing ObjectsSplit Crossing ObjectsSplit Crossing Objects – When a group of objects 

are selected, a Boolean split is performed on 

ANY objects that overlap
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Local Coordinate Systems
The ability to create local coordinate systems adds a great deal of flexibility to the 
creations of structural objects.  In previous sections we have only discussed 
objects that are aligned to the global coordinate system.  The local coordinate 
system simplifies the definition of objects that do not align with the global 
coordinate system.  In addition, the object history is defined relative to a 
coordinate system.  If the coordinate system is moved, the geometry will 
automatically move with it.  The definition of coordinate systems are maintained 
in the Model Tree.

Working Coordinate SystemWorking Coordinate SystemWorking Coordinate SystemWorking Coordinate System

The working coordinate system is the currently selected CS.  This can be a 
local or global CS

Global CSGlobal CSGlobal CSGlobal CS

The default fixed coordinate system

RelativeRelativeRelativeRelative CSCSCSCS

User defined local coordinate system.

Offset

Rotated

Both

FaceFaceFaceFace CSCSCSCS

User defined local coordinate system.  It is tied to the location of the object 
face it was created on.  If the size of the base object changes, all objects 
created relative to the face CS will be updated automatically.

Continued on Next Page
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Local Coordinate Systems (Continued)
Face CS (Continued)Face CS (Continued)Face CS (Continued)Face CS (Continued)

To create a face CS, select the menu item 3D Modeler > Coordinate 3D Modeler > Coordinate 3D Modeler > Coordinate 3D Modeler > Coordinate 
System > FaceSystem > FaceSystem > FaceSystem > Face

1. Graphically select Face (Highlighted in model)

2. Select Origin for Face CS 

3. Set X-Axis

Step 1: Select Face Step 2: Select Origin

Step 3: Set X-Axis
New Working CS
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Cone is created with Face CS

Change the size of the box and 
the Cone is automatically 
moved with the Face CS

Local Coordinate Systems (Continued)
Example of Face CSExample of Face CSExample of Face CSExample of Face CS
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Parametric Geometry
The parametric modeler capability allows us to define variables in replace of a 
fixed position or size.  Once this has been defined the variable can be changed 
by the user or by Optimetrics.  Optimetrics can then be used to perform 
automatic Optimization, Parametric Sweeps, Statistical, or Sensitivity Analysis.  

Defining ParametersDefining ParametersDefining ParametersDefining Parameters

Select the command to parameterized

Choose the value to change

Enter a variable in replace of the fixed value

Define the variable using any combination of math functions or design 
variables.

The model will automatically be updated
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Parametric Geometry (Continued)
VariablesVariablesVariablesVariables

There are two types of variables that can be defined in the HFSS Desktop 

Design PropertiesDesign PropertiesDesign PropertiesDesign Properties – Local to model.  To access the local variables 
select the menu item HFSS >  Design PropertiesHFSS >  Design PropertiesHFSS >  Design PropertiesHFSS >  Design Properties

Project VariablesProject VariablesProject VariablesProject Variables – Global to all models in project. Start with $.  To 
access the global or project variables, select the menu item Project Project Project Project 
> > > > ProjectProjectProjectProject VariablesVariablesVariablesVariables

UnitsUnitsUnitsUnits

When defining variables they must contain units.  The default units 
for variables is meters.  

EquationsEquationsEquationsEquations

The variables can contain complex equations.  See the Online Help 
for a complete list of math functions

Equation based Curves and SurfacesEquation based Curves and SurfacesEquation based Curves and SurfacesEquation based Curves and Surfaces

Any curve/surface that can be described 

by an equation in three dimensions 

can be drawn.

AnimationAnimationAnimationAnimation

Right-Click in the 3D Model Window & Choose Animate to preview 
the parameterization

Note: depending on the quality of your graphics card you have the 
option of exporting ether AVI or GIF animation files.
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1.1
Boundary Conditions

Boundary Conditions
This chapter describes the basics for applying boundary conditions.   Boundary 

conditions enable you to control the characteristics of planes, faces, or interfaces 

between objects.  Boundary conditions are important to understand and are 

fundamental to solution of Maxwell’s equations.

Why they are Important
The wave equation that is solved by Ansoft HFSS is derived from the differential 

form of Maxwell’s Equations.   For these expressions to be valid, it is assumed 

that the field vectors are single-valued, bounded, and have continuous 
distribution along with their derivatives.  Along boundaries or sources, the fields 

are discontinuous and the derivatives have no meaning.  Therefore boundary 

conditions define the field behavior across discontinuous boundaries.

As a user of Ansoft HFSS you should be aware of the field assumptions made by 
boundary conditions.  Since boundary conditions force a field behavior we want 

to be aware of the assumptions so we can determine if they are appropriate for 

the simulation.  Improper use of boundary conditions may lead to inconsistent 

results.

When used properly, boundary conditions can be successfully utilized to reduce 
the model complexity.  In fact, Ansoft HFSS automatically uses boundary 

conditions to reduce the complexity of the model.  Ansoft HFSS can be thought of 

as a virtual prototyping  world for passive RF devices.  Unlike the real world 

which is bounded by infinite space, the virtual prototyping world needs to be 

made finite.  In order to achieve this finite space, Ansoft HFSS applies a 
background or outer boundary condition which is applied to the region 

surrounding the geometric model.  

The model complexity usually is directly tied to the solution time and computer 

resources so it is a competitive advantage to utilize them whenever possible.
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Common Boundary Conditions
There are three types of boundary conditions.  The first two are largely the users 

responsibility to define them or ensure that they are defined correctly.  The 

material boundary conditions are transparent to the user.

1.1.1.1. ExcitationsExcitationsExcitationsExcitations

Wave Ports (External) 

Lumped Ports (Internal)

2.2.2.2. Surface ApproximationsSurface ApproximationsSurface ApproximationsSurface Approximations

Symmetry Planes

Perfect Electric or Magnetic Surfaces

Radiation Surfaces

Background or Outer Surface

3.3.3.3. Material PropertiesMaterial PropertiesMaterial PropertiesMaterial Properties

Boundary between two dielectrics

Finite Conductivity of a conductor
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How the Background Affects a Structure
The background is the region that surrounds the geometric model and fills any 

space that is not occupied by an object.  Any object surface that touches the 

background is automatically defined to be a Perfect E boundary and given the 

boundary name outer.  You can think of your structure as being encased with a 
thin, perfect conductor.

If it is necessary, you can change a surface that is exposed to the background to 

have properties that are different from outer:

To model losses in a surface, you can redefine the surface to be either a 
Finite Conductivity or Impedance boundary.  A Finite Conductivity 

boundary can be a lossy metal, with loss as a function of frequency and 

defined using conductivity and relative permeability parameters. An 

Impedance boundary has real or complex values that by default remain 

constant over frequency.

To model a surface to allow waves to radiate infinitely far into space, 

redefine the surface to be radiation boundary.

The background can affect how you make material assignments.  For example, if 
you are modeling a simple air-filled rectangular waveguide, you can create a 

single object in the shape of the waveguide and define it to have the 

characteristics of air.  The surface of the waveguide is automatically assumed to 

be a perfect conductor and given the boundary condition outer, or you can 
change it to a lossy conductor.
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Boundary Conditions

Boundary Condition Precedence
The order in which boundaries are assigned is important in HFSS. Latter 

assigned boundaries take precedence over former assigned boundaries.

For example, if one face of an object is assigned to a Perfect E boundary, and a 

hole which lies in the same plane as this surface is assigned a Prefect H 

boundary, then the Perfect H will override the Perfect E in the area of the hole, 
and the E field will pass through the hole. If this operation were performed in the 

reverse order, then the Perfect E boundary would cover the Perfect H boundary, 

and no field would penetrate.

Once boundaries have been assigned, they can be re-prioritized by selecting 
HFSS > Boundaries > ReHFSS > Boundaries > ReHFSS > Boundaries > ReHFSS > Boundaries > Re----prioritizeprioritizeprioritizeprioritize. The order of the boundaries can be changed 
by clicking on a boundary and dragging it further up or down in the list. NOTE: 

Ports will always take the highest precedence.
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Technical Definition of Boundary Conditions
ExcitationExcitationExcitationExcitation – An excitation port is a type of boundary condition that permits energy 

to flow into and out of a structure. See the section on Excitations.

Perfect EPerfect EPerfect EPerfect E – Perfect E is a perfect electrical conductor, also referred to as a perfect 
conductor.  This type of boundary forces the electric field (E-Field) perpendicular 

to the surface. There are also two automatic Perfect E assignments:

Any object surface that touches the background is automatically defined to 

be a Perfect E boundary and given the boundary condition name outer.

Any object that is assigned the material pec (Perfect Electric Conductor) is 
automatically assigned the boundary condition Perfect E to its surface and 

given the boundary condition name smetal.

Perfect HPerfect HPerfect HPerfect H – Perfect H is a perfect magnetic conductor.  Forces E-Field tangential 
to the surface.

NaturalNaturalNaturalNatural – for a Perfect H boundary that overlaps with a perfect E boundary, 

this reverts the selected area to its original material, erasing the Perfect E 

boundary condition. It does not affect any material assignments. It can be 

used, for example, to model a cut-out in a ground plane for a coax feed.

Finite ConductivityFinite ConductivityFinite ConductivityFinite Conductivity –A Finite Conductivity boundary enables you to define the 

surface of an object as a lossy (imperfect) conductor. It is an imperfect E 

boundary condition, and is analogous to the lossy metal material definition.  To 
model a lossy surface, you provide loss in Siemens/meter and permeability 

parameters.  Loss is calculated as a function of frequency.  It is only valid for 

good conductors.  Forces the tangential E-Field equal to Zs(n x Htan).  The 

surface impedance (Zs) is equal to, (1+j)/(δσ), where:
δ is the skin depth, (2/(ωσµ))0.5 of the conductor being modeled
ω is the frequency of the excitation wave.

σ is the conductivity of the conductor
µ is the permeability of the conductor
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Technical Definition of Boundary Conditions (Continued)
ImpedanceImpedanceImpedanceImpedance – a resistive surface that calculates the field behavior and losses 

using analytical formulas.  Forces the tangential E-Field equal to Zs(n x Htan).  

The surface impedance is equal to Rs + jXs, where:

Rs is the resistance in ohms/square

Xs is the reactance in ohms/square

Layered ImpedanceLayered ImpedanceLayered ImpedanceLayered Impedance – Multiple thin layers in a structure can be modeled as an 

impedance surface.  See the Online Help for additional information on how to use 

the Layered Impedance boundary.

Lumped RLCLumped RLCLumped RLCLumped RLC – a parallel combination of lumped resistor, inductor, and/or 

capacitor surface.  The simulation is similar to the ImpedanceImpedanceImpedanceImpedance boundary, but the 

software calculate the ohms/square using the user supplied R, L, C values.

Infinite Ground PlaneInfinite Ground PlaneInfinite Ground PlaneInfinite Ground Plane – Generally, the ground plane is treated as an infinite, 

Perfect E, Finite Conductivity, or Impedance boundary condition. If radiation 

boundaries are used in a structure, the ground plane acts as a shield for far-field 

energy, preventing waves from propagating past the ground plane. to simulate 
the effect of an infinite ground plane, check the Infinite ground plane box when 

defining a Perfect E, Finite Conductivity, or Impedance boundary condition. 

NOTE: Enabling the Infinite Ground Plane approximation ONLY affects post-

processed far-field radiation patterns. It will not change the current flowing on the 
ground plane.

RadiationRadiationRadiationRadiation – Radiation boundaries, also referred to as absorbing boundaries,

enable you to model a surface as electrically open: waves can then radiate out of 

the structure and toward the radiation boundary. The system absorbs the wave at 
the radiation boundary, essentially ballooning the boundary infinitely far away 

from the structure and into space.  Radiation boundaries may also be placed 

relatively close to a structure and can be arbitrarily shaped. This condition 

eliminates the need for a spherical boundary. For structures that include radiation 

boundaries, calculated S-parameters include the effects of radiation loss.  When 
a radiation boundary is included in a structure, far-field calculations are 

performed as part of the simulation.
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Technical Definition of Boundary Conditions (Continued)
SymmetrySymmetrySymmetrySymmetry - represent perfect E or perfect H planes of symmetry. Symmetry 

boundaries enable you to model only part of a structure, which reduces the size 

or complexity of your design, thereby shortening the solution time. Symmetry 

boundaries, as opposed to a simple Perfect E or H plane, should be used when 

the plane cuts across a port. In this instance, the port has a different amount of 
power, voltage, and current associated with it, and thus a different impedance. To 

make a port with a symmetry plane look like a full-sized port, you must use the 

Impedance Multiplier in the boundary wizard.

For a single Symmetry H boundary, the Impedance Multiplier is 0.5.

For a single Symmetry E boundary, the Impedance Multiplier is 2.

Other considerations for a Symmetry boundary condition:

A plane of symmetry must be exposed to the background.

A plane of symmetry must not cut through an object drawn in the 3D 
Modeler window.

A plane of symmetry must be defined on a planar surface.

Only three orthogonal symmetry planes can be defined in a problem

Master / SlaveMaster / SlaveMaster / SlaveMaster / Slave - Master and slave boundaries enable you to model planes of 

periodicity where the E-field on one surface matches the E-field on another to 

within a phase difference. They force the E-field at each point on the slave 

boundary match the E-field to within a phase difference at each corresponding 

point on the master boundary. They are useful for simulating devices such as 
infinite arrays.  Some considerations for Master/Slave boundaries:

They can only be assigned to planar surfaces.

The geometry of the surface on one boundary must match the geometry 

on the surface of the other boundary. 
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Arbitrary Wave Sources
Polarized plane waves (circular, elliptical)

Evanescent plane waves

Gaussian beams

Hertzian Dipole  and  Line Source

Linear antenna

. 

airairairair

glassglassglassglass

Incident Gaussian BeamIncident Gaussian BeamIncident Gaussian BeamIncident Gaussian Beam Total FieldsTotal FieldsTotal FieldsTotal Fields
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Frequency Selective Surfaces
Automated Reflection & Transmission computation

interpolating sweep may be applied !

. 

Frequency Selective Surfaces: Theory and DesignFrequency Selective Surfaces: Theory and DesignFrequency Selective Surfaces: Theory and DesignFrequency Selective Surfaces: Theory and Design,

Ben A. Munk, Fig 2.15, pg 38



��������	��
�	
���
��
��	������
�



Ansoft High Frequency Structure Simulator v10 User’s Guide 

1.2
Excitations

1.2-1

Technical Overview
Ports are a unique type of boundary condition that allow energy to flow into and 

out of a structure.   You can assign a port to any 2D object or 3D object face.  

Before the full three-dimensional electromagnetic field inside a structure can be 

calculated, it is necessary to determine the excitation field pattern at each port.  

Ansoft HFSS uses an arbitrary port solver to calculate the natural field patterns or 
modes that can exist inside a transmission structure with the same cross section 

as the port.  The resulting 2D field patterns serve as boundary conditions for the 

full three-dimensional problem. 

By default Ansoft HFSS assumes that all structures are completely 

encased in a conductive shield with no energy propagating through it.  You 

apply Wave PortsWave PortsWave PortsWave Ports to the structure to indicate the area were the energy 

enters and exits the conductive shield.  

As an alternative to using Wave PortsWave PortsWave PortsWave Ports, you can apply Lumped PortsLumped PortsLumped PortsLumped Ports to a 

structure instead.  Lumped PortsLumped PortsLumped PortsLumped Ports are useful for modeling internal ports 

within a structure.  
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Wave Port
The port solver assumes that the Wave PortWave PortWave PortWave Port you define is connected to a semi-

infinitely long waveguide that has the same cross-section and material properties 

as the port.  Each Wave PortWave PortWave PortWave Port is excited individually and each mode incident on a 

port contains one watt of time-averaged power.  Wave PortsWave PortsWave PortsWave Ports calculate 

characteristic impedance, complex propagation constant, and generalized S-
Parameters.

Wave Equation

The field pattern of a traveling wave inside a waveguide can be determined 
by solving Maxwell’s equations.  The following equation that is solved by 

the 2D solver is derived directly from Maxwell’s equation.

where:

EEEE(x,y) is a phasor representing an oscillating electric field.

k0 is the free space wave number, 

µr is the complex relative permeability.
εr is the complex relative permittivity.

To solve this equation, the 2D solver obtains an excitation field pattern in 
the form of a phasor solution, EEEE(x,y). These phasor solutions are 

independent of z and t; only after being multiplied by e-γz do they become 
traveling waves.  

Also note that the excitation field pattern computed is valid only at a single 
frequency. A different excitation field pattern is computed for each 

frequency point of interest.

( ) 0),(,
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Modes
For a waveguide or transmission line with a given cross section, there is a series 

of basic field patterns (modes) that satisfy Maxwell’s Equations at a specific 

frequency.  Any linear combination of these modes can exist in the waveguide.

Mode Conversion

In some cases it is necessary to include the effects of higher-order modes 

because the structure acts as a mode converter.  For example, if the mode 

1 (dominant) field at one port is converted (as it passes through a structure) 

to a mode 2 field pattern at another, then it is necessary to obtain the S-
parameters for the mode 2 field.

Modes, Reflections, and Propagation

It is also possible for a 3D field solution generated by an excitation signal of 
one specific mode to contain reflections of higher-order modes which arise 

due to discontinuities in a high frequency structure. If these higher-order 

modes are reflected back to the excitation port or transmitted onto another 

port, the S-parameters associated with these modes should be calculated.  

If the higher-order mode decays before reaching any port—either because 
of attenuation due to losses or because it is a non-propagating evanescent 

mode—there is no need to obtain the S-parameters for that mode. 

Modes and Frequency

The field patterns associated with each mode generally vary with

frequency.  However, the propagation constants and impedances always 

vary with frequency. Therefore, when a frequency sweep has been 

requested, a solution is calculated for each frequency point of interest.  
When performing frequency sweeps, be aware that as the frequency

increases, the likelihood of higher-order modes propagating also increases.
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Modes and S-Parameters

When the Wave Ports are defined correctly, for the modes that are included 
in the simulation, there is a perfect matched condition at the Wave Port.  

Because of this, the S-Parameters for each mode and Wave Port are 

normalized to a frequency dependent impedance.  This type of S-

Parameter is referred to as Generalized S-Parameter.

Laboratory measurements, such as those from a vector network analyzer, 

or circuit simulators use a constant reference impedance (i.e. the ports are 

not perfectly matched at every frequency).  

To obtain results consistent with measurements or for use with 

circuit simulators, the generalized s-parameters calculated by Ansoft 

HFSS must be renormalized to a constant characteristic impedance.  

See the section on Calibrating Wave PortsCalibrating Wave PortsCalibrating Wave PortsCalibrating Wave Ports for details on how to 
perform the renormalization.

Note:Note:Note:Note: Failure to renormalize the generalized S-Parameters may 

result in inconsistent results.  For example, since the Wave Ports 

are perfectly matched at every frequency, the S-Parameters do not 
exhibit the interaction that actually exists between ports with a 

constant characteristic impedance. 



Ansoft High Frequency Structure Simulator v10 User’s Guide 

1.2
Excitations

1.2-5

Wave Port Boundary Condition
The edge of a Wave Port can have the following boundary conditions:

Perfect E or Finite Conductivity – by default the outer edge of a Wave Port 

is defined to have a Perfect E boundary.  With this assumption, the port is 

defined within a  waveguide.  For transmission line structures that are 

enclosed by metal, this is not a problem.  For unbalanced or non-enclosed 
lines, the fields in the surrounding dielectric must be included.  Improper 

sizing of the port definition will result in erroneous results.

Symmetry – the port solver understands Perfect E and Perfect H symmetry 
planes.  The proper Wave Port impedance multiplier needs to be applied 

when using symmetry planes.

Impedance – the port solver will recognize an impedance boundary at the 
edges of the ports. 

Radiation – the default setting for the interface between a Wave Port and a

Radiation boundary is to apply a Perfect E boundary to the edge of the 

ports.  
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Calibrating Wave Ports
Wave Ports that are added to a structure must be calibrated to ensure consistent 
results. This calibration is required in order to determine direction and polarity of 

fields and to make voltage calculations.

Solution Type: Driven Modal

For Driven Modal simulations, the Wave Ports are calibrated using 

Integration Lines.  Each Integration Line is used to calculate the following 

characteristics:

Impedance – As an impedance line, the line serves as the path over 
which Ansoft HFSS integrates the E-field to obtain the voltage at a 

Wave Port.  Ansoft HFSS uses the voltage to compute the 

characteristic impedance of the Wave Ports, which is needed to 

renormalize generalized S-matrices to specific impedances such as 
50 ohms.  

Note: Note: Note: Note: If you want to be able to renormalize S-parameters or 

view the values of Zpv or Zvi, you must apply Integration 

Lines to the Wave Ports of a structure.

Calibration – As a calibration line, the line explicitly defines the up or 
positive direction at each Wave Port.  At any Wave Port, the 
direction of the field at ωt = 0 can be in at least one of two directions.  
At some ports, such as circular ports, there can be more than two 
possible directions, and you will want to use Polarize E-Field.  If you 

do not define an Integration Line, the resulting S-parameters can be 

out of phase with what you expect.

Tip Tip Tip Tip You may need to run a ports-only solution first to help determine how 
the Integration Lines need to be applied to a Wave Port and their direction.
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To calibrate a Wave Port, that has already been defined, with an

Integration Line:

1. From the Project TreeProject TreeProject TreeProject Tree, expand ExcitationsExcitationsExcitationsExcitations and double click on the 
Wave Port to be calibrated

2. Select the ModesModesModesModes tab.

3. From the table, select the Integration LineIntegration LineIntegration LineIntegration Line column for the first mode 

and choose New LineNew LineNew LineNew Line.

4. Enter the position and length of the line using one of the following 

methods

Type the start and stop points of the line directly into the x, y, 

or z axis fields, referenced to the working coordinates.  For 

more information on coordinates, refer to “Getting Oriented in 
the Drawing Space” in Chapter **, Drawing Basics and Tips.

Graphically pick the points in the Design Window’s graphics 

area.  The line is displayed as a vector; the vector indicates 

direction. From the Integration LineIntegration LineIntegration LineIntegration Line column, select Swap Swap Swap Swap 
Endpoints Endpoints Endpoints Endpoints to reverse the direction of the line, if necessary.

5. Repeat steps 3 and 4 to define and apply lines to other modes of the 

current Wave Port. 

6. Click the OKOKOKOK button when you are finished defining Integration Lines

7. Repeat steps 1-6 to apply lines to other Wave Ports.

Step 3: Create New Line
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About Impedance Lines

The S-matrices initially calculated by Ansoft HFSS are generalized S-
matrices normalized to the impedances of each port.  However, it is often 

desirable to compute S-matrices that are normalized to specific 

impedances such as 50 ohms.  To convert a generalized S-matrix to a 

renormalized S-matrix, Ansoft HFSS first computes the characteristic 

impedance at each port.  There are several ways to compute the 
characteristic impedance (Zpi, Zpv, Zvi).  

Ansoft HFSS will always calculate Zpi.  The impedance calculation using 

power and current is well defined for a Wave Port.  The other two methods 
– Zpv and Zvi – require a line of integration to determine voltage.  By defining 

an Integration Line for each mode, the voltage can be computed. 

In general, the impedance line should be defined between two points at 
which the voltage differential is expected to be a maximum.  If you are 

analyzing multiple modes, define a separate Integration Lines for each 

mode since the orientation of the electric field will vary.

About Calibration Lines

When the excitation field pattern at a Wave Port is computed, the direction 

of the field at ωt=0 is arbitrary and can point in one of at least two ways.  
The Integration Lines calibrate the port by defining the preferred direction 

or the reference orientation.  Be sure to define Integration Lines for each 
Wave Port so that the preferred direction is the same relative to other ports 

having identical or similar cross-sections.  In this way, the results of 

laboratory measurements (in which the setup is calibrated by removing the 

structure and connecting two ports together) can be duplicated.

Because the calibration lines only determine the phase of the excitation 

signal and the traveling wave, the system ignores them during the Ports-

Only solution
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Solution Type: Driven Terminal

The Modal S-matrix solution computed by Ansoft HFSS is expressed in 
terms of the incident and reflected powers of the waveguide modes.  This 

description does not lend itself to problems where several different quasi-

transverse electromagnetic (TEM) modes can propagate simultaneously.  

For structures like coupled transmission lines or connectors, which support 

multiple, quasi-TEM modes of propagation, it is often desirable to compute 
the Terminal S-Parameters.

To calibrate a Wave Port, that has already been defined, with Terminal 

Lines:

1. From the Project TreeProject TreeProject TreeProject Tree, expand ExcitationsExcitationsExcitationsExcitations and double click on the 

Wave Port to be calibrated

2. Select the TerminalsTerminalsTerminalsTerminals tab.

3. From the table, select the Terminal LineTerminal LineTerminal LineTerminal Line column for the first terminal 
and choose New LineNew LineNew LineNew Line.

4. Enter the position and length of the line using one of the following 

methods

Type the start and stop points of the line directly into the x, y, 

or z axis fields, referenced to the working coordinates.  For 
more information on coordinates, refer to “Getting Oriented in 

the Drawing Space” in Chapter **, Drawing Basics and Tips.

Graphically pick the points in the Design Window’s graphics 

area.  The line is displayed as a vector; the vector indicates 
direction. From the Terminal LineTerminal LineTerminal LineTerminal Line column, select Swap Swap Swap Swap 

Endpoints Endpoints Endpoints Endpoints to reverse the direction of the line, if necessary.

5. Repeat steps 3 and 4 to define and apply lines to other terminals of 

the current Wave Port. 

6. Click the OKOKOKOK button when you are finished defining Terminal Lines

7. Repeat steps 1-6 to apply lines to other Wave Ports.
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About Terminal Lines

The Terminal S-Parameters represent the linear combination of nodal 
voltages and currents for the Wave Port.  From the nodal voltages and 

currents, the admittance, impedance, and pseudo-S-matrices can be 

determined.

By defining a Terminal Line for each conductor across a port, Ansoft HFSS

will automatically convert the Modal Solution to its equivalent Terminal 

Solution.  

In general a single terminal line is created from the reference or 

“ground” conductor to each port-plane conductor.  

The polarity reference for the voltage is established by the arrow 

head(+) and the base(-) of the terminal line.  If you decide to create 

terminal lines, they must be defined for every port and every terminal 
on the port
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Considerations for Defining Wave Ports

Wave Port Locations

It is recommended that only surfaces that are exposed to the background 

be defined as Wave Ports.  The background is given the boundary name 
outer.  Therefore a surface is exposed to the background if it touches the 
boundary outer.  You can locate all regions of outer by selecting the menu 
item HFSS, Boundary Display (Solver View).  HFSS, Boundary Display (Solver View).  HFSS, Boundary Display (Solver View).  HFSS, Boundary Display (Solver View).  From the Solver View of Solver View of Solver View of Solver View of 

BoundariesBoundariesBoundariesBoundaries, check the VisibilityVisibilityVisibilityVisibility for outer.

Interior Wave Ports

If you want to apply Wave Ports to the interior of a structure, you 
must create an inner void or select the surface of an interior object 

that is assign a perfect conductor material property.  Inner voids are 

automatically assigned the boundary outer. You can create an inner 

void by surrounding one object entirely with another object, then 

subtracting the interior object.

Ports are Planar

A port must lie in a single plane. Ports that bend are not allowed. For 

example, if a geometric model has a curved surface exposed to the 
background, that curved surface cannot be defined as a port.
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Wave Ports Require a Length of Uniform Cross Section

Ansoft HFSS assumes that each port you define is connected to a semi-
infinitely long waveguide that has the same cross section as the Wave Port. 

When solving for S-parameters, the simulator assumes that the structure is 

excited by the natural field patterns (modes) associated with these cross 

sections.  The following figures illustrate cross sections. The first figure 

shows regions that have been defined as Wave Ports on the outer 
conductive surface of a structure.  

In the next figure, cross sections must be added to the structure. The 

waveguide on the left is not modeled correctly because it does not contain 

a length of uniform cross section at either Wave Port. To model it correctly, 

add a length of uniform cross section at each Wave Port, as shown on the 
waveguide to the right.

Port 1

Port 2

Port 3

Port 4

no uniform cross section

at Wave Ports

uniform cross section 

added for each Wave Port
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The length of the uniform cross section must be long enough to allow non-

propagating modes to die out. This ensures accurate simulation results. For 

example, if a non-propagating mode takes approximately one-eighth of a 
wavelength to die out, either because of losses or because it is an 

evanescent mode, then you should make the uniform cross section one-

eighth of a wavelength. Otherwise, you must include the effects of that 

higher-order mode in the simulation.   

Discontinuities placed close to the port may also cause non-propagating 

modes to reach the port.  Placing the port too close to discontinuities will 

cause erroneous results since the boundary condition at the port will 

prevent the simulated solution from matching the actual solution (i.e. The 
system forces the field at each port to be a linear combination of the modes 

you request).  The energy from the non-propagating modes that reach the 

port will affect the apparent energy in the dominate mode and produce 

erroneous results.  

The modes attenuate as a function of e-αz, assuming the wave propagates 

in the z-direction.  Therefore, the required distance (uniform port length) 

depends on the value of the modes propagation constant. 

When the Wave Ports lengths are correct, for modes that are included in 

the simulation there is a perfect matched condition at a Wave Port, as if the 

waveguide extended to infinity. For modes that are not included in a 

simulation, a Wave Port appears as a perfect conductor.

Wave Ports and Multiple Propagating Modes

Each higher-order mode represents a different field pattern that can 

propagate down a waveguide.  In general, all propagating modes should be 

included in a simulation.  In most cases, you can accept the default of 1 
mode, but where propagating higher-order modes are present you need to 

change this to include higher-order modes.  If there are more propagating 

modes than the number specified, erroneous results will be generated. The 

number of modes can vary among ports.
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Propagating Modes

Propagating modes are those that have a propagation constant, β (rad/m), 
that is greater than their attenuation constant, α (Np/meter). One way to 
determine which modes need to be modeled is to set up the problem with 

multiple modes and generate a solution with no adaptive passes. Then, 

inspect the complex propagation constant, γ = α + β, associated with each 
mode.  To inspect the complex propagation constant (Gamma) after an 
analysis has been performed:

1. From the HFSS, Analysis Setup HFSS, Analysis Setup HFSS, Analysis Setup HFSS, Analysis Setup menu, select Matrix Data.Matrix Data.Matrix Data.Matrix Data.

2. A dialog similar to the one shown below will appear, check GammaGammaGammaGamma

and change the display type to Real/Imaginary.Real/Imaginary.Real/Imaginary.Real/Imaginary.

Each additional mode at a port results in an additional set of S-parameters. 
For example, if you are analyzing two modes at each port in a three-port 

structure, the final result is a 6x6 S-matrix. In general, an n-port solution is 

the total number of excitations of all ports, the number of modes, plus the 

number of sources. 

If you choose not to include some higher-order modes in a simulation, 

make sure the cross sections on the Wave Ports are long enough so that 

the modes die out and are not reflected back.
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Wave Ports and Symmetry Planes – The Impedance Multiplier

When a ports size is reduced because of a symmetry plane, the impedance 
needs to be adjusted to account for the loss of voltage and power-flow.  

A Perfect E Symmetry plane must be adjusted by a factor of 2. 

Such models have half the voltage differential and half the 

power flow of the full structure, resulting in impedances that 
are half of those for the full structure.

A Perfect H Symmetry plane must be adjusted by a factor of 0.5.

Such models have the same voltage differential but half the 
power flow of the full structure, resulting in impedances that 

are twice those for the full structure.

If the structure has a combination of Perfect E and Perfect H 

Symmetry planes,  adjust accordingly. 

For instance, you do not have to enter an impedance 

multiplier for a structure with both a Perfect E and Perfect H 

boundary since you would be multiplying by 0.5 and 2.
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Analysis Setup 
This chapter provides details on Analysis in the Ansoft HFSS v.10.0 software 

such as:

Add Solution Setup

Adapt Frequency

Convergence Criteria

Initial Mesh Options

Adaptive Options

Low-Order Basis Functions

Setup

Properties

Add Sweep

Sweep – Properties and Types of Sweeps
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Adaptive Meshing
The adaptive meshing constructs a mesh that conforms to the electrical 
performance of the device.  By employing adaptive meshing, the mesh is 
automatically tuned to give the most accurate and efficient mesh possible.  
Without adaptive meshing, the responsibility of generating the correct mesh 
would be left to the user.  This is both error prone and tedious.  With Adaptive 
Meshing you will know the answer is right the first time.

How it Works 
The adaptive meshing algorithm searches for the largest gradients in the E-
field or error and sub-divides the mesh in those regions.  It also targets 
singularities, such as the edge of a conductor, as locations to add extra 
elements.  

The mesh growth for each adaptive pass is controlled by the Tetrahedron 
Refinement in Setup Solution (Advanced Tab)Setup Solution (Advanced Tab)Setup Solution (Advanced Tab)Setup Solution (Advanced Tab).  You should notice, that the 
TetTetTetTet. Refinement. Refinement. Refinement. Refinement is a percentage.  This ensures that between each pass the 
mesh is sufficiently perturbed and guarantees that you will not receive false 
convergences.

After the mesh has been refined, a full solution is performed and the 
process is repeated until convergence

Convergence
After each adaptive pass, HFSS compares the S-Parameters from the 
current mesh to the results of the previous mesh.  If the answers have not 
changed by the user defined value or Delta S, then the solution has 
converged and the current or previous mesh can be used to perform a 
frequency sweep.  If the solution has converged, then technically, the 
previous mesh is as good as the current mesh.  In this case, Ansoft HFSS 
will use the previous mesh to perform frequency sweeps if they have been 
requested.

Delta S
The Delta S is the default criteria used to determine mesh/solution 
convergence.  The Delta S is defined as the maximum change in the 
magnitude of the S-parameters between two consecutive passes: 

Maxij[mag(SN
ij – S(N-1)

ij)], where i and j cover all matrix entries and N 
represents the pass number

Since this is the magnitude of a vector quantity, it can vary between 
0 and 2
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Adaptive Meshing (Continued)
Since the adaptive meshing is based on the E-field, choosing the proper adapt 
frequency can be critical.  Like anything in engineering, there are exceptions to 
every rule, but in general, the following tips will help you select the correct 
adaptive frequency.

Broadband Structures
For broadband structures, the end frequency should be used since the finer 
mesh should be valid at all lower frequency points.  

Filters
For filters or narrow-band devices, a frequency within the pass-band or 
operating region should be used since in the stop-band the E-field is only 
present at the ports.  

Fast Frequency Sweeps
For Fast Frequency Sweeps, typically use the center of the frequency 
band.  The Fast Frequency Sweep uses the mesh/solution at the adaptive 
frequency point.  Since the error in the Fast Frequency Sweep typically 
increases as you move away from this point, the center of the frequency 
band is usually the preferred solution frequency to extrapolate the entire 
band from.  It is also important to center the frequency sweep around a 
center point that will produce an adequate mesh.  This is especially true for 
very high Q devices such as narrow-band filters.  If the center frequency is 
not in the filters pass-band, the bandwidth and resonant frequency will not 
be accurate. 

Full-Wave Spice Export
For Full-Wave Spice problems, use the Knee Frequency 
(Fknee≈0.5/rise_time) to adapt to convergence.  Then perform 2-5 more 
frequency points to adapt at.  The additional points should be selected 
between the Knee Frequency and the maximum frequency (Only needs 2-3 
passes per frequency point).  

Frequencies below the Knee Frequency should have the largest 
impact on the time-domain, therefore the Knee Frequency is used 
for the primary adaptive meshing.  Unfortunately, the mesh needed 
at the higher frequencies may not be resolved enough without 
performing the additional adaptive mesh passes.  

Due to the large bandwidths, typically you will use an Interpolating 
Sweep.  Using multiple frequency sweeps and combining the results 
may also be useful.



Ansoft High Frequency Structure Simulator v10 User’s Guide 

2
Analysis Setup

2-4

Adaptive Meshing (Continued)

High-Speed Digital/Signal Integrity

For high-speed digital simulations you are interested in the performance 

over a broad frequency range.  To determine the frequency bandwidth that 

you need to simulate over, the following guide is recommended:

BW ≥  5*Fknee, where Fknee ≈ 0.5/rise_time

In general, all of the frequencies below the Fknee frequency have the largest 

impact on the digital signal.  Therefore a good high-speed digital design will 

have a clean, well matched response up to at least Fknee. 

High-Speed Digital (SPICE Export)

To export to SPICE, for transient simulations, a large bandwidth is required 

(≥5*Fknee). The reason for this is that the Fknee is an approximation, plus you 

want more then 1 sample point over the rise-time.  

When exporting to SPICE, the low frequency is also important.  You want 
to get as close to DC as possible.  Every port setup and every problem is a 

little different with regards to how low you can solve in Ansoft HFSS.  99% 

of the time you can simulate to at least 100MHz.  Below that is trial an 

error.  When you export to Full-Wave SPICE, the DC component will be 

extrapolated from the lowest frequency in the solve.  Therefore, going from 
1GHz to DC is not going to give a very accurate extrapolation.

Frequency spacing.  The setup for Full-Wave Spice recommends that the 

minimum frequency be used as the spacing.  This usually results in 1000-

3000 points depending on the bandwidth of the sweep.

High-Speed Digital  (Adaptive Meshing)

Since the simulation bandwidths can be so large, determining the proper 

adaptive mesh frequency can be very difficult.  The following technique is 

recommended:

1. Adapt at the Fknee until convergence (Delta S 0.02 to 0.01)

2. Pick 2-3 frequency points above Fknee to adapt at

Don’t run these to convergence, just do 3-5 passes

3. Solve the Frequency Sweep

For large bandwidths, either break up the frequency sweep 

and/or use Interpolating Sweeps
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Adaptive Meshing (Continued)

High-Speed Digital (Why this technique?)

If the frequency points below Fknee have the biggest impact on the digital 

response, then meshing at that frequency should produce an accurate 

mesh for all frequency points below it.

If you simulate most passive devices over a large enough bandwidth, they 

start to exhibit a low pass filter response.  So the higher frequency content 

contributes less to the time-domain simulation in addition to being filtered 

out by the devices frequency response.  This is why we don't worry as 

much about the higher frequency adaptive passes converging.  To 
appreciate the significance of this you also have to take into account how 

HFSS does its adaptive meshing.  It is done by finding the highest gradient 

of the electric field.  So if the device behaves as a filter and we are 

adapting outside the pass band of the filter, we are focusing most of the 

mesh only at the ports.

Now if your device performs well beyond Fknee, there is no harm in 

adapting at a higher frequency until convergence.  Unfortunately, for real 

problems(10-40Gb/s) the design challenge is to get the device to work at 

least up to the knee frequency.

For these large Bandwidth sweeps, use the Interpolating Sweep.  This 

sweep is based on the discrete sweep, but it adaptively picks discrete 

points and curve fits.  So it takes less discrete points to represent a large 

bandwidth.  The interpolating sweep can use either a polynomial fit or a 

rational function.  So it can help to break up the sweep.  Up to the knee 
frequency works good for a polynomial fit and above that the rational 

function will work better.  The interpolation sweep will always pass through 

the start/end frequency points so if you don't change the mesh and make 

sure the start and end frequency points match up for your sweeps, they 

combine together without a problem.
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Adaptive Meshing (Continued)

High-Speed Digital (Design Flow)

Up until this point, the entire discussion of High Speed Digital was based 

on the assumption that you are exporting every simulation to SPICE.   

There are many stages in the design cycle and going to SPICE is not 
required for every part of the design.  If you have resonance's, mismatch, 

coupling, etc below the Fknee, these should be addressed in the field 

solver prior to running SPICE simulations.  Therefore, the sweep only 

needs to be done to 1.5-2x Fknee to investigate the performance.  In 

addition, for engineering design purposes, you may not need to go below 
1GHz. 

During these early stages of design, you may also want to use the Fast 

Frequency Sweep since you can get S-Parameters and fields for every 

frequency in the Sweep.  This allows you to visualize any resonance or 

coupling you may be seeing in the S-Parameters.  

Another useful tool for package/board analysis is the EigenMode solver.  In 

many instances, resonances caused by the power and ground plane nets 

are the largest contributor to designs problems.  By removing everything 

except the power/ground nets, the Eigenmode solver can be used to 
quickly identify resonances. 
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HFSS v10 Mesh Algorithm Improvements
Fault Tolerant Meshing

HFSS v10 introduces new feature when it comes to meshing 3D 
geometries. It is called Fault Tolerant Meshing. By default the Classical 
mesh maker is still default mesh maker since it has been improved over the 
years. If the classical mesh maker fails Fault Tolerant mesh maker will get 
invoked. You will notice that mesh3D_init_FT line in your profile file 
whenever Fault Tolerant mesher gets invoked. By default if the classical 
mesh maker was used the profile file will contain only mesh3D_init line.

Model Resolution length (MRL)
The model resolution length can be thought as a post initial mesh feature. It 
is a feature that could not be supported in the classical mesh maker. So if 
the user set the MRL, only the Fault Tolerant mesher will be used. Model 
resolution length enables model convergence. In the previous versions of 
HFSS the number of  tetrahedrons as a basic mesh element could get too 
large so the solver would run out of memory.  With the MRL we are able to 
reduce the number of tetrahedrons using a less memory resources while 
keeping he same accuracy as before.

MRL Default values
The model resolution length is the length to which mesh will resolve the 
model. The default values are 100 times the absolute resolution length 
(ResAbs) used by ACIS. ACIS uses 1.0 e-6 user units as the default 
ResAbs. Recommended values are of on the order of 0.1 to 0.05 of your 
wavelength. You can simply start with values from 0.1 and then try 0.01 
and 0.001 and see if they improve the mesh sizes.  If the user specifies the 
length that the mesh grossly misinterprets the model or changes the 
contacts between the objects HFSS will detect this and report this as an 
error ( “ MRL too large or object_name lost all surface triangles”) 
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Setting Convergence
It is very common to request too much accuracy when defining the Delta S.  

Remember! The manufacturing process, the laboratory equipment, and the 

measurement process all have inherent errors associated with them.  Asking 

HFSS to provide a level of accuracy that is orders of magnitudes greater then 

what you can obtain in the real-world does not buy you anything other then extra 
simulation time.  Instead, use the Convergence Monitoring and good engineering 

judgment to determine when to terminate the adaptive meshing process and how 

to set the Delta S.  In general a Delta S of 0.02(2%), which is the default, or as 

low as 0.01(1%), is sufficient.

Solution Convergence – S-Matrix vs. Fields 
The convergence criteria is based on the S-Matrix.  Typically, the S-Matrix 
converges prior to field quantities.  That is to say if you are looking for the 

absolute field value within the problem region, chances are you will need to solve 

several more adaptive passes in order to see the same convergence that was 

obtained for the S-Matrix.  This will also depend on the field quantity you are 

solving for.  Ansoft HFSS solves for the E-field directly.  From the E-field it 
calculates the H-field and from the H-field it calculates current.  Therefore, the 

field quantities will also converge with varying mesh densities.
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Adding a Solution Setup
In order to perform an Analysis in Ansoft HFSS a Solution Setup must be added.  

To do this, right click on Analysis in the Ansoft HFSS model tree.

By default, the General Tab will be displayed.  The Solution Frequency and the 

Convergence Criteria are set here.

Enabling/Disabling a Solution Setup
When adding a new solution setup, by default, it will be enabled. To disable any 

setups, right click on the setup and remove the check mark next to EnableEnableEnableEnable by left 

clicking once. Once a solution is disables, it will be grayed out in the project tree. 

To enable a disabled project, right click on the disbaled setup and place a check 

mark next to EnableEnableEnableEnable by left clicking once.

EnabledEnabledEnabledEnabled

Disabled Disabled Disabled Disabled 

EnabledEnabledEnabledEnabled
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Adding a Solution Setup (Continued)

General Tab

Solution FrequencySolution FrequencySolution FrequencySolution Frequency –––– This frequency point is used by the adaptive mesher  

to automatically refine the mesh to electrical performance of the device.

Solve Ports OnlySolve Ports OnlySolve Ports OnlySolve Ports Only - The Port Solution uses an arbitrary, adaptive 2D 
eigenmode solver to determine the natural frequencies or modes 

that will be used to excite the structure.  The ports only solution can 

be used to calculate only the modal field patterns for the 2D cross 

sections defined to be ports.  This is useful for determining the 

number of modes, modal fields, the port length, and/or proper port 
setup prior to running a full solution.

Adaptive SolutionsAdaptive SolutionsAdaptive SolutionsAdaptive Solutions

Maximum Number of PassesMaximum Number of PassesMaximum Number of PassesMaximum Number of Passes - This number controls the maximum 

number of passes the adaptive mesh routine will perform as it 
attempts to satisfy the convergence criteria.

Maximum Delta S Per PassMaximum Delta S Per PassMaximum Delta S Per PassMaximum Delta S Per Pass – This number defines the convergence 

criteria for the adaptive meshing process.
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Adding a Solution Setup (Continued)

Options Tab

Initial Mesh OptionsInitial Mesh OptionsInitial Mesh OptionsInitial Mesh Options

Lambda RefinementLambda RefinementLambda RefinementLambda Refinement - The Initial Mesh is based only on the 3D solid 

model, it has no bearing on the electrical performance of the device 

to be simulated.  The Lambda Refinement process refines the Initial 

Mesh until most mesh element lengths are approximately one-
quarter wavelength for air and one-third wavelength for dielectrics.  

A wavelength is based on the Single Frequency value entered in the 

Solution FrequencySolution FrequencySolution FrequencySolution Frequency.  In almost all cases Lambda Refinement should 

be used.

Use Free Space LambdaUse Free Space LambdaUse Free Space LambdaUse Free Space Lambda – This will force the lambda refinement to 

target a mesh size approximately one-quarter of a wavelength for 

air.  The material properties of objects will be ignored.  This may be 

useful in applications that have dielectrics with very high 

conductivities.  Brain tissue or salt water are examples of materials 
that will produce very high mesh counts even though the RF 

penetration into the material will be limited to a region very close to 

the surface. 
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Adding a Solution Setup (Continued)

Options Tab 

Adaptive OptionsAdaptive OptionsAdaptive OptionsAdaptive Options

Refinement Per PassRefinement Per PassRefinement Per PassRefinement Per Pass -The mesh growth for each adaptive pass is 

controlled by the Refinement Per Pass.  The Refinement Per Pass is 
a percentage.  This ensures that between each pass the mesh is 

sufficiently perturbed and guarantees that you will not receive false 

convergences.

Minimum Number of PassesMinimum Number of PassesMinimum Number of PassesMinimum Number of Passes - An adaptive analysis will not stop 

unless the minimum number of passes you specify has been 
completed, even if convergence criteria have been met 

Minimum Converged PassesMinimum Converged PassesMinimum Converged PassesMinimum Converged Passes - An adaptive analysis will not stop 

unless the minimum number of converged passes you specify has 

been completed.   The convergence criteria must be met for at least 
this number of passes before the adaptive analysis will stop

Use Matrix Convergence Use Matrix Convergence Use Matrix Convergence Use Matrix Convergence ---- You can specify different stopping criteria 

for specific entries in the S-matrix. This is done by checking the Use Use Use Use 

Matrix ConvergenceMatrix ConvergenceMatrix ConvergenceMatrix Convergence box. The adaptive analysis will continue until 

the magnitude and phase of the entries change by an amount less 
than the specified criteria from one pass to the next, or until the 

number of requested passes is completed. 
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Adding a Solution Setup (Continued)

Options Tab (Continued)

Use LowUse LowUse LowUse Low----Order Solution BasisOrder Solution BasisOrder Solution BasisOrder Solution Basis – The Low Order Basis Functions reduce the 

default second-order basis function to a linear basis function.  It is intended

for simulations in which the edge to edge spacing between tetrahedron is 
electrically small.  In this situation, the basis function, and hence the 

number of unknowns, can be reduced.  For this assumption to be valid, the 

edge lengths for all tetrahedron in the model should be on the order of 

1/20th of a wavelength.  In versions prior to v10.0, this was set with a 

system environment variable called ZERO_ORDER.

Common Applications :

On-Chip Spiral Inductors, Capacitors, Transformers, etc.

Package Analysis – Flip-Chip, BGA, etc.
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Adding a Solution Setup (Continued)

Advanced Tab

Port Adapt OptionsPort Adapt OptionsPort Adapt OptionsPort Adapt Options

Port Field Accuracy - Usually, the default Port Field AccuracyPort Field AccuracyPort Field AccuracyPort Field Accuracy value 

is adequate. You may want improved port accuracy under the 
following conditions:

You are interested primarily in the port impedances. Port 

impedances are computed as part of the port solution.

You need to lower the noise floor to catch S-parameters that 

are expected to be in the -70 dB range.

Refining the mesh at the ports causes HFSS to refine the mesh for 

the entire structure as well. This occurs because it uses the port field 

solutions as boundary conditions when computing the full 3D 

solution. Therefore, specifying too small a port field accuracy can 
result in an unnecessarily complex finite element mesh
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Adding a Solution Setup (Continued)

Solution Setp (Continued)

Set Min/Max TrianglesSet Min/Max TrianglesSet Min/Max TrianglesSet Min/Max Triangles

The mesh for each model port will be adaptively refined until it

includes the minimum number of triangles. Refinement will then 
continue until the port field accuracy or the maximum number of 

triangles is reached. 

To specify the minimum and maximum number of triangles in 

the port mesh, uncheck the  Automatically Set Min/Max Automatically Set Min/Max Automatically Set Min/Max Automatically Set Min/Max 

TrianglesTrianglesTrianglesTriangles option.

Enter a value for the Minimum Number of TrianglesMinimum Number of TrianglesMinimum Number of TrianglesMinimum Number of Triangles.  The 

default value is 25 for models with lumped gap ports and 90 

for models with wave ports.

Enter a value for the Maximum Number of TrianglesMaximum Number of TrianglesMaximum Number of TrianglesMaximum Number of Triangles.  The 
default value is 400.

If you leave Automatically Set Min/Max TrianglesAutomatically Set Min/Max TrianglesAutomatically Set Min/Max TrianglesAutomatically Set Min/Max Triangles selected, HFSS 

will determine the reasonable values for the minimum and maximum

number of triangles based on the port’s setup.

Defaults Tab

The Defaults tab allows you to save the current settings as the defaults for 

future solution setups or revert the current settings to the standard setting.
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Frequency Sweeps
Using the converged mesh or initial mesh if no adaptive passes were requested, 

the swept frequency response of the device can be obtained.  Ansoft HFSS 

provides several methods for calculating the frequency response:

DiscreteDiscreteDiscreteDiscrete – performs a full solution at every frequency using the current 

mesh.  The time required is the single frequency solve times the number of 
frequency points. Fields can be displayed at any frequency within the 

sweep range if the Save Fields Box is checked.

Fast Fast Fast Fast – uses an Adaptive Lanczos-Pade Sweep(ALPS) based solver to 

extrapolate an entire bandwidth of solution information from the center 
frequency.  Very good for high-Q devices but it can not be used to solve for 

devices that pass through cut-off.  Once the band has been extrapolated, a 

high number of frequency points can be calculated without a penalty.  In 

addition, the Fields can be displayed at any frequency within the sweep 

range.  The time and memory required to solve a fast frequency sweep 
may be much larger then the single frequency solve.   

InterpolatingInterpolatingInterpolatingInterpolating – performs solves at discrete frequency points that are fit by 

interpolating.  Ansoft HFSS determines the frequency points to solve at 

based on the error in the interpolation between consecutive passes.  The 

interpolation error and maximum number of points is defined by the user in 
the Edit Sweep.  Edit Sweep.  Edit Sweep.  Edit Sweep.  As with the fast frequency sweep, the Interpolating Sweep 

can generate a larger number of frequency points.  But you only have the 

field solution for the last solved frequency. The maximum solution time is 

the single frequency solve times the maximum number of points.
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Add Sweep
After a Solution Setup has been added you can also add a Frequency Sweep.  

To do this, right-click on Setup in the HFSS Model Tree.  The Edit Sweep window 

will appear

Sweep Type
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Add Sweep (Continued)

Frequency Setup

After the sweep type has been chosen, the frequencies of interest must be 

specified.

There are three Frequency Setup Options:

Linear Step -- specify a linear range of values with a constant step size 

Linear Count -- specify a linear range of values and the number, or count, 

of points within the variable range 

Single Points -- specify a single values for the sweep definition

Saving Fields 

It is possible to save the Field data for every point in the Fast Sweep and 

the Discrete Sweep.  To save the Field information make sure that the 
Save Fields (All Frequencies) box is checked.

For the Interpolation Sweep, only the Field data for the last solved 

frequency will be available for post-processing.
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Add Sweep (Continued)

DC Extrapolation Options

When exporting Spice subcircuits it is necessary to include the DC point.  

Since Ansoft HFSS does not solve down to DC we can use DC 

Extrapolation. The DC Extrapolation option is available in the Discrete and 
Interpolating Sweeps.

Time Domain Calculation

Ansoft HFSS can calculate the maximum frequency required to obtain an 
accurate time domain result.   HFSS uses the following equation:

Max. Freq. = (0.5/Signal Rise Time) x Time Steps Per Rise Time
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Frequency Sweeps (Continued)
Adding Points to a Fast or Interpolating SweepAdding Points to a Fast or Interpolating SweepAdding Points to a Fast or Interpolating SweepAdding Points to a Fast or Interpolating Sweep

After the Fast or Interpolating sweeps have completed, additional 

frequency points can be added by changing the number of points in Edit Edit Edit Edit 

SweepSweepSweepSweep Clicking on AnalyzeAnalyzeAnalyzeAnalyze will not resolve the entire frequency sweep, it 

will just calculate the additional frequency points.

Adding Solutions to Interpolating SweepsAdding Solutions to Interpolating SweepsAdding Solutions to Interpolating SweepsAdding Solutions to Interpolating Sweeps

If the interpolating sweep does not converge with the requested passes or 

you wish to change the target convergence, the values can be changed 

and resolved.  The interpolating sweep will recalculate the two end 
frequencies but after that it will use the previously calculated points and 

continue trying to reach the target convergence.

Ports Only and Frequency SweepsPorts Only and Frequency SweepsPorts Only and Frequency SweepsPorts Only and Frequency Sweeps

A discrete or interpolating frequency sweep can be used with the Ports 
Only solution.

Fast Frequency Sweep Ports SolveFast Frequency Sweep Ports SolveFast Frequency Sweep Ports SolveFast Frequency Sweep Ports Solve

The Fast Frequency sweep can not be used on ports that pass through cut-

off.  You may also experience problems if the sweep frequency approaches 

cut-off.

Combining Multiple Frequency SweepsCombining Multiple Frequency SweepsCombining Multiple Frequency SweepsCombining Multiple Frequency Sweeps

For very large bandwidths, breaking the band into smaller frequency 

sweeps can improve the results.  Since the Fast Frequency Sweep is 

extrapolated from the center frequency different error curves at the end 
frequencies will prevent the sweeps from aligning.  The interpolating sweep 

will not have this problem since the solution always passes through the end 

frequencies (Assuming the same mesh is used).
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Enhancements and New Features
Mesh Re-use

Copy geometric equivalent meshes – For optimetrics analysis setups you 

can request HFSS to copy a mesh that was calculated for one sweep 

variation for reuse on a geometrically-equivalent sweep variation. 

Initial Mesh Options

Use mesh from current design – enables the use of a 

mesh from a previous setup. 

Use mesh from other project – enables the use of a

mesh from another model that has the same geometry 
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Enhancements and New Features

Matrix Convergence Options – allows the ability to define other convergence 

criteria

Output Variable Convergence – Allows the creation of an output variable to 
be used for the convergence criteria. In order to use this, an output variable 

expression has to be created, then this field will become active
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Ansoft HFSS Data Reporting

Overview
Ansoft HFSS has very powerful and flexible data management and plotting 

capabilities. Once understood, it will make the whole solution process much 

easier, and will help craft the entire problem setup.

Topics of Discussion
Data management

2D Plotting

3D Plotting

Antenna characteristics

Field Plotting



Ansoft High Frequency Structure Simulator v10 User’s Guide 

3

3-2

Ansoft HFSS Data Reporting

Data Management
With every model variation that is solved, a new data entry is stored within the 

project results directory. This capability has implications in that the user can 

perform a parametric sweep of a model without needing an Optimetrics license.

NOTE: Automatic parametric sweeps along with the other Optimetrics 

functions, Optimization, Sensitivity, and Statistical analyses, DO require an 
Optimetrics license.

The dataset validity can be checked by selecting HFSS > Results > Browse HFSS > Results > Browse HFSS > Results > Browse HFSS > Results > Browse 
SolutionsSolutionsSolutionsSolutions

By examining this dialog, the user can determine which parametric instances 

have been solved, and how many adaptive passes were necessary.
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Ansoft HFSS Data Reporting

Data Management
Post-processing steps can also be performed in the new interface for HFSS. The 

common operations that were previously performed in the Matrix Data module of 

previous releases are:

Port Impedance RenormalizationPort Impedance RenormalizationPort Impedance RenormalizationPort Impedance Renormalization

Port DePort DePort DePort De----embeddingembeddingembeddingembedding

Differential pair analysesDifferential pair analysesDifferential pair analysesDifferential pair analyses

Other post-processing operations that used to require the Matrix Data module 

that are now computed by default in HFSS version 9.0 are the YYYY---- and Zand Zand Zand Z----matricesmatricesmatricesmatrices. 

Also, given that the Solution TypeSolution TypeSolution TypeSolution Type defined early on in the process, negate the 
necessity of computing Terminal S-parameters from Modal S-parameters.

Port Impedance RenormalizationPort Impedance RenormalizationPort Impedance RenormalizationPort Impedance Renormalization

Within the new interface, many calculations are made automatically without 
user intervention. The wave port renormalization impedances are specified 

with the port wizard. By simply editing the properties of a port once a 

solution is completed, the port can be re-normalized.

Port DePort DePort DePort De----embeddingembeddingembeddingembedding

This same dialog can be used to change the distance that a port will be de-

embedded. The user can go back and edit this value as many times as 

necessary. Each time the OK button is pressed, the data, and also the plots 

if they exist, will be updated with the newly de-embedded data.

Positive values of  de-embedding will move the reference plane into the 
model
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Ansoft HFSS Data Reporting

Data Management
Differential pair analysesDifferential pair analysesDifferential pair analysesDifferential pair analyses

For multiple terminals per port, differential pairs can be created to look at 

differential S-parameters instead of single-ended S-parameters. This can 

be useful for investigating the possible conversion between differential and 

common mode within a given structure.

Within the wave port dialog, the Differential Pairs tab controls the creation 

of the pairs from the individual Terminals

1. To create a differential pair, select New PairNew PairNew PairNew Pair, and select the terminal 

lines that represent the positive and negative sides 

2. From here, you can also change the DifferentialDifferentialDifferentialDifferential and CommonCommonCommonCommon mode 

impedance setting for each pair.
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Ansoft HFSS Data Reporting

Data Management
Importing Data from other solutionsImporting Data from other solutionsImporting Data from other solutionsImporting Data from other solutions

Often it is desirable to compare the results of one simulation to the results 

of another simulation, HFSS, circuit, or planar, or even measurements. 

This can be accomplished readily within the HFSS version 9.0 desktop 

environment.

To import solutions into HFSS Desktop:To import solutions into HFSS Desktop:To import solutions into HFSS Desktop:To import solutions into HFSS Desktop:

NOTE: The minimum requirements for importing a solution are an 

existing model with at least one port.

1. Select HFSS > Results > Import SolutionsHFSS > Results > Import SolutionsHFSS > Results > Import SolutionsHFSS > Results > Import Solutions, and the following dialog 
will appear:

The import options are Import SolutionsImport SolutionsImport SolutionsImport Solutions and Import TableImport TableImport TableImport Table. 

Solutions represent S-parameter matrices in standard forms 
such as Touchstone and Ansoft legacy data in .szg file 

format. Tables are simply files containing rows and columns 

of data.

2. Selecting Import SolutionImport SolutionImport SolutionImport Solution will bring up the following dialog:
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Ansoft HFSS Data Reporting

Data Management
3. From this window, select BrowseBrowseBrowseBrowse to find the file to be imported. The 

acceptable file formats are: .sNp, .szg, .flp, .yNp, .zNp, and .tou.

4. Click OpenOpenOpenOpen to load the file.

5. Click ImportImportImportImport to bring the data into the HFSS desktop

6. Click OKOKOKOK when you are done importing solutions

All solutions will appear in the report editor under the SweepSweepSweepSweep category 

(more on this later)

For Import Table, the following dialog will appear:
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Ansoft HFSS Data Reporting

Plotting Data
Data plotting can take a variety of forms. The most often used format is 2D 

Cartesian plotting, but we also have the capability to plot in 3D as well. Below is a 

list of all the quantities that can be plotted on various graphs. For definitions of 

each of these quantities, see the online help.

Eigenmode solutionEigenmode solutionEigenmode solutionEigenmode solution

Eigenmode Parameters (modes)

Driven Modal SolutionDriven Modal SolutionDriven Modal SolutionDriven Modal Solution

S-parameters

Y-parameters

Z-parameters

VSWR

Gamma (complex propagation constant)

Port Zo

Driven Terminal SolutionDriven Terminal SolutionDriven Terminal SolutionDriven Terminal Solution

S-parameters

Y-parameters

Z-parameters

VSWR

Power (at port)

Voltage Transform matrix (T)

Terminal Port Zo

FieldsFieldsFieldsFields

Mag_E

Mag_H

Mag_Jvol

Mag_Jsurf

ComplexMag_E

ComplexMag_H

ComplexMag_Jvol

ComplexMag_Jsurf

Local_SAR (Specific Absorption Rate)

Average_SAR

NOTENOTENOTENOTE: For all Field plots, a polyline or surface must be selected before 
creating the Field plot.
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Ansoft HFSS Data Reporting

Plotting Data
Types of Plots:Types of Plots:Types of Plots:Types of Plots:

Rectangular Plot

Polar Plot

3D Rectangular Plot

3D Polar Plot

Smith Chart

Data Table

Radiation Pattern

To Create a Plot:To Create a Plot:To Create a Plot:To Create a Plot:

1. Select HFSS > Results > Create Report

2. Select Report Type and Display Type from the selections above

3. Click OK and the Report Editor will be displayed – we will go over the 
options in this dialog on the next page.
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Ansoft HFSS Data Reporting

Plotting Data
Creating a PlotCreating a PlotCreating a PlotCreating a Plot (cont’d)

4.4.4.4. ContextContextContextContext

DesignDesignDesignDesign – choose from available designs within a project

SweepSweepSweepSweep – choose from available sweeps including adaptive passes 
and imported data

DomainDomainDomainDomain – defaults to Sweep, but can be switched to Time domain for 

plotting S-parameters with an impulse or step response.

5.5.5.5. Sweep / X / Y TabsSweep / X / Y TabsSweep / X / Y TabsSweep / X / Y Tabs

Sweep Sweep Sweep Sweep – controls the source of the independent variable in the plot.

NOTE:NOTE:NOTE:NOTE: By default, the Report editor selects Use Current Use Current Use Current Use Current 

Design and Project variable valuesDesign and Project variable valuesDesign and Project variable valuesDesign and Project variable values. This will select the 

primary sweep of frequency usually, and the current 

simulated values of the project variables

To display a plot with multiple traces for different variable 

values, change this setting to Sweep Design and Project Sweep Design and Project Sweep Design and Project Sweep Design and Project 

variable values variable values variable values variable values You can then change the primary sweep from 

frequency to a variable if desired. This is useful for looking at 

S21 versus stub length, for example. Simply select the value 
in the Name Name Name Name column next to primary sweepprimary sweepprimary sweepprimary sweep, and change the 

value to whatever you desire.

You can also uncheck the All PointsAll PointsAll PointsAll Points block to select which 

values of a variable are to be plotted.

XXXX – controls any functional operator on the independent variable

YYYY – select the value to be plotted and any operator

6. Select Add TraceAdd TraceAdd TraceAdd Trace for as many values as you would like to plot

7. Select DoneDoneDoneDone when finished

An example of a multi-trace plot of the sweep tab shown on the previous page is 

shown next
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Ansoft HFSS Data Reporting

Plotting Data
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Ansoft HFSS Data Reporting

Plotting Data
3D Plots – simply add a third dimension such that instead of plotting a family of 

curves, you can plot a 3D surface that represents your data changing with two 

independent variables. Below is a 3D plot of the previous family of curves.
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Ansoft HFSS Data Plotting

Plotting Data
Output VariablesOutput VariablesOutput VariablesOutput Variables

In addition to being able to plot the built-in solved quantities, you can also 

create your own by using output variables.

Clicking on the Output Variables button in the Traces dialog shown before, 
brings up the following dialog:

To create an output variable:To create an output variable:To create an output variable:To create an output variable:

Type a name into the NameNameNameName box

Create an equation in the ExpressionExpressionExpressionExpression box

Click AddAddAddAdd

In the example show above, we have created an output variable that makes 

an approximation for Inductance of a spiral inductor. We could also have 

created an equation to calculate Q as well.

NOTENOTENOTENOTE: These output variables can also be used for optimization.
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Ansoft HFSS – Data Reporting

Data Plotting – Special Case – Antenna Parameters
Since antenna parameters require a special computation setup to determine the 

region over which the fields are to be computed, displaying antenna parameters 

is a two step process.

Create an Infinite Sphere setup:

1. Select HFSS > Radiation > Insert Far Field Setup > Infinite SphereHFSS > Radiation > Insert Far Field Setup > Infinite SphereHFSS > Radiation > Insert Far Field Setup > Infinite SphereHFSS > Radiation > Insert Far Field Setup > Infinite Sphere

2. Enter the values and steps for ThetaThetaThetaTheta and PhiPhiPhiPhi

3. You can also change the coordinate system to calculate based upon a 

shifted or rotated coordinate system. Select the Coordinate SystemCoordinate SystemCoordinate SystemCoordinate System tab, 
and switch to the new CS.

4. You can also change the Radiation Surface over which the far fields are 

computed by simply switching to the Radiation SurfaceRadiation SurfaceRadiation SurfaceRadiation Surface tab, and select a 

new surface from any that were previously defined.

5. Click OKOKOKOK
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Data Plotting – Antenna Parameters
Creating a 2D plot:Creating a 2D plot:Creating a 2D plot:Creating a 2D plot:

1. Select HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Select Far FieldFar FieldFar FieldFar Field form the Report TypeReport TypeReport TypeReport Type pulldown

3. Select Radiation PatternRadiation PatternRadiation PatternRadiation Pattern from the Display TypeDisplay TypeDisplay TypeDisplay Type pulldown

4. Select the quantity to be plotted from the TracesTracesTracesTraces dialog

Note: If multiple Infinite Sphere setups exist, make sure you select 

the appropriate one

5. Select Add TraceAdd TraceAdd TraceAdd Trace and DoneDoneDoneDone

For a definition of the available antenna parameters, see the online help

Below is an example of the 2D slices of a patch antenna for LHCP and RHCP 

directivity.
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Data Plotting – Antenna Parameters
Creating a 3D Plot:Creating a 3D Plot:Creating a 3D Plot:Creating a 3D Plot:

Follow the procedures above for the 3D plot, except change the Phi Phi Phi Phi and 

ThetaThetaThetaTheta quantities to match the far field calculation. Also choose an antenna 

quantity to plot.

Below is an example of a 3D plot for a patch antenna:
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Data Plotting – Antenna Parameters
Special Case – Antenna Arrays

When using master and slave boundary condition pairs to emulate an 

antenna array, you might want to apply an array factor to the computation 

of the antenna patterns. This can easily be done in Ansoft HFSS

To create an Antenna Array Factor calculation:To create an Antenna Array Factor calculation:To create an Antenna Array Factor calculation:To create an Antenna Array Factor calculation:

1. Select HFSS > Radiation > Antenna Array SetupHFSS > Radiation > Antenna Array SetupHFSS > Radiation > Antenna Array SetupHFSS > Radiation > Antenna Array Setup

2. Select NoNoNoNo, RegularRegularRegularRegular, or Custom ArrayCustom ArrayCustom ArrayCustom Array

3. Switch to the next tab, and enter the characteristics of the array, or 

enter the filename that contains the element locations

4. Once you click OK, any plots or calculations that are displayed will 

be updated with the array factor calculation. To go back to the single 

element calculations, select No Array SetupNo Array SetupNo Array SetupNo Array Setup
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Data Plotting – Antenna Parameters
Antenna array – Shown below are field patterns of a single element and an array

setup scanned to 30 degree angle.
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Data Manipulation
Sometimes, the built-in calculated quantities are not adequate even given the 

output variable capability. Because of this, Ansoft HFSS has the flexibility built in 

with an arbitrary fields calculator.

You can use the Fields Calculator to manipulate field quantities to obtain any 

number of values. One common use is to evaluate power flow within a structure. 
This can be accomplished by integrating the Poynting vector over a geometric 

surface. This can easily be accomplished within the field calculator.

To access the fields calculator:To access the fields calculator:To access the fields calculator:To access the fields calculator:

Select HFSS  > Fields > CalculatorHFSS  > Fields > CalculatorHFSS  > Fields > CalculatorHFSS  > Fields > Calculator

For a more detailed explanation of the functions within the field calculator, visit 

our online technical support at http://www.ansoft.com.ots
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Field Overlay Plotting
Previously mentioned was the capability to plot field quantities over a geometry 

within a 2D plot, but this doesn’t give us a lot of insight. One of the main benefits 

of HFSS is that we can visualize what is going on with the electromagnetic fields 

within a structure, something that cannot be measured directly.

Field plots can be applied to geometry selection within the 3D modeler, and can 
be modified given different stimulus amplitude, frequency, and phase. We can 

also visualize how a field propagates throughout the volume by animating this 

plot versus phase, which essentially adds a time base.

To create a 2D / 3D Field Overlay Plot:To create a 2D / 3D Field Overlay Plot:To create a 2D / 3D Field Overlay Plot:To create a 2D / 3D Field Overlay Plot:

1. Select a face of an object, an entire object, or even multiple object

2. Select HFSS > Fields > Plot Fields >HFSS > Fields > Plot Fields >HFSS > Fields > Plot Fields >HFSS > Fields > Plot Fields >

3. You can then change the frequency of the stimulus or phase with the 

resultant dialog box:



Ansoft High Frequency Structure Simulator v10 User’s Guide 

3

3-20

Ansoft HFSS Data Reporting

Field Overlay Plots
Resultant modeler window for Magic “T” model with Mag_E plotted on Global:XY 

plane

Selecting the object “arm”, and plotting within the volume yields:
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Field Overlay Plots
The 3D plot shown on the previous page is called an Isoval surface plot. This is 

not the default

To change the field plot type:To change the field plot type:To change the field plot type:To change the field plot type:

1. Selecting: HFSS > Fields > Modify Plot AttributesHFSS > Fields > Modify Plot AttributesHFSS > Fields > Modify Plot AttributesHFSS > Fields > Modify Plot Attributes

2. Switch to the PlotPlotPlotPlot tab

3. Select the applicable PlotPlotPlotPlot from the pulldown

4. Select the IsoValSurfaceIsoValSurfaceIsoValSurfaceIsoValSurface radio button

You can also leave the default of cloud plotcloud plotcloud plotcloud plot and adjust the cloud cloud cloud cloud 
densitydensitydensitydensity and point sizepoint sizepoint sizepoint size until the plot looks acceptable
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Field Overlay plots – Source Stimulus
Sometimes it might be desirable to have multiple ports excited at the same time, 

perhaps out of phase. This is useful for evaluating power combiners. You might 

even want need to calculate the incident or reflected power for a plane wave 

source.

To change the Field Plot stimulus:To change the Field Plot stimulus:To change the Field Plot stimulus:To change the Field Plot stimulus:

Select HFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit Sources

The following field d overlay plots shows what happens to the Magic “T” 

when we have a 90 degree phase shift at  the 2  E-plane end inputs. The 

component doesn’t isolate one port.
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Field Overlay Plot – Phase animation
The final step in field overlay plots is creating animation. This essentially shows 

you how a wave propagates through the structure as you vary phase (time).

To create an animated 3D field plot:To create an animated 3D field plot:To create an animated 3D field plot:To create an animated 3D field plot:

1. Select HFSS > Field > AnimateHFSS > Field > AnimateHFSS > Field > AnimateHFSS > Field > Animate

2. Typically, you can accept the defaults, but you may want to change the 

number of steps to limit computation time.
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Mesh Overlay Plot
Another plot that can be valuable in evaluating a simulation is the mesh overlay 

plot. Once created, you can tell which areas of the structure may need more 

tetrahedra for an improved quality of mesh.

To create a Mesh overlay plot:To create a Mesh overlay plot:To create a Mesh overlay plot:To create a Mesh overlay plot:

1. Select the face, plane, or object to plot the mesh

2. Select HFSS > Fields > Plot MeshHFSS > Fields > Plot MeshHFSS > Fields > Plot MeshHFSS > Fields > Plot Mesh
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Viewing in the 3D modeler
With the ability to plot field quantities and mesh within the 3D modeler, it can 

sometimes get crowded, and model details can be obscured by the plots. You 

can reduce the clutter by turning off the visibility of objects and even field plots.

To turn off the visibility of field overlay plots:To turn off the visibility of field overlay plots:To turn off the visibility of field overlay plots:To turn off the visibility of field overlay plots:

1. Select View > Visibility

2. Select the Fields ReporterFields ReporterFields ReporterFields Reporter tab, and check, �, or uncheck, ����,,,, the fields plot 

you want displayed.
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Solve Loop
Unlike pre-processing, the solution process is very automated.  Once the 
problem has been defined properly, HFSS will take over and step through several 
stages of the solution process.  To start the solution process, right click on 
AnalysisAnalysisAnalysisAnalysis in the HFSS Model Tree and select AnalyzeAnalyzeAnalyzeAnalyze.  

It is important to review this section since the solution setup has a direct impact 
on the automated solution process.  A closer look at the solution process reveals 
it consists of three components:

Initial Solution – includes the mesh generation, ports solution, and a full 
solution at a single frequency

Adaptive Refinement Loop – refines the mesh and performs a full solution at 
the Initial solution frequency until convergence

Frequency Sweep – calculates the swept frequency response using a mesh 
generated by the Adaptive Refinement Loop

Mesh ReMesh ReMesh ReMesh Re----useuseuseuse

Copy geometric equivalent meshes – For optimetrics analysis setups you 
can request HFSS to copy a mesh that was calculated for one sweep 
variation for reuse on a geometrically-equivalent sweep variation. 

Initial Mesh Options

Use mesh from current design – enables the use of a 

mesh from a previous setup. 

Use mesh from other project – enables the use of a

mesh from another model that has the same geometry

The illustration on the following page outlines the steps performed by the solution 
process.
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Initial MeshInitial MeshInitial MeshInitial Mesh
Seeding andSeeding andSeeding andSeeding and

Lambda RefinementLambda RefinementLambda RefinementLambda Refinement
(Single Frequency)(Single Frequency)(Single Frequency)(Single Frequency)

Port SolutionPort SolutionPort SolutionPort Solution

Full Volumetric SolutionFull Volumetric SolutionFull Volumetric SolutionFull Volumetric Solution
(S(S(S(S----Parameters/EParameters/EParameters/EParameters/E----Fields)Fields)Fields)Fields)

Frequency SweepFrequency SweepFrequency SweepFrequency Sweep

Refine Mesh Refine Mesh Refine Mesh Refine Mesh 
(Gradient of E(Gradient of E(Gradient of E(Gradient of E----Field Field Field Field 
at Single Frequency)at Single Frequency)at Single Frequency)at Single Frequency)

Full Volumetric SolutionFull Volumetric SolutionFull Volumetric SolutionFull Volumetric Solution
(S(S(S(S----Parameters/EParameters/EParameters/EParameters/E----Fields)Fields)Fields)Fields)

Check ConvergenceCheck ConvergenceCheck ConvergenceCheck Convergence
(Delta S)(Delta S)(Delta S)(Delta S)

NoNoNoNo

YESYESYESYES

Initial Solution

Adaptive Mesh Loop

No Adaptive MeshingNo Adaptive MeshingNo Adaptive MeshingNo Adaptive Meshing

Ports Only &Ports Only &Ports Only &Ports Only &

Frequency SweepFrequency SweepFrequency SweepFrequency Sweep
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Improved Analysis Configuration

Configurable default execution priority

To set this option, go to Tools > Tools > Tools > Tools > 

Options > HFSS Options > SolverOptions > HFSS Options > SolverOptions > HFSS Options > SolverOptions > HFSS Options > Solver

Remote Analysis

heterogeneous platform support

Queuing

Queue Projects, Designs, Parametric Sweeps, Frequency Sweeps

To enable this feature, go to Tools > Options > General Options > Analysis Tools > Options > General Options > Analysis Tools > Options > General Options > Analysis Tools > Options > General Options > Analysis 
Options > Options > Options > Options > QueQueQueQue all Simulationsall Simulationsall Simulationsall Simulations

To view queued projects, go to Tools > Show Queued SimulationsTools > Show Queued SimulationsTools > Show Queued SimulationsTools > Show Queued Simulations
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Distributed Analysis
10X Analysis Speed-Up

An automated client-server implementation

little/no overhead

setup easily via remote analysis capability

For Optimetrics instances and partitioned frequency sweeps

An optional license to augment

10 “dependent analyses”
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Monitoring Convergence
You can view the Convergence of the entire solution process.  Right click on 

Analysis/SetupAnalysis/SetupAnalysis/SetupAnalysis/Setup in the HFSS model tree.  The Convergence TabConvergence TabConvergence TabConvergence Tab can be used to 

display a table or a  plot.  

Matrix Convergence Options – allows the ability to define other 
convergence criteria

All – default

Diagonal

Off-Diagonal

Selected Entries
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Profile
At any time during or after the solution process, you can examine the computing 

resources - or profile data - that were used by HFSS during the analysis. The 

profile data is essentially a log of the tasks performed by HFSS during the 

solution. The log indicates the length of time each task took and how much 

RAM/disk memory was required

Task -- lists the software module that performed a task during the solution 
process, and the type of task that was performed. For example, for the task 

mesh3d_adapt, Mesh3d is the software module that adaptively refined the mesh.

Real Time -- the amount of real time required to perform the task.

CPU Time -- the amount of CPU time required to perform the task.

Memory -- the peak amount of memory used by your machine while performing 

the task. This value includes all of the applications running at the time; it is not 

limited to HFSS..

Information -------- general information about the solution, including the number of 

tetrahedra used in the mesh.
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Matrix Data
After the Solution is complete the Matrix Data can be viewed by clicking on 

Analysis/Setup.  Right click on Setup Setup Setup Setup and select Matrix DataMatrix DataMatrix DataMatrix Data.  The Solution DataSolution DataSolution DataSolution Data

window will appear.

In the Simulation pull-down list, click the solution setup and solved pass -

adaptive, single frequency solution, or frequency sweep - for which you want to 

view matrices.

Select the type of matrix to view.  

S-matrix

Y-matrix 

Z-matrix

Gamma

Zo (characteristic impedance.)

The available types depend on the solution type
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Matrix Data (cont.)
Data can be displayed in the following formats:

Magnitude/ Phase

Real/ Imaginary 

dB/ Phase 

Magnitude

Phase 

Real 

Imaginary

dB 

The available formats depend on the matrix type being displayed.

You can also select solved frequencies that you would like to display

To display the matrix entries for all solved frequencies, choose All All All All FreqsFreqsFreqsFreqs.

To show the matrix entries for one solved frequency, clear All Frequencies 
and then select the solved frequency that you want to view. 

For adaptive passes, only the solution frequency specified in the Solution 
Setup dialog box is available. For frequency sweeps, the entire frequency 
range is available.

To insert of delete one or more displayed frequencies, click Edit Edit Edit Edit FreqsFreqsFreqsFreqs. 

This command is only available if the sweep type is Fast or Interpolating. If you 
choose to export the matrix data for the Fast or Interpolating sweep after 
modifying the frequencies in the Edit Frequencies dialog box, only those 
frequencies displayed under the Matrix Data tab will be exported.

Exporting Matrix Data
A number of export formats are available:

Touchstone (*.sNp)

Data Table (*.tab)

Planar EM/HFSS v6+ (*.szg)

Neutral Model Format (*.nmf)

MATLAB (*.m)

Citifile (*.cit)
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Equivalent Circuit Export
It is possible to export Full-Wave Spice, Lumped Element and Partial Fraction 

Expansion models from Ansoft HFSS.  To do this, click on Analysis/Setup/Matrix Analysis/Setup/Matrix Analysis/Setup/Matrix Analysis/Setup/Matrix 

Data/Equivalent Circuit ExportData/Equivalent Circuit ExportData/Equivalent Circuit ExportData/Equivalent Circuit Export.

The Equivalent Circuit Export Options window will appear
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If you have a Driven Terminal solution you can export  to PSpicePSpicePSpicePSpice, HSPICE, , HSPICE, , HSPICE, , HSPICE, 

Spectre, or Maxwell SpiceSpectre, or Maxwell SpiceSpectre, or Maxwell SpiceSpectre, or Maxwell Spice. You must have a frequency sweep solution and five 

or more frequency points to successfully export an equivalent circuit data file. 

Select Lumped Element Export (Low Bandwidth)Lumped Element Export (Low Bandwidth)Lumped Element Export (Low Bandwidth)Lumped Element Export (Low Bandwidth) if you want to save the data as 

a low-frequency circuit model using simple lumped elements (resistors,

capacitors, inductors, and dependent current sources).

Select Partial Fraction Expansion for Partial Fraction Expansion for Partial Fraction Expansion for Partial Fraction Expansion for MatlabMatlabMatlabMatlab to create a *.m file

Click Combine SweepsCombine SweepsCombine SweepsCombine Sweeps if you want to combine the data from two or more 

frequency sweeps into one file. The end points of the sweep ranges can touch, 

but may not overlap.

The S-matrices are written to the data file that you specified in the equivalent 

circuit data format.
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List
To view Model Parameters, Boundaries, Excitations, Mesh Operations and 

Analysis Setup right click on AnalysisAnalysisAnalysisAnalysis in the Ansoft HFSS model tree and select 

ListListListList
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Mesh Operations
This chapter provides details on meshing in the Ansoft HFSS v.10.0 software.   It 

discusses the default meshing of curvature, user control thereof, and the new 

volume correctionvolume correctionvolume correctionvolume correction capabilities used in matrix solution.  The following topics are

discussed:

Curved Geometry Mesh Adaptation

Faceting Default Settings

Volume Perturbation in FEM Solutions

User-Defining Surface Approximations

Application Recommendations

Model Resolution

Applying Mesh Operations

Examples/BenchmarksExamples/BenchmarksExamples/BenchmarksExamples/Benchmarks

The following examples are provided to demonstrate the topics discussed 
in the chapter:

Standard Pillbox Resonator

Hemispherical Dielectric Resonator Antenna with Cavity

Accelerator Spoke-Cavity Application

Circular WG Quadrature Ortho-mode Junction (OMJ)
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Curve Mesh Adaptation in HFSS v10.0
HFSS v10.0 meshes handles curved surfaces differently than prior versions of 

HFSS.  Proper understanding of the differences in curved mesh handling and the 
advantages of new capabilities in the HFSS v10.0 solver are essential to 

obtaining accurate results.  

The new graphical drawing interface encourages the use of true-curved 

drawing, by removing the option to assign a facet count to the construction 
of primitives such as circles, cylinders, spheres, and ellipses.

Faceted primitives are available however as polyhedrons and 

polyhedral solids, if still desired.

Initial meshing is constrained by faceting decisions made by the first pass 

of the meshing algorithms.  In prior versions of HFSS however, adaptive 
mesh points could be placed ‘anywhere’ on the true-surface of the affected 

object(s), as shown in the before and after images below. (Initial mesh left, 

adapted at right.  Note that regular faceting was not maintained after 

adaptive mesh alteration.)

For HFSS v10.0, however, in order to provide more robust meshing with 
respect to more complex geometries, the initial faceting selections made 

for curved objects are respected throughout the adaptation process, so that 

the adapted mesh is a subdivided variation of the same meshed volume as 
the initial mesh.  An adapted mesh from HFSS v10.0 is shown below.
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Faceter Default Settings
In order to keep initial meshes at reasonable sizes, the initial faceting default 
setting is to constrain the mesh surface normals to fall within 30degrees30degrees30degrees30degrees of the 
true-curved surface normals.

This means that a cylindrical surface would be ‘faceted’ into 16 segments 
about its circumference, as illustrated below.

The normal for each flat segment cannot be off by more than 30 degrees 
from the normal for the curved true surface which that segment’s face is 
approximating.

Although aided by the Volume PerturbationVolume PerturbationVolume PerturbationVolume Perturbation technique now used in HFSS 
v10.0, it is not anticipated that this default faceting will be ‘enough’ for 
extremely high-accuracy analysis of resonant cavity volumes, spheroids, 
etc. 

The faceting default does not include a stringent aspect ratio default (note 
long triangles on top and bottom cylindrical faces).

The default however is sufficient for most applications in which the curved 
geometry is not itself highly critical to the simulation result, yet where more 
faceting would result in an extremely large initial mesh

E.g. Applicable for:

…meshing of transmission line models with both signal and non-
signal vias present to prevent parallel-plate modes in stripline or 
CPW configurations

…Coaxial applications, where both the inner and outer radius faceting 
maintains an effectively congruent distance for characteristic 
impedance results.

…cylinders or spheres used as radiation boundaries.

Less Applicable for:

….cylindrical cavity resonances to 0.001% frequency accuracy

…elliptical waveguide coupling irises

…circular waveguides
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Introduction of Volume Perturbation to HFSS Solutions
Despite lower faceting ‘compliance’ to the true-curved geometry as the 

adaptation process adds mesh points, HFSS v10.0 introduces a new solution 

technology that should result in a more accurate solution from far smaller mesh 

counts than in prior versions.  This technology is referred to as Volume Volume Volume Volume 

Perturbation Perturbation Perturbation Perturbation or Volume CorrectionVolume CorrectionVolume CorrectionVolume Correction....

In a faceted mesh of a cylindrical solid, small arc-section volumes are ‘lost’ 

to the cylinder volume and become part of the volume of the cylinder’s 

surroundings.

Since the true geometry definition is known before faceting, the delta-
volumes represented by each of these sliver regions is computable

The meshing algorithm in HFSS v10.0 can provide ‘adjustment factors’ to 

both the tetrahedral center-edge node locations and to the appropriate 

volumes of the tetrahedra on either side of the curved boundary, so that the 

FEM solution proceeds with the right terms even for a loosely-discretized 
mesh

The end result is higher accuracy from the same mesh, even before the 

benefits of adaptive mesh refinement are taken into account.

Volume Perturbation solutions are always on.  No user setting is required to 
active them.

Sliver Region (only top surface 
mesh outline shown)
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User Control of Curved Mesh Faceting
Since Volume Perturbation alone is not always enough, users can control the 
fidelity to which the initial mesh faceting conforms to geometric curvature by 
assigning Mesh Operation Surface Approximations to appropriate objects and/or 
object faces

Mesh Operations can be assigned from the HFSSHFSSHFSSHFSS menu, from the Design Design Design Design 
TreeTreeTreeTree, or from the geometry interface’s context-sensitive menu.

The Surface Approximation options are shown below right.  Definitions 
follow:

Surface Deviation is the maximum spacing,
in drawing units, that the tetrahedral surfaces
may be from the true-curved geometry’s
surface.

Normal Deviation is the maximum angular
difference, in degrees, that a tetrahedral
face’s normal can have from the surface 
normal for the true geometry which it is 
meant to represent.

Aspect Ratio refers to the maximum allowed
aspect ratio of all faces of all tetrahedra of
the selected object or face.  This setting 
influences mesh quality rather than actual
meshed volume or surface locations.
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Each Setting can be forced, left at the default, or turned off entirely

Ignore means no evaluation of this
constraint will be done in generation of 
the initial meshing, not even to the 

“built-in” settings HFSS follows without

surface approximation instructions

Use Defaults leaves that constraint at the
built-in settings, and is selected if you do

not wish to tighten this constraint but also

do not wish to deactivate it.

Set… is of course used to apply a user
constraint value which may be tighter orororor
looser than the built-in constraint used

in the absence of specific instructions.

Setting looser constraints than the

default may require also setting

adjoining objects to the same
looser constraint so that the 

default does not take precedence

at interfaces.

Usage Suggestions
Do not Do not Do not Do not overspecifyoverspecifyoverspecifyoverspecify....

It is always easier to ‘add’ than subtract mesh, by running more adaptive 

passes or by adding supplemental mesh instructions

Too stringent a setting (e.g. Normal Deviation of 1 degree) can result in 
poor mesh qualities due to aspect ratios, poor mesh gradients to

surrounding objects, etc.

Use Aspect Ratio settings along with Normal or Surface Deviation settings

For cylindrical type objects where curved and planar faces meet, the 

normal and surface deviation settings apply to the curved faces only.  
Setting an aspect ratio limit as well (e.g. 4:1) will force a few additional 

triangles on the planar faces and help preserve a cleaner overall mesh

Consider using Polyhedrons or Polygons instead if using to ‘reduce’ mesh

If your design has many curved objects which you want only very coarsely 
meshed (e.g. a whole fence of ground vias, for which 30 degree default 

normal deviation is unnecessary), and the geometry is not imported, 

consider drawing the vias as hexagonal or even square solids instead, 

rather than having to ‘remember’ to reduce the meshing fidelity on them all.
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Model Resolution
Model resolution enables model convergence and reduce solve times. If in 

previous versions the tetrahedron count got too large, the solver could run out of 

memory. It would be trying to add meshing elements to areas of the model that 

are not important. Now with model resolution, we are able to crank down the 

mesh size in order to actually get convergence before memory becomes an 
issue. 

Model resolution is a length based value that modifies the initial mesh. This 

meshing operation allows the user to specify a minimum edge length of any 

tetrahedron used for the mesh. By specifying a minimum edge length for a 
tetrahedron, the mesher will have to coarsely mesh geometric detail that may not 

be electrically important. This saves the solver a tremendous amount of solution 

time since the initial mesh is smaller, and the mesher does not have to add mesh 

elements to areas that are not electrically important.

When dealing with models that have very high aspect ratios due to small 
geometric detail, use a model resolution of 1/10 to 1/20 of the thinnest conductor 

to start with. Then adjust the value accordingly.

A Complex ConnectorA Complex ConnectorA Complex ConnectorA Complex Connector

Enabled Convergence
(previously unsolvable)

one half the mesh

two thirds the memory

one third the time
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Model Resolution Con’t
Practical Example

This is part of a complex design that benefited from model resolution. The 

grey outline is the reduced model. The pink lines were the original model 

details that were removed due to the mesh operation. The original model 

had an initial mesh of 184,675 tets. After model resolution, the initial mesh 
was 24,691 tets.
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Applying Mesh Operations
If you want to refine the mesh on a face or volume but don’t want to generate a 

solution, do the following after defining mesh operations:

If a current mesh has been generated, HFSS will refine it using the defined 

mesh operations.

If a current mesh has not been generated, HFSS will apply the mesh 

operations to the initial mesh. 

If an initial mesh has not been generated, HFSS will generate it and apply 

the mesh operations to the initial mesh. 

If the defined mesh operations have been applied to the selected face or 
object, the current mesh will not be altered.

Define a new mesh operation rather than modify an existing mesh 

operation. HFSS will not re-apply a modified mesh operation. Applying 

mesh operations without solving enables you to experiment with mesh 
refinement in specific problem regions without losing design solutions. You 

cannot undo the applied mesh operations, but you can discard them by 

closing the project without saving them.
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Source:  (Canonical)

Description
A pillbox resonator is a simple cylindrical cavity, the exact resonance of which is 

solved analytically as:

Equations for TE and TM modes of order (n, m, p) where p is the 
number of half-wave variations in the cavity axis direction

pnm and qnm represent the zeros of the Bessel functions or their 
derivatives

b is cavity radius, and l is cavity height

cε is the speed of light in the enclosed volume media

Benchmark
A pillbox project with b = 10 cm and l = 10 cm was constructed.

Volume of cavity was vacuum; wall boundaries were perfect conductors

Solution was requested for 3 eigenmodes, with Surface Approximations set to 

vary the Normal Deviation

norm was varied from 5 to 45 degrees by 5 degree steps

Aspect ratio was set at 5:1; Surface Deviation setting was “Ignore”

Solution setup was 0.25 GHz starting frequency (to assure a starting 
frequency did not add mesh beyond those set by the surface approximation 

settings

Solutions were continued to 0.01% delta-f (real part) or 10 passes, 

whichever came first

Tabulated results vs. theoretical computations are shown on the page following

Bessel zeros were computed to about 5 digits (e.g. p11 = 1.84118)

Speed of light used was 299792458 m/s
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Results:

Observations:
With higher-order modes, absolute error is higher in order of ascending frequency 

regardless of normal deviation faceting applied

This is expected due to some solution dependence on ‘starting’ frequency.

Added adaptive elements are ‘shared’ among modes.  Yet higher order 

modes have more ‘focused’ field peaks as compared to more fundamental 

modes.  Therefore more rapid improvement for lower order modes are an 
artifact of the adaptation technique and not one volume correction can 

strongly influence.

Note that for higher-accuracy analysis of the higher frequency modes, the 

solution can be executed with solution settings that will find that as the 

lowest frequency mode.

Even 22.5 degree setting will result in better than 0.05% error for the 

fundamental mode solution.

40 and 45 degree cases had identical meshes and results

When used to ‘reduce’ mesh, other quality checks may still constrain the 
result to more than just the surface approximation settings requested.

Conclusions:
For simple canonical shapes and fundamental modes, increased faceting is 

unnecessary unless extremely tight accuracy deviations are required

Normal 
Deviation 

(deg)

HFSS 
TM010 
Result 
(GHz)

Delta vs. 
Theory 

(%)

HFSS 
TE111 

Result 1 
(GHz)

HFSS 
TE111 

Result 2 
(GHz)

Avg. 
Delta vs. 
Theory 

(%)

Final 
Tetrahedra 

Count

Final Delta-f 
Convergence 

(%)

5 1.147406 0.001482 1.7361 1.736118 0.0756005 3347 0.0067755
10 1.147345 0.006798 1.73307 1.733154 0.2480399 2670 0.0077428
15 1.147124 0.026058 1.72758 1.727638 0.5647448 1882 0.022301
20 1.146748 0.058827 1.7192 1.719607 1.0370537 1060 0.042848
25 1.146623 0.069721 1.71165 1.712348 1.4632887 1087 0.040982
30 1.146196 0.106935 1.69707 1.697355 2.3142622 1008 0.052023
35 1.145602 0.158703 1.68868 1.688798 2.8019963 890 0.12154
40 1.144962 0.214481 1.67654 1.677916 3.4645009 887 0.033112
45 1.144962 0.214481 1.67654 1.677916 3.4645009 887 0.033112
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Source:  
K. K. So and K. W. Leung, “Annular Slot Excited Dielectric Resonator Antenna 
with a Backing Cavity,” Proceedings of the 2002 IEEE Antennas and Propagation 
Society International Symposium, San Antonio, TX, June 2002, Volume 4

Description:
A hemispherical dielectric resonator antenna (DRA) is fed by a coaxial cable 
across an annular ring slot, which couples the DRA to a hemispherical cavity 
beneath it.  This project has a combination of spherical and planar-circle curves 
which should give good evidence of the utility of the volume correction approach.  
The source provides both author-derived analytical results and measurement 
results.

Benchmark:
An image of the modeled geometry is shown (below, right).

Symmetry was used (1 plane).

Cavity (vacuum filled) is 25mm radius; DRA is 12.5 mm radius. 
DRA material has εr = 9.5
Annular ring outer radius is 5.8 mm, 1 mm width

Feed is generated using a lumped gap source port spanning the annular 
ring (see detail image)

A 30mm radius by 35mm height polyhedron (16 sides) is used for the 
radiation boundary.  

Bottom ground plane is treated as 
‘infinite ground’ boundary condition

Solution requested using only default surface approximations

10 adaptive passes or to delta-S of 0.01 at adaptive frequency of 
3.75 GHz

2.5 – 5 GHz fast sweep requested

Feed DetailFeed DetailFeed DetailFeed Detail
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Results:
Plots of S11 vs. frequency and real and imaginary Z11 vs. frequency are shown

Results conformed almost exactly to source’s reported measured results, and 

were closer to measurements than source analysis

HFSS v8.5 solved to effectively the same result, but required about 4 times the 
mesh

3324 at pass 8 (v10) vs. 13,300 tetrahedra at pass 11 (v8.5)

Conclusions:
This provides an example of a project for which the volume perturbation is 
extremely well-suited, by providing the proper dielectric resonance volume

Past experiments with as many as 24 facets per circumference without 

volume perturbation demonstrated a noticable frequency error, therefore 

the role of the new solution capability in this success is clear.

Solution accuracy was excellent in absolute terms even with default settings, and 

greatly exceeded HFSS v8.5’s capabilities

A second simulation with Normal Deviation set to 15 degrees solved to the 

same results and excellent convergence, still beating the HFSS v8.5 mesh 

required
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Source:  
http://www.jlab.org/~piller/spoke/spoke.htm

Description:
A Spoke cavity is used in accelerators for ion beams.  This variant is a ‘low Beta’ 
type.  The cavity consists of a cylindrical volume with spherical sections 
subtracted from the flat ends.  The ‘spoke’ is a smaller cylinder with its axis 
orthogonal to the main cavity’s axis that cuts through the cavity centerline on a 
diameter.  There is an input/output beam pipe that runs coaxial with the main 
cavity and exits the two concave spheroid ends.  Due to symmetry these cavities 
are usually analyzed in 1/8 sections with PHC boundary conditions

Benchmark:
An image of the modeled cavity geometry from the HFSS graphical interface is 
shown (below, right).

Main cavity 21.908 cm radius by 25.4cm height

Spherical subtractions have radius 64.572 cm

Spoke is 3.81 cm radius; beam pipe 1.359 cm radius

Solved for Normal Deviations from 5 to 30 degrees (as parametric sweep)

Solution settings 10 passes or to delta-f of 0.01%(real)

The beam ports were left as PHC bondaries, so port loading is not
included in these simulation results

Results:
A plot of solved resonant frequency vs. the Normal Deviation surface 
approximation setting used is shown above left.  Tabulated results are on the 
page following, with mesh and error statistics

The reference website indicates that a different solution method for the cavity 
obtained a resonance frequency of 338.048 MHz, yet the measurement obtained 
348.578 MHz.  Deltas to both are shown in the table.
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Results, cont.

Observations:
Since the reference analysis and measurement do not match, neither can be 

taken as an absolute accuracy validator for comparison to the HFSS results.

The measurement was of a cavity with port loading at the beam pipe(s) and 

a probe loop which will themselves perturb results slightly

The trend of resonant frequency shift with tighter normal deviation restriction is 

quite nearly linear

Tighter initial faceting results in better reported convergence for the same pass 

count

V8.5 convergence was still not at low levels after the last solved pass.  Therefore 

it was only coincidentally near the most-refined HFSS v10 solution.  Carrying the 

HFSS v8.5 solution to good convergence rather than a limited number of 
tetrahedra took more mesh than reported for HFSS v10.

Conclusions:
None of the meshes resulted in inadequate volume filling or clearly incorrect 

solutions.  This is a geometry type for which increased faceting merely fine-tunes 
the resulting convergence and final solution outputs.

Normal 
Deviation 

(deg)
f_r (MHz)

Delta vs. 
Ref. 

Analysis (%)

Delta vs. Ref. 
Measurement 

(%)

Final 
Tetrahedra 

Count

Final Delta-f 
Convergence 

(%)
5 339.332 0.379827717 2.652490978 21160 0.0021053

10 341.486 1.017015335 2.034551808 9425 0.011095
15 344.907 2.029001799 1.053135884 4246 0.10175
20 347.903 2.915266471 0.19364389 3356 0.1472
25 347.353 2.752567683 0.351427801 3757 0.016916
30 352.195 4.184908652 1.037644372 2601 0.3341



Ansoft High Frequency Structure Simulator v10 User’s Guide 

4.1
Mesh Operations

4.1-16

Source:
Henry Z. Zhang, “A Wideband Orthogonal-Mode Junction using Ridged Sectoral
Waveguides,” Proceedings of the 2002 IEEE Antennas and Propagation Society 
International Symposium, San Antonio, TX, June 2002, Volume 4

Description:
This quadrature orthomode junction (OMJ) uses a tapered septum to convert a 
circular, coaxial, quad-ridge waveguide into four contoured ridge waveguides which 
have modes analagous to rectangular single-ridge waveguide.  The use of tapered 
septums intersecting with circular cross-sections necessitates drawing in true 
curvature.

Benchmark:
The geometry is shown above.  Dimensions are as follows:

Outer radius 160 mm, Ridge diameter 150mm, center diameter 60mm

Ridges subtend 45 degrees, evenly spaced at 90 degree intervals

Septums subtend 2 degrees and extend half the length of the modeled section 
(400mm)

Two small ‘perturbers’ of εr = 1.001 (in red) are inserted at the single-
waveguide end to provide stabilization of the degenerate mode order

The HFSS v10 project was generated by direct translation of the v8.5 project, and 
solved mesh surface approximation settings.

900 MHz adapt, swept from 400 – 950 MHz

10 passes or to a Delta-S of 0.009

10 and 15 degree normal deviation allowance



Ansoft High Frequency Structure Simulator v10 User’s Guide 

4.1
Mesh Operations

4.1-17

Results
Solution results are shown below, focusing on return loss.

Results for 15 degree normal deviation are still unstable

Delta-S of 0.0342; final mesh of 16,177 tetrahedra

Results for 10 degree normal deviation are excellent

Delta-S of 0.00752; final mesh of 15,897 tetrahedra (shown)

Conclusions:
Due to very narrow annular gaps at the ridge peaks, this geometry type is poorly 
meshed without user-guidance in the form of tighter surface approximation 

settings, providing an example for which such guidance is required

However, with 10 degree faceting the solution convergence was better and to a 

smaller final mesh than with 15 degree faceting.  Therefore in geometric cases 

where surface approximations are required for a good answer, they do not 
necessarily imply a longer solution time.
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The Ultra-High Frequency (UHF) Probe
This example is intended to show you how to create, simulate, and analyze a 

UHF probe, using the Ansoft HFSS Design Environment.
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Ansoft HFSS Design Environment
The following features of the Ansoft HFSS Design Environment are used to 

create this passive device model

3D Solid Modeling

Primitives: Cylinders, BoxesCylinders, BoxesCylinders, BoxesCylinders, Boxes

Boolean Operations: Unite, SubtractUnite, SubtractUnite, SubtractUnite, Subtract

Boundaries/Excitations

Ports: Wave PortsWave PortsWave PortsWave Ports

Analysis

Sweep: Fast Frequency: Fast Frequency: Fast Frequency: Fast Frequency

Results

Cartesian plottingCartesian plottingCartesian plottingCartesian plotting

Field Overlays:

3D Far Field Plots3D Far Field Plots3D Far Field Plots3D Far Field Plots
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Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select 

the Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, click the � On the Standard toolbar, or 

select the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose Driven TerminalDriven TerminalDriven TerminalDriven Terminal

2. Click the OKOKOKOK button
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Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: in (inches)in (inches)in (inches)in (inches)

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type coppercoppercoppercopper in the Search by NameSearch by NameSearch by NameSearch by Name field

2. Click the OKOKOKOK button
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Creating Annular RingsCreating Annular RingsCreating Annular RingsCreating Annular Rings

Creating a ring is accomplished by creating a cylinder that represents the outer 
radius and a cylinder that represents the inner radius.  By performing a Boolean 

subtraction, the resulting geometry is a ring.

For this model, two sets of rings are necessary.  Instead of manually creating 

both rings, we will create one ring, copy it, and edit the dimensions of the copy.

Create Ring 1Create Ring 1Create Ring 1Create Ring 1

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the Enter Enter Enter Enter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.310.310.310.31, dY: 0.00.00.00.0, dZ: 0.0, 0.0, 0.0, 0.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 5.0, 5.0, 5.0, 5.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: ring_innerring_innerring_innerring_inner

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  Or press the CTRL+DCTRL+DCTRL+DCTRL+D

key
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Creating Annular Rings (Continued)Creating Annular Rings (Continued)Creating Annular Rings (Continued)Creating Annular Rings (Continued)

Create Ring 1 (Continued)Create Ring 1 (Continued)Create Ring 1 (Continued)Create Ring 1 (Continued)

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.370.370.370.37, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 5.05.05.05.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: ring_1ring_1ring_1ring_1

3. Click the OKOKOKOK button

To select objects to be subtracted:To select objects to be subtracted:To select objects to be subtracted:To select objects to be subtracted:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: ring_1, ring_1, ring_1, ring_1, ring_innerring_innerring_innerring_inner

2. Click the OK OK OK OK button

To subtract:To subtract:To subtract:To subtract:

1. Select the menu item 3D Modeler > Boolean > Subtract3D Modeler > Boolean > Subtract3D Modeler > Boolean > Subtract3D Modeler > Boolean > Subtract

2. Subtract Window

Blank Parts: ring_1ring_1ring_1ring_1

Tool Parts: ring_innerring_innerring_innerring_inner

Clone tool objects before subtract: � UncheckedUncheckedUncheckedUnchecked

Click the OKOKOKOK button
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Creating Annular Rings (Continued)Creating Annular Rings (Continued)Creating Annular Rings (Continued)Creating Annular Rings (Continued)

Create Ring 2 Create Ring 2 Create Ring 2 Create Ring 2 

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: ring_1ring_1ring_1ring_1

2. Click the OK OK OK OK button

3. Select the menu item Edit > CopyEdit > CopyEdit > CopyEdit > Copy

4. Select the menu item Edit > PasteEdit > PasteEdit > PasteEdit > Paste

Change the dimensions of Ring 2Change the dimensions of Ring 2Change the dimensions of Ring 2Change the dimensions of Ring 2

1. To change the dimensions of ring_2, expand the model tree as shown 
below.  It should be noted that order of the editing is important.  If you make 

the inner radius > then the outer radius, a invalid object will result and it will 

be removed from the model.  

2. Using the mouse, double click the left mouse button on the CreateCylinderCreateCylinderCreateCylinderCreateCylinder
command for ring_2ring_2ring_2ring_2

3. Properties dialog

1. Change the radius to: 0.5 in0.5 in0.5 in0.5 in

2. Click the OKOKOKOK button

4. Using the mouse, double click the left mouse button on the CreateCylinderCreateCylinderCreateCylinderCreateCylinder

command for ring_inner1ring_inner1ring_inner1ring_inner1

5. Properties dialog

1. Change the radius to: 0.435 in0.435 in0.435 in0.435 in

2. Click the OKOKOKOK button
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Create Arm_1Create Arm_1Create Arm_1Create Arm_1

To create Arm_1To create Arm_1To create Arm_1To create Arm_1

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----0.10.10.10.1, Y: ----0.310.310.310.31, Z: 5.05.05.05.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 0.20.20.20.2, dY: ----4.694.694.694.69, dZ: ----0.0650.0650.0650.065, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Arm_1Arm_1Arm_1Arm_1

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View....

Group ConductorsGroup ConductorsGroup ConductorsGroup Conductors

To group the conductors:To group the conductors:To group the conductors:To group the conductors:

1. Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible.  .  .  .  Or press the CTRL+ACTRL+ACTRL+ACTRL+A key

2. Select the menu item, 3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite
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Create the Center pinCreate the Center pinCreate the Center pinCreate the Center pin

To create the center pinTo create the center pinTo create the center pinTo create the center pin

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.10.10.10.1, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 5.15.15.15.1, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: center_pincenter_pincenter_pincenter_pin

3. Click the OKOKOKOK button
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Create Arm_2Create Arm_2Create Arm_2Create Arm_2

To create Arm_2To create Arm_2To create Arm_2To create Arm_2

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----0.10.10.10.1, Y: 0.00.00.00.0, Z: 5.15.15.15.1, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 0.20.20.20.2, dY: 5.05.05.05.0, dZ: ----0.0650.0650.0650.065, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Arm_2Arm_2Arm_2Arm_2

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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Create the Grounding PinCreate the Grounding PinCreate the Grounding PinCreate the Grounding Pin

To create the grounding pinTo create the grounding pinTo create the grounding pinTo create the grounding pin

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 1.01.01.01.0, Z: 0.0, 0.0, 0.0, 0.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.06250.06250.06250.0625, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 5.15.15.15.1, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: pinpinpinpin

3. Click the OKOKOKOK button

Group ConductorsGroup ConductorsGroup ConductorsGroup Conductors

To group the conductors:To group the conductors:To group the conductors:To group the conductors:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Arm_2, Arm_2, Arm_2, Arm_2, center_pincenter_pincenter_pincenter_pin, pin, pin, pin, pin

Note:Note:Note:Note: Use the Ctrl + Left mouse button to select multiple 

objects

2. Click the OK OK OK OK button

3. Select the menu item, 3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite
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Create the Wave portCreate the Wave portCreate the Wave portCreate the Wave port

To create a circle that represents the port:To create a circle that represents the port:To create a circle that represents the port:To create a circle that represents the port:

1. Select the menu item Draw > CircleDraw > CircleDraw > CircleDraw > Circle

2. Using the coordinate entry fields, enter the center position

X: 0.00.00.00.0,  Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius of the circle:

dX: 0.310.310.310.31, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: p1p1p1p1

3. Click the OKOKOKOK button
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Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

Using the 3D Modeler Materials toolbar, choose vacuumvacuumvacuumvacuum

Create AirCreate AirCreate AirCreate Air

To create AirTo create AirTo create AirTo create Air

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----5.05.05.05.0, Y: ----10.010.010.010.0, Z: 0.0, 0.0, 0.0, 0.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 

rectangle:

dX: 10.010.010.010.0, dY: 20.020.020.020.0, dZ: 12.012.012.012.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: AirAirAirAir

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Create Radiation BoundaryCreate Radiation BoundaryCreate Radiation BoundaryCreate Radiation Boundary

To create a radiation boundaryTo create a radiation boundaryTo create a radiation boundaryTo create a radiation boundary

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: AirAirAirAir

2. Click the OK OK OK OK button

3. Select the menu item HFSS > Boundaries >Assign>  RadiationHFSS > Boundaries >Assign>  RadiationHFSS > Boundaries >Assign>  RadiationHFSS > Boundaries >Assign>  Radiation

4. Radiation Boundary window

1. Name: Rad1Rad1Rad1Rad1

2. Click the OKOKOKOK button
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Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)

To select the object p1:To select the object p1:To select the object p1:To select the object p1:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: p1p1p1p1

2. Click the OK OK OK OK button

To assign wave port excitationTo assign wave port excitationTo assign wave port excitationTo assign wave port excitation

1. Select the menu item HFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave Port

2. Wave Port : General

1. Name: p1p1p1p1, 

2. Click the NextNextNextNext button

3. Wave Port : Terminals

1. Number of Terminals: 1111,

2. For T1T1T1T1, click the UndefinedUndefinedUndefinedUndefined column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: 0.31, Y: 0.0, Z: 0.0, X: 0.31, Y: 0.0, Z: 0.0, X: 0.31, Y: 0.0, Z: 0.0, X: 0.31, Y: 0.0, Z: 0.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex

dXdXdXdX: : : : ----0.21, 0.21, 0.21, 0.21, dYdYdYdY: 0.0, : 0.0, : 0.0, : 0.0, dZdZdZdZ: 0.0, : 0.0, : 0.0, : 0.0, Press the EnterEnterEnterEnter key

5. Click the NextNextNextNext button

4. Wave Port : Differential Pairs 

1. Click the NextNextNextNext button

5. Wave Port : Post Processing 

1. Reference Impedance: 50505050

6. Click the FinishFinishFinishFinish button
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Create Infinite Ground PlaneCreate Infinite Ground PlaneCreate Infinite Ground PlaneCreate Infinite Ground Plane

To create an Infinite groundTo create an Infinite groundTo create an Infinite groundTo create an Infinite ground

1. Select the menu item Edit > Select > FacesEdit > Select > FacesEdit > Select > FacesEdit > Select > Faces

2. Graphically select the face of the Air object at Z=0

3. Select the menu item HFSS > Boundaries > Assign> Finite ConductivityHFSS > Boundaries > Assign> Finite ConductivityHFSS > Boundaries > Assign> Finite ConductivityHFSS > Boundaries > Assign> Finite Conductivity

4. Finite Conductivity Boundary window

1. Name: gnd_planegnd_planegnd_planegnd_plane

2. Use Material: � CheckedCheckedCheckedChecked

3. Click the vacuumvacuumvacuumvacuum button

4. Select Definition Window:

1. Type coppercoppercoppercopper in the Search Search Search Search 

by Nameby Nameby Nameby Name field

2. Click the OKOKOKOK button

5. Infinite Ground Plane: � CheckedCheckedCheckedChecked

6. Click the OKOKOKOK button

Create a Radiation SetupCreate a Radiation SetupCreate a Radiation SetupCreate a Radiation Setup

To define the radiation setupTo define the radiation setupTo define the radiation setupTo define the radiation setup

1. Select the menu item HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite 
SphereSphereSphereSphere

2. Far Field Radiation Sphere Setup dialog

1.1.1.1. Infinite SphereInfinite SphereInfinite SphereInfinite Sphere Tab

1. Name: ff_2dff_2dff_2dff_2d

2. Phi: (Start: 0, 0, 0, 0, Stop: 90, 90, 90, 90, Step Size: 90)90)90)90)

3. Theta: (Start: ----180, 180, 180, 180, Stop: 180, 180, 180, 180, Step Size: 2)2)2)2)

2. Click the OKOKOKOK button
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Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 0.55 GHz: 0.55 GHz: 0.55 GHz: 0.55 GHz

Maximum Number of Passes: 10101010

Maximum Delta S per Pass: 0.020.020.020.02

2. Click the OKOKOKOK button

Adding a Frequency SweepAdding a Frequency SweepAdding a Frequency SweepAdding a Frequency Sweep

To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:

1. Select the menu item HFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add Sweep

1. Select Solution Setup: Setup1 Setup1 Setup1 Setup1 

2. Click the OKOKOKOK button

2. Edit Sweep Window:

1. Sweep Type: Fast: Fast: Fast: Fast

2. Frequency Setup Type: Linear Count: Linear Count: Linear Count: Linear Count

Start: 0.35GHz0.35GHz0.35GHz0.35GHz

Stop: 0.75GHz: 0.75GHz: 0.75GHz: 0.75GHz

Count: 401: 401: 401: 401

Save Fields: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_uhf_probehfss_uhf_probehfss_uhf_probehfss_uhf_probe

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 
Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze All
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button
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Create Reports

Create Terminal SCreate Terminal SCreate Terminal SCreate Terminal S----Parameter Plot Parameter Plot Parameter Plot Parameter Plot ---- MagnitudeMagnitudeMagnitudeMagnitude

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Domain: SweepSweepSweepSweep

3. Click the YYYY tab

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: St(p1,p1), St(p1,p1), St(p1,p1), St(p1,p1), 

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button
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Far Field Overlays

Create Far Field OverlayCreate Far Field OverlayCreate Far Field OverlayCreate Far Field Overlay

To create a 2D polar far field plot :To create a 2D polar far field plot :To create a 2D polar far field plot :To create a 2D polar far field plot :

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Far FieldsFar FieldsFar FieldsFar Fields

2. Display Type: Radiation PatternRadiation PatternRadiation PatternRadiation Pattern

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Setup1: Setup1: Setup1: LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Geometry: ff_2dff_2dff_2dff_2d

3. In the SweepsSweepsSweepsSweeps tab, select PhiPhiPhiPhi under the NameNameNameName column, and on the 
drop list, select ThetaThetaThetaTheta. This changes the primary sweep to Theta.

4. In the MagMagMagMag tab

1. Category: GainGainGainGain

2. Quantity: GainTotalGainTotalGainTotalGainTotal

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

5. Click the DoneDoneDoneDone button
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Dual Mode Conical Horn 
This example is intended to show you how to create, simulate, and analyze a 

waveguide horn antenna using the Ansoft HFSS Design Environment.  
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Ansoft HFSS Design Environment
The following features of the Ansoft HFSS Design Environment are used to 

create this passive device model:

3D Solid Modeling

Primitives: CylindersCylindersCylindersCylinders

Boolean: Union, Subtract, ConnectUnion, Subtract, ConnectUnion, Subtract, ConnectUnion, Subtract, Connect

Boundaries/Excitations

Excitations: Wave PortsWave PortsWave PortsWave Ports

Boundaries: RadiationRadiationRadiationRadiation

Results

Plotting: Radiation PatternRadiation PatternRadiation PatternRadiation Pattern
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Design Review
Port Size/TypePort Size/TypePort Size/TypePort Size/Type

Since the port is external to the model we could use a Wave Port.  The 

size of the port is determined by the physical dimensions of the

waveguide.  Because the waveguide is circular, we must Polarize the E-

Field for the port definition.

Free SpaceFree SpaceFree SpaceFree Space

Since we are evaluating a radiating structure, we need to create a free 

space environment for the device to operate in.  This can be achieved by 
using the Radiation Boundary condition or a Perfectly Matched Layer 

(PML). We will use a Radiation Boundary since the surface will be 

cylindrical.

The Radiation Boundary needs to be placed at least λ/4 from radiating 
devices.  For our example we will assume that  ~λ/4 (0.6in)
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Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select 

the Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, click the � On the Standard toolbar, or 

select the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose Driven ModalDriven ModalDriven ModalDriven Modal

2. Click the OKOKOKOK button
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Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: in in in in 

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

Using the 3D Modeler Materials toolbar, choose vacuumvacuumvacuumvacuum

Create Circular WaveguideCreate Circular WaveguideCreate Circular WaveguideCreate Circular Waveguide

Create waveguideCreate waveguideCreate waveguideCreate waveguide

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.0  0.0  0.0  0.0  Press the Enter Enter Enter Enter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.8380.8380.8380.838, dY: 0.00.00.00.0, dZ: 0.0  0.0  0.0  0.0  Press the Enter Enter Enter Enter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 3.0  3.0  3.0  3.0  Press the Enter Enter Enter Enter key 

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: WaveguideWaveguideWaveguideWaveguide

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
Or press the CTRL+DCTRL+DCTRL+DCTRL+D key



5.2
Example – Conical Horn

5.2-7Ansoft High Frequency Structure Simulator v10 User’s Guide 

Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

Create CSCreate CSCreate CSCreate CS

1. Select the menu item 3D Modeler > Coordinate System > Create >  Relative 3D Modeler > Coordinate System > Create >  Relative 3D Modeler > Coordinate System > Create >  Relative 3D Modeler > Coordinate System > Create >  Relative 
CS > OffsetCS > OffsetCS > OffsetCS > Offset

2. Using the coordinate entry fields, enter the origin

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 3.0 3.0 3.0 3.0 Press the Enter Enter Enter Enter key 

Create Transition RegionCreate Transition RegionCreate Transition RegionCreate Transition Region

Create waveguide transitionCreate waveguide transitionCreate waveguide transitionCreate waveguide transition

1. Select the menu item Draw > ConeDraw > ConeDraw > ConeDraw > Cone

2. Using the coordinate entry fields, enter the center position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.0 0.0 0.0 0.0 Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the lower radius:

dX: 0.8380.8380.8380.838, dY: 0.00.00.00.0, dZ: 0.0 0.0 0.0 0.0 Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the upper radius:

dX: 0.7090.7090.7090.709, dY: 0.00.00.00.0, dZ: 0.0  0.0  0.0  0.0  Press the EnterEnterEnterEnter key

5. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 1.227 1.227 1.227 1.227 Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: TaperTaperTaperTaper

3. Click the OKOKOKOK button
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Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

Create CSCreate CSCreate CSCreate CS

1. Select the menu item 3D Modeler > Coordinate System > Create >  3D Modeler > Coordinate System > Create >  3D Modeler > Coordinate System > Create >  3D Modeler > Coordinate System > Create >  
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 1.227 1.227 1.227 1.227 Press the EnterEnterEnterEnter key

Create the ThroatCreate the ThroatCreate the ThroatCreate the Throat

Create ThroatCreate ThroatCreate ThroatCreate Throat

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.0 0.0 0.0 0.0 Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 1.5471.5471.5471.547, dY: 0.00.00.00.0, dZ: 0.0 0.0 0.0 0.0 Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 3.236 3.236 3.236 3.236 Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: ThroatThroatThroatThroat

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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Group ObjectGroup ObjectGroup ObjectGroup Object

To group the objects:To group the objects:To group the objects:To group the objects:

1. Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible.  .  .  .  Or press the CTRL+ACTRL+ACTRL+ACTRL+A key

2. Select the menu item, 3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite

Rename groupRename groupRename groupRename group

To rename the group of objects:To rename the group of objects:To rename the group of objects:To rename the group of objects:

1. From the ModelModelModelModel tree, select the only object shown

2. Click the Properties Properties Properties Properties button

1. For the ValueValueValueValue of NameNameNameName type: Horn_AirHorn_AirHorn_AirHorn_Air

2. Click the OKOKOKOK button

3. Click the DoneDoneDoneDone button

Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: GlobalGlobalGlobalGlobal

2. Click the SelectSelectSelectSelect button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type pecpecpecpec in the Search by NameSearch by NameSearch by NameSearch by Name field

2. Click the OKOKOKOK button
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Create the Horn WallCreate the Horn WallCreate the Horn WallCreate the Horn Wall

Create hornCreate hornCreate hornCreate horn

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.0 0.0 0.0 0.0 Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 1.6471.6471.6471.647, dY: 0.00.00.00.0, dZ: 0.0 : 0.0 : 0.0 : 0.0 Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.0: 0.0: 0.0: 0.0, dY: 0.0: 0.0: 0.0: 0.0, dZ: 7.463 : 7.463 : 7.463 : 7.463 Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: HornHornHornHorn

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Complete the HornComplete the HornComplete the HornComplete the Horn

To select the objectTo select the objectTo select the objectTo select the object

Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible.  .  .  .  Or press the CTRL+ACTRL+ACTRL+ACTRL+A key

To complete the horn:To complete the horn:To complete the horn:To complete the horn:

1. Select the menu item 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 

2. Subtract Window

Blank Parts: HornHornHornHorn

Tool Parts: Horn_AirHorn_AirHorn_AirHorn_Air

Clone tool objects before subtract: ���� UncheckedUncheckedUncheckedUnchecked

Click the OKOKOKOK button
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Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

Using the 3D Modeler Materials toolbar, choose vacuumvacuumvacuumvacuum

Create AirCreate AirCreate AirCreate Air

Create AirCreate AirCreate AirCreate Air

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.0 : 0.0 : 0.0 : 0.0 Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 2.2: 2.2: 2.2: 2.2, dY: 0.0: 0.0: 0.0: 0.0, dZ: 0.0 : 0.0 : 0.0 : 0.0 Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.0: 0.0: 0.0: 0.0, dY: 0.0: 0.0: 0.0: 0.0, dZ: 8.2 : 8.2 : 8.2 : 8.2 Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: AirAirAirAir

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View....

Create Radiation BoundaryCreate Radiation BoundaryCreate Radiation BoundaryCreate Radiation Boundary

To create a radiation boundaryTo create a radiation boundaryTo create a radiation boundaryTo create a radiation boundary

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: AirAirAirAir

2. Click the OK OK OK OK button

3. Select the menu item HFSS > Boundaries > Assign> RadiationHFSS > Boundaries > Assign> RadiationHFSS > Boundaries > Assign> RadiationHFSS > Boundaries > Assign> Radiation

4. Radiation Boundary window

1. Name: Rad1Rad1Rad1Rad1

2. Click the OKOKOKOK button
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Create the Wave portCreate the Wave portCreate the Wave portCreate the Wave port

To create a circle that represents the port:To create a circle that represents the port:To create a circle that represents the port:To create a circle that represents the port:

1. Select the menu item Draw > CircleDraw > CircleDraw > CircleDraw > Circle

2. Using the coordinate entry fields, enter the center position

X: 0.0: 0.0: 0.0: 0.0, Y: 0.0: 0.0: 0.0: 0.0, Z: 0.0 : 0.0 : 0.0 : 0.0 Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius of the circle:

dX: 0.838: 0.838: 0.838: 0.838, dY: 0.0: 0.0: 0.0: 0.0, dZ: 0.0 : 0.0 : 0.0 : 0.0 Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: p1p1p1p1

3. Click the OKOKOKOK button

To select the object p1:To select the object p1:To select the object p1:To select the object p1:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: p1p1p1p1

2. Click the OK OK OK OK button
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Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)

To assign wave port excitationTo assign wave port excitationTo assign wave port excitationTo assign wave port excitation

1. Select the menu item HFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave Port

2. Wave Port : General

1. Name: p1p1p1p1

2. Click the NextNextNextNext button

3. Wave Port : Modes

1. Number of Modes: 2222

2. For Mode 1Mode 1Mode 1Mode 1, click the NoneNoneNoneNone column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: : : : ----0.8380.8380.8380.838, Y: 0.0: 0.0: 0.0: 0.0, Z: 0.0 : 0.0 : 0.0 : 0.0 Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex

dX: 1.676: 1.676: 1.676: 1.676, dY: 0.0: 0.0: 0.0: 0.0, dZ: 0.0 : 0.0 : 0.0 : 0.0 Press the EnterEnterEnterEnter key

5. Polarize E Field: � CheckedCheckedCheckedChecked

6. Click the NextNextNextNext button

4. Wave Port : Post Processing 

5. Click the FinishFinishFinishFinish button
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Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

Create CSCreate CSCreate CSCreate CS

1. Select the menu item 3D Modeler > Coordinate System > Create >  3D Modeler > Coordinate System > Create >  3D Modeler > Coordinate System > Create >  3D Modeler > Coordinate System > Create >  
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: 0.0: 0.0: 0.0: 0.0, Y: 0.0: 0.0: 0.0: 0.0, Z: 7.463 : 7.463 : 7.463 : 7.463 Press the EnterEnterEnterEnter key

Create a Radiation SetupCreate a Radiation SetupCreate a Radiation SetupCreate a Radiation Setup

To define the radiation setupTo define the radiation setupTo define the radiation setupTo define the radiation setup

1. Select the menu item HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite 
SphereSphereSphereSphere

2. Far Field Radiation Sphere Setup dialog

Infinite SphereInfinite SphereInfinite SphereInfinite Sphere Tab

1. Name: ff_2dff_2dff_2dff_2d

2. Phi: (Start: 0, 0, 0, 0, Stop: 90, 90, 90, 90, Step Size: 90)90)90)90)

3. Theta: (Start: ----180, 180, 180, 180, Stop: 180, 180, 180, 180, Step Size: 2)2)2)2)

1.1.1.1. Coordinate System Coordinate System Coordinate System Coordinate System Tab

1. Select Use local coordinate systemUse local coordinate systemUse local coordinate systemUse local coordinate system

2. Choose RelativeCS3RelativeCS3RelativeCS3RelativeCS3

2. Click the OKOKOKOK button
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Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 5.0 GHz: 5.0 GHz: 5.0 GHz: 5.0 GHz

Maximum Number of Passes: 10101010

Maximum Delta S per Pass: 0.020.020.020.02

2. Click the OKOKOKOK button

Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_chornhfss_chornhfss_chornhfss_chorn

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 

Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze All
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button
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Far Field Overlays

Edit SourcesEdit SourcesEdit SourcesEdit Sources

To Modify a Terminal excitation:To Modify a Terminal excitation:To Modify a Terminal excitation:To Modify a Terminal excitation:

1. Select the menu item HFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit Sources

2. Edit Sources window

1. Source: p1:m1p1:m1p1:m1p1:m1

1. Scaling Factor: 1111

2. Offset: 0000

2. Source: p1:m2p1:m2p1:m2p1:m2

1. Scaling Factor: 1111

2. OffsetPhase: 90909090

3. Click the OKOKOKOK button

Create Far Field OverlayCreate Far Field OverlayCreate Far Field OverlayCreate Far Field Overlay

To create a 2D polar far field plot :To create a 2D polar far field plot :To create a 2D polar far field plot :To create a 2D polar far field plot :

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Far FieldsFar FieldsFar FieldsFar Fields

2. Display Type: Radiation PatternRadiation PatternRadiation PatternRadiation Pattern

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Setup1: Setup1: Setup1: LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Geometry: ff_2dff_2dff_2dff_2d

3. In the SweepsSweepsSweepsSweeps tab

1. Primary Sweep: Click on the Name PhiPhiPhiPhi and toggle to ThetaThetaThetaTheta

4. In the MagMagMagMag tab

1. Category: GainGainGainGain

2. Quantity: GainLHCPGainLHCPGainLHCPGainLHCP, , , , GainRHCPGainRHCPGainRHCPGainRHCP

3. Function: dBdBdBdB

5. Click the DoneDoneDoneDone button



5.2
Example – Conical Horn

5.2-18Ansoft High Frequency Structure Simulator v10 User’s Guide 



5.3
Example – Probe Feed Patch Antenna

5.3-1Ansoft High Frequency Structure Simulator v10 User’s Guide 

The Probe Feed Patch Antenna
This example is intended to show you how to create, simulate, and analyze a 

probe feed patch antenna using the Ansoft HFSS Design Environment.  

Infinite Ground

Sub1 (Dielectric)

Patch (Signal)

0.32cm
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Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select 

the Ansoft > HFSS 10Ansoft > HFSS 10Ansoft > HFSS 10Ansoft > HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, click the � On the Standard toolbar, or 

select the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose Driven TerminalDriven TerminalDriven TerminalDriven Terminal

2. Click the OKOKOKOK button
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Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: cmcmcmcm

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type Rogers RT/Rogers RT/Rogers RT/Rogers RT/duroidduroidduroidduroid 5880 (tm)5880 (tm)5880 (tm)5880 (tm) in the Search by NameSearch by NameSearch by NameSearch by Name field

2. Click the OKOKOKOK button
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Create SubstrateCreate SubstrateCreate SubstrateCreate Substrate

To create the substrate:To create the substrate:To create the substrate:To create the substrate:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----5.05.05.05.0, Y: ----4.54.54.54.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

2. Using the coordinate entry fields, enter the opposite corner of the box

dX: 10.010.010.010.0, dY: 9.09.09.09.0, dZ: 0.320.320.320.32, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Sub1Sub1Sub1Sub1

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . Or press the CTRL+DCTRL+DCTRL+DCTRL+D key
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Create Infinite GroundCreate Infinite GroundCreate Infinite GroundCreate Infinite Ground

To create the infinite ground:To create the infinite ground:To create the infinite ground:To create the infinite ground:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the rectangle position

X: ----5.05.05.05.0, Y: ----4.54.54.54.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the rectangle:

dX: 10.010.010.010.0, dY: 9.09.09.09.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Inf_GNDInf_GNDInf_GNDInf_GND

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Assign a Perfect E boundary to the Infinite GroundAssign a Perfect E boundary to the Infinite GroundAssign a Perfect E boundary to the Infinite GroundAssign a Perfect E boundary to the Infinite Ground

To select the trace:To select the trace:To select the trace:To select the trace:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Inf_GNDInf_GNDInf_GNDInf_GND

2. Click the OK OK OK OK button

To assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundary

1. Select the menu item HFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect E

2. Perfect E Boundary window

1. Name: PerfE_Inf_GNDPerfE_Inf_GNDPerfE_Inf_GNDPerfE_Inf_GND

2. Infinite Ground Plane: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Create Infinite Ground Cut OutCreate Infinite Ground Cut OutCreate Infinite Ground Cut OutCreate Infinite Ground Cut Out

To create the cut out:To create the cut out:To create the cut out:To create the cut out:

1. Select the menu item Draw > CircleDraw > CircleDraw > CircleDraw > Circle

2. Using the coordinate entry fields, enter the center position

X: ----0.50.50.50.5, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.160.160.160.16, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Cut_OutCut_OutCut_OutCut_Out

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View

Complete the Infinite GroundComplete the Infinite GroundComplete the Infinite GroundComplete the Infinite Ground

To select the objects To select the objects To select the objects To select the objects Inf_GNDInf_GNDInf_GNDInf_GND & & & & Cut_OutCut_OutCut_OutCut_Out::::

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Inf_GNDInf_GNDInf_GNDInf_GND, , , , Cut_OutCut_OutCut_OutCut_Out

2. Click the OK OK OK OK button

To complete the ring:To complete the ring:To complete the ring:To complete the ring:

1. Select the menu item 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 

2. Subtract Window

Blank Parts: Inf_GnDInf_GnDInf_GnDInf_GnD

Tool Parts: Cut_OutCut_OutCut_OutCut_Out

Clone tool objects before subtract: ���� UncheckedUncheckedUncheckedUnchecked

Click the OKOKOKOK button
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Create PatchCreate PatchCreate PatchCreate Patch

To create the patch:To create the patch:To create the patch:To create the patch:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the rectangle position

X: ----2.02.02.02.0, Y: ----1.51.51.51.5, Z: 0.320.320.320.32, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the rectangle:

dX: 4.04.04.04.0, dY: 3.03.03.03.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: PatchPatchPatchPatch

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Assign a Perfect E boundary to the TraceAssign a Perfect E boundary to the TraceAssign a Perfect E boundary to the TraceAssign a Perfect E boundary to the Trace

To select the trace:To select the trace:To select the trace:To select the trace:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: PatchPatchPatchPatch

2. Click the OK OK OK OK button

To assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundary

1. Select the menu item HFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect E

2. Perfect E Boundary window

1. Name: PerfE_PatchPerfE_PatchPerfE_PatchPerfE_Patch

2. Click the OKOKOKOK button
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Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose vacuum vacuum vacuum vacuum 

Create the CoaxCreate the CoaxCreate the CoaxCreate the Coax

To create the coax:To create the coax:To create the coax:To create the coax:

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: ----0.50.50.50.5, Y: 0.00.00.00.0, Z: 0.0 0.0 0.0 0.0 Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.160.160.160.16, dY: 0.00.00.00.0, dZ: 0.0 0.0 0.0 0.0 Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: ----0.5 0.5 0.5 0.5 Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: CoaxCoaxCoaxCoax

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type pecpecpecpec in the Search by NameSearch by NameSearch by NameSearch by Name field

2. Click the OKOKOKOK button

Create the Coax PinCreate the Coax PinCreate the Coax PinCreate the Coax Pin

To create the coax pin:To create the coax pin:To create the coax pin:To create the coax pin:

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: ----0.50.50.50.5, Y: 0.00.00.00.0, Z: 0.0 0.0 0.0 0.0 Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.070.070.070.07, dY: 0.00.00.00.0, dZ: 0.0 0.0 0.0 0.0 Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: ----0.5 0.5 0.5 0.5 Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Coax_PinCoax_PinCoax_PinCoax_Pin

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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Create the Wave portCreate the Wave portCreate the Wave portCreate the Wave port

To create a circle that represents the port:To create a circle that represents the port:To create a circle that represents the port:To create a circle that represents the port:

1. Select the menu item Draw > CircleDraw > CircleDraw > CircleDraw > Circle

2. Using the coordinate entry fields, enter the center position

X: : : : ----0.50.50.50.5, Y: 0.0: 0.0: 0.0: 0.0, Z: : : : ----0.5 0.5 0.5 0.5 Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius of the circle:

dX: 0.16: 0.16: 0.16: 0.16, dY: 0.0: 0.0: 0.0: 0.0, dZ: 0.0 : 0.0 : 0.0 : 0.0 Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Port1Port1Port1Port1

3. Click the OKOKOKOK button

To select the object Port1:To select the object Port1:To select the object Port1:To select the object Port1:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Port1Port1Port1Port1

2. Click the OK OK OK OK button

To assign wave port excitationTo assign wave port excitationTo assign wave port excitationTo assign wave port excitation

1. Select the menu item HFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave Port

2. Wave Port : General

1. Name: p1p1p1p1

2. Click the NextNextNextNext button

3. Wave Port : Terminals

1. Number of Terminals: 1111,

2. For T1T1T1T1, click the UndefinedUndefinedUndefinedUndefined column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: ----0.340.340.340.34, Y: 0.00.00.00.0, Z: ----0.50.50.50.5, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex

dX: ----0.090.090.090.09, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

5. Click the NextNextNextNext button

4. Wave Port : Differential Pairs 

1. Click the NextNextNextNext button

5. Wave Port : Post Processing 

1. Reference Impedance: 50505050

6. Click the FinishFinishFinishFinish button
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Create the ProbeCreate the ProbeCreate the ProbeCreate the Probe

To create the probe:To create the probe:To create the probe:To create the probe:

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: ----0.50.50.50.5, Y: 0.00.00.00.0, Z: 0.0 0.0 0.0 0.0 Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.070.070.070.07, dY: 0.00.00.00.0, dZ: 0.0 0.0 0.0 0.0 Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 0.32 0.32 0.32 0.32 Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: ProbeProbeProbeProbe

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose vacuum vacuum vacuum vacuum 

Create AirCreate AirCreate AirCreate Air

To create the air:To create the air:To create the air:To create the air:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----5.05.05.05.0, Y: ----4.54.54.54.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

2. Using the coordinate entry fields, enter the opposite corner of the box

dX: 10.010.010.010.0, dY: 9.09.09.09.0, dZ: 3.323.323.323.32, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: AirAirAirAir

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 
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Create Radiation BoundaryCreate Radiation BoundaryCreate Radiation BoundaryCreate Radiation Boundary

Picking the faces:Picking the faces:Picking the faces:Picking the faces:

1. Select the menu item Edit > Select > FacesEdit > Select > FacesEdit > Select > FacesEdit > Select > Faces

2. Graphically select allallallall of the facesfacesfacesfaces of the AirAirAirAir object except except except except the face at Z=0.0cmface at Z=0.0cmface at Z=0.0cmface at Z=0.0cm

To create a radiation boundaryTo create a radiation boundaryTo create a radiation boundaryTo create a radiation boundary

1. Select the menu item HFSS > Boundaries > Assign> RadiationHFSS > Boundaries > Assign> RadiationHFSS > Boundaries > Assign> RadiationHFSS > Boundaries > Assign> Radiation

2. Radiation Boundary window

1. Name: Rad1Rad1Rad1Rad1

2. Click the OKOKOKOK button

Create a Radiation SetupCreate a Radiation SetupCreate a Radiation SetupCreate a Radiation Setup

To define the radiation setupTo define the radiation setupTo define the radiation setupTo define the radiation setup

1. Select the menu item HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite 
SphereSphereSphereSphere

2. Far Field Radiation Sphere Setup dialog

1. Select the Infinite SphereInfinite SphereInfinite SphereInfinite Sphere Tab

1. Name: ff_2dff_2dff_2dff_2d

2. Phi: (Start: 0, 0, 0, 0, Stop: 90, 90, 90, 90, Step Size: 90)90)90)90)

3. Theta: (Start: ----180, 180, 180, 180, Stop: 180, 180, 180, 180, Step Size: 2)2)2)2)

2. Click the OKOKOKOK button
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Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 2.25 GHz: 2.25 GHz: 2.25 GHz: 2.25 GHz

Maximum Number of Passes: 20202020

Maximum Delta S per Pass: 0.020.020.020.02

2. Click the OKOKOKOK button

Adding a Frequency SweepAdding a Frequency SweepAdding a Frequency SweepAdding a Frequency Sweep

To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:

1. Select the menu item HFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add Sweep

1. Select Solution Setup: Setup1 Setup1 Setup1 Setup1 

2. Click the OKOKOKOK button

2. Edit Sweep Window:

1. Sweep Type: Fast: Fast: Fast: Fast

2. Frequency Setup Type: Linear Count: Linear Count: Linear Count: Linear Count

Start: 1.0GHz1.0GHz1.0GHz1.0GHz

Stop: 3.5GHz: 3.5GHz: 3.5GHz: 3.5GHz

Count: 201: 201: 201: 201

Save Fields: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button



5.3
Example – Probe Feed Patch Antenna

5.3-16Ansoft High Frequency Structure Simulator v10 User’s Guide 

Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_probepatchhfss_probepatchhfss_probepatchhfss_probepatch

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 
Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze All
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button
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Create Reports

Create Terminal SCreate Terminal SCreate Terminal SCreate Terminal S----Parameter Plot Parameter Plot Parameter Plot Parameter Plot ---- MagnitudeMagnitudeMagnitudeMagnitude

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Domain: SweepSweepSweepSweep

3. Click the YYYY tab

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: St(p1,p1), St(p1,p1), St(p1,p1), St(p1,p1), 

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button

4. Select the menu Report 2D > Mark All TracesReport 2D > Mark All TracesReport 2D > Mark All TracesReport 2D > Mark All Traces

1. Click the MinMinMinMin button
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Far Field Overlays

Create Far Field OverlayCreate Far Field OverlayCreate Far Field OverlayCreate Far Field Overlay

To create a 2D polar far field plot :To create a 2D polar far field plot :To create a 2D polar far field plot :To create a 2D polar far field plot :

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Far FieldsFar FieldsFar FieldsFar Fields

2. Display Type: Radiation PatternRadiation PatternRadiation PatternRadiation Pattern

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Geometry: ff_2dff_2dff_2dff_2d

3. In the SweepsSweepsSweepsSweeps tab, select PhiPhiPhiPhi under the NameNameNameName column, and on the 
drop list, select ThetaThetaThetaTheta. This changes the primary sweep to Theta.

4. In the SweepsSweepsSweepsSweeps tab, select the row labeled FreqFreqFreqFreq and select the 

frequency 2.36252.36252.36252.3625 from the list.

5. In the MagMagMagMag tab

1. Category: GainGainGainGain

2. Quantity: GainTotalGainTotalGainTotalGainTotal

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

6. Click the DoneDoneDoneDone button
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The Slot Coupled Patch Antenna
This example is intended to show you how to create, simulate, and analyze a 

probe feed patch antenna using the Ansoft HFSS Design Environment.  

Slot (Plane)

Feed (Signal)

Sub2 (Dielectric) 0.16cm

Sub1 (Dielectric)

Patch (Signal)

0.16cm
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Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select 

the Ansoft > HFSS 10Ansoft > HFSS 10Ansoft > HFSS 10Ansoft > HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, click the � On the Standard toolbar, or 

select the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose Driven TerminalDriven TerminalDriven TerminalDriven Terminal

2. Click the OKOKOKOK button
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Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: cmcmcmcm

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type Rogers RT/Rogers RT/Rogers RT/Rogers RT/duroidduroidduroidduroid 5880 (tm)5880 (tm)5880 (tm)5880 (tm) in the Search by NameSearch by NameSearch by NameSearch by Name field

2. Click the OKOKOKOK button
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Create SubstrateCreate SubstrateCreate SubstrateCreate Substrate

To create the substrate:To create the substrate:To create the substrate:To create the substrate:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----7.07.07.07.0, Y: ----4.54.54.54.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

2. Using the coordinate entry fields, enter the opposite corner of the box

dX: 12.012.012.012.0, dY: 9.09.09.09.0, dZ: 0.320.320.320.32, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Sub1Sub1Sub1Sub1

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . Or press the CTRL+DCTRL+DCTRL+DCTRL+D key
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Create the FeedCreate the FeedCreate the FeedCreate the Feed

To create the feed:To create the feed:To create the feed:To create the feed:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the rectangle position

X: ----5.05.05.05.0, Y: ----0.24750.24750.24750.2475, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the rectangle:

dX: 7.07.07.07.0, dY: 0.4950.4950.4950.495, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: FeedFeedFeedFeed

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Assign a Perfect E boundary to the FeedAssign a Perfect E boundary to the FeedAssign a Perfect E boundary to the FeedAssign a Perfect E boundary to the Feed

To select the feed:To select the feed:To select the feed:To select the feed:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: FeedFeedFeedFeed

2. Click the OK OK OK OK button

To assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundary

1. Select the menu item HFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect E

2. Perfect E Boundary window

1. Name: PerfE_FeedPerfE_FeedPerfE_FeedPerfE_Feed

2. Infinite Ground Plane: ���� UncheckedUncheckedUncheckedUnchecked

3. Click the OKOKOKOK button
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Create GroundCreate GroundCreate GroundCreate Ground

To create the ground:To create the ground:To create the ground:To create the ground:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the rectangle position

X: ----7.07.07.07.0, Y: ----4.54.54.54.5, Z: 0.160.160.160.16, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the rectangle:

dX: 12.012.012.012.0, dY: 9.09.09.09.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: GroundGroundGroundGround

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Assign a Perfect E boundary to the GroundAssign a Perfect E boundary to the GroundAssign a Perfect E boundary to the GroundAssign a Perfect E boundary to the Ground

To select the ground:To select the ground:To select the ground:To select the ground:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: GroundGroundGroundGround

2. Click the OK OK OK OK button

To assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundary

1. Select the menu item HFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect E

2. Perfect E Boundary window

1. Name: PerfE_GroundPerfE_GroundPerfE_GroundPerfE_Ground

2. Infinite Ground Plane: ���� UncheckedUncheckedUncheckedUnchecked

3. Click the OKOKOKOK button
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Create Slot Cut OutCreate Slot Cut OutCreate Slot Cut OutCreate Slot Cut Out

To create the cut out:To create the cut out:To create the cut out:To create the cut out:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the rectangle position

X: ----0.07750.07750.07750.0775, Y: ----0.70.70.70.7, Z: 0.160.160.160.16, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the rectangle:

dX: 0.1550.1550.1550.155, dY: 1.41.41.41.4, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: SlotSlotSlotSlot

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View

Complete the GroundComplete the GroundComplete the GroundComplete the Ground

To select the objects ground & slotTo select the objects ground & slotTo select the objects ground & slotTo select the objects ground & slot

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Ground, SlotGround, SlotGround, SlotGround, Slot

2. Click the OK OK OK OK button

To complete the ring:To complete the ring:To complete the ring:To complete the ring:

1. Select the menu item 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 

2. Subtract Window

Blank Parts: GroundGroundGroundGround

Tool Parts: SlotSlotSlotSlot

Clone tool objects before subtract: ���� UncheckedUncheckedUncheckedUnchecked

Click the OKOKOKOK button
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Create PatchCreate PatchCreate PatchCreate Patch

To create the patch:To create the patch:To create the patch:To create the patch:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the rectangle position

X: ----2.02.02.02.0, Y: ----1.51.51.51.5, Z: 0.320.320.320.32, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the rectangle:

dX: 4.04.04.04.0, dY: 3.03.03.03.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: PatchPatchPatchPatch

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Assign a Perfect E boundary to the TraceAssign a Perfect E boundary to the TraceAssign a Perfect E boundary to the TraceAssign a Perfect E boundary to the Trace

To select the trace:To select the trace:To select the trace:To select the trace:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: PatchPatchPatchPatch

2. Click the OK OK OK OK button

To assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundary

1. Select the menu item HFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect E

2. Perfect E Boundary window

1. Name: PerfE_PatchPerfE_PatchPerfE_PatchPerfE_Patch

2. Click the OKOKOKOK button
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Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose vacuum vacuum vacuum vacuum 

Create AirCreate AirCreate AirCreate Air

To create the air:To create the air:To create the air:To create the air:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----7.07.07.07.0, Y: ----4.54.54.54.5, Z: ----2.02.02.02.0, Press the EnterEnterEnterEnter key

2. Using the coordinate entry fields, enter the opposite corner of the box

dX: 12.012.012.012.0, dY: 9.09.09.09.0, dZ: 4.324.324.324.32, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: AirAirAirAir

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View
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Create Radiation BoundaryCreate Radiation BoundaryCreate Radiation BoundaryCreate Radiation Boundary

Picking the faces:Picking the faces:Picking the faces:Picking the faces:

1. Select the menu item Edit > Select > FacesEdit > Select > FacesEdit > Select > FacesEdit > Select > Faces

2. Graphically select allallallall of the facesfacesfacesfaces of the AirAirAirAir object except except except except the face at Z=0.0cmface at Z=0.0cmface at Z=0.0cmface at Z=0.0cm

To create a radiation boundaryTo create a radiation boundaryTo create a radiation boundaryTo create a radiation boundary

1. Select the menu item HFSS > Boundaries >  RadiationHFSS > Boundaries >  RadiationHFSS > Boundaries >  RadiationHFSS > Boundaries >  Radiation

2. Radiation Boundary window

1. Name: Rad1Rad1Rad1Rad1

2. Click the OKOKOKOK button

Create a Radiation SetupCreate a Radiation SetupCreate a Radiation SetupCreate a Radiation Setup

To define the radiation setupTo define the radiation setupTo define the radiation setupTo define the radiation setup

1. Select the menu item HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite 
SphereSphereSphereSphere

2. Far Field Radiation Sphere Setup dialog

1. Select the Infinite SphereInfinite SphereInfinite SphereInfinite Sphere Tab

1. Name: ff_2dff_2dff_2dff_2d

2. Phi: (Start: 0, 0, 0, 0, Stop: 90, 90, 90, 90, Step Size: 90)90)90)90)

3. Theta: (Start: ----180, 180, 180, 180, Stop: 180, 180, 180, 180, Step Size: 2)2)2)2)

2. Click the OKOKOKOK button
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Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ

Create SourceCreate SourceCreate SourceCreate Source

To create source:To create source:To create source:To create source:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the box position

X: ----5.05.05.05.0, Y: ----0.24750.24750.24750.2475, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 0.00.00.00.0, dY: 0.4950.4950.4950.495, dZ: 0.160.160.160.16, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: SourceSourceSourceSource

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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Assign ExcitationAssign ExcitationAssign ExcitationAssign Excitation

To select the object Source:To select the object Source:To select the object Source:To select the object Source:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: SourceSourceSourceSource

2. Click the OK OK OK OK button

NoteNoteNoteNote:  You can also select the object from the Model 

Tree

To assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitation

1. Select the menu item HFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped Port

2. Lumped Port : General 

1. Name: p1p1p1p1, 

2. Resistance: 50505050

3. Reactance: 0000

4. Click the NextNextNextNext button

3. Lumped Port : Terminals

1. Number of Terminals: 1111, 

2. For T1T1T1T1, click the UndefinedUndefinedUndefinedUndefined column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: ----5.05.05.05.0, Y: 0.00.00.00.0, Z: 0.160.160.160.16, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: ----0.160.160.160.16, Press the EnterEnterEnterEnter key

5. Click the NextNextNextNext button

6. Click the Finish Finish Finish Finish button
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Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 2.25 GHz: 2.25 GHz: 2.25 GHz: 2.25 GHz

Maximum Number of Passes: 20202020

Maximum Delta S: 0.020.020.020.02

2. Click the OKOKOKOK button

Adding a Frequency SweepAdding a Frequency SweepAdding a Frequency SweepAdding a Frequency Sweep

To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:

1. Select the menu item HFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add Sweep

1. Select Solution Setup: Setup1 Setup1 Setup1 Setup1 

2. Click the OKOKOKOK button

2. Edit Sweep Window:

1. Sweep Type: Fast: Fast: Fast: Fast

2. Frequency Setup Type: Linear Count: Linear Count: Linear Count: Linear Count

Start: 1.0GHz1.0GHz1.0GHz1.0GHz

Stop: 3.5GHz: 3.5GHz: 3.5GHz: 3.5GHz

Count: 201: 201: 201: 201

Save Fields: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_slotpatchhfss_slotpatchhfss_slotpatchhfss_slotpatch

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 
Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze All
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button
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Create Reports

Create Terminal SCreate Terminal SCreate Terminal SCreate Terminal S----Parameter Plot Parameter Plot Parameter Plot Parameter Plot ---- MagnitudeMagnitudeMagnitudeMagnitude

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Domain: SweepSweepSweepSweep

3. Click the YYYY tab

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: St(p1,p1), St(p1,p1), St(p1,p1), St(p1,p1), 

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button

4. Select the menu Report 2D > Mark All TracesReport 2D > Mark All TracesReport 2D > Mark All TracesReport 2D > Mark All Traces

1. Click the MinMinMinMin button
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Far Field Overlays

Create Far Field OverlayCreate Far Field OverlayCreate Far Field OverlayCreate Far Field Overlay

To create a 2D polar far field plot :To create a 2D polar far field plot :To create a 2D polar far field plot :To create a 2D polar far field plot :

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Far FieldsFar FieldsFar FieldsFar Fields

2. Display Type: Radiation PatternRadiation PatternRadiation PatternRadiation Pattern

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Geometry: ff_2dff_2dff_2dff_2d

3. In the SweepsSweepsSweepsSweeps tab, select PhiPhiPhiPhi under the NameNameNameName column, and on the 
drop list, select ThetaThetaThetaTheta. This changes the primary sweep to Theta.

4. In the SweepsSweepsSweepsSweeps tab, select the row labeled FreqFreqFreqFreq and select the 

frequency 2.32.32.32.3 from the list.

5. In the MagMagMagMag tab

1. Category: GainGainGainGain

2. Quantity: GainPhiGainPhiGainPhiGainPhi, , , , GainThetaGainThetaGainThetaGainTheta

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

6. Click the DoneDoneDoneDone button
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5.5-1

Specific Absorption Rate
This example is intended to show you how to create, simulate, and analyze a 

simple phantom, which is commonly used to calibrate Specific Absorption Rate 

test equipment, using the Ansoft HFSS Design Environment.

With the explosion of consumer demand for wireless devices, consumers and the 

media have become aware of and are concerned with the biological effects of 

long-term exposure to radio frequency radiation (RFR).  To ensure public safety, 

the Federal Communication Commission (FCC) has developed safety standards 

that wireless devices are required to meet in order to be sold in the US (Similar 
guidelines exist in other countries). The quantity used to quantify the amount of 

energy absorbed is the Specific Absorption Rate or SAR.

Nominal Design:Nominal Design:Nominal Design:Nominal Design:

Bowl:Bowl:Bowl:Bowl:

Inner radius = 106.5= 106.5= 106.5= 106.5±±±±5mm 5mm 5mm 5mm 

Thickness = 5= 5= 5= 5±±±±0.5mm. 0.5mm. 0.5mm. 0.5mm. 

Opening = d2 =170mm170mm170mm170mm

εr= 4.6= 4.6= 4.6= 4.6

Antenna:Antenna:Antenna:Antenna:

Overall Length = 168mm168mm168mm168mm

Gap between dipoles = 1mm1mm1mm1mm

Wire Diameter = 3.6mm3.6mm3.6mm3.6mm

Fluid:Fluid:Fluid:Fluid:

εr = 42.9 = 42.9 = 42.9 = 42.9 ±±±±5%5%5%5%

σ= 0.9 = 0.9 = 0.9 = 0.9 ±±±±10%10%10%10%

ρ= 1 g/cm= 1 g/cm= 1 g/cm= 1 g/cm3333

Level = d1 = 13.4 cm13.4 cm13.4 cm13.4 cm
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5.5-2

Ansoft HFSS Analysis of Specific Absorption Rate for Flat 

Phantom Measurement Standard Outlined in IEEE P1528-2002
Reference: Draft  Recommended Standard for Determining the Spatial Peak 
Specific Absorption Rate (SAR) in the Human Head from Wireless 
Communication Devices: Measurement Technique

The table below summarizes the data from an Ansoft HFSS analysis of flat 

phantom models as described in the IEEE draft standard for SAR measurements.

In general there is excellent agreement between the HFSS simulations and 

measurements. The possible exception would be the Local SAR above the 

feedpoint. This is likely due to the use of 50 Ω lumped gap sources as an
approximation to the balun feed for the dipoles. Calculation of 1g and 10g SAR 

was done via the fields calculator on explicitly defined volumes in the flat 

phantom located immediately below the feed point 

HFSS results: Measured data in parenthesis, from Table 8-1 of paper

8.8 (9.5)157.66 (140.2)26.48 (25.7)65.81 (63.8)3000

8.09 (7.7)115 (104.2)25.42 (24.0)55.42 (52.4)2450

6.54 (6.6)78.02 (72.1)21.21 (20.5)40.97 (39.7)1900

6.85 (6.8)74.39 (69.5)20.45 (19.8)39.36 (38.1)1800

6.54 (6.5)53.90 (50.2)16.50 (16.0)29.83 (29.0)1450

5.47 (5.4)17.01 (16.4)7.02 (6.9)10.98 (10.8)900

4.93 (4.9)14.71 (14.1)6.26 (6.2)9.62 (9.5)835

3.28 (3.2)7.59 (7.2)3.31 (3.3)4.98 (4.9)450

2.20 (2.1)4.63 (4.4)2.07 (2.0)3.06 (3.0)300

Local SAR at 
surface (y= 
2cm offset 

from 
feedpoint)

Local SAR at 
surface 
(above 

feedpoint)

10g SAR1g SARFrequency 
(MHz)
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5.5-3

Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select 

the Ansoft > HFSS 10Ansoft > HFSS 10Ansoft > HFSS 10Ansoft > HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button



Ansoft High Frequency Structure Simulator v10 User’s Guide 

5.5
Example – Specific Absorption Rate

5.5-4

Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, click the � On the Standard toolbar, or select 

the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose Driven ModalDriven ModalDriven ModalDriven Modal

2. Click the OKOKOKOK button
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5.5-5

Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: mmmmmmmm

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type pecpecpecpec in the Search by NameSearch by NameSearch by NameSearch by Name field

2. Click the OKOKOKOK button
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5.5-6

Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:

1. Select the menu item 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: ----6.86.86.86.8, Press the Enter Enter Enter Enter key 

Create Dipole Antenna Arm 1Create Dipole Antenna Arm 1Create Dipole Antenna Arm 1Create Dipole Antenna Arm 1

To set grid planeTo set grid planeTo set grid planeTo set grid plane

1. Select the menu item 3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ

To create the dipole antenna:To create the dipole antenna:To create the dipole antenna:To create the dipole antenna:

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.0, : 0.0, : 0.0, : 0.0, Y: : : : ----84.0, 84.0, 84.0, 84.0, Z: 0.0, : 0.0, : 0.0, : 0.0, Press the Enter Enter Enter Enter key 

3. Using the coordinate entry fields, enter the radius:

dX: 1.8, : 1.8, : 1.8, : 1.8, dY: 0.0, : 0.0, : 0.0, : 0.0, dZ: 0.0, : 0.0, : 0.0, : 0.0, Press the Enter Enter Enter Enter key 

4. Using the coordinate entry fields, enter the height:

dX: 0.0, : 0.0, : 0.0, : 0.0, dY: 83.5, : 83.5, : 83.5, : 83.5, dZ: 0.0, : 0.0, : 0.0, : 0.0, Press the Enter Enter Enter Enter key 

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: DipoleDipoleDipoleDipole

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  Or press the CTRL+DCTRL+DCTRL+DCTRL+D key



Ansoft High Frequency Structure Simulator v10 User’s Guide 

5.5
Example – Specific Absorption Rate

5.5-7

Create Dipole Antenna Arm 2Create Dipole Antenna Arm 2Create Dipole Antenna Arm 2Create Dipole Antenna Arm 2

To create arm 2:To create arm 2:To create arm 2:To create arm 2:

1. Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible.  .  .  .  Or press the CTRL+ACTRL+ACTRL+ACTRL+A key.

2. Select the menu item, Edit > Duplicate > MirrorEdit > Duplicate > MirrorEdit > Duplicate > MirrorEdit > Duplicate > Mirror.

1. Input the anchor point of the mirror plane:

X: 0.0, : 0.0, : 0.0, : 0.0, Y: 0.0, : 0.0, : 0.0, : 0.0, Z: 0.0, : 0.0, : 0.0, : 0.0, Press the Enter Enter Enter Enter key

2. Input the target point of the vector normal to the mirror plane:

dX: 0.0, : 0.0, : 0.0, : 0.0, dY: 1.0, : 1.0, : 1.0, : 1.0, dZdZdZdZ: 0.0, : 0.0, : 0.0, : 0.0, Press the Enter Enter Enter Enter key 

Group the Dipole Antenna ArmsGroup the Dipole Antenna ArmsGroup the Dipole Antenna ArmsGroup the Dipole Antenna Arms

To group the dipole arms:To group the dipole arms:To group the dipole arms:To group the dipole arms:

1. Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible

2. Select the menu item, 3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite

Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY

Create SourceCreate SourceCreate SourceCreate Source

To create source:To create source:To create source:To create source:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the rectangle position

X: : : : ----1.8, 1.8, 1.8, 1.8, Y: : : : ----0.5, 0.5, 0.5, 0.5, Z: 0.0, : 0.0, : 0.0, : 0.0, Press the Enter Enter Enter Enter key 

3. Using the coordinate entry fields, enter the opposite corner of the rectangle:

dX: 3.6, : 3.6, : 3.6, : 3.6, dY: 1.0, : 1.0, : 1.0, : 1.0, dZ: 0.0, : 0.0, : 0.0, : 0.0, Press the Enter Enter Enter Enter key 

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: SourceSourceSourceSource

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 
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Assign ExcitationAssign ExcitationAssign ExcitationAssign Excitation

To select the object Source:To select the object Source:To select the object Source:To select the object Source:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: SourceSourceSourceSource

2. Click the OK OK OK OK button

NoteNoteNoteNote:  You can also select the object from the Model Tree

To assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitation

1. Select the menu item HFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped Port

2. Lumped Port : General 

1. Name: p1p1p1p1, 

2. Resistance: 50505050

3. Reactance: 0000

4. Click the NextNextNextNext button

3. Lumped Port : Modes

1. Number of Modes: 1111, 

2. For Mode 1Mode 1Mode 1Mode 1, click the None None None None column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: 0.0, : 0.0, : 0.0, : 0.0, Y: : : : ----0.5, 0.5, 0.5, 0.5, Z: 0.0, : 0.0, : 0.0, : 0.0, Press the Enter Enter Enter Enter key

4. Using the coordinate entry fields, enter the vertex

dX: 0.0, : 0.0, : 0.0, : 0.0, dY: 1.0, : 1.0, : 1.0, : 1.0, dZ: 0.0, : 0.0, : 0.0, : 0.0, Press the Enter Enter Enter Enter key 

5. Click the NextNextNextNext button

6. Click the FinishFinishFinishFinish button



Ansoft High Frequency Structure Simulator v10 User’s Guide 

5.5
Example – Specific Absorption Rate

5.5-9

Add New MaterialAdd New MaterialAdd New MaterialAdd New Material

To add a new material:To add a new material:To add a new material:To add a new material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. From the Select Definition window, click the Add MaterialAdd MaterialAdd MaterialAdd Material button

3. View/Edit Material Window:

1. For the Material NameMaterial NameMaterial NameMaterial Name type: My_BowlMy_BowlMy_BowlMy_Bowl

2. For the ValueValueValueValue of Relative PermittivityRelative PermittivityRelative PermittivityRelative Permittivity type: 4.64.64.64.6

3. Click the OKOKOKOK button

4. Click the OKOKOKOK button
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Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: GlobalGlobalGlobalGlobal

2. Click the SelectSelectSelectSelect button

Create BowlCreate BowlCreate BowlCreate Bowl

To create the bowl:To create the bowl:To create the bowl:To create the bowl:

1. Select the menu item Draw > SphereDraw > SphereDraw > SphereDraw > Sphere

2. Using the coordinate entry fields, enter the sphere position

X: 0.0, : 0.0, : 0.0, : 0.0, Y: 0.0, : 0.0, : 0.0, : 0.0, Z: 111.5, : 111.5, : 111.5, : 111.5, Press the Enter Enter Enter Enter key

3. Using the coordinate entry fields, enter the radius:

dX: 111.5, : 111.5, : 111.5, : 111.5, dY: 0.0, : 0.0, : 0.0, : 0.0, dZ: 0.0, : 0.0, : 0.0, : 0.0, Press the Enter Enter Enter Enter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: BowlBowlBowlBowl

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View....

Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:

1. Select the menu item 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: 0.0, : 0.0, : 0.0, : 0.0, Y: 0.0, : 0.0, : 0.0, : 0.0, Z: 164.0, : 164.0, : 164.0, : 164.0, Press the Enter Enter Enter Enter key
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Create the Opening in the BowlCreate the Opening in the BowlCreate the Opening in the BowlCreate the Opening in the Bowl

To select the object Bowl:To select the object Bowl:To select the object Bowl:To select the object Bowl:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: BowlBowlBowlBowl

2. Click the OK OK OK OK button

To select the split the bowl object:To select the split the bowl object:To select the split the bowl object:To select the split the bowl object:

1. Select the menu item 3D Modeler > Boolean > Split3D Modeler > Boolean > Split3D Modeler > Boolean > Split3D Modeler > Boolean > Split

2. Split Window

1. Split Plane: XYXYXYXY

2. Keep Fragments: Negative SideNegative SideNegative SideNegative Side

3. Click the OKOKOKOK button

Add New MaterialAdd New MaterialAdd New MaterialAdd New Material

To add a new material:To add a new material:To add a new material:To add a new material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. From the Select Definition window, click the Add MaterialAdd MaterialAdd MaterialAdd Material button

3. View/Edit Material Window:

1. For the Material NameMaterial NameMaterial NameMaterial Name type: My_BrainFluidMy_BrainFluidMy_BrainFluidMy_BrainFluid

2. For the ValueValueValueValue of Relative PermittivityRelative PermittivityRelative PermittivityRelative Permittivity type: 42.942.942.942.9

3. For the ValueValueValueValue of Bulk ConductivityBulk ConductivityBulk ConductivityBulk Conductivity type: 0.90.90.90.9

4. Click the OKOKOKOK button

4. Click the OKOKOKOK button

Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: GlobalGlobalGlobalGlobal

2. Click the SelectSelectSelectSelect button
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Create Brain FluidCreate Brain FluidCreate Brain FluidCreate Brain Fluid

To create the brain fluid:To create the brain fluid:To create the brain fluid:To create the brain fluid:

1. Select the menu item Draw > SphereDraw > SphereDraw > SphereDraw > Sphere

2. Using the coordinate entry fields, enter the sphere position

X: 0.0, Y: 0.0, Z: 111.5, X: 0.0, Y: 0.0, Z: 111.5, X: 0.0, Y: 0.0, Z: 111.5, X: 0.0, Y: 0.0, Z: 111.5, Press the Enter Enter Enter Enter key

3. Using the coordinate entry fields, enter the radius:

dXdXdXdX: 106.5, : 106.5, : 106.5, : 106.5, dYdYdYdY: 0.0, : 0.0, : 0.0, : 0.0, dZdZdZdZ: 0.0, : 0.0, : 0.0, : 0.0, Press the Enter Enter Enter Enter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: BrainFluidBrainFluidBrainFluidBrainFluid

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View....

Create the Shell of the BowlCreate the Shell of the BowlCreate the Shell of the BowlCreate the Shell of the Bowl

To select the objects Bowl and To select the objects Bowl and To select the objects Bowl and To select the objects Bowl and BrainFluidBrainFluidBrainFluidBrainFluid::::

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Bowl, Bowl, Bowl, Bowl, BrainFluidBrainFluidBrainFluidBrainFluid

2. Click the OK OK OK OK button

To complete the bowl:To complete the bowl:To complete the bowl:To complete the bowl:

1. Select the menu item 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 

2. Subtract Window

Blank Parts: BowlBowlBowlBowl

Tool Parts: BrainFluidBrainFluidBrainFluidBrainFluid

Clone tool objects before subtracting: � CheckedCheckedCheckedChecked

Click the OKOKOKOK button
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Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:

1. Select the menu item 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: 0.0, : 0.0, : 0.0, : 0.0, Y: 0.0, : 0.0, : 0.0, : 0.0, Z: 134.0, : 134.0, : 134.0, : 134.0, Press the Enter Enter Enter Enter key

Set the Fluid LevelSet the Fluid LevelSet the Fluid LevelSet the Fluid Level

To select the object To select the object To select the object To select the object BrainFluidBrainFluidBrainFluidBrainFluid::::

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: BrainFluidBrainFluidBrainFluidBrainFluid

2. Click the OK OK OK OK button

To select the split the bowl object:To select the split the bowl object:To select the split the bowl object:To select the split the bowl object:

1. Select the menu item 3D Modeler > Boolean > Split3D Modeler > Boolean > Split3D Modeler > Boolean > Split3D Modeler > Boolean > Split

2. Split Window

1. Split Plane: XYXYXYXY

2. Keep Fragments: Negative SideNegative SideNegative SideNegative Side

3. Click the OKOKOKOK button

Create a SAR Calculation LineCreate a SAR Calculation LineCreate a SAR Calculation LineCreate a SAR Calculation Line

To create a line:To create a line:To create a line:To create a line:

1. Select the menu item Draw > LineDraw > LineDraw > LineDraw > Line

2. Using the coordinate entry fields, enter the vertex point:

X: 0.0, Y: 0.0, Z: X: 0.0, Y: 0.0, Z: X: 0.0, Y: 0.0, Z: X: 0.0, Y: 0.0, Z: ----129.0, 129.0, 129.0, 129.0, Press the Enter Enter Enter Enter key

3. Using the coordinate entry fields, enter the vertex point:

X: 0.0, Y: 0.0, Z: 0.0, X: 0.0, Y: 0.0, Z: 0.0, X: 0.0, Y: 0.0, Z: 0.0, X: 0.0, Y: 0.0, Z: 0.0, Press the Enter Enter Enter Enter key

4. Click the Enter Enter Enter Enter key for the same point to end line creation

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: SAR_LineSAR_LineSAR_LineSAR_Line

3. Click the OKOKOKOK button
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Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: RelativeCS1RelativeCS1RelativeCS1RelativeCS1

2. Click the SelectSelectSelectSelect button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose vacuumvacuumvacuumvacuum

Create Air BoxCreate Air BoxCreate Air BoxCreate Air Box

To create the air box:To create the air box:To create the air box:To create the air box:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: : : : ----155.0, 155.0, 155.0, 155.0, Y: : : : ----155.0, 155.0, 155.0, 155.0, Z: : : : ----44.0, 44.0, 44.0, 44.0, Press the Enter Enter Enter Enter key

3. Using the coordinate entry fields, enter the opposite corner of the base 

rectangle:

dX: 310.0, : 310.0, : 310.0, : 310.0, dY: 310.0, : 310.0, : 310.0, : 310.0, dZ: 257.0, : 257.0, : 257.0, : 257.0, Press the Enter Enter Enter Enter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: AirAirAirAir

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 
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Create Radiation BoundaryCreate Radiation BoundaryCreate Radiation BoundaryCreate Radiation Boundary

To select the object Air:To select the object Air:To select the object Air:To select the object Air:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: AirAirAirAir

2. Click the OK OK OK OK button

To create a radiation boundaryTo create a radiation boundaryTo create a radiation boundaryTo create a radiation boundary

1. Select the menu item HFSS > Boundaries > Assign > RadiationHFSS > Boundaries > Assign > RadiationHFSS > Boundaries > Assign > RadiationHFSS > Boundaries > Assign > Radiation

2. Radiation Boundary Window

Name: Rad1Rad1Rad1Rad1

Click the OKOKOKOK button

Create a Radiation SetupCreate a Radiation SetupCreate a Radiation SetupCreate a Radiation Setup

To define the radiation setupTo define the radiation setupTo define the radiation setupTo define the radiation setup

1. Select the menu item HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite 
SphereSphereSphereSphere

2. Far Field Radiation Sphere Setup dialog

1. Select the Infinite SphereInfinite SphereInfinite SphereInfinite Sphere Tab

1. Name: ff_2dff_2dff_2dff_2d

2. Phi: (Start: 0, 0, 0, 0, Stop: 90, 90, 90, 90, Step Size: 90)90)90)90)

3. Theta: (Start: ----180, 180, 180, 180, Stop: 180, 180, 180, 180, Step Size: 2)2)2)2)

2. Click the OKOKOKOK button
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Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 0.835GHz: 0.835GHz: 0.835GHz: 0.835GHz

Maximum Number of Passes: 20202020

Maximum Delta S: 0.020.020.020.02

2. Click the OKOKOKOK button

Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_sarhfss_sarhfss_sarhfss_sar

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 

Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze All
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button
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Create Reports

Create SCreate SCreate SCreate S----Parameter Plot vs. Adaptive PassParameter Plot vs. Adaptive PassParameter Plot vs. Adaptive PassParameter Plot vs. Adaptive Pass

Note: Note: Note: Note: If this report is created prior or during the solution process, a real-time 

update of the results are displayed

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Modal S ParametersModal S ParametersModal S ParametersModal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Adaptive1Setup1: Adaptive1Setup1: Adaptive1Setup1: Adaptive1

2. Click the YYYY tab

1. Category: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Quantity: St(p1,p1), St(p1,p1), St(p1,p1), St(p1,p1), 

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

3. Click the DoneDoneDoneDone button
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Create SAR PlotCreate SAR PlotCreate SAR PlotCreate SAR Plot

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: FieldsFieldsFieldsFields

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Setup1: Setup1: Setup1: LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Geometry: : : : SAR_LineSAR_LineSAR_LineSAR_Line

3. Click the YYYY tab

1. Category: Calculator ExpressionsCalculator ExpressionsCalculator ExpressionsCalculator Expressions

2. Quantity: Local_SARLocal_SARLocal_SARLocal_SAR, , , , Average_SARAverage_SARAverage_SARAverage_SAR

3. Function: <none><none><none><none>

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button
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Field Overlays

Create Field OverlayCreate Field OverlayCreate Field OverlayCreate Field Overlay

Select the Global YZ PlaneSelect the Global YZ PlaneSelect the Global YZ PlaneSelect the Global YZ Plane

1. Using the Model Tree, expand PlanesPlanesPlanesPlanes

1. Select Global:YZGlobal:YZGlobal:YZGlobal:YZ

2. Select the menu item HFSS > Fields >  HFSS > Fields >  HFSS > Fields >  HFSS > Fields >  FieldsFieldsFieldsFields >  E  >  >  E  >  >  E  >  >  E  >  Mag_EMag_EMag_EMag_E

3. Create Field Plot Window

1. Solution: Setup1 :  Setup1 :  Setup1 :  Setup1 :  LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Quantity: Mag_EMag_EMag_EMag_E

3. In Volume: BrainFluidBrainFluidBrainFluidBrainFluid

4. Click the DoneDoneDoneDone button

To modify the attributes of a field plot:To modify the attributes of a field plot:To modify the attributes of a field plot:To modify the attributes of a field plot:

1. Select the menu item HFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot Attributes

2. Select Plot Folder Window:

1. Select: E FieldE FieldE FieldE Field

2. Click the OKOKOKOK button

3. E-Field1 Window:

1. Click the Scale Scale Scale Scale tab

1. Select Use LimitsUse LimitsUse LimitsUse Limits

2. Min: 2222

3. Max: 200200200200

4. Scale: LogLogLogLog

2. Click the CloseCloseCloseClose button
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Far Field Overlays

Create Far Field OverlayCreate Far Field OverlayCreate Far Field OverlayCreate Far Field Overlay

To create a 2D polar far field plot :To create a 2D polar far field plot :To create a 2D polar far field plot :To create a 2D polar far field plot :

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Far FieldsFar FieldsFar FieldsFar Fields

2. Display Type: Radiation PatternRadiation PatternRadiation PatternRadiation Pattern

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Setup1: Setup1: Setup1: LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Geometry: ff_2dff_2dff_2dff_2d

3. In the SweepsSweepsSweepsSweeps tab, select PhiPhiPhiPhi under the NameNameNameName column, and on the 
drop list, select ThetaThetaThetaTheta. This changes the primary sweep to Theta.

4. In the MagMagMagMag tab

1. Category: GainGainGainGain

2. Quantity: GainL3YGainL3YGainL3YGainL3Y

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

5. Click the DoneDoneDoneDone button
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5.6

5.6-1

The CPW Fed Bowtie Antenna
This example is intended to show you how to create, simulate, and analyze a 

Coplanar Waveguide (CPW) fed Bowtie antenna using the Ansoft HFSS Design 

Environment.  

A Lumped PortLumped PortLumped PortLumped Port excitation will be used for the CPW feed.

Reference: 
Guiping Zheng, A. Z. Elsherbeni, and C. E. Smith, “A coplanar waveguide bow-
tie aperture antenna,” Antennas and Propagation Society International Antennas and Propagation Society International Antennas and Propagation Society International Antennas and Propagation Society International 

SymposiumSymposiumSymposiumSymposium, 2002.  IEEE, Volume 1, 16-21 June 2002, Page 564-567.

Sub1 (Dielectric)

Copper Cladding w/ Cutout

2.0mm
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5.6

5.6-2

Design Review
1. The CPW slots and antenna shape will be openings in a metallized plane. Consider 

how the port will look

2. The antenna will be analyzed over a frequency range of 8 – 12 GHz.  How large 

should the air volume be?

Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select 

the Ansoft > HFSS 10Ansoft > HFSS 10Ansoft > HFSS 10Ansoft > HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 

following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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5.6

5.6-3

Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, click the � On the Standard toolbar, or 

select the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose Driven ModalDriven ModalDriven ModalDriven Modal

2. Click the OKOKOKOK button
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5.6

5.6-4

Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: mmmmmmmm

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type “ArlonArlonArlonArlon CCCC” in the Search by NameSearch by NameSearch by NameSearch by Name field and select ArlonArlonArlonArlon CuCladCuCladCuCladCuClad

217 (tm)217 (tm)217 (tm)217 (tm) from the table below.

2. Click the OKOKOKOK button
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5.6

5.6-5

Create SubstrateCreate SubstrateCreate SubstrateCreate Substrate

To create the substrate:To create the substrate:To create the substrate:To create the substrate:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----17.017.017.017.0, Y: ----32323232, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

2. Using the coordinate entry fields, enter the opposite corner of the box

dX: 34.034.034.034.0, dY: 64.064.064.064.0, dZ: ----2.02.02.02.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Sub1Sub1Sub1Sub1

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View or press the CTRL+DCTRL+DCTRL+DCTRL+D key
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5.6

5.6-6

Create Copper CladdingCreate Copper CladdingCreate Copper CladdingCreate Copper Cladding

To create the ground:To create the ground:To create the ground:To create the ground:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the Drawing Plane dropdown, set the current plane to XYXYXYXY

3. Using graphical snapping, draw a rectangle to cover the top face of Sub1Sub1Sub1Sub1

First corner snap X: ----17.017.017.017.0, Y: ----32.032.032.032.0, Z: 0.00.00.00.0

Second corner snap dX: 34.034.034.034.0, dY: 64.064.064.064.0, dZ: 0.00.00.00.0

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: CuCladCuCladCuCladCuClad

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View
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5.6

5.6-7

Assign a Finite Conductivity boundary to the Copper CladdingAssign a Finite Conductivity boundary to the Copper CladdingAssign a Finite Conductivity boundary to the Copper CladdingAssign a Finite Conductivity boundary to the Copper Cladding

To select the rectangle:To select the rectangle:To select the rectangle:To select the rectangle:

1. In the 3D Modeler Design Tree, right-click on ModelModelModelModel and select Expand AllExpand AllExpand AllExpand All

2. Find the entry name CuCladCuCladCuCladCuClad under the category Not AssignedNot AssignedNot AssignedNot Assigned and click it to 

select.

To assign the Finite Conductivity boundaryTo assign the Finite Conductivity boundaryTo assign the Finite Conductivity boundaryTo assign the Finite Conductivity boundary

1. Right-Click on the 3D Modeler view, and select the menu item Assign Assign Assign Assign 
Boundary > Finite ConductivityBoundary > Finite ConductivityBoundary > Finite ConductivityBoundary > Finite Conductivity

2. Finite Conductivity Boundary window

1. Name: Cu_boundCu_boundCu_boundCu_bound

2. Beneath Permeability, Check � Use MaterialUse MaterialUse MaterialUse Material

3. Click the block showing ArlonArlonArlonArlon CuCladCuCladCuCladCuClad 217 (tm)217 (tm)217 (tm)217 (tm) to open the Material 

Listing

4. Type “cocococo” in the Name field and select coppercoppercoppercopper from the table below, 
and click OKOKOKOK

5. Leave Unchecked ���� Infinite Ground PlaneInfinite Ground PlaneInfinite Ground PlaneInfinite Ground Plane

6. Click the OK OK OK OK button
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5.6

5.6-8

Create Feed Cut OutCreate Feed Cut OutCreate Feed Cut OutCreate Feed Cut Out

To create the feed gap:To create the feed gap:To create the feed gap:To create the feed gap:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the first corner position

X: ----0.50.50.50.5, Y: 0.50.50.50.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the diagonal corner:

dX: 13.013.013.013.0, dY: 0.60.60.60.6, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. Leave the ValueValueValueValue of NameNameNameName as Rect1Rect1Rect1Rect1

3. Click the OKOKOKOK button

Create Bowtie armCreate Bowtie armCreate Bowtie armCreate Bowtie arm

To create the bowtie polygon:To create the bowtie polygon:To create the bowtie polygon:To create the bowtie polygon:

1. Select the menu item Draw > LineDraw > LineDraw > LineDraw > Line

2. Snap to the first vertex position

Location X: ----0.50.50.50.5, Y: 0.50.50.50.5, Z: 0.00.00.00.0

3. Using the coordinate entry fields, enter the second vertex

X: ----6.76.76.76.7, Y: 21.021.021.021.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the third vertex

X: 6.06.06.06.0, Y: 21.021.021.021.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

5. Using the coordinate entry fields, enter the fourth vertex

X: 0.50.50.50.5, Y: 1.11.11.11.1, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

6. Double-click on the starting vertex to finish and close the polyline.

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. Set the ValueValueValueValue of NameNameNameName as BowtieBowtieBowtieBowtie

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View



Ansoft High Frequency Structure Simulator v10 User’s Guide 

Example – CPW Fed Bowtie Antenna

5.6

5.6-9

Unite Feed and BowtieUnite Feed and BowtieUnite Feed and BowtieUnite Feed and Bowtie

To select the objects Bowtie and Rect1To select the objects Bowtie and Rect1To select the objects Bowtie and Rect1To select the objects Bowtie and Rect1

1. In the 3D Modeler Design Tree, right-click on ModelModelModelModel and select Expand AllExpand AllExpand AllExpand All

2. Under the category Unassigned Unassigned Unassigned Unassigned select Bowtie Bowtie Bowtie Bowtie and Rect1.  Rect1.  Rect1.  Rect1.  (Use the CTRLCTRLCTRLCTRL

key to select multiple objects)

To complete the bowtie arm:To complete the bowtie arm:To complete the bowtie arm:To complete the bowtie arm:

1. Select the menu item 3D Modeler > Boolean > Unite.  3D Modeler > Boolean > Unite.  3D Modeler > Boolean > Unite.  3D Modeler > Boolean > Unite.  (The united object 
will take the name of the first item selected, Bowtie Bowtie Bowtie Bowtie 

Mirror the BowtieMirror the BowtieMirror the BowtieMirror the Bowtie

To create the other side of the Bowtie:To create the other side of the Bowtie:To create the other side of the Bowtie:To create the other side of the Bowtie:

1. Select the object BowtieBowtieBowtieBowtie from the 3D Modeler Design Tree

2. Select the menu item Edit > Duplicate > MirrorEdit > Duplicate > MirrorEdit > Duplicate > MirrorEdit > Duplicate > Mirror

3. Set the starting vertex of the mirror normal using the coordinate entry box:

Location X: 0000, Y: 0000, Z: 0000

4. Set the ending vertex of the mirror normal using the coordinate entry box

Location dX: 0000, dY: 1.01.01.01.0, dZ: 0.0 0.0 0.0 0.0 
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5.6
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Open the Bowtie Aperture in the Copper CladdingOpen the Bowtie Aperture in the Copper CladdingOpen the Bowtie Aperture in the Copper CladdingOpen the Bowtie Aperture in the Copper Cladding

To subtract the Bowtie from the CladdingTo subtract the Bowtie from the CladdingTo subtract the Bowtie from the CladdingTo subtract the Bowtie from the Cladding

1. Select the objects BowtieBowtieBowtieBowtie, Bowtie_1Bowtie_1Bowtie_1Bowtie_1 and CuCladCuCladCuCladCuClad from the 3D Modeler 

Design Tree

2. Select the menu item 3D Modeler > Boolean > Subtract3D Modeler > Boolean > Subtract3D Modeler > Boolean > Subtract3D Modeler > Boolean > Subtract

3. Subtract Window

Blank Parts: CuCladCuCladCuCladCuClad

Tool Parts: BowtieBowtieBowtieBowtie, Bowtie_1Bowtie_1Bowtie_1Bowtie_1

Clone tool objects before 

subtracting: � CheckedCheckedCheckedChecked

Click the OKOKOKOK button 

Assign a Mesh Operation on the Bowtie geometryAssign a Mesh Operation on the Bowtie geometryAssign a Mesh Operation on the Bowtie geometryAssign a Mesh Operation on the Bowtie geometry

To assign the mesh operation:To assign the mesh operation:To assign the mesh operation:To assign the mesh operation:

1. Select the objects BowtieBowtieBowtieBowtie and Bowtie_1Bowtie_1Bowtie_1Bowtie_1 from the 3D Modeler 

Design Tree

2. Select the menu item HFSS > Mesh Operation > Assign > On Selection > HFSS > Mesh Operation > Assign > On Selection > HFSS > Mesh Operation > Assign > On Selection > HFSS > Mesh Operation > Assign > On Selection > 
Length BasedLength BasedLength BasedLength Based

3. Element Length Based Refinement Window :

Name Length1Length1Length1Length1

Restrict Length of Elements: 

� CheckedCheckedCheckedChecked

Maximum Length of Elements: 
3 mm3 mm3 mm3 mm

Restrict the Number of Elements: 

���� UncheckedUncheckedUncheckedUnchecked

4. Click the OKOKOKOK button
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5.6

5.6-11

Create the Lumped PortCreate the Lumped PortCreate the Lumped PortCreate the Lumped Port

To draw the port rectangle:To draw the port rectangle:To draw the port rectangle:To draw the port rectangle:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the first corner position

X: 12.512.512.512.5, Y: ----0.50.50.50.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the diagonal corner:

dX: ----1.01.01.01.0, dY: 1.01.01.01.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. Enter the ValueValueValueValue of NameNameNameName as P1P1P1P1

3. Click the OKOKOKOK button

To select the object Port1:To select the object Port1:To select the object Port1:To select the object Port1:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: P1P1P1P1

2. Click the OK OK OK OK button
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5.6

5.6-12

Create the Lumped port, cont.Create the Lumped port, cont.Create the Lumped port, cont.Create the Lumped port, cont.

To assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitation

1. Select the menu item HFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped Port

2. Lumped Port : General

1. Name: Port1Port1Port1Port1

2. Resistance: 50 ohm50 ohm50 ohm50 ohm

3. Reactance: 0 ohm0 ohm0 ohm0 ohm

4. Click the NextNextNextNext button

3. Lumped Port : Modes

1. Number of Modes: 1111,

2. In the row for Mode 1111, click None None None None in the Integration Line column and 

select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: 12.512.512.512.5, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex

dX: ----1.01.01.01.0, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Click the FinishFinishFinishFinish button
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5.6

5.6-13

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose vacuum vacuum vacuum vacuum 

Create the Air VolumeCreate the Air VolumeCreate the Air VolumeCreate the Air Volume

The analysis will be performed between 8 – 12 GHz.  Therefore the minimum 
distance between the air volume wall and the radiating aperture should be one 

quarter wavelength at 8 GHz, or 0.25*(3e11/8e9) = 9.375mm.  The following 

dimensions round this up to 9.5mm spacing.

To create the air volumeTo create the air volumeTo create the air volumeTo create the air volume

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the starting position

X: ----17.017.017.017.0, Y: ----32.032.032.032.0, Z: ----9.5 9.5 9.5 9.5 Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the diagonal corner:

dX: 34.034.034.034.0, dY: 64.064.064.064.0, dZ: 19.0 19.0 19.0 19.0 Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: AirBoxAirBoxAirBoxAirBox

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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5.6

5.6-14

Assign the Radiation BoundaryAssign the Radiation BoundaryAssign the Radiation BoundaryAssign the Radiation Boundary

To select the air volumeTo select the air volumeTo select the air volumeTo select the air volume

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: AirBoxAirBoxAirBoxAirBox

2. Click the OK OK OK OK button

To assign the boundary:To assign the boundary:To assign the boundary:To assign the boundary:

1. Right-click in the graphical view and select the Menu pick Assign Boundary > Assign Boundary > Assign Boundary > Assign Boundary > 

Radiation Radiation Radiation Radiation 

2. For the ValueValueValueValue of NameNameNameName type: Rad1Rad1Rad1Rad1

3. Click the OKOKOKOK button

Create a Radiation SetupCreate a Radiation SetupCreate a Radiation SetupCreate a Radiation Setup

To define the radiation setupTo define the radiation setupTo define the radiation setupTo define the radiation setup

1. Select the menu item HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite 
SphereSphereSphereSphere

2. Far Field Radiation Sphere Setup dialog

1. Select the Infinite SphereInfinite SphereInfinite SphereInfinite Sphere Tab

1. Name: ff_allff_allff_allff_all

2. Phi: (Start: ----90, 90, 90, 90, Stop: 90, 90, 90, 90, 

Step Size: 10)10)10)10)

3. Theta: (Start: 0, 0, 0, 0, Stop: 360, 360, 360, 360, 

Step Size: 10)10)10)10)

2. Click the OKOKOKOK button
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5.6

5.6-15

Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 10 GHz: 10 GHz: 10 GHz: 10 GHz

Maximum Number of Passes: 6666

Maximum Delta S: 0.010.010.010.01

2. Click the OKOKOKOK button

Adding a Frequency SweepAdding a Frequency SweepAdding a Frequency SweepAdding a Frequency Sweep

To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:

1. Select the menu item HFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add Sweep

1. Select Solution Setup: Setup1 Setup1 Setup1 Setup1 

2. Click the OKOKOKOK button

2. Edit Sweep Window:

1. Sweep Type: Fast: Fast: Fast: Fast

2. Frequency Setup Type: Linear Step: Linear Step: Linear Step: Linear Step

Start: 8.0GHz8.0GHz8.0GHz8.0GHz

Stop: 12.0GHz: 12.0GHz: 12.0GHz: 12.0GHz

Step: 0.02: 0.02: 0.02: 0.02

Save Fields: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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5.6

5.6-16

Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_cpwbowtiehfss_cpwbowtiehfss_cpwbowtiehfss_cpwbowtie

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 
Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze All
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last Adaptive Setup1, Last Adaptive Setup1, Last Adaptive Setup1, Last Adaptive during solution.

2. Click the CloseCloseCloseClose button when done viewing or simulation complete.
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Create Reports

Create Modal SCreate Modal SCreate Modal SCreate Modal S----Parameter Plot Parameter Plot Parameter Plot Parameter Plot ---- MagnitudeMagnitudeMagnitudeMagnitude

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Modal S ParametersModal S ParametersModal S ParametersModal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Domain: SweepSweepSweepSweep

3. Click the YYYY tab

1. Category: S ParameterS ParameterS ParameterS Parameter

2. Quantity: S(Port1,Port1), S(Port1,Port1), S(Port1,Port1), S(Port1,Port1), 

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button

4. Select the menu Report 2D > Mark All TracesReport 2D > Mark All TracesReport 2D > Mark All TracesReport 2D > Mark All Traces

1. Click the MinMinMinMin button to see the best match displayed

5. Right-click on the graph and select Exit Marker ModeExit Marker ModeExit Marker ModeExit Marker Mode
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5.6

5.6-19

Create Reports

Create Modal SCreate Modal SCreate Modal SCreate Modal S----Parameter Plot Parameter Plot Parameter Plot Parameter Plot –––– ImpedanceImpedanceImpedanceImpedance

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Modal S ParametersModal S ParametersModal S ParametersModal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Domain: SweepSweepSweepSweep

3. Click the YYYY tab

1. Category: Z ParameterZ ParameterZ ParameterZ Parameter

2. Quantity: Z(Port1,Port1), Z(Port1,Port1), Z(Port1,Port1), Z(Port1,Port1), 

3. Function: rererere

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

5. Function: imimimim

6. Click the Add TraceAdd TraceAdd TraceAdd Trace button

7. In the tabular listing of assigned Traces, click the Y1Y1Y1Y1

entry beside im(Z(Port1,Port1))im(Z(Port1,Port1))im(Z(Port1,Port1))im(Z(Port1,Port1)) and from the dropdown 

switch to Y2Y2Y2Y2

4. Click the DoneDoneDoneDone button

5.5.5.5. Note: Note: Note: Note: Since a Lumped Port excitation was used, this plot is not 
deembedded up to the aperture itself.
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5.6-20

Far Field Overlays

Create Far Field OverlayCreate Far Field OverlayCreate Far Field OverlayCreate Far Field Overlay

To create a 2D polar far field plot :To create a 2D polar far field plot :To create a 2D polar far field plot :To create a 2D polar far field plot :

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Far FieldsFar FieldsFar FieldsFar Fields

2. Display Type: Radiation PatternRadiation PatternRadiation PatternRadiation Pattern

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Geometry: ff_allff_allff_allff_all

3. In the SweepsSweepsSweepsSweeps tab:

1. Select PhiPhiPhiPhi under the NameNameNameName column, and on the drop list, 

select ThetaThetaThetaTheta. This changes the primary sweep to Theta.

2. Highlight the second row which now reads PhiPhiPhiPhi.  Uncheck ����

All Values All Values All Values All Values above the list to the right.  Highlight only ----90deg 90deg 90deg 90deg 
and 0deg0deg0deg0deg from this list.

3. Select the row labeled FreqFreqFreqFreq and select the frequency 10.44 10.44 10.44 10.44 

GHzGHzGHzGHz from the list.

4. In the MagMagMagMag tab

1. Category: DirectivityDirectivityDirectivityDirectivity

2. Quantity: DirTotalDirTotalDirTotalDirTotal

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

5. Click the DoneDoneDoneDone button
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5.6-21

To create a 3D polar far field plot :To create a 3D polar far field plot :To create a 3D polar far field plot :To create a 3D polar far field plot :

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Far FieldsFar FieldsFar FieldsFar Fields

2. Display Type: 3D Polar Plot3D Polar Plot3D Polar Plot3D Polar Plot

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Geometry: ff_allff_allff_allff_all

3. In the SweepsSweepsSweepsSweeps tab, select the row labeled FreqFreqFreqFreq and select the 

frequency 10.44 GHz10.44 GHz10.44 GHz10.44 GHz from the list.

4. In the MagMagMagMag tab

1. Category: GainGainGainGain

2. Quantity: GainTotalGainTotalGainTotalGainTotal

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

5. Click the DoneDoneDoneDone button
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5.7

5.7-1

The Endfire Waveguide Array
This example is intended to show you how to create, simulate, and analyze a 

Waveguide array antenna using the Ansoft HFSS Design Environment

A WavePort excitation will be used for the feed

PMLs (Perfectly Matched Layers) will be used for the radiation load

Master/Slave boundary conditions will be used to create the array

Reference: 
[1]   C.A. Balanis, “Antenna Theory – Analysis and Design”, Harper and Row, 

Publishers, Inc., 1982,  ISBN 0-06-040458-2, section 6.2.

[2]   S.W. Lee and W.R. Jones, “On the Suppression of Radiation Nulls and 
Broadband Impedance Matching of Rectangular Waveguide Phased Arrays”, 

IEEE Trans. on Antennas Propagat., vol. AP-19, No. 1, pp. 41-51, Jan. 1971.
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5.7

5.7-2

Design Review
1. Instead of modeling the entire array, we will make use of the master/slave boundary 

conditions and only model a unit cell.

2. Since the Master/Slave boundary conditions also allow us to change the scan angle, 

we will need a better radiation load on the top of the antenna than a simple radiation 

boundary condition. We will need to use a PML.

Ansoft HFSS Design Environment
The following features of the Ansoft HFSS Design Environment are used to create 
this passive device model

3D Solid Modeling

Primitives: BoxBoxBoxBox

Other: Perfectly Matched Layer (PML)Perfectly Matched Layer (PML)Perfectly Matched Layer (PML)Perfectly Matched Layer (PML)

Boundaries/Excitations

Ports: Wave PortsWave PortsWave PortsWave Ports

Boundaries: Master/Slave, ImpedanceMaster/Slave, ImpedanceMaster/Slave, ImpedanceMaster/Slave, Impedance

Analysis

Sweep: None: None: None: None

Results

Cartesian plottingCartesian plottingCartesian plottingCartesian plotting

Field Overlays:

Radiation PatternsRadiation PatternsRadiation PatternsRadiation Patterns

Optimetrics

Parametric sweepParametric sweepParametric sweepParametric sweep

Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select 
the Ansoft > HFSS 10Ansoft > HFSS 10Ansoft > HFSS 10Ansoft > HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10
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5.7

5.7-3

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 

following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : 

� CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button

Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, click the � On the Standard toolbar, or 
select the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....
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5.7

5.7-4

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose Driven ModalDriven ModalDriven ModalDriven Modal

2. Click the OKOKOKOK button

Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: inininin

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, make sure that vacuum is the 
default material
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5.7

5.7-5

Create WaveguideCreate WaveguideCreate WaveguideCreate Waveguide

To create the waveguide:To create the waveguide:To create the waveguide:To create the waveguide:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0000, Y: 0000, Z: 0000, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box

dX: 0.40.40.40.4, dY: 0.90.90.90.9, dZ: 1.01.01.01.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: waveguidewaveguidewaveguidewaveguide

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View or press the CTRL+DCTRL+DCTRL+DCTRL+D keys
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5.7

5.7-6

Create Create Create Create AirboxAirboxAirboxAirbox

To create the To create the To create the To create the airboxairboxairboxairbox::::

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----0.050.050.050.05, Y: ----0.050.050.050.05, Z: 1.01.01.01.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box

dX: 0.50.50.50.5, dY: 1.01.01.01.0, dZ: 1.01.01.01.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: airboxairboxairboxairbox

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View
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5.7

5.7-7

Create PML loadCreate PML loadCreate PML loadCreate PML load

To select the proper face of the To select the proper face of the To select the proper face of the To select the proper face of the airboxairboxairboxairbox::::

1. Select the menu item Edit > Select > FacesEdit > Select > FacesEdit > Select > FacesEdit > Select > Faces

2. Graphically pick the top face of the airbox that was just created.

To assign the PML boundaryTo assign the PML boundaryTo assign the PML boundaryTo assign the PML boundary

1. Select the menu item HFSS > Boundaries > PML Setup WizardHFSS > Boundaries > PML Setup WizardHFSS > Boundaries > PML Setup WizardHFSS > Boundaries > PML Setup Wizard

2. PML Setup Wizard: Cover Objects

1. Select: Create PML Cover Objects on Selected FacesCreate PML Cover Objects on Selected FacesCreate PML Cover Objects on Selected FacesCreate PML Cover Objects on Selected Faces

2. Uniform Layer Thickness: 0.2in0.2in0.2in0.2in

3. Click the NextNextNextNext button

3. PML Setup Wizard: Material Parameters

1. Select: PMLPMLPMLPML Objects acceptObjects acceptObjects acceptObjects accept Free RadiationFree RadiationFree RadiationFree Radiation

1. Min Frequency: 9 GHz: 9 GHz: 9 GHz: 9 GHz

2. Minimum Radiating Distance: 1in: 1in: 1in: 1in

3. Click the NextNextNextNext button

2. Review settings on the PML Setup Wizard: Summary pagePML Setup Wizard: Summary pagePML Setup Wizard: Summary pagePML Setup Wizard: Summary page

3. Click the FinishFinishFinishFinish button

Top face selected PML added
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5.7

5.7-8

Make the PML object visibleMake the PML object visibleMake the PML object visibleMake the PML object visible

By default, the PML wizard will turn off visibility of the PML object once it is 
created. We want to turn it back on again.

1. Select the menu item View >  Active View View >  Active View View >  Active View View >  Active View VisiblilityVisiblilityVisiblilityVisiblility

2. Check the box next to PML_airbox1PML_airbox1PML_airbox1PML_airbox1

3. Click DoneDoneDoneDone

Create the Master/Slave boundary objects

Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ

Draw the Master / Slave objectsDraw the Master / Slave objectsDraw the Master / Slave objectsDraw the Master / Slave objects

To draw the first Master/Slave rectangle:To draw the first Master/Slave rectangle:To draw the first Master/Slave rectangle:To draw the first Master/Slave rectangle:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the box position

X: 0.450.450.450.45, Y: ----0.050.050.050.05, Z: 1.01.01.01.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the rectangle

dX: 0000, dY: 1.01.01.01.0, dZ: 1.21.21.21.2, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: master1master1master1master1

3. Click the OKOKOKOK button

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ

To draw the second Master/Slave rectangle:To draw the second Master/Slave rectangle:To draw the second Master/Slave rectangle:To draw the second Master/Slave rectangle:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the box position

X: ----0.050.050.050.05, Y: ----0.050.050.050.05, Z: 1.01.01.01.0, Press the EnterEnterEnterEnter key

2. Using the coordinate entry fields, enter the opposite corner of the rectangle

dX: 0.50.50.50.5, dY: 0000, dZ: 1.21.21.21.2, Press the EnterEnterEnterEnter key
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5.7

5.7-9

Create the Master/Slave boundary objects (continued)

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: master2master2master2master2

3. Click the OKOKOKOK button

To duplicate the objects to create the slavesTo duplicate the objects to create the slavesTo duplicate the objects to create the slavesTo duplicate the objects to create the slaves

1. Select the menu item Edit > Select > ObjectsEdit > Select > ObjectsEdit > Select > ObjectsEdit > Select > Objects

2. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

3. Select the object, master1master1master1master1

4. Select the menu item Edit > Duplicate > Along LineEdit > Duplicate > Along LineEdit > Duplicate > Along LineEdit > Duplicate > Along Line

5. Using the coordinate entry fields, enter the start position of the duplicate 
vector

X: 0000, Y: 0000, Z: 0000, Press the EnterEnterEnterEnter key

6. Using the coordinate entry fields, enter the end point of the duplicate vector

dX: ----0.50.50.50.5, dY: 0000, dZ: 0000, Press the EnterEnterEnterEnter key

7. When the dialog box pops up requesting the total number of copies, 

change the value to 2222, Press the OKOKOKOK button.

8. Repeat this process for the object master2master2master2master2 using a duplicate vector of 

<0,1,0><0,1,0><0,1,0><0,1,0>

Change Slave boundary names
To change the duplicated master boundary to slave boundaryTo change the duplicated master boundary to slave boundaryTo change the duplicated master boundary to slave boundaryTo change the duplicated master boundary to slave boundary

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: master1_1master1_1master1_1master1_1

2. Click the OK OK OK OK button

3. Select the menu Item: Edit > PropertiesEdit > PropertiesEdit > PropertiesEdit > Properties

4. Change the name to: slave1slave1slave1slave1

5. Repeat the process for master2_1 master2_1 master2_1 master2_1 ���� slave2slave2slave2slave2
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5.7

5.7-10

Assign Master/Slave Boundaries
To create a Master boundaryTo create a Master boundaryTo create a Master boundaryTo create a Master boundary

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: master1master1master1master1

2. Click the OK OK OK OK button

3. Select the menu item HFSS > Boundaries >  Assign > MasterHFSS > Boundaries >  Assign > MasterHFSS > Boundaries >  Assign > MasterHFSS > Boundaries >  Assign > Master

4. Master Boundary window

1. Name: master1master1master1master1

2. Coordinate System: U Vector: click UndefinedUndefinedUndefinedUndefined pulldown

3. Using the coordinate entry fields, enter the start position

X:0.450.450.450.45, Y: ----0.05,0.05,0.05,0.05, Z:1.01.01.01.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the stop position of the 
vector 

dX: 0000, dY: 1111, dZ: 0000, Press the EnterEnterEnterEnter key

5. For the V vector, check the Reverse DirectionReverse DirectionReverse DirectionReverse Direction box

Repeat the process for master2 using the following points:Repeat the process for master2 using the following points:Repeat the process for master2 using the following points:Repeat the process for master2 using the following points:

1. Using the coordinate entry fields, enter the start position

X:0.450.450.450.45, Y: ----0.05,0.05,0.05,0.05, Z:1.01.01.01.0, Press the EnterEnterEnterEnter key

2. Using the coordinate entry fields, enter the stop position of the vector 

dX::::----0.50.50.50.5, dY: 0000, dZ: 0000, Press the EnterEnterEnterEnter key

To create a Slave boundaryTo create a Slave boundaryTo create a Slave boundaryTo create a Slave boundary

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: slave1slave1slave1slave1

2. Click the OK OK OK OK button

3. Select the menu item HFSS > Boundaries >  Assign > SlaveHFSS > Boundaries >  Assign > SlaveHFSS > Boundaries >  Assign > SlaveHFSS > Boundaries >  Assign > Slave

4. Slave Boundary window

1. Name: slave1slave1slave1slave1

2. Master Boundary: click on UndefinedUndefinedUndefinedUndefined pulldown and select Master1Master1Master1Master1

3. Coordinate System: U Vector: click UndefinedUndefinedUndefinedUndefined pulldown

4. Using the coordinate entry fields, enter the start position

X:-0.050.050.050.05, Y: ----0.05,0.05,0.05,0.05, Z:1.01.01.01.0, Press the EnterEnterEnterEnter key
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5.7

5.7-11

Assign Master / Slave Boundaries (continued)
To create a Slave boundary (continued)To create a Slave boundary (continued)To create a Slave boundary (continued)To create a Slave boundary (continued)

1. Using the coordinate entry fields, enter the stop position of the 

vector 

dX: 0000, dY: 1111, dZ: 0000, Press the EnterEnterEnterEnter key

2. Click the NextNextNextNext button

3. Make sure that Use Scan Angles To Calculate Phase DelayUse Scan Angles To Calculate Phase DelayUse Scan Angles To Calculate Phase DelayUse Scan Angles To Calculate Phase Delay is 

checked

1. For PhiPhiPhiPhi, enter 0 deg

2. For ThetaThetaThetaTheta, enter a variable name theta_scantheta_scantheta_scantheta_scan, and hit EnterEnterEnterEnter

3. For the Add VariableAdd VariableAdd VariableAdd Variable dialog, enter 30deg30deg30deg30deg for theta_scantheta_scantheta_scantheta_scan

Repeat the process for slave2:Repeat the process for slave2:Repeat the process for slave2:Repeat the process for slave2:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: slave2slave2slave2slave2

2. Click the OK OK OK OK button

3. Select the menu item HFSS > Boundaries >  Assign > SlaveHFSS > Boundaries >  Assign > SlaveHFSS > Boundaries >  Assign > SlaveHFSS > Boundaries >  Assign > Slave

4. Slave Boundary window

1. Name: slave2slave2slave2slave2

2. Master Boundary: click on UndefinedUndefinedUndefinedUndefined pulldown and select Master2Master2Master2Master2

3. Coordinate System: U Vector: click UndefinedUndefinedUndefinedUndefined pulldown

4. Using the coordinate entry fields, enter the start position

X:0.450.450.450.45, Y: 0.95,0.95,0.95,0.95, Z:1.01.01.01.0, Press the EnterEnterEnterEnter key

5. Using the coordinate entry fields, enter the stop position of the 

vector 

dX::::----0.50.50.50.5, dY: 0000, dZ: 0000, Press the EnterEnterEnterEnter key
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5.7

5.7-12

Assign Impedance Boundary
To create the impedance boundary on the PML object:To create the impedance boundary on the PML object:To create the impedance boundary on the PML object:To create the impedance boundary on the PML object:

1. Select the menu item Edit > Select > FacesEdit > Select > FacesEdit > Select > FacesEdit > Select > Faces

2. Graphically pick the top face of the PML object

3. Select the menu item: HFSS > Boundaries > Assign > ImpedanceHFSS > Boundaries > Assign > ImpedanceHFSS > Boundaries > Assign > ImpedanceHFSS > Boundaries > Assign > Impedance

4. Name: TopLoadTopLoadTopLoadTopLoad

5. Resistance: 377*377*377*377*cos(theta_scancos(theta_scancos(theta_scancos(theta_scan)

6. Reactance: 0000

Create WavePort
To assign waveport to waveguide object:To assign waveport to waveguide object:To assign waveport to waveguide object:To assign waveport to waveguide object:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Face dialog: Select the object waveguidewaveguidewaveguidewaveguide from the left column

3. Select different FaceIDs until the bottom face of the waveguide is 

highlighted.

4. Click OKOKOKOK
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5.7

5.7-13

Create WavePort (continued)
To assign waveport to waveguide object (continued):To assign waveport to waveguide object (continued):To assign waveport to waveguide object (continued):To assign waveport to waveguide object (continued):

1. Select the menu item HFSS > Excitation > Assign > HFSS > Excitation > Assign > HFSS > Excitation > Assign > HFSS > Excitation > Assign > WavePortWavePortWavePortWavePort

2. Name: p1p1p1p1

3. Click NextNextNextNext

4. Wave Port: Modes

1. Click NextNextNextNext

5. Wave Port: Post-Processing 

1. Click FinishFinishFinishFinish

Create Facelist for Post-Processing
Far field calculations cannot be made on the impedance surface nor on the PML 

object. We need to create a facelist on which to calculate the radiation patterns.

To create the To create the To create the To create the facelistfacelistfacelistfacelist::::

1. Select the menu item Edit > Select > FacesEdit > Select > FacesEdit > Select > FacesEdit > Select > Faces

2. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

3. Select Face dialog: Select the object airboxairboxairboxairbox from the left column

4. Select different FaceIDs until the top face of the waveguide is highlighted.

5. Click OKOKOKOK
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5.7
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Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 9.25 GHz: 9.25 GHz: 9.25 GHz: 9.25 GHz

Maximum Number of Passes: 5555

Maximum Delta S: 0.00010.00010.00010.0001

2. Click the OKOKOKOK button

Create a Radiation SetupCreate a Radiation SetupCreate a Radiation SetupCreate a Radiation Setup

To define the radiation setupTo define the radiation setupTo define the radiation setupTo define the radiation setup

1. Select the menu item HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite 
SphereSphereSphereSphere

2. Far Field Radiation Sphere Setup dialog

1. Select the Infinite SphereInfinite SphereInfinite SphereInfinite Sphere Tab

1. Name: ff_allff_allff_allff_all

2. Phi: (Start: 0, 0, 0, 0, Stop: 0, 0, 0, 0, 

Step Size: 10)10)10)10)

3. Theta: (Start: 0, 0, 0, 0, Stop: 360, 360, 360, 360, 

Step Size: 2)2)2)2)

2. Switch to the Radiation SurfaceRadiation SurfaceRadiation SurfaceRadiation Surface tab

3. Make sure that Use Custom Radiation SurfaceUse Custom Radiation SurfaceUse Custom Radiation SurfaceUse Custom Radiation Surface is enabled and 
Facelist1Facelist1Facelist1Facelist1 has been selected

4. Click the OKOKOKOK button



Ansoft High Frequency Structure Simulator v10 User’s Guide 

Example – Endfire Antenna Array

5.7

5.7-15

Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_pmlarrayhfss_pmlarrayhfss_pmlarrayhfss_pmlarray

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 
Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze All
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last Adaptive Setup1, Last Adaptive Setup1, Last Adaptive Setup1, Last Adaptive during solution.

2. Click the CloseCloseCloseClose button when done viewing or simulation complete.
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Far Field Plots

Create Far Field PlotCreate Far Field PlotCreate Far Field PlotCreate Far Field Plot

To create a 2D polar far field plot :To create a 2D polar far field plot :To create a 2D polar far field plot :To create a 2D polar far field plot :

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Far FieldsFar FieldsFar FieldsFar Fields

2. Display Type: Radiation PatternRadiation PatternRadiation PatternRadiation Pattern

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Setup1: Setup1: Setup1: LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Geometry: ff_allff_allff_allff_all

3. In the SweepsSweepsSweepsSweeps tab:

1. Select PhiPhiPhiPhi under the NameNameNameName column, and on the drop list, 

select ThetaThetaThetaTheta. This changes the primary sweep to Theta.

4. In the MagMagMagMag tab

1. Category: DirectivityDirectivityDirectivityDirectivity

2. Quantity: DirTotalDirTotalDirTotalDirTotal

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

5. Click the DoneDoneDoneDone button
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5.7

5.7-18

Add Array Factor to PlotAdd Array Factor to PlotAdd Array Factor to PlotAdd Array Factor to Plot

To setup array factor:To setup array factor:To setup array factor:To setup array factor:

1. Select the menu item HFSS > Radiation > Antenna Array SetupHFSS > Radiation > Antenna Array SetupHFSS > Radiation > Antenna Array SetupHFSS > Radiation > Antenna Array Setup

2. Select the radio button for Regular Array SetupRegular Array SetupRegular Array SetupRegular Array Setup

3. Switch to the Regular ArrayRegular ArrayRegular ArrayRegular Array tab

4. First Cell Position:

X:0in0in0in0in, Y: 0 in,0 in,0 in,0 in, Z:0 in0 in0 in0 in

5. Directions: U vector

X:1111, Y: 0,0,0,0, Z:0000

6. Directions: V Vector

X:0000, Y: 1,1,1,1, Z:0000

7. Distance Between Cells

U Direction: 0.5 in0.5 in0.5 in0.5 in

V Direction 1 in1 in1 in1 in

8. Number of Cells

U Direction: 25252525

V Direction 25252525

9. Scan Definition: Use Scan Angles

Theta: theta_scantheta_scantheta_scantheta_scan

Phi: 0 deg0 deg0 deg0 deg
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Add Array Factor to Plot (continued)Add Array Factor to Plot (continued)Add Array Factor to Plot (continued)Add Array Factor to Plot (continued)
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Optimetrics Setup – Parametric Sweep
For this array design, we want to see the effect of scan angle on the input match 

of the antenna. To do this, we must sweep the scan angle with a parametric 

sweep.

Add a Parametric SweepAdd a Parametric SweepAdd a Parametric SweepAdd a Parametric Sweep

1. Select the menu item HFSS > Optimetrics Analysis > Add ParametricHFSS > Optimetrics Analysis > Add ParametricHFSS > Optimetrics Analysis > Add ParametricHFSS > Optimetrics Analysis > Add Parametric

2. Setup Sweep AnalysisSweep AnalysisSweep AnalysisSweep Analysis Window:

1. Click the Sweep DefinitionsSweep DefinitionsSweep DefinitionsSweep Definitions tab::::

1. Click the AddAddAddAdd button

2. Add/Edit Sweep Dialog

1. Select Variable: theta_scantheta_scantheta_scantheta_scan (this is the only variable defined, 

so it is greyed out)

2. Select Linear StepLinear StepLinear StepLinear Step

3. Start: 0deg0deg0deg0deg

4. Stop: 60deg60deg60deg60deg

5. Step: 10deg10deg10deg10deg

6. Click the AddAddAddAdd button

7. Click the OKOKOKOK button

Analyze Parametric SweepAnalyze Parametric SweepAnalyze Parametric SweepAnalyze Parametric Sweep

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Expand the Project Tree to display the items listed under OptimetricsOptimetricsOptimetricsOptimetrics

2. Right-click the mouse on ParametricSetup1 ParametricSetup1 ParametricSetup1 ParametricSetup1 and choose Analyze Analyze Analyze Analyze 

Optimetrics ResultsOptimetrics ResultsOptimetrics ResultsOptimetrics Results

To view the Optimetrics Results:To view the Optimetrics Results:To view the Optimetrics Results:To view the Optimetrics Results:

1. Select the menu item HFSS > Optimetrics Analysis > Optimetrics ResultsHFSS > Optimetrics Analysis > Optimetrics ResultsHFSS > Optimetrics Analysis > Optimetrics ResultsHFSS > Optimetrics Analysis > Optimetrics Results

2. Select the ProfileProfileProfileProfile Tab to view the solution progress for each setup.

3. Click the CloseCloseCloseClose button when you are finished viewing the results
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Create SCreate SCreate SCreate S----Parameter Plot Parameter Plot Parameter Plot Parameter Plot –––– S11 at each S11 at each S11 at each S11 at each θθθθ
To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Modal S ParametersModal S ParametersModal S ParametersModal S Parameters

2. Display Type: Rectangular PlotRectangular PlotRectangular PlotRectangular Plot

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Setup1: Setup1: Setup1: LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Click the SweepsSweepsSweepsSweeps tab

1. Select Sweep Design and Project variable valuesSweep Design and Project variable valuesSweep Design and Project variable valuesSweep Design and Project variable values

3. In the SweepsSweepsSweepsSweeps tab:

1. Select Freq Freq Freq Freq under the NameNameNameName column, and on the drop list, 

select theta_scantheta_scantheta_scantheta_scan. This changes the primary sweep to 
theta_scan.

4. Click the YYYY tab

1. Category: S ParameterS ParameterS ParameterS Parameter

2. Quantity: S(p1,p1)S(p1,p1)S(p1,p1)S(p1,p1)

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

5. Click the DoneDoneDoneDone button
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6.3 – Ring Hybrid

6.4 – Coax Stub

Includes Optimetrics Example

6.5 – Microstrip - Wave Ports

Includes Optimetrics Example

6.6 – Dielectric Resonator
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The Magic T

This example is intended to show you how to create, simulate, and analyze a Magic 
T, which is a commonly used microwave device, using the Ansoft HFSS Design 

Environment.

Nominal Design:Nominal Design:Nominal Design:Nominal Design:

Waveguide:Waveguide:Waveguide:Waveguide:

Width = 50.0 mmWidth = 50.0 mmWidth = 50.0 mmWidth = 50.0 mm

Height = 20.0 mm Height = 20.0 mm Height = 20.0 mm Height = 20.0 mm 

Length =Length =Length =Length = 50.0 mm50.0 mm50.0 mm50.0 mm

Port1

Port2

Port3 Port4

Width

Length

Height
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Ansoft HFSS Design Environment

The following features of the Ansoft HFSS Design Environment are used to create 
this passive device model

3D Solid Modeling

Primitives: BoxBoxBoxBox

Boolean Operations: Unite, DuplicateUnite, DuplicateUnite, DuplicateUnite, Duplicate

Excitations

Ports: Wave PortsWave PortsWave PortsWave Ports

Analysis

Sweep: Fast Frequency: Fast Frequency: Fast Frequency: Fast Frequency

Results

Cartesian plottingCartesian plottingCartesian plottingCartesian plotting

Fields

3D Field Plots, Animations3D Field Plots, Animations3D Field Plots, Animations3D Field Plots, Animations
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Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select 

the Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 

following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �
CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, click the � On the Standard toolbar, or select 
the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose Driven ModalDriven ModalDriven ModalDriven Modal

2. Click the OKOKOKOK button
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Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: mmmmmmmm

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose vacuumvacuumvacuumvacuum

Create Top ArmCreate Top ArmCreate Top ArmCreate Top Arm

To create arm 1:To create arm 1:To create arm 1:To create arm 1:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----25.025.025.025.0, Y: ----10.010.010.010.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 

rectangle:

dX: 50.050.050.050.0, dY: 20.020.020.020.0, dZ: 75.0, 75.0, 75.0, 75.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: ArmArmArmArm

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Or press the CTRL+DCTRL+DCTRL+DCTRL+D key
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Create Wave Port Excitation 1Create Wave Port Excitation 1Create Wave Port Excitation 1Create Wave Port Excitation 1

Picking the port face:Picking the port face:Picking the port face:Picking the port face:

1. Select the menu item Edit > Select > FacesEdit > Select > FacesEdit > Select > FacesEdit > Select > Faces

2. Graphically select the top face of the arm at Z=75mm

To assign wave port excitationTo assign wave port excitationTo assign wave port excitationTo assign wave port excitation

1. Select the menu item HFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave Port

2. Wave Port : General

1. Name: p1p1p1p1

2. Click the NextNextNextNext button

3. Wave Port : Modes

1. Click the NextNextNextNext button

4. Wave Port : Post Processing 

1. Click the FinishFinishFinishFinish button

Top face

Wave Port Face
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Set Object Selection Set Object Selection Set Object Selection Set Object Selection 

Set select to objectsSet select to objectsSet select to objectsSet select to objects

1. Select the menu item Edit > Select > ObjectsEdit > Select > ObjectsEdit > Select > ObjectsEdit > Select > Objects

Create Arm 2Create Arm 2Create Arm 2Create Arm 2

To create arm 2:To create arm 2:To create arm 2:To create arm 2:

1. Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible.  .  .  .  Or press the CTRL+ACTRL+ACTRL+ACTRL+A key.

2. Select the menu item, Edit > Duplicate > Around AxisEdit > Duplicate > Around AxisEdit > Duplicate > Around AxisEdit > Duplicate > Around Axis.

1. Axis: XXXX

2. Angle: 90909090

3. Total Number: 2222

4. Click the OK OK OK OK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Create Arm 3 & 4Create Arm 3 & 4Create Arm 3 & 4Create Arm 3 & 4

To select the object Arm_1:To select the object Arm_1:To select the object Arm_1:To select the object Arm_1:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Arm_1Arm_1Arm_1Arm_1

2. Click the OK OK OK OK button

To create arm 3 & 4:To create arm 3 & 4:To create arm 3 & 4:To create arm 3 & 4:

1. Select the menu item, Edit > Duplicate > Around AxisEdit > Duplicate > Around AxisEdit > Duplicate > Around AxisEdit > Duplicate > Around Axis.

1. Axis: ZZZZ

2. Angle: 90909090

3. Total Number: 3333

4. Click the OK OK OK OK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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Group the ArmsGroup the ArmsGroup the ArmsGroup the Arms

To group the arms:To group the arms:To group the arms:To group the arms:

1. Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible.  .  .  .  Or press the CTRL+ACTRL+ACTRL+ACTRL+A key.

2. Select the menu item, 3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View....

Boundary DisplayBoundary DisplayBoundary DisplayBoundary Display

To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:

1. Select the menu item HFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary Display (Solver View)(Solver View)(Solver View)(Solver View)

2. From the Solver View of Boundaries, toggle the Visibility check box for the  
boundaries you wish to display.

Note:Note:Note:Note: The background (Perfect Conductor) is displayed as the outerouterouterouter

boundary.

Note:Note:Note:Note: The Perfect Conductors are displayed as the smetalsmetalsmetalsmetal boundary.

Note:Note:Note:Note: Select the menu item, View > VisibilityView > VisibilityView > VisibilityView > Visibility to hide all of the 

geometry objects.  This makes it easier to see the boundary

3. Click the CloseCloseCloseClose button when you are finished
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Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 4.0GHz: 4.0GHz: 4.0GHz: 4.0GHz

Maximum Number of Passes: 5555

Maximum Delta S per Pass: 0.020.020.020.02

2. Click the OKOKOKOK button

Adding a Frequency SweepAdding a Frequency SweepAdding a Frequency SweepAdding a Frequency Sweep

To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:

1. Select the menu item HFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add Sweep

1. Select Solution Setup: Setup1 Setup1 Setup1 Setup1 

2. Click the OKOKOKOK button

2. Edit Sweep Window:

1. Sweep Type: Fast: Fast: Fast: Fast

2. Frequency Setup Type: Linear Count: Linear Count: Linear Count: Linear Count

Start: 3.4GHz3.4GHz3.4GHz3.4GHz

Stop: 4.0GHz: 4.0GHz: 4.0GHz: 4.0GHz

Count: 1001: 1001: 1001: 1001

Save Fields: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_magic_thfss_magic_thfss_magic_thfss_magic_t

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 

Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > AnalyzeHFSS > AnalyzeHFSS > AnalyzeHFSS > Analyze
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button
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Create Reports

Create SCreate SCreate SCreate S----Parameter Plot vs. Adaptive PassParameter Plot vs. Adaptive PassParameter Plot vs. Adaptive PassParameter Plot vs. Adaptive Pass

Note: Note: Note: Note: If this report is created prior or during the solution process, a real-time 

update of the results are displayed

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Modal S ParametersModal S ParametersModal S ParametersModal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Adaptive1Setup1: Adaptive1Setup1: Adaptive1Setup1: Adaptive1

2. Click the X X X X tab

1. Use Primary Sweep: : : : ���� UncheckedUncheckedUncheckedUnchecked

2. Category: VariablesVariablesVariablesVariables

3. Quantity: Pass: Pass: Pass: Pass

3. Click the YYYY tab

1. Category: S ParameterS ParameterS ParameterS Parameter

2. Quantity: S(p1,p1), S(p1,p2), S(p1,p3), S(p1,p4)S(p1,p1), S(p1,p2), S(p1,p3), S(p1,p4)S(p1,p1), S(p1,p2), S(p1,p3), S(p1,p4)S(p1,p1), S(p1,p2), S(p1,p3), S(p1,p4)

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button
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Create SCreate SCreate SCreate S----Parameter PlotParameter PlotParameter PlotParameter Plot

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Modal S ParametersModal S ParametersModal S ParametersModal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Domain: SweepSweepSweepSweep

3. Click the YYYY tab

1. Category: S ParameterS ParameterS ParameterS Parameter

2. Quantity: S(p1,p1), S(p1,p2), S(p1,p3), S(p1,p4)S(p1,p1), S(p1,p2), S(p1,p3), S(p1,p4)S(p1,p1), S(p1,p2), S(p1,p3), S(p1,p4)S(p1,p1), S(p1,p2), S(p1,p3), S(p1,p4)

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button
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Create Field OverlayCreate Field OverlayCreate Field OverlayCreate Field Overlay

To select an object:To select an object:To select an object:To select an object:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: ArmArmArmArm

2. Click the OK OK OK OK button

3. Select the menu item HFSS > Fields > HFSS > Fields > HFSS > Fields > HFSS > Fields > FieldsFieldsFieldsFields > E > > E > > E > > E > Mag_EMag_EMag_EMag_E

4. Create Field Plot Window

1. Solution: Setup1 :  Setup1 :  Setup1 :  Setup1 :  LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Quantity: Mag_EMag_EMag_EMag_E

3. In Volume: AllAllAllAll

4. Click the DoneDoneDoneDone button

To modify the attributes of a field plot:To modify the attributes of a field plot:To modify the attributes of a field plot:To modify the attributes of a field plot:

1. Select the menu item HFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot Attributes

2. Select Plot Folder Window:

1. Select: E FieldE FieldE FieldE Field

2. Click the OKOKOKOK button

3. E-Field Window:

1. Click the PlotPlotPlotPlot tab

1. IsoValType: IsoValSurfaceIsoValSurfaceIsoValSurfaceIsoValSurface

2. Click the ApplyApplyApplyApply button.

4. Click the CloseCloseCloseClose button

Field AnimationsField AnimationsField AnimationsField Animations

To Animate a Magnitude field plot:To Animate a Magnitude field plot:To Animate a Magnitude field plot:To Animate a Magnitude field plot:

1. Select the menu item View > AnimateView > AnimateView > AnimateView > Animate

2. In the Swept VariableSwept VariableSwept VariableSwept Variable tab, accept the defaults settings:

1. Swept variable: PhasePhasePhasePhase

2. Start: 0deg0deg0deg0deg

3. Stop: 180deg180deg180deg180deg

4. Steps: 9999

3. Click OKOKOKOK
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The Coaxial Connector
This example is intended to show you how to create, simulate, and analyze a 

coaxial connector, using the Ansoft HFSS Design Environment.
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6.2-2

Ansoft HFSS Design Environment
The following features of the Ansoft HFSS Design Environment are used to 

create this passive device model

3D Solid Modeling

Primitives: Cylinders, Polylines, CirclesCylinders, Polylines, CirclesCylinders, Polylines, CirclesCylinders, Polylines, Circles

Boolean Operations: Unite, Subtract, and SweepUnite, Subtract, and SweepUnite, Subtract, and SweepUnite, Subtract, and Sweep

Boundaries/Excitations

Ports: Wave Ports and Terminal LinesWave Ports and Terminal LinesWave Ports and Terminal LinesWave Ports and Terminal Lines

Analysis

Sweep: Fast Frequency: Fast Frequency: Fast Frequency: Fast Frequency

Results

Cartesian plottingCartesian plottingCartesian plottingCartesian plotting

Field Overlays:

3D Field Plots, Animations, Cut3D Field Plots, Animations, Cut3D Field Plots, Animations, Cut3D Field Plots, Animations, Cut----PlanesPlanesPlanesPlanes
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Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select 

the Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, click the � On the Standard toolbar, or select 

the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose Driven TerminalDriven TerminalDriven TerminalDriven Terminal

2. Click the OKOKOKOK button
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Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: cmcmcmcm

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type pecpecpecpec in the Search by NameSearch by NameSearch by NameSearch by Name field

2. Click the OKOKOKOK button
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Create the Conductor 1Create the Conductor 1Create the Conductor 1Create the Conductor 1

To create the conductorTo create the conductorTo create the conductorTo create the conductor

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.1520.1520.1520.152, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 1.4481.4481.4481.448, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Conductor1Conductor1Conductor1Conductor1

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
Or press the CTRL+DCTRL+DCTRL+DCTRL+D key

Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:

1. Select the menu item 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 1.448, 1.448, 1.448, 1.448, Press the EnterEnterEnterEnter key

Create a SectionCreate a SectionCreate a SectionCreate a Section

To section the conductorTo section the conductorTo section the conductorTo section the conductor

1. Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible.  .  .  .  Or press the CTRL+ACTRL+ACTRL+ACTRL+A key.

2. Select the menu item 3D Modeler > Surface > Section3D Modeler > Surface > Section3D Modeler > Surface > Section3D Modeler > Surface > Section

3. Section Window

Section Plane: XYXYXYXY

Click the OK OK OK OK button
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Rename the SectionRename the SectionRename the SectionRename the Section

To set the name:To set the name:To set the name:To set the name:

1. Select the menu item HFSS > ListHFSS > ListHFSS > ListHFSS > List

2. From the ModelModelModelModel tab, select the object named Section1Section1Section1Section1

3. Click the Properties Properties Properties Properties button

1. For the ValueValueValueValue of NameNameNameName type: BendBendBendBend

2. Click the OKOKOKOK button

4. Click the DoneDoneDoneDone button

Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ

Create Conductor BendCreate Conductor BendCreate Conductor BendCreate Conductor Bend

To create the bend:To create the bend:To create the bend:To create the bend:

1. Select the menu item Draw > Arc > Center PointDraw > Arc > Center PointDraw > Arc > Center PointDraw > Arc > Center Point

2. Using the coordinate entry fields, enter the vertex point:

X: 0.00.00.00.0, Y: 0.40.40.40.4, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radial point:

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the sweep arc length:

X: 0.00.00.00.0, Y: 0.40.40.40.4, Z: 0.40.40.40.4, Press the EnterEnterEnterEnter key

5. Using the mouse, right-click and select DoneDoneDoneDone

6. Click the OKOKOKOK button when the Properties dialog appears

Sweep Bend:Sweep Bend:Sweep Bend:Sweep Bend:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Bend, Polyline1Bend, Polyline1Bend, Polyline1Bend, Polyline1

2. Click the OK OK OK OK button

3. Select the menu item Draw > Sweep > Along PathDraw > Sweep > Along PathDraw > Sweep > Along PathDraw > Sweep > Along Path

4. Sweep along path Window

Angle of twist: 0000

Draft Angle: 0000

Draft Type: RoundRoundRoundRound

Click the OK OK OK OK button
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Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ

Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:

1. Select the menu item 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: 0.00.00.00.0, Y: 0.40.40.40.4, Z: 0.4, 0.4, 0.4, 0.4, Press the EnterEnterEnterEnter key

Create the Conductor 2Create the Conductor 2Create the Conductor 2Create the Conductor 2

To create the conductorTo create the conductorTo create the conductorTo create the conductor

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.1520.1520.1520.152, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.4360.4360.4360.436, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Conductor2Conductor2Conductor2Conductor2

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:

1. Select the menu item 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: 0.00.00.00.0, Y: 0.4360.4360.4360.436, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key
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Create the Conductor 3Create the Conductor 3Create the Conductor 3Create the Conductor 3

To create the conductorTo create the conductorTo create the conductorTo create the conductor

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.2250.2250.2250.225, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 1.31.31.31.3, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Conductor3Conductor3Conductor3Conductor3

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Group the ConductorsGroup the ConductorsGroup the ConductorsGroup the Conductors

To group the conductors:To group the conductors:To group the conductors:To group the conductors:

1. Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible.  .  .  .  Or press the CTRL+ACTRL+ACTRL+ACTRL+A key.

2. Select the menu item, 3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose vacuum vacuum vacuum vacuum 
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Create the Female EndCreate the Female EndCreate the Female EndCreate the Female End

To create the female end:To create the female end:To create the female end:To create the female end:

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.5110.5110.5110.511, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 1.31.31.31.3, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: FemaleFemaleFemaleFemale

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 

Create the Female BendCreate the Female BendCreate the Female BendCreate the Female Bend

To create the bend:To create the bend:To create the bend:To create the bend:

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.0, Y: 0.0, Z: 0.0, X: 0.0, Y: 0.0, Z: 0.0, X: 0.0, Y: 0.0, Z: 0.0, X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key

3. Using the coordinate entry fields, enter the radius:

dXdXdXdX: 0.351, : 0.351, : 0.351, : 0.351, dYdYdYdY: 0.0, : 0.0, : 0.0, : 0.0, dZdZdZdZ: 0.0, : 0.0, : 0.0, : 0.0, Press the Enter key

4. Using the coordinate entry fields, enter the height:

dXdXdXdX: 0.0, : 0.0, : 0.0, : 0.0, dYdYdYdY: : : : ----1.236, 1.236, 1.236, 1.236, dZdZdZdZ: 0.0, : 0.0, : 0.0, : 0.0, Press the Enter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: FemaleBendFemaleBendFemaleBendFemaleBend

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.   .   .   .   
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Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: GlobalGlobalGlobalGlobal

2. Click the SelectSelectSelectSelect button

Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY

Create the Male EndCreate the Male EndCreate the Male EndCreate the Male End

To create the male end:To create the male end:To create the male end:To create the male end:

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.0, Y: 0.0, Z: 0.0, X: 0.0, Y: 0.0, Z: 0.0, X: 0.0, Y: 0.0, Z: 0.0, X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key

3. Using the coordinate entry fields, enter the radius:

dXdXdXdX: 0.351, : 0.351, : 0.351, : 0.351, dYdYdYdY: 0.0, : 0.0, : 0.0, : 0.0, dZdZdZdZ: 0.0, : 0.0, : 0.0, : 0.0, Press the Enter key

4. Using the coordinate entry fields, enter the height:

dXdXdXdX: 0.0, : 0.0, : 0.0, : 0.0, dYdYdYdY: 0.0, : 0.0, : 0.0, : 0.0, dZdZdZdZ: 2.348, : 2.348, : 2.348, : 2.348, Press the Enter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: MaleMaleMaleMale

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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Group the Vacuum ObjectsGroup the Vacuum ObjectsGroup the Vacuum ObjectsGroup the Vacuum Objects

To unite the objects  Female, To unite the objects  Female, To unite the objects  Female, To unite the objects  Female, FemaleBendFemaleBendFemaleBendFemaleBend and Male:and Male:and Male:and Male:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Female, Female, Female, Female, FemaleBendFemaleBendFemaleBendFemaleBend, Male, Male, Male, Male

2. Click the OK OK OK OK button

3. Select the menu item, 3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Add New MaterialAdd New MaterialAdd New MaterialAdd New Material

To add a new material:To add a new material:To add a new material:To add a new material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. From the Select Definition window, click the Add MaterialAdd MaterialAdd MaterialAdd Material button

3. View/Edit Material Window:

1. For the Material NameMaterial NameMaterial NameMaterial Name type: My_RingMy_RingMy_RingMy_Ring

2. For the ValueValueValueValue of Relative PermittivityRelative PermittivityRelative PermittivityRelative Permittivity type: 3333

3. Click the OKOKOKOK button

4. Click the OKOKOKOK button
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Create the RingCreate the RingCreate the RingCreate the Ring

To create the ring:To create the ring:To create the ring:To create the ring:

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.7360.7360.7360.736, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.5110.5110.5110.511, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 0.2360.2360.2360.236, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: RingRingRingRing

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 

Complete the RingComplete the RingComplete the RingComplete the Ring

To select the objects Ring and Male:To select the objects Ring and Male:To select the objects Ring and Male:To select the objects Ring and Male:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Ring, FemaleRing, FemaleRing, FemaleRing, Female

2. Click the OK OK OK OK button

To complete the ring:To complete the ring:To complete the ring:To complete the ring:

1. Select the menu item 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 

2. Subtract Window

Blank Parts: RingRingRingRing

Tool Parts: FemaleFemaleFemaleFemale

Clone tool objects before subtract: � CheckedCheckedCheckedChecked

Click the OKOKOKOK button
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Add New MaterialAdd New MaterialAdd New MaterialAdd New Material

To add a new material:To add a new material:To add a new material:To add a new material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. From the Select Definition window, click the Add MaterialAdd MaterialAdd MaterialAdd Material button

3. View/Edit Material Window:

1. For the Material NameMaterial NameMaterial NameMaterial Name type: My_TeflonMy_TeflonMy_TeflonMy_Teflon

2. For the ValueValueValueValue of Relative PermittivityRelative PermittivityRelative PermittivityRelative Permittivity type: 2.12.12.12.1

3. Click the OKOKOKOK button

4. Click the OKOKOKOK button

Create the Male TeflonCreate the Male TeflonCreate the Male TeflonCreate the Male Teflon

To create the To create the To create the To create the teflonteflonteflonteflon::::

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.460.460.460.46, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.5110.5110.5110.511, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 0.7880.7880.7880.788, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: MaleTeflonMaleTeflonMaleTeflonMaleTeflon

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View....
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Create Wave Port Excitation 1Create Wave Port Excitation 1Create Wave Port Excitation 1Create Wave Port Excitation 1

Note: Note: Note: Note: To simplify the instructions, a 2D object will be created to represent the 
port.  This is not a requirement for defining ports.  Graphical face selection can 

be used as an alternative.

To create a circle that represents the port:To create a circle that represents the port:To create a circle that represents the port:To create a circle that represents the port:

1. Select the menu item Draw > CircleDraw > CircleDraw > CircleDraw > Circle

2. Using the coordinate entry fields, enter the center position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius of the circle:

dX: 0.3510.3510.3510.351, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: p1p1p1p1

3. Click the OKOKOKOK button

To select the object p1:To select the object p1:To select the object p1:To select the object p1:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: p1p1p1p1

2. Click the OK OK OK OK button

NoteNoteNoteNote:  You can also select the object from the Model Tree
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Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)

To assign wave port excitationTo assign wave port excitationTo assign wave port excitationTo assign wave port excitation

1. Select the menu item HFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave Port

2. Wave Port : General

1. Name: p1p1p1p1, 

2. Click the NextNextNextNext button

3. Wave Port : Terminals

1. Number of Terminals: 1111,

2. For T1T1T1T1, click the UndefinedUndefinedUndefinedUndefined column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: 0.3510.3510.3510.351, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex

dX: ----0.1990.1990.1990.199, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

5. Click the NextNextNextNext button

4. Wave Port : Differential Pairs 

1. Click the NextNextNextNext button

5. Wave Port : Post Processing 

1. Full Port Impedance: 50505050

6. Click the FinishFinishFinishFinish button

Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: RelativeCS3RelativeCS3RelativeCS3RelativeCS3

2. Click the SelectSelectSelectSelect button

Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ
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Create Wave Port Excitation 2Create Wave Port Excitation 2Create Wave Port Excitation 2Create Wave Port Excitation 2

Note: Note: Note: Note: To simplify the instructions, a 2D object will be created to represent the 
port.  This is not a requirement for defining ports.  Graphical face selection can 

be used as an alternative.

To create a circle that represents the port:To create a circle that represents the port:To create a circle that represents the port:To create a circle that represents the port:

1. Select the menu item Draw > CircleDraw > CircleDraw > CircleDraw > Circle

2. Using the coordinate entry fields, enter the center position

X: 0.00.00.00.0, Y: 1.31.31.31.3, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius of the circle:

dX: 0.5110.5110.5110.511, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: p2p2p2p2

3. Click the OKOKOKOK button

To select the object p2:To select the object p2:To select the object p2:To select the object p2:

1. Select Object Dialog, 

1. Select the objects named: p2p2p2p2

2. Click the OK OK OK OK button
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Create Wave Port Excitation 2 (Continued)Create Wave Port Excitation 2 (Continued)Create Wave Port Excitation 2 (Continued)Create Wave Port Excitation 2 (Continued)

To assign wave port excitationTo assign wave port excitationTo assign wave port excitationTo assign wave port excitation

1. Select the menu item HFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave Port

2. Wave Port : General

1. Name: p2p2p2p2, 

2. Click the NextNextNextNext button

3. Wave Port : Terminals

1. Number of Terminals: 1111,

2. For T1T1T1T1, click the UndefinedUndefinedUndefinedUndefined column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: 0.5110.5110.5110.511, Y: 1.31.31.31.3, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex

dX: ----0.2860.2860.2860.286, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

5. Click the NextNextNextNext button

4. Wave Port : Differential Pairs 

1. Click the NextNextNextNext button

5. Wave Port : Post Processing 

1. Full Port Impedance : 50505050

2. Click the FinishFinishFinishFinish button



Ansoft High Frequency Structure Simulator v10 User’s Guide 

6.2
Example – Coaxial Connector

6.2-19

Create the Female TeflonCreate the Female TeflonCreate the Female TeflonCreate the Female Teflon

To create the Teflon:To create the Teflon:To create the Teflon:To create the Teflon:

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.0, Y: 0.0, Z: 0.0, X: 0.0, Y: 0.0, Z: 0.0, X: 0.0, Y: 0.0, Z: 0.0, X: 0.0, Y: 0.0, Z: 0.0, Press the Enter key

3. Using the coordinate entry fields, enter the radius:

dXdXdXdX: 0.511, : 0.511, : 0.511, : 0.511, dYdYdYdY: 0.0, : 0.0, : 0.0, : 0.0, dZdZdZdZ: 0.0, : 0.0, : 0.0, : 0.0, Press the Enter key

4. Using the coordinate entry fields, enter the height:

dXdXdXdX: 0.0, : 0.0, : 0.0, : 0.0, dYdYdYdY: : : : ----0.236, 0.236, 0.236, 0.236, dZdZdZdZ: 0.0, : 0.0, : 0.0, : 0.0, Press the Enter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: FemaleTeflonFemaleTeflonFemaleTeflonFemaleTeflon

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View....

Complete the Vacuum ObjectComplete the Vacuum ObjectComplete the Vacuum ObjectComplete the Vacuum Object

To select the objects Female, To select the objects Female, To select the objects Female, To select the objects Female, MaleTeflonMaleTeflonMaleTeflonMaleTeflon, , , , FemaleTeflonFemaleTeflonFemaleTeflonFemaleTeflon

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Female, Female, Female, Female, MaleTeflonMaleTeflonMaleTeflonMaleTeflon, , , , FemaleTeflonFemaleTeflonFemaleTeflonFemaleTeflon

2. Click the OK OK OK OK button

To complete the To complete the To complete the To complete the vacummvacummvacummvacumm objects:objects:objects:objects:

1. Select the menu item 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 

2. Subtract Window

Blank Parts: FemaleFemaleFemaleFemale

Tool Parts: MaleTeflonMaleTeflonMaleTeflonMaleTeflon, , , , FemaleTeflonFemaleTeflonFemaleTeflonFemaleTeflon

Clone tool objects before subtract: � CheckedCheckedCheckedChecked

Click the OKOKOKOK button
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Complete the ModelComplete the ModelComplete the ModelComplete the Model

To complete the model:To complete the model:To complete the model:To complete the model:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named:  Conductor1, Female, Conductor1, Female, Conductor1, Female, Conductor1, Female, MaleTeflonMaleTeflonMaleTeflonMaleTeflon, , , , 

FemaleTeflonFemaleTeflonFemaleTeflonFemaleTeflon

2. Click the OK OK OK OK button

3. Select the menu item 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 

4. Subtract Window

Blank Parts: Female, Female, Female, Female, FemaleTeflonFemaleTeflonFemaleTeflonFemaleTeflon, , , , MaleTeflonMaleTeflonMaleTeflonMaleTeflon

Tool Parts: Conductor1Conductor1Conductor1Conductor1

Clone tool objects before subtract: � CheckedCheckedCheckedChecked

Click the OKOKOKOK button

Boundary DisplayBoundary DisplayBoundary DisplayBoundary Display

To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:

1. Select the menu item HFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary Display (Solver View)(Solver View)(Solver View)(Solver View)

2. From the Solver View of Boundaries, toggle the Visibility check box for the  
boundaries you wish to display.

Note:Note:Note:Note: The background (Perfect Conductor) is displayed as the outerouterouterouter

boundary.

Note:Note:Note:Note: The Perfect Conductors are displayed as the smetalsmetalsmetalsmetal boundary.

Note:Note:Note:Note: Select the menu item, View > VisibilityView > VisibilityView > VisibilityView > Visibility to hide all of the 
geometry objects.  This makes it easier to see the boundary

3. Click the CloseCloseCloseClose button when you are finished
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Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 8.1GHz: 8.1GHz: 8.1GHz: 8.1GHz

Maximum Number of Passes: 10101010

Maximum Delta S: 0.020.020.020.02

2. Click the OKOKOKOK button 

3. Click the OptionsOptionsOptionsOptions tab::::

Minimum Converged Passes: 2222

4. Click the OKOKOKOK button

Adding a Frequency SweepAdding a Frequency SweepAdding a Frequency SweepAdding a Frequency Sweep

To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:

1. Select the menu item HFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add Sweep

1. Select Solution Setup: Setup1 Setup1 Setup1 Setup1 

2. Click the OKOKOKOK button

2. Edit Sweep Window:

1. Sweep Type: Fast: Fast: Fast: Fast

2. Frequency Setup Type: Linear Count: Linear Count: Linear Count: Linear Count

Start: 0.1GHz0.1GHz0.1GHz0.1GHz

Stop: 8.1GHz: 8.1GHz: 8.1GHz: 8.1GHz

Count: 801: 801: 801: 801

Save Fields: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_coaxhfss_coaxhfss_coaxhfss_coax

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 
Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > AnalyzeHFSS > AnalyzeHFSS > AnalyzeHFSS > Analyze
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button
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Create Reports

Create Terminal SCreate Terminal SCreate Terminal SCreate Terminal S----Parameter Plot vs. Adaptive PassParameter Plot vs. Adaptive PassParameter Plot vs. Adaptive PassParameter Plot vs. Adaptive Pass

Note: Note: Note: Note: If this report is created prior to or during the solution process, a 
real-time update of the results are displayed

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Adaptive1Setup1: Adaptive1Setup1: Adaptive1Setup1: Adaptive1

2. Click the X X X X tab

1. Use Primary Sweep: : : : ���� UncheckedUncheckedUncheckedUnchecked

2. Category: VariablesVariablesVariablesVariables

3. Quantity: Pass: Pass: Pass: Pass

3. Click the YYYY tab

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: St(p1,p1), St(p1,p2), St(p1,p1), St(p1,p2), St(p1,p1), St(p1,p2), St(p1,p1), St(p1,p2), 

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button
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Create Terminal SCreate Terminal SCreate Terminal SCreate Terminal S----Parameter Plot Parameter Plot Parameter Plot Parameter Plot ---- MagnitudeMagnitudeMagnitudeMagnitude

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Domain: SweepSweepSweepSweep

3. Click the YYYY tab

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: St(p1,p1), St(p1,p2), St(p1,p1), St(p1,p2), St(p1,p1), St(p1,p2), St(p1,p1), St(p1,p2), 

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button
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Create Terminal SCreate Terminal SCreate Terminal SCreate Terminal S----Parameter Plot Parameter Plot Parameter Plot Parameter Plot ---- PhasePhasePhasePhase

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Domain: SweepSweepSweepSweep

3. Click the YYYY tab

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: St(p1,p1), St(p1,p2), St(p1,p1), St(p1,p2), St(p1,p1), St(p1,p2), St(p1,p1), St(p1,p2), 

3. Function: ang_degang_degang_degang_deg

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button
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Field Overlays

Create Field OverlayCreate Field OverlayCreate Field OverlayCreate Field Overlay

To create a field plot:To create a field plot:To create a field plot:To create a field plot:

1. Select the Global YZ Plane

1. Using the Model Tree, expand PlanesPlanesPlanesPlanes

2. Select Global:YZGlobal:YZGlobal:YZGlobal:YZ

2. Select the menu item HFSS > Fields > HFSS > Fields > HFSS > Fields > HFSS > Fields > FieldsFieldsFieldsFields >  E > >  E > >  E > >  E > Mag_EMag_EMag_EMag_E

3. Create Field Plot Window

1. Solution: Setup1 :  Setup1 :  Setup1 :  Setup1 :  LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Quantity: Mag_EMag_EMag_EMag_E

3. In Volume: AllAllAllAll

4. Click the DoneDoneDoneDone button

To modify a Magnitude field plot:To modify a Magnitude field plot:To modify a Magnitude field plot:To modify a Magnitude field plot:

1. Select the menu item HFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot Attributes

2. Select Plot Folder Window:

1. Select: E FieldE FieldE FieldE Field

2. Click the OKOKOKOK button

3. E-Field Window:

1. Click the Scale Scale Scale Scale tab

1. Select Use LimitsUse LimitsUse LimitsUse Limits

2. Min: 1.01.01.01.0

3. Max: 1000.01000.01000.01000.0

4. Scale: LogLogLogLog

2. Click the CloseCloseCloseClose button
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Edit SourcesEdit SourcesEdit SourcesEdit Sources

To Modify a Terminal excitation:To Modify a Terminal excitation:To Modify a Terminal excitation:To Modify a Terminal excitation:

1. Select the menu item HFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit Sources

2. Select p2:T1p2:T1p2:T1p2:T1 from the Edit Sources window

Check the TerminatedTerminatedTerminatedTerminated box

3. Click the OKOKOKOK button

To Select the Electric Field plot:To Select the Electric Field plot:To Select the Electric Field plot:To Select the Electric Field plot:

1. Expand the Project tree

2. Expand the Field OverlaysField OverlaysField OverlaysField Overlays

3. Click on the E FieldE FieldE FieldE Field or Mag_E1Mag_E1Mag_E1Mag_E1 to 
display the field plot

Field AnimationsField AnimationsField AnimationsField Animations

To Animate a Magnitude field plot:To Animate a Magnitude field plot:To Animate a Magnitude field plot:To Animate a Magnitude field plot:

1. Select the menu item View > AnimateView > AnimateView > AnimateView > Animate

2. In the Swept VariableSwept VariableSwept VariableSwept Variable tab, accept defaults settings:

1. Swept variable: PhasePhasePhasePhase

2. Start: 0deg0deg0deg0deg

3. Stop: 180deg180deg180deg180deg

4. Steps: 9999

3. Click the CloseCloseCloseClose button
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6.3-1

The 180° Ring Hybrid
This example is intended to show you how to create, simulate, and analyze a ring 

hybrid, using Ansoft HFSS.
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6.3-2

Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and 

select the Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, click the � On the Standard toolbar, or select 

the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose Driven TerminalDriven TerminalDriven TerminalDriven Terminal

2. Click the OKOKOKOK button
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6.3-4

Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: mmmmmmmm

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Click the Add MaterialAdd MaterialAdd MaterialAdd Material button

2. View/Edit Material Window:

1. For the Material NameMaterial NameMaterial NameMaterial Name type: My_SubMy_SubMy_SubMy_Sub

2. For the ValueValueValueValue of Relative PermittivityRelative PermittivityRelative PermittivityRelative Permittivity type: 2.33 2.33 2.33 2.33 

3. For the ValueValueValueValue of Dielectric Loss TangentDielectric Loss TangentDielectric Loss TangentDielectric Loss Tangent type: 4.29e4.29e4.29e4.29e----4 4 4 4 

4. Click the OKOKOKOK button

3. Click the OKOKOKOK button
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Create SubstrateCreate SubstrateCreate SubstrateCreate Substrate

To create the substrate:To create the substrate:To create the substrate:To create the substrate:

1. Select the menu item Draw > Regular PolyhedronDraw > Regular PolyhedronDraw > Regular PolyhedronDraw > Regular Polyhedron

2. Using the coordinate entry fields, enter the center position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: ----1.1431.1431.1431.143, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 22.345mm/cos(30*pi/180),22.345mm/cos(30*pi/180),22.345mm/cos(30*pi/180),22.345mm/cos(30*pi/180), dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 2.2862.2862.2862.286, Press the EnterEnterEnterEnter key

Segment Number Window

Number of Segments: 6666

Click the OKOKOKOK button

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: SubstrateSubstrateSubstrateSubstrate

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
Or press the CTRL+DCTRL+DCTRL+DCTRL+D key
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Create Trace Create Trace Create Trace Create Trace 

To create the trace:To create the trace:To create the trace:To create the trace:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the rectangle position

X: ----0.891540.891540.891540.89154, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the rectangle:

dX: 1.783081.783081.783081.78308, dY: 22.34522.34522.34522.345, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: TraceTraceTraceTrace

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Assign a Perfect E boundary to the TraceAssign a Perfect E boundary to the TraceAssign a Perfect E boundary to the TraceAssign a Perfect E boundary to the Trace

To select the trace:To select the trace:To select the trace:To select the trace:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: TraceTraceTraceTrace

2. Click the OK OK OK OK button

To assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundary

1. Select the menu item HFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect E

2. Perfect E Boundary window

1. Name: PerfE_TracePerfE_TracePerfE_TracePerfE_Trace

2. Click the OKOKOKOK button
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6.3-7

Create Wave Port Excitation 1Create Wave Port Excitation 1Create Wave Port Excitation 1Create Wave Port Excitation 1

Note: Note: Note: Note: This structure requires 4 ports with 1 terminal lines per port. We could use 
face selection to select the ends of the substrate that represent the port, define 

terminal lines, assign excitation, and repeat for port2-4.  Since we can duplicate 

port definitions, it is more efficient to define a rectangle with the appropriate port 

definition and copy it to the location of ports 2-4.  The second method is 

described here:

To set grid planeTo set grid planeTo set grid planeTo set grid plane

1. Select the menu item 3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ

To sit the viewTo sit the viewTo sit the viewTo sit the view

Select the menu item View > Modify Attributes > OrientationView > Modify Attributes > OrientationView > Modify Attributes > OrientationView > Modify Attributes > Orientation

Select Viewing Direction form the List Window

1. From the list select the view name: RightRightRightRight

2. Click the ApplyApplyApplyApply button

3. Click the CloseCloseCloseClose button

To create the rectangle graphically:To create the rectangle graphically:To create the rectangle graphically:To create the rectangle graphically:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the mouse, position the active position indicator such that it snaps to 

the vertex of the lower left corner of the substrate face.  The shape of the 
active position indicator will change to a square when it snaps to the vertex

3. Click the left mouse button to select this point as the start position. 

4. Continued on next page…
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6.3-8

Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)

4. Using the mouse, position the active position indicator such that it snaps to 
the vertex of the upper right corner of the substrate face.  The shape of the 

active position indicator will change to a square when it snaps to the vertex

5. Click the left mouse button to set the opposite corner of the rectangle. 

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: PortPortPortPort

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  



Ansoft High Frequency Structure Simulator v10 User’s Guide 

6.3
Example – 180° Ring Hybrid

6.3-9

Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)

To assign wave port excitationTo assign wave port excitationTo assign wave port excitationTo assign wave port excitation

1. Select the menu item HFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave Port

2. Wave Port : General

1. Name: p1p1p1p1

2. Click the NextNextNextNext button

3. Wave Port : Terminals

1. Number of Terminals: 1111, Click the UpdateUpdateUpdateUpdate button

2. For T1T1T1T1, click the UndefinedUndefinedUndefinedUndefined column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: 0.00.00.00.0, Y: 22.34522.34522.34522.345, Z: ----1.1431.1431.1431.143, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 1.1431.1431.1431.143, Press the EnterEnterEnterEnter key

5. Click the NextNextNextNext button

4. Wave Port : Differential Pairs 

1. Click the NextNextNextNext button

5. Wave Port : Post Processing 

6. Click the FinishFinishFinishFinish button

Terminal Line
Wave Port Face
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Create the remaining Traces and Wave PortsCreate the remaining Traces and Wave PortsCreate the remaining Traces and Wave PortsCreate the remaining Traces and Wave Ports

To select objects:To select objects:To select objects:To select objects:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Trace, PortTrace, PortTrace, PortTrace, Port

2. Click the OK OK OK OK button

To duplicate the objects:To duplicate the objects:To duplicate the objects:To duplicate the objects:

1. Select the menu item, Edit > Duplicate > Around AxisEdit > Duplicate > Around AxisEdit > Duplicate > Around AxisEdit > Duplicate > Around Axis

2. Duplicate Around Axis Window

1. Axis: ZZZZ

2. Angle: 60deg60deg60deg60deg

3. Total Number: 4444

4. Click the OKOKOKOK button 

Create Outer RingCreate Outer RingCreate Outer RingCreate Outer Ring

To set grid planeTo set grid planeTo set grid planeTo set grid plane

1. Select the menu item 3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY

To create the ring:To create the ring:To create the ring:To create the ring:

1. Select the menu item Draw > CircleDraw > CircleDraw > CircleDraw > Circle

2. Using the coordinate entry fields, enter the position

X: 0.00.00.00.0, Y: 0.00.00.00.0,  Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 11.79511.79511.79511.795, dY: 0.00.00.00.0,  dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: OuterOuterOuterOuter

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit DrawingView > Fit DrawingView > Fit DrawingView > Fit Drawing....
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6.3-11

Group the ConductorsGroup the ConductorsGroup the ConductorsGroup the Conductors

To group the conductors:To group the conductors:To group the conductors:To group the conductors:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Trace, Trace_1, Trace_2, Trace_3, OuterTrace, Trace_1, Trace_2, Trace_3, OuterTrace, Trace_1, Trace_2, Trace_3, OuterTrace, Trace_1, Trace_2, Trace_3, Outer

2. Click the OK OK OK OK button

3. Select the menu item, 3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit DrawingView > Fit DrawingView > Fit DrawingView > Fit Drawing....

Create Inner RingCreate Inner RingCreate Inner RingCreate Inner Ring

To create the ring:To create the ring:To create the ring:To create the ring:

1. Select the menu item Draw > CircleDraw > CircleDraw > CircleDraw > Circle

2. Using the coordinate entry fields, enter the position

X: 0.00.00.00.0, Y: 0.00.00.00.0,  Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 10.79510.79510.79510.795, dY: 0.00.00.00.0,  dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: InnerInnerInnerInner

3. Click the OKOKOKOK button

Select objects:Select objects:Select objects:Select objects:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Trace, InnerTrace, InnerTrace, InnerTrace, Inner

2. Click the OK OK OK OK button

3. Select the menu item, 3D Modeler > Boolean > Subtract3D Modeler > Boolean > Subtract3D Modeler > Boolean > Subtract3D Modeler > Boolean > Subtract

4. Subtract Window

1. Blank Parts: TraceTraceTraceTrace

2. Tool Parts: InnerInnerInnerInner

3. Clone tool objects before subtracting: : : : ���� UncheckedUncheckedUncheckedUnchecked

4. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit DrawingView > Fit DrawingView > Fit DrawingView > Fit Drawing.... Or press the CTRL+DCTRL+DCTRL+DCTRL+D key
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6.3-12

Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 4.0 GHz: 4.0 GHz: 4.0 GHz: 4.0 GHz

Maximum Number of Passes: 20202020

Maximum Delta S: 0.020.020.020.02

2. Click the OKOKOKOK button

Adding a Frequency SweepAdding a Frequency SweepAdding a Frequency SweepAdding a Frequency Sweep

To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:

1. Select the menu item HFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add Sweep

1. Select Solution Setup: Setup1 Setup1 Setup1 Setup1 

2. Click the OKOKOKOK button

2. Edit Sweep Window:

1. Sweep Type: Fast: Fast: Fast: Fast

2. Frequency Setup Type: Linear Step: Linear Step: Linear Step: Linear Step

Start: 2.0 GHz2.0 GHz2.0 GHz2.0 GHz

Stop: 7.0 GHz: 7.0 GHz: 7.0 GHz: 7.0 GHz

Step: 0.05 GHz: 0.05 GHz: 0.05 GHz: 0.05 GHz

Save Fields: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Create Reports

Create Terminal SCreate Terminal SCreate Terminal SCreate Terminal S----Parameter Plot vs. Adaptive PassParameter Plot vs. Adaptive PassParameter Plot vs. Adaptive PassParameter Plot vs. Adaptive Pass

Note: Note: Note: Note: If this report is created prior or during the solution process, a real-time 

update of the results are displayed

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Adaptive1Setup1: Adaptive1Setup1: Adaptive1Setup1: Adaptive1

2. Click the X X X X tab

1. Use Primary Sweep: : : : ���� UncheckedUncheckedUncheckedUnchecked

2. Category: VariablesVariablesVariablesVariables

3. Quantity: Pass: Pass: Pass: Pass

3. Click the YYYY tab

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: St(p1,p1), St(p1,p2), St(p1,p3), St(p1,p4)St(p1,p1), St(p1,p2), St(p1,p3), St(p1,p4)St(p1,p1), St(p1,p2), St(p1,p3), St(p1,p4)St(p1,p1), St(p1,p2), St(p1,p3), St(p1,p4)

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button
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Create Terminal SCreate Terminal SCreate Terminal SCreate Terminal S----Parameter Plot Parameter Plot Parameter Plot Parameter Plot ---- MagnitudeMagnitudeMagnitudeMagnitude

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Domain: SweepSweepSweepSweep

3. Click the YYYY tab

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: St(p1,p1), St(p1,p2), St(p1,p3), St(p1,p4)St(p1,p1), St(p1,p2), St(p1,p3), St(p1,p4)St(p1,p1), St(p1,p2), St(p1,p3), St(p1,p4)St(p1,p1), St(p1,p2), St(p1,p3), St(p1,p4)

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_ringhybridhfss_ringhybridhfss_ringhybridhfss_ringhybrid

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 
Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > AnalyzeHFSS > AnalyzeHFSS > AnalyzeHFSS > Analyze
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button
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Terminal STerminal STerminal STerminal S----Parameter Plot vs. Adaptive PassParameter Plot vs. Adaptive PassParameter Plot vs. Adaptive PassParameter Plot vs. Adaptive Pass

Terminal STerminal STerminal STerminal S----Parameter Plot Parameter Plot Parameter Plot Parameter Plot ---- MagnitudeMagnitudeMagnitudeMagnitude
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6.4-1

The Coaxial Stub Resonator
This example is intended to show you how to create, simulate, and optimize a 

coaxial stub resonator, using the Ansoft HFSS Design Environment.
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6.4-2

Ansoft HFSS Design Environment
The following features of the Ansoft HFSS Design Environment are used to 

create this passive device model:

3D Solid Modeling

Primitives: CylindersCylindersCylindersCylinders

Boolean: UnionUnionUnionUnion

Duplicate: Around AxisAround AxisAround AxisAround Axis

Boundaries/Excitations

Excitations: Wave PortsWave PortsWave PortsWave Ports

Analysis

Sweep: Fast FrequencyFast FrequencyFast FrequencyFast Frequency

Optimization

ParametricsParametricsParametricsParametrics Setup Setup Setup Setup 

Optimetrics SetupOptimetrics SetupOptimetrics SetupOptimetrics Setup

Results

Data: Tabular Tabular Tabular Tabular 

Plotting: CartesianCartesianCartesianCartesian
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6.4-3

Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select 

the Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, click the � On the Standard toolbar, or select 

the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose Driven TerminalDriven TerminalDriven TerminalDriven Terminal

2. Click the OKOKOKOK button



Ansoft High Frequency Structure Simulator v10 User’s Guide 

6.4
Example – Coaxial Stub Resonator

6.4-5

Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: mmmmmmmm

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type pecpecpecpec in the Search by NameSearch by NameSearch by NameSearch by Name field

2. Click the OKOKOKOK button
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Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ

Create the Conductor 1Create the Conductor 1Create the Conductor 1Create the Conductor 1

To create the conductorTo create the conductorTo create the conductorTo create the conductor

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.860.860.860.86, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: ----6.06.06.06.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window

2. For the ValueValueValueValue of NameNameNameName type: ConductorConductorConductorConductor

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . Or press the CTRL+DCTRL+DCTRL+DCTRL+D key
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Create the StubCreate the StubCreate the StubCreate the Stub

To create the stubTo create the stubTo create the stubTo create the stub

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.860.860.860.86, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 4.754.754.754.75, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To parameterize the object:To parameterize the object:To parameterize the object:To parameterize the object:

1. Select the CommandCommandCommandCommand tab from the PropertiesPropertiesPropertiesProperties window

2. For HeightHeightHeightHeight, type: LLLL, Click the TabTabTabTab key to accept 

Add Variable LLLL: 4.75mm4.75mm4.75mm4.75mm, Click the OKOKOKOK button

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: StubStubStubStub

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View....

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose vacuumvacuumvacuumvacuum
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Create the BodyCreate the BodyCreate the BodyCreate the Body

To create the bodyTo create the bodyTo create the bodyTo create the body

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 2.02.02.02.0, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: ----6.06.06.06.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: BodyBodyBodyBody

3. Click the OKOKOKOK button

Create Wave Port Excitation 1Create Wave Port Excitation 1Create Wave Port Excitation 1Create Wave Port Excitation 1

Note: Note: Note: Note: To simplify the instructions, a 2D object will be created to represent the 

port.  This is not a requirement for defining ports.  Graphical face selection can 

be used as an alternative.

To create a circle that represents the port:To create a circle that represents the port:To create a circle that represents the port:To create a circle that represents the port:

1. Select the menu item Draw > CircleDraw > CircleDraw > CircleDraw > Circle

2. Using the coordinate entry fields, enter the center position

X: 0.00.00.00.0, Y: ----6.06.06.06.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius of the circle:

dX: 2.02.02.02.0, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: p1p1p1p1

3. Click the OKOKOKOK button

To select the object p1:To select the object p1:To select the object p1:To select the object p1:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: p1p1p1p1

2. Click the OK OK OK OK button

NoteNoteNoteNote:  You can also select the object from the Model Tree
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Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)

To assign wave port excitationTo assign wave port excitationTo assign wave port excitationTo assign wave port excitation

1. Select the menu item HFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave Port

2. Wave Port : General

1. Name: p1p1p1p1, 

2. Click the NextNextNextNext button

3. Wave Port : Terminals

1. Number of Terminals: 1111,

2. For T1T1T1T1, click the UndefinedUndefinedUndefinedUndefined column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: 2.02.02.02.0, Y: ----6.06.06.06.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex

dX: ----1.141.141.141.14, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

5. Click the NextNextNextNext button

4. Wave Port : Differential Pairs 

1. Click the NextNextNextNext button

5. Wave Port : Post Processing 

1. Full Port Impedance: 50505050

6. Click the FinishFinishFinishFinish button
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Create Port 2 ArmCreate Port 2 ArmCreate Port 2 ArmCreate Port 2 Arm

To select the objects Conductor, Body, & p1:To select the objects Conductor, Body, & p1:To select the objects Conductor, Body, & p1:To select the objects Conductor, Body, & p1:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Body, Conductor, p1Body, Conductor, p1Body, Conductor, p1Body, Conductor, p1

Note:Note:Note:Note: Use the Ctrl + Left mouse button to select multiple objects

2. Click the OK OK OK OK button

To create the port 2 arm:To create the port 2 arm:To create the port 2 arm:To create the port 2 arm:

1. Select the menu item, Edit > Duplicate > Around AxisEdit > Duplicate > Around AxisEdit > Duplicate > Around AxisEdit > Duplicate > Around Axis.

1. Axis: XXXX

2. Angle: -90909090

3. Total Number: 2222

4. Click the OK OK OK OK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Create Stub BodyCreate Stub BodyCreate Stub BodyCreate Stub Body

To select the objects Body:To select the objects Body:To select the objects Body:To select the objects Body:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: BodyBodyBodyBody

2. Click the OK OK OK OK button

To create the stub body:To create the stub body:To create the stub body:To create the stub body:

1. Select the menu Select the menu item, Edit > Duplicate > Around AxisEdit > Duplicate > Around AxisEdit > Duplicate > Around AxisEdit > Duplicate > Around Axis.

1. Axis: XXXX

2. Angle: 180180180180

3. Total Number: 2222

4. Click the OK OK OK OK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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Group the Body ObjectsGroup the Body ObjectsGroup the Body ObjectsGroup the Body Objects

To select the objects Body, Body_1, Body_2:To select the objects Body, Body_1, Body_2:To select the objects Body, Body_1, Body_2:To select the objects Body, Body_1, Body_2:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Body, Body_1, Body_2Body, Body_1, Body_2Body, Body_1, Body_2Body, Body_1, Body_2

2. Click the OK OK OK OK button

3. Select the menu item, 3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Group the Conductor & Stub ObjectsGroup the Conductor & Stub ObjectsGroup the Conductor & Stub ObjectsGroup the Conductor & Stub Objects

To select the objects Conductor, Conductor_1, Stub:To select the objects Conductor, Conductor_1, Stub:To select the objects Conductor, Conductor_1, Stub:To select the objects Conductor, Conductor_1, Stub:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Conductor, Conductor_1, StubConductor, Conductor_1, StubConductor, Conductor_1, StubConductor, Conductor_1, Stub

2. Click the OK OK OK OK button

3. Select the menu item, 3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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Boundary DisplayBoundary DisplayBoundary DisplayBoundary Display

To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:

1. Select the menu item HFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary Display (Solver View)(Solver View)(Solver View)(Solver View)

2. From the Solver View of Boundaries, toggle the Visibility check box for the  

boundaries you wish to display.

Note:Note:Note:Note: The background (Perfect Conductor) is displayed as the outerouterouterouter
boundary.

Note:Note:Note:Note: The Perfect Conductors are displayed as the smetalsmetalsmetalsmetal boundary.

Note:Note:Note:Note: Select the menu item, View > VisibilityView > VisibilityView > VisibilityView > Visibility to hide all of the 
geometry objects.  This makes it easier to see the boundary

3. Click the CloseCloseCloseClose button when you are finished

Mesh OperationsMesh OperationsMesh OperationsMesh Operations

To select the object BodyTo select the object BodyTo select the object BodyTo select the object Body

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: BodyBodyBodyBody

2. Click the OK OK OK OK button

To create a mesh operation:To create a mesh operation:To create a mesh operation:To create a mesh operation:

1. Select the menu item HFSS > Mesh Operations > Assign > Inside HFSS > Mesh Operations > Assign > Inside HFSS > Mesh Operations > Assign > Inside HFSS > Mesh Operations > Assign > Inside 
Selection > Length basedSelection > Length basedSelection > Length basedSelection > Length based

2. Element Length Based Refinement Window:

1. Name: : : : Body_MeshBody_MeshBody_MeshBody_Mesh

2. Restrict Length of Elements: : : : � UncheckedUncheckedUncheckedUnchecked

3. Restrict the Number of Elements: � CheckedCheckedCheckedChecked

1. Maximum Number of Elements: 2000200020002000

4. Click the OKOKOKOK button
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Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 13.0 GHz: 13.0 GHz: 13.0 GHz: 13.0 GHz

Maximum Number of Passes: 10101010

Maximum Delta S: 0.020.020.020.02

2. Click the OKOKOKOK button

Adding a Frequency SweepAdding a Frequency SweepAdding a Frequency SweepAdding a Frequency Sweep

To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:

1. Select the menu item HFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add Sweep

1. Select Solution Setup: Setup1 Setup1 Setup1 Setup1 

2. Click the OKOKOKOK button

2. Edit Sweep Window:

1. Sweep Type: Fast: Fast: Fast: Fast

2. Frequency Setup Type: Linear Step: Linear Step: Linear Step: Linear Step

Start: 5.0 GHz5.0 GHz5.0 GHz5.0 GHz

Stop: 20.0 GHz: 20.0 GHz: 20.0 GHz: 20.0 GHz

Step: 0.01 GHz: 0.01 GHz: 0.01 GHz: 0.01 GHz

Save Fields: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Create Terminal SCreate Terminal SCreate Terminal SCreate Terminal S----Parameter Plot Parameter Plot Parameter Plot Parameter Plot ---- MagnitudeMagnitudeMagnitudeMagnitude

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: Rectangular PlotRectangular PlotRectangular PlotRectangular Plot

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Domain: SweepSweepSweepSweep

3. Click the YYYY tab

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: St(p1,p1), St(p1,p2), St(p1,p1), St(p1,p2), St(p1,p1), St(p1,p2), St(p1,p1), St(p1,p2), 

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_stub_resonatorhfss_stub_resonatorhfss_stub_resonatorhfss_stub_resonator

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 
Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > AnalyzeHFSS > AnalyzeHFSS > AnalyzeHFSS > Analyze
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button
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Data MarkersData MarkersData MarkersData Markers

The plot we created prior to the simulation will automatically be updated when the 
analysis completes.  The xy plot should currently be displayed.  If it is not, select 

the menu item Window > XY Plot1Window > XY Plot1Window > XY Plot1Window > XY Plot1 to switch to the plot display

Mark All TracesMark All TracesMark All TracesMark All Traces

1. Select the menu item Report 2D > Mark All TracesReport 2D > Mark All TracesReport 2D > Mark All TracesReport 2D > Mark All Traces

2. Click the Min Min Min Min button 

3. When you are finished, select the menu item Report 2D > Mark All TracesReport 2D > Mark All TracesReport 2D > Mark All TracesReport 2D > Mark All Traces
to remove the marker.
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Optimetrics Setup – Parametric Sweep
During the design of a microwave device, it is common practice to develop 

design trends based on swept parameters.  Ansoft HFSS with Optimetrics 

Parametric Sweep can automatically create these design curves.

Add a Parametric SweepAdd a Parametric SweepAdd a Parametric SweepAdd a Parametric Sweep

1. Select the menu item HFSS > Optimetrics Analysis > Add ParametricHFSS > Optimetrics Analysis > Add ParametricHFSS > Optimetrics Analysis > Add ParametricHFSS > Optimetrics Analysis > Add Parametric

2. Setup Sweep AnalysisSweep AnalysisSweep AnalysisSweep Analysis Window:

1. Click the Sweep DefinitionsSweep DefinitionsSweep DefinitionsSweep Definitions tab::::

1. Click the AddAddAddAdd button

2. Add/Edit Sweep Dialog

1. Select Variable: LLLL

2. Select Linear CountLinear CountLinear CountLinear Count

3. Start: 4.0mm4.0mm4.0mm4.0mm

4. Stop: 5.5mm5.5mm5.5mm5.5mm

5. Count: 5555

6. Click the AddAddAddAdd button

7. Click the OKOKOKOK button

2. Click the OptionsOptionsOptionsOptions tab::::

1. Save Fields and Mesh: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button

Analyze Parametric SweepAnalyze Parametric SweepAnalyze Parametric SweepAnalyze Parametric Sweep

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Expand the Project Tree to display the items listed under OptimetricsOptimetricsOptimetricsOptimetrics

2. Right-click the mouse on ParametricSetup1 ParametricSetup1 ParametricSetup1 ParametricSetup1 and choose Analyze Analyze Analyze Analyze 

Optimetrics ResultsOptimetrics ResultsOptimetrics ResultsOptimetrics Results

To view the Optimetrics Results:To view the Optimetrics Results:To view the Optimetrics Results:To view the Optimetrics Results:

1. Select the menu item HFSS > Optimetrics Analysis > Optimetrics ResultsHFSS > Optimetrics Analysis > Optimetrics ResultsHFSS > Optimetrics Analysis > Optimetrics ResultsHFSS > Optimetrics Analysis > Optimetrics Results

2. Select the ProfileProfileProfileProfile Tab to view the solution progress for each setup.

3. Click the CloseCloseCloseClose button when you are finished viewing the results
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Create Terminal SCreate Terminal SCreate Terminal SCreate Terminal S----Parameter Plot Parameter Plot Parameter Plot Parameter Plot –––– S12 at each LS12 at each LS12 at each LS12 at each L

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: Rectangular PlotRectangular PlotRectangular PlotRectangular Plot

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Domain: SweepSweepSweepSweep

3. Click the SweepsSweepsSweepsSweeps tab

1. Select Sweep Design and Project variable valuesSweep Design and Project variable valuesSweep Design and Project variable valuesSweep Design and Project variable values

4. Click the YYYY tab

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: St(p1,p2)St(p1,p2)St(p1,p2)St(p1,p2)

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

5. Click the DoneDoneDoneDone button
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Optimetrics Setup – Optimization
The Parametric Sweep was useful for generating design curves.  For this simple 

design with only a single variable we could use the design curves to make 

educated guesses at performance targets that are not contained in the 

Parametric Sweep.  Ansoft HFSS and Optimetrics with Optimization takes the 

guess work out of achieving performance targets.  To demonstrate this we will 
target a minimum S12 at 13GHz.  Since this device has a very high Q, we will 

consider anything <= -40dB at 13GHz to be a minimum.  From the Parametric 

Sweep, we can see that the search range can be limited to the range 4.7-5.1mm.  

Since we are only interested in obtaining an optimum solution for 13GHz, we will 

add an additional Solution Setup that does not include the frequency sweep.  
This will reduce the amount of simulation time required to achieve the 

performance goal.

Add an Analysis SetupAdd an Analysis SetupAdd an Analysis SetupAdd an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 13.0 GHz: 13.0 GHz: 13.0 GHz: 13.0 GHz

Maximum Number of Passes: 10101010

Maximum Delta S per Pass: 0.020.020.020.02

2. Click the OKOKOKOK button

Define Optimization Design VariablesDefine Optimization Design VariablesDefine Optimization Design VariablesDefine Optimization Design Variables

To Define Optimization Design VariableTo Define Optimization Design VariableTo Define Optimization Design VariableTo Define Optimization Design Variable

1. Select the menu item HFSS > Design PropertiesHFSS > Design PropertiesHFSS > Design PropertiesHFSS > Design Properties

2. Click the Optimization Optimization Optimization Optimization radio button::::

1. Name: LLLL

2. Include: � CheckedCheckedCheckedChecked

3. Min: 4.0 mm 4.0 mm 4.0 mm 4.0 mm 

4. Max: 5.5 mm5.5 mm5.5 mm5.5 mm

3. Click the OKOKOKOK button
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Add Optimization SetupAdd Optimization SetupAdd Optimization SetupAdd Optimization Setup

1. Select the menu item HFSS > Optimetrics Analysis > Add  OptimizationHFSS > Optimetrics Analysis > Add  OptimizationHFSS > Optimetrics Analysis > Add  OptimizationHFSS > Optimetrics Analysis > Add  Optimization

2. Setup Optimization Window:

1. Click the GoalsGoalsGoalsGoals tab:

1. Optimizer: QuasiQuasiQuasiQuasi----NewtonNewtonNewtonNewton

2. Max. No. of Iterations: 10101010

3. Click the AddAddAddAdd button

4. From the Solution Column, click on the Setup1:Last Adaptive Setup1:Last Adaptive Setup1:Last Adaptive Setup1:Last Adaptive and 

select Setup2:LastAdaptiveSetup2:LastAdaptiveSetup2:LastAdaptiveSetup2:LastAdaptive from the list of solutions

5. Click the Edit CalculationEdit CalculationEdit CalculationEdit Calculation button

6. Setup Output Variables dialog:

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: St(p1,p2)St(p1,p2)St(p1,p2)St(p1,p2)

3. Function: magmagmagmag

4. Click the Insert Quantity Into ExpressionInsert Quantity Into ExpressionInsert Quantity Into ExpressionInsert Quantity Into Expression button

5. Name: s21_mags21_mags21_mags21_mag

6. Click the Add Add Add Add button

7. Click the DoneDoneDoneDone button

7. Condition: <=<=<=<=

8. Goal: 0.010.010.010.01

9. Weight:1111

10. Acceptable Cost: 0000

11. Click the VariablesVariablesVariablesVariables tab:

1. Min: 4.7 mm4.7 mm4.7 mm4.7 mm

2. Max: 5.1mm5.1mm5.1mm5.1mm

12. Click the OKOKOKOK button
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Analyze OptimizationAnalyze OptimizationAnalyze OptimizationAnalyze Optimization

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Expand the Project Tree to display the items listed under OptimetricsOptimetricsOptimetricsOptimetrics

2. Right-click the mouse on OptimizationSetup1 OptimizationSetup1 OptimizationSetup1 OptimizationSetup1 and choose Analyze Analyze Analyze Analyze 

Optimetrics ResultsOptimetrics ResultsOptimetrics ResultsOptimetrics Results

To view the Optimetrics Results:To view the Optimetrics Results:To view the Optimetrics Results:To view the Optimetrics Results:

1. Select the menu item HFSS > Optimetrics Analysis > Optimetrics ResultsHFSS > Optimetrics Analysis > Optimetrics ResultsHFSS > Optimetrics Analysis > Optimetrics ResultsHFSS > Optimetrics Analysis > Optimetrics Results

2. Click the CloseCloseCloseClose button when you are finished viewing the results
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Create Terminal SCreate Terminal SCreate Terminal SCreate Terminal S----Parameter Plot of Optimum ResultParameter Plot of Optimum ResultParameter Plot of Optimum ResultParameter Plot of Optimum Result

Once the Optimization completes, the design will automatically be updated 
with the Optimum value.  To view the performance of the device versus 

frequency will require you to analyze the HFSS project with the optimum 

design value.

To analyze the optimum designTo analyze the optimum designTo analyze the optimum designTo analyze the optimum design

1. Select the menu item HFSS > AnalyzeHFSS > AnalyzeHFSS > AnalyzeHFSS > Analyze

To  view the plotTo  view the plotTo  view the plotTo  view the plot

The existing XY Plot 1XY Plot 1XY Plot 1XY Plot 1 will automatically be updated when the solution 

completes.  

To change to the XY Plot 1 window, select the menu item Window > XY Window > XY Window > XY Window > XY 
Plot 1.Plot 1.Plot 1.Plot 1.
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Microstrip Wave Port
This example is intended to show you how wave port size can influence the 

results of any simulation using the Ansoft HFSS Version 10 Design Environment.
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Ansoft Design Environment
The following features of the Ansoft HFSS Design Environment are used to 

create this passive device model

3D Solid Modeling

Primitives: Boxes, RectangleBoxes, RectangleBoxes, RectangleBoxes, Rectangle

Boolean Operations: Duplicate Along LineDuplicate Along LineDuplicate Along LineDuplicate Along Line

Boundary/Excitation

Ports: Wave Ports and Integration LinesWave Ports and Integration LinesWave Ports and Integration LinesWave Ports and Integration Lines

Analysis

Solution: Ports OnlyPorts OnlyPorts OnlyPorts Only

Sweep: InterpolatingInterpolatingInterpolatingInterpolating

Results

Cartesian plottingCartesian plottingCartesian plottingCartesian plotting

Fields Overlays

Port Field Display Port Field Display Port Field Display Port Field Display 
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Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and 

select the Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Design Review

Generally speaking when we assign a wave port to a microstrip line, or any 

quasi-TEM line, we need to include some area around the actual transmission 

line. The big question is, “how much area?”

Below you will see the cross section of a simple microstrip line with naming 

conventions shown.

As a rule of thumb, we typically create a 2D rectangle to represent the wave port 

stimulus for this type of structure. The dimensions of the rectangle are roughly 

five times the width of the transmission line by four times the height of the 

substrate.

REMEMBER: These are only guidelines !!!

The height of the port will be affected by the permittivity of the substrate. The 

higher the permittivity, the less the fields will propagate in the air, and the shorter 

the port can be made.

~5w

w

h

>4h

The width of the port will affect the port impedance and 

propagating modes. The narrower the width (image on 

right), the more the fields will couple to the side walls of 
the port. This effect may not be physical. The wider the 

port, the greater chance that a higher frequency 

waveguide mode can propagate.

This example will explore this last phenomenon.
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Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

In an  Ansoft HFSS window, click the � On the Standard toolbar, or select 

the menu item File > NewFile > NewFile > NewFile > New.

From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

Solution Type Window:

Choose Driven ModalDriven ModalDriven ModalDriven Modal

Click the OKOKOKOK button

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

Set Model Units:

Select Units: milmilmilmil

Click the OKOKOKOK button
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Add New MaterialAdd New MaterialAdd New MaterialAdd New Material

To add a new material:To add a new material:To add a new material:To add a new material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. From the Select Definition window, click the Add MaterialAdd MaterialAdd MaterialAdd Material button

3. View/Edit Material Window:

1. Material Name: My_RogersMy_RogersMy_RogersMy_Rogers

2. Relative Permittivity: 3.38 3.38 3.38 3.38 

3. Click the OKOKOKOK button

4. Click the OKOKOKOK button
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Create SubstrateCreate SubstrateCreate SubstrateCreate Substrate

To create the substrate:To create the substrate:To create the substrate:To create the substrate:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: ----400.0400.0400.0400.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 200.0200.0200.0200.0, dY: 800.0800.0800.0800.0, dZ: 8.08.08.08.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: SubstrateSubstrateSubstrateSubstrate

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type pecpecpecpec in the Search by NameSearch by NameSearch by NameSearch by Name field

2. Click the OKOKOKOK button
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Create TraceCreate TraceCreate TraceCreate Trace

To create the trace:To create the trace:To create the trace:To create the trace:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: ----9.259.259.259.25, Z: 8.08.08.08.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 200.0200.0200.0200.0, dY: 18.518.518.518.5, dZ: 1.41.41.41.4, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: TraceTraceTraceTrace

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 

Create GroundCreate GroundCreate GroundCreate Ground

To create the ground:To create the ground:To create the ground:To create the ground:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: ----400.0400.0400.0400.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 200.0200.0200.0200.0, dY: 800.0800.0800.0800.0, dZ: ----1.41.41.41.4, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: GroundGroundGroundGround

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 
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Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose vacuumvacuumvacuumvacuum

Create AirCreate AirCreate AirCreate Air

To create the Air:To create the Air:To create the Air:To create the Air:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: ----400.0400.0400.0400.0, Z: ----1.41.41.41.4, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 200.0200.0200.0200.0, dY: 800.0800.0800.0800.0, dZ: 200.0200.0200.0200.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: AirAirAirAir

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 

Create Radiation BoundaryCreate Radiation BoundaryCreate Radiation BoundaryCreate Radiation Boundary

To select the object Air:To select the object Air:To select the object Air:To select the object Air:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: AirAirAirAir

2. Click the OK OK OK OK button

To create a radiation boundaryTo create a radiation boundaryTo create a radiation boundaryTo create a radiation boundary

1. Select the menu item HFSS > Boundaries > Assign > RadiationHFSS > Boundaries > Assign > RadiationHFSS > Boundaries > Assign > RadiationHFSS > Boundaries > Assign > Radiation

2. Radiation Boundary Window

Name: Rad1Rad1Rad1Rad1

Click the OKOKOKOK button
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Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ

Create the Wave PortCreate the Wave PortCreate the Wave PortCreate the Wave Port

To create a rectangle that represents the port:To create a rectangle that represents the port:To create a rectangle that represents the port:To create a rectangle that represents the port:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the center position

X: 0.0: 0.0: 0.0: 0.0, Y: : : : ----200.0200.0200.0200.0, Z: 0.0,: 0.0,: 0.0,: 0.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the rectangle:

dX: 0.0: 0.0: 0.0: 0.0, dY: 400.0: 400.0: 400.0: 400.0, dZ: 50: 50: 50: 50.0000, Press the EnterEnterEnterEnter key

To parameterize the object:To parameterize the object:To parameterize the object:To parameterize the object:

1. Select the CommandCommandCommandCommand tab from the PropertiesPropertiesPropertiesProperties window

2. For PositionPositionPositionPosition, type: 0mil, 0mil, 0mil, 0mil, ----Port_Width/2, 0milPort_Width/2, 0milPort_Width/2, 0milPort_Width/2, 0mil, Click the TabTabTabTab key to accept 

Add Variable Port_WidthPort_WidthPort_WidthPort_Width: 400mil400mil400mil400mil, Click the OKOKOKOK button

3. For YSizeYSizeYSizeYSize, type: Port_WidthPort_WidthPort_WidthPort_Width, Click the TabTabTabTab key to accept 

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Port1Port1Port1Port1

3. Click the OKOKOKOK button
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Assign the Excitation 1Assign the Excitation 1Assign the Excitation 1Assign the Excitation 1

To select the object p1:To select the object p1:To select the object p1:To select the object p1:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Port1Port1Port1Port1

2. Click the OK OK OK OK button

To assign wave port excitationTo assign wave port excitationTo assign wave port excitationTo assign wave port excitation

1. Select the menu item HFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave Port

2. Wave Port : General

1. Name: p1p1p1p1, 

2. Click the NextNextNextNext button

3. Wave Port : Modes

1. Number of Modes: 5555

2. For Mode 1111, click the NoneNoneNoneNone column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.0, 0.0, 0.0, 0.0, Press the Enter Enter Enter Enter key

4. Using the coordinate entry fields, enter the vertex

dX: 0.0, : 0.0, : 0.0, : 0.0, dYdYdYdY: 0.0: 0.0: 0.0: 0.0, dZ: 8.0, 8.0, 8.0, 8.0, Press the Enter Enter Enter Enter key 

For Mode 1111, click the ZpiZpiZpiZpi column and select ZpvZpvZpvZpv

1. Click the NextNextNextNext button

4. Wave Port : Post Processing 

1. Click the NextNextNextNext button

5. Click the FinishFinishFinishFinish button
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Create Wave Port Excitation 2Create Wave Port Excitation 2Create Wave Port Excitation 2Create Wave Port Excitation 2

To select the object Port1:To select the object Port1:To select the object Port1:To select the object Port1:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Port1Port1Port1Port1

2. Click the OK OK OK OK button

To duplicate the port:To duplicate the port:To duplicate the port:To duplicate the port:

1. Select the menu item, Edit > Duplicate > Along LineEdit > Duplicate > Along LineEdit > Duplicate > Along LineEdit > Duplicate > Along Line

2. Using the coordinate entry fields, enter the first point of the duplicate vector

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the second point of the duplicate 

vector

dX: 200.0200.0200.0200.0, dY: 0.00.00.00.0, dZ: 0.0,0.0,0.0,0.0, Press the EnterEnterEnterEnter key

4. Duplicate Along Line Windows

1. Total Number: 2222

2. Click the OKOKOKOK button 

5. Click the DoneDoneDoneDone button
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Boundary DisplayBoundary DisplayBoundary DisplayBoundary Display

To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:

1. Select the menu item HFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary Display (Solver View)(Solver View)(Solver View)(Solver View)

2. From the Solver View of Boundaries, toggle the Visibility check box for the  

boundaries you wish to display.

Note:Note:Note:Note: The background (Perfect Conductor) is displayed as the outerouterouterouter
boundary.

Note:Note:Note:Note: The Perfect Conductors are displayed as the smetalsmetalsmetalsmetal boundary.

Note:Note:Note:Note: Select the menu item, View > VisibilityView > VisibilityView > VisibilityView > Visibility to hide all of the 
geometry objects.  This makes it easier to see the boundary

3. Click the CloseCloseCloseClose button when you are finished
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Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 20GHz: 20GHz: 20GHz: 20GHz

2. Check Solve Ports Only Solve Ports Only Solve Ports Only Solve Ports Only �

3. Click the OKOKOKOK button

Adding a Frequency SweepAdding a Frequency SweepAdding a Frequency SweepAdding a Frequency Sweep

To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:

1. Select the menu item HFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add Sweep

1. Select Solution Setup: Setup1 Setup1 Setup1 Setup1 

2. Click the OKOKOKOK button

2. Edit Sweep Window:

1. Frequency Setup Type: Linear Count: Linear Count: Linear Count: Linear Count

Start: 0.1GHz0.1GHz0.1GHz0.1GHz

Stop: 50.1GHz: 50.1GHz: 50.1GHz: 50.1GHz

Count: 81: 81: 81: 81

3. Edit Setup Interpolation Basis Window:

1. Click the button for Setup Interpolation Basis 

Sweep Type: InterpolatingInterpolatingInterpolatingInterpolating

Error Tolerance: 0.5%0.5%0.5%0.5%

Max Solutions: 20202020

2. Click the OKOKOKOK button

4. Click the OKOKOKOK button
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_waveportshfss_waveportshfss_waveportshfss_waveports

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 
Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > AnalyzeHFSS > AnalyzeHFSS > AnalyzeHFSS > Analyze
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

2. Click the CloseCloseCloseClose button
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Create Reports

Create Propagation Constant vs. FrequencyCreate Propagation Constant vs. FrequencyCreate Propagation Constant vs. FrequencyCreate Propagation Constant vs. Frequency

To Create a report:To Create a report:To Create a report:To Create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Modal S ParametersModal S ParametersModal S ParametersModal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Click the YYYY tab

1. Domain: SweepSweepSweepSweep

2. Category: GammaGammaGammaGamma

3. Quantity: Gamma(p1:1),Gamma(p1:2), Gamma(p1:3), Gamma(p1:1),Gamma(p1:2), Gamma(p1:3), Gamma(p1:1),Gamma(p1:2), Gamma(p1:3), Gamma(p1:1),Gamma(p1:2), Gamma(p1:3), 

Gamma(p1:4), Gamma(p1:5)Gamma(p1:4), Gamma(p1:5)Gamma(p1:4), Gamma(p1:5)Gamma(p1:4), Gamma(p1:5)

4. Function: imimimim

5. Click the Add TraceAdd TraceAdd TraceAdd Trace button

3. Click the DoneDoneDoneDone button

4. See next page for plot and discussion of results
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Create Reports

DiscussionDiscussionDiscussionDiscussion

What does this plot tell us? 

Given the physical size of the wave port object that we created, the fundamental 

mode (p2:1) is a quasi-TEM mode that propagates from DC on up.

This also shows that higher order modes can propagate (b>0) at a high enough 

frequency. The second modes starts propagating at ~14 GHz.

Therefore, if we only needed to simulate up to 10 GHz, we wouldn’t need to size 

our port any different, however, if we need to simulate up to 50 GHz, then we 

need to resize our port to eliminate the higher order propagating modes.

The last part of the exercise will explore this.
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Field Pattern Plots
It might be illuminating to look at the field patterns at the port to discover which 

modes are excited.

To display the Mode field patterns in the modeler:To display the Mode field patterns in the modeler:To display the Mode field patterns in the modeler:To display the Mode field patterns in the modeler:

1. From within the project manager, expand the section Port Field DisplayPort Field DisplayPort Field DisplayPort Field Display

2. Expand p1p1p1p1, and select Mode 2Mode 2Mode 2Mode 2

1. The field pattern will be overlaid on the 3D model. From the plot 

below, Mode 2 is clearly not a microstrip mode, but a TE10-like 

waveguide mode.
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Optimetrics Setup – Parametric Sweep

Add a Parametric SweepAdd a Parametric SweepAdd a Parametric SweepAdd a Parametric Sweep

1. Select the menu item HFSS > Optimetrics Analysis > Add ParametricHFSS > Optimetrics Analysis > Add ParametricHFSS > Optimetrics Analysis > Add ParametricHFSS > Optimetrics Analysis > Add Parametric

2. Setup Sweep AnalysisSweep AnalysisSweep AnalysisSweep Analysis Window:

1. Click the Sweep DefinitionsSweep DefinitionsSweep DefinitionsSweep Definitions tab::::

1. Click the AddAddAddAdd button

2. Add/Edit Sweep Dialog

1. Variable: Port_WidthPort_WidthPort_WidthPort_Width

2. Select Linear StepLinear StepLinear StepLinear Step

3. Start: 200mil200mil200mil200mil

4. Stop: 600mil600mil600mil600mil

5. Step: 100mil100mil100mil100mil

6. Click the AddAddAddAdd >>>>>>>> button

7. Click the OKOKOKOK button

2. Click the OKOKOKOK button
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > SaveFile > SaveFile > SaveFile > Save.

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 

Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Expand the Project Tree to display the items listed under OptimetricsOptimetricsOptimetricsOptimetrics

2. Right-click the mouse on ParametricSetup1 ParametricSetup1 ParametricSetup1 ParametricSetup1 and choose Analyze Analyze Analyze Analyze 
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Create Reports

Create Propagation Constant vs. Frequency vs. Create Propagation Constant vs. Frequency vs. Create Propagation Constant vs. Frequency vs. Create Propagation Constant vs. Frequency vs. Port_WidthPort_WidthPort_WidthPort_Width

To Create a report:To Create a report:To Create a report:To Create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Modal S ParametersModal S ParametersModal S ParametersModal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Click the Sweeps tab

1. Select the Sweep Design and Project Variable ValuesSweep Design and Project Variable ValuesSweep Design and Project Variable ValuesSweep Design and Project Variable Values button

3. Click the YYYY tab

1. Domain: SweepSweepSweepSweep

2. Category: GammaGammaGammaGamma

3. Quantity: Gamma(p1:2), Gamma(p1:2), Gamma(p1:2), Gamma(p1:2), 

4. Function: imimimim

5. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button

5. See next page for plot and discussion of results



Ansoft High Frequency Structure Simulator v10 User’s Guide 

6.5
Example – Wave Ports

6.5-23

Create Reports

DiscussionDiscussionDiscussionDiscussion

What does this plot tell us? 

This shows that as we decrease the width of the port, the frequency at which the 

higher order mode starts to propagate increases.

Therefore, by properly sizing the wave port, you can eliminate any higher order 

propagating modes if you believe that they do not exist.

You need to use caution if you are simulating very high frequencies, i.e., 

millimeter wavelengths, as you may not be able to make the ports small enough 
to eliminate these modes. You probably shouldn’t even try as the higher order 

modes might represent real world effects.
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Dielectric Resonator 
This example is intended to show you how to create, simulate, and analyze a 

shielded cylindrical dielectric resonator using the Ansoft HFSS Design 

Environments eigen mode solver.

A dielectric resonator is intended to operate within a given frequency range and 

the electromagnetic field in the vicinity of the resonator is expect to exhibit 

behavior specific to the desired modes of operation. However, when employing 

resonant circuits, frequencies of undesired modes may interfere with the desired 

modes.

It is therefore of great practical importance to be able to determine the resonant 

frequencies, mode patterns, energy and dissipated power of the modes existing 

in a given structure, such that operation of and coupling to the resonator can be 

determined.

Dielectric 

resonator

Substrate with ground plane

Cavity
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Ansoft HFSS Design Environment
The following features of the Ansoft HFSS Design Environment are used to 

create this passive device model:

3D Solid Modeling

Primitives: CylindersCylindersCylindersCylinders

Variables: Project and model variablesProject and model variablesProject and model variablesProject and model variables

Materials/Boundaries/Excitations

Materials: Defining custom materialsDefining custom materialsDefining custom materialsDefining custom materials

Boundaries: Perfect EPerfect EPerfect EPerfect E

Solution Setup

Parametric sweepParametric sweepParametric sweepParametric sweep

Results

Eigenmode DataEigenmode DataEigenmode DataEigenmode Data – convergence of the individual modes

Formatting plots

Fields: EEEE---- & H& H& H& H----FieldFieldFieldField

Fields: Plotting on custom cutPlotting on custom cutPlotting on custom cutPlotting on custom cut----planesplanesplanesplanes
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Design Review
This example is taken from the book "Finite Element Software for Microwave 

Engineering" by Tatsuo Itoh, Giuseppe Pelosi and Peter P. Silvester, 1996, 

John Wiley & Sons ISBN 0-471-12636-5 (page 62 onwards)

The goal of this simulation is to determine how the resonant modes set up in 

the dielectric resonator changes as the geometry around the resonator 

changes. In particular a variation of the distance from the dielectric resonator 

top to the cavity top will be examined.

There are two methods we could use to analyze this problem:

Method 1:Method 1:Method 1:Method 1: Define e.g. a microstrip transfering in and out of the cavity and 

define excitation of the microstrip. The microstrip will have a loading 

effect on the cavity depending on location, termination etc. Therefore an 

investigation using this approach will be dependent on the feed structure 

and modes may be missed.

Method 2Method 2Method 2Method 2: Use the Eigenmode solver to determine the natural 

resonances of the cylindrical dielectric resonator alone. 

To follow the procedure in the reference, we will use the second method. As 

the eigenmode solver does not use ports we will only have to define the 
geometry and the boundary conditions. We will solve for the first 6 modes 

appearing in the structure.
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Details of the model
The commonly used resonant modes in cylindrical dielectrics are denoted TE0,m,δ, 

TM0,m,δ, and HEMn,m,δ, respectively, for transverse electric, transverse magnetic, 

and hybrid mode. The subscripts m, n, and δ are the azimuthal, radial and axial 

wavenumbers, respectively.

The dimensions in the model are as follows and a picture showing the 
dimensions given below as well.

9.6ε_s

15mmR

1mmh_s

Substrate

36ε_r

10mmD

5mmh

Dielectric resonator

1ε_0

15mmR

6-15mmHwall

Cavity

Hwall

Hs

h εr

εs

R

D

ε0
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Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select 

the Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, click the � On the Standard toolbar, or 

select the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose EigenmodeEigenmodeEigenmodeEigenmode

2. Click the OKOKOKOK button
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Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: mm mm mm mm 

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

Using the 3D Modeler Materials toolbar, choose vacuumvacuumvacuumvacuum

Create the cavityCreate the cavityCreate the cavityCreate the cavity

Create a cylinderCreate a cylinderCreate a cylinderCreate a cylinder

1. Select the cylinder icon from the 3D modeler toolbar

2. Using the coordinate entry fields, enter the base center

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key 

3. Using the 3D Modeler toolbar make sure that the base coordinate entry 

plane is set to xyxyxyxy. Then set the cavity radius in the x entry field and the 

height in the z-entry field. Note: It is not yet possible to use parameters 
directly in the coordinate entry field.

dX: 15: 15: 15: 15, dY: 0.0: 0.0: 0.0: 0.0, dZ: 10, : 10, : 10, : 10, Press the EnterEnterEnterEnter key

Parameterize the height of the cavityParameterize the height of the cavityParameterize the height of the cavityParameterize the height of the cavity

1. In the ‘Height’ entry box write a parameter name called ‘HwallHwallHwallHwall’.

2. Upon hitting the EnterEnterEnterEnter key HFSS will ask you for the value of the parameter

3. Write ’10mm10mm10mm10mm’ – do not forget the units!

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: CavityCavityCavityCavity
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To set the To set the To set the To set the WireframeWireframeWireframeWireframe view:view:view:view:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. Display Wireframe: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
Or press the CTRL+DCTRL+DCTRL+DCTRL+D key

Create New Materials and Set Default MaterialCreate New Materials and Set Default MaterialCreate New Materials and Set Default MaterialCreate New Materials and Set Default Material

Create new materials:Create new materials:Create new materials:Create new materials:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Click ‘Add MaterialAdd MaterialAdd MaterialAdd Material’-button.

3. Set Material Name to subssubssubssubs

4. Set the dielectric permittivity, εεεεrrrr, to 9.69.69.69.6 and leave the rest with their defaults

5. Click ’OKOKOKOK’

6. Add new material called DielResDielResDielResDielRes with εεεεrrrr=36=36=36=36

To set the default material:To set the default material:To set the default material:To set the default material:

1. You can now set default material by selecting subssubssubssubs in the list and clicking OKOKOKOK

Create the substrateCreate the substrateCreate the substrateCreate the substrate

Create a cylinderCreate a cylinderCreate a cylinderCreate a cylinder

1. Select the cylinder icon from the 3D modeler toolbar

2. Using the coordinate entry fields, enter the base center

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key 

3. Set base coordinate entry plane to xy. Then set the radius in the x entry field 

and the height in the z-entry field. 

dX: 15151515, dY: 0.00.00.00.0, dZ: ----1.01.01.01.0, Press the Enter key

To set the name:To set the name:To set the name:To set the name:

1. Select the Attribute tab from the Properties window.

2. For the Value of Name type: SubstrateSubstrateSubstrateSubstrate

You can now set transparency and color to your likingsYou can now set transparency and color to your likingsYou can now set transparency and color to your likingsYou can now set transparency and color to your likings
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Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

Set the default material:Set the default material:Set the default material:Set the default material:

1. Using the 3D Modeler Materials toolbar select the material created previously 

called DielResDielResDielResDielRes.

Create the Dielectric ResonatorCreate the Dielectric ResonatorCreate the Dielectric ResonatorCreate the Dielectric Resonator

Create Cylinder representing resonatorCreate Cylinder representing resonatorCreate Cylinder representing resonatorCreate Cylinder representing resonator

1. Select the cylinder icon from the 3D modeler toolbar

2. Using the coordinate entry fields, enter the base center

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key 

3. Set base coordinate entry plane to xy. Then set the radius in the x entry field 
and the height in the z-entry field. 

dX: 5.05.05.05.0, dY: 0.00.00.00.0, dZ: 5.05.05.05.0, Press the Enter key

To set the name:To set the name:To set the name:To set the name:

1. Select the Attribute tab from the Properties window.

2. For the Value of Name type: DielResDielResDielResDielRes

You can now set transparency and color to your likingsYou can now set transparency and color to your likingsYou can now set transparency and color to your likingsYou can now set transparency and color to your likings

Setting Boundary ConditionsSetting Boundary ConditionsSetting Boundary ConditionsSetting Boundary Conditions

We have know defined the complete model, the only thing missing before running the 

analysis is what boundary condition should be applied to the other part of the cavity 

and the substrate. 

HFSS assigns per default ‘Perfect Electrical Conductor’ (PEC) to any boundary exposed 
to the background. This default assignment can be overriden if you wanted to 

enclose the resonator in e.g. a aluminum cavity. This would  have an effect on the 

quality factor and the resonant modes. How much influence we could easily 

determine using the eigenmode solver.

However for this exercise we will just stick to the default behaviour of HFSS, and 
therefore we will effectively enclose the resonator in perfectly conducting cavity.
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Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Minimum Frequency: 3 GHz: 3 GHz: 3 GHz: 3 GHz

Number of Modes: 6: 6: 6: 6

Maximum Number of Passes: 14141414

Maximum Delta Frequency per Pass: 2.52.52.52.5%

2. Under the OptionsOptionsOptionsOptions tab:

Minimum Converged Passes : 3: 3: 3: 3

Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_diel_reshfss_diel_reshfss_diel_reshfss_diel_res

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

It is possible to check the validity of the model you have builtIt is possible to check the validity of the model you have builtIt is possible to check the validity of the model you have builtIt is possible to check the validity of the model you have built before sending it off before sending it off before sending it off before sending it off 

to be solved. This can e.g. be extremely useful before starting to be solved. This can e.g. be extremely useful before starting to be solved. This can e.g. be extremely useful before starting to be solved. This can e.g. be extremely useful before starting a large simulation.a large simulation.a large simulation.a large simulation.

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 

Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > AnalyzeHFSS > AnalyzeHFSS > AnalyzeHFSS > Analyze
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile (memory use, solution time and no. of To view the Profile (memory use, solution time and no. of To view the Profile (memory use, solution time and no. of To view the Profile (memory use, solution time and no. of 

tetrahedratetrahedratetrahedratetrahedra):):):):

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 
the convergence data.

To view the Eigenmode Data:To view the Eigenmode Data:To view the Eigenmode Data:To view the Eigenmode Data:

1. Click the EignemodeEignemodeEignemodeEignemode DataDataDataData Tab. You will notice that the 

following modes has been found:
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Solution Data (continued)Solution Data (continued)Solution Data (continued)Solution Data (continued)

2. You will notice that some of the modes comes in pairs – they 

are degenerate modes. You will also see this later in the 

exercise when we plot the fields inside the structure.

Note: Note: Note: Note: To view a real-time update of the Eigenmode Data, set 
the Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button

We will now view the convergence of the individual modes rather We will now view the convergence of the individual modes rather We will now view the convergence of the individual modes rather We will now view the convergence of the individual modes rather than looking at than looking at than looking at than looking at 

the convergence through the HFSS convergence criteria, the convergence through the HFSS convergence criteria, the convergence through the HFSS convergence criteria, the convergence through the HFSS convergence criteria, ∆∆∆∆f in percent.f in percent.f in percent.f in percent.

1. Select the menu item HFSS > Results > Create Report

2. Create Report Window:

1. Report Type: Eigenmode Parameters

2. Display Type: Rectangular

3. Click the OK button

3. Traces Window:

1. Solution: Setup1: Adaptive_1

2. Click the Y tab

3. Category: Eigen Modes

4. Quantity: Mode(1), Mode(2), .... Mode(6). You can use CTRL for 

multiple select.

5. Function: Re

6. Click the Add Trace button

7. Click the Done button

4. The plot you now see we need to format at bit to make it more easily 

readable. 

1. Double click on the y-axis numbers. This will get you the following 
dialogue:
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Solution Data (continued)Solution Data (continued)Solution Data (continued)Solution Data (continued)

2. Click the ScalingScalingScalingScaling-tab.

3. Click the checkbox ‘Scientific NotationScientific NotationScientific NotationScientific Notation’

4. Write e.g. ‘Resonant Frequency [Hz]Resonant Frequency [Hz]Resonant Frequency [Hz]Resonant Frequency [Hz]’ in the ‘Label’ text field

Note: Note: Note: Note: To view a real-time update of the Eigenmode Data, set 
the Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button

As you can see, the modes HFSS has found stays fairly constant in frequency 

versus iteration number after pass number 7. It is also easily identified that mode 
pair 5 & 6 as well as mode pair 1 & 2 are actually one and the same. The glitch in 

mode 5 between adaptive pass 4 and 6 is caused by the fact that mode 5  is not 

well represented by the mesh at pass no. 4. However, as mode 5 is degenerate 

we could most likely have plotted the fields at adaptive pass 4 by looking at the 

field distribution of mode 6 instead, and using our knowlegde that the fields of the 
degenerate modes are orthogonal.
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Field Overlays
We will now take the opportunity to look at the eigenmodes that HFSS has found. 

HFSS includes a number of different plotting techniques which will be explored in 

this section.

Create Field OverlayCreate Field OverlayCreate Field OverlayCreate Field Overlay

To create a field plot:To create a field plot:To create a field plot:To create a field plot:

1. Select the Global:XZGlobal:XZGlobal:XZGlobal:XZ-plane in the model tree under the folder Planes. Planes. Planes. Planes. 

2. Select the menu item HFSS > Fields > HFSS > Fields > HFSS > Fields > HFSS > Fields > FieldsFieldsFieldsFields > E > > E > > E > > E > Mag_EMag_EMag_EMag_E

3. Create Field Plot Window

1. Solution: Setup1 :  Setup1 :  Setup1 :  Setup1 :  LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Quantity: Mag_EMag_EMag_EMag_E

3. In Volume: AllAllAllAll

4. Click the DoneDoneDoneDone button

4. You will now see the distribution of the Magnitude of the E-field on the XZ-

cross plane for the complete model. 

NoteNoteNoteNote: HFSS will be default display the first mode in the structure.

6. To change the mode excitation of the structure

1. Select the menu item HFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit Sources

2. Edit Sources window

1. Set source: EigenMode_1EigenMode_1EigenMode_1EigenMode_1 to magnitude: 0000 and phase: 0000

2. Source: EigenMode_2EigenMode_2EigenMode_2EigenMode_2 to magnitude: 1111 and phase: 0000

3. Click the OKOKOKOK button

Mode 1: Magnitude of EMode 1: Magnitude of EMode 1: Magnitude of EMode 1: Magnitude of E----FieldFieldFieldField
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Magnitude of E plots in the XZ-plane
The following is a plot of the different mode field distribution in the XZ-plane, 

which has been created by modifying the source excitation.

Mode 1: Magnitude of EMode 1: Magnitude of EMode 1: Magnitude of EMode 1: Magnitude of E----FieldFieldFieldField Mode 2: Magnitude of EMode 2: Magnitude of EMode 2: Magnitude of EMode 2: Magnitude of E----FieldFieldFieldField

Mode 3: Magnitude of EMode 3: Magnitude of EMode 3: Magnitude of EMode 3: Magnitude of E----FieldFieldFieldField Mode 4: Magnitude of EMode 4: Magnitude of EMode 4: Magnitude of EMode 4: Magnitude of E----FieldFieldFieldField

Mode 5: Magnitude of EMode 5: Magnitude of EMode 5: Magnitude of EMode 5: Magnitude of E----FieldFieldFieldField Mode 6: Magnitude of EMode 6: Magnitude of EMode 6: Magnitude of EMode 6: Magnitude of E----FieldFieldFieldField
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Magnitude of H plots in the XZ-plane
The following is a plot of the different mode field distributions in the XZ-plane for 

the H field. 

NoteNoteNoteNote: The field distribution patters for the H-field will at the default excitation 

(phase = 0) at times (depending on the setup) seemingly not provide any field –

i.e. the 

Mode 1: Magnitude of HMode 1: Magnitude of HMode 1: Magnitude of HMode 1: Magnitude of H----FieldFieldFieldField Mode 2: Magnitude of HMode 2: Magnitude of HMode 2: Magnitude of HMode 2: Magnitude of H----FieldFieldFieldField

Mode 3: Magnitude of HMode 3: Magnitude of HMode 3: Magnitude of HMode 3: Magnitude of H----FieldFieldFieldField Mode 4: Magnitude of HMode 4: Magnitude of HMode 4: Magnitude of HMode 4: Magnitude of H----FieldFieldFieldField

Mode 5: Magnitude of HMode 5: Magnitude of HMode 5: Magnitude of HMode 5: Magnitude of H----FieldFieldFieldField Mode 6: Magnitude of HMode 6: Magnitude of HMode 6: Magnitude of HMode 6: Magnitude of H----FieldFieldFieldField
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Plotting Field Data on Custom Cut-plane
It is possible to plot the field data on a custom defined cutplane. We will do this in the 

following:

1. Create a new coordinate system which contains the cross plane of interest.

1. Select 3D Modeler3D Modeler3D Modeler3D Modeler---->Coordinate System>Coordinate System>Coordinate System>Coordinate System---->Create>Create>Create>Create---->Relative CS>Relative CS>Relative CS>Relative CS---->Both>Both>Both>Both

2. Set origin to be at the center of the resonator by using the coordinate 

entry field:

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 5.00 / 25.00 / 25.00 / 25.00 / 2, Press the EnterEnterEnterEnter key 

3. Set the X-axis location

dX: 5.005.005.005.00, Y: 0.00.00.00.0, Z: -5.00 / 25.00 / 25.00 / 25.00 / 2, Press the EnterEnterEnterEnter key 

4. Set the XY-plane (remember to select AbsoluteAbsoluteAbsoluteAbsolute referencing on the 

coordinate toolbar)

X: 0.00.00.00.0, Y: 5.05.05.05.0, Z: 0.0 0.0 0.0 0.0 , Press the EnterEnterEnterEnter key 

5. You will now see a new coordinate system called RelativeCS1RelativeCS1RelativeCS1RelativeCS1. The cut-

planes of this coordinate system can be selected in the Model Tree 
under the tab called Planes.Planes.Planes.Planes.

6. Select RelativeCS1:XYRelativeCS1:XYRelativeCS1:XYRelativeCS1:XY

7. Select HFSS > Fields > Fields > H > HFSS > Fields > Fields > H > HFSS > Fields > Fields > H > HFSS > Fields > Fields > H > Mag_HMag_HMag_HMag_H and accept the defaults 
except setting PhasePhasePhasePhase to 180deg. Do the same for Vector_HVector_HVector_HVector_H.
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Optimetrics Setup – Parametric Sweep
We would now like to examine how the resonant frequencies changes as we 

change the the heigh of the cavity, HWall.  Ansoft HFSS with Optimetrics 

Parametric Sweep can automatically create these design curves.

Since the structure already is parameterized with respect to HWall, we will only 

need to create a parametric sweep. Afterwards we can then generate design trend 
curves to see how the modes shift.

NoteNoteNoteNote: This exercise, will depending on the speed of your computer take quite 

some time. It took approximately 3.5 hours to solve on a 2.2GHz machine using at 
most 130Mb of RAM. Therefore if you want to follow this part of the exercise, you 

may want to reserve yourself more time than what is alloted during the standard 

Ansoft Training courses.  Nevertheless, the exercise will give you some important 

insight into how the parametric analysis works together with the eigenmode solver 

in HFSS. Therefore, you may want to consider to 

1. Reduce the Maximum number of adaptive passes used to 8

2. Reduce the number of HWall steps to 4 (using ‘Linear Count’ in the analysis 

setup)

3. Reduce the number of modes solved for to 4 (the TE0,m,δ, TM0,m,δ, and HEM 
modes + 1 degenerate)..

Add a Parametric SweepAdd a Parametric SweepAdd a Parametric SweepAdd a Parametric Sweep

1. Select the menu item HFSS > Optimetrics Analysis > Add ParametricHFSS > Optimetrics Analysis > Add ParametricHFSS > Optimetrics Analysis > Add ParametricHFSS > Optimetrics Analysis > Add Parametric

2. Setup Sweep AnalysisSweep AnalysisSweep AnalysisSweep Analysis Window:

1. Click the Sweep DefinitionsSweep DefinitionsSweep DefinitionsSweep Definitions tab::::

1. Click the AddAddAddAdd button

2. Add/Edit Sweep Dialog

1. Variable: HWallHWallHWallHWall

2. Select Linear StepLinear StepLinear StepLinear Step

3. Start: 6mm6mm6mm6mm

4. Stop: 15mm15mm15mm15mm

5. Step: 1mm1mm1mm1mm

6. Click the AddAddAddAdd >>>>>>>> button

7. Click the OKOKOKOK button

2. Click on the GeneralGeneralGeneralGeneral tab::::

1. Save Fields: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > SaveFile > SaveFile > SaveFile > Save.

Analyze
To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS HFSS HFSS HFSS ----> Analyze> Analyze> Analyze> Analyze

As previously mentioned this will take a couple of hours to solve depending 

on your solution settings.

Create Reports

Create Mode plot vs. Create Mode plot vs. Create Mode plot vs. Create Mode plot vs. HHHHWallWallWallWall

To Create a report:To Create a report:To Create a report:To Create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Eigenmode Eigenmode Eigenmode Eigenmode ParamtersParamtersParamtersParamters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Setup1: Setup1: Setup1: LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Click the Sweeps tab

1. Select the Sweep Design and Project Variable ValuesSweep Design and Project Variable ValuesSweep Design and Project Variable ValuesSweep Design and Project Variable Values button, 

to be able to look at the parametric sweeps and not only the 

nominal design

2. In the table make sure HHHHWallWallWallWall appears in the top of the Name 

column

3. Click the YYYY tab

1. Category: Eigen Modes

2. Quantity: Mode(1), Mode(2), .... Mode(6). 

3. Function: Re

4. Click the Add Trace button

4. Click the DoneDoneDoneDone button

4. Results can be seen on the following page, together with results from the 

reference stated on page 3.
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Mode dependence on Hwall

Modes found by HFSSModes found by HFSSModes found by HFSSModes found by HFSS

Modes found by Modes found by Modes found by Modes found by ItohItohItohItoh et al.et al.et al.et al.

Mode 1Mode 1Mode 1Mode 1

Mode 2Mode 2Mode 2Mode 2

Mode 3Mode 3Mode 3Mode 3

Mode 4Mode 4Mode 4Mode 4
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Parametric investigation of mode dependence on Hwall
From the mode investigations on the previous page it is apparent that the results 

seems to qualitative the same. However ‘Mode 1’ which one would immediately 

think represents the TM01δ-mode seems to flatten off towards4.92GHz rather than 

rising to 5.72GHz at Hwall=15mm. This appears as a wrong result, but really is 

not. Rather this is due to the fact that :

HFSS orders the modes such that the lowest resonant frequency always 

will be Mode1, the second lowest resonant frequency will always be Mode2 

etc. That is

ffffMode1Mode1Mode1Mode1 < f< f< f< fMode2Mode2Mode2Mode2 < f< f< f< fMode3Mode3Mode3Mode3 < .... < f< .... < f< .... < f< .... < fMode[n]Mode[n]Mode[n]Mode[n]

Therefore to correlate the results we need to take this into consideration. We thus 

see that 

The TE01δ-mode is represented by Mode 4 upto HWall=12mm and thereafter 
by Mode 3

The TM01δ-mode is represented by Mode 1 upto HWall=8mm. Upto 12mm by 

Mode 3 and then finally by Mode 4 upto 16mm.

The hybrid mode, HEM, will be represented by Mode 3 upto HWall=8mm 

and upwards by Mode 1 / Mode 2 (which again will be degenerate. 

If we needed to determine the above without using a reference like Itoh, we 

would need to look at field plots to determine what the different modes found by 

HFSS represents. But as you have seen this is a fairly easy task simply but 

plotting the E and / or H fields in a cross section or within either the complete 
model volume or within specific parts of the model.

This concludes the exercise.



��������	��
�	
���
��
��	������
�



Ansoft High Frequency Structure Simulator v10 User’s Guide 

Chapter 7.0
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7.1 – Bandpass Filter 

7.2 – Bandstop Filter
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Bandpass Filter
This example is intended to show you how to create, simulate, and analyze a 

bandpass filter using the Ansoft HFSS Design Environment.

Nominal Design:Nominal Design:Nominal Design:Nominal Design:

FFFFcentercentercentercenter = 1.50 GHz= 1.50 GHz= 1.50 GHz= 1.50 GHz

BW = 1 GHzBW = 1 GHzBW = 1 GHzBW = 1 GHz
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Ansoft Design Environment
The following features of the Ansoft HFSS Design Environment are used to 

create this passive device model

3D Solid Modeling

Primitives: Cylinders, BoxesCylinders, BoxesCylinders, BoxesCylinders, Boxes

Boolean Operations: Duplicate Around AxisDuplicate Around AxisDuplicate Around AxisDuplicate Around Axis

Boundary/Excitation

Ports: Wave Ports and Terminal LinesWave Ports and Terminal LinesWave Ports and Terminal LinesWave Ports and Terminal Lines

Analysis

Sweep: Fast FrequencyFast FrequencyFast FrequencyFast Frequency

Results

Cartesian plottingCartesian plottingCartesian plottingCartesian plotting

Fields Overlays

2D & 3D Field Plots2D & 3D Field Plots2D & 3D Field Plots2D & 3D Field Plots



Ansoft High Frequency Structure Simulator v10 User’s Guide 

7.1
Example – Bandpass Filter

7.1-3

Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and 

select the Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

In an  Ansoft HFSS window, click the � On the Standard toolbar, or select 

the menu item File > NewFile > NewFile > NewFile > New.

From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

Solution Type Window:

Choose Driven TerminalDriven TerminalDriven TerminalDriven Terminal

Click the OKOKOKOK button
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Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

Set Model Units:

Select Units: inininin

Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

Using the 3D Modeler Materials toolbar, choose vacuumvacuumvacuumvacuum

Create BodyCreate BodyCreate BodyCreate Body

To create body:To create body:To create body:To create body:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----1.01.01.01.0, Y: ----1.71.71.71.7, Z: ----0.31250.31250.31250.3125, Press the EnterEnterEnterEnter key

2. Using the coordinate entry fields, enter the opposite corner of the box

dX: 2.02.02.02.0, dY: 3.43.43.43.4, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

1. Using the coordinate entry fields, enter the box hieght

dX: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.6250.6250.6250.625, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: airairairair

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . Or press the CTRL+DCTRL+DCTRL+DCTRL+D key
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Create coax outer diameterCreate coax outer diameterCreate coax outer diameterCreate coax outer diameter

To create the outer diameter:To create the outer diameter:To create the outer diameter:To create the outer diameter:

1. From the Drawing Plane toolbar, change the active plane to YZYZYZYZ.

2. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

3. Using the coordinate entry fields, enter the center position

X: 1.01.01.01.0, Y: ----0.90.90.90.9, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the radius of the cylinder

dX: 0.00.00.00.0, dY: 0.140.140.140.14, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

5. Using the coordinate entry fields, enter the height of the cylinder

dX: 0.750.750.750.75, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the Enter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: feed1feed1feed1feed1

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type pecpecpecpec in the Search by NameSearch by NameSearch by NameSearch by Name field

2. Click the OKOKOKOK button
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Create coax inner diameterCreate coax inner diameterCreate coax inner diameterCreate coax inner diameter

To create the inner diameter:To create the inner diameter:To create the inner diameter:To create the inner diameter:

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the center position

X: 1.01.01.01.0, Y: ----0.90.90.90.9, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius of the cylinder

dX: 0.00.00.00.0, dY: 0.060.060.060.06, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height of the cylinder

dX: 0.750.750.750.75, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: feedin1feedin1feedin1feedin1

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 

Create the coax feed probeCreate the coax feed probeCreate the coax feed probeCreate the coax feed probe

To create the coax feed probe:To create the coax feed probe:To create the coax feed probe:To create the coax feed probe:

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the center position

X: 1.01.01.01.0, Y: ----0.90.90.90.9, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius of the cylinder

dX: 0.00.00.00.0, dY: 0.060.060.060.06, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height of the cylinder

dX: ----0.150.150.150.15, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: feedprobe1feedprobe1feedprobe1feedprobe1

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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Create the resonatorsCreate the resonatorsCreate the resonatorsCreate the resonators

To create l1:To create l1:To create l1:To create l1:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0.850.850.850.85, Y: ----0.96250.96250.96250.9625, Z: ----0.030.030.030.03, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box

dX: ----1.71.71.71.7, dY: 0.1250.1250.1250.125, dZ: 0.060.060.060.06, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: l1l1l1l1

3. Click the OKOKOKOK button

To create l2:To create l2:To create l2:To create l2:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----1.01.01.01.0, Y: ----0.750.750.750.75, Z: ----0.030.030.030.03, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box

dX: 1.8181.8181.8181.818, dY: 0.1250.1250.1250.125, dZ: 0.060.060.060.06, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: l2l2l2l2

3. Click the OKOKOKOK button

To create l3:To create l3:To create l3:To create l3:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 1.01.01.01.0, Y: ----0.480.480.480.48, Z: ----0.030.030.030.03, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box

dX: ----1.8181.8181.8181.818, dY: 0.1250.1250.1250.125, dZ: 0.060.060.060.06, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: l3l3l3l3

3. Click the OKOKOKOK button
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Create the resonators (Continued)Create the resonators (Continued)Create the resonators (Continued)Create the resonators (Continued)
To create l4:To create l4:To create l4:To create l4:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----1.01.01.01.0, Y: ----0.20.20.20.2, Z: ----0.030.030.030.03, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box

dX: 1.8181.8181.8181.818, dY: 0.1250.1250.1250.125, dZ: 0.060.060.060.06, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: l4l4l4l4

3. Click the OKOKOKOK button

Create the Wave portCreate the Wave portCreate the Wave portCreate the Wave port
Picking the port face:Picking the port face:Picking the port face:Picking the port face:

1. Select the menu item Edit > Select > FacesEdit > Select > FacesEdit > Select > FacesEdit > Select > Faces

2. Graphically select the outer face of the coax line at X=1.75in

To assign the wave port excitation:To assign the wave port excitation:To assign the wave port excitation:To assign the wave port excitation:

1. Select the menu item HFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave Port

2. Wave Port: General

Name: p1p1p1p1

Click the NextNextNextNext button

3. Wave Port: Terminals

1. Number of Terminals: 1111,

2. For T1T1T1T1, click the UndefinedUndefinedUndefinedUndefined column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: 1.751.751.751.75, Y: ----0.90.90.90.9, Z: ----0.140.140.140.14, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 0.080.080.080.08, Press the EnterEnterEnterEnter key

5. Click the NextNextNextNext button

4. Wave Port : Differential Pairs 

1. Click the NextNextNextNext button

5. Wave Port : Post Processing 

1. Full Port Impedance : 50505050

6. Click the FinishFinishFinishFinish button
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Set Object SelectionSet Object SelectionSet Object SelectionSet Object Selection

Set select to objects

1. Select the menu item Edit > Select > ObjectsEdit > Select > ObjectsEdit > Select > ObjectsEdit > Select > Objects

Create rest of model by duplicationCreate rest of model by duplicationCreate rest of model by duplicationCreate rest of model by duplication

To select objects to be duplicated:To select objects to be duplicated:To select objects to be duplicated:To select objects to be duplicated:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: feed1, feedpin1, feedprobe1, l1, l2, l3, l4feed1, feedpin1, feedprobe1, l1, l2, l3, l4feed1, feedpin1, feedprobe1, l1, l2, l3, l4feed1, feedpin1, feedprobe1, l1, l2, l3, l4

Note:Note:Note:Note: Use the Ctrl + Left mouse button to select multiple objects

2. Click the OK OK OK OK button

To create rest of model:To create rest of model:To create rest of model:To create rest of model:

1. Select the menu item Edit > Duplicate > Around AxisEdit > Duplicate > Around AxisEdit > Duplicate > Around AxisEdit > Duplicate > Around Axis

Axis: ZZZZ

Angle: 180180180180

Total Number: 2222

Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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Boundary DisplayBoundary DisplayBoundary DisplayBoundary Display

To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:

1. Select the menu item HFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary Display (Solver View)(Solver View)(Solver View)(Solver View)

2. From the Solver View of Boundaries, toggle the Visibility check box for the  

boundaries you wish to display.

Note:Note:Note:Note: The background (Perfect Conductor) is displayed as the outerouterouterouter
boundary.

Note:Note:Note:Note: The Perfect Conductors are displayed as the smetalsmetalsmetalsmetal boundary.

Note:Note:Note:Note: Select the menu item, View > VisibilityView > VisibilityView > VisibilityView > Visibility to hide all of the 
geometry objects.  This makes it easier to see the boundary

3. Click the CloseCloseCloseClose button when you are finished
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Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 1.5GHz: 1.5GHz: 1.5GHz: 1.5GHz

Maximum Number of Passes: 15151515

Maximum Delta S per Pass: 0.020.020.020.02

2. Click the OKOKOKOK button

Adding a Frequency SweepAdding a Frequency SweepAdding a Frequency SweepAdding a Frequency Sweep

To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:

1. Select the menu item HFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add Sweep

1. Select Solution Setup: Setup1 Setup1 Setup1 Setup1 

2. Click the OKOKOKOK button

2. Edit Sweep Window:

1. Sweep Type: Fast: Fast: Fast: Fast

2. Frequency Setup Type: Linear Count: Linear Count: Linear Count: Linear Count

Start: 0.6GHz0.6GHz0.6GHz0.6GHz

Stop: 2.4GHz: 2.4GHz: 2.4GHz: 2.4GHz

Count: 451: 451: 451: 451

Save Fields: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_bpfhfss_bpfhfss_bpfhfss_bpf

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 
Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > AnalyzeHFSS > AnalyzeHFSS > AnalyzeHFSS > Analyze
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button
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Create Reports

Create SCreate SCreate SCreate S----parameter vs. Frequencyparameter vs. Frequencyparameter vs. Frequencyparameter vs. Frequency

To Create a report:To Create a report:To Create a report:To Create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Click the YYYY tab

1. Domain: SweepSweepSweepSweep

2. Category: Terminal STerminal STerminal STerminal S----ParametersParametersParametersParameters

3. Quantity: S(p1,p1), S(p2,p1)S(p1,p1), S(p2,p1)S(p1,p1), S(p2,p1)S(p1,p1), S(p2,p1)

4. Function: dBdBdBdB

5. Click the Add TraceAdd TraceAdd TraceAdd Trace button

3. Click the DoneDoneDoneDone button
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Add a zoomed trace to the existing plotAdd a zoomed trace to the existing plotAdd a zoomed trace to the existing plotAdd a zoomed trace to the existing plot

To modify an existing plot:To modify an existing plot:To modify an existing plot:To modify an existing plot:

Right mouse click on the existing plot

Select Modify Report…Modify Report…Modify Report…Modify Report… from the context menu

To add the trace:To add the trace:To add the trace:To add the trace:

1. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Click the YYYY tab

1. Domain: SweepSweepSweepSweep

2. Category: Terminal STerminal STerminal STerminal S----ParametersParametersParametersParameters

3. Quantity: S(p2,p1)S(p2,p1)S(p2,p1)S(p2,p1)

4. Function: dBdBdBdB

5. Click the Add TraceAdd TraceAdd TraceAdd Trace button

3. From the listing at the top of the Traces window, select the axis 
pulldown for the second instance of S(p2,p1), and select Y2Y2Y2Y2

4. Click the DoneDoneDoneDone button
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Change Plot ScaleChange Plot ScaleChange Plot ScaleChange Plot Scale

Plot window:

1. Double click on the Y-axis on the right right right right side of the plot, 

2. Y Axis Properties Dialog

1. Click the Scaling Scaling Scaling Scaling tab

2. Autoscale: ���� UncheckedUncheckedUncheckedUnchecked

3. Min: ----1.01.01.01.0

4. Max: 0.00.00.00.0

5. Click the OK OK OK OK button



Ansoft High Frequency Structure Simulator v10 User’s Guide 

7.1
Example – Bandpass Filter

7.1-18

Field Overlays

Set Sources: Terminate Port Set Sources: Terminate Port Set Sources: Terminate Port Set Sources: Terminate Port 

To set the port termination:To set the port termination:To set the port termination:To set the port termination:

1. Select the menu item HFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit Sources

2. Edit Sources Window::::

1. Select source: p2:T1: p2:T1: p2:T1: p2:T1

Terminated: : : : � CheckedCheckedCheckedChecked

Resistance: 50: 50: 50: 50

Reactance: 0 : 0 : 0 : 0 

2. Click the OKOKOKOK button
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Field Overlays (Continued)

Create Field Overlay Create Field Overlay Create Field Overlay Create Field Overlay 

Select the Global XY PlaneSelect the Global XY PlaneSelect the Global XY PlaneSelect the Global XY Plane

1. Using the Model Tree, expand PlanesPlanesPlanesPlanes

1. Select Global:XYGlobal:XYGlobal:XYGlobal:XY

2. Select the menu item HFSS > Fields > Fields > E > HFSS > Fields > Fields > E > HFSS > Fields > Fields > E > HFSS > Fields > Fields > E > Mag_EMag_EMag_EMag_E

3. Create Field Plot Window

1. Solution: Setup1 :  Setup1 :  Setup1 :  Setup1 :  LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Quantity: Mag_EMag_EMag_EMag_E

3. In Volume: AllAllAllAll

4. Click the DoneDoneDoneDone button

To modify the attributes of a field plot:To modify the attributes of a field plot:To modify the attributes of a field plot:To modify the attributes of a field plot:

1. Select the menu item HFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot Attributes

2. Select Plot Folder Window:

1. Select: E FieldE FieldE FieldE Field

2. Click the OKOKOKOK button

3. E-Field1 Window:

1. Click the Scale Scale Scale Scale tab

1. Select Use LimitsUse LimitsUse LimitsUse Limits

2. Min: 5555

3. Max: 1500150015001500

4. Scale: LogLogLogLog

2. Click the CloseCloseCloseClose button
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7.2-1

The Microstrip Bandstop Filter
This example is intended to show you how to create, simulate, and analyze a 

microstrip filter using the Ansoft HFSS Design Environment.

Nominal Design:Nominal Design:Nominal Design:Nominal Design:

L1 = 91.2 milL1 = 91.2 milL1 = 91.2 milL1 = 91.2 mil

L2 = 86.4 mil L2 = 86.4 mil L2 = 86.4 mil L2 = 86.4 mil 

S =S =S =S = 4.8 mil4.8 mil4.8 mil4.8 mil

L1L1L1L1

L2L2L2L2

SSSS
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7.2-2

Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and 

select the Ansoft > HFSS 10Ansoft > HFSS 10Ansoft > HFSS 10Ansoft > HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

In an  Ansoft HFSS window, click the � On the Standard toolbar, or select 

the menu item File > NewFile > NewFile > NewFile > New.

From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

Solution Type Window:

Choose Driven TerminalDriven TerminalDriven TerminalDriven Terminal

Click the OKOKOKOK button
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Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: milmilmilmil

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type pecpecpecpec in the Search by NameSearch by NameSearch by NameSearch by Name field

2. Click the OKOKOKOK button
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Create Input 1Create Input 1Create Input 1Create Input 1

To create the input:To create the input:To create the input:To create the input:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: ----4.84.84.84.8, dY: ----14.414.414.414.4, dZ: 0.10.10.10.1, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Input1Input1Input1Input1

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 

Create L1Create L1Create L1Create L1

To create L1:To create L1:To create L1:To create L1:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: ----4.84.84.84.8, dY: 91.291.291.291.2, dZ: 0.10.10.10.1, Press the EnterEnterEnterEnter key

To parameterize the object:To parameterize the object:To parameterize the object:To parameterize the object:

1. Select the CommandCommandCommandCommand tab from the PropertiesPropertiesPropertiesProperties window

2. For YSizeYSizeYSizeYSize, type: L1, L1, L1, L1, Click the TabTabTabTab key to accept

1. Add Variable L1L1L1L1: 91.2mil91.2mil91.2mil91.2mil, Click the OKOKOKOK button

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: L1L1L1L1

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 
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Create S for Stub 1Create S for Stub 1Create S for Stub 1Create S for Stub 1

To create S:To create S:To create S:To create S:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 4.84.84.84.8, dY: 4.84.84.84.8, dZ: 0.10.10.10.1, Press the EnterEnterEnterEnter key

To parameterize the object:To parameterize the object:To parameterize the object:To parameterize the object:

1. Select the CommandCommandCommandCommand tab from the PropertiesPropertiesPropertiesProperties window

2. For XSizeXSizeXSizeXSize, type: S, S, S, S, Click the TabTabTabTab key to accept

1. Add Variable SSSS: 4.8mil4.8mil4.8mil4.8mil, Click the OKOKOKOK button

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: S_Stub1S_Stub1S_Stub1S_Stub1

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 
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Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ

Create Source 1Create Source 1Create Source 1Create Source 1

To create source:To create source:To create source:To create source:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: -14.414.414.414.4, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 

rectangle:

dX: ----4.84.84.84.8, dY: 0.00.00.00.0, dZ: ----5.05.05.05.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Source1Source1Source1Source1

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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Assign ExcitationAssign ExcitationAssign ExcitationAssign Excitation

To select the object Source:To select the object Source:To select the object Source:To select the object Source:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Source1Source1Source1Source1

2. Click the OK OK OK OK button

NoteNoteNoteNote:  You can also select the object from the Model Tree

To assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitation

1. Select the menu item HFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped Port

2. Lumped Port : General 

1. Name: p1p1p1p1, 

2. Resistance: 50505050

3. Reactance: 0000

4. Click the NextNextNextNext button

3. Lumped Port : Terminals

1. Number of Terminals: 1111, 

2. For T1T1T1T1, click the UndefinedUndefinedUndefinedUndefined column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: ----2.42.42.42.4, Y: ----14.414.414.414.4, Z: ----5.05.05.05.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 5.05.05.05.0, Press the EnterEnterEnterEnter key

4. Click the NextNextNextNext button

5. Wave Port : Post Processing 

1. Full Port Impedance : 50505050

Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY
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Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:

1. Select the menu item 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: 4.84.84.84.8, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the Enter Enter Enter Enter key 

Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: RelativeCS1RelativeCS1RelativeCS1RelativeCS1

2. Click the SelectSelectSelectSelect button

To set the name:To set the name:To set the name:To set the name:

Note:Note:Note:Note: After selecting the coordinate system, its properties will be displayed 

in the property window.  If you do not see the properties, repeat the steps to 

set the working coordinate system, or select the CS from the model tree.

1. For the ValueValueValueValue of NameNameNameName type: CS_Stub1CS_Stub1CS_Stub1CS_Stub1

To parameterize the origin:To parameterize the origin:To parameterize the origin:To parameterize the origin:

Note:Note:Note:Note: After selecting the coordinate system, its properties will be displayed 

in the property window.  If you do not see the properties, repeat the steps to 

set the working coordinate system, or select the CS from the model tree

1. For the ValueValueValueValue of OriginOriginOriginOrigin type: S, 0, 0, S, 0, 0, S, 0, 0, S, 0, 0, Click the TabTabTabTab key to accept
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Create L2 for Stub 1Create L2 for Stub 1Create L2 for Stub 1Create L2 for Stub 1

To create L2:To create L2:To create L2:To create L2:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 4.84.84.84.8, dY: 86.486.486.486.4, dZ: 0.10.10.10.1, Press the EnterEnterEnterEnter key

To parameterize the object:To parameterize the object:To parameterize the object:To parameterize the object:

1. Select the CommandCommandCommandCommand tab from the PropertiesPropertiesPropertiesProperties window

2. For YSizeYSizeYSizeYSize, type: L2, L2, L2, L2, Click the TabTabTabTab key to accept

1. Add Variable L2L2L2L2: 86.4mil86.4mil86.4mil86.4mil, Click the OKOKOKOK button

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: L2_Stub1L2_Stub1L2_Stub1L2_Stub1

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 

Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: GlobalGlobalGlobalGlobal

2. Click the SelectSelectSelectSelect button
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Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:

1. Select the menu item 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: -4.84.84.84.8, Y: 91.291.291.291.2, Z: 0.00.00.00.0, Press the Enter Enter Enter Enter key 

Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: RelativeCS1RelativeCS1RelativeCS1RelativeCS1

2. Click the SelectSelectSelectSelect button

To set the name:To set the name:To set the name:To set the name:

Note:Note:Note:Note: After selecting the coordinate system, its properties will be displayed 

in the property window.  If you do not see the properties, repeat the steps to 

set the working coordinate system, or select the CS from the model tree.

1. For the ValueValueValueValue of NameNameNameName type: CS_L1CS_L1CS_L1CS_L1

To parameterize the origin:To parameterize the origin:To parameterize the origin:To parameterize the origin:

Note:Note:Note:Note: After selecting the coordinate system, its properties will be displayed 

in the property window.  If you do not see the properties, repeat the steps to 

set the working coordinate system, or select the CS from the model tree

1. For the ValueValueValueValue of OriginOriginOriginOrigin type: ----4.8, L1, 0, 4.8, L1, 0, 4.8, L1, 0, 4.8, L1, 0, Click the TabTabTabTab key to accept
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Create Input2Create Input2Create Input2Create Input2

To create the input:To create the input:To create the input:To create the input:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 4.84.84.84.8, dY: 4.8+14.44.8+14.44.8+14.44.8+14.4, dZ: 0.10.10.10.1, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Input2Input2Input2Input2

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 

Create S for Stub 2Create S for Stub 2Create S for Stub 2Create S for Stub 2

To create S:To create S:To create S:To create S:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: ----4.84.84.84.8, dY: 4.84.84.84.8, dZ: 0.10.10.10.1, Press the EnterEnterEnterEnter key

To parameterize the object:To parameterize the object:To parameterize the object:To parameterize the object:

1. Select the CommandCommandCommandCommand tab from the PropertiesPropertiesPropertiesProperties window

2. For XSizeXSizeXSizeXSize, type: -S, S, S, S, Click the TabTabTabTab key to accept

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: S_Stub2S_Stub2S_Stub2S_Stub2

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 
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Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ

Create Source 2Create Source 2Create Source 2Create Source 2

To create source:To create source:To create source:To create source:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: 4.8+14.44.8+14.44.8+14.44.8+14.4, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 

rectangle:

dX: 4.84.84.84.8, dY: 0.00.00.00.0, dZ: ----5.05.05.05.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Source2Source2Source2Source2

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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Assign ExcitationAssign ExcitationAssign ExcitationAssign Excitation

To select the object Source:To select the object Source:To select the object Source:To select the object Source:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Source2Source2Source2Source2

2. Click the OK OK OK OK button

NoteNoteNoteNote:  You can also select the object from the Model Tree

To assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitation

1. Select the menu item HFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped Port

2. Lumped Port : General 

1. Name: p2p2p2p2, 

2. Resistance: 50505050

3. Reactance: 0000

4. Click the NextNextNextNext button

3. Lumped Port : Terminals

1. Number of Terminals: 1111, 

2. For T1T1T1T1, click the UndefinedUndefinedUndefinedUndefined column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: 2.42.42.42.4, Y: 19.219.219.219.2, Z: ----5.05.05.05.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 5.05.05.05.0, Press the EnterEnterEnterEnter key

4. Click the NextNextNextNext button

5. Wave Port : Post Processing 

1. Full Port Impedance : 50505050

Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY
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Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:

1. Select the menu item 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: -4.84.84.84.8, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the Enter Enter Enter Enter key 

Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: RelativeCS1RelativeCS1RelativeCS1RelativeCS1

2. Click the SelectSelectSelectSelect button

To set the name:To set the name:To set the name:To set the name:

Note:Note:Note:Note: After selecting the coordinate system, its properties will be displayed 

in the property window.  If you do not see the properties, repeat the steps to 

set the working coordinate system, or select the CS from the model tree.

1. For the ValueValueValueValue of NameNameNameName type: CS_Stub2CS_Stub2CS_Stub2CS_Stub2

To parameterize the origin:To parameterize the origin:To parameterize the origin:To parameterize the origin:

Note:Note:Note:Note: After selecting the coordinate system, its properties will be displayed 

in the property window.  If you do not see the properties, repeat the steps to 

set the working coordinate system, or select the CS from the model tree

1. For the ValueValueValueValue of OriginOriginOriginOrigin type: ----S, 0, 0, S, 0, 0, S, 0, 0, S, 0, 0, Click the TabTabTabTab key to accept
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Create L2 for Stub 2Create L2 for Stub 2Create L2 for Stub 2Create L2 for Stub 2

To create L2:To create L2:To create L2:To create L2:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: 4.84.84.84.8, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: ----4.84.84.84.8, dY: ----86.486.486.486.4, dZ: 0.10.10.10.1, Press the EnterEnterEnterEnter key

To parameterize the object:To parameterize the object:To parameterize the object:To parameterize the object:

1. Select the CommandCommandCommandCommand tab from the PropertiesPropertiesPropertiesProperties window

2. For YSizeYSizeYSizeYSize, type: ----L2, L2, L2, L2, Click the TabTabTabTab key to accept

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: L2_Stub2L2_Stub2L2_Stub2L2_Stub2

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 
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Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: GlobalGlobalGlobalGlobal

2. Click the SelectSelectSelectSelect button

Create GroundCreate GroundCreate GroundCreate Ground

To create the ground:To create the ground:To create the ground:To create the ground:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----34.434.434.434.4, Y: ----34.434.434.434.4, Z: ----5.05.05.05.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 64.064.064.064.0, dY: 164.8164.8164.8164.8, dZ: ----0.10.10.10.1, Press the EnterEnterEnterEnter key

To parameterize the object:To parameterize the object:To parameterize the object:To parameterize the object:

1. Select the CommandCommandCommandCommand tab from the PropertiesPropertiesPropertiesProperties window

2. For PositionPositionPositionPosition, type: ----SSSS----29.6mil, 29.6mil, 29.6mil, 29.6mil, ----34.4mil, 34.4mil, 34.4mil, 34.4mil, ----5mil, 5mil, 5mil, 5mil, Click the TabTabTabTab key to accept

3. For XSizeXSizeXSizeXSize, type: 54.4mil+2*S, 54.4mil+2*S, 54.4mil+2*S, 54.4mil+2*S, Click the TabTabTabTab key to accept

4. For YSizeYSizeYSizeYSize, type: 73.6mil+L1, 73.6mil+L1, 73.6mil+L1, 73.6mil+L1, Click the TabTabTabTab key to accept

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: GroundGroundGroundGround

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 
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Add New MaterialAdd New MaterialAdd New MaterialAdd New Material

To add a new material:To add a new material:To add a new material:To add a new material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. From the Select Definition window, click the Add MaterialAdd MaterialAdd MaterialAdd Material button

3. View/Edit Material Window:

1. Material Name: My_AluminaMy_AluminaMy_AluminaMy_Alumina

2. Relative Permittivity: 9.9 9.9 9.9 9.9 

3. Click the OKOKOKOK button

4. Click the OKOKOKOK button
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Create SubstrateCreate SubstrateCreate SubstrateCreate Substrate

To create the substrate:To create the substrate:To create the substrate:To create the substrate:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----34.434.434.434.4, Y: ----34.434.434.434.4, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 64.064.064.064.0, dY: 164.8164.8164.8164.8, dZ: ----5.05.05.05.0, Press the EnterEnterEnterEnter key

To parameterize the object:To parameterize the object:To parameterize the object:To parameterize the object:

1. Select the CommandCommandCommandCommand tab from the PropertiesPropertiesPropertiesProperties window

2. For PositionPositionPositionPosition, type: ----SSSS----29.6mil, 29.6mil, 29.6mil, 29.6mil, ----34.4mil, 0mil, 34.4mil, 0mil, 34.4mil, 0mil, 34.4mil, 0mil, Click the TabTabTabTab key to accept

3. For XSizeXSizeXSizeXSize, type: 54.4mil+2*S, 54.4mil+2*S, 54.4mil+2*S, 54.4mil+2*S, Click the TabTabTabTab key to accept

4. For YSizeYSizeYSizeYSize, type: 73.6mil+L1, 73.6mil+L1, 73.6mil+L1, 73.6mil+L1, Click the TabTabTabTab key to accept

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: SubstrateSubstrateSubstrateSubstrate

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose vacuumvacuumvacuumvacuum
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Create AirCreate AirCreate AirCreate Air

To create the Air:To create the Air:To create the Air:To create the Air:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----34.434.434.434.4, Y: ----34.434.434.434.4, Z: ----5.15.15.15.1, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 64.064.064.064.0, dY: 164.8164.8164.8164.8, dZ: 50.050.050.050.0, Press the EnterEnterEnterEnter key

To parameterize the object:To parameterize the object:To parameterize the object:To parameterize the object:

1. Select the CommandCommandCommandCommand tab from the PropertiesPropertiesPropertiesProperties window

2. For PositionPositionPositionPosition, type: ----SSSS----29.6mil, 29.6mil, 29.6mil, 29.6mil, ----34.4mil, 34.4mil, 34.4mil, 34.4mil, ----5.1mil, 5.1mil, 5.1mil, 5.1mil, Click the TabTabTabTab key to accept

3. For XSizeXSizeXSizeXSize, type: 54.4mil+2*S, 54.4mil+2*S, 54.4mil+2*S, 54.4mil+2*S, Click the TabTabTabTab key to accept

4. For YSizeYSizeYSizeYSize, type: 73.6mil+L1, 73.6mil+L1, 73.6mil+L1, 73.6mil+L1, Click the TabTabTabTab key to accept

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: AirAirAirAir

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 

Create Radiation BoundaryCreate Radiation BoundaryCreate Radiation BoundaryCreate Radiation Boundary

To select the object Air:To select the object Air:To select the object Air:To select the object Air:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: AirAirAirAir

2. Click the OK OK OK OK button

To create a radiation boundaryTo create a radiation boundaryTo create a radiation boundaryTo create a radiation boundary

1. Select the menu item HFSS > Boundaries > Assign > RadiationHFSS > Boundaries > Assign > RadiationHFSS > Boundaries > Assign > RadiationHFSS > Boundaries > Assign > Radiation

2. Radiation Boundary Window

Name: Rad1Rad1Rad1Rad1

Click the OKOKOKOK button
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Boundary DisplayBoundary DisplayBoundary DisplayBoundary Display

To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:

1. Select the menu item HFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary Display (Solver View)(Solver View)(Solver View)(Solver View)

2. From the Solver View of Boundaries, toggle the Visibility check box for the  

boundaries you wish to display.

Note:Note:Note:Note: The background (Perfect Conductor) is displayed as the outerouterouterouter
boundary.

Note:Note:Note:Note: The Perfect Conductors are displayed as the smetalsmetalsmetalsmetal boundary.

Note:Note:Note:Note: Select the menu item, View > VisibilityView > VisibilityView > VisibilityView > Visibility to hide all of the 
geometry objects.  This makes it easier to see the boundary

3. Click the CloseCloseCloseClose button when you are finished
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Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 20.0GHz: 20.0GHz: 20.0GHz: 20.0GHz

Maximum Number of Passes: 20202020

Maximum Delta S per Pass: 0.020.020.020.02

2. Click the OKOKOKOK button

Adding a Frequency SweepAdding a Frequency SweepAdding a Frequency SweepAdding a Frequency Sweep

To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:

1. Select the menu item HFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add Sweep

1. Select Solution Setup: Setup1 Setup1 Setup1 Setup1 

2. Click the OKOKOKOK button

2. Edit Sweep Window:

1. Sweep Type: Fast: Fast: Fast: Fast

2. Frequency Setup Type: Linear Step: Linear Step: Linear Step: Linear Step

Start: 4.0GHz4.0GHz4.0GHz4.0GHz

Stop: 20.0GHz: 20.0GHz: 20.0GHz: 20.0GHz

Step: 0.05GHz: 0.05GHz: 0.05GHz: 0.05GHz

Save Fields: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_msbsfhfss_msbsfhfss_msbsfhfss_msbsf

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 
Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > AnalyzeHFSS > AnalyzeHFSS > AnalyzeHFSS > Analyze
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button
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Create Reports

Create SCreate SCreate SCreate S----parameter vs. Frequencyparameter vs. Frequencyparameter vs. Frequencyparameter vs. Frequency

To Create a report:To Create a report:To Create a report:To Create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Click the YYYY tab

1. Domain: SweepSweepSweepSweep

2. Category: Terminal STerminal STerminal STerminal S----ParametersParametersParametersParameters

3. Quantity: St(p1,p1), St(p2,p1)St(p1,p1), St(p2,p1)St(p1,p1), St(p2,p1)St(p1,p1), St(p2,p1)

4. Function: dBdBdBdB

5. Click the Add TraceAdd TraceAdd TraceAdd Trace button

3. Click the DoneDoneDoneDone button
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Chapter 8.0 – Signal Integrity Examples
8.1 – LVDS Differential Pair 

Includes Optimetrics Example

8.1a – LVDS Differential Pair Transient Simulation (Ansoft Designer)

8.2 – Segmented Return Path

8.2a – Segmented Return Path TDR (Ansoft Designer)

8.3 – Non-Ideal Planes

8.4 – Return Path
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8.1a-1

8.1a

LVDS Differential Pair
This differential pair example is intended to show you how to create, simulate, 

and analyze a differential pair using the Ansoft HFSS Design Environment.  

Low Voltage Differential Signaling (LVDS) technology is used for high-
performance backplanes.  The LVDS is used for multi-point communications and 

uses a bus similar to system show below.  The following illustrations detail the 

passive device you will be creating.    

LAYER 1 (TOP SIDE)

LAYER 2 (SIGNAL 1)

LAYER 3 (BOTTOM SIDE)

26mil

Nominal Design:Nominal Design:Nominal Design:Nominal Design:

Traces:Traces:Traces:Traces:

Width= 6milWidth= 6milWidth= 6milWidth= 6mil

Spacing= 18milSpacing= 18milSpacing= 18milSpacing= 18mil

Thickness=0.7milThickness=0.7milThickness=0.7milThickness=0.7mil

Length: 1000milLength: 1000milLength: 1000milLength: 1000mil

Substrate:Substrate:Substrate:Substrate:

Thickness=26milThickness=26milThickness=26milThickness=26mil

εεεεrrrr= 4.4= 4.4= 4.4= 4.4
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Ansoft HFSS Design Environment
The following features of the Ansoft HFSS Design Environment are used to 

create this passive device model.

3D Solid Modeling

Primitives: Box, RectanglesBox, RectanglesBox, RectanglesBox, Rectangles

Boolean Operations: Duplicate Along Line, Sweep Along VectorDuplicate Along Line, Sweep Along VectorDuplicate Along Line, Sweep Along VectorDuplicate Along Line, Sweep Along Vector

Boundaries/Excitations

Ports: Wave Ports, Terminal LinesWave Ports, Terminal LinesWave Ports, Terminal LinesWave Ports, Terminal Lines

Analysis

Sweep: InterpolatingInterpolatingInterpolatingInterpolating

Results

Cartesian and Smith Chart plottingCartesian and Smith Chart plottingCartesian and Smith Chart plottingCartesian and Smith Chart plotting

Field Overlays

3D Field Plots3D Field Plots3D Field Plots3D Field Plots
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8.1a

Design Review
Before we jump into setting up this device lets review the design.  

Trace Width = 6mils

Trace Length= 1000mils

Dielectric Height= 13mils x 2

1/2oz copper Traces/Grounds= 0.7mils

Port Size=  ???

Port Width

From the Using Ports section, the port width should be at least 3-5 times 

the stackup(78-130mils).  Since the traces are not centered, lets use 5x 

and add the pair spacing(18mils) for a total port/model width of 220mils.

Trace Length

Since we are modeling a uniform transmission line, we do not need to 

simulate the 1000mils length.  Lets reduce the model to 100 mils and use 

de-embedding to add the extra length.

Material Properties

To start with, lets make an engineering assumption that the material 

properties are constant over frequency.  In addition, we will assume that 

the modeling the traces as perfect conductors will not have an impact on 
the performance of the device.  This will speed up the simulation.  As an 

additional exercise, the model can be modified to include frequency 

dependent materials and lossy conductors.

Ground Planes

Since we are ignoring the metal conductivity, we do not need to create 

objects for the ground planes.  Instead, we will utilize the background 

(Perfect Conductor) boundary.  If we need to investigate the effects of 

copper, a finite conductivity boundary condition can be used to simulate the 
copper ground planes.
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8.1a

Solution Setup
Since we are going to use the model for SPICE simulation, the frequency range 

of interest is going to be determined by the rise-time(tr) of the input signal.  The 

maximum frequency is calculated by taking 0.5/tr, or the knee frequency, and 

multiplying it by the number of samples per tr.  The minimum frequency should 

be selected as close to DC as possible.

The following values will be used for the Solution Setup

Rise-Time(tr): 330ps

Number of Samples: 5

Upper Frequency: (0.5/330ps)*5 ~ 7.58GHz or 8.0GHz

Lower Frequency: 0.01GHz

Frequency Spacing: 0.01GHz

Single(Adaptive) Frequency: 8.0GHz

Adaptive Passes: 10

Delta S: 0.02

Sweep Type: Interpolating
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8.1a

Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select 

the Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, click the � On the Standard toolbar, or select 

the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose Driven TerminalDriven TerminalDriven TerminalDriven Terminal

2. Click the OKOKOKOK button
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Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: milmilmilmil

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type pecpecpecpec in the Search by NameSearch by NameSearch by NameSearch by Name field

2. Click the OKOKOKOK button
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Create Trace 1Create Trace 1Create Trace 1Create Trace 1

To create trace 1:To create trace 1:To create trace 1:To create trace 1:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: 9.09.09.09.0, Z: ----0.350.350.350.35,  Press the Enter Enter Enter Enter key 

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 100.0100.0100.0100.0, dY: 6.06.06.06.0, dZ: 0.7, 0.7, 0.7, 0.7, Press the Enter Enter Enter Enter key

To parameterize the object:To parameterize the object:To parameterize the object:To parameterize the object:

1. Select the CommandCommandCommandCommand tab from the PropertiesPropertiesPropertiesProperties window

2. For PositionPositionPositionPosition, type: 0.0mil, S/2, 0.0mil, S/2, 0.0mil, S/2, 0.0mil, S/2, ----0.35mil0.35mil0.35mil0.35mil, Click the TabTabTabTab key to accept 

Add Variable SSSS: 18mil18mil18mil18mil, Click the OKOKOKOK button

3. For YSizeYSizeYSizeYSize, type: WWWW, Click the TabTabTabTab key to accept 

Add Variable WWWW: 6mil6mil6mil6mil, Click the OKOKOKOK button

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: trace1trace1trace1trace1

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
Or press the CTRL+DCTRL+DCTRL+DCTRL+D key
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Create Trace 2Create Trace 2Create Trace 2Create Trace 2

To create trace 2:To create trace 2:To create trace 2:To create trace 2:

1. Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible.  .  .  .  Or press the CTRL+ACTRL+ACTRL+ACTRL+A key.

2. Select the menu item, Edit > Duplicate > MirrorEdit > Duplicate > MirrorEdit > Duplicate > MirrorEdit > Duplicate > Mirror.

1. Input the anchor point of the mirror plane:

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the Enter Enter Enter Enter key

2. Input the target point of the vector normal to the mirror plane:

dX: 0.00.00.00.0, dY: ----1.01.01.01.0, dZ: 0.00.00.00.0, Press the Enter Enter Enter Enter key

To set the name:To set the name:To set the name:To set the name:

1. Select the menu item HFSS > ListHFSS > ListHFSS > ListHFSS > List

2. From the ModelModelModelModel tab, select the object named trace1_1trace1_1trace1_1trace1_1

3. Click the Properties Properties Properties Properties button

1. For the ValueValueValueValue of NameNameNameName type: trace2trace2trace2trace2

2. Click the OKOKOKOK button

4. Click the DoneDoneDoneDone button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  



Ansoft High Frequency Structure Simulator v10 User’s Guide 

Example – LVDS Differential Pair

8.1a-10

8.1a

Add New MaterialAdd New MaterialAdd New MaterialAdd New Material

To add a new material:To add a new material:To add a new material:To add a new material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. From the Select Definition window, click the Add MaterialAdd MaterialAdd MaterialAdd Material button

3. View/Edit Material Window:

1. Material Name: My_FR4My_FR4My_FR4My_FR4

2. Relative Permittivity: 4.4 4.4 4.4 4.4 

3. Click the OKOKOKOK button

4. Click the OKOKOKOK button
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Create SubstrateCreate SubstrateCreate SubstrateCreate Substrate

To create substrate:To create substrate:To create substrate:To create substrate:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: ----100.0100.0100.0100.0,  Z: ----13.0, 13.0, 13.0, 13.0, Press the Enter Enter Enter Enter key

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 100.0100.0100.0100.0, dY: 200.0200.0200.0200.0, dZ: 26.0, 26.0, 26.0, 26.0, Press the Enter Enter Enter Enter key 

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: substratesubstratesubstratesubstrate

To set the transparency:To set the transparency:To set the transparency:To set the transparency:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. Click the button for Transparency

1. Move the slide bar to 0.8 0.8 0.8 0.8 (Opaque=0, Transparency=1)

2. Click the OKOKOKOK button

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 
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Create Wave Port Excitation 1Create Wave Port Excitation 1Create Wave Port Excitation 1Create Wave Port Excitation 1

Note: Note: Note: Note: This structure requires 2 ports with 2 terminal lines per port. We could use 
face selection to select the ends of the substrate that represent the port, define 

terminal lines, assign excitation, and repeat for port2.  But since we can duplicate 

port definitions, it is more efficient to define a rectangle with the appropriate port 

definition and copy it to the location of the 2nd port.  The second method is 

described here:

To set grid planeTo set grid planeTo set grid planeTo set grid plane

Select the menu item 3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ

To create a rectangle that represents the port:To create a rectangle that represents the port:To create a rectangle that represents the port:To create a rectangle that represents the port:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the rectangle position

X: 0.00.00.00.0, Y: ----100.0100.0100.0100.0, Z: ----13.013.013.013.0, Press the Enter Enter Enter Enter key

3. Using the coordinate entry fields, enter the opposite corner of the rectangle:

dX: 0.00.00.00.0, dY: 200.0200.0200.0200.0, dZ: 26.026.026.026.0, Press the Enter Enter Enter Enter key 

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Port1Port1Port1Port1

3. Click the OKOKOKOK button

To select the object Port1:To select the object Port1:To select the object Port1:To select the object Port1:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Port1Port1Port1Port1

2. Click the OK OK OK OK button

NoteNoteNoteNote:  You can also select the object from the 

Model Tree
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Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)Create Wave Port Excitation 1 (Continued)

To assign wave port excitationTo assign wave port excitationTo assign wave port excitationTo assign wave port excitation

1. Select the menu item HFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave Port

2. Wave Port : General

1. Name: p1p1p1p1

2. Click the NextNextNextNext button

3. Wave Port : Terminals

1. Number of Terminals: 2222, Click the UpdateUpdateUpdateUpdate button

2. For T1T1T1T1, click the UndefinedUndefinedUndefinedUndefined column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: ----13.013.013.013.0, Press the Enter Enter Enter Enter key 

4. Using the coordinate entry fields, enter the vertex

dX: 0.00.00.00.0, dY: 12.012.012.012.0, dZ: 12.6512.6512.6512.65, Press the Enter Enter Enter Enter key 

5. For T2T2T2T2, click the UndefinedUndefinedUndefinedUndefined column and select New LineNew LineNew LineNew Line

6. Using the coordinate entry fields, enter the vector position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: ----13.013.013.013.0, Press the Enter Enter Enter Enter key 

7. Using the coordinate entry fields, enter the vertex

dX: 0.00.00.00.0, dY: ----12.012.012.012.0, dZ: 12.6512.6512.6512.65, Press the Enter Enter Enter Enter key 

8. Click the NextNextNextNext button

4. Wave Port : Differential Pairs 

1. Click the New PairNew PairNew PairNew Pair button

2. Click the NextNextNextNext button

5. Wave Port : Post Processing 

6. Click the FinishFinishFinishFinish button

Terminal Lines

Wave Port Face
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8.1a

Create Wave Port Excitation 2Create Wave Port Excitation 2Create Wave Port Excitation 2Create Wave Port Excitation 2

To select the object Port1:To select the object Port1:To select the object Port1:To select the object Port1:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Port1Port1Port1Port1

2. Click the OK OK OK OK button

To duplicate the port:To duplicate the port:To duplicate the port:To duplicate the port:

1. Select the menu item, Edit > Duplicate > Along LineEdit > Duplicate > Along LineEdit > Duplicate > Along LineEdit > Duplicate > Along Line

2. Using the coordinate entry fields, enter the first point of the duplicate vector

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the second point of the duplicate 

vector

dX: 100.0100.0100.0100.0, dY: 0.00.00.00.0, dZ: 0.0,0.0,0.0,0.0, Press the EnterEnterEnterEnter key

4. Duplicate Along Line Windows

1. Total Number: 2222

2. Click the OKOKOKOK button 

To set To set To set To set deembeddingdeembeddingdeembeddingdeembedding::::

1. Select the menu item HFSS > ListHFSS > ListHFSS > ListHFSS > List

2. From the ExcitationsExcitationsExcitationsExcitations tab, select the excitation named p2p2p2p2

3. Click the Properties Properties Properties Properties button

1. Deembed: � CheckedCheckedCheckedChecked

2. Deembed Distance: ----900mil 900mil 900mil 900mil (Positive Values are into the Port)

3. Click the OKOKOKOK button

4. Click the DoneDoneDoneDone button
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Boundary DisplayBoundary DisplayBoundary DisplayBoundary Display

To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:

1. Select the menu item HFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary Display (Solver View)(Solver View)(Solver View)(Solver View)

2. From the Solver View of Boundaries, toggle the Visibility check box for the  

boundaries you wish to display.

Note:Note:Note:Note: The background (Perfect Conductor) is displayed as the outerouterouterouter
boundary.

Note:Note:Note:Note: The Perfect Conductors are displayed as the smetalsmetalsmetalsmetal boundary.

Note:Note:Note:Note: Select the menu item, View > VisibilityView > VisibilityView > VisibilityView > Visibility to hide all of the 

geometry objects.  This makes it easier to see the boundary

3. Click the CloseCloseCloseClose button when you are finished.
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Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 8.0GHz: 8.0GHz: 8.0GHz: 8.0GHz

Maximum Number of Passes: 20202020

Maximum Delta S: 0.020.020.020.02

2. Click the OptionsOptionsOptionsOptions tab::::

Do Lambda Refinement: � CheckedCheckedCheckedChecked

Target: 0.05: 0.05: 0.05: 0.05

Use Low-Order Solution Basis: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button

Adding a Frequency SweepAdding a Frequency SweepAdding a Frequency SweepAdding a Frequency Sweep

To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:

1. Select the menu item HFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add Sweep

1. Select Solution Setup: Setup1 Setup1 Setup1 Setup1 

2. Click the OKOKOKOK button

2. Edit Sweep Window:

1. Sweep Type: Interpolating: Interpolating: Interpolating: Interpolating

2. Click the Setup Interpolation Basis Setup Interpolation Basis Setup Interpolation Basis Setup Interpolation Basis button

Max Solutions: 20: 20: 20: 20

Error Tolerance: 0.5%: 0.5%: 0.5%: 0.5%

User All Entries: User All Entries: User All Entries: User All Entries: Selected

Click OKOKOKOK

3. Extrapolate to DC: : : : � CheckedCheckedCheckedChecked

Minimum Solve Frequency: 0.01 GHz: 0.01 GHz: 0.01 GHz: 0.01 GHz

4. Snap Magnitude to 0 or 1 at DC:  ���� UncheckedUncheckedUncheckedUnchecked

5. Frequency Setup Type: Linear Step: Linear Step: Linear Step: Linear Step

Stop: 8.0GHz: 8.0GHz: 8.0GHz: 8.0GHz

Step: 0.01GHz: 0.01GHz: 0.01GHz: 0.01GHz

6. Click the OKOKOKOK button
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_lvds_diffpairhfss_lvds_diffpairhfss_lvds_diffpairhfss_lvds_diffpair

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, see the Message 
Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > AnalyzeHFSS > AnalyzeHFSS > AnalyzeHFSS > Analyze
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button
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Create Reports

Create Differential Pair SCreate Differential Pair SCreate Differential Pair SCreate Differential Pair S----Parameter PlotParameter PlotParameter PlotParameter Plot

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Domain: SweepSweepSweepSweep

3. Click the YYYY tab

1. Category: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Quantity: St(p1:Diff1,p1:Diff1), St(p1:Diff1,p1:Comm1), St(p1:Diff1,p1:Diff1), St(p1:Diff1,p1:Comm1), St(p1:Diff1,p1:Diff1), St(p1:Diff1,p1:Comm1), St(p1:Diff1,p1:Diff1), St(p1:Diff1,p1:Comm1), 

St(p1:Diff1,p2:Diff1)St(p1:Diff1,p2:Diff1)St(p1:Diff1,p2:Diff1)St(p1:Diff1,p2:Diff1)

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button
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Create Differential and Common Pair Impedances Data TableCreate Differential and Common Pair Impedances Data TableCreate Differential and Common Pair Impedances Data TableCreate Differential and Common Pair Impedances Data Table

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: Data TableData TableData TableData Table

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Setup1: Setup1: Setup1: LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Click the YYYY tab

1. Category: Terminal Port Terminal Port Terminal Port Terminal Port ZoZoZoZo

2. Quantity: Zot(p1:Diff1,p1:Diff1), Zot(p1:Comm1,p1:Comm1)Zot(p1:Diff1,p1:Diff1), Zot(p1:Comm1,p1:Comm1)Zot(p1:Diff1,p1:Diff1), Zot(p1:Comm1,p1:Comm1)Zot(p1:Diff1,p1:Diff1), Zot(p1:Comm1,p1:Comm1)

3. Function: magmagmagmag

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

3. Click the DoneDoneDoneDone button
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Matrix Data Matrix Data Matrix Data Matrix Data ---- Export SExport SExport SExport S----parameters to a fileparameters to a fileparameters to a fileparameters to a file

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Select the menu item HFSS > Results > Solution Data, HFSS > Results > Solution Data, HFSS > Results > Solution Data, HFSS > Results > Solution Data, 

2. Solution Data dialog

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

2. Simulation: Setup1, Sweep1Setup1, Sweep1Setup1, Sweep1Setup1, Sweep1

3. Click the ExportExportExportExport button. 

1. Filename: hfss_lvds_diffpairhfss_lvds_diffpairhfss_lvds_diffpairhfss_lvds_diffpair

2. Save as Type: TouchstoneTouchstoneTouchstoneTouchstone

3. Click the SaveSaveSaveSave button

4. Click the OKOKOKOK button to accept 50 ohm reference impedance

4. Click the CloseCloseCloseClose button
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8.1a

Field Overlays

Set Sources: CommonSet Sources: CommonSet Sources: CommonSet Sources: Common

To set the field excitation:To set the field excitation:To set the field excitation:To set the field excitation:

1. Select the menu item HFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit Sources

2. Edit Sources Window::::

1. Select source: p1:T1: p1:T1: p1:T1: p1:T1

Magnitude: 1: 1: 1: 1

Phase: 0: 0: 0: 0

2. Select source: p1:T2: p1:T2: p1:T2: p1:T2

Magnitude: 1: 1: 1: 1

Phase: 0: 0: 0: 0

3. Select source: p2:T1: p2:T1: p2:T1: p2:T1

Terminated: : : : � CheckedCheckedCheckedChecked

Resistance: 50: 50: 50: 50

Reactance: 0 : 0 : 0 : 0 

4. Select source: p2:T2: p2:T2: p2:T2: p2:T2

Terminated: : : : � CheckedCheckedCheckedChecked

Resistance: 50: 50: 50: 50

Reactance: 0 : 0 : 0 : 0 

5. Click the OKOKOKOK button
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8.1a

Create Field OverlayCreate Field OverlayCreate Field OverlayCreate Field Overlay

To create a field plot:To create a field plot:To create a field plot:To create a field plot:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Port1Port1Port1Port1

2. Click the OK OK OK OK button

3. Select the menu item HFSS > Fields > HFSS > Fields > HFSS > Fields > HFSS > Fields > FieldsFieldsFieldsFields > E > > E > > E > > E > Mag_EMag_EMag_EMag_E

4. Create Field Plot Window

1. Solution: Setup1 :  Setup1 :  Setup1 :  Setup1 :  LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Quantity: Mag_EMag_EMag_EMag_E

3. In Volume: AllAllAllAll

4. Click the DoneDoneDoneDone button

To modify the attributes of a field plot:To modify the attributes of a field plot:To modify the attributes of a field plot:To modify the attributes of a field plot:

1. Select the menu item HFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot Attributes

2. Select Plot Folder Window:

1. Select: E FieldE FieldE FieldE Field

2. Click the OKOKOKOK button

3. E-Field Window:

1. Click the Scale Scale Scale Scale tab

1. Select Use LimitsUse LimitsUse LimitsUse Limits

2. Min: 5555

3. Max: 10000100001000010000

4. Scale: LogLogLogLog

2. Click the PlotPlotPlotPlot tab

1. IsoValType: FringeFringeFringeFringe

2. If real time modereal time modereal time modereal time mode is not checked, click the ApplyApplyApplyApply button.

4. Click the CloseCloseCloseClose button
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8.1a

Create Field OverlayCreate Field OverlayCreate Field OverlayCreate Field Overlay

To create a field plot:To create a field plot:To create a field plot:To create a field plot:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Port1Port1Port1Port1

2. Click the OK OK OK OK button

3. Select the menu item HFSS > Fields > HFSS > Fields > HFSS > Fields > HFSS > Fields > FieldsFieldsFieldsFields >  E > >  E > >  E > >  E > Vector_EVector_EVector_EVector_E

4. Create Field Plot Window

1. Solution: Setup1 :  Setup1 :  Setup1 :  Setup1 :  LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Quantity: Vector_EVector_EVector_EVector_E

3. In Volume: AllAllAllAll

4. Click the DoneDoneDoneDone button

To modify the attributes of a field plot:To modify the attributes of a field plot:To modify the attributes of a field plot:To modify the attributes of a field plot:

1. Select the menu item HFSS > Fields > Modify Plot AttributesHFSS > Fields > Modify Plot AttributesHFSS > Fields > Modify Plot AttributesHFSS > Fields > Modify Plot Attributes

2. Select Plot Folder Window:

1. Select: E FieldE FieldE FieldE Field

2. Click the OKOKOKOK button

3. E-Field Window:

1. Click the Marker/ArrowMarker/ArrowMarker/ArrowMarker/Arrow tab

1. Type: CylinderCylinderCylinderCylinder

2. Map Size: ���� UncheckedUncheckedUncheckedUnchecked

3. Arrow Tale:  ���� UncheckedUncheckedUncheckedUnchecked

4. If real time modereal time modereal time modereal time mode is not checked, click the ApplyApplyApplyApply button.

4. Click the CloseCloseCloseClose button
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Set Differential Mode Field ExcitationSet Differential Mode Field ExcitationSet Differential Mode Field ExcitationSet Differential Mode Field Excitation

To set the field excitation:To set the field excitation:To set the field excitation:To set the field excitation:

1. Select the menu item HFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit Sources

2. Edit Sources Window::::

1. Select source: p1:T1: p1:T1: p1:T1: p1:T1

Magnitude: 1: 1: 1: 1

Phase: 0: 0: 0: 0

2. Select source: p1:T2: p1:T2: p1:T2: p1:T2

Magnitude: 1: 1: 1: 1

Phase: 180 : 180 : 180 : 180 

3. Select source: p2:T1: p2:T1: p2:T1: p2:T1

Terminated: : : : � CheckedCheckedCheckedChecked

Resistance: 50: 50: 50: 50

Reactance: 0 : 0 : 0 : 0 

4. Select source: p2:T2: p2:T2: p2:T2: p2:T2

Terminated: : : : � CheckedCheckedCheckedChecked

Resistance: 50: 50: 50: 50

Reactance: 0 : 0 : 0 : 0 

5. Click the OKOKOKOK button

The field plots will automatically be updated to reflect the changes.
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8.1a

Optimetrics Setup – Parametric Sweep
During the design of a device, it is common practice to develop design trends based on 

swept parameters.  Ansoft HFSS with Optimetrics Parametric Sweep can automatically 

create these design curves.

We will parameterize this design using two variables:

1. Variable W will vary the width of traces: 6 ≤ W ≤ 12 mils

2. Variable S  will vary the spacing between traces: 15 ≤ S ≤ 21 mils

In the post processor you will able to display results and see how Differential impedance 

changes with the respect to trace width and spacing between traces.

6 6 6 6 ≤≤≤≤ W W W W ≤≤≤≤ 12 mils12 mils12 mils12 mils

15  15  15  15  ≤≤≤≤ S S S S ≤≤≤≤ 21 mils21 mils21 mils21 mils

WWWW

SSSS
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Optimetrics Setup – Parametric Sweep

Add a Parametric SweepAdd a Parametric SweepAdd a Parametric SweepAdd a Parametric Sweep

1. Select the menu item HFSS > Optimetrics Analysis > Add ParametricHFSS > Optimetrics Analysis > Add ParametricHFSS > Optimetrics Analysis > Add ParametricHFSS > Optimetrics Analysis > Add Parametric

2. Setup Sweep AnalysisSweep AnalysisSweep AnalysisSweep Analysis Window:

1. Click the Sweep DefinitionsSweep DefinitionsSweep DefinitionsSweep Definitions tab::::

1. Click the AddAddAddAdd button

2. Add/Edit Sweep Dialog

1. Variable: W W W W 

2. Select Linear CountLinear CountLinear CountLinear Count

3. Start: 6mil6mil6mil6mil

4. Stop: 12mil12mil12mil12mil

5. Count: 3333

6. Click the AddAddAddAdd >>>>>>>> button

7. Variable: SSSS

8. Select Linear CountLinear CountLinear CountLinear Count

9. Start: 15mil15mil15mil15mil

10. Stop: 21mil21mil21mil21mil

11. Count: 3333

12. Click the Add >>Add >>Add >>Add >> button

13. Click the OKOKOKOK button

2. Click on the OptionsOptionsOptionsOptions tab::::

1. Save Fields And Mesh: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > SaveFile > SaveFile > SaveFile > Save.

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 

Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Expand the Project Tree to display the items listed under OptimetricsOptimetricsOptimetricsOptimetrics

2. Right-click the mouse on ParametricSetup1 ParametricSetup1 ParametricSetup1 ParametricSetup1 and choose Analyze Analyze Analyze Analyze 
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Create Reports

Create Terminal Port Create Terminal Port Create Terminal Port Create Terminal Port ZoZoZoZo vsvsvsvs SSSS

To Create a report:To Create a report:To Create a report:To Create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Setup1: Setup1: Setup1: LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Click the Sweeps tab

1. Select the Sweep Design and Project Variable ValuesSweep Design and Project Variable ValuesSweep Design and Project Variable ValuesSweep Design and Project Variable Values button

2. From the table, select FreqFreqFreqFreq from the Name column and toggle 

the Primary Sweep to SSSS

3. Click the YYYY tab

1. Category: Terminal Port Terminal Port Terminal Port Terminal Port ZoZoZoZo

2. Quantity: Zot(p1:Diff1,p1:Diff1), Zot(p1:Comm1,p1:Comm1) Zot(p1:Diff1,p1:Diff1), Zot(p1:Comm1,p1:Comm1) Zot(p1:Diff1,p1:Diff1), Zot(p1:Comm1,p1:Comm1) Zot(p1:Diff1,p1:Diff1), Zot(p1:Comm1,p1:Comm1) 

3. Function: magmagmagmag

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button
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8.1a

Field Overlays

Create Field Plot Create Field Plot Create Field Plot Create Field Plot vsvsvsvs SSSS

Using the project tree, expand the Field OverlayField OverlayField OverlayField Overlay, E FieldE FieldE FieldE Field.

Double Click on Mag_E1Mag_E1Mag_E1Mag_E1 to make the field plot visible

Right-Click on Mag_E1Mag_E1Mag_E1Mag_E1 and select AnimateAnimateAnimateAnimate

Setup Animation

Swept Variable: SSSS

Click the OKOKOKOK button

The Animation dialog will appear. 

Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > SaveFile > SaveFile > SaveFile > Save. 

Exiting HFSSExiting HFSSExiting HFSSExiting HFSS

To Exit HFSS:To Exit HFSS:To Exit HFSS:To Exit HFSS:

1. Select the menu item File > ExitFile > ExitFile > ExitFile > Exit

1. If prompted Save the changes



Ansoft High Frequency Structure Simulator v10 User’s Guide 

Example – LVDS Differential Pair

8.1b-1

8.1b

Ansoft Designer – Transient Simulation

Launching Ansoft DesignerLaunching Ansoft DesignerLaunching Ansoft DesignerLaunching Ansoft Designer

1. To access Ansoft Designer, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and 

select the DesignerDesignerDesignerDesigner program group.  Click Ansoft DesignerAnsoft DesignerAnsoft DesignerAnsoft Designer.

Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft Designer window, click the � On the Standard toolbar, or select 
the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert Circuit Design.Insert Circuit Design.Insert Circuit Design.Insert Circuit Design.

3. Click NoneNoneNoneNone button when prompted for Choose Layout Technology.Choose Layout Technology.Choose Layout Technology.Choose Layout Technology.

Note:Note:Note:Note: In this example we are not creating a layout or using 
components such as transmission lines that require substrate or stack 

up information.  If we did, then it is recommended to choose a stack 

up from the list or create your own.

Project Manager Window
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Creating the Circuit 

Component PlacementComponent PlacementComponent PlacementComponent Placement

Importing SImporting SImporting SImporting S----parametersparametersparametersparameters

1. Select the menu item Draw > Draw > Draw > Draw > NNNN----PortPortPortPort or click the           toolbar button.

2. In the N-port data window, 

1. Select the Link to fileLink to fileLink to fileLink to file radial button

2. Click the browse button to locate and select your Touchstone file: 

hfss_lvds_diffpair.s4phfss_lvds_diffpair.s4phfss_lvds_diffpair.s4phfss_lvds_diffpair.s4p

3. Click the Open Open Open Open button

3. Click the Ok Ok Ok Ok button
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8.1b

Component Placement Component Placement Component Placement Component Placement –––– continuedcontinuedcontinuedcontinued

1. To place the new component, single click with the left mouse button in the 
middle of the screen.

Placing Resistors, Voltage Sources, and Voltage Probes

1. Click the ComponentsComponentsComponentsComponents tab in the Project ManagerProject ManagerProject ManagerProject Manager window.

ResistorsResistorsResistorsResistors : Expand Lumped Lumped Lumped Lumped ----> Resistors> Resistors> Resistors> Resistors

Voltage Sources: Voltage Sources: Voltage Sources: Voltage Sources: Expand Sources Sources Sources Sources ----> Independent Sources> Independent Sources> Independent Sources> Independent Sources

Voltage probesVoltage probesVoltage probesVoltage probes: Expand ProbesProbesProbesProbes

Tabs for Project, Components, and SearchTabs for Project, Components, and SearchTabs for Project, Components, and SearchTabs for Project, Components, and Search

1

2

3

4
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Component Placement Component Placement Component Placement Component Placement –––– continuedcontinuedcontinuedcontinued

Place 3 Resistors in the schematic

1. In the Components TabComponents TabComponents TabComponents Tab, under LumpedLumpedLumpedLumped ----> Resistors> Resistors> Resistors> Resistors, double click 

ResistorsResistorsResistorsResistors

2. Click the left mouse button 3 times to place 3 resistors in the 

schematic. 

3. To end the placement, click the right mouse button and select 

FinishFinishFinishFinish. (You can also end the placement by pressing the space bar)

Note:  Note:  Note:  Note:  Before placing a component on the schematic use the RRRR key to 
rotate. If a component is already placed, use the <ctrl> R<ctrl> R<ctrl> R<ctrl> R key to rotate.

Change the value of the resistors

1. Right mouse click the component and then select Properties in the 

pull down menu

2. Change the value from 100 to 50505050, then hit EnterEnterEnterEnter

Note: alternatively, you can left mouse button click on the resistor to 

bring up the PropertiesPropertiesPropertiesProperties window (shown below) and change the value 

from 100 to 50505050, then hit EnterEnterEnterEnter
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Component Placement Component Placement Component Placement Component Placement –––– continuedcontinuedcontinuedcontinued

Place Piecewise Linear Source

1. In the Components Tab, under Sources Sources Sources Sources ----> Independent Sources> Independent Sources> Independent Sources> Independent Sources, 

double click on Voltage SourceVoltage SourceVoltage SourceVoltage Source.

2. Left mouse click to place the source in the schematic

3. Press the space barspace barspace barspace bar to finish the placement

Source Selection dialog

1. In the Properties Window, click EditEditEditEdit

2. For NameNameNameName type VposVposVposVpos

3. For TypeTypeTypeType, choose Piecewise LinearPiecewise LinearPiecewise LinearPiecewise Linear

4. Click on the Waveform List BoxWaveform List BoxWaveform List BoxWaveform List Box (which is the unmarked column in 

between Unit and Description as shown below)

Waveform List Box
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8.1b

Component Placement Component Placement Component Placement Component Placement –––– continuedcontinuedcontinuedcontinued

Piece-wise Waveform List dialog

1. Click on the Radial button next to Enter time/value points.Enter time/value points.Enter time/value points.Enter time/value points.

2. Enter two points: 

Time     ValueTime     ValueTime     ValueTime     Value

0000 0000
330ps   1V330ps   1V330ps   1V330ps   1V

Note: make sure you hit 

Enter Enter Enter Enter after typing values

1. Click OK OK OK OK to finish

2. Click OK OK OK OK to exit out 

of Source SelectionSource SelectionSource SelectionSource Selection

Adding Second Source

1. Repeat the same steps as adding the first source except change:

1. For Name, type Vneg Vneg Vneg Vneg 

2. The data points to: 

Time     ValueTime     ValueTime     ValueTime     Value

0           00           00           00           0

330ps   330ps   330ps   330ps   ----1V1V1V1V
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Component Placement Component Placement Component Placement Component Placement –––– continuedcontinuedcontinuedcontinued

Adding Wiring to connect componentsAdding Wiring to connect componentsAdding Wiring to connect componentsAdding Wiring to connect components

1. Select the menu item Draw Draw Draw Draw ----> Wire> Wire> Wire> Wire

2. Place the cursor (which is now an X) over a node and left mouse click once

3. Drag the mouse to the connection node and left mouse click once.

4. Repeat this procedure until the connections below are made

Adding Ground ConnectionsAdding Ground ConnectionsAdding Ground ConnectionsAdding Ground Connections

1. Select the menu item Draw > GroundDraw > GroundDraw > GroundDraw > Ground (alternatively you can select the 

toolbar icon)

2. Place 2 ground connections on the ends of the voltage sources 

Adding Voltage Probes Adding Voltage Probes Adding Voltage Probes Adding Voltage Probes 

1. In the ComponentsComponentsComponentsComponents tab, expand the Probes.Probes.Probes.Probes.

2. Place 4 Voltage ProbesVoltage ProbesVoltage ProbesVoltage Probes and name them Vin1, Vin2, Vout1, Vout2.

3. Place a Voltage Probe w/Ref. NodeVoltage Probe w/Ref. NodeVoltage Probe w/Ref. NodeVoltage Probe w/Ref. Node across the 100 Ohm resistor and name 

it VdiffVdiffVdiffVdiff

50

50

10
0

+
0V

Vpos

V Vin1

V Vin2

V Vout1

V Vout2 V +V
diff

+ 0V
Vneg

1

2

3

4



Ansoft High Frequency Structure Simulator v10 User’s Guide 

Example – LVDS Differential Pair

8.1b-8
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: lvds_diffpair_transientlvds_diffpair_transientlvds_diffpair_transientlvds_diffpair_transient

3. Click the SaveSaveSaveSave button

Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. In the Project ManagerProject ManagerProject ManagerProject Manager window, click the ProjectProjectProjectProject tab

2. Select the menu item Circuit Circuit Circuit Circuit ----> Add Solution Setup> Add Solution Setup> Add Solution Setup> Add Solution Setup

3. Analysis Setup Window:

1. For Analysis TypeAnalysis TypeAnalysis TypeAnalysis Type, choose Transient AnalysisTransient AnalysisTransient AnalysisTransient Analysis

2. Click NextNextNextNext

3. Analysis Control

1. Length of Analysis: 2ns2ns2ns2ns

2. Maximum Time Step Allowed: 1ps1ps1ps1ps

4. Convolution Control

1. Maximum Sampling Frequency: 8GHz8GHz8GHz8GHz

2. Delta Frequency: 0.01GHz0.01GHz0.01GHz0.01GHz

5. Click FinishFinishFinishFinish

4. Select the menu item Circuit Circuit Circuit Circuit ----> Analyze> Analyze> Analyze> Analyze
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Create Reports

Plot Input, Output and Difference waveformsPlot Input, Output and Difference waveformsPlot Input, Output and Difference waveformsPlot Input, Output and Difference waveforms

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item Circuit  Circuit  Circuit  Circuit  ----> Create Report> Create Report> Create Report> Create Report

2. Create Report Window::::

1. Report Type: StandardStandardStandardStandard

2. Display Type: Rectangular PlotRectangular PlotRectangular PlotRectangular Plot

3. Click the OK OK OK OK button

3. Traces Window::::

1. Category: VoltageVoltageVoltageVoltage

2. Quantity: V(VPRB:Vin1),  V(VPRB:Vin2),  V(VPRB:Vout1),  V(VPRB:Vin1),  V(VPRB:Vin2),  V(VPRB:Vout1),  V(VPRB:Vin1),  V(VPRB:Vin2),  V(VPRB:Vout1),  V(VPRB:Vin1),  V(VPRB:Vin2),  V(VPRB:Vout1),  

V(VPRB:Vout2),  V(VPRB:Vout2),  V(VPRB:Vout2),  V(VPRB:Vout2),  V(VPRB:DiffV(VPRB:DiffV(VPRB:DiffV(VPRB:Diff))))

3. Function: <none><none><none><none>

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

5. Click the DoneDoneDoneDone button
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Segmented Return Path
This example is intended to show you how to create, simulate, and analyze a trace 

over a slot in the ground plant using the Ansoft HFSS Design Environment.  

LAYER 1 (SIGNAL 1)

LAYER 2 (BOTTOM SIDE)

1.3mm

Nominal Design:Nominal Design:Nominal Design:Nominal Design:

Board:Board:Board:Board:

Thickness= 1.3mmThickness= 1.3mmThickness= 1.3mmThickness= 1.3mm

εεεεrrrr= 4.5= 4.5= 4.5= 4.5
Trace:Trace:Trace:Trace:

Length= 8.2cmLength= 8.2cmLength= 8.2cmLength= 8.2cm

Termination: 47Termination: 47Termination: 47Termination: 47ΩΩΩΩ

8 mm

4 cm

5 cm 6 mm 3.4 cm 1 cm

1 cm

3mm

6 cm
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Ansoft HFSS Design Environment
The following features of the Ansoft HFSS Design Environment are used to create 

this passive device model

3D Solid Modeling

Primitives: Box, RectanglesBox, RectanglesBox, RectanglesBox, Rectangles

Boolean Operations: SubtractSubtractSubtractSubtract

Boundaries/Excitations

Ports: Lumped Port, Terminal LinesLumped Port, Terminal LinesLumped Port, Terminal LinesLumped Port, Terminal Lines

Boundary Conditions: Lumped RLC, PMLLumped RLC, PMLLumped RLC, PMLLumped RLC, PML

Analysis

Sweep: Interpolating  SweepInterpolating  SweepInterpolating  SweepInterpolating  Sweep

Results

Cartesian and Smith Chart plottingCartesian and Smith Chart plottingCartesian and Smith Chart plottingCartesian and Smith Chart plotting

Field Overlays

Magnitude and Vector Field PlottingMagnitude and Vector Field PlottingMagnitude and Vector Field PlottingMagnitude and Vector Field Plotting

AnimationAnimationAnimationAnimation
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8.2a

Design Review
Before we jump into setting up this device lets review the design.  

Trace Width = 3mm

Trace Length= 8.2cm

Dielectric Height= 1.3mm

Port Size/Type=  ???

Free Space= PML or Radiation Boundary

Port Size/Type

Since the trace is internal to the model, let’s use a lumped gap source port

Trace Thickness/Material Properties

To start let’s make an engineering assumption that the trace thickness and 
conductivity will not have an impact on the performance of the device.  This 
will speed up the simulation.

Free Space

We should expect some radiation to occur because of the slot in the ground, 
however, it should not be very strong.  Because there is limited radiation the 
separation from the device and the free-space boundary can be kept to a 
minimum.  The incidence angle of the radiation is unknown, therefore we 
should use a PML.  The maximum spacing will be ~λ/20 @ 1GHz or about 
1.5cm
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8.2a

Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select 

the Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10Ansoft, HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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8.2a

Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, click the � On the Standard toolbar, or select 

the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose Driven TerminalDriven TerminalDriven TerminalDriven Terminal

2. Click the OKOKOKOK button
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8.2a

Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: cmcmcmcm

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Click the Add MaterialAdd MaterialAdd MaterialAdd Material button

2. View/Edit Material Window:

1. For the Material NameMaterial NameMaterial NameMaterial Name type: My_FR4My_FR4My_FR4My_FR4

2. For the ValueValueValueValue of Relative PermittivityRelative PermittivityRelative PermittivityRelative Permittivity type: 4.5 4.5 4.5 4.5 

3. Click the OKOKOKOK button

3. Click the OKOKOKOK button
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8.2a

Create BoardCreate BoardCreate BoardCreate Board

To create the board:To create the board:To create the board:To create the board:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 6.06.06.06.0, dY: 10.010.010.010.0, dZ: ----1.3mm1.3mm1.3mm1.3mm, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: BoardBoardBoardBoard

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View or press the CTRL+DCTRL+DCTRL+DCTRL+D key

Create GroundCreate GroundCreate GroundCreate Ground

To create ground:To create ground:To create ground:To create ground:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: ----1.3mm1.3mm1.3mm1.3mm, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 

rectangle:

dX: 6.06.06.06.0, dY: 10.010.010.010.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: GroundGroundGroundGround

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  



Ansoft High Frequency Structure Simulator v10 User’s Guide 8.2a -8

8.2a

Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:

1. Select the menu item 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: 0.00.00.00.0, Y: 5.05.05.05.0, Z: ----1.3mm1.3mm1.3mm1.3mm, Press the EnterEnterEnterEnter key

Create Ground Cut OutCreate Ground Cut OutCreate Ground Cut OutCreate Ground Cut Out

To create cut out:To create cut out:To create cut out:To create cut out:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 

rectangle:

dX: 4.04.04.04.0, dY: 6.0mm6.0mm6.0mm6.0mm, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

Select Ground & Rectangle1:Select Ground & Rectangle1:Select Ground & Rectangle1:Select Ground & Rectangle1:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Ground, Rectangle1Ground, Rectangle1Ground, Rectangle1Ground, Rectangle1

2. Click the OK OK OK OK button

To complete the ground object:To complete the ground object:To complete the ground object:To complete the ground object:

1. Select the menu item 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 

2. Subtract Window

Blank Parts: GroundGroundGroundGround

Tool Parts: Rectangle1Rectangle1Rectangle1Rectangle1

Clone tool objects before subtract: ���� UncheckedUncheckedUncheckedUnchecked

Click the OKOKOKOK button
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8.2a

Assign a Perfect E boundary to the GroundAssign a Perfect E boundary to the GroundAssign a Perfect E boundary to the GroundAssign a Perfect E boundary to the Ground

To select the ground:To select the ground:To select the ground:To select the ground:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: GroundGroundGroundGround

2. Click the OK OK OK OK button

To assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundary

1. Select the menu item HFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect E

2. Perfect E Boundary window

1. Name: PerfE_GroundPerfE_GroundPerfE_GroundPerfE_Ground

2. Click the OKOKOKOK button

Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: GlobalGlobalGlobalGlobal

2. Click the SelectSelectSelectSelect button

Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:

1. Select the menu item 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: 1.01.01.01.0, Y: 8.0mm8.0mm8.0mm8.0mm, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key
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8.2a

Create Trace Create Trace Create Trace Create Trace 

To create trace:To create trace:To create trace:To create trace:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 3.0mm3.0mm3.0mm3.0mm, dY: 8.28.28.28.2, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: TraceTraceTraceTrace

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Assign a Perfect E boundary to the TraceAssign a Perfect E boundary to the TraceAssign a Perfect E boundary to the TraceAssign a Perfect E boundary to the Trace

To select the trace:To select the trace:To select the trace:To select the trace:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: TraceTraceTraceTrace

2. Click the OK OK OK OK button

To assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundary

1. Select the menu item HFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect E

2. Perfect E Boundary window

1. Name: PerfE_TracePerfE_TracePerfE_TracePerfE_Trace

2. Click the OKOKOKOK button
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8.2a

Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ

Create SourceCreate SourceCreate SourceCreate Source

To create source:To create source:To create source:To create source:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 3.0mm3.0mm3.0mm3.0mm, dY: 0.00.00.00.0, dZ: ----1.3mm1.3mm1.3mm1.3mm, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: SourceSourceSourceSource

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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8.2a

Assign ExcitationAssign ExcitationAssign ExcitationAssign Excitation

To select the object Source:To select the object Source:To select the object Source:To select the object Source:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: SourceSourceSourceSource

2. Click the OK OK OK OK button

NoteNoteNoteNote:  You can also select the object from the Model Tree

To assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitation

1. Select the menu item HFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped Port

2. Lumped Port : General 

1. Name: p1p1p1p1, 

2. Resistance: 50505050

3. Reactance: 0000

4. Click the NextNextNextNext button

3. Lumped Port : Terminals

1. Number of Terminals: 1111, 

2. For T1T1T1T1, click the UndefinedUndefinedUndefinedUndefined column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: 1.5mm1.5mm1.5mm1.5mm, Y: 0.00.00.00.0, Z: ----1.3mm1.3mm1.3mm1.3mm, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 1.3mm1.3mm1.3mm1.3mm, Press the EnterEnterEnterEnter key

5. Click the FinishFinishFinishFinish button
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8.2a

Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:

1. Select the menu item 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: 0.00.00.00.0, Y: 8.28.28.28.2, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

Create ResistorCreate ResistorCreate ResistorCreate Resistor

To create source:To create source:To create source:To create source:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 

rectangle:

dX: 3.0mm3.0mm3.0mm3.0mm, dY: 0.00.00.00.0, dZ: ----1.3mm1.3mm1.3mm1.3mm, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: ResistorResistorResistorResistor

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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8.2a

Assign Lumped RLCAssign Lumped RLCAssign Lumped RLCAssign Lumped RLC

To select the object Resistor:To select the object Resistor:To select the object Resistor:To select the object Resistor:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: ResistorResistorResistorResistor

2. Click the OK OK OK OK button

To assign lumped RLC boundaryTo assign lumped RLC boundaryTo assign lumped RLC boundaryTo assign lumped RLC boundary

1. Select the menu item HFSS > Boundaries> Assign > Lumped  RLCHFSS > Boundaries> Assign > Lumped  RLCHFSS > Boundaries> Assign > Lumped  RLCHFSS > Boundaries> Assign > Lumped  RLC

2. Lumped RLC Boundary 

1. Name: RRRR, 

2. Resistance: � CheckedCheckedCheckedChecked

3. Resistance: 47 Ohm47 Ohm47 Ohm47 Ohm

4. For Current Flow LineCurrent Flow LineCurrent Flow LineCurrent Flow Line, click UndefinedUndefinedUndefinedUndefined and select New LineNew LineNew LineNew Line

5. Using the coordinate entry fields, enter the vector position

X: 1.5mm1.5mm1.5mm1.5mm, Y: 0.00.00.00.0, Z: ----1.3mm1.3mm1.3mm1.3mm, Press the EnterEnterEnterEnter key

6. Using the coordinate entry fields, enter the vertex

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 1.3mm1.3mm1.3mm1.3mm, Press the EnterEnterEnterEnter key

7. Click the OKOKOKOK button
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8.2a

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose vacuumvacuumvacuumvacuum

Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: GlobalGlobalGlobalGlobal

2. Click the SelectSelectSelectSelect button

Create AirCreate AirCreate AirCreate Air

To create the air:To create the air:To create the air:To create the air:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----1.51.51.51.5, Y: ----1.51.51.51.5, Z: ----1.51.51.51.5, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 

rectangle:

dX: 9.09.09.09.0, dY: 13.013.013.013.0, dZ: 3.03.03.03.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: AirAirAirAir

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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8.2a

Assign a Perfectly Matched Layer (PML)Assign a Perfectly Matched Layer (PML)Assign a Perfectly Matched Layer (PML)Assign a Perfectly Matched Layer (PML)

To select the air:To select the air:To select the air:To select the air:

1. Select the menu item Edit > Select > FacesEdit > Select > FacesEdit > Select > FacesEdit > Select > Faces

2. Select the menu item Edit > Select by nameEdit > Select by nameEdit > Select by nameEdit > Select by name

3. Object Name: AirAirAirAir

1. FaceID: <Select All>: <Select All>: <Select All>: <Select All>

2. Click the OK OK OK OK button

To assign the PML boundaryTo assign the PML boundaryTo assign the PML boundaryTo assign the PML boundary

1. Select the menu item HFSS > Boundaries > PML Setup WizardHFSS > Boundaries > PML Setup WizardHFSS > Boundaries > PML Setup WizardHFSS > Boundaries > PML Setup Wizard

2. PML Setup Wizard: Cover Objects

1. Select: Create PML Cover Objects on Selected FacesCreate PML Cover Objects on Selected FacesCreate PML Cover Objects on Selected FacesCreate PML Cover Objects on Selected Faces

2. Uniform Layer Thickness: 1cm1cm1cm1cm

3. Create joining corner and edge objects:  � CheckedCheckedCheckedChecked

4. Click the NextNextNextNext button

3. PML Setup Wizard: Material Parameters

1. Select: PMLPMLPMLPML Objects acceptObjects acceptObjects acceptObjects accept Free RadiationFree RadiationFree RadiationFree Radiation

1. Min Frequency: 0.01 GHz: 0.01 GHz: 0.01 GHz: 0.01 GHz

2. Click the NextNextNextNext button

2. Review settings on the PML Setup Wizard: Summary page.

3. Click the FinishFinishFinishFinish button
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8.2a

Create a Face ListCreate a Face ListCreate a Face ListCreate a Face List

Since we are using the PML, we need to create a face list that will be used for the 
radiation calculation.

To create a face listTo create a face listTo create a face listTo create a face list

1. Select the menu item Edit > Select > FacesEdit > Select > FacesEdit > Select > FacesEdit > Select > Faces

2. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

3. Select Object Dialog, 

1. Select the objects named: AirAirAirAir

2. FaceID: <Select All>: <Select All>: <Select All>: <Select All>

3. Click the OK OK OK OK button

4. Select the menu item 3D Modeler > List > Create > Face List3D Modeler > List > Create > Face List3D Modeler > List > Create > Face List3D Modeler > List > Create > Face List

Create a Radiation SetupCreate a Radiation SetupCreate a Radiation SetupCreate a Radiation Setup

To define the radiation setupTo define the radiation setupTo define the radiation setupTo define the radiation setup

1. Select the menu item HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite HFSS > Radiation > Insert Far Field Setup > Infinite 
SphereSphereSphereSphere

2. Far Field Radiation Sphere Setup dialog

Infinite SphereInfinite SphereInfinite SphereInfinite Sphere Tab

1. Name: RadiationRadiationRadiationRadiation

2. Phi: (Start: 0, 0, 0, 0, Stop: 90, 90, 90, 90, Step Size: 90)90)90)90)

3. Theta: (Start: ----180, 180, 180, 180, Stop: 180, 180, 180, 180, Step Size: 2)2)2)2)

1. Click the OKOKOKOK button
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8.2a

Boundary DisplayBoundary DisplayBoundary DisplayBoundary Display

To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:

1. Select the menu item HFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary Display (Solver View)(Solver View)(Solver View)(Solver View)

2. From the Solver View of Boundaries, toggle the Visibility check box for the  

boundaries you wish to display.

Note:Note:Note:Note: The background (Perfect Conductor) is displayed as the outerouterouterouter
boundary.

Note:Note:Note:Note: The Perfect Conductors are displayed as the smetalsmetalsmetalsmetal boundary.

Note:Note:Note:Note: Select the menu item, View > VisibilityView > VisibilityView > VisibilityView > Visibility to hide all of the 
geometry objects.  This makes it easier to see the boundary

3. Click the CloseCloseCloseClose button when you are finished.
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8.2a

Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 2.5GHz: 2.5GHz: 2.5GHz: 2.5GHz

Maximum Number of Passes: 20202020

Maximum Delta S: 0.030.030.030.03

2. Click the OptionsOptionsOptionsOptions tab::::

Do Lambda Refinement: � CheckedCheckedCheckedChecked

Target: 0.1: 0.1: 0.1: 0.1

User Low-Order Solution Basis: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button

Adding a Frequency SweepAdding a Frequency SweepAdding a Frequency SweepAdding a Frequency Sweep

To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:

1. Select the menu item HFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add Sweep

1. Select Solution Setup: Setup1 Setup1 Setup1 Setup1 

2. Click the OKOKOKOK button

2. Edit Sweep Window:

1. Sweep Type: Interpolating: Interpolating: Interpolating: Interpolating

2. Click the Setup Interpolation Basis Setup Interpolation Basis Setup Interpolation Basis Setup Interpolation Basis button

Max Solutions: 20: 20: 20: 20

Error Tolerance: 0.5%: 0.5%: 0.5%: 0.5%

Click the OK OK OK OK button

3. Extrapolate to DC: : : : � CheckedCheckedCheckedChecked

Minimum Solve Frequency: 0.01 GHz: 0.01 GHz: 0.01 GHz: 0.01 GHz

4. Snap Magnitude to 0 or 1 at DC:  ���� UncheckedUncheckedUncheckedUnchecked

5. Frequency Setup Type: Linear Step: Linear Step: Linear Step: Linear Step

Stop: 2.5GHz: 2.5GHz: 2.5GHz: 2.5GHz

Step: 0.01GHz: 0.01GHz: 0.01GHz: 0.01GHz

6. Click the OKOKOKOK button



Ansoft High Frequency Structure Simulator v10 User’s Guide 8.2a -20

8.2a

Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_seg_gplanehfss_seg_gplanehfss_seg_gplanehfss_seg_gplane

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 
Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > AnalyzeHFSS > AnalyzeHFSS > AnalyzeHFSS > Analyze
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button
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Create Reports

Create Terminal SCreate Terminal SCreate Terminal SCreate Terminal S----Parameter Plot vs. Adaptive PassParameter Plot vs. Adaptive PassParameter Plot vs. Adaptive PassParameter Plot vs. Adaptive Pass

Note: Note: Note: Note: If this report is created prior or during the solution process, a real-time update 

of the results are displayed

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Adaptive1Setup1: Adaptive1Setup1: Adaptive1Setup1: Adaptive1

2. Click the YYYY tab

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: St(p1,p1)St(p1,p1)St(p1,p1)St(p1,p1)

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

3. Click the DoneDoneDoneDone button



Ansoft High Frequency Structure Simulator v10 User’s Guide 8.2a -23

8.2a

Create Terminal ZCreate Terminal ZCreate Terminal ZCreate Terminal Z----Parameter Plot Parameter Plot Parameter Plot Parameter Plot –––– Real/ImaginaryReal/ImaginaryReal/ImaginaryReal/Imaginary

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Domain: SweepSweepSweepSweep

3. Click the YYYY tab

1. Category: Terminal Z ParameterTerminal Z ParameterTerminal Z ParameterTerminal Z Parameter

2. Quantity: Zt(p1,p1)Zt(p1,p1)Zt(p1,p1)Zt(p1,p1)

3. Function: ReReReRe

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

5. Category: Terminal Z ParameterTerminal Z ParameterTerminal Z ParameterTerminal Z Parameter

6. Quantity: Zt(p1,p1)Zt(p1,p1)Zt(p1,p1)Zt(p1,p1)

7. Function: ImImImIm

8. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4.4.4.4. To add an additional YTo add an additional YTo add an additional YTo add an additional Y----Axis for im(Zt(p1,p1)Axis for im(Zt(p1,p1)Axis for im(Zt(p1,p1)Axis for im(Zt(p1,p1)

1. Select Y1 for Row 2 in Y-axis column and toggle it to Y2Y2Y2Y2

5. Click the DoneDoneDoneDone button
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Create Terminal SCreate Terminal SCreate Terminal SCreate Terminal S----Parameter Plot Parameter Plot Parameter Plot Parameter Plot –––– Smith ChartSmith ChartSmith ChartSmith Chart

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: Smith ChartSmith ChartSmith ChartSmith Chart

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Click the PolarPolarPolarPolar tab

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: St(p1,p1)St(p1,p1)St(p1,p1)St(p1,p1)

3. Function: <none><none><none><none>

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

3. Click the DoneDoneDoneDone button
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Matrix Data Matrix Data Matrix Data Matrix Data ---- Export SExport SExport SExport S----parameters to a fileparameters to a fileparameters to a fileparameters to a file

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Select the menu item HFSS > Results > Solution Data, HFSS > Results > Solution Data, HFSS > Results > Solution Data, HFSS > Results > Solution Data, 

2. Solution Data dialog

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

2. Simulation: Setup1, Sweep1Setup1, Sweep1Setup1, Sweep1Setup1, Sweep1

3. Click the ExportExportExportExport button. 

1. Filename: hfss_seg_gplanehfss_seg_gplanehfss_seg_gplanehfss_seg_gplane

2. Save as Type: TouchstoneTouchstoneTouchstoneTouchstone

3. Click the SaveSaveSaveSave button

4. Click the OKOKOKOK button to accept 50ohm reference impedance

4. Click the CloseCloseCloseClose button
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Create 3D Polar Far Field PlotCreate 3D Polar Far Field PlotCreate 3D Polar Far Field PlotCreate 3D Polar Far Field Plot

To create a 3D Far Field PlotTo create a 3D Far Field PlotTo create a 3D Far Field PlotTo create a 3D Far Field Plot

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Far FieldsFar FieldsFar FieldsFar Fields

2. Display Type: 3D Polar Plot3D Polar Plot3D Polar Plot3D Polar Plot

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Setup1: Setup1: Setup1: LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Domain: RadiationRadiationRadiationRadiation

3. Click the MagMagMagMag tab

1. Category: rErErErE

2. Quantity: rETotalrETotalrETotalrETotal

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button
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Field Overlays

Create Field OverlayCreate Field OverlayCreate Field OverlayCreate Field Overlay

To create a field plot:To create a field plot:To create a field plot:To create a field plot:

1. Confirm you are in Object SelectObject SelectObject SelectObject Select mode by right-clicking in the geometry 
window, and selecting from context menu if necessary.

2. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

3. Select Object Dialog, 

1. Select the objects named: BoardBoardBoardBoard

2. Click the OK OK OK OK button

4. Select the menu item HFSS > Fields > Plot Fields > HFSS > Fields > Plot Fields > HFSS > Fields > Plot Fields > HFSS > Fields > Plot Fields > Mag_EMag_EMag_EMag_E

5. Create Field Plot Window

1. Solution: Setup1 :  Setup1 :  Setup1 :  Setup1 :  LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Quantity: Mag_EMag_EMag_EMag_E

3. In Volume: AllAllAllAll

4. Click the DoneDoneDoneDone button

To modify a Magnitude field plot:To modify a Magnitude field plot:To modify a Magnitude field plot:To modify a Magnitude field plot:

1. Select the menu item HFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot Attributes

2. Select Plot Folder Window:

1. Select: E FieldE FieldE FieldE Field

2. Click the OKOKOKOK button

3. E-Field Window:

1. Click the Scale Scale Scale Scale tab

1. Select Use LimitsUse LimitsUse LimitsUse Limits

2. Min: 1111

3. Max: 4500450045004500

4. Scale: LogLogLogLog

2. Click the PlotsPlotsPlotsPlots Tab

1. Scalar Plot: IsoValSurfaceIsoValSurfaceIsoValSurfaceIsoValSurface

2. Click the CloseCloseCloseClose button
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Create Field OverlayCreate Field OverlayCreate Field OverlayCreate Field Overlay

To create a field plot:To create a field plot:To create a field plot:To create a field plot:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: GroundGroundGroundGround

2. Click the OK OK OK OK button

3. Select the menu item HFSS > Fields > Plot Fields > HFSS > Fields > Plot Fields > HFSS > Fields > Plot Fields > HFSS > Fields > Plot Fields > Vector_RealPoyntingVector_RealPoyntingVector_RealPoyntingVector_RealPoynting

4. Create Field Plot Window

1. Solution: Setup1 :  Setup1 :  Setup1 :  Setup1 :  LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Quantity: Vector_RealPoyntingVector_RealPoyntingVector_RealPoyntingVector_RealPoynting

3. In Volume: AllAllAllAll

4. Click the DoneDoneDoneDone button

To modify the attributes of a field plot:To modify the attributes of a field plot:To modify the attributes of a field plot:To modify the attributes of a field plot:

1. Select the menu item HFSS > Fields > Modify Plot AttributesHFSS > Fields > Modify Plot AttributesHFSS > Fields > Modify Plot AttributesHFSS > Fields > Modify Plot Attributes

2. Select Plot Folder Window:

1. Select: PoyntingPoyntingPoyntingPoynting

2. Click the OKOKOKOK button

3. Poynting Window:

1. Click the Scale Scale Scale Scale tab

1. Select Use LimitsUse LimitsUse LimitsUse Limits

2. Min: 0.010.010.010.01

3. Max: 2500250025002500

4. Scale: LogLogLogLog

2. Click the Marker/ArrowMarker/ArrowMarker/ArrowMarker/Arrow tab

1. Type: CylinderCylinderCylinderCylinder

2. Map Size: ���� UncheckedUncheckedUncheckedUnchecked

3. Arrow Tale:  ���� UncheckedUncheckedUncheckedUnchecked

4. If real time modereal time modereal time modereal time mode is not checked, click the ApplyApplyApplyApply button.

4. Click the CloseCloseCloseClose button

Exiting HFSSExiting HFSSExiting HFSSExiting HFSS

To Exit HFSS:To Exit HFSS:To Exit HFSS:To Exit HFSS:

1. Select the menu item File > ExitFile > ExitFile > ExitFile > Exit

1. If prompted Save the changes



Ansoft High Frequency Structure Simulator v10 User’s Guide 8.2a -29

8.2a



��������	��
�	
���
��
��	������
�



Ansoft High Frequency Structure Simulator v10 User’s Guide 8.2b -1

8.2b

Ansoft Designer – Transient Simulation

Launching Ansoft DesignerLaunching Ansoft DesignerLaunching Ansoft DesignerLaunching Ansoft Designer

1. To access Ansoft Designer, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and 

select the DesignerDesignerDesignerDesigner program group.  Click Ansoft DesignerAnsoft DesignerAnsoft DesignerAnsoft Designer.

Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft Designer window, click the � On the Standard toolbar, or select 
the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert Circuit Design.Insert Circuit Design.Insert Circuit Design.Insert Circuit Design.

3. Click NoneNoneNoneNone button when prompted for Choose Layout Technology.Choose Layout Technology.Choose Layout Technology.Choose Layout Technology.

Note:Note:Note:Note: In this example we are not creating a layout or using 
components such as transmission lines that require substrate or stack 

up information.  If we did, then it is recommended to choose a stack 

up from the list or create your own.

Project Manager Window
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1

50 Z=50
P=10000mil

+
0V

Source1

V v1 V v2

Creating the Circuit 

Component PlacementComponent PlacementComponent PlacementComponent Placement

Importing SImporting SImporting SImporting S----parametersparametersparametersparameters

1. Select the menu item Draw > Draw > Draw > Draw > NNNN----PortPortPortPort or click the           toolbar button.

2. In the N-port data window, 

1. Select the Link to fileLink to fileLink to fileLink to file radial button

2. Click the browse button to locate and select your Touchstone file: 

hfss_seg_gplane.s1phfss_seg_gplane.s1phfss_seg_gplane.s1phfss_seg_gplane.s1p

3. Click the Open Open Open Open button

3. Click the Ok Ok Ok Ok button

Browse
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Component Placement Component Placement Component Placement Component Placement –––– continuedcontinuedcontinuedcontinued

1. To place the new component, single click with the left mouse button in the 
middle of the screen.

Placing Resistors, Voltage Sources, and Voltage Probes

1. Click the ComponentsComponentsComponentsComponents tab in the Project ManagerProject ManagerProject ManagerProject Manager window.

ResistorsResistorsResistorsResistors : Expand Lumped Lumped Lumped Lumped ----> Resistors> Resistors> Resistors> Resistors

Voltage Sources: Voltage Sources: Voltage Sources: Voltage Sources: Expand Sources Sources Sources Sources ----> Independent Sources> Independent Sources> Independent Sources> Independent Sources

Voltage probesVoltage probesVoltage probesVoltage probes: Expand ProbesProbesProbesProbes

Tabs for Project, Components, and SearchTabs for Project, Components, and SearchTabs for Project, Components, and SearchTabs for Project, Components, and Search

1
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Component Placement Component Placement Component Placement Component Placement –––– continuedcontinuedcontinuedcontinued

Place a Resistor in the schematic

1. In the Components TabComponents TabComponents TabComponents Tab, under LumpedLumpedLumpedLumped ----> Resistors> Resistors> Resistors> Resistors, double click 

ResistorResistorResistorResistor

2. Click the left mouse button once to place a resistor in the schematic. 

3. To end the placement, click the right mouse button and select 
FinishFinishFinishFinish. (You can also end the placement by pressing the space bar)

Change the value of the resistor

1. Right mouse click the component and then select Properties in the 
pull down menu

2. Change the value from 100 to 50505050, then hit EnterEnterEnterEnter

Note: alternatively, you can left mouse button click on the resistor to 

bring up the PropertiesPropertiesPropertiesProperties window (shown below) and change the value 

from 100 to 50505050, then hit EnterEnterEnterEnter

1

100
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Component Placement Component Placement Component Placement Component Placement –––– continuedcontinuedcontinuedcontinued

Place a Coaxial Cable in the schematic

1. In the Components TabComponents TabComponents TabComponents Tab, under Coaxial CableCoaxial CableCoaxial CableCoaxial Cable, double click Coaxial Coaxial Coaxial Coaxial 

Cable, KCable, KCable, KCable, K

2. Click the left mouse button once to place a coaxial cable in the

schematic. 

3. Press the space barspace barspace barspace bar to finish the placement

Change the physical length of the coaxial cable

1. Right mouse click the component and then select Properties in the 

pull down menu

2. Change the value of PPPP to 10000mil10000mil10000mil10000mil, then hit EnterEnterEnterEnter

1

50 Z=50
P=10000mil
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Component Placement Component Placement Component Placement Component Placement –––– continuedcontinuedcontinuedcontinued

Place Piecewise Linear Source

1. In the Components Tab, under Sources Sources Sources Sources ----> Independent Sources> Independent Sources> Independent Sources> Independent Sources, 

double click on Voltage SourceVoltage SourceVoltage SourceVoltage Source.

2. Left mouse click to place the source in the schematic

3. Press the space barspace barspace barspace bar to finish the placement

Source Selection dialog

1. In the Properties Window, click EditEditEditEdit

2. For NameNameNameName type VinVinVinVin

3. For TypeTypeTypeType, choose Piecewise LinearPiecewise LinearPiecewise LinearPiecewise Linear

4. Click on the Waveform List BoxWaveform List BoxWaveform List BoxWaveform List Box (which is the unmarked column in 

between Unit and Description as shown below)

Waveform List Box

1

50 Z=50
P=10000mil

+
0V

Source1
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Component Placement Component Placement Component Placement Component Placement –––– continuedcontinuedcontinuedcontinued

Piece-wise Waveform List dialog

1. Click on the Radial button next to Enter time/value points.Enter time/value points.Enter time/value points.Enter time/value points.

2. Enter two points: 

Time     ValueTime     ValueTime     ValueTime     Value

0000 0000
1ns       1V1ns       1V1ns       1V1ns       1V

Note:Note:Note:Note: make sure you hit Enter Enter Enter Enter after typing values

1. Click the OK OK OK OK button

1. Click the OK OK OK OK button
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Component Placement Component Placement Component Placement Component Placement –––– continuedcontinuedcontinuedcontinued

Adding Wiring to connect componentsAdding Wiring to connect componentsAdding Wiring to connect componentsAdding Wiring to connect components

1. Select the menu item Draw Draw Draw Draw ----> Wire> Wire> Wire> Wire

2. Place the cursor (which is now an X) over a node and left mouse click once

3. Drag the mouse to the connection node and left mouse click once.

4. Repeat this procedure until the connections below are made

Adding Ground ConnectionsAdding Ground ConnectionsAdding Ground ConnectionsAdding Ground Connections

1. Select the menu item Draw > GroundDraw > GroundDraw > GroundDraw > Ground (alternatively you can select the 
toolbar icon)

2. Place a ground connection on the end of the voltage source

Adding Voltage Probes Adding Voltage Probes Adding Voltage Probes Adding Voltage Probes 

1. In the ComponentsComponentsComponentsComponents tab, expand the Probes.Probes.Probes.Probes.

2. Place 2 Voltage ProbesVoltage ProbesVoltage ProbesVoltage Probes and name them v1, v2.

1

50 Z=50
P=10000mil

+
0V

Source1

V v1 V v2
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Creating the Circuit

Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft Designer window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_seg_gplane_tdrhfss_seg_gplane_tdrhfss_seg_gplane_tdrhfss_seg_gplane_tdr

3. Click the SaveSaveSaveSave button

Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. In the Project ManagerProject ManagerProject ManagerProject Manager window, click the ProjectProjectProjectProject tab

2. Select the menu item Circuit Circuit Circuit Circuit ----> Add Solution Setup> Add Solution Setup> Add Solution Setup> Add Solution Setup

3. Analysis Setup Window:

1. For Analysis TypeAnalysis TypeAnalysis TypeAnalysis Type, choose Transient AnalysisTransient AnalysisTransient AnalysisTransient Analysis

2. Click NextNextNextNext

3. Analysis Control

1. Length of Analysis: 8ns8ns8ns8ns

2. Maximum Time Step Allowed: 1ps1ps1ps1ps

4. Convolution Control

1. Maximum Sampling Frequency: 2.5GHz2.5GHz2.5GHz2.5GHz

2. Delta Frequency: 0.01GHz0.01GHz0.01GHz0.01GHz

5. Click FinishFinishFinishFinish

4. Select the menu item Circuit Circuit Circuit Circuit ----> Analyze> Analyze> Analyze> Analyze
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Create Reports

Plot Input, Output waveformsPlot Input, Output waveformsPlot Input, Output waveformsPlot Input, Output waveforms

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item Circuit  Circuit  Circuit  Circuit  ----> Create Report> Create Report> Create Report> Create Report

2. Create Report Window::::

1. Report Type: StandardStandardStandardStandard

2. Display Type: Rectangular PlotRectangular PlotRectangular PlotRectangular Plot

3. Click the OK OK OK OK button

3. Traces Window::::

1. Category: VoltageVoltageVoltageVoltage

2. Quantity: V(VPRB:V1),  V(VPRB:V2)V(VPRB:V1),  V(VPRB:V2)V(VPRB:V1),  V(VPRB:V2)V(VPRB:V1),  V(VPRB:V2)

3. Function: <none><none><none><none>

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

5. Click the DoneDoneDoneDone button
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Create Reports

Plot TDRPlot TDRPlot TDRPlot TDR
To create a report:To create a report:To create a report:To create a report:

1. Select the menu item Circuit  Circuit  Circuit  Circuit  ----> Create Report> Create Report> Create Report> Create Report

2. Create Report Window::::

1. Report Type: StandardStandardStandardStandard

2. Display Type: Rectangular PlotRectangular PlotRectangular PlotRectangular Plot

3. Click the OK OK OK OK button

3. Click on Output VariablesOutput VariablesOutput VariablesOutput Variables button to create TDR equation

1. Name: type TDRTDRTDRTDR

2. Expression: V(VPRB:v2)/(V(VPRB:v1)V(VPRB:v2)/(V(VPRB:v1)V(VPRB:v2)/(V(VPRB:v1)V(VPRB:v2)/(V(VPRB:v1)----V(VPRB:v2))*50V(VPRB:v2))*50V(VPRB:v2))*50V(VPRB:v2))*50

Note: Note: Note: Note: To create the above expression, follow these steps:

1. Category:  VoltageVoltageVoltageVoltage

2. Quantity:  V(VPRB:v2) V(VPRB:v2) V(VPRB:v2) V(VPRB:v2) 

3. Click Insert Quantity into ExpressionInsert Quantity into ExpressionInsert Quantity into ExpressionInsert Quantity into Expression button

4. Type //// then type ((((

5. Quantity:  V(VPRB:v1) V(VPRB:v1) V(VPRB:v1) V(VPRB:v1) 

6. Click Insert Quantity into ExpressionInsert Quantity into ExpressionInsert Quantity into ExpressionInsert Quantity into Expression button

7. Type ----

8. Quantity:  V(VPRB:v2)V(VPRB:v2)V(VPRB:v2)V(VPRB:v2)

9. Click Insert Quantity into ExpressionInsert Quantity into ExpressionInsert Quantity into ExpressionInsert Quantity into Expression button

10. Type ))))

11. Type * 50* 50* 50* 50

3. Click the Add Add Add Add button

4. Click the DoneDoneDoneDone button

� Traces Window::::

� Category: Output VariablesOutput VariablesOutput VariablesOutput Variables

� Quantity: TDRTDRTDRTDR

� Function: <none><none><none><none>

� Click the Add TraceAdd TraceAdd TraceAdd Trace button

� Click the DoneDoneDoneDone button (see next page for TDR plot)
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8.3

Non-Ideal Ground Plane
This example is intended to show you how to create, simulate, and analyze non-

ideal ground planes using the Ansoft HFSS Design Environment.  

Nominal Design:Nominal Design:Nominal Design:Nominal Design:

Ground:Ground:Ground:Ground:

Thickness = 0.1 mmThickness = 0.1 mmThickness = 0.1 mmThickness = 0.1 mm

Board:Board:Board:Board:

Thickness = 0.9 mmThickness = 0.9 mmThickness = 0.9 mmThickness = 0.9 mm

εεεεr r r r = 1= 1= 1= 1
Trace:Trace:Trace:Trace:

Length = 10 mmLength = 10 mmLength = 10 mmLength = 10 mm

Width = 1 mmWidth = 1 mmWidth = 1 mmWidth = 1 mm

Thickness = 0.1 mmThickness = 0.1 mmThickness = 0.1 mmThickness = 0.1 mm
Via:Via:Via:Via:

Diameter = 1 mmDiameter = 1 mmDiameter = 1 mmDiameter = 1 mm

Height = 0.9 mmHeight = 0.9 mmHeight = 0.9 mmHeight = 0.9 mm

bot_gndbot_gndbot_gndbot_gnd

top_gndtop_gndtop_gndtop_gnd

trace1trace1trace1trace1

V
ia

V
ia

V
ia

V
ia

trace2trace2trace2trace2
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8.3

Ansoft HFSS Design Environment
The following features of the Ansoft HFSS Design Environment are used to 

create this passive device model

3D Solid Modeling

Primitives: Box, Rectangles, CylindersBox, Rectangles, CylindersBox, Rectangles, CylindersBox, Rectangles, Cylinders

Boolean Operations: Subtract, Unite, DuplicateSubtract, Unite, DuplicateSubtract, Unite, DuplicateSubtract, Unite, Duplicate

Boundary

Boundary Conditions: Perfect H/NaturalPerfect H/NaturalPerfect H/NaturalPerfect H/Natural

Excitations

Ports: Lumped Gap Source Port, Terminal LinesLumped Gap Source Port, Terminal LinesLumped Gap Source Port, Terminal LinesLumped Gap Source Port, Terminal Lines

Analysis

Sweep: Fast Frequency: Fast Frequency: Fast Frequency: Fast Frequency

Results

Cartesian plottingCartesian plottingCartesian plottingCartesian plotting

Fields

Fast Frequency Sweep/Field PlotsFast Frequency Sweep/Field PlotsFast Frequency Sweep/Field PlotsFast Frequency Sweep/Field Plots
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8.3

Design Review
Before we jump into setting up this device lets review the design.  

Port Size/Type=  ???

Free Space= ???

Port Size/Type

Since the trace is internal to the model, lets use a lumped gap source port

Trace Thickness/Material Properties

To start with perfect conductor, lets make an engineering assumption that the 

trace conductivity will not have an impact on the performance of the device.  

This will speed up the simulation.

Free Space

Since we are only interested in the modes that occur between the ground 

planes, we can use a Perfect H or open boundary condition.  We should 

expect to get the same answer using an Open(Perfect H) or 

matched(Radiation) boundary.  The radiation boundary takes longer to solve 
since it requires a complex solve.

You do need to use some caution when using Perfect H boundary 

conditions in place of radiation boundaries.  The Perfect H and 

Symmetry Perfect H are mathematically equivalent.  Therefore if you 

are simulating a subsection of a larger geometry, you have the 
potential to create modes that are the result of the boundary condition 

or non-physical.  In our example, the Perfect H is applied to the outside 

of the model and not along any symmetry planes.  

It should be noted that the Perfect H boundary condition can be used 
with the Driven and Eigenmode solver.  The Radiation boundary is

only supported by the Driven Solution.
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8.3

Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select 

the Ansoft HFSS 10Ansoft HFSS 10Ansoft HFSS 10Ansoft HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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8.3

Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, click the � On the Standard toolbar, or select 

the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose Driven TerminalDriven TerminalDriven TerminalDriven Terminal

2. Click the OKOKOKOK button
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8.3

Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: mmmmmmmm

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type pecpecpecpec in the Search by NameSearch by NameSearch by NameSearch by Name field

2. Click the OKOKOKOK button
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8.3

Create TraceCreate TraceCreate TraceCreate Trace

To create the trace:To create the trace:To create the trace:To create the trace:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----0.50.50.50.5, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 1.01.01.01.0, dY: ----10.010.010.010.0, dZ: 0.10.10.10.1, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: TraceTraceTraceTrace

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  Or press the CTRL+DCTRL+DCTRL+DCTRL+D key

Create Via PadCreate Via PadCreate Via PadCreate Via Pad

To create the via pad:To create the via pad:To create the via pad:To create the via pad:

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0,  Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.750.750.750.75, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 0.10.10.10.1, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Via_padVia_padVia_padVia_pad

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 



Ansoft High Frequency Structure Simulator v10 User’s Guide 

Example – Non-Ideal Planes

8.3-8

8.3

Group the Trace & Via PadGroup the Trace & Via PadGroup the Trace & Via PadGroup the Trace & Via Pad

To group the dipole arms:To group the dipole arms:To group the dipole arms:To group the dipole arms:

1. Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible.  .  .  .  Or press the CTRL+ACTRL+ACTRL+ACTRL+A key.

2. Select the menu item, 3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite

Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:

1. Select the menu item 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: ----0.20.20.20.2, Press the EnterEnterEnterEnter key

Create Ground 1Create Ground 1Create Ground 1Create Ground 1

To create ground:To create ground:To create ground:To create ground:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----10.010.010.010.0, Y: ----20.020.020.020.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 20.020.020.020.0, dY: 40.040.040.040.0, dZ: 0.10.10.10.1, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: GroundGroundGroundGround

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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8.3

Create AntiCreate AntiCreate AntiCreate Anti----PadPadPadPad

To create the antiTo create the antiTo create the antiTo create the anti----pad:pad:pad:pad:

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 1.01.01.01.0, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 0.10.10.10.1, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: AntipadAntipadAntipadAntipad

3. Click the OKOKOKOK button

Select Ground & Antipad:Select Ground & Antipad:Select Ground & Antipad:Select Ground & Antipad:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Antipad, GroundAntipad, GroundAntipad, GroundAntipad, Ground

2. Click the OK OK OK OK button

To complete the ground object:To complete the ground object:To complete the ground object:To complete the ground object:

1. Select the menu item 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 

2. Subtract Window

Blank Parts: GroundGroundGroundGround

Tool Parts: AntipadAntipadAntipadAntipad

Clone tool objects before subtract: ���� UncheckedUncheckedUncheckedUnchecked

Click the OKOKOKOK button



Ansoft High Frequency Structure Simulator v10 User’s Guide 

Example – Non-Ideal Planes

8.3-10

8.3

Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: GlobalGlobalGlobalGlobal

2. Click the SelectSelectSelectSelect button

Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:

1. Select the menu item 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: ----0.50.50.50.5, Y: ----10.010.010.010.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ
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8.3

Create SourceCreate SourceCreate SourceCreate Source

To create source:To create source:To create source:To create source:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 1.01.01.01.0, dY: 0.00.00.00.0, dZ: ----0.10.10.10.1, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: SourceSourceSourceSource

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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8.3

Assign ExcitationAssign ExcitationAssign ExcitationAssign Excitation

To select the object Source:To select the object Source:To select the object Source:To select the object Source:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: SourceSourceSourceSource

2. Click the OK OK OK OK button

NoteNoteNoteNote:  You can also select the object from the Model Tree

To assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitation

1. Select the menu item HFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped Port

2. Lumped Port : General 

1. Name: p1p1p1p1, 

2. Resistance: 50505050

3. Reactance: 0000

4. Click the NextNextNextNext button

3. Lumped Port : Terminals

1. Number of Terminals: 1111, 

2. For T1T1T1T1, click the UndefinedUndefinedUndefinedUndefined column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: 0.50.50.50.5, Y: 0.00.00.00.0, Z: ----0.10.10.10.1, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 0.10.10.10.1, Press the EnterEnterEnterEnter key

5. Click the FinishFinishFinishFinish button
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8.3

Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: GlobalGlobalGlobalGlobal

2. Click the SelectSelectSelectSelect button

Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:

1. Select the menu item 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: ----0.450.450.450.45, Press the EnterEnterEnterEnter key

Duplicate ObjectsDuplicate ObjectsDuplicate ObjectsDuplicate Objects

To duplicate the existing objects:To duplicate the existing objects:To duplicate the existing objects:To duplicate the existing objects:

1. Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible.  .  .  .  Or press the CTRL+ACTRL+ACTRL+ACTRL+A key.

2. Select the menu item, Edit > Duplicate > Around AxisEdit > Duplicate > Around AxisEdit > Duplicate > Around AxisEdit > Duplicate > Around Axis.

1. Axis: XXXX

2. Angle: 180180180180

3. Total Number: 2222

4. Click the OK OK OK OK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY
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8.3

Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: GlobalGlobalGlobalGlobal

2. Click the SelectSelectSelectSelect button

Create Via Create Via Create Via Create Via 

To create the via:To create the via:To create the via:To create the via:

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0,  Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.50.50.50.5, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: ----0.90.90.90.9, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: ViaViaViaVia

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:

1. Select the menu item 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: ----5.05.05.05.0, Y: ----10.010.010.010.0, Z: ----0.20.20.20.2, Press the EnterEnterEnterEnter key
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Create Ground Via Create Ground Via Create Ground Via Create Ground Via 

To create the Ground Via:To create the Ground Via:To create the Ground Via:To create the Ground Via:

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the cylinder position

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radius:

dX: 0.50.50.50.5, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the height:

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: ----0.50.50.50.5, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Via_GNDVia_GNDVia_GNDVia_GND

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: GlobalGlobalGlobalGlobal

2. Click the SelectSelectSelectSelect button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose vacuumvacuumvacuumvacuum
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Create BoardCreate BoardCreate BoardCreate Board

To create the board:To create the board:To create the board:To create the board:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----10.010.010.010.0, Y: ----20.020.020.020.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 20.020.020.020.0, dY: 40.040.040.040.0, dZ: ----0.90.90.90.9, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: BoardBoardBoardBoard

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 

Create AirCreate AirCreate AirCreate Air

To create the Air:To create the Air:To create the Air:To create the Air:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----15.015.015.015.0, Y: ----25.025.025.025.0, Z: ----5.05.05.05.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 

rectangle:

dX: 30.030.030.030.0, dY: 50.050.050.050.0, dZ: 10.010.010.010.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: AirAirAirAir

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

2.2.2.2.
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Assign Perfect H/Natural BoundariesAssign Perfect H/Natural BoundariesAssign Perfect H/Natural BoundariesAssign Perfect H/Natural Boundaries

To select the object Air:To select the object Air:To select the object Air:To select the object Air:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: AirAirAirAir

2. Click the OK OK OK OK button

To assign Perfect H BoundaryTo assign Perfect H BoundaryTo assign Perfect H BoundaryTo assign Perfect H Boundary

1. Select the menu item HFSS > Boundaries> Assign > Perfect H…HFSS > Boundaries> Assign > Perfect H…HFSS > Boundaries> Assign > Perfect H…HFSS > Boundaries> Assign > Perfect H…

2. Click the OK OK OK OK button

Boundary DisplayBoundary DisplayBoundary DisplayBoundary Display

To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:

1. Select the menu item HFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary Display (Solver View)(Solver View)(Solver View)(Solver View)

2. From the Solver View of Boundaries, toggle the Visibility check box for the  
boundaries you wish to display.

Note:Note:Note:Note: The Perfect Conductors are displayed as the smetalsmetalsmetalsmetal boundary.

Note:Note:Note:Note: Select the menu item, View > VisibilityView > VisibilityView > VisibilityView > Visibility to hide all of the 
geometry objects.  This makes it easier to see the boundary

3. Click the CloseCloseCloseClose button when you are finished.
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Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 10.0GHz: 10.0GHz: 10.0GHz: 10.0GHz

Maximum Number of Passes: 20202020

Maximum Delta S: 0.020.020.020.02

2. Click the OptionsOptionsOptionsOptions tab::::

Do Lambda Refinement: � CheckedCheckedCheckedChecked

Target: 0.05: 0.05: 0.05: 0.05

Use Low-Order Solution Basis: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button

Adding a Frequency SweepAdding a Frequency SweepAdding a Frequency SweepAdding a Frequency Sweep

To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:

1. Select the menu item HFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add Sweep

1. Select Solution Setup: Setup1 Setup1 Setup1 Setup1 

2. Click the OKOKOKOK button

2. Edit Sweep Window:

1. Sweep Type: Fast: Fast: Fast: Fast

2. Frequency Setup Type: Linear Count: Linear Count: Linear Count: Linear Count

Start: 0.1GHz0.1GHz0.1GHz0.1GHz

Stop: 10.0GHz: 10.0GHz: 10.0GHz: 10.0GHz

Count: 991: 991: 991: 991

Save Fields: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_nonidealgndhfss_nonidealgndhfss_nonidealgndhfss_nonidealgnd

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 
Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > AnalyzeHFSS > AnalyzeHFSS > AnalyzeHFSS > Analyze
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button
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Create Reports

Create Terminal SCreate Terminal SCreate Terminal SCreate Terminal S----Parameter Plot vs. Adaptive PassParameter Plot vs. Adaptive PassParameter Plot vs. Adaptive PassParameter Plot vs. Adaptive Pass

Note: Note: Note: Note: If this report is created prior or during the solution process, a real-time 

update of the results are displayed

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Adaptive1Setup1: Adaptive1Setup1: Adaptive1Setup1: Adaptive1

2. Click the X X X X tab

1. Use Primary Sweep: : : : ���� UncheckedUncheckedUncheckedUnchecked

2. Category: VariablesVariablesVariablesVariables

3. Quantity: Pass: Pass: Pass: Pass

3. Click the YYYY tab

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: St(p1,p1) and St(p1, p2)St(p1,p1) and St(p1, p2)St(p1,p1) and St(p1, p2)St(p1,p1) and St(p1, p2)

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button
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Create Terminal S21 Plot Create Terminal S21 Plot Create Terminal S21 Plot Create Terminal S21 Plot vsvsvsvs FrequencyFrequencyFrequencyFrequency

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Domain: SweepSweepSweepSweep

3. Click the YYYY tab

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: St(p1,p2)St(p1,p2)St(p1,p2)St(p1,p2)

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button

To add data marker to the PlotsTo add data marker to the PlotsTo add data marker to the PlotsTo add data marker to the Plots

1. Select the menu item Report2D > Data MarkerReport2D > Data MarkerReport2D > Data MarkerReport2D > Data Marker

2. Move cursor to the resonant points on the plotting curve and click the left 

mouse button

3. When you are finished placing markers at the resonances, right-click the 

mouse and select Exit Marker ModeExit Marker ModeExit Marker ModeExit Marker Mode.
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8.3
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Field Overlays

Create Field OverlayCreate Field OverlayCreate Field OverlayCreate Field Overlay

Select the Relative CS XY PlaneSelect the Relative CS XY PlaneSelect the Relative CS XY PlaneSelect the Relative CS XY Plane

1. Using the Model Tree, expand PlanesPlanesPlanesPlanes

1. Select Relative CS3 XYRelative CS3 XYRelative CS3 XYRelative CS3 XY

Note:Note:Note:Note: Relative CS3 XYRelative CS3 XYRelative CS3 XYRelative CS3 XY plane is the plane between the two Ground 

planes.

2. Select the menu item HFSS > Fields > HFSS > Fields > HFSS > Fields > HFSS > Fields > FieldsFieldsFieldsFields >  E > >  E > >  E > >  E > Mag_EMag_EMag_EMag_E

3. Create Field Plot Window

1. Solution: Setup1 :  Sweep1Setup1 :  Sweep1Setup1 :  Sweep1Setup1 :  Sweep1

2. Intrinsic Variables: Freq: 1.9GHz; Phase: 0degFreq: 1.9GHz; Phase: 0degFreq: 1.9GHz; Phase: 0degFreq: 1.9GHz; Phase: 0deg

3. Quantity: Mag_EMag_EMag_EMag_E

4. In Volume: BoardBoardBoardBoard

5. Click the DoneDoneDoneDone button

To modify the attributes of a field plot:To modify the attributes of a field plot:To modify the attributes of a field plot:To modify the attributes of a field plot:

1. Select the menu item HFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot Attributes

2. Select Plot Folder Window:

1. Select: E FieldE FieldE FieldE Field

2. Click the OKOKOKOK button

3. E-Field Window:

1. Click the Scale Scale Scale Scale tab

1. Select Use LimitsUse LimitsUse LimitsUse Limits

2. Min: 5555

3. Max: 3500350035003500

4. Scale: LogLogLogLog

2. Click the PlotsPlotsPlotsPlots Tab

1. Scalar Plot: FringeFringeFringeFringe

2. Click the CloseCloseCloseClose button
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Create Field Overlay Create Field Overlay Create Field Overlay Create Field Overlay –––– Additional Frequency PointsAdditional Frequency PointsAdditional Frequency PointsAdditional Frequency Points

To modify the Frequency of a field plot:To modify the Frequency of a field plot:To modify the Frequency of a field plot:To modify the Frequency of a field plot:

1. Select the menu item HFSS > Fields >  Modify Plot HFSS > Fields >  Modify Plot HFSS > Fields >  Modify Plot HFSS > Fields >  Modify Plot 

2. Select Plot Folder Window:

1. Select: E FieldE FieldE FieldE Field

2. Click the OKOKOKOK button

3. Create Field Plot Window

1. Solution: Setup1 :  Sweep1Setup1 :  Sweep1Setup1 :  Sweep1Setup1 :  Sweep1

2. Freq: 6.84 GHz6.84 GHz6.84 GHz6.84 GHz

Exiting HFSSExiting HFSSExiting HFSSExiting HFSS

To Exit HFSS:To Exit HFSS:To Exit HFSS:To Exit HFSS:

1. Select the menu item File > ExitFile > ExitFile > ExitFile > Exit

1. If prompted Save the changes
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Return Path
This example is intended to show you how to create, simulate, and analyze the 

return path examples used in the Boundary/Excitations Overview for the Ansoft 

HFSS Design Environment.  

Port1Port1Port1Port1

Port2Port2Port2Port2 Port3Port3Port3Port3
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Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select 

the Ansoft > HFSS 10Ansoft > HFSS 10Ansoft > HFSS 10Ansoft > HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, click the � On the Standard toolbar, or select 

the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose Driven TerminalDriven TerminalDriven TerminalDriven Terminal

2. Click the OKOKOKOK button
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Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: mmmmmmmm

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type pecpecpecpec in the Search by NameSearch by NameSearch by NameSearch by Name field

2. Click the OKOKOKOK button
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Create ConductorCreate ConductorCreate ConductorCreate Conductor

To create the conductor:To create the conductor:To create the conductor:To create the conductor:

1. Select the menu item Draw > LineDraw > LineDraw > LineDraw > Line

2. Using the coordinate entry fields, enter the vertex point:

X: ----5.05.05.05.0, Y: ----0.240.240.240.24, Z: 0.10.10.10.1, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the vertex point:

X: ----1.01.01.01.0, Y: ----0.240.240.240.24, Z: 0.10.10.10.1, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex point:

X: ----1.01.01.01.0, Y: ----0.240.240.240.24, Z: 1.11.11.11.1, Press the EnterEnterEnterEnter key

5. Using the coordinate entry fields, enter the vertex point:

X: 0.00.00.00.0, Y: ----0.240.240.240.24, Z: 1.11.11.11.1, Press the EnterEnterEnterEnter key

6. Using the mouse, right-click and select DoneDoneDoneDone

7. Click the OKOKOKOK button when the Properties dialog appears

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ

To create conductor profile:To create conductor profile:To create conductor profile:To create conductor profile:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the box position

X: ----5.05.05.05.0, Y: ----0.30.30.30.3, Z: 0.10.10.10.1, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:

dX: 0.00.00.00.0, dY: 0.120.120.120.12, dZ: 0.020.020.020.02, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: CondCondCondCond

3. Click the OKOKOKOK button

To Sweep the profile:To Sweep the profile:To Sweep the profile:To Sweep the profile:

1. Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible.  .  .  .  Or press the CTRL+ACTRL+ACTRL+ACTRL+A key

2. Select the menu item Draw > Sweep > Along PathDraw > Sweep > Along PathDraw > Sweep > Along PathDraw > Sweep > Along Path

3. Click the OKOKOKOK button when the Sweep along path dialog appears

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
Or press the CTRL+DCTRL+DCTRL+DCTRL+D key
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Duplicate ConductorDuplicate ConductorDuplicate ConductorDuplicate Conductor

To select the object:To select the object:To select the object:To select the object:

1. Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible.  .  .  .  

To duplicate the conductor:To duplicate the conductor:To duplicate the conductor:To duplicate the conductor:

1. Select the menu item, Edit > Duplicate > Along LineEdit > Duplicate > Along LineEdit > Duplicate > Along LineEdit > Duplicate > Along Line.

1. First Point: X: 0.0, : 0.0, : 0.0, : 0.0, Y: 0.0, : 0.0, : 0.0, : 0.0, Z: 0.0 : 0.0 : 0.0 : 0.0 Press the EnterEnterEnterEnter key

2. Second Point: dX: 0.0: 0.0: 0.0: 0.0, dY: 0.24: 0.24: 0.24: 0.24, dZ: 0.0 : 0.0 : 0.0 : 0.0 Press the EnterEnterEnterEnter key

3. Total Number: 3333

4. Click the OK OK OK OK button

Mirror ConductorMirror ConductorMirror ConductorMirror Conductor

To duplicate the existing objects:To duplicate the existing objects:To duplicate the existing objects:To duplicate the existing objects:

1. Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible.  .  .  .  Or press the CTRL+ACTRL+ACTRL+ACTRL+A key.

2. Select the menu item, Edit > Duplicate > MirrorEdit > Duplicate > MirrorEdit > Duplicate > MirrorEdit > Duplicate > Mirror.

1. Input the anchor point of the mirror plane:

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the Enter Enter Enter Enter key

2. Input the target point of the vector normal to the mirror plane:

dX: 1.01.01.01.0, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the Enter Enter Enter Enter key

Group ConductorsGroup ConductorsGroup ConductorsGroup Conductors

To group the conductors:To group the conductors:To group the conductors:To group the conductors:

1. Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible.  .  .  .  

2. Select the menu item, 3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite
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Create GroundCreate GroundCreate GroundCreate Ground

To create the ground:To create the ground:To create the ground:To create the ground:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----5.05.05.05.0, Y: ----1.01.01.01.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 4.04.04.04.0, dY: 2.02.02.02.0, dZ: -0.020.020.020.02, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: GNDGNDGNDGND

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 

Mirror GroundMirror GroundMirror GroundMirror Ground

To select the object GND:To select the object GND:To select the object GND:To select the object GND:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: GNDGNDGNDGND

2. Click the OK OK OK OK button

To mirror the ground:To mirror the ground:To mirror the ground:To mirror the ground:

1. Select the menu item, Edit > Duplicate > MirrorEdit > Duplicate > MirrorEdit > Duplicate > MirrorEdit > Duplicate > Mirror.

1. Input the anchor point of the mirror plane:

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the Enter Enter Enter Enter key

2. Input the target point of the vector normal to the mirror plane:

dX: 1.01.01.01.0, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the Enter Enter Enter Enter key
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Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ

Create SourceCreate SourceCreate SourceCreate Source

To create source:To create source:To create source:To create source:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the box position

X: 5.05.05.05.0, Y: -0.060.060.060.06, Z: 0.10.10.10.1, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 

rectangle:

dX: 0.00.00.00.0, dY: 0.120.120.120.12, dZ: ----0.10.10.10.1, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: SourceSourceSourceSource

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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Assign ExcitationAssign ExcitationAssign ExcitationAssign Excitation

To select the object Source:To select the object Source:To select the object Source:To select the object Source:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: SourceSourceSourceSource

2. Click the OK OK OK OK button

NoteNoteNoteNote:  You can also select the object from the Model Tree

To assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitation

1. Select the menu item HFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped Port

2. Lumped Port : General 

1. Name: p1p1p1p1, 

2. Resistance: 50505050

3. Reactance: 0000

4. Click the NextNextNextNext button

3. Lumped Port : Terminals

1. Number of Terminals: 1111, 

2. For T1T1T1T1, click the UndefinedUndefinedUndefinedUndefined column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: 5.05.05.05.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex

dX: 0.00.00.00.0, dY: 0.00.00.00.0, dZ: 0.10.10.10.1, Press the EnterEnterEnterEnter key

5. Click the Next Next Next Next button

6. Click the FinishFinishFinishFinish button
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Create Source2Create Source2Create Source2Create Source2

To select Source:To select Source:To select Source:To select Source:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: SourceSourceSourceSource

2. Click the OK OK OK OK button

To mirror the source:To mirror the source:To mirror the source:To mirror the source:

1. Select the menu item, Edit > Duplicate > MirrorEdit > Duplicate > MirrorEdit > Duplicate > MirrorEdit > Duplicate > Mirror.

1. Input the anchor point of the mirror plane:

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the Enter Enter Enter Enter key

2. Input the target point of the vector normal to the mirror plane:

dX: 1.01.01.01.0, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the Enter Enter Enter Enter key

Create Source3Create Source3Create Source3Create Source3

To select Source:To select Source:To select Source:To select Source:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Source_1Source_1Source_1Source_1

2. Click the OK OK OK OK button

To mirror the source:To mirror the source:To mirror the source:To mirror the source:

1. Select the menu item, Edit > Duplicate > MirrorEdit > Duplicate > MirrorEdit > Duplicate > MirrorEdit > Duplicate > Mirror.

1. Input the anchor point of the mirror plane:

X: 0.00.00.00.0, Y: 0.120.120.120.12, Z: 0.00.00.00.0, Press the Enter Enter Enter Enter key

2. Input the target point of the vector normal to the mirror plane:

dX: 0.00.00.00.0, dY: 1.01.01.01.0, dZ: 0.00.00.00.0, Press the Enter Enter Enter Enter key
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Add New MaterialAdd New MaterialAdd New MaterialAdd New Material

To add a new material:To add a new material:To add a new material:To add a new material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. From the Select Definition window, click the Add MaterialAdd MaterialAdd MaterialAdd Material button

3. View/Edit Material Window:

1. Material Name: My_FR4My_FR4My_FR4My_FR4

2. Relative Permittivity: 4.4 4.4 4.4 4.4 

3. Click the OKOKOKOK button

4. Click the OKOKOKOK button
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Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY

Create SubstrateCreate SubstrateCreate SubstrateCreate Substrate

To create substrate:To create substrate:To create substrate:To create substrate:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----5.05.05.05.0, Y: ----1.01.01.01.0,  Z: 0.0, 0.0, 0.0, 0.0, Press the Enter Enter Enter Enter key

3. Using the coordinate entry fields, enter the opposite corner of the base rectangle:

dX: 4.04.04.04.0, dY: 2.02.02.02.0, dZ: 0.1, 0.1, 0.1, 0.1, Press the Enter Enter Enter Enter key 

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: SubstrateSubstrateSubstrateSubstrate

To set the transparency:To set the transparency:To set the transparency:To set the transparency:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. Click the button for Transparency

1. Move the slide bar to 0.8 0.8 0.8 0.8 (Opaque=0, Transparency=1)

2. Click the OKOKOKOK button

3. Click the OKOKOKOK button

Mirror SubstrateMirror SubstrateMirror SubstrateMirror Substrate

To select the object substrate:To select the object substrate:To select the object substrate:To select the object substrate:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: SubstrateSubstrateSubstrateSubstrate

2. Click the OK OK OK OK button

To mirror the ground:To mirror the ground:To mirror the ground:To mirror the ground:

1. Select the menu item, Edit > Duplicate > MirrorEdit > Duplicate > MirrorEdit > Duplicate > MirrorEdit > Duplicate > Mirror.

1. Input the anchor point of the mirror plane:

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the Enter Enter Enter Enter key

2. Input the target point of the vector normal to the mirror plane:

dX: 1.01.01.01.0, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the Enter Enter Enter Enter key
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Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose vacuumvacuumvacuumvacuum

Create AirCreate AirCreate AirCreate Air

To create the Air:To create the Air:To create the Air:To create the Air:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----5.25.25.25.2, Y: ----2.02.02.02.0, Z: ----0.20.20.20.2, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 10.410.410.410.4, dY: 4.04.04.04.0, dZ: 2.02.02.02.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: AirAirAirAir

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Assign RadiationAssign RadiationAssign RadiationAssign Radiation

To select the object Air:To select the object Air:To select the object Air:To select the object Air:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: AirAirAirAir

2. Click the OK OK OK OK button

To assign Radiation BoundaryTo assign Radiation BoundaryTo assign Radiation BoundaryTo assign Radiation Boundary

1. Select the menu item HFSS > Boundaries> Assign > RadiationHFSS > Boundaries> Assign > RadiationHFSS > Boundaries> Assign > RadiationHFSS > Boundaries> Assign > Radiation

2. Click the OK OK OK OK button
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Boundary DisplayBoundary DisplayBoundary DisplayBoundary Display

To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:

1. Select the menu item HFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary Display (Solver View)(Solver View)(Solver View)(Solver View)

2. From the Solver View of Boundaries, toggle the Visibility check box for the  

boundaries you wish to display.

Note:Note:Note:Note: The Perfect Conductors are displayed as the smetalsmetalsmetalsmetal boundary.

Note:Note:Note:Note: Select the menu item, View > VisibilityView > VisibilityView > VisibilityView > Visibility to hide all of the 
geometry objects.  This makes it easier to see the boundary

3. Click the CloseCloseCloseClose button when you are finished.
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Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 15.1GHz: 15.1GHz: 15.1GHz: 15.1GHz

Maximum Number of Passes: 20202020

Maximum Delta S: 0.030.030.030.03

2. Click the OptionsOptionsOptionsOptions tab::::

Do Lambda Refinement: � CheckedCheckedCheckedChecked

Target: 0.05: 0.05: 0.05: 0.05

User Low-Order Solution Basis: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button

Adding a Frequency SweepAdding a Frequency SweepAdding a Frequency SweepAdding a Frequency Sweep

To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:

1. Select the menu item HFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add Sweep

1. Select Solution Setup: Setup1 Setup1 Setup1 Setup1 

2. Click the OKOKOKOK button

2. Edit Sweep Window:

1. Sweep Type: Fast: Fast: Fast: Fast

2. Frequency Setup Type: Linear Count: Linear Count: Linear Count: Linear Count

Start: 0.1GHz0.1GHz0.1GHz0.1GHz

Stop: 15.1GHz: 15.1GHz: 15.1GHz: 15.1GHz

Count: 301: 301: 301: 301

Save Fields: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_returnpathhfss_returnpathhfss_returnpathhfss_returnpath

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 
Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze All
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button
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Create Reports

Create Terminal SCreate Terminal SCreate Terminal SCreate Terminal S----Parameter Plot vs. Adaptive PassParameter Plot vs. Adaptive PassParameter Plot vs. Adaptive PassParameter Plot vs. Adaptive Pass

Note: Note: Note: Note: If this report is created prior or during the solution process, a real-time 

update of the results are displayed

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Adaptive1Setup1: Adaptive1Setup1: Adaptive1Setup1: Adaptive1

2. Click the YYYY tab

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: St(p1,p1), St(p1, p2), St(p1, p3)St(p1,p1), St(p1, p2), St(p1, p3)St(p1,p1), St(p1, p2), St(p1, p3)St(p1,p1), St(p1, p2), St(p1, p3)

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

3. Click the DoneDoneDoneDone button
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Create Terminal SCreate Terminal SCreate Terminal SCreate Terminal S----Parameter Plot Parameter Plot Parameter Plot Parameter Plot vsvsvsvs FrequencyFrequencyFrequencyFrequency

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Domain: SweepSweepSweepSweep

3. Click the YYYY tab

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: St(p1,p1), St(p1, p2), St(p1, p3)St(p1,p1), St(p1, p2), St(p1, p3)St(p1,p1), St(p1, p2), St(p1, p3)St(p1,p1), St(p1, p2), St(p1, p3)

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button.

No DCNo DCNo DCNo DC

Return PathReturn PathReturn PathReturn Path
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Return Path – Add a DC Return Path
We will continue our investigation by adding a connection between the two 

ground planes.  The DC return path will be the path of least resistance.

DCDCDCDC

Return PathReturn PathReturn PathReturn Path
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Copy the DesignCopy the DesignCopy the DesignCopy the Design

To copy the entire design:To copy the entire design:To copy the entire design:To copy the entire design:

1. Using the project manager, 

1. Right-click on HFSSModel1HFSSModel1HFSSModel1HFSSModel1, and choose CopyCopyCopyCopy

2. Using the project manager, 

1. Right-click on hfss_returnpathhfss_returnpathhfss_returnpathhfss_returnpath, and choose PastePastePastePaste

Open the 3D Model EditorOpen the 3D Model EditorOpen the 3D Model EditorOpen the 3D Model Editor

To open the 3D Model Editor:To open the 3D Model Editor:To open the 3D Model Editor:To open the 3D Model Editor:

1. Using the project manager, 

1. Right-click on HFSSModel2HFSSModel2HFSSModel2HFSSModel2 and choose 3D Model Editor3D Model Editor3D Model Editor3D Model Editor

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose pecpecpecpec
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Create DC PathCreate DC PathCreate DC PathCreate DC Path

To create the DC path:To create the DC path:To create the DC path:To create the DC path:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----1.01.01.01.0, Y: 1.01.01.01.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 2.02.02.02.0, dY: ----0.120.120.120.12, dZ: 0.020.020.020.02, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: DCPathDCPathDCPathDCPath

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 



Ansoft High Frequency Structure Simulator v10 User’s Guide 8.4-23

8.4
Example – Return Path

Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > SaveFile > SaveFile > SaveFile > Save

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze All

To Open All Existing ReportTo Open All Existing ReportTo Open All Existing ReportTo Open All Existing Report

To open all reports:To open all reports:To open all reports:To open all reports:

1. Select the menu item HFSS > Results > Open All ReportsHFSS > Results > Open All ReportsHFSS > Results > Open All ReportsHFSS > Results > Open All Reports
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Return Path – Add a RF Return Path
We will continue our investigation by adding an RF return path between the two 

ground planes.  The RF return path will be the path of least inductance.

RF Return PathRF Return PathRF Return PathRF Return Path
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Copy the DesignCopy the DesignCopy the DesignCopy the Design

To copy the entire design:To copy the entire design:To copy the entire design:To copy the entire design:

1. Using the project manager, 

1. Right-click on HFSSModel1HFSSModel1HFSSModel1HFSSModel1, and choose CopyCopyCopyCopy

2. Using the project manager, 

1. Right-click on hfss_returnpathhfss_returnpathhfss_returnpathhfss_returnpath, and choose PastePastePastePaste

Open the 3D Model EditorOpen the 3D Model EditorOpen the 3D Model EditorOpen the 3D Model Editor

To open the 3D Model Editor:To open the 3D Model Editor:To open the 3D Model Editor:To open the 3D Model Editor:

1. Using the project manager, 

1. Right-click on HFSSModel3HFSSModel3HFSSModel3HFSSModel3 and choose 3D Model Editor3D Model Editor3D Model Editor3D Model Editor

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose pecpecpecpec
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Create RF PathCreate RF PathCreate RF PathCreate RF Path

To create the RF path:To create the RF path:To create the RF path:To create the RF path:

1. Select the menu item Draw > LineDraw > LineDraw > LineDraw > Line

2. Using the coordinate entry fields, enter the vertex point:

X: ----1.01.01.01.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the radial point:

X: ----0.9720.9720.9720.972, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the sweep arc length:

X: ----0.9720.9720.9720.972, Y: 0.00.00.00.0, Z: 1.0721.0721.0721.072, Press the EnterEnterEnterEnter key

5. Using the coordinate entry fields, enter the sweep arc length:

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 1.0721.0721.0721.072, Press the EnterEnterEnterEnter key

6. Using the mouse, right-click and select DoneDoneDoneDone

7. Click the OKOKOKOK button when the Properties dialog appears

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ

To create the profile:To create the profile:To create the profile:To create the profile:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the box position

X: ----1.01.01.01.0, Y: ----0.060.060.060.06, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 

rectangle:

dX: 0.00.00.00.0, dY: 0.120.120.120.12, dZ: -0.020.020.020.02, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: RFPathRFPathRFPathRFPath

3. Click the OKOKOKOK button

To Sweep the profile:To Sweep the profile:To Sweep the profile:To Sweep the profile:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Polyline2, Polyline2, Polyline2, Polyline2, RFPathRFPathRFPathRFPath

2. Click the OK OK OK OK button

3. Select the menu item Draw > Sweep > Along PathDraw > Sweep > Along PathDraw > Sweep > Along PathDraw > Sweep > Along Path

4. Click the OKOKOKOK button when the Sweep along path dialog appears
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Mirror ConductorMirror ConductorMirror ConductorMirror Conductor

To duplicate the existing objects:To duplicate the existing objects:To duplicate the existing objects:To duplicate the existing objects:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: RFPathRFPathRFPathRFPath

2. Click the OK OK OK OK button

3. Select the menu item, Edit > Duplicate > MirrorEdit > Duplicate > MirrorEdit > Duplicate > MirrorEdit > Duplicate > Mirror.

1. Input the anchor point of the mirror plane:

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the Enter Enter Enter Enter key

2. Input the target point of the vector normal to the mirror plane:

dX: 1.01.01.01.0, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the Enter Enter Enter Enter key

Group ConductorsGroup ConductorsGroup ConductorsGroup Conductors

To group the conductors:To group the conductors:To group the conductors:To group the conductors:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: RFPathRFPathRFPathRFPath, RFPath_1, RFPath_1, RFPath_1, RFPath_1

2. Click the OK OK OK OK button

3. Select the menu item, 3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > SaveFile > SaveFile > SaveFile > Save

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > AnalyzeHFSS > AnalyzeHFSS > AnalyzeHFSS > Analyze

To Open All Existing ReportTo Open All Existing ReportTo Open All Existing ReportTo Open All Existing Report

To open all reports:To open all reports:To open all reports:To open all reports:

1. Select the menu item HFSS > Results > Open All ReportsHFSS > Results > Open All ReportsHFSS > Results > Open All ReportsHFSS > Results > Open All Reports
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Exiting HFSSExiting HFSSExiting HFSSExiting HFSS

To Exit HFSS:To Exit HFSS:To Exit HFSS:To Exit HFSS:

1. Select the menu item File > ExitFile > ExitFile > ExitFile > Exit

1. If prompted Save the changes
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9.1

Example – Heat Sink

Heat Sink 
This example is intended to show you how to create, simulate, and analyze a 

heat sink using the Ansoft HFSS Design Environment.

With higher power and microwave clock speed, containing emissions from heat 
sinks for microelectronics is rapidly becoming a necessity.  We will investigate 

the performance of a single grounding configuration.  The following illustrations 

detail the passive device you will be creating:    

Top ViewTop ViewTop ViewTop View

1111

2222

Heat Sink/Ground/Ground Pins = Perfect Conductor

Heat Sink

Ground Plane

Ground Pins
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9.1

Example – Heat Sink

Ansoft HFSS Design Environment
The following features of the Ansoft HFSS Design Environment are used to 

create this passive device model:

3D Solid Modeling

Primitives: Box, RectangleBox, RectangleBox, RectangleBox, Rectangle

Boundaries/Excitations

Boundaries: Perfect H, Perfect EPerfect H, Perfect EPerfect H, Perfect EPerfect H, Perfect E

Results

Eigenmode DataEigenmode DataEigenmode DataEigenmode Data

Fields: EEEE---- & H& H& H& H----FieldFieldFieldField
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9.1

Example – Heat Sink

Design Review
Before we jump into setting up this device lets review the design.  

Port Size/Type=  ???

Free Space= ??

Port Size/TypePort Size/TypePort Size/TypePort Size/Type

The goal of this simulation is to determine the effectiveness of various 

grounding conditions at reducing the radiated emissions from a heat sink.  

There are two methods we could use to analyze this problem:

Method 1:Method 1:Method 1:Method 1: Define a port which will excite the structure and 

measure the radiated emissions some distance from the model to 

determine the resonant frequencies.  From the radiated 

emissions, the low frequency performance can be determined.  

This can be very computer intensive and depending on the 
location of the excitation, modes can be missed.

Method 2Method 2Method 2Method 2: Use the Eigenmode solver to determine the natural 

resonances of the heat sink.  This will not give us the radiated

emissions, but it will quickly tell us which configuration reduces 

the low frequency emissions.

Let’s try Case 2.  The Eigenmode solver does not use ports so we only 

have to define the geometry and the boundary conditions.

Free SpaceFree SpaceFree SpaceFree Space

The Eigenmode Solver does not support radiation boundaries.  

Therefore, we will apply a perfect H boundary to the outside of the model 

to simulate free space.
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9.1

Example – Heat Sink

Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select 

the Ansoft  HFSS 10Ansoft  HFSS 10Ansoft  HFSS 10Ansoft  HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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9.1

Example – Heat Sink

Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, click the � On the Standard toolbar, or 

select the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose EigenmodeEigenmodeEigenmodeEigenmode

2. Click the OKOKOKOK button
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9.1

Example – Heat Sink

Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: mm mm mm mm 

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

Using the 3D Modeler Materials toolbar, choose vacuumvacuumvacuumvacuum

Create an Air boxCreate an Air boxCreate an Air boxCreate an Air box

Create Air boxCreate Air boxCreate Air boxCreate Air box

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----80.080.080.080.0, Y: : : : ----60.060.060.060.0, Z: 0.0, : 0.0, : 0.0, : 0.0, Press the EnterEnterEnterEnter key 

3. Using the coordinate entry fields, enter the opposite corner of the base 

rectangle:

dX: 160.0: 160.0: 160.0: 160.0, dY: 120.0: 120.0: 120.0: 120.0, dZ: 44.1, : 44.1, : 44.1, : 44.1, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: AirAirAirAir

To set the To set the To set the To set the WireframeWireframeWireframeWireframe view:view:view:view:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. Display Wireframe: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View
or press the CTRL+DCTRL+DCTRL+DCTRL+D key
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9.1

Example – Heat Sink

Assign a Perfect H boundary to AirAssign a Perfect H boundary to AirAssign a Perfect H boundary to AirAssign a Perfect H boundary to Air

To select the Air:To select the Air:To select the Air:To select the Air:

1. Select the menu item Edit > Select  AllEdit > Select  AllEdit > Select  AllEdit > Select  All

To assign the Perfect H boundaryTo assign the Perfect H boundaryTo assign the Perfect H boundaryTo assign the Perfect H boundary

1. Select the menu item HFSS > Boundaries > Assign > Perfect HHFSS > Boundaries > Assign > Perfect HHFSS > Boundaries > Assign > Perfect HHFSS > Boundaries > Assign > Perfect H

2. Perfect H Boundary window

1. Name: OpenOpenOpenOpen

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type pecpecpecpec in the Search by NameSearch by NameSearch by NameSearch by Name field

2. Click the OKOKOKOK button

Create the Heat SinkCreate the Heat SinkCreate the Heat SinkCreate the Heat Sink

Create Heat SinkCreate Heat SinkCreate Heat SinkCreate Heat Sink

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----44.4544.4544.4544.45, Y: : : : ----31.7531.7531.7531.75, Z: 6.0 : 6.0 : 6.0 : 6.0 Press the EnterEnterEnterEnter key 

3. Using the coordinate entry fields, enter the opposite corner of the base 

rectangle:

dX: 88.9: 88.9: 88.9: 88.9, dY: 63.5: 63.5: 63.5: 63.5, dZ: 38.1 : 38.1 : 38.1 : 38.1 Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: SinkSinkSinkSink

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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9.1

Example – Heat Sink

Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

Create CSCreate CSCreate CSCreate CS

1. Select the menu item 3D Modeler > Coordinate System > Create >  3D Modeler > Coordinate System > Create >  3D Modeler > Coordinate System > Create >  3D Modeler > Coordinate System > Create >  
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: ----44.4544.4544.4544.45, Y: 0.00.00.00.0, Z: 6.0  6.0  6.0  6.0  Press the EnterEnterEnterEnter key

Create a Ground Pin 1Create a Ground Pin 1Create a Ground Pin 1Create a Ground Pin 1

Create Ground Pin 1Create Ground Pin 1Create Ground Pin 1Create Ground Pin 1

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: : : : ----3.03.03.03.0, Z: 0.0 : 0.0 : 0.0 : 0.0 Press the EnterEnterEnterEnter key 

3. Using the coordinate entry fields, enter the opposite corner of the base 

rectangle:

dX: 6.0: 6.0: 6.0: 6.0, dY: 6.0: 6.0: 6.0: 6.0, dZ: : : : ----6.0 6.0 6.0 6.0 Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Ground_PinGround_PinGround_PinGround_Pin

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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Create Ground Pin 2Create Ground Pin 2Create Ground Pin 2Create Ground Pin 2

To select the object To select the object To select the object To select the object Ground_PinGround_PinGround_PinGround_Pin::::

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Ground_PinGround_PinGround_PinGround_Pin

2. Click the OK OK OK OK button

To create Ground Pin 2:To create Ground Pin 2:To create Ground Pin 2:To create Ground Pin 2:

1. Select the menu item, Edit > Duplicate > Along LineEdit > Duplicate > Along LineEdit > Duplicate > Along LineEdit > Duplicate > Along Line.

1. First Point: X: 6.0, : 6.0, : 6.0, : 6.0, Y: 0.0, : 0.0, : 0.0, : 0.0, Z: 0.0 : 0.0 : 0.0 : 0.0 Press the EnterEnterEnterEnter key

2. Second Point: dX: 82.9: 82.9: 82.9: 82.9, dY: 0.0: 0.0: 0.0: 0.0, dZ: 0.0 : 0.0 : 0.0 : 0.0 Press the EnterEnterEnterEnter key

3. Total Number: 2222

4. Click the OK OK OK OK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: GlobalGlobalGlobalGlobal

2. Click the SelectSelectSelectSelect button
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Create GroundCreate GroundCreate GroundCreate Ground

To create ground:To create ground:To create ground:To create ground:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the box position

X: ----80.080.080.080.0, Y: : : : ----60.060.060.060.0, Z: 0.0, : 0.0, : 0.0, : 0.0, Press the EnterEnterEnterEnter key 

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 160.0: 160.0: 160.0: 160.0, dY: 120.0: 120.0: 120.0: 120.0, dZ: 0.0, : 0.0, : 0.0, : 0.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: GroundGroundGroundGround

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Assign a Perfect E boundary to the GroundAssign a Perfect E boundary to the GroundAssign a Perfect E boundary to the GroundAssign a Perfect E boundary to the Ground

To select the ground:To select the ground:To select the ground:To select the ground:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: GroundGroundGroundGround

2. Click the OK OK OK OK button

To assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundary

1. Select the menu item HFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect E

2. Perfect E Boundary window

1. Name: PerfE_GroundPerfE_GroundPerfE_GroundPerfE_Ground

2. Click the OKOKOKOK button
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Mesh OperationsMesh OperationsMesh OperationsMesh Operations

To select an object:To select an object:To select an object:To select an object:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: GroundGroundGroundGround

2. Click the OK OK OK OK button

To assign a mesh operation:To assign a mesh operation:To assign a mesh operation:To assign a mesh operation:

1. Select the menu item, HFSS > Mesh Operations > Assign > On Selection > HFSS > Mesh Operations > Assign > On Selection > HFSS > Mesh Operations > Assign > On Selection > HFSS > Mesh Operations > Assign > On Selection > 
Length BasedLength BasedLength BasedLength Based

2. Element Length Based Refinement Dialog.

1. Name: GroundGroundGroundGround

2. Restrict Length of Elements: ���� UncheckedUncheckedUncheckedUnchecked

3. Restrict Number of Elements:  � CheckedCheckedCheckedChecked

4. Maximum Number of Elements: 1000100010001000

5. Click the OK OK OK OK button



Ansoft High Frequency Structure Simulator v10 User’s Guide 9.1-12

9.1

Example – Heat Sink

Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Minimum Frequency: 0.1 GHz: 0.1 GHz: 0.1 GHz: 0.1 GHz

Number of Modes: 2: 2: 2: 2

Maximum Number of Passes: 10101010

Maximum Delta Frequency per Pass: 1111%

2. Click the OKOKOKOK button

Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_heat_sinkhfss_heat_sinkhfss_heat_sinkhfss_heat_sink

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 

Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze All
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Eigenmode Data:To view the Eigenmode Data:To view the Eigenmode Data:To view the Eigenmode Data:

1. Click the Eigenmode DataEigenmode DataEigenmode DataEigenmode Data Tab

Note: Note: Note: Note: To view a real-time update of the Eigenmode Data, set 

the Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button
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Field Overlays

Create Field OverlayCreate Field OverlayCreate Field OverlayCreate Field Overlay

To create a field plot:To create a field plot:To create a field plot:To create a field plot:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: GroundGroundGroundGround

2. Click the OK OK OK OK button

3. Select the menu item HFSS > Fields > HFSS > Fields > HFSS > Fields > HFSS > Fields > FieldsFieldsFieldsFields > E > > E > > E > > E > Mag_EMag_EMag_EMag_E

4. Create Field Plot Window

1. Solution: Setup1 :  Setup1 :  Setup1 :  Setup1 :  LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Quantity: Mag_EMag_EMag_EMag_E

3. In Volume: AllAllAllAll

4. Click the DoneDoneDoneDone button

Mode 1: EMode 1: EMode 1: EMode 1: E----FieldFieldFieldField
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Edit SourcesEdit SourcesEdit SourcesEdit Sources

To Excite Mode 2:To Excite Mode 2:To Excite Mode 2:To Excite Mode 2:

1. Select the menu item HFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit Sources

2. Edit Sources window

1. Source: EigenMode_1EigenMode_1EigenMode_1EigenMode_1

1. Scaling Factor: 0000

2. Offset Phase: 0000

2. Source: EigenMode_2EigenMode_2EigenMode_2EigenMode_2

1. Scaling Factor: 1111

2. Offset Phase: 0000

3. Click the OKOKOKOK button

Mode 2: EMode 2: EMode 2: EMode 2: E----FieldFieldFieldField
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Create Field OverlayCreate Field OverlayCreate Field OverlayCreate Field Overlay

To create a field plot:To create a field plot:To create a field plot:To create a field plot:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: GroundGroundGroundGround

2. Click the OK OK OK OK button

3. Select the menu item HFSS > Fields > HFSS > Fields > HFSS > Fields > HFSS > Fields > FieldsFieldsFieldsFields > H > > H > > H > > H > Mag_HMag_HMag_HMag_H

4. Create Field Plot Window

1. Solution: Setup1 :  Setup1 :  Setup1 :  Setup1 :  LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Quantity: Mag_HMag_HMag_HMag_H

3. In Volume: AllAllAllAll

4. Click the DoneDoneDoneDone button

Edit SourcesEdit SourcesEdit SourcesEdit Sources

To Excite Mode 1:To Excite Mode 1:To Excite Mode 1:To Excite Mode 1:

1. Select the menu item HFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit Sources

2. Edit Sources window

1. Source: EigenMode_1EigenMode_1EigenMode_1EigenMode_1

1. Scaling Factor: 1111

2. Offset Phase: 90: 90: 90: 90

2. Source: EigenMode_2EigenMode_2EigenMode_2EigenMode_2

1. Scaling Factor: 0000

2. Offset Phase: 0000

3. Click the OKOKOKOK button

Mode 1: HMode 1: HMode 1: HMode 1: H----FieldFieldFieldField
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Edit SourcesEdit SourcesEdit SourcesEdit Sources

To Excite Mode 2:To Excite Mode 2:To Excite Mode 2:To Excite Mode 2:

1. Select the menu item HFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit SourcesHFSS > Fields > Edit Sources

2. Edit Sources window

1. Source: EigenMode_1EigenMode_1EigenMode_1EigenMode_1

1. Scaling Factor: 0000

2. Offset Phase: 0: 0: 0: 0

2. Source: EigenMode_2EigenMode_2EigenMode_2EigenMode_2

1. Scaling Factor: 1111

2. Offset Phase: 90909090

3. Click the OKOKOKOK button

Mode 2: HMode 2: HMode 2: HMode 2: H----FieldFieldFieldField

Exiting HFSSExiting HFSSExiting HFSSExiting HFSS

To Exit HFSS:To Exit HFSS:To Exit HFSS:To Exit HFSS:

1. Select the menu item File > ExitFile > ExitFile > ExitFile > Exit

1. If prompted Save the changes



��������	��
�	
���
��
��	������
�



Example – Enclosure

Ansoft High Frequency Structure Simulator v10 User’s Guide 9.2-1

9.2

Shielded Enclosure 
This example is intended to show you how to create, simulate, and analyze a 

shielded enclosure using the Ansoft HFSS Design Environment.

Shielding enclosures for high-speed digital designs can be compromised by 
slots and apertures.  Therefore an understanding of the energy coupling 

mechanisms is essential.
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Ansoft HFSS Design Environment
The following features of the Ansoft HFSS Design Environment are used to 

create this passive device model:

3D Solid Modeling

Primitives: Box, Rectangle, CylinderBox, Rectangle, CylinderBox, Rectangle, CylinderBox, Rectangle, Cylinder

Boolean: Unite, SubtractUnite, SubtractUnite, SubtractUnite, Subtract

Boundaries/Excitations

Boundaries: Lumped RLC, RadiationLumped RLC, RadiationLumped RLC, RadiationLumped RLC, Radiation

Results

Reports: SSSS----ParametersParametersParametersParameters

Fields: EEEE----FieldFieldFieldField
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Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and select 

the Ansoft HFSS 10Ansoft HFSS 10Ansoft HFSS 10Ansoft HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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9.2

Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

1. In an  Ansoft HFSS window, click the � On the Standard toolbar, or 

select the menu item File > NewFile > NewFile > NewFile > New.

2. From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose Driven TerminalDriven TerminalDriven TerminalDriven Terminal

2. Click the OKOKOKOK button
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9.2

Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: cm cm cm cm 

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

Using the 3D Modeler Materials toolbar, choose vacuumvacuumvacuumvacuum

Create the Air Inside caseCreate the Air Inside caseCreate the Air Inside caseCreate the Air Inside case

Create Air Inside CaseCreate Air Inside CaseCreate Air Inside CaseCreate Air Inside Case

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: 0.0: 0.0: 0.0: 0.0, Z: 0.0, : 0.0, : 0.0, : 0.0, Press the EnterEnterEnterEnter key 

3. Using the coordinate entry fields, enter the opposite corner of the base 

rectangle:

dX: 22.0: 22.0: 22.0: 22.0, dY: 14.0: 14.0: 14.0: 14.0, dZ: 30.0, : 30.0, : 30.0, : 30.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Air_InsideAir_InsideAir_InsideAir_Inside

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
Or press the CTRL+DCTRL+DCTRL+DCTRL+D key
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9.2

Create the SlotCreate the SlotCreate the SlotCreate the Slot
Create SlotCreate SlotCreate SlotCreate Slot

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 0.00.00.00.0, Y: 0.2: 0.2: 0.2: 0.2, Z: 9.0 : 9.0 : 9.0 : 9.0 Press the EnterEnterEnterEnter key 

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: : : : ----0.050.050.050.05, dY: 0.1: 0.1: 0.1: 0.1, dZ: 12.0 : 12.0 : 12.0 : 12.0 Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: SlotSlotSlotSlot

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 

Create an Air boxCreate an Air boxCreate an Air boxCreate an Air box
Create an Air boxCreate an Air boxCreate an Air boxCreate an Air box

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----4.054.054.054.05, Y: : : : ----4.054.054.054.05, Z: : : : ----4.05, 4.05, 4.05, 4.05, Press the EnterEnterEnterEnter key 

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 28.1: 28.1: 28.1: 28.1, dY: 20.1: 20.1: 20.1: 20.1, dZ: 38.1, : 38.1, : 38.1, : 38.1, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: AirAirAirAir

3. Display Wireframe: � CheckedCheckedCheckedChecked

4. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System
Create CSCreate CSCreate CSCreate CS

1. Select the menu item 3D Modeler > Coordinate System > Create >  Relative 3D Modeler > Coordinate System > Create >  Relative 3D Modeler > Coordinate System > Create >  Relative 3D Modeler > Coordinate System > Create >  Relative 
CS > OffsetCS > OffsetCS > OffsetCS > Offset

2. Using the coordinate entry fields, enter the origin

X: 17.017.017.017.0, Y: 14.014.014.014.0, Z: 15.0  15.0  15.0  15.0  Press the EnterEnterEnterEnter key
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9.2

Create Coax DielectricCreate Coax DielectricCreate Coax DielectricCreate Coax Dielectric
To create the coax dielectric:To create the coax dielectric:To create the coax dielectric:To create the coax dielectric:

1. From the Drawing Plane toolbar, change the active plane to XZXZXZXZ.

2. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

3. Using the coordinate entry fields, enter the center position

X: 0.0: 0.0: 0.0: 0.0, Y: 0.0: 0.0: 0.0: 0.0, Z: 0.0,: 0.0,: 0.0,: 0.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the radius of the cylinder

dX: 0.16: 0.16: 0.16: 0.16, dY: 0.0: 0.0: 0.0: 0.0, dZ: 0: 0: 0: 0.0000, Press the EnterEnterEnterEnter key

5. Using the coordinate entry fields, enter the height of the cylinder

dX: 0.0: 0.0: 0.0: 0.0, dY: 2.05: 2.05: 2.05: 2.05, dZ: 0.0: 0.0: 0.0: 0.0,  Press the EnterEnterEnterEnter key 

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Coax_DielCoax_DielCoax_DielCoax_Diel

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View

Group ObjectsGroup ObjectsGroup ObjectsGroup Objects
To group the objects:To group the objects:To group the objects:To group the objects:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Air_InsideAir_InsideAir_InsideAir_Inside, , , , Coax_DielCoax_DielCoax_DielCoax_Diel, Slot, Slot, Slot, Slot

2. Click the OK OK OK OK button.

3. Select the menu item, 3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View....

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material
To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type pecpecpecpec in the Search by NameSearch by NameSearch by NameSearch by Name field

2. Click the OKOKOKOK button
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9.2

Create Coax ShieldCreate Coax ShieldCreate Coax ShieldCreate Coax Shield

To create the coax shield:To create the coax shield:To create the coax shield:To create the coax shield:

1. From the Drawing Plane toolbar, change the active plane to XZXZXZXZ.

2. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

3. Using the coordinate entry fields, enter the center position

X: 0.0: 0.0: 0.0: 0.0, Y: 0.0: 0.0: 0.0: 0.0, Z: 0.0,: 0.0,: 0.0,: 0.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the radius of the cylinder

dX: 0.21: 0.21: 0.21: 0.21, dY: 0.0: 0.0: 0.0: 0.0, dZ: 0: 0: 0: 0.0000, Press the EnterEnterEnterEnter key

5. Using the coordinate entry fields, enter the height of the cylinder

dX: 0.0: 0.0: 0.0: 0.0, dY: 2.05: 2.05: 2.05: 2.05, dZ: 0.0: 0.0: 0.0: 0.0,  Press the EnterEnterEnterEnter key 

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Coax_ShieldCoax_ShieldCoax_ShieldCoax_Shield

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View

Create Coax PinCreate Coax PinCreate Coax PinCreate Coax Pin

To create the coax pin:To create the coax pin:To create the coax pin:To create the coax pin:

1. From the Drawing Plane toolbar, change the active plane to XZXZXZXZ.

2. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

3. Using the coordinate entry fields, enter the center position

X: 0.0: 0.0: 0.0: 0.0, Y: 2.05: 2.05: 2.05: 2.05, Z: 0.0,: 0.0,: 0.0,: 0.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the radius of the cylinder

dX: 0.08: 0.08: 0.08: 0.08, dY: 0.0: 0.0: 0.0: 0.0, dZ: 0: 0: 0: 0.0000, Press the EnterEnterEnterEnter key

5. Using the coordinate entry fields, enter the height of the cylinder

dX: 0.0: 0.0: 0.0: 0.0, dY: : : : ----15.8915.8915.8915.89, dZ: 0.0: 0.0: 0.0: 0.0,  Press the EnterEnterEnterEnter key 

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Coax_PinCoax_PinCoax_PinCoax_Pin

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View
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9.2

Create the Wave portCreate the Wave portCreate the Wave portCreate the Wave port
To create a circle that represents the port:To create a circle that represents the port:To create a circle that represents the port:To create a circle that represents the port:

1. From the Drawing Plane toolbar, change the active plane to XZXZXZXZ.

2. Select the menu item Draw > CircleDraw > CircleDraw > CircleDraw > Circle

3. Using the coordinate entry fields, enter the center position

X: 0.0: 0.0: 0.0: 0.0, Y: 2.05: 2.05: 2.05: 2.05, Z: 0.0,: 0.0,: 0.0,: 0.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the radius of the circle:

dX: 0.16: 0.16: 0.16: 0.16, dY: 0.0: 0.0: 0.0: 0.0, dZ: 0: 0: 0: 0.0000, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: p1p1p1p1

3. Click the OKOKOKOK button

To select the object p1:To select the object p1:To select the object p1:To select the object p1:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: p1p1p1p1

2. Click the OK OK OK OK button

To assign wave port excitationTo assign wave port excitationTo assign wave port excitationTo assign wave port excitation

1. Select the menu item HFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave Port

2. Wave Port : General

1. Name: p1p1p1p1, 

2. Click the NextNextNextNext button

3. Wave Port : Terminals

1. Number of Terminals: 1111,

2. For T1T1T1T1, click the UndefinedUndefinedUndefinedUndefined column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: 0.160.160.160.16, Y: 2.052.052.052.05, Z: 0.0, 0.0, 0.0, 0.0, Press the Enter Enter Enter Enter key

4. Using the coordinate entry fields, enter the vertex

dX: : : : ----0.08, 0.08, 0.08, 0.08, dYdYdYdY: 0.0: 0.0: 0.0: 0.0, dZ: 0.0, 0.0, 0.0, 0.0, Press the Enter Enter Enter Enter key 

5. Click the NextNextNextNext button

4. Wave Port : Differential Pairs 

1. Click the NextNextNextNext button

5. Wave Port : Post Processing 

1. Reference Impedance: 50505050

6. Click the FinishFinishFinishFinish button
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9.2

Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

Create CSCreate CSCreate CSCreate CS

1. Select the menu item 3D Modeler > Coordinate System > Create >  3D Modeler > Coordinate System > Create >  3D Modeler > Coordinate System > Create >  3D Modeler > Coordinate System > Create >  
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: 0.00.00.00.0, Y: ----13.8413.8413.8413.84, Z: 0.0  0.0  0.0  0.0  Press the EnterEnterEnterEnter key

Create ResistorCreate ResistorCreate ResistorCreate Resistor

To create the Resistor:To create the Resistor:To create the Resistor:To create the Resistor:

1. From the Drawing Plane toolbar, change the active plane to XYXYXYXY.

2. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

3. Using the coordinate entry fields, enter the box position

X: ----0.080.080.080.08, Y: 0.0: 0.0: 0.0: 0.0, Z: 0.0, : 0.0, : 0.0, : 0.0, Press the EnterEnterEnterEnter key 

4. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 0.16: 0.16: 0.16: 0.16, dY: : : : ----0.160.160.160.16, dZ: 0.0, : 0.0, : 0.0, : 0.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: ResistorResistorResistorResistor

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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9.2

Assign a Lumped RLC boundary to the ResistorAssign a Lumped RLC boundary to the ResistorAssign a Lumped RLC boundary to the ResistorAssign a Lumped RLC boundary to the Resistor

To select the ground:To select the ground:To select the ground:To select the ground:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: ResistorResistorResistorResistor

2. Click the OK OK OK OK button

To assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundary

1. Select the menu item HFSS > Boundaries > Assign > Lumped RLCHFSS > Boundaries > Assign > Lumped RLCHFSS > Boundaries > Assign > Lumped RLCHFSS > Boundaries > Assign > Lumped RLC

2. Lumped RLC Boundary window

1. Name: ResistorResistorResistorResistor

2.2.2.2. ���� ResistanceResistanceResistanceResistance: : : : 47 ohm47 ohm47 ohm47 ohm

3. Current Flow Line: New Line: New Line: New Line: New Line

1. Point 1: X: 0.0: 0.0: 0.0: 0.0, Y: 0.00.00.00.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter Key

2. Point 2: dX: 0.0: 0.0: 0.0: 0.0, dY: : : : ----0.160.160.160.16, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter Key

4. Click the OKOKOKOK button

Set Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate SystemSet Working Coordinate System

To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:To set the working  coordinate system:

1. Select the menu item 3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS3D Modeler > Coordinate System > Set Working CS

2. Select Coordinate System Window,

1. From the list, select the CS: GlobalGlobalGlobalGlobal

2. Click the SelectSelectSelectSelect button
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9.2

Create the CaseCreate the CaseCreate the CaseCreate the Case

Create CaseCreate CaseCreate CaseCreate Case

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----0.050.050.050.05, Y: : : : ----0.050.050.050.05, Z: : : : ----0.05, 0.05, 0.05, 0.05, Press the EnterEnterEnterEnter key 

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 22.1: 22.1: 22.1: 22.1, dY: 14.1: 14.1: 14.1: 14.1, dZ: 30.1, : 30.1, : 30.1, : 30.1, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: CaseCaseCaseCase

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Group ObjectsGroup ObjectsGroup ObjectsGroup Objects

To group the objects:To group the objects:To group the objects:To group the objects:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Case, Case, Case, Case, Coax_ShieldCoax_ShieldCoax_ShieldCoax_Shield

2. Click the OK OK OK OK button

3. Select the menu item, 3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View....
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9.2

Complete the CaseComplete the CaseComplete the CaseComplete the Case

To select the objects:To select the objects:To select the objects:To select the objects:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Case, Case, Case, Case, Air_InsideAir_InsideAir_InsideAir_Inside

2. Click the OK OK OK OK button

To complete the case:To complete the case:To complete the case:To complete the case:

1. Select the menu item 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 

2. Subtract Window

Blank Parts: CaseCaseCaseCase

Tool Parts: Air_InsideAir_InsideAir_InsideAir_Inside

Clone tool objects before subtract: ���� UncheckedUncheckedUncheckedUnchecked

Click the OKOKOKOK button

Create Radiation BoundaryCreate Radiation BoundaryCreate Radiation BoundaryCreate Radiation Boundary

To create a radiation boundaryTo create a radiation boundaryTo create a radiation boundaryTo create a radiation boundary

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: AirAirAirAir

2. Click the OK OK OK OK button

3. Select the menu item HFSS > Boundaries >  Assign > RadiationHFSS > Boundaries >  Assign > RadiationHFSS > Boundaries >  Assign > RadiationHFSS > Boundaries >  Assign > Radiation

4. Radiation Boundary window

1. Name: Rad1Rad1Rad1Rad1

2. Click the OKOKOKOK button
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9.2

Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 1.1 GHz: 1.1 GHz: 1.1 GHz: 1.1 GHz

Maximum Number of Passes: 10101010

Maximum Delta S: 0.020.020.020.02

2. Click the OKOKOKOK button

Adding a Frequency SweepAdding a Frequency SweepAdding a Frequency SweepAdding a Frequency Sweep

To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:

1. Select the menu item HFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add Sweep

1. Select Solution Setup: Setup1 Setup1 Setup1 Setup1 

2. Click the OKOKOKOK button

2. Edit Sweep Window:

1. Sweep Type: Fast: Fast: Fast: Fast

2. Frequency Setup Type: Linear Count: Linear Count: Linear Count: Linear Count

Start: 0.6 GHz0.6 GHz0.6 GHz0.6 GHz

Stop: 1.6 GHz: 1.6 GHz: 1.6 GHz: 1.6 GHz

Count: 201: 201: 201: 201

Save Fields: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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9.2

Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_enclosurehfss_enclosurehfss_enclosurehfss_enclosure

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 
Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze All
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9.2

Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button
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9.2

Create Reports

Create Terminal SCreate Terminal SCreate Terminal SCreate Terminal S----Parameter Plot Parameter Plot Parameter Plot Parameter Plot ---- MagnitudeMagnitudeMagnitudeMagnitude

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Domain: SweepSweepSweepSweep

3. Click the YYYY tab

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: St(p1,p1), St(p1,p1), St(p1,p1), St(p1,p1), 

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button
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9.2

Create Reports (Continued)

Custom Equations Custom Equations Custom Equations Custom Equations –––– Output VariablesOutput VariablesOutput VariablesOutput Variables

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Click the Output VariablesOutput VariablesOutput VariablesOutput Variables button

2. Output Variables dialog:

1. Name:  Pdelivered_nWPdelivered_nWPdelivered_nWPdelivered_nW

2. Expression: 

Type: 2.5*(12.5*(12.5*(12.5*(1----

Category: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

Quantity: St(p1,p1)St(p1,p1)St(p1,p1)St(p1,p1)

Function: magmagmagmag

Click the Insert Quantity into ExpressionInsert Quantity into ExpressionInsert Quantity into ExpressionInsert Quantity into Expression button

Type: ^2)^2)^2)^2)

3. Click the AddAddAddAdd button

4. Click the DoneDoneDoneDone button

3. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

4. Domain: SweepSweepSweepSweep

5. Click the YYYY tab

1. Category: Output VariablesOutput VariablesOutput VariablesOutput Variables

2. Quantity: Pdelivered_nWPdelivered_nWPdelivered_nWPdelivered_nW

3. Function: <none><none><none><none>

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

6. Click the DoneDoneDoneDone button

( )2

11

2

1
8

S
Z

V
P

o

s −=

Power Delivered

Vs – Source Voltage (1mV)

Zo - 50Ω

(1mv)^2/8*50 = 2.5e-9
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9.2
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9.2

Field OverlaysField OverlaysField OverlaysField Overlays

To create a field plot:To create a field plot:To create a field plot:To create a field plot:

1. Select an object to overlay fields

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: AirAirAirAir

2. Click the OK OK OK OK button

NoteNoteNoteNote:  You can also select the object from the Model Tree

2. Select the menu item HFSS > Fields > HFSS > Fields > HFSS > Fields > HFSS > Fields > FieldsFieldsFieldsFields >  E > >  E > >  E > >  E > Mag_EMag_EMag_EMag_E

3. Create Field Plot Window

1. Solution: Setup1 :  Sweep1Setup1 :  Sweep1Setup1 :  Sweep1Setup1 :  Sweep1

2. Freq: 0.89 GHz0.89 GHz0.89 GHz0.89 GHz

3. Quantity: Mag_EMag_EMag_EMag_E

4. In Volume: AllAllAllAll

5. Click the DoneDoneDoneDone button

To modify the attributes of a field plot:To modify the attributes of a field plot:To modify the attributes of a field plot:To modify the attributes of a field plot:

1. Select the menu item HFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot Attributes

2. Select Plot Folder Window:

1. Select: E FieldE FieldE FieldE Field

2. Click the OKOKOKOK button

3. E-Field Window:

1. Click the Scale Scale Scale Scale tab

1. Select Use LimitsUse LimitsUse LimitsUse Limits

2. Min: 5555

3. Max: 600600600600

4. Scale: LogLogLogLog

2. Click the PlotPlotPlotPlot tab

1. IsoValType: IsoValSurfaceIsoValSurfaceIsoValSurfaceIsoValSurface

2. Click the ApplyApplyApplyApply button.

4. Click the CloseCloseCloseClose button
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9.2

Field OverlaysField OverlaysField OverlaysField Overlays

To modify the Frequency of a field plot:To modify the Frequency of a field plot:To modify the Frequency of a field plot:To modify the Frequency of a field plot:

1. Select the menu item HFSS > Fields >  Modify Plot HFSS > Fields >  Modify Plot HFSS > Fields >  Modify Plot HFSS > Fields >  Modify Plot 

2. Select Plot Folder Window:

1. Select: E FieldE FieldE FieldE Field

2. Click the OKOKOKOK button

3. Create Field Plot Window

1. Solution: Setup1 :  Sweep1Setup1 :  Sweep1Setup1 :  Sweep1Setup1 :  Sweep1

2. Freq: 1.08 GHz1.08 GHz1.08 GHz1.08 GHz

1.08 GHz1.08 GHz1.08 GHz1.08 GHz
1.51 GHz1.51 GHz1.51 GHz1.51 GHz
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Example – Silicon Spiral Inductor

10.1

10.1-1

The Silicon Spiral Inductor
This example is intended to show you how to create, simulate, and analyze a 2.5 

turn spiral inductor using the Ansoft HFSS Design Environment.

SubstrateSubstrateSubstrateSubstrate

OxideOxideOxideOxide

PassivationPassivationPassivationPassivation

M6M6M6M6

M5M5M5M5

Nominal Design:Nominal Design:Nominal Design:Nominal Design:

Spiral:  Spiral:  Spiral:  Spiral:  2.5T, W=15um, S=1.5um, Rad=60um

M6, 2um, σ= 2.8e7 S/m

Underpass:Underpass:Underpass:Underpass: M5, 0.5um, σ= 2.8e7 S/m

Stackup:Stackup:Stackup:Stackup:

PassivationPassivationPassivationPassivation: : : : 0.7um

εr = 7.9

Oxide: Oxide: Oxide: Oxide: 9.8um

εr = 4.0

Substrate: Substrate: Substrate: Substrate: 300um

εr = 11.9, σ= 10 S/m
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Example – Silicon Spiral Inductor

10.1

10.1-2

Getting Started

Launching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSSLaunching Ansoft HFSS

1. To access Ansoft HFSS, click the Microsoft StartStartStartStart button, select ProgramsProgramsProgramsPrograms, and 

select the Ansoft > HFSS 10Ansoft > HFSS 10Ansoft > HFSS 10Ansoft > HFSS 10 program group.  Click HFSS 10HFSS 10HFSS 10HFSS 10.

Setting Tool OptionsSetting Tool OptionsSetting Tool OptionsSetting Tool Options

To set the tool options:To set the tool options:To set the tool options:To set the tool options:

Note:  Note:  Note:  Note:  In order to follow the steps outlined in this example, verify that the 
following tool options are set : : : : 

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : �

CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

3. Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options.

4. 3D Modeler Options Window:

1. Click the OperationOperationOperationOperation tab

Automatically cover closed polylines: : : : � CheckedCheckedCheckedChecked

2. Click the DrawingDrawingDrawingDrawing tab

Edit property of new primitives: : : : � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button
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Example – Silicon Spiral Inductor

10.1

10.1-3

Opening a New ProjectOpening a New ProjectOpening a New ProjectOpening a New Project

To open a new project:To open a new project:To open a new project:To open a new project:

In an  Ansoft HFSS window, click the � On the Standard toolbar, or select 

the menu item File > NewFile > NewFile > NewFile > New.

From the ProjectProjectProjectProject menu, select Insert HFSS DesignInsert HFSS DesignInsert HFSS DesignInsert HFSS Design....

Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

Solution Type Window:

Choose Driven TerminalDriven TerminalDriven TerminalDriven Terminal

Click the OKOKOKOK button
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Example – Silicon Spiral Inductor

10.1

10.1-4

Creating the 3D Model

Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: umumumum

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Click the Add MaterialAdd MaterialAdd MaterialAdd Material button

2. View/Edit Material Window:

1. For the Material NameMaterial NameMaterial NameMaterial Name type: My_SubMy_SubMy_SubMy_Sub

2. For the ValueValueValueValue of Relative PermittivityRelative PermittivityRelative PermittivityRelative Permittivity type: 11.9 11.9 11.9 11.9 

3. For the ValueValueValueValue of Bulk ConductivityBulk ConductivityBulk ConductivityBulk Conductivity type: 10101010

4. Click the OKOKOKOK button

3. Click the OKOKOKOK button



Ansoft High Frequency Structure Simulator v10 User’s Guide 

Example – Silicon Spiral Inductor

10.1

10.1-5

Create SubstrateCreate SubstrateCreate SubstrateCreate Substrate

To create the substrate:To create the substrate:To create the substrate:To create the substrate:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----270.0270.0270.0270.0, Y: ----270.0270.0270.0270.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 540.0540.0540.0540.0, dY: 540.0540.0540.0540.0, dZ: 300.0300.0300.0300.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: SubSubSubSub

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Click the Add MaterialAdd MaterialAdd MaterialAdd Material button

2. View/Edit Material Window:

1. For the Material NameMaterial NameMaterial NameMaterial Name type: My_OxideMy_OxideMy_OxideMy_Oxide

2. For the ValueValueValueValue of Relative PermittivityRelative PermittivityRelative PermittivityRelative Permittivity type: 4.0 4.0 4.0 4.0 

3. Click the OKOKOKOK button

3. Click the OKOKOKOK button
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Example – Silicon Spiral Inductor

10.1

10.1-6

Create OxideCreate OxideCreate OxideCreate Oxide

To create substrate:To create substrate:To create substrate:To create substrate:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----270.0270.0270.0270.0, Y: ----270.0270.0270.0270.0, Z: 300.0300.0300.0300.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 540.0540.0540.0540.0, dY: 540.0540.0540.0540.0, dZ: 9.89.89.89.8, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: OxideOxideOxideOxide

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Click the Add MaterialAdd MaterialAdd MaterialAdd Material button

2. View/Edit Material Window:

1. For the Material NameMaterial NameMaterial NameMaterial Name type: My_PassMy_PassMy_PassMy_Pass

2. For the ValueValueValueValue of Relative PermittivityRelative PermittivityRelative PermittivityRelative Permittivity type: 7.9 7.9 7.9 7.9 

3. Click the OKOKOKOK button

3. Click the OKOKOKOK button
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Example – Silicon Spiral Inductor

10.1

10.1-7

Create Create Create Create PassivationPassivationPassivationPassivation

To create substrate:To create substrate:To create substrate:To create substrate:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----270.0270.0270.0270.0, Y: ----270.0270.0270.0270.0, Z: 309.8309.8309.8309.8, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 540.0540.0540.0540.0, dY: 540.0540.0540.0540.0, dZ: 0.70.70.70.7, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: PassPassPassPass

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose vacuumvacuumvacuumvacuum

Create AirCreate AirCreate AirCreate Air

To create air:To create air:To create air:To create air:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----270.0270.0270.0270.0, Y: ----270.0270.0270.0270.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 540.0540.0540.0540.0, dY: 540.0540.0540.0540.0, dZ: 600.0600.0600.0600.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: AirAirAirAir

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View
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Example – Silicon Spiral Inductor

10.1

10.1-8

Create Radiation Boundary
To select the object AirTo select the object AirTo select the object AirTo select the object Air:

Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

Select Object Dialog, 

Select the objects named: AirAirAirAir

Click the OKOKOKOK button

To create a radiation boundaryTo create a radiation boundaryTo create a radiation boundaryTo create a radiation boundary

Select the menu item HFSS > Boundaries > Assign > RadiationHFSS > Boundaries > Assign > RadiationHFSS > Boundaries > Assign > RadiationHFSS > Boundaries > Assign > Radiation

Radiation Boundary Window

Name: Rad1Rad1Rad1Rad1

Click the OKOKOKOK button

Create Ground
To create ground:To create ground:To create ground:To create ground:

Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

Using the coordinate entry fields, enter the box position

X: ----270.0270.0270.0270.0, Y: ----270.0270.0270.0270.0, Z: 0.00.00.00.0, Press the Enter key

Using the coordinate entry fields, enter the opposite corner of the base 

rectangle:

dX: 540.0540.0540.0540.0, dY: 540.0540.0540.0540.0, dZ: 0.00.00.00.0, Press the Enter key

To set the name:

Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

For the ValueValueValueValue of NameNameNameName type: GroundGroundGroundGround

Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

Select the menu item View > Fit All > Active View.  View > Fit All > Active View.  View > Fit All > Active View.  View > Fit All > Active View.  
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Example – Silicon Spiral Inductor

10.1

10.1-9

Assign a Perfect E boundary to the GroundAssign a Perfect E boundary to the GroundAssign a Perfect E boundary to the GroundAssign a Perfect E boundary to the Ground

To select the ground:To select the ground:To select the ground:To select the ground:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: GroundGroundGroundGround

2. Click the OK OK OK OK button

To assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundaryTo assign the Perfect E boundary

1. Select the menu item HFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect EHFSS > Boundaries > Assign > Perfect E

2. Perfect E Boundary window

1. Name: PerfE_GroundPerfE_GroundPerfE_GroundPerfE_Ground

2. Click the OKOKOKOK button

Hide DielectricsHide DielectricsHide DielectricsHide Dielectrics

To hide the dielectrics:To hide the dielectrics:To hide the dielectrics:To hide the dielectrics:

1. Select the menu item Edit > Select  All VisibleEdit > Select  All VisibleEdit > Select  All VisibleEdit > Select  All Visible

2. Select the menu item View > Hide Selection > All ViewsView > Hide Selection > All ViewsView > Hide Selection > All ViewsView > Hide Selection > All Views

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Click the Add MaterialAdd MaterialAdd MaterialAdd Material button

2. View/Edit Material Window:

1. For the Material NameMaterial NameMaterial NameMaterial Name type: My_MetMy_MetMy_MetMy_Met

2. For the ValueValueValueValue of Bulk ConductivityBulk ConductivityBulk ConductivityBulk Conductivity type: 2.8e72.8e72.8e72.8e7

3. Click the OKOKOKOK button

3. Click the OKOKOKOK button

Create Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate SystemCreate Offset Coordinate System

To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:To create an offset Coordinate System:

1. Select the menu item 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 3D Modeler > Coordinate System > Create > 
Relative CS > OffsetRelative CS > OffsetRelative CS > OffsetRelative CS > Offset

2. Using the coordinate entry fields, enter the origin

X: 0.00.00.00.0, Y: 0.00.00.00.0, Z: 304.8304.8304.8304.8, Press the Enter Enter Enter Enter key 
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10.1

10.1-10

Create Spiral PathCreate Spiral PathCreate Spiral PathCreate Spiral Path

To create the path:To create the path:To create the path:To create the path:

1. Select the menu item Draw > LineDraw > LineDraw > LineDraw > Line

2. Using the coordinate entry fields, enter the vertex point:

X: ----60.060.060.060.0, Y: 7.57.57.57.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the vertex point:

X: ----60.060.060.060.0, Y: ----60.060.060.060.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex point:

X: 76.576.576.576.5, Y: ----60.060.060.060.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

5. Using the coordinate entry fields, enter the vertex point:

X: 76.576.576.576.5, Y: 76.576.576.576.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

6. Using the coordinate entry fields, enter the vertex point:

X: -76.576.576.576.5, Y: 76.576.576.576.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

7. Using the coordinate entry fields, enter the vertex point:

X: -76.576.576.576.5, Y: -76.576.576.576.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

8. Using the coordinate entry fields, enter the vertex point:

X: 93.093.093.093.0, Y: -76.576.576.576.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

9. Using the coordinate entry fields, enter the vertex point:

X: 93.093.093.093.0, Y: 93.093.093.093.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

10. Using the coordinate entry fields, enter the vertex point:

X: -93.093.093.093.0, Y: 93.093.093.093.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

11. Using the coordinate entry fields, enter the vertex point:

X: -93.093.093.093.0, Y: -93.093.093.093.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

12. Using the coordinate entry fields, enter the vertex point:

X: 109.5109.5109.5109.5, Y: -93.093.093.093.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

13. Using the coordinate entry fields, enter the vertex point:

X: 109.5109.5109.5109.5, Y: 7.57.57.57.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

14. Using the coordinate entry fields, enter the vertex point:

X: 131.0131.0131.0131.0, Y: 7.57.57.57.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

15. Using the mouse, right-click and select DoneDoneDoneDone

16. Click the OKOKOKOK button when the Properties dialog appears
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10.1

10.1-11

Create the SpiralCreate the SpiralCreate the SpiralCreate the Spiral

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ3D Modeler > Grid Plane > XZ

To create conductor profile:To create conductor profile:To create conductor profile:To create conductor profile:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the box position

X: ----60.060.060.060.0, Y: 7.57.57.57.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 

rectangle:

dX: ----15.015.015.015.0, dY: 0.00.00.00.0, dZ: 2.02.02.02.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: SpiralSpiralSpiralSpiral

3. Click the OKOKOKOK button

To Sweep the profile:To Sweep the profile:To Sweep the profile:To Sweep the profile:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Polyline1, SpiralPolyline1, SpiralPolyline1, SpiralPolyline1, Spiral

2. Click the OK OK OK OK button

NoteNoteNoteNote:  You can also select the object from the Model Tree

1. Select the menu item Draw > Sweep > Along PathDraw > Sweep > Along PathDraw > Sweep > Along PathDraw > Sweep > Along Path

2. Click the OKOKOKOK button when the Sweep along path dialog appears

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the grid plane:To set the grid plane:To set the grid plane:To set the grid plane:

1. Select the menu item 3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY3D Modeler > Grid Plane > XY

Create UnderpassCreate UnderpassCreate UnderpassCreate Underpass

To create underpass:To create underpass:To create underpass:To create underpass:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----60.060.060.060.0, Y: 7.57.57.57.5, Z: ----0.80.80.80.8, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: ----75.075.075.075.0, dY: ----15.015.015.015.0, dZ: ----0.50.50.50.5, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: UnderpassUnderpassUnderpassUnderpass

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View....
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Create Via1Create Via1Create Via1Create Via1

To create via:To create via:To create via:To create via:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----60.060.060.060.0, Y: 7.57.57.57.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: ----15.015.015.015.0, dY: ----15.015.015.015.0, dZ: ----0.80.80.80.8, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Via1Via1Via1Via1

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View....

Create Via2Create Via2Create Via2Create Via2

To create via:To create via:To create via:To create via:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----120.0120.0120.0120.0, Y: 7.57.57.57.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: ----15.015.015.015.0, dY: ----15.015.015.015.0, dZ: ----0.80.80.80.8, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Via2Via2Via2Via2

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View....
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Create FeedCreate FeedCreate FeedCreate Feed

To create feed:To create feed:To create feed:To create feed:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----120.0120.0120.0120.0, Y: 7.57.57.57.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: ----22.022.022.022.0, dY: ----15.015.015.015.0, dZ: 2.02.02.02.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: FeedFeedFeedFeed

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View....

Solve Inside ConductorsSolve Inside ConductorsSolve Inside ConductorsSolve Inside Conductors

To solve inside:To solve inside:To solve inside:To solve inside:

1. Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible

2. Select the menu item Edit > PropertiesEdit > PropertiesEdit > PropertiesEdit > Properties

3. Properties Dialog Attribute Tab

1. Solve Inside: � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

Click the OKOKOKOK button for all warning messages (Solving inside a solid with high 

conductivity may require a large mesh) 

Seed Mesh Conductors set for Solve InsideSeed Mesh Conductors set for Solve InsideSeed Mesh Conductors set for Solve InsideSeed Mesh Conductors set for Solve Inside

To solve inside:To solve inside:To solve inside:To solve inside:

1. Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible

2. Select the menu item HFSS > Mesh Operations > Assign > Inside HFSS > Mesh Operations > Assign > Inside HFSS > Mesh Operations > Assign > Inside HFSS > Mesh Operations > Assign > Inside 
Selection > Length BasedSelection > Length BasedSelection > Length BasedSelection > Length Based

3. Element Length Based Refinement Dialog

1. Restrict Length of Elements: ���� UncheckedUncheckedUncheckedUnchecked

2. Restrict Number of Elements: � CheckedCheckedCheckedChecked

3. Maximum Number of Elements: 5000: 5000: 5000: 5000

4. Click the OKOKOKOK button
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Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type pecpecpecpec in the Search by NameSearch by NameSearch by NameSearch by Name field

2. Click the OKOKOKOK button

Create Ground RingCreate Ground RingCreate Ground RingCreate Ground Ring

To create outer ring:To create outer ring:To create outer ring:To create outer ring:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----225.0225.0225.0225.0, Y: ----225.0225.0225.0225.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 450.0450.0450.0450.0, dY: 450.0450.0450.0450.0, dZ: 2.02.02.02.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: RingRingRingRing

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View

Create Inner RingCreate Inner RingCreate Inner RingCreate Inner Ring

To create inner ring:To create inner ring:To create inner ring:To create inner ring:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----210.0210.0210.0210.0, Y: ----210.0210.0210.0210.0, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 420.0420.0420.0420.0, dY: 420.0420.0420.0420.0, dZ: 2.02.02.02.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: InnerInnerInnerInner

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View
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Complete the RingComplete the RingComplete the RingComplete the Ring

To select the objects Ring and Inner:To select the objects Ring and Inner:To select the objects Ring and Inner:To select the objects Ring and Inner:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Ring, InnerRing, InnerRing, InnerRing, Inner

2. Click the OK OK OK OK button

To complete the ring:To complete the ring:To complete the ring:To complete the ring:

1. Select the menu item 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 3D Modeler > Boolean > Subtract 

2. Subtract Window

Blank Parts: RingRingRingRing

Tool Parts: InnerInnerInnerInner

Click the OKOKOKOK button

Create Extension 1Create Extension 1Create Extension 1Create Extension 1

To create extension:To create extension:To create extension:To create extension:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: ----157.0157.0157.0157.0, Y: 7.57.57.57.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: ----53.053.053.053.0, dY: ----15.015.015.015.0, dZ: 2.02.02.02.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Ring_Ext1Ring_Ext1Ring_Ext1Ring_Ext1

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View
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Create Extension 2Create Extension 2Create Extension 2Create Extension 2

To create extension:To create extension:To create extension:To create extension:

1. Select the menu item Draw > BoxDraw > BoxDraw > BoxDraw > Box

2. Using the coordinate entry fields, enter the box position

X: 146.0146.0146.0146.0, Y: 7.57.57.57.5, Z: 0.00.00.00.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the box:

dX: 64.064.064.064.0, dY: ----15.015.015.015.0, dZ: 2.02.02.02.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Ring_Ext2Ring_Ext2Ring_Ext2Ring_Ext2

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View

Group the ConductorsGroup the ConductorsGroup the ConductorsGroup the Conductors

To group the conductors:To group the conductors:To group the conductors:To group the conductors:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Ring, Ring_Ext1, Ring_Ext2Ring, Ring_Ext1, Ring_Ext2Ring, Ring_Ext1, Ring_Ext2Ring, Ring_Ext1, Ring_Ext2

2. Click the OK OK OK OK button

3. Select the menu item, 3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View. . . . 
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Create Source 1Create Source 1Create Source 1Create Source 1
To create source:To create source:To create source:To create source:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the box position

X: ----142.0142.0142.0142.0, Y: 7.57.57.57.5, Z: 1.01.01.01.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: ----15.015.015.015.0, dY: ----15.015.015.015.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Source1Source1Source1Source1

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Assign ExcitationAssign ExcitationAssign ExcitationAssign Excitation
To select the object Source:To select the object Source:To select the object Source:To select the object Source:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Source1Source1Source1Source1

2. Click the OK OK OK OK button

NoteNoteNoteNote:  You can also select the object from the Model Tree

To assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitation

1. Select the menu item HFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped Port

2. Lumped Port : General 

1. Name: p1p1p1p1, 

2. Resistance: 50505050

3. Reactance: 0000

4. Click the NextNextNextNext button

3. Lumped Port : Terminals

1. Number of Terminals: 1111, 

2. For T1T1T1T1, click the UndefinedUndefinedUndefinedUndefined column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: ----157.0157.0157.0157.0, Y: 0.00.00.00.0, Z: 1.01.01.01.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex

dX: 15.015.015.015.0, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

5. Click the FinishFinishFinishFinish button
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Create Source 2Create Source 2Create Source 2Create Source 2
To create source:To create source:To create source:To create source:

1. Select the menu item Draw > RectangleDraw > RectangleDraw > RectangleDraw > Rectangle

2. Using the coordinate entry fields, enter the box position

X: 131.0131.0131.0131.0, Y: 7.57.57.57.5, Z: 1.01.01.01.0, Press the EnterEnterEnterEnter key

3. Using the coordinate entry fields, enter the opposite corner of the base 
rectangle:

dX: 15.015.015.015.0, dY: ----15.015.015.015.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Source2Source2Source2Source2

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  

Assign ExcitationAssign ExcitationAssign ExcitationAssign Excitation
To select the object Source:To select the object Source:To select the object Source:To select the object Source:

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Source2Source2Source2Source2

2. Click the OK OK OK OK button

NoteNoteNoteNote:  You can also select the object from the Model Tree

To assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitationTo assign lumped port excitation

1. Select the menu item HFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped PortHFSS > Excitations > Assign > Lumped Port

2. Lumped Port : General 

1. Name: p2p2p2p2, 

2. Resistance: 50505050

3. Reactance: 0000

4. Click the NextNextNextNext button

3. Lumped Port : Terminals

1. Number of Terminals: 1111, 

2. For T1T1T1T1, click the UndefinedUndefinedUndefinedUndefined column and select New LineNew LineNew LineNew Line

3. Using the coordinate entry fields, enter the vector position

X: 146.0146.0146.0146.0, Y: 0.00.00.00.0, Z: 1.01.01.01.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the vertex

dX: ----15.015.015.015.0, dY: 0.00.00.00.0, dZ: 0.00.00.00.0, Press the EnterEnterEnterEnter key

5. Click the FinishFinishFinishFinish button
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Show AllShow AllShow AllShow All

To show all objectTo show all objectTo show all objectTo show all object

1. Select the menu item View > Show All > All ViewsView > Show All > All ViewsView > Show All > All ViewsView > Show All > All Views

Boundary DisplayBoundary DisplayBoundary DisplayBoundary Display

To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:To verify the boundary setup:

1. Select the menu item HFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary DisplayHFSS > Boundary Display (Solver View)(Solver View)(Solver View)(Solver View)

2. From the Solver View of Boundaries, toggle the Visibility check box for the  

boundaries you wish to display.

Note:Note:Note:Note: The background (Perfect Conductor) is displayed as the outerouterouterouter
boundary.

Note:Note:Note:Note: The Perfect Conductors are displayed as the smetalsmetalsmetalsmetal boundary.

Note:Note:Note:Note: Select the menu item, View > VisibilityView > VisibilityView > VisibilityView > Visibility to hide all of the 

geometry objects.  This makes it easier to see the boundary

3. Click the CloseCloseCloseClose button when you are finished
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Analysis Setup

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 12.0GHz: 12.0GHz: 12.0GHz: 12.0GHz

Maximum Number of Passes: 20202020

Maximum Delta S: 0.020.020.020.02

2. Click the OptionsOptionsOptionsOptions tab::::

Do Lambda Refinement: � CheckedCheckedCheckedChecked

Target: 0.05: 0.05: 0.05: 0.05

User Low-Order Solution Basis: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button

Adding a Frequency SweepAdding a Frequency SweepAdding a Frequency SweepAdding a Frequency Sweep

To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:

1. Select the menu item HFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add Sweep

1. Select Solution Setup: Setup1 Setup1 Setup1 Setup1 

2. Click the OKOKOKOK button

2. Edit Sweep Window:

1. Sweep Type: Interpolating: Interpolating: Interpolating: Interpolating

2. Click the Setup Interpolation Basis Setup Interpolation Basis Setup Interpolation Basis Setup Interpolation Basis button

Max Solutions: 20: 20: 20: 20

Error Tolerance: 0.5%: 0.5%: 0.5%: 0.5%

Click the OK OK OK OK button

3. Frequency Setup Type: Linear Step: Linear Step: Linear Step: Linear Step

Start: 0.1GHz0.1GHz0.1GHz0.1GHz

Stop: 20.0GHz: 20.0GHz: 20.0GHz: 20.0GHz

Step: 0.1GHz: 0.1GHz: 0.1GHz: 0.1GHz

4. Click the OKOKOKOK button
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_spiral_inductorhfss_spiral_inductorhfss_spiral_inductorhfss_spiral_inductor

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message 
Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze All
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Solution DataSolution DataSolution DataSolution Data

To view the Solution Data:To view the Solution Data:To view the Solution Data:To view the Solution Data:

1. Select the menu item HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

To view the Profile:To view the Profile:To view the Profile:To view the Profile:

1. Click the ProfileProfileProfileProfile Tab.

To view the Convergence:To view the Convergence:To view the Convergence:To view the Convergence:

1. Click the ConvergenceConvergenceConvergenceConvergence Tab

Note: Note: Note: Note: The default view is for convergence is TableTableTableTable.  Select 

the PlotPlotPlotPlot radio button to view a graphical representations of 

the convergence data.

To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:To view the Matrix Data:

1. Click the Matrix DataMatrix DataMatrix DataMatrix Data Tab

Note: Note: Note: Note: To view a real-time update of the Matrix Data, set the 

Simulation to Setup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last AdaptiveSetup1, Last Adaptive

2. Click the CloseCloseCloseClose button
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Create Reports

Create SCreate SCreate SCreate S----parameter vs. Frequencyparameter vs. Frequencyparameter vs. Frequencyparameter vs. Frequency

To Create a report:To Create a report:To Create a report:To Create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Click the YYYY tab

1. Domain: SweepSweepSweepSweep

2. Category: Terminal STerminal STerminal STerminal S----ParametersParametersParametersParameters

3. Quantity: St(p1,p1), St(p2,p1)St(p1,p1), St(p2,p1)St(p1,p1), St(p2,p1)St(p1,p1), St(p2,p1)

4. Function: dBdBdBdB

5. Click the Add TraceAdd TraceAdd TraceAdd Trace button

3. Click the DoneDoneDoneDone button
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Create Reports (Continued)

Custom Equations Custom Equations Custom Equations Custom Equations –––– Output VariablesOutput VariablesOutput VariablesOutput Variables

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Click the Output VariablesOutput VariablesOutput VariablesOutput Variables button

2. Output Variables dialog:

1. Name:  Q11Q11Q11Q11

2. Expression: 

Category: Terminal Y ParametersTerminal Y ParametersTerminal Y ParametersTerminal Y Parameters

Quantity: Yt(p1,p1)Yt(p1,p1)Yt(p1,p1)Yt(p1,p1)

Function: imimimim

Click the Insert Quantity into ExpressionInsert Quantity into ExpressionInsert Quantity into ExpressionInsert Quantity into Expression button

Type: ////

Quantity: Yt(p1,p1)Yt(p1,p1)Yt(p1,p1)Yt(p1,p1)

Function: rererere

Click the Insert Quantity into ExpressionInsert Quantity into ExpressionInsert Quantity into ExpressionInsert Quantity into Expression button

3. Click the AddAddAddAdd button

4. Repeat for Q22Q22Q22Q22, by replacing Yt(p1,p1)Yt(p1,p1)Yt(p1,p1)Yt(p1,p1) with Yt(p2,p2)Yt(p2,p2)Yt(p2,p2)Yt(p2,p2)

5. Click the DoneDoneDoneDone button

3. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

4. Domain: SweepSweepSweepSweep

5. Click the YYYY tab

1. Category: Output VariablesOutput VariablesOutput VariablesOutput Variables

2. Quantity: Q11, Q22Q11, Q22Q11, Q22Q11, Q22

3. Function: absabsabsabs

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

6. Click the DoneDoneDoneDone button
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Create Reports (Continued)

Custom Equations Custom Equations Custom Equations Custom Equations –––– Output VariablesOutput VariablesOutput VariablesOutput Variables

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Terminal S ParametersTerminal S ParametersTerminal S ParametersTerminal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Click the Output VariablesOutput VariablesOutput VariablesOutput Variables button

2. Output Variables dialog:

1. Name:  L11L11L11L11

2. Expression: 

Type: ----1/(2*pi*freq*1/(2*pi*freq*1/(2*pi*freq*1/(2*pi*freq*

Category: Terminal Y ParametersTerminal Y ParametersTerminal Y ParametersTerminal Y Parameters

Quantity: Yt(p1,p1)Yt(p1,p1)Yt(p1,p1)Yt(p1,p1)

Function: imimimim

Click the Insert Quantity into ExpressionInsert Quantity into ExpressionInsert Quantity into ExpressionInsert Quantity into Expression button

Type: ))))

3. Click the AddAddAddAdd button

4. Click the DoneDoneDoneDone button

3. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

4. Domain: SweepSweepSweepSweep

5. Click the YYYY tab

1. Category: Output VariablesOutput VariablesOutput VariablesOutput Variables

2. Quantity: Y11Y11Y11Y11

3. Function: nonenonenonenone

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

6. Click the DoneDoneDoneDone button
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Appendix – Alternative Lumped Ports

G S G

Port

PEC BridgePEC BridgePEC BridgePEC Bridge
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Appendix – Alternative Lumped Ports

G S G

Port

SSSSGGGG GGGG

Lumped Lumped Lumped Lumped 

PortPortPortPort

gapgapgapgap

gapgapgapgap
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Appendix – Alternative Lumped Ports

G S G

Port

SSSSGGGG GGGG

ViaViaViaVia ViaViaViaVia
Lumped PortLumped PortLumped PortLumped Port

Ground BridgeGround BridgeGround BridgeGround Bridge
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Quick Example – Coax Tee HFSS – High Frequency Structure Simulator

Full-Wave 3D field solver

Solves for the fields in an arbitrary volume

Coax Dielectric

Coax Center Pin

Outer Boundary

Coax Shield
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Starting HFSS
Click the Microsoft Start Start Start Start button, select ProgramsProgramsProgramsPrograms, and select the Ansoft > HFSS 10  > HFSS 10Ansoft > HFSS 10  > HFSS 10Ansoft > HFSS 10  > HFSS 10Ansoft > HFSS 10  > HFSS 10

Or Or Or Or Double click on the HFSS 10 icon  on the Windows Desktop

Adding a Design
When you first start HFSS a new project with a new design will be automatically added to the Project Tree.

Toolbar:Toolbar:Toolbar:Toolbar: Insert HFSS Design

To include additional designs into an existing project, select the menu item Project > Insert HFSS DesignProject > Insert HFSS DesignProject > Insert HFSS DesignProject > Insert HFSS Design

Alternatively to open a new project with a new design manually, select the menu item File > NewFile > NewFile > NewFile > New.
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Ansoft Desktop

Menu 

bar

Progress 

Window

Property Window

Message 

Manager

Project

Manager

with project

tree

Status 

bar

3D Modeler

Window

Toolbars

Coordinate Entry Fields
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Ansoft Desktop – Project Manager
Multiple Designs per Project

Multiple Projects per Desktop

Integrated Optimetrics Setup

Requires License for Analysis

Project

Design

Design Results

Design Setup

Design Automation
•Parametric

•Optimization
•Sensitivity

•Statistical

Project Manager Window
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Ansoft Desktop – 3D Modeler

Edge
Vertex

Plane

Coordinate System (CS)

Origin

Face

Model

3D Modeler Window

Graphics

area

Model

3D Modeler 

design tree

Context menu
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Set Solution TypeSet Solution TypeSet Solution TypeSet Solution Type

To set the solution type:To set the solution type:To set the solution type:To set the solution type:

1. Select the menu item HFSS > Solution TypeHFSS > Solution TypeHFSS > Solution TypeHFSS > Solution Type

2. Solution Type Window:

1. Choose Driven ModalDriven ModalDriven ModalDriven Modal

2. Click the OKOKOKOK button

HFSS HFSS HFSS HFSS ---- Solution TypesSolution TypesSolution TypesSolution Types

Driven ModalDriven ModalDriven ModalDriven Modal - calculates the modal-based S-parameters. The S-matrix solutions will be expressed in terms of the 

incident and reflected powers of waveguide modes.

Generalized S-parameters

Driven TerminalDriven TerminalDriven TerminalDriven Terminal - calculates the terminal-based S-parameters of multi-conductor transmission line ports. The S-

matrix solutions will be expressed in terms of terminal voltages and currents.

EigenmodeEigenmodeEigenmodeEigenmode – calculate the eigenmodes, or resonances, of a structure. The Eigenmode solver finds the resonant 

frequencies of the structure and the fields at those resonant frequencies. 

Convergence

Driven ModalDriven ModalDriven ModalDriven Modal – Delta S for modal S-Parameters.   

Driven TerminalDriven TerminalDriven TerminalDriven Terminal – Delta S for the single-ended or differential nodal S-Parameters.  

EigenmodeEigenmodeEigenmodeEigenmode - Delta F
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Set Model UnitsSet Model UnitsSet Model UnitsSet Model Units

To set the units:To set the units:To set the units:To set the units:

1. Select the menu item 3D Modeler > Units3D Modeler > Units3D Modeler > Units3D Modeler > Units

2. Set Model Units:

1. Select Units: mmmmmmmm

2. Click the OKOKOKOK button

Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

1. Using the 3D Modeler Materials toolbar, choose SelectSelectSelectSelect

2. Select Definition Window:

1. Type pecpecpecpec in the Search by NameSearch by NameSearch by NameSearch by Name field

2. Click the OKOKOKOK button
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3D Modeler – Create a Primitive

Point 2

Point 3

Point 1

Grid Plane

Base Rectangle

Point 1

Point 2

Point 3

Coordinate Entry Fields

The Coordinate Entry fields allow equations to be entered for position values.  

Examples: 2*5, 2+6+8, 2*cos(10*(pi/180)).

Variables are not allowed in the Coordinate Entry Field

NoteNoteNoteNote: Trig functions are in radians
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3D Modeler – Object Properties

Attributes

Commands

Attributes

Commands
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3D Modeler – Attributes
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Set Grid PlaneSet Grid PlaneSet Grid PlaneSet Grid Plane

To set the Grid Plane:To set the Grid Plane:To set the Grid Plane:To set the Grid Plane:

Select the menu item 3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ3D Modeler > Grid Plane > YZ

Create Coax PinCreate Coax PinCreate Coax PinCreate Coax Pin

To create the coax pin:To create the coax pin:To create the coax pin:To create the coax pin:

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the center position

X: 0.0: 0.0: 0.0: 0.0, Y: 0.0: 0.0: 0.0: 0.0, Z: 0.0,: 0.0,: 0.0,: 0.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the radius of the cylinder

dX: 0.0: 0.0: 0.0: 0.0, dY: .86.0: .86.0: .86.0: .86.0, dZ: 0: 0: 0: 0.0000, Press the EnterEnterEnterEnter key

5. Using the coordinate entry fields, enter the height of the cylinder

dX: 6.0: 6.0: 6.0: 6.0, dY: 0.0: 0.0: 0.0: 0.0 dZ: 0.0: 0.0: 0.0: 0.0,  Press the EnterEnterEnterEnter key 

Continued on Next PageContinued on Next PageContinued on Next PageContinued on Next Page



Ansoft High Frequency Structure Simulator v10 – Training Seminar P1-13

Overview
Presentation

1

Create Coax Pin (Continued)Create Coax Pin (Continued)Create Coax Pin (Continued)Create Coax Pin (Continued)

To Parameterize the HeightTo Parameterize the HeightTo Parameterize the HeightTo Parameterize the Height

1. Select the CommandCommandCommandCommand tab from the PropertiesPropertiesPropertiesProperties window

2. Height: HHHH

3. Press the Tab Tab Tab Tab key

4. Add Variable Window

1. Value: 6mm6mm6mm6mm

2. Click the OKOKOKOK button

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: Coax_PinCoax_PinCoax_PinCoax_Pin

To set the color:To set the color:To set the color:To set the color:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. Click the EditEditEditEdit button

To set the transparency:To set the transparency:To set the transparency:To set the transparency:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. Click the OK OK OK OK button

To finish editing the object propertiesTo finish editing the object propertiesTo finish editing the object propertiesTo finish editing the object properties

1. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View
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3D Modeler - Views
View > Modify Attributes >View > Modify Attributes >View > Modify Attributes >View > Modify Attributes >

Orientation Orientation Orientation Orientation – Predefined/Custom View Angles 

LightingLightingLightingLighting – Control angle, intensity, and color of light

ProjectionProjectionProjectionProjection – Control camera and perspective

Background ColorBackground ColorBackground ColorBackground Color – Control color of 3D Modeler background

View > Active View VisibilityView > Active View VisibilityView > Active View VisibilityView > Active View Visibility - Controls the display of: 3D Modeler 

Objects, Color Keys, Boundaries, Excitations, Field Plots

View > OptionsView > OptionsView > OptionsView > Options – Stereo Mode, Drag Optimization, Color Key Defaults,

Default Rotation

View > Render > Wire FrameView > Render > Wire FrameView > Render > Wire FrameView > Render > Wire Frame or Smooth ShadedSmooth ShadedSmooth ShadedSmooth Shaded (Default)

View > Coordinate System > HideView > Coordinate System > HideView > Coordinate System > HideView > Coordinate System > Hide or Small (Large)Small (Large)Small (Large)Small (Large)

View > Grid SettingView > Grid SettingView > Grid SettingView > Grid Setting – Controls the grid display

Toolbar:Toolbar:Toolbar:Toolbar: Toggle Grid Visibility
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Changing the View
ToolbarToolbarToolbarToolbar

Context MenuContext MenuContext MenuContext Menu

ShortcutsShortcutsShortcutsShortcuts

Since changing the view is a frequently used operation, some useful shortcut keys exist.  Press the 

appropriate keys and drag the mouse with the left button pressed:

ALT + DragALT + DragALT + DragALT + Drag – Rotate

In addition, there are 9 pre-defined view angles that can be selected by holding the ALT key and 

double clicking on the locations shown on the next page.

Shift + DragShift + DragShift + DragShift + Drag - Pan

ALT + Shift + DragALT + Shift + DragALT + Shift + DragALT + Shift + Drag – Dynamic Zoom

Pan

Rotate Around

Model Center

Dynamic Zoom

Zoom In/Out

TopTopTopTop

BottomBottomBottomBottom

RightRightRightRight

Predefined View Angles

LeftLeftLeftLeft

Rotate Around

Current Axis

Rotate Around

Screen Center

Fit All

Fit Selected
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Set Default MaterialSet Default MaterialSet Default MaterialSet Default Material

To set the default material:To set the default material:To set the default material:To set the default material:

Using the 3D Modeler Materials toolbar, choose vacuumvacuumvacuumvacuum

Create Coax Create Coax Create Coax Create Coax 

To create the coax:To create the coax:To create the coax:To create the coax:

1. Select the menu item Draw > CylinderDraw > CylinderDraw > CylinderDraw > Cylinder

2. Using the coordinate entry fields, enter the center position

X: 0.0: 0.0: 0.0: 0.0, Y: 0.0: 0.0: 0.0: 0.0, Z: 0.0,: 0.0,: 0.0,: 0.0, Press the EnterEnterEnterEnter key

4. Using the coordinate entry fields, enter the radius of the cylinder

dX: 0.0: 0.0: 0.0: 0.0, dY: 2.0: 2.0: 2.0: 2.0, dZ: 0: 0: 0: 0.0000, Press the EnterEnterEnterEnter key

5. Using the coordinate entry fields, enter the height of the cylinder

dX: 6.0: 6.0: 6.0: 6.0, dY: 0.0: 0.0: 0.0: 0.0 dZ: 0.0: 0.0: 0.0: 0.0,  Press the EnterEnterEnterEnter key 

To Parameterize the Height:To Parameterize the Height:To Parameterize the Height:To Parameterize the Height:

1. Select the CommandCommandCommandCommand tab from the PropertiesPropertiesPropertiesProperties window

2. Height: HHHH

3. Click the OKOKOKOK button

To set the name:To set the name:To set the name:To set the name:

1. Select the AttributeAttributeAttributeAttribute tab from the PropertiesPropertiesPropertiesProperties window.

2. For the ValueValueValueValue of NameNameNameName type: CoaxCoaxCoaxCoax

3. Click the OKOKOKOK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View
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Create ExcitationCreate ExcitationCreate ExcitationCreate Excitation

Face SelectionFace SelectionFace SelectionFace Selection

Select the menu item Edit > Select > FacesEdit > Select > FacesEdit > Select > FacesEdit > Select > Faces

By moving the mouse, graphically highlight the top face of the Coax object

Click the left mouse button to select the face

Assign ExcitationAssign ExcitationAssign ExcitationAssign Excitation

Select the menu item HFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave PortHFSS > Excitations > Assign > Wave Port

1. Wave Port : General

1. Name: p1p1p1p1

2. Click the NextNextNextNext button

2. Wave Port : Modes

1. Click the NextNextNextNext button

3. Wave Port : Post Processing 

1. Renormalize All Modes: � CheckedCheckedCheckedChecked

2. Full Port Impedance: 50 Ohm50 Ohm50 Ohm50 Ohm

4. Click the FinishFinishFinishFinish button
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Duplicate boundaries with geometryDuplicate boundaries with geometryDuplicate boundaries with geometryDuplicate boundaries with geometry

Works with all boundaries and excitations

1. Select the menu item Tools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS OptionsTools > Options > HFSS Options

2. HFSS Options Window:

1. Click the GeneralGeneralGeneralGeneral tab

Use Wizards for data entry when creating new boundaries: : : : � CheckedCheckedCheckedChecked

Duplicate boundaries with geometry: : : : � CheckedCheckedCheckedChecked

2. Click the OKOKOKOK button

Example: 

Assign an Excitation to the face of an object

Duplicate the object around an axis three times

The Excitation is automatically duplicated
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Set Object Selection Set Object Selection Set Object Selection Set Object Selection 

Set select to objectsSet select to objectsSet select to objectsSet select to objects

1. Select the menu item Edit > Select > ObjectsEdit > Select > ObjectsEdit > Select > ObjectsEdit > Select > Objects

Create TeeCreate TeeCreate TeeCreate Tee

To create Tee:To create Tee:To create Tee:To create Tee:

1. Select the menu item Edit > Select All VisibleEdit > Select All VisibleEdit > Select All VisibleEdit > Select All Visible.  .  .  .  Or press the CTRL+ACTRL+ACTRL+ACTRL+A key.

2. Select the menu item, Edit > Duplicate > Around AxisEdit > Duplicate > Around AxisEdit > Duplicate > Around AxisEdit > Duplicate > Around Axis.

1. Axis: ZZZZ

2. Angle: 90909090

3. Total Number: 3333

4. Click the OK OK OK OK button

To fit the view:To fit the view:To fit the view:To fit the view:

1. Select the menu item View > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active ViewView > Fit All > Active View.  .  .  .  
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Unite ConductorsUnite ConductorsUnite ConductorsUnite Conductors

Select ConductorsSelect ConductorsSelect ConductorsSelect Conductors

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Coax_PinCoax_PinCoax_PinCoax_Pin, Coax_Pin_1, Coax_Pin_2, Coax_Pin_1, Coax_Pin_2, Coax_Pin_1, Coax_Pin_2, Coax_Pin_1, Coax_Pin_2

2. Click the OK OK OK OK button

Unite Unite Unite Unite 

1. Select the menu item 3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite

Unite CoaxUnite CoaxUnite CoaxUnite Coax

Select CoaxSelect CoaxSelect CoaxSelect Coax

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: Coax, Coax_1, Coax_2Coax, Coax_1, Coax_2Coax, Coax_1, Coax_2Coax, Coax_1, Coax_2

2. Click the OK OK OK OK button

Unite Unite Unite Unite 

1. Select the menu item 3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite3D Modeler > Boolean > Unite
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HFSS - Solution Setup 

Creating an Analysis SetupCreating an Analysis SetupCreating an Analysis SetupCreating an Analysis Setup

To create an analysis setup:To create an analysis setup:To create an analysis setup:To create an analysis setup:

1. Select the menu item HFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution SetupHFSS > Analysis Setup > Add Solution Setup

2. Solution Setup Window:

1. Click the GeneralGeneralGeneralGeneral tab::::

Solution Frequency: 10.0 GHz: 10.0 GHz: 10.0 GHz: 10.0 GHz

2. Click the OKOKOKOK button

Picking the Adapt Frequency

See User Guide Chapter 2User Guide Chapter 2User Guide Chapter 2User Guide Chapter 2

Adapt Frequency

Add Solution SetupAdd Solution SetupAdd Solution SetupAdd Solution Setup
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Adding a Frequency SweepAdding a Frequency SweepAdding a Frequency SweepAdding a Frequency Sweep

To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:To add a frequency sweep:

1. Select the menu item HFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add SweepHFSS > Analysis Setup > Add Sweep

1. Select Solution Setup: Setup1 Setup1 Setup1 Setup1 

2. Click the OKOKOKOK button

2. Edit Sweep Window:

1. Sweep Type: Fast: Fast: Fast: Fast

2. Frequency Setup Type: Linear Step: Linear Step: Linear Step: Linear Step

Start: 1.0 GHz1.0 GHz1.0 GHz1.0 GHz

Stop: 10.0 GHz: 10.0 GHz: 10.0 GHz: 10.0 GHz

Step: 0.1 GHz: 0.1 GHz: 0.1 GHz: 0.1 GHz

Save Fields: � CheckedCheckedCheckedChecked

3. Click the OKOKOKOK button

HFSS – Frequency Sweep 
Discrete Discrete Discrete Discrete – Solves using adaptive mesh at every frequency

Matrix Data and Fields at every frequency in sweep

Fast Fast Fast Fast - ALPS

Matrix Data and Fields at every frequency in sweep

Interpolating Interpolating Interpolating Interpolating – Adaptively determines discrete solve
points using the adaptive mesh

Matrix Data at every frequency in sweeps

Fields at last adaptive solution

Add SweepAdd SweepAdd SweepAdd Sweep
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Save ProjectSave ProjectSave ProjectSave Project

To save the project:To save the project:To save the project:To save the project:

1. In an  Ansoft HFSS window, select the menu item File > Save AsFile > Save AsFile > Save AsFile > Save As.

2. From the Save As Save As Save As Save As window, type the Filename: hfss_coax_teehfss_coax_teehfss_coax_teehfss_coax_tee

3. Click the SaveSaveSaveSave button

Analyze

Model ValidationModel ValidationModel ValidationModel Validation

To validate the model:To validate the model:To validate the model:To validate the model:

1. Select the menu item HFSS > Validation CheckHFSS > Validation CheckHFSS > Validation CheckHFSS > Validation Check

2. Click the Close Close Close Close button

Note:Note:Note:Note: To view any errors or warning messages, use the Message Manager.

AnalyzeAnalyzeAnalyzeAnalyze

To start the solution process:To start the solution process:To start the solution process:To start the solution process:

1. Select the menu item HFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze AllHFSS > Analyze All

ValidateValidateValidateValidate Analyze AllAnalyze AllAnalyze AllAnalyze All
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Create ReportsCreate ReportsCreate ReportsCreate Reports

To create a report:To create a report:To create a report:To create a report:

1. Select the menu item HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

2. Create Report Window::::

1. Report Type: Modal S ParametersModal S ParametersModal S ParametersModal S Parameters

2. Display Type: RectangularRectangularRectangularRectangular

3. Click the OK OK OK OK button

3. Traces Window::::

1. Solution: Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1Setup1: Sweep1

2. Domain: SweepSweepSweepSweep

3. Click the YYYY tab

1. Category: Terminal S ParameterTerminal S ParameterTerminal S ParameterTerminal S Parameter

2. Quantity: S(p1,p1), S(p1,p2), S(p2,p3)S(p1,p1), S(p1,p2), S(p2,p3)S(p1,p1), S(p1,p2), S(p2,p3)S(p1,p1), S(p1,p2), S(p2,p3)

3. Function: dBdBdBdB

4. Click the Add TraceAdd TraceAdd TraceAdd Trace button

4. Click the DoneDoneDoneDone button
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Field OverlaysField OverlaysField OverlaysField Overlays
To create a field plot:To create a field plot:To create a field plot:To create a field plot:

1. Select an object to overlay fields

1. Select the menu item Edit > Select > By NameEdit > Select > By NameEdit > Select > By NameEdit > Select > By Name

2. Select Object Dialog, 

1. Select the objects named: CoaxCoaxCoaxCoax

2. Click the OK OK OK OK button

2. Select the menu item HFSS > Fields > HFSS > Fields > HFSS > Fields > HFSS > Fields > FieldsFieldsFieldsFields > E > > E > > E > > E > Mag_EMag_EMag_EMag_E

3. Create Field Plot Window

1. Solution: Setup1 :  Setup1 :  Setup1 :  Setup1 :  LastAdaptiveLastAdaptiveLastAdaptiveLastAdaptive

2. Quantity: Mag_EMag_EMag_EMag_E

3. In Volume: AllAllAllAll

4. Click the DoneDoneDoneDone button

To modify the attributes of a field plot:To modify the attributes of a field plot:To modify the attributes of a field plot:To modify the attributes of a field plot:

1. Select the menu item HFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot AttributesHFSS > Fields >  Modify Plot Attributes

2. Select Plot Folder Window:

1. Select: E FieldE FieldE FieldE Field

2. Click the OKOKOKOK button

3. E-Field Window:

1. Click the Scale Scale Scale Scale tab

1. Select Use LimitsUse LimitsUse LimitsUse Limits

2. Min: 5555

3. Max: 25000250002500025000

4. Scale: LogLogLogLog

2. Click the PlotPlotPlotPlot tab

1. IsoValType: IsoValSurfaceIsoValSurfaceIsoValSurfaceIsoValSurface

2. Click the ApplyApplyApplyApply button.

4. Click the CloseCloseCloseClose button



Ansoft High Frequency Structure Simulator v10 – Training Seminar P1-26

Overview
Presentation

1

What is HFSS?
HFSS HFSS HFSS HFSS –––– High Frequency Structure SimulatorHigh Frequency Structure SimulatorHigh Frequency Structure SimulatorHigh Frequency Structure Simulator

Arbitrary 3D Volumetric Full-Wave Field Solver

Ansoft DesktopAnsoft DesktopAnsoft DesktopAnsoft Desktop

Advanced ACIS based Modeling

True Parametric Technology – Dynamic Editing

Powerful Report Generation

Dynamic Field Visualization

Design Flow Automation

Optimetrics/Ansoft Designer/AnsoftLinks

Advanced Material TypesAdvanced Material TypesAdvanced Material TypesAdvanced Material Types

Frequency Dependent Materials

Non-linear Materials

Anisotropic Materials

Advanced Boundary ConditionsAdvanced Boundary ConditionsAdvanced Boundary ConditionsAdvanced Boundary Conditions

Radiation and Perfectly Matched Layers

Symmetry, Finite Conductivity, Infinite Planes, RLC, and Layered Impedance

Master/Slave – Unit Cells

Advanced Solver TechnologyAdvanced Solver TechnologyAdvanced Solver TechnologyAdvanced Solver Technology

Automatic Conformal Mesh Generation

Adaptive Mesh Generation

Internal/External Excitations – Includes Loss

ALPS Fast Frequency Sweep

Eigenmode
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Common HFSS Applications

AntennaAntennaAntennaAntenna

Planar Antennas - Patches, Dipoles, Horns, Conformal Cell Phone Antennas, Spirals

Waveguide – Circular/Square Horns

Wire – Dipole, Helix

Arrays - Infinite Arrays, Frequency Selective Surfaces (FSS) & Photonic Band Gaps (PBG)

Radar Cross Section (RCS)

MicrowaveMicrowaveMicrowaveMicrowave

Filters – Cavity Filters, Microstrip, Dielectric

EMC/EMI – Shield Enclosures, Coupling, Near- or Far-Field Radiation

Connectors – Coax, SFP/XFP, Backplane, Transitions

Waveguide – Filters, Resonators, Transitions, Couplers

Silicon/GaSa - Spiral Inductors, Transformers

Signal Integrity/HighSignal Integrity/HighSignal Integrity/HighSignal Integrity/High----Speed DigitalSpeed DigitalSpeed DigitalSpeed Digital

Package Modeling – BGA, QFP, Flip-Chip

PCB Board Modeling – Power/Ground planes, Mesh Grid Grounds, Backplanes

Connectors – SFP/XFP, VHDM, GBX, NexLev, Coax

Transitions – Differential/Single-ended Vias
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What Information does HFSS Compute?

Matrix DataMatrix DataMatrix DataMatrix Data

Modal/Terminal/Differential

S-, Y-, and Z-Parameters

VSWR

Excitations

Complex Propagation Constant (Gamma)

Zo

Full-Wave Spice

Full-Wave Spice – Broadband Model

Lumped RLC – Low Frequency Model

Partial Fraction - Matlab

Export Formats – HSPICE, PSPICE, Cadence Spectre, and Maxwell SPICE

Common Display Formats:

Rectangular, Polar

Smith Chart

Data Tables

Common Output Formats:

Neutral Models Files (NMF) (Optimetrics only) 

Parametric Results

Touchstone, Data Tables, Matlab, 

Citifile

Graphics – Windows Clipboard
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What Information does HFSS Compute? (Continued)
FieldsFieldsFieldsFields

Modal/Terminal/Differential

Electric Field

Magnetic Field

Current (Volume/Surface)

Power

Specific Absorption Rate

Radiation

2D/3D Far-/Near-Fields

Arrays – Regular and Custom Setups

RCS

Field Calculator

User Defined Field Calculations

Common Display Formats

Volume

Surface

Vector

2D Reports – Rectangular, Polar, Radiation Patterns

Common Output Formats:

Animations – AVI, GIF

Data Tables

Graphics – Windows Clipboard, BMP, GIF, JPG, TIFF, VRML
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What is the Technology Behind the HFSS Field Solver?

Volumetric Field SolverVolumetric Field SolverVolumetric Field SolverVolumetric Field Solver

Type: FullFullFullFull----WaveWaveWaveWave

Solution Method: 3D Finite Element Method (FEM)3D Finite Element Method (FEM)3D Finite Element Method (FEM)3D Finite Element Method (FEM)

AccuracyAccuracyAccuracyAccuracy:  If there were no limits on the size of the matrix and on the number of digits 
for computation, there would be no limit to the accuracy of the Finite Element Method!

Mesh Type: ConformalConformalConformalConformal

Mesh Element: TetrahedronTetrahedronTetrahedronTetrahedron

Mesh Process: Adaptive Adaptive Adaptive Adaptive 

Convergence: Complex Magnitude Complex Magnitude Complex Magnitude Complex Magnitude 
Change in SChange in SChange in SChange in S----Parameters (Delta S)Parameters (Delta S)Parameters (Delta S)Parameters (Delta S)

Excitations Excitations Excitations Excitations ---- Port SolverPort SolverPort SolverPort Solver

Solution Method: 2D Finite Element Method2D Finite Element Method2D Finite Element Method2D Finite Element Method

Mesh Process: AdaptiveAdaptiveAdaptiveAdaptive

Frequency SweepsFrequency SweepsFrequency SweepsFrequency Sweeps

Fast Frequency Sweep: ALPS

Matrix Data and Fields at every frequency in sweep

Supports sweeps as large as 10000 data points from a single solution.

Interpolating Sweep

Adaptive Discrete Sweep with curve fitting

Supports sweeps as large as 10000 data points.  Number of discrete solution 
points varies with response. 

VertexVertexVertexVertex: Explicitly Solved

EdgeEdgeEdgeEdge: Explicitly Solved

FaceFaceFaceFace: Interpolated
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Adaptive Mesh RefinementAdaptive Mesh RefinementAdaptive Mesh RefinementAdaptive Mesh Refinement automatically 
tunes the mesh to the electrical 
performance of the device.  This ensures 
simulations are correct the first time.

Mesh ConvergenceMesh ConvergenceMesh ConvergenceMesh Convergence:  Real-Time update of  
performance per adaptive solution. 

Matrix Data

Fields 

Adaptive RefinementAdaptive RefinementAdaptive RefinementAdaptive Refinement

Initial MeshInitial MeshInitial MeshInitial Mesh
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The Process

DesignDesignDesignDesign

Solution TypeSolution TypeSolution TypeSolution Type

1.1. Boundaries1.1. Boundaries1.1. Boundaries1.1. Boundaries

1.2. Excitations1.2. Excitations1.2. Excitations1.2. Excitations

4.1 Mesh 4.1 Mesh 4.1 Mesh 4.1 Mesh 
OperationsOperationsOperationsOperations

2. Analysis2. Analysis2. Analysis2. Analysis
Solution Setup

Frequency Sweep

1. Parametric Model1. Parametric Model1. Parametric Model1. Parametric Model
Geometry/Materials

3. Results3. Results3. Results3. Results
2D Reports

Fields

MeshMeshMeshMesh
RefinementRefinementRefinementRefinement

SolveSolveSolveSolve

UpdateUpdateUpdateUpdate

ConvergedConvergedConvergedConverged

AnalyzeAnalyzeAnalyzeAnalyze

FinishedFinishedFinishedFinished

4. Solve Loop4. Solve Loop4. Solve Loop4. Solve Loop

NONONONO

YESYESYESYES
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Frequency SweepFrequency SweepFrequency SweepFrequency Sweep
YESYESYESYES

Initial Solution

Adaptive Mesh Loop

No Adaptive MeshingNo Adaptive MeshingNo Adaptive MeshingNo Adaptive Meshing

Ports Only &Ports Only &Ports Only &Ports Only &

Frequency SweepFrequency SweepFrequency SweepFrequency Sweep

Initial MeshInitial MeshInitial MeshInitial Mesh
Seeding andSeeding andSeeding andSeeding and

Lambda RefinementLambda RefinementLambda RefinementLambda Refinement
(Single Frequency)(Single Frequency)(Single Frequency)(Single Frequency)

Port SolutionPort SolutionPort SolutionPort Solution
(Adaptive)(Adaptive)(Adaptive)(Adaptive)

Full Volumetric SolutionFull Volumetric SolutionFull Volumetric SolutionFull Volumetric Solution
(S(S(S(S----Parameters/EParameters/EParameters/EParameters/E----Fields)Fields)Fields)Fields)

Refine Mesh Refine Mesh Refine Mesh Refine Mesh 
(Gradient of E(Gradient of E(Gradient of E(Gradient of E----Field Field Field Field 
at Single Frequency)at Single Frequency)at Single Frequency)at Single Frequency)

Full Volumetric SolutionFull Volumetric SolutionFull Volumetric SolutionFull Volumetric Solution
(S(S(S(S----Parameters/EParameters/EParameters/EParameters/E----Fields)Fields)Fields)Fields)

Check ConvergenceCheck ConvergenceCheck ConvergenceCheck Convergence
(Delta S)(Delta S)(Delta S)(Delta S)

NoNoNoNo
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3D Modeler – Model Tree
Select menu item 3D Modeler > Group by Material3D Modeler > Group by Material3D Modeler > Group by Material3D Modeler > Group by Material

Grouped by MaterialGrouped by MaterialGrouped by MaterialGrouped by Material Object ViewObject ViewObject ViewObject View

Material

Object

Object Command History
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3D Modeler – Commands
Parametric Technology

Dynamic Edits - Change Dimensions

Add Variables

Project Variables (Global) or Design Variables (Local)

Animate Geometry

Include Units – Default Unit is meters

Supports mixed Units
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3D Modeler – Primitives
2D Draw Objects2D Draw Objects2D Draw Objects2D Draw Objects

The following 2D Draw objects are available:

Line, Spline, Arc, Equation Based Curve,

Rectangle, Ellipse, Circle, Regular Polygon, 

Equation Based Surface

3D Draw Objects3D Draw Objects3D Draw Objects3D Draw Objects

The following 3D Draw objects are available:

Box, Cylinder, Regular Polyhedron 

Cone, Sphere, Torus, Helix, Spiral, Bond 

Wire

Toolbar:Toolbar:Toolbar:Toolbar: 2D Objects Toolbar:Toolbar:Toolbar:Toolbar: 3D Objects
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Splitting versus Subtracting objects 
Two or more true surface objects overlapping

Perform Split of objects for Meshing purposes

1. Move coordinate system to a desired position

2. Select multiple objects to split

3. Select 3D Modeler > Boolean > Split3D Modeler > Boolean > Split3D Modeler > Boolean > Split3D Modeler > Boolean > Split

4. Select desired split plane and Both sets of objects to keep.

No need to Copy->Subtract->Paste

Original Model 

(overlaps between two cylinders)

Recommended approach

Relative CS
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3D Modeler – Boolean Operations/Transformations
3D Modeler > Boolean >3D Modeler > Boolean >3D Modeler > Boolean >3D Modeler > Boolean >

UniteUniteUniteUnite – combine multiple primitives

Unite disjoint objects (Separate BodiesSeparate BodiesSeparate BodiesSeparate Bodies to separate)

SubtractSubtractSubtractSubtract – remove part of a primitive from another

IntersectIntersectIntersectIntersect– keep only the parts of primitives that overlap

SplitSplitSplitSplit – break primitives into multiple parts along a plane (XY, YZ, XZ)

Split Crossing Objects Split Crossing Objects Split Crossing Objects Split Crossing Objects –––– splits objects along a plane (XY, YZ, XZ) only where they intersect

Separate Bodies Separate Bodies Separate Bodies Separate Bodies –––– separates objects which are united but not physically connected into individual 
objects

3D Modeler > Surfaces > Move Faces3D Modeler > Surfaces > Move Faces3D Modeler > Surfaces > Move Faces3D Modeler > Surfaces > Move Faces – Resize or Reposition an objects face along a normal or vector.

Edit > Arrange >Edit > Arrange >Edit > Arrange >Edit > Arrange >

Move Move Move Move –––– Translates the structure along a vector

Rotate Rotate Rotate Rotate –––– Rotates the shape around a coordinate axis by an angle

Mirror Mirror Mirror Mirror –––– Mirrors the shape around a specified plane

Offset Offset Offset Offset –––– Performs a uniform scale in x, y, and z.

Edit > Duplicate >Edit > Duplicate >Edit > Duplicate >Edit > Duplicate >

Along Line Along Line Along Line Along Line –––– Create multiple copies of an object along a vector

Around Axis Around Axis Around Axis Around Axis –––– Create multiple copies of an object rotated by a fixed angle around the x, y, or z axis

Mirror Mirror Mirror Mirror ---- Mirrors the shape around a specified plane and creates a duplicate

Edit > Scale Edit > Scale Edit > Scale Edit > Scale –––– Allows non-uniform scaling in the x, y, or z direction

Toolbar:Toolbar:Toolbar:Toolbar: Boolean

Toolbar:Toolbar:Toolbar:Toolbar: Arrange

Toolbar:Toolbar:Toolbar:Toolbar: Duplicate
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3D Modeler - Selection

Selection TypesSelection TypesSelection TypesSelection Types

Object (Default)Object (Default)Object (Default)Object (Default)

FaceFaceFaceFace

EdgeEdgeEdgeEdge

VertexVertexVertexVertex

Selection ModesSelection ModesSelection ModesSelection Modes

All ObjectsAll ObjectsAll ObjectsAll Objects

All Visible ObjectAll Visible ObjectAll Visible ObjectAll Visible Object

By NameBy NameBy NameBy Name

Highlight Selection DynamicallyHighlight Selection DynamicallyHighlight Selection DynamicallyHighlight Selection Dynamically –––– By default, moving the mouse pointer over an object will dynamically 

highlight the object for selection.  To select the object simply click the left mouse button.

Multiple Object SelectionMultiple Object SelectionMultiple Object SelectionMultiple Object Selection – Hold the CTRLCTRLCTRLCTRL key down to graphically select multiple objects

Next BehindNext BehindNext BehindNext Behind – To select an object located behind another object, select the front object, press the bbbb key to get 
the next behind.  Note:  The mouse pointer must be located such that the next behind object is under the 

mouse pointer.

To Disable:  To Disable:  To Disable:  To Disable:  Select the menu item Tools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler OptionsTools > Options > 3D Modeler Options

From the Display TabDisplay TabDisplay TabDisplay Tab, uncheck Highlight selection dynamicallyHighlight selection dynamicallyHighlight selection dynamicallyHighlight selection dynamically

Dynamically Highlighted

(Only frame of object)

Selected
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3D Modeler – Moving Around

Step 1: Start Point Step 2: Hold X key and select vertex point

Step 3: CTRL+Enter Keys set a local reference Step 4: Hold Z key and set height

Edge Center Snap

Toolbar:Toolbar:Toolbar:Toolbar: Snap Mode
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3D Modeler – Coordinate System
Can be Parameterized

Working Coordinate SystemWorking Coordinate SystemWorking Coordinate SystemWorking Coordinate System

Currently selected CS.  This can be a local or global CS

Global CSGlobal CSGlobal CSGlobal CS

The default fixed coordinate system

RelativeRelativeRelativeRelative CSCSCSCS

User defined local coordinate system.

Offset

Rotated

Both

FaceFaceFaceFace CSCSCSCS (setting available to automatically switch to face coordinate system in the 3D Modeler Options)

Step 1: Select Face Step 2: Select Origin

Step 3: Set X-Axis New Working CS

Cone created with Face CS

Change Box Size and Cone is 

automatically positioned with 

the top face of the box

Toolbar:Toolbar:Toolbar:Toolbar: Coordinate System
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HFSS – Matrix Data
HFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution DataHFSS > Results > Solution Data

Export

NMF, Touchstone, Data Tables, Citifile, MATLAB (*.m) 

NOTENOTENOTENOTE:  Make sure the Simulation is set to a Sweep before exporting. The Adaptive Passes will only export a 
single frequency point.

Equivalent Circuit Export

HSPICE, PSPICE, Spectre, Maxwell SPICE
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Results – Data Management
HFSS > Results > Browse SolutionsHFSS > Results > Browse SolutionsHFSS > Results > Browse SolutionsHFSS > Results > Browse Solutions

Solved model variations are retained.  

Unless otherwise notified by HFSS.

HFSS > Results > Clean Up SolutionsHFSS > Results > Clean Up SolutionsHFSS > Results > Clean Up SolutionsHFSS > Results > Clean Up Solutions

HFSS > Results > Import SolutionsHFSS > Results > Import SolutionsHFSS > Results > Import SolutionsHFSS > Results > Import Solutions
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Results – Create Reports
HFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create ReportHFSS > Results > Create Report

Output Variables

User Defined Equations
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Fields
Select Object Volume, Surface, or Line to display fields

HFSS > Fields > Plot Fields >HFSS > Fields > Plot Fields >HFSS > Fields > Plot Fields >HFSS > Fields > Plot Fields >

Modify Plot – Solution/Frequency/Qty

Plot Attributes

Edit Sources – Change Excitation
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Mesh Display
Field Overlay

1. Select an object

2. Select the menu item HFSS > Fields > Plot MeshHFSS > Fields > Plot MeshHFSS > Fields > Plot MeshHFSS > Fields > Plot Mesh
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Menu Structure
DrawDrawDrawDraw – Primitives

3D Modeler3D Modeler3D Modeler3D Modeler – Settings and Boolean Operations

EditEditEditEdit – Arrange, Duplicate

HFSSHFSSHFSSHFSS – Boundaries, Excitations, Mesh Operations, Analysis Setup, Results



Ansoft High Frequency Structure Simulator v10 – Training Seminar P1-48

Overview
Presentation

1

Measure 
3D Modeler > Measure >3D Modeler > Measure >3D Modeler > Measure >3D Modeler > Measure >

PositionPositionPositionPosition – Points and Distance

LengthLengthLengthLength – Edge Length

AreaAreaAreaArea – Surface Area

VolumeVolumeVolumeVolume – Object Volume

Position PointsPosition PointsPosition PointsPosition Points
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Options – General
Tools > Options > General OptionsTools > Options > General OptionsTools > Options > General OptionsTools > Options > General Options

Temp DirectoryTemp DirectoryTemp DirectoryTemp Directory – Location used during solution process

Make sure it is  at least 512MB free disk.

Options - HFSS
Tools > Options >  HFSS Options > SolverTools > Options >  HFSS Options > SolverTools > Options >  HFSS Options > SolverTools > Options >  HFSS Options > Solver

Number of Processors – Requires additional license

Desired RAM Limit – leave it unchecked for auto-detect

Maximum RAM Limit – leave it unchecked for auto-detect

Process Priority – set the simulation priority from Critical

(highest) to Idle (lowest)
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Converting Older HFSS Projects (pre-HFSS v9) to HFSS v10
From HFSS v10.0From HFSS v10.0From HFSS v10.0From HFSS v10.0, 

1. Select the menu item File > OpenFile > OpenFile > OpenFile > Open

2. Open dialog

1. Files of Type:  Ansoft Legacy EM Projects (.Ansoft Legacy EM Projects (.Ansoft Legacy EM Projects (.Ansoft Legacy EM Projects (.clsclsclscls))))

2. Browse to the existing project and select the .cls file

3. Click the OpenOpenOpenOpen button

What is Converted?What is Converted?What is Converted?What is Converted?

Converts Entire Model: Geometry, Materials, Boundaries,

Sources and Setup

Solutions, Optimetrics projects and Macros are not converted

Legacy License
Existing customers using HFSS v9.2.1 should have received legacy licenses with the new v10.0 licenses.  

These licenses allow you to run either v10.0 or v9.2.1

Contact your Account Manager if this feature is not available

NOTE:NOTE:NOTE:NOTE: Once a project is saved in v10 it can no longer be opened in v9
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HFSS v10 Enhancements

From import of complex solid models to HFSS analysis is a multi-stage process, each step of which 

plays an important role

import import import import ���� healing healing healing healing ���� meshing meshing meshing meshing ���� model resolution model resolution model resolution model resolution ���� analysisanalysisanalysisanalysis

Applications Include:

Complex Connectors 

High-Speed PCBs

Microwave Devices
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HFSS v10 Enhancements  

Healing GeometryHealing GeometryHealing GeometryHealing Geometry

Key Edit Features

Auto/Manual Import Healing 

3D Model Analysis – 3D Modeler/Analyze

Face, Object , Area analysis based on user inputs

List of problems (faces, edges, vertices)

Auto Zoom In into region where problem exists

Remove Face

Remove Edge

Remove Sliver

Remove Vertices
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HFSS v10 Enhancements 
Improved Mesh Generation

Significantly improved mesh generation algorithms
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HFSS v10 Enhancements
Model Resolution

Mesh beforeMesh beforeMesh beforeMesh before:

184,675 tets

Mesh after:Mesh after:Mesh after:Mesh after:

24,691 tets

Length=0.1 mmLength=0.1 mmLength=0.1 mmLength=0.1 mm
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HFSS v10 Enhancements
New dynamic links with HFSS and between Designer/Nexxim and SIWave

New incident wave: Spherical, cylindrical, line dipole, Gaussian beam, etc
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HFSS v10 Enhancements
Distributed Analysis

1) The graphical user interface enables users to select 

computer addresses for analysis distribution

2) Automated parser management and reassembly of data

3) Parametric tables and studies

4) Frequency sweeps for discrete, fast, and interpolating

5) Per license, distributed analysis allows up to 10 parallel 

simulations on remote machines, providing near-linear 

reduction of simulation run times
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Recommended Service Packs (SP) – PC only
Microsoft Windows XP  - SP2 or higher

Microsoft Windows 2000 – SP4 or higher

Updating Drivers
Update your DirectX drivers to ver9.0c 

http://www.microsoft.com/directx

Update your video drivers to the latest available from the card manufacturer

Memory allocation HFSS v9.2
With the release of HFSS v9.2 you can access sup to 3GB of Ram on PC 

All about 3GB switch, supported OS

http://support.microsoft.com/default.aspx?scid=kb;en-us;291988

How to use /3GB switch

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/ddtools/hh/ddtools/bootini_1fcj.asp

Possible problems

http://support.microsoft.com/default.aspx?scid=kb;en-us;328269

Increasing Memory allocation HFSS v10
With the release of HFSS v10 on a 64bit operating system theoretically there is no RAM limitation

Practically you can access up to 32GB of RAM due to hardware limitations
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Unix Operating Systems
HPUX 11.0

Solaris 2.8 and 2.9

Note: Requires OpenGL

Note: Please perform required OS updates outlined in readme file on the CD

Common Desktop (CDE) 
There is an issue with HFSS dialog boxes moving behind the main window.  The following instructions describe 

how to prevent this:

Select Tools > Desktop ControlsTools > Desktop ControlsTools > Desktop ControlsTools > Desktop Controls

Select Window Style ManagerWindow Style ManagerWindow Style ManagerWindow Style Manager

From the Style Manager – Window

Uncheck Allow Primary Windows on TopAllow Primary Windows on TopAllow Primary Windows on TopAllow Primary Windows on Top
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Project Files
Everything regarding the project is stored in an ascii file

File: <<<<project_nameproject_nameproject_nameproject_name>.>.>.>.hfsshfsshfsshfss

Double click from Windows Explorer will open and launch HFSS v10

Results and Mesh are stored in a folder named <<<<project_nameproject_nameproject_nameproject_name>.>.>.>.hfssresultshfssresultshfssresultshfssresults

Lock file: <<<<project_nameproject_nameproject_nameproject_name>.>.>.>.lock.hfsslock.hfsslock.hfsslock.hfss

Created when a project is opened

Auto Save File: <<<<project_nameproject_nameproject_nameproject_name>.>.>.>.hfss.autohfss.autohfss.autohfss.auto

When recovering, software only checks date

If an error occurred when saving the auto file, the date will be newer then the original  

Look at file size (provided in recover dialog)

Scripts
Default Script recorded in v10

Visual Basic Script

Remote Solve (Windows Only)
Tools > Options > General Options >Tools > Options > General Options >Tools > Options > General Options >Tools > Options > General Options >

Analysis OptionsAnalysis OptionsAnalysis OptionsAnalysis Options

Uses DCOM
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Ansoft Designer SV
Ansoft Designer™ SV is a full-featured subset of Ansoft's commercially distributed Ansoft Designer 

Ansoft Designer SV contains a complete high-frequency linear circuit simulator, schematic and layout design entry, 

powerful design utilities, and post-processing, all integrated in an easy-to-use environment. The software also 

includes a complete set of linear distributed transmission line models, discontinuities, vendor component parts, and 

ideal circuit elements. 

Ansoft Designer SV allows the simulation of S-, Y-, and Z-parameters, group delay, noise figure, and stability 

circles of RF and microwave circuits. Utilities include real-time tuning, filter and TRL synthesis, and Smith Tool 

matching. Post-processing includes rectangular plots, Smith Charts, polar plots, and data tables. Additionally, 

Ansoft Designer SV comes with a set of real-world examples. 

Free DownloadFree DownloadFree DownloadFree Download: www.ansoft.com/ansoftdesignersv
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For Technical Support
The following link will direct you to the Ansoft Support Page.  The Ansoft Support Pages provide additional 

documentation, training, and application notes. Web Site: http://www.ansoft.com/support.cfm

Application Engineers for North America
The names and numbers in this list may change without notice

9-4 EST: 

Pittsburgh, PAPittsburgh, PAPittsburgh, PAPittsburgh, PA

(412) 261-3200 x0 – Ask for Technical Support

Burlington, MABurlington, MABurlington, MABurlington, MA

(781) 229-8900 x0 – Ask for Technical Support 

9-4 PST: 

San Jose, CA San Jose, CA San Jose, CA San Jose, CA 

(408) 261-9095 x0 – Ask for Technical Support

Portland, ORPortland, ORPortland, ORPortland, OR

(503) 906-7944 or (503) 906-7947 

El Segundo, CAEl Segundo, CAEl Segundo, CAEl Segundo, CA

(310) 426-2287 – Ask for Technical Support
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Why are They Critical?

For most practical problems, the solution to Maxwell’s equations requires a 
rigorous matrix approach such as the Finite Element Method (FEM) which 
is used by Ansoft HFSS.

The wave equation solved by Ansoft HFSS is derived from the 
differential form of Maxwell’s equations.

For these expressions to be valid, it is assumed that the field vectors are:

single-valued, 

bounded, and have a

continuous distribution (along with their derivatives)

Along boundaries of media or at sources, 

Field vectors are discontinuous

Derivatives of the field vectors have no meaning

0=⋅∇
=⋅∇

∂
∂+=×∇

∂
∂−=×∇

B

D
t

D
JH

t

B
E

ρ

Boundary Conditions define the field behavior across discontinuous boundaries
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Why do I Care?

They Force the fields to align with the definition of the boundary condition

As a user I should be asking

What assumptions, about the fields, do the boundary conditions make?

Are these assumptions appropriate for the structure being simulated?

Model Scope

To reduce the infinite space of the real world to a finite volume, Ansoft HFSS automatically 
applies a boundary to the surface surrounding the geometric model

Outer boundary

Default Boundary: Perfect E

Model Complexity

To reduce the complexity of a model, the boundary conditions can be used to improve the:

Solution Time

Computer Resources

Failure to understand boundary conditions may lead to inconsistent results
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What are Common Ansoft HFSS Boundary Conditions?

Excitations

Wave Ports (External) 

Lumped Ports (Internal)

Surface Approximations

Perfect E or Perfect H Surface

Finite Conductivity Surface

Impedance Surface

Symmetry Planes

Radiation Surface

Material Properties

Boundary between two dielectrics

Finite Conductivity of a conductor

Largely the users responsibility

Transparent to the user
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Surface Approximations

Perfect EPerfect EPerfect EPerfect E – Forces the electric field perpendicular to the surface

Outer Surface – Default Boundary

PEC/Perfect Conductor Material Property

Model complexity: Reduced by eliminating conductor loss

Perfect HPerfect HPerfect HPerfect H – Forces the electric field tangent to the surface

Finite ConductivityFinite ConductivityFinite ConductivityFinite Conductivity – Lossy electric conductor.

Forces the tangential electric field at the surface to: Zs(n x Htan).

The surface impedance (Zs) is equal to, (1+j)/(δσ),
Model complexity: Reduced by eliminating conductor thickness

Impedance SurfaceImpedance SurfaceImpedance SurfaceImpedance Surface – Represent surfaces of a known impedance 

Forces the tangential electric field at the surface to: Zs(n x Htan).

The surface impedance (Zs) is equal to, Rs + jXs (Ohms/Square)

Layered ImpedanceLayered ImpedanceLayered ImpedanceLayered Impedance – Models multiple thin layers in a structure as an Impedance Surface

Lumped RLCLumped RLCLumped RLCLumped RLC – Parallel combination

Perfect E SurfacePerfect E SurfacePerfect E SurfacePerfect E Surface

Perfect H Surface
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Surface Approximations (Continued)

Symmetry PlanesSymmetry PlanesSymmetry PlanesSymmetry Planes – Enable you to model only part of a structure 

Perfect E or Perfect H Symmetry Planes

Must be exposed to the outer surface

Must be on a planar surface

Remember! Mechanical Symmetry does not Equal Electrical SymmetryRemember! Mechanical Symmetry does not Equal Electrical SymmetryRemember! Mechanical Symmetry does not Equal Electrical SymmetryRemember! Mechanical Symmetry does not Equal Electrical Symmetry

Model complexity: Reduced by eliminating part of the solution volume

Full ModelFull ModelFull ModelFull Model

Perfect E SymmetryPerfect E SymmetryPerfect E SymmetryPerfect E Symmetry

Perfect H SymmetryPerfect H SymmetryPerfect H SymmetryPerfect H Symmetry
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Surface Approximations (Continued)

Radiation SurfaceRadiation SurfaceRadiation SurfaceRadiation Surface – Allows waves to radiate infinitely far into space.  

The boundary absorbs wave at the radiation surface

Can be placed on arbitrary surfaces

Accuracy depends on

The distance between the boundary and the radiating object

The radiation boundary should be located at least one-quarter of a wavelength 
from a radiating structure.  If you are simulating a structure that does not radiate, 
the boundary can be located less then one-quarter of a wave length (The validity 
of this assumption will require your engineering judgment).

The incident angle

The radiation boundary will reflect varying amounts of energy depending on the 
incidence angle.  The best performance is achieved at normal incidence.  Avoid 
angles greater then ~30degrees.  In addition, the radiation boundary must remain 
convex relative to the wave.

Perfectly Matched Layer (PML)Perfectly Matched Layer (PML)Perfectly Matched Layer (PML)Perfectly Matched Layer (PML) – Allows waves to radiate infinitely far into space.  

Not a Boundary Condition.  Fictitious materials that fully absorb the electromagnetic fields 
impinging upon them. These materials are complex anisotropic.

Types

Free Space Termination or Reflection Free Termination

Can only be placed on planar surface

Model complexity:  They do not suffer from the distance or incident angle problems of 
Radiation boundaries but should be place at least one-tenth of a wave length from 
strong radiators
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Surface Approximations (Continued)

Infinite GroundInfinite GroundInfinite GroundInfinite Ground PlanesPlanesPlanesPlanes – Simulate the effects of an infinite ground plane

Only affects the calculation of near- or far-field radiation during post processing

Types: Perfect E, Finite Conductivity,  or Impedance Surface

Frequency Dependent Boundary ConditionsFrequency Dependent Boundary ConditionsFrequency Dependent Boundary ConditionsFrequency Dependent Boundary Conditions

The following boundary parameters can be assigned an expression that includes Freq: 

Finite Conductivity

Impedance

Lumped RLC

Layered Impedance

Supported Frequency Sweeps

Single Frequency

Discrete Sweep

Interpolating Sweep
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Port 1

Port 2
Port 3

Port 4

Excitations

Ports are a unique type of boundary condition 

Allow energy to flow into and out of a structure.

Defined on 2D planar surface

Arbitrary port solver calculates the natural field patterns or modes 

Assumes semi-infinitely long waveguide

Same cross-section and material properties as port surface

2D field patterns serve as boundary conditions for the full 3D problem

Excitation TypesExcitation TypesExcitation TypesExcitation Types

Wave Port (Waveguide) – External

Recommended only for surfaces exposed to the background

Supports multiple modes (Example: Coupled Lines) and deembedding

Compute Generalized S-Parameters

Frequency dependent Characteristic Impedance (Zo)

Perfectly matched at every frequency

Lumped Port – Internal

Recommended only for surfaces internal to geometric model

Single mode (TEM) and no deembedding

Normalized to a constant user defined Zo

MeasurementsMeasurementsMeasurementsMeasurements

Constant Constant Constant Constant ZoZoZoZo
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Excitations (Continued)

Wave EquationWave EquationWave EquationWave Equation

The field pattern of a traveling wave inside a waveguide can be determined by solving 
Maxwell’s equations.  The following equation that is solved by the 2D solver is derived directly 
from Maxwell’s equation.

where:

EEEE(x,y) is a phasor representing an oscillating electric field.

k0 is the free space wave number, 

µr is the complex relative permeability.

εr is the complex relative permittivity.

To solve this equation, the 2D solver obtains an excitation field pattern in the form of a phasor
solution, EEEE(x,y). These phasor solutions are independent of z and t; only after being multiplied 
by e-γz do they become traveling waves.  

Also note that the excitation field pattern computed is valid only at a single frequency. A 
different excitation field pattern is computed for each frequency point of interest.

( ) 0),(,
1 2

0 =−







×∇×∇ yxEkyxE r

r

ε
µ
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Excitations (Continued)

Modes, Reflections, and PropagationModes, Reflections, and PropagationModes, Reflections, and PropagationModes, Reflections, and Propagation

It is also possible for a 3D field solution generated by an excitation signal of one specific 
mode to contain reflections of higher-order modes which arise due to discontinuities in a high 
frequency structure. 

If these higher-order modes are reflected back to the excitation port or transmitted onto 
another port, the S-parameters associated with these modes should be calculated.  

If the higher-order mode decays before reaching any port—either because of attenuation due 
to losses or because it is a non-propagating evanescent mode—there is no need to obtain the 
S-parameters for that mode. 

Wave Ports Require a Length of Uniform Cross SectionWave Ports Require a Length of Uniform Cross SectionWave Ports Require a Length of Uniform Cross SectionWave Ports Require a Length of Uniform Cross Section

Ansoft HFSS assumes that each port you define is connected to a semi-infinitely long 
waveguide that has the same cross section as the Wave Port

no uniform cross section

at Wave Ports

uniform cross section 

added for each Wave Port
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Excitations (Continued)

Wave Port Boundary ConditionsWave Port Boundary ConditionsWave Port Boundary ConditionsWave Port Boundary Conditions

Perfect E or Finite Conductivity

Default: All outer edges are Perfect E boundary.  

Port is defined within a waveguide.  

Easy for enclosed transmission lines: Coax or Waveguide

Challenging for unbalanced or non-enclosed lines: Microstrip, CPW, Slotline, etc.

Symmetry or Impedance 

Recognized at the port edges

Radiation

Default interface is a Perfect E boundary
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Excitations (Continued)

Lumped Port Boundary ConditionsLumped Port Boundary ConditionsLumped Port Boundary ConditionsLumped Port Boundary Conditions

Perfect E or Finite Conductivity

Any port edge that interfaces with a conductor or another port edge

Perfect H

All remaining port edges

Perfect H

Perfect H

Perfect E

Perfect E
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Excitations (Continued)

Excitation Excitation Excitation Excitation –––– CalibrationCalibrationCalibrationCalibration

Ports must be calibrated to ensure consistent results. Determines:

Direction and polarity of fields

Voltage calculations.

Solution Type: Driven Modal

Expressed in terms of the incident and reflected powers of the waveguide modes.  

Definition not desirable for problems having several propagating quasi-TEM modes

Coupled/Multi-Coupled Transmission Lines

Always used by the solver

Calibration: Integration Line

Phase between Ports

Modal voltage integration path: Zpi, Zpv, Zvi

Solution Type: Driven Terminal

Linear combination of nodal voltages and currents for the Wave Port.  

Equivalent transformation performed from Modal Solution

Calibration: Terminal Line

Polarity

Nodal voltage integration path
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Example Solution Types:

T1T1T1T1 T2T2T2T2

Integration LineIntegration LineIntegration LineIntegration Line

Mode 1Mode 1Mode 1Mode 1

(Even Mode)(Even Mode)(Even Mode)(Even Mode)

Integration LineIntegration LineIntegration LineIntegration Line

Mode 2Mode 2Mode 2Mode 2

(Odd Mode)(Odd Mode)(Odd Mode)(Odd Mode)

Modes to NodesModes to NodesModes to NodesModes to Nodes

TransformationTransformationTransformationTransformation

SPICESPICESPICESPICE

Differential PairsDifferential PairsDifferential PairsDifferential Pairs

Modal
Port1Port1Port1Port1 Port2Port2Port2Port2

TerminalPort1Port1Port1Port1 Port2Port2Port2Port2

T1T1T1T1

T2T2T2T2

T1T1T1T1

T2T2T2T2

2 Modes2 Modes2 Modes2 Modes 2 Modes2 Modes2 Modes2 Modes
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Application of Boundary Conditions - Case 1

Emulate laboratory measurements

Verification/Validation before production

Picture courtesy of Delphi 
Picture courtesy of Tektronix
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Application of Boundary Conditions - Case 2

Isolate part of a structure (i.e. Exciting arbitrary transmission lines)

Not physically possible to measure in the laboratory

Full-Wave analysis not required for total system

Or total system too complex

Design work/Component level optimization

Post production problem solving

Isolated Component – Via Transition

Total System
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Example Structure

Coax to Stripline

LAYER 2 (SIGNAL)

LAYER 3 (BOTTOM SIDE)

LAYER 1 (TOP SIDE)
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Material Properties
All 3D (Solid) objects have material definitions

To complete the model shown previously we must include the air

that surrounds the structure. 

airairairair

Note:Note:Note:Note: Substrate/Air boundary Substrate/Air boundary Substrate/Air boundary Substrate/Air boundary 

included in structureincluded in structureincluded in structureincluded in structure
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Remember! Material Boundary conditions are transparent to the user

They are not visible in the Project Tree

Example Material Boundary: Conductors � Surface Approximations 

Perfect Conductors � Perfect E Boundary (Boundary Name: smetal)

Forces E-Field perpendicular to surface

Lossy Conductors � Finite Conductivity Boundary

Forces tangential E-Field to ((1+j)/(δσ))(n x Htan).

Assumes one skin depth – User must manually force Ansoft HFSS to 

solve inside lossy conductors that are ≤ a skin depth

smetalsmetalsmetalsmetal
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Surface Approximations

Background or Outer Boundary

Not visible in the Project Tree

Any object surface that touches it � Perfect E Boundary

Default boundary applied to the region surrounding the geometric model

Model is encased in a thin metal layer that no fields propagate through

Override withOverride withOverride withOverride with

Radiation BoundaryRadiation BoundaryRadiation BoundaryRadiation Boundary

outerouterouterouter
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What Port Type Should I Use?
Example is easy decision

Port touches background (External)

Cross Section is Coax (Enclosed Transmission Line)

Wave Port

Solution Type: Driven Terminal

SPICE Output

Identify Port Type &Identify Port Type &Identify Port Type &Identify Port Type &

Cross SectionCross SectionCross SectionCross Section

Assign Excitation &Assign Excitation &Assign Excitation &Assign Excitation &

Calibrate PortCalibrate PortCalibrate PortCalibrate Port

Define Default Define Default Define Default Define Default 

Post ProcessingPost ProcessingPost ProcessingPost Processing
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Is it Really that Simple?

Yes, but the geometric model was setup with several considerations

1. Only the face of the coax dielectric was selected for the port face

Port Boundary conditions define outer conductor

Material Definitions define inner conductor

2. Uniform port cross-section

Only supports a single mode

Higher-order modes caused by reflections would attenuate before port

Modes attenuate as a function of e-αz, assuming propagation in the z-direction.

Required distance (uniform port length) depends on modes propagation constant.

Uniform crossUniform crossUniform crossUniform cross----sectionsectionsectionsection

Rule of Thumb: 5x Rule of Thumb: 5x Rule of Thumb: 5x Rule of Thumb: 5x 

Critical DistanceCritical DistanceCritical DistanceCritical Distance
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How often is the Setup that Simple?
If you are emulating laboratory measurements? [Case 1 ]

Most of the time!

Laboratory equipment does not directly connect to arbitrary transmission 
lines

Exceptions

Emulating Complex Probes with a Port � Understanding of Probe

If you are isolating part of a structure? [Case 2 ]

For “real” designs - usually only by dumb luck!

User Must Understand and/or Implement Correctly:

1. Port Boundary conditions and impact of boundary condition

2. Fields within the structure

3. Assumptions made by port solver

4. Return path
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Side Note: Problems Associated with Correlating Results [Case 2]

Can be broken into two categories of problems

1. Complex Structure

BGA, Backplane, Antenna Feed, Waveguide “Plumbing”, etc

Most common problems result from

Measurement setup – Test fixtures, deembedding, etc. 

Failing to understand the fields in the structure � Boundary Problem

Return path problems – Model truncation

2. Simple Structures

Uniform transmission lines

Equations or Circuit Elements

Most common problems result from

Improper use of default or excitation boundary conditions

Failure to understand the assumptions used by “correct” results 

(Equations or Circuit Elements)
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Why are they critical?

Any current injected into a system must return to the source

DC

Chooses path of least resistance

AC

Chooses path of least inductance

A signal propagates between the signal trace and its reference plane 

Reference plane is just as important as signal trace!

Why do I care?

Many real designs have nonideal return paths

These effects are only captured by full-wave simulators

Isolating parts of a structure

Failure to maintain the correct return path will

Limit correlation to measurements

Mask or create design problems

Port and Boundary setup is the most common source of error in model setup
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Port1Port1Port1Port1

Port2Port2Port2Port2 Port3Port3Port3Port3

No DCNo DCNo DCNo DC

Return PathReturn PathReturn PathReturn Path
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Port1Port1Port1Port1

Port2Port2Port2Port2 Port3Port3Port3Port3

DCDCDCDC

Return PathReturn PathReturn PathReturn Path
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DC & RFDC & RFDC & RFDC & RF

Return PathReturn PathReturn PathReturn Path

S21S21S21S21

S11S11S11S11

S31S31S31S31
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Isolate part of structure - Case 2 

Isolate Transition

Deembed

Recombine using Ansoft Designer - Circuit

Wave PortWave PortWave PortWave Port
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Ansoft Designer Ansoft Designer Ansoft Designer Ansoft Designer ---- CircuitCircuitCircuitCircuit
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What went wrong?

Isolate Port from Discontinuity?

Yes

Uniform Cross-Section?

NO – The cross section of the port (including its boundaries) is not maintained

Maintain Return Path?

NO – Boundary on port shorts the planes together at edges

Identical to placing vias at port edge!

All Modes Accounted for?

NO – Did not consider Parallel Plate mode

Even if we did, the via (port edge) cuts off mode � Reason vias are used! 
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StriplineStriplineStriplineStripline

ParallelParallelParallelParallel

PlatePlatePlatePlate

Mode Matching

Ansoft Designer Ansoft Designer Ansoft Designer Ansoft Designer ---- CircuitCircuitCircuitCircuit

Wave PortWave PortWave PortWave Port

2 Terminals2 Terminals2 Terminals2 Terminals
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No DCNo DCNo DCNo DC
Return PathReturn PathReturn PathReturn Path

Port InfluencesPort InfluencesPort InfluencesPort Influences
ResultsResultsResultsResults

Lumped PortLumped PortLumped PortLumped Port
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TOP

T1T2

T3

Power

GND

BOTTOM

G

P

SIDE

Power

GND
Signal

Lumped Gap Port

Terminal Line
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Lumped Gap Port



Ansoft High Frequency Structure Simulator v10 – Training Seminar P2-38

Boundary/Excitations - Overview
Presentation

2

Differential Lumped Gap PortsDifferential Lumped Gap PortsDifferential Lumped Gap PortsDifferential Lumped Gap Ports
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G S G

Port
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w

h

6h to 
10h

10w, w ≥ h
or

5w (3h to 4h), w < h

Microstrip Port Sizing Guidelines

Assume width of microstrip trace is w

Assume height of substrate dielectric is h

Port Height Guidelines

Between 6h and 10h

Tend towards upper limit as dielectric constant drops and more fields exist in air rather than substrate

Bottom edge of port coplanar with the upper face of ground plane

(If real structure is enclosed lower than this guideline, model the real structure!)

Port Width Guidelines

10w, for microstrip profiles with w ≥ h

5w, or on the order of 3h to 4h, for microstrip profiles with w < h
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Stripline Port Sizing Guidelines

Assume width of stripline trace is w

Assume height of substrate dielectric is h

Port Height Guidelines

Extend from upper to lower groundplane, h

Port Width Guidelines

8w, for microstrip profiles with w ≥ h

5w, or on the order of 3h to 4h, for microstrip profiles with w < h

Boundary Note:  Can also make side walls of port Perfect H boundaries

w

h

8w, w ≥ h
or

5w (3h to 4h), w < h
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